Debian Bug report logs - #644447
Please update poppler to new released 0.18

version graph

Package: poppler; Maintainer for poppler is Loic Minier <lool@dooz.org>;

Reported by: YunQiang Su <wzssyqa@gmail.com>

Date: Thu, 6 Oct 2011 01:33:01 UTC

Severity: wishlist

Found in versions 0.16.7-2, pdftoipe/20091014-3, gambas2/2.23.1-1, 0.0.2-1, python-poppler/0.12.1-4, gimp/2.6.11-5, apvlv/0.1.1-1.1, pdf-presenter-console/2.0-6, webkit2pdf/0.2-2

Fixed in version poppler/0.18.3-1

Done: Pino Toscano <pino@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 06 Oct 2011 01:33:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to YunQiang Su <wzssyqa@gmail.com>:
New Bug report received and forwarded. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 06 Oct 2011 01:33:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: YunQiang Su <wzssyqa@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Please update poppler to new released 0.18
Date: Thu, 6 Oct 2011 09:29:29 +0800
Package: poppler
Version: 0.16.7-2

The version 0.18.0 of poppler has been released, and fix lots of bugs

Please update to 0.18.0 in sid

-- 
YunQiang Su




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 06 Oct 2011 11:36:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Marc J. Driftmeyer" <mjd@reanimality.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 06 Oct 2011 11:36:06 GMT) Full text and rfc822 format available.

Message #10 received at 644447@bugs.debian.org (full text, mbox):

From: "Marc J. Driftmeyer" <mjd@reanimality.com>
To: Debian Bug Tracking System <644447@bugs.debian.org>
Subject: poppler: Scribus and other Poppler leveled apps cannot build with support until 0.18 is packaged
Date: Thu, 06 Oct 2011 04:33:49 -0700
Package: poppler
Followup-For: Bug #644447

Dear Maintainer,

I'm here to second the request to get Poppler packaged sooner rather than later. I follow the Dev List as a subscriber and l considerable amount of change has gone into the 0.18 branch and soon a point release is on it's way.

For now, building Scribus Trunk disables Poppler Support. More recent versions of Evince and Okular will be dependent upon the 0.18 and the upcoming 0.20 branch now the developer branch for Poppler.

I can only second the sooner, rather than later for allowing Debian to build GNOME 3.2 packages against, not to mention KDE 4.7.2 packages.

- Marc J. Driftmeyer

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Sat, 15 Oct 2011 10:27:27 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pino Toscano <pino@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sat, 15 Oct 2011 10:27:31 GMT) Full text and rfc822 format available.

Message #15 received at 644447@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: 644447@bugs.debian.org
Cc: YunQiang Su <wzssyqa@gmail.com>, "Marc J. Driftmeyer" <mjd@reanimality.com>
Subject: Re: Please update poppler to new released 0.18
Date: Sat, 15 Oct 2011 12:26:03 +0200
[Message part 1 (text/plain, inline)]
Hi,

> Please update to 0.18.0 in sid

> I'm here to second the request to get Poppler packaged sooner rather
> than later.

Poppler 0.18 also causes the usual API/ABI breakage in the private core 
library, plus some API loss in poppler-glib causes more problems too.

At the moment there are about a dozen or so sources in Debian which will 
*not* build at all with poppler 0.18, which means you won't see it in 
unstable soon. Maybe in a couple of months, but not before all the 
issues (which have been mostly reported) are solved.

> For now, building Scribus Trunk disables Poppler Support.

Any pointer about this?

> More recent
> versions of Evince and Okular will be dependent upon the 0.18 and
> the upcoming 0.20 branch now the developer branch for Poppler.
> 
> I can only second the sooner, rather than later for allowing Debian
> to build GNOME 3.2 packages against, not to mention KDE 4.7.2
> packages.

Evince of GNOME 3.2 and Okular of KDE 4.7 compile fine with poppler 
0.16. (Not to consider that Okular can compile and work with any 
poppler-qt4 version >= 0.8.)

-- 
Pino Toscano
[signature.asc (application/pgp-signature, inline)]

Severity set to 'wishlist' from 'normal' Request was from Pino Toscano <pino@debian.org> to control@bugs.debian.org. (Sat, 15 Oct 2011 10:48:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Sat, 15 Oct 2011 13:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Marc J. Driftmeyer" <mjd@reanimality.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sat, 15 Oct 2011 13:27:03 GMT) Full text and rfc822 format available.

Message #22 received at 644447@bugs.debian.org (full text, mbox):

From: "Marc J. Driftmeyer" <mjd@reanimality.com>
To: Pino Toscano <pino@debian.org>
Cc: 644447@bugs.debian.org, YunQiang Su <wzssyqa@gmail.com>
Subject: Re: Please update poppler to new released 0.18
Date: Sat, 15 Oct 2011 06:25:01 -0700
[Message part 1 (text/plain, inline)]

On 10/15/2011 03:26 AM, Pino Toscano wrote:
> Hi,
>
>> Please update to 0.18.0 in sid
>> I'm here to second the request to get Poppler packaged sooner rather
>> than later.
> Poppler 0.18 also causes the usual API/ABI breakage in the private core
> library, plus some API loss in poppler-glib causes more problems too.
>
> At the moment there are about a dozen or so sources in Debian which will
> *not* build at all with poppler 0.18, which means you won't see it in
> unstable soon. Maybe in a couple of months, but not before all the
> issues (which have been mostly reported) are solved.
>
>> For now, building Scribus Trunk disables Poppler Support.


> Any pointer about this?

mdriftmeyer@horus:~/DeveloperProjects/QtProjects/Scribus/cmake-trunk$ 
cmake ../trunk/
-- Shared Library Flags:
-- Scribus 1.5.0.svn will be built to install into /usr/local
-- Machine: x86_64-linux-gnu, void pointer size: 8
-- Found target X86
-- Found target X86_64
-- Building for target x86_64-linux-gnu
-- Using standard ApplicationDataDir. You can change it with 
-DAPPLICATION_DATA_DIR
Qt4 Found OK
-- QtWebkit Found OK
-- Building without Qt3 Support (GOOD)
ZLIB Library Found OK
Using PNG Library: /usr/lib/libpng.so
PNG Library Found OK
OSG found OK
JPEG Library Found OK
TIFF Library Found OK
Python Library Found OK
-- FreeType2 Library Found OK
-- Previously selected rendering system: CAIRO
-- Found Cups: /usr/lib/x86_64-linux-gnu/libcups.so
CUPS Library Found OK
LIBXML2 Library Found OK
LCMS ReleaseLibrary: /usr/lib/liblcms.so
LCMS Debug Library: LCMS_LIBRARY_DEBUG-NOTFOUND
LCMS Library: /usr/lib/liblcms.so
LCMS 2 ReleaseLibrary: /usr/lib/liblcms2.so
LCMS 2 Debug Library: LCMS2_LIBRARY_DEBUG-NOTFOUND
LCMS 2 Library: /usr/lib/liblcms2.so
LittleCMS-2 Library Found OK
FontConfig Found OK
ASpell Found OK
PoDoFo found OK
Boost Library Found OK
GRAPHICS_MAGIC debug: pkgconf: /usr/include/GraphicsMagick, 
include:/usr/include/ImageMagick;/usr/include/Imagemagick/magick 
lib:/usr/lib/libGraphicsMagick.so
GraphicksMagick Found OK
*-- checking for one of the modules 'libpoppler>=0.17.1;poppler>=0.17.1'
Poppler NOT found - Disabling support for native PDF import*
-- GMAGICK: Libs: /usr/lib/libGraphicsMagick.so, Inc: 
/usr/include/ImageMagick;/usr/include/Imagemagick/magick/GraphicsMagick, 
Ldflags:
RPATH: lib/scribus/plugins/;
-- 
/usr/lib/libQtCore.so/usr/lib/libQtGui.so/usr/lib/libQtXml.so/usr/lib/libxml2.so/usr/lib/libz.so
-- Building with Scripter 1
-- Source header files will be installed
-- 
/home/mdriftmeyer/DeveloperProjects/QtProjects/Scribus/trunk/resources/translations/po
-- The following GUI languages will be installed:
-- Configuring done
-- Generating done
-- Build files have been written to: 
/home/mdriftmeyer/DeveloperProjects/QtProjects/Scribus/cmake-trunk
mdriftmeyer@horus:~/DeveloperProjects/QtProjects/Scribus/cmake-trunk$

So you can see trunk is building against a beta of poppler. I've been 
following the poppler dev lists so I'm aware of all the abi issues and 
that they are working on landing an 0.18.1 release.

>> More recent
>> versions of Evince and Okular will be dependent upon the 0.18 and
>> the upcoming 0.20 branch now the developer branch for Poppler.
>>
>> I can only second the sooner, rather than later for allowing Debian
>> to build GNOME 3.2 packages against, not to mention KDE 4.7.2
>> packages.
> Evince of GNOME 3.2 and Okular of KDE 4.7 compile fine with poppler
> 0.16. (Not to consider that Okular can compile and work with any
> poppler-qt4 version>= 0.8.)
>

From what I've been following Poppler's version for Okular is not 
standard libpoppler.

http://lists.freedesktop.org/archives/poppler/2011-October/008094.html

A lot of xpdf303 is being ported over to Poppler trunk, as well.

- Marc
-- 
Marc J. Driftmeyer
Email :: mjd@reanimality.com <mailto:mjd@reanimality.com>
Web :: http://www.reanimality.com
Cell :: (509) 435-5212
[Message part 2 (text/html, inline)]
[mjd.vcf (text/x-vcard, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Sat, 15 Oct 2011 13:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pino Toscano <pino@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sat, 15 Oct 2011 13:45:04 GMT) Full text and rfc822 format available.

Message #27 received at 644447@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: "Marc J. Driftmeyer" <mjd@reanimality.com>
Cc: 644447@bugs.debian.org
Subject: Re: Please update poppler to new released 0.18
Date: Sat, 15 Oct 2011 15:41:52 +0200
[Message part 1 (text/plain, inline)]
Alle sabato 15 ottobre 2011, Marc J. Driftmeyer ha scritto:
> On 10/15/2011 03:26 AM, Pino Toscano wrote:
> > Any pointer about this?
> 
> mdriftmeyer@horus:~/DeveloperProjects/QtProjects/Scribus/cmake-trunk$
> cmake ../trunk/
> [...]
> *-- checking for one of the modules
> 'libpoppler>=0.17.1;poppler>=0.17.1' Poppler NOT found - Disabling
> support for native PDF import*

Nothing bad about it, just a development version requiring the newer 
Poppler. As long as the stable scribus has no such dependency, I don's 
see an immediate issue.

>  From what I've been following Poppler's version for Okular is not
> standard libpoppler.

?!?
Okular for KDE 4 (i.e. any version >= 0.5.80) has always used an 
external poppler-qt4.

> http://lists.freedesktop.org/archives/poppler/2011-October/008094.htm
> l

This emails shows three commits:
- an apidox change, given okular migrated from svn to git
- a cmake build system fix (adding a missing include directory)
- a typo in the cmake build system

I _know_ poppler 0.18 is an improvement over 0.16 (I'm a poppler 
developer since few years), but really, it cannot go to Debian unstable 
right now, nor for at least one or two months.

-- 
Pino Toscano
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Sun, 16 Oct 2011 02:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Marc Driftmeyer <mjd@reanimality.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sun, 16 Oct 2011 02:54:03 GMT) Full text and rfc822 format available.

Message #32 received at 644447@bugs.debian.org (full text, mbox):

From: Marc Driftmeyer <mjd@reanimality.com>
To: Pino Toscano <pino@debian.org>
Cc: "644447@bugs.debian.org" <644447@bugs.debian.org>
Subject: Re: Please update poppler to new released 0.18
Date: Sat, 15 Oct 2011 19:46:03 -0700
This request was about building against trunk. Do I need to add that Inkscape is soon moving to a newer branch, along with Cairo? I didn't know we were discussing Debian stable?

- Marc

Sent from my iPad

On Oct 15, 2011, at 6:41 AM, Pino Toscano <pino@debian.org> wrote:

> Alle sabato 15 ottobre 2011, Marc J. Driftmeyer ha scritto:
>> On 10/15/2011 03:26 AM, Pino Toscano wrote:
>>> Any pointer about this?
>> 
>> mdriftmeyer@horus:~/DeveloperProjects/QtProjects/Scribus/cmake-trunk$
>> cmake ../trunk/
>> [...]
>> *-- checking for one of the modules
>> 'libpoppler>=0.17.1;poppler>=0.17.1' Poppler NOT found - Disabling
>> support for native PDF import*
> 
> Nothing bad about it, just a development version requiring the newer 
> Poppler. As long as the stable scribus has no such dependency, I don's 
> see an immediate issue.
> 
>> From what I've been following Poppler's version for Okular is not
>> standard libpoppler.
> 
> ?!?
> Okular for KDE 4 (i.e. any version >= 0.5.80) has always used an 
> external poppler-qt4.
> 
>> http://lists.freedesktop.org/archives/poppler/2011-October/008094.htm
>> l
> 
> This emails shows three commits:
> - an apidox change, given okular migrated from svn to git
> - a cmake build system fix (adding a missing include directory)
> - a typo in the cmake build system
> 
> I _know_ poppler 0.18 is an improvement over 0.16 (I'm a poppler 
> developer since few years), but really, it cannot go to Debian unstable 
> right now, nor for at least one or two months.
> 
> -- 
> Pino Toscano




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Sun, 16 Oct 2011 08:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pino Toscano <pino@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sun, 16 Oct 2011 08:12:03 GMT) Full text and rfc822 format available.

Message #37 received at 644447@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: Marc Driftmeyer <mjd@reanimality.com>
Cc: "644447@bugs.debian.org" <644447@bugs.debian.org>
Subject: Re: Please update poppler to new released 0.18
Date: Sun, 16 Oct 2011 10:09:13 +0200
[Message part 1 (text/plain, inline)]
Alle domenica 16 ottobre 2011, Marc Driftmeyer ha scritto:
> I didn't know we were discussing Debian stable?

No, we're discussing how introducing poppler 0.18 in Debian unstable 
*right now* would break a dozen of other sources, including cups, gimp, 
evince.

I understood you need poppler 0.18 for something, but you should please 
also understand poppler 0.18 at the moment is *not* feasible for Debian 
unstable (which does not mean "can be broken at will").

-- 
Pino Toscano
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Tue, 18 Oct 2011 02:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Marc J. Driftmeyer" <mjd@reanimality.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Tue, 18 Oct 2011 02:54:03 GMT) Full text and rfc822 format available.

Message #42 received at 644447@bugs.debian.org (full text, mbox):

From: "Marc J. Driftmeyer" <mjd@reanimality.com>
To: Pino Toscano <pino@debian.org>
Cc: "644447@bugs.debian.org" <644447@bugs.debian.org>
Subject: Re: Please update poppler to new released 0.18
Date: Mon, 17 Oct 2011 19:52:18 -0700
[Message part 1 (text/plain, inline)]
I'm well aware it will break packages. I'm also well aware that GNOME 
3.2 has broken my installation inside Debian, but you guys hide behind 
(Experimental) when it's convenient and behind Stable as a last resort 
when you declare Sid to be (Unstable) and thus one should use Stable.

I'm more interested in bringing attention to the dependent library that 
so many growing packages rely on and that one should rebuild those apps 
against a more stable solution poppler 0.18.x branch than the prior 
stable branch.

I'm not holding a gun to anyone's head, just pointing out that 4 weeks 
most likely or more will have passed before you get around to updating.

But since you pointed out Evince it relies upon a custom version so as 
not to be held back and that seems to me, like Okular, counter-intuitive 
to the concept of shared libraries.

I'm not going to die if poppler isn't current. I'll just wait and when 
it's out rebuild Scribus to test and file more bugs against.

No harm, no foul.

- Marc

On 10/16/2011 01:09 AM, Pino Toscano wrote:
> Alle domenica 16 ottobre 2011, Marc Driftmeyer ha scritto:
>> I didn't know we were discussing Debian stable?
> No, we're discussing how introducing poppler 0.18 in Debian unstable
> *right now* would break a dozen of other sources, including cups, gimp,
> evince.
>
> I understood you need poppler 0.18 for something, but you should please
> also understand poppler 0.18 at the moment is *not* feasible for Debian
> unstable (which does not mean "can be broken at will").
>

-- 
Marc J. Driftmeyer
Email :: mjd@reanimality.com <mailto:mjd@reanimality.com>
Web :: http://www.reanimality.com
Cell :: (509) 435-5212
[Message part 2 (text/html, inline)]
[mjd.vcf (text/x-vcard, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Tue, 18 Oct 2011 08:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pino Toscano <pino@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Tue, 18 Oct 2011 08:15:03 GMT) Full text and rfc822 format available.

Message #47 received at 644447@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: "Marc J. Driftmeyer" <mjd@reanimality.com>
Cc: "644447@bugs.debian.org" <644447@bugs.debian.org>
Subject: Re: Please update poppler to new released 0.18
Date: Tue, 18 Oct 2011 10:11:37 +0200
[Message part 1 (text/plain, inline)]
Alle martedì 18 ottobre 2011, Marc J. Driftmeyer ha scritto:
> I'm well aware it will break packages. I'm also well aware that GNOME
> 3.2 has broken my installation inside Debian, but you guys hide
> behind (Experimental) when it's convenient and behind Stable as a
> last resort when you declare Sid to be (Unstable) and thus one
> should use Stable.

a) I'm not involved in GNOME packaging at all
b) I'm not hiding behind anything, I just explained to you why poppler 
0.18 is not fit for unstable, at the moment. maybe experimental will 
come, but I've not gotten around it, yet.

> But since you pointed out Evince it relies upon a custom version so
> as not to be held back and that seems to me, like Okular,
> counter-intuitive to the concept of shared libraries.

I said that the current versions of Evince and Okular in Debian and 
their very latest versions are both fine to use and work with poppler 
0.16.

-- 
Pino Toscano
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Tue, 06 Dec 2011 09:30:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Tue, 06 Dec 2011 09:30:17 GMT) Full text and rfc822 format available.

Message #52 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Tue, 6 Dec 2011 10:26:15 +0100
[Message part 1 (text/plain, inline)]
Package: pdftoipe
Version: 20091014-3
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Ubuntu once 0.18 lands there.

pdftoipe does not have a patch system and is not 3.0 (quilt) yet. I
suppose if you apply this you actually want to use a broken-out patch,
but that's the discretion of you as the package maintainer of course.

Thanks for considering,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[pdftoipe.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Wed, 07 Dec 2011 13:03:20 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastien Bacher <seb128@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Wed, 07 Dec 2011 13:03:22 GMT) Full text and rfc822 format available.

Message #57 received at 644447@bugs.debian.org (full text, mbox):

From: Sebastien Bacher <seb128@ubuntu.com>
To: 644447@bugs.debian.org
Subject: debdiff for the update
Date: Wed, 07 Dec 2011 13:34:08 +0100
[Message part 1 (text/plain, inline)]
Hi,

We did the update in Ubuntu, there is a debdiff for the update adapted 
to Debian.
Martin Pitt is also fixing most of the rdepends and will send patches to 
the Debian BTS Cc-ing that bug while he's doing so.

Cheers,
Sebastien Bacher
[poppler.debdiff (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 08 Dec 2011 09:52:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 08 Dec 2011 09:52:13 GMT) Full text and rfc822 format available.

Message #62 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Tue, 6 Dec 2011 11:45:40 +0100
[Message part 1 (text/plain, inline)]
Package: gambas2
Version: 2.23.1-1
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there.

Debdiff attached.

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[gambas2.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 08 Dec 2011 09:52:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 08 Dec 2011 09:52:22 GMT) Full text and rfc822 format available.

Message #67 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Wed, 7 Dec 2011 08:05:33 +0100
[Message part 1 (text/plain, inline)]
Package: poppler-sharp
Version: 0.0.2-1
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there.

Debdiff attached. I also sent the patch to upstream at
https://github.com/jacintos/poppler-sharp/issues/5

Thanks,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[poppler-sharp.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 08 Dec 2011 09:52:26 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 08 Dec 2011 09:52:29 GMT) Full text and rfc822 format available.

Message #72 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Tue, 6 Dec 2011 13:07:00 +0100
[Message part 1 (text/plain, inline)]
Package: python-poppler
Version: 0.12.1-4
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there.

Debdiff attached. I also sent the patch to upstream at
https://launchpad.net/bugs/900707.

Thanks,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[python-poppler.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Thu, 08 Dec 2011 09:52:42 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Thu, 08 Dec 2011 09:52:43 GMT) Full text and rfc822 format available.

Message #77 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Tue, 6 Dec 2011 11:18:11 +0100
[Message part 1 (text/plain, inline)]
Package: gimp
Version: 2.6.11-5
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there.

For GIMP's PDF plugin, Fedora already did the porting. I stole their
patch and confirmed that it works fine against our current GIMP
package. debdiff attached.

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[gimp.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Mon, 12 Dec 2011 16:03:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Mon, 12 Dec 2011 16:03:52 GMT) Full text and rfc822 format available.

Message #82 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Mon, 12 Dec 2011 17:00:46 +0100
[Message part 1 (text/plain, inline)]
Package: apvlv
Version: 0.1.1-1.1
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Ubuntu once 0.18 lands there. But this
patch works with poppler 0.16 just as well.

This is taken from upstream git head:

  https://github.com/naihe2010/apvlv/commit/e5aec2fd102a0f041dc53f4aa8040ab89043e05d

apvlv does not have a patch system and is not 3.0 (quilt) yet, so I
applied it inline just as the existing code change.

Thanks for considering,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[apvlv.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Mon, 12 Dec 2011 16:09:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Mon, 12 Dec 2011 16:09:07 GMT) Full text and rfc822 format available.

Message #87 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Mon, 12 Dec 2011 17:05:20 +0100
[Message part 1 (text/plain, inline)]
Package: pdf-presenter-console
Version: 2.0-6
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there. But this
patch works with poppler 0.16 just as well, so it's fine to apply to
Debian now.

This was reported upstream at

  https://github.com/jakobwesthoff/Pdf-Presenter-Console/issues/35

and fixed in a branch:

  https://github.com/davvil/Pdf-Presenter-Console/commit/8f9a742f725a7dcd46a22377572993f775152e29

Thanks for considering,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[pdf-presenter-console_poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Mon, 12 Dec 2011 16:51:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Mon, 12 Dec 2011 16:51:08 GMT) Full text and rfc822 format available.

Message #92 received at 644447@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Debian BTS Submit <submit@bugs.debian.org>
Cc: 644447@bugs.debian.org
Subject: Patch for porting to poppler 0.18
Date: Mon, 12 Dec 2011 17:47:53 +0100
[Message part 1 (text/plain, inline)]
Package: webkit2pdf
Version: 0.2-2
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch precise

Hello,

In http://bugs.debian.org/644447 there is some discussion about
updating poppler to 0.18 in Debian. This will cause some FTBFS. We are
doing the transition in Ubuntu now and want to forward patches so that
they are readily available in Debian once 0.18 lands there. But this
patch works with poppler 0.16 just as well, so it's fine to apply to
Debian now.

This was reported upstream at

  https://sourceforge.net/tracker/?func=detail&aid=3306044&group_id=264450&atid=1127720

I sent the patch there as well.

Thanks for considering,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
[webkit2pdf.poppler-0.18.debdiff (text/plain, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#644447; Package poppler. (Tue, 24 Jan 2012 18:42:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to shirish शिरीष <shirishag75@gmail.com>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Tue, 24 Jan 2012 18:42:03 GMT) Full text and rfc822 format available.

Message #97 received at 644447@bugs.debian.org (full text, mbox):

From: shirish शिरीष <shirishag75@gmail.com>
To: 644447@bugs.debian.org
Subject: an updated 0.18.3 got released few days ago
Date: Wed, 25 Jan 2012 00:09:42 +0530
Hi all,
I have been following the discussion for a while and also wanted to
see the latest version in unstable . Just a heads up, 0.18.3 got
released just a few days ago :-

The 0.18 branch is the stable release series. The latest such release
is poppler-0.18.3.tar.gz, released on January 15, 2012:

        core:
         * Do not fail if we are trying to save a file with Encrypt
that has not been modified. KDE Bug #288045
         * Include .otf fonts when finding substitute fonts. Bug #44412
         * Fix stack overflow in PDFDoc::markObject(). Bug #44660
         * Include strings.h as we use memcpy. Bug #43558

        utils:
         * pdfunite: Properly initialize globalParams. Bug #44659
         * pdfseparate: Properly initialize globalParams
         * Fix iniliazialization of GooString arguments

        build system:
         * autoconf: Check for cairo-ft and other cairo backends. Bug #43969

As always one can find poppler releases at
http://poppler.freedesktop.org/releases.html which has changelog with
every release as well.
-- 
          Regards,
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17




Added tag(s) pending. Request was from Pino Toscano <pino@debian.org> to control@bugs.debian.org. (Sun, 12 Feb 2012 11:12:20 GMT) Full text and rfc822 format available.

Message sent on to YunQiang Su <wzssyqa@gmail.com>:
Bug#644447. (Sun, 12 Feb 2012 11:12:39 GMT) Full text and rfc822 format available.

Message #102 received at 644447-submitter@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: 644447-submitter@bugs.debian.org
Subject: Bug#644447 marked as pending
Date: Sun, 12 Feb 2012 11:08:52 +0000
tag 644447 pending
thanks

Hello,

Bug #644447 reported by you has been fixed in the Git repository. You can
see the changelog below, and you can check the diff of the fix at:

    http://git.debian.org/?p=pkg-freedesktop/poppler.git;a=commitdiff;h=9217ed3

---
commit 9217ed3248b2999bc533da0f0fe62fca7a7c4609
Author: Pino Toscano <pino@debian.org>
Date:   Sun Feb 12 12:07:23 2012 +0100

    note the new release fixes #644447, #443547, #524323

diff --git a/debian/changelog b/debian/changelog
index 92c55a1..77ded47 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
 poppler (0.18.3-0r1) UNRELEASED; urgency=low
 
-  * New upstream release.
+  * New upstream release: (Closes: #644447)
+    - fixes rendering of Porirua City overview map. (Closes: #443547)
+    - shows the names of unknown fonts. (Closes: #524323)
   * Rename packages according to the new SONAMEs:
     - libpoppler13 -> libpoppler19
     - libpoppler-glib6 -> libpoppler-glib8




Reply sent to Pino Toscano <pino@debian.org>:
You have taken responsibility. (Thu, 16 Feb 2012 19:51:20 GMT) Full text and rfc822 format available.

Notification sent to YunQiang Su <wzssyqa@gmail.com>:
Bug acknowledged by developer. (Thu, 16 Feb 2012 19:51:21 GMT) Full text and rfc822 format available.

Message #107 received at 644447-close@bugs.debian.org (full text, mbox):

From: Pino Toscano <pino@debian.org>
To: 644447-close@bugs.debian.org
Subject: Bug#644447: fixed in poppler 0.18.3-1
Date: Thu, 16 Feb 2012 19:49:03 +0000
Source: poppler
Source-Version: 0.18.3-1

We believe that the bug you reported is fixed in the latest version of
poppler, which is due to be installed in the Debian FTP archive:

gir1.2-poppler-0.18_0.18.3-1_amd64.deb
  to main/p/poppler/gir1.2-poppler-0.18_0.18.3-1_amd64.deb
libpoppler-cpp-dev_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-cpp-dev_0.18.3-1_amd64.deb
libpoppler-cpp0_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-cpp0_0.18.3-1_amd64.deb
libpoppler-dev_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-dev_0.18.3-1_amd64.deb
libpoppler-glib-dev_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-glib-dev_0.18.3-1_amd64.deb
libpoppler-glib8_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-glib8_0.18.3-1_amd64.deb
libpoppler-private-dev_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-private-dev_0.18.3-1_amd64.deb
libpoppler-qt4-3_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-qt4-3_0.18.3-1_amd64.deb
libpoppler-qt4-dev_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler-qt4-dev_0.18.3-1_amd64.deb
libpoppler19_0.18.3-1_amd64.deb
  to main/p/poppler/libpoppler19_0.18.3-1_amd64.deb
poppler-dbg_0.18.3-1_amd64.deb
  to main/p/poppler/poppler-dbg_0.18.3-1_amd64.deb
poppler-utils_0.18.3-1_amd64.deb
  to main/p/poppler/poppler-utils_0.18.3-1_amd64.deb
poppler_0.18.3-1.debian.tar.gz
  to main/p/poppler/poppler_0.18.3-1.debian.tar.gz
poppler_0.18.3-1.dsc
  to main/p/poppler/poppler_0.18.3-1.dsc
poppler_0.18.3.orig.tar.gz
  to main/p/poppler/poppler_0.18.3.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 644447@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Pino Toscano <pino@debian.org> (supplier of updated poppler package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 12 Feb 2012 22:49:35 +0100
Source: poppler
Binary: libpoppler19 libpoppler-dev libpoppler-private-dev libpoppler-glib8 libpoppler-glib-dev gir1.2-poppler-0.18 libpoppler-qt4-3 libpoppler-qt4-dev libpoppler-cpp0 libpoppler-cpp-dev poppler-utils poppler-dbg
Architecture: source amd64
Version: 0.18.3-1
Distribution: experimental
Urgency: low
Maintainer: Loic Minier <lool@dooz.org>
Changed-By: Pino Toscano <pino@debian.org>
Description: 
 gir1.2-poppler-0.18 - GObject introspection data for poppler-glib
 libpoppler-cpp-dev - PDF rendering library -- development files (CPP interface)
 libpoppler-cpp0 - PDF rendering library (CPP shared library)
 libpoppler-dev - PDF rendering library -- development files
 libpoppler-glib-dev - PDF rendering library -- development files (GLib interface)
 libpoppler-glib8 - PDF rendering library (GLib-based shared library)
 libpoppler-private-dev - PDF rendering library -- private development files
 libpoppler-qt4-3 - PDF rendering library (Qt 4 based shared library)
 libpoppler-qt4-dev - PDF rendering library -- development files (Qt 4 interface)
 libpoppler19 - PDF rendering library
 poppler-dbg - PDF rendering library -- debugging symbols
 poppler-utils - PDF utilities (based on Poppler)
Closes: 443547 524323 617604 644447 646688 651968
Changes: 
 poppler (0.18.3-1) experimental; urgency=low
 .
   * New upstream release: (Closes: #644447)
     - fixes rendering of Porirua City overview map. (Closes: #443547)
     - shows the names of unknown fonts. (Closes: #524323)
   * Rename packages according to the new SONAMEs:
     - libpoppler13 -> libpoppler19
     - libpoppler-glib6 -> libpoppler-glib8
   * Bump shlibs for libpoppler-glib8 and libpoppler-qt4-3.
   * debian/patches:
     - ltmain-as-needed.diff: refresh
   * Update copyright.
   * Update configure arguments:
     - Remove: --disable-poppler-qt, --disable-abiword-output
   * Drop test-poppler-glib from libpoppler-glib-dev, as it does not exist
     anymore.
   * Update build dependencies, dependencies and suggests:
     - Switch liblcms-dev to liblcms1-dev, to make it explicit lcms 1 is used.
     - Add libtiff-dev (for TIFF support).
     - Remove the gnome-pkg-tools B-D, unused.
     - libpoppler-dev: remove libfontconfig1-dev.
     - libpoppler-private-dev: suggest packages containing headers included in
       barely used private poppler core headers: libfreetype6-dev,
       libopenjpeg-dev, libpng-dev, libtiff-dev. (Closes: #646688)
     - libpoppler-glib-dev: remove libgtk2.0-dev.
   * Enable the GObject introspection support (Closes: #617604):
     - Add libgirepository1.0-dev and gobject-introspection build dependencies.
     - Add a new package gir1.2-poppler-0.18, and make libpoppler-glib-dev
       depend on it.
     - Enable the introspection in configure arguments.
   * Improve description of poppler-utils, also including the new tools
     (pdfseparate, pdftocairo, pdfunite).
   * Convert convert to the `dh' sequencer:
     - Drop cdbs build dependency.
     - Bump debhelper build dependency to 7.0.50.
     - Make use of the gir dh addon.
     - Enable parallel build support.
   * Remove ${shlibs:Depends} from poppler-dbg.
   * Install the upstream ChangeLog only in the libpopplerN package.
   * Convert to multi-arch:
     - Bump debhelper build dependency to 8.9.0.
     - Bump compat to 9.
     - Add dpkg build dependency to 1.16.1.
     - libpoppler19, libpoppler-glib8, libpoppler-qt4-3, libpoppler-cpp0:
       mark "Multi-Arch: same", and add Pre-Depends.
     - poppler-utils: mark "Multi-Arch: foreign".
     - Fix (using wildcard) library paths in .install files, taking care of
       installing the gir .typelib file in a non-multi-arch path.
   * Use DEB_LDFLAGS_MAINT_APPEND in rules to properly append custom LDFLAGS.
     (Closes: #651968)
   * Make the build verbose (V=1).
Checksums-Sha1: 
 ee7ef2cb22f97cb71cdb745493670439fd6fa58e 2345 poppler_0.18.3-1.dsc
 a57fbf63e0a4b611931caf8e47f1f96714acce8c 1985256 poppler_0.18.3.orig.tar.gz
 2f4c09d1021dffa476a3f41054256f233b03c342 16437 poppler_0.18.3-1.debian.tar.gz
 5caf1f959602f3b8a18100880f8d49acba705f2a 1095822 libpoppler19_0.18.3-1_amd64.deb
 ef311637e20882fdbcf01cecd7bb83f1a23c6f6e 1089154 libpoppler-dev_0.18.3-1_amd64.deb
 5043e0e63e0f812ae45871315e597da67ae62f87 14900 libpoppler-private-dev_0.18.3-1_amd64.deb
 f6e70ed83295c0c7115335c571e07642fc2938f6 104478 libpoppler-glib8_0.18.3-1_amd64.deb
 16a6d052a8fbed2b675963eca235f4be47b2a55a 227888 libpoppler-glib-dev_0.18.3-1_amd64.deb
 f4c98b18cceae124799085bc20bb7beb5f5a5754 27242 gir1.2-poppler-0.18_0.18.3-1_amd64.deb
 fdb1fc502eb7ab3be1557d088c862b4a2bac8426 144998 libpoppler-qt4-3_0.18.3-1_amd64.deb
 22a5913005ef53094048ef74821de72dba23dca8 194396 libpoppler-qt4-dev_0.18.3-1_amd64.deb
 3e7baa6ecc7007f6d5640e658874189442128ebe 46822 libpoppler-cpp0_0.18.3-1_amd64.deb
 df3cbe56f6451a1f690a9d454e58eb362cd08deb 54240 libpoppler-cpp-dev_0.18.3-1_amd64.deb
 50a37fb66f53d47b7912a258dfc113121bad539a 153592 poppler-utils_0.18.3-1_amd64.deb
 0805250f0381642c0f616fa2109b79ed9bb5ca0b 4599558 poppler-dbg_0.18.3-1_amd64.deb
Checksums-Sha256: 
 c06fa7b37af0a83d6ae615b86b0287c586295efeb62672bee4aa59642c97b4f5 2345 poppler_0.18.3-1.dsc
 d9019c403a36ee029bd90fee94a0793e63917646d7253ce24637de5194133462 1985256 poppler_0.18.3.orig.tar.gz
 c12f339dfe4736e25e3da28374851aa54e14a95876a8c01c2dbfe1a149fdc065 16437 poppler_0.18.3-1.debian.tar.gz
 760145cfb3c47725d0fe6f925983782bceda6043aecc09a4de3067bdf7ef769e 1095822 libpoppler19_0.18.3-1_amd64.deb
 47b090f489d274bd1cb3a5510992c754baadfd11a682aded266708c40bbe7f58 1089154 libpoppler-dev_0.18.3-1_amd64.deb
 0de7f5bc79531a9ac207e990bad5e3c174de01230b702a7aa1fae619b574ddd0 14900 libpoppler-private-dev_0.18.3-1_amd64.deb
 954f962582fc7e230b014aada27f0703274dea03436033036d7c73d2a328b810 104478 libpoppler-glib8_0.18.3-1_amd64.deb
 87f1f3b95b036126dad1bec0bb36a249d9c4a18dee4d3cf1caf7e4ce15c4630e 227888 libpoppler-glib-dev_0.18.3-1_amd64.deb
 885a294eff59fd7992b463af33138c5c0d26f07696fc7abca5f6e7f01c1ddc9e 27242 gir1.2-poppler-0.18_0.18.3-1_amd64.deb
 1f80f5bddcfbed69fbb02317ed442b786311fd4cc935dba3201a4a10b495ac96 144998 libpoppler-qt4-3_0.18.3-1_amd64.deb
 5ec3d95001018e11de556756861d8ea9d953421da0c3c064b46d44d4edd0b22f 194396 libpoppler-qt4-dev_0.18.3-1_amd64.deb
 ddce243562edd0224d9006015bb22fabc09e9b1107f8618aedbdc42b5afcfe96 46822 libpoppler-cpp0_0.18.3-1_amd64.deb
 13be49ddcc6c92c3af45a501a460414c0a2dff1215a25a04abadbab93ae1c03c 54240 libpoppler-cpp-dev_0.18.3-1_amd64.deb
 2b51ac91cd2e41656446099909fb190f83d48d07e1c1490e3830256fcf3c9ac3 153592 poppler-utils_0.18.3-1_amd64.deb
 61f2d38f7a7b0e33b0ed74aaecdc09d8a34bc06d8151e74fdc4a62a7dbea912d 4599558 poppler-dbg_0.18.3-1_amd64.deb
Files: 
 c143cdcf88d5847c38ef82fafe23b72f 2345 devel optional poppler_0.18.3-1.dsc
 d70d2d63d8acd29c97185f7e5f09c9b4 1985256 devel optional poppler_0.18.3.orig.tar.gz
 6af6600af4a70f592590a0a377706234 16437 devel optional poppler_0.18.3-1.debian.tar.gz
 4aaa2031442d2a78ef0270927087b964 1095822 libs optional libpoppler19_0.18.3-1_amd64.deb
 303bac8daca27b643d10c323dba9a7df 1089154 libdevel optional libpoppler-dev_0.18.3-1_amd64.deb
 136d668fdb3824f2869e3bc9f3172740 14900 libdevel optional libpoppler-private-dev_0.18.3-1_amd64.deb
 19ee2f1085974e8b1cb5451161f1c2fb 104478 libs optional libpoppler-glib8_0.18.3-1_amd64.deb
 f89150774a3c8a0b4052e628793c6fbd 227888 libdevel optional libpoppler-glib-dev_0.18.3-1_amd64.deb
 3ff396512fb78a17a38508f1ae5c9315 27242 introspection optional gir1.2-poppler-0.18_0.18.3-1_amd64.deb
 578da74a619b61b2db2f5f1a7a247d87 144998 libs optional libpoppler-qt4-3_0.18.3-1_amd64.deb
 4a3cfdc8a3efd1f01fddb038abc57472 194396 libdevel optional libpoppler-qt4-dev_0.18.3-1_amd64.deb
 758b37afea30240040bef36d8324cc3f 46822 libs optional libpoppler-cpp0_0.18.3-1_amd64.deb
 2fd7c3f2c309900fecbc0b69d43ddbf0 54240 libdevel optional libpoppler-cpp-dev_0.18.3-1_amd64.deb
 8f0b89b88f0cd00b57cef2880748cf5a 153592 utils optional poppler-utils_0.18.3-1_amd64.deb
 6d191c1e286a98410d36d3630b3da5b5 4599558 debug extra poppler-dbg_0.18.3-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFPODk9TNH2piB/L3oRAk3sAKCZq18JvqTS+ulGBMpNSHj/EeelSwCgxMvm
S3JYwWxYbxaxVm3gADhEnEc=
=INR5
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 30 Jul 2012 07:28:17 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 21:02:13 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.