Debian Bug report logs - #632449
openswan: obsolete build-dependency: libopensc2-dev

version graph

Package: openswan; Maintainer for openswan is Rene Mayrhofer <rmayr@debian.org>; Source for openswan is src:openswan.

Reported by: Julien Cristau <jcristau@debian.org>

Date: Sat, 2 Jul 2011 10:24:07 UTC

Severity: serious

Tags: sid, wheezy

Found in version openswan/1:2.6.28+dfsg-5

Fixed in version openswan/1:2.6.37-1

Done: Harald Jenny <harald@a-little-linux-box.at>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Rene Mayrhofer <rmayr@debian.org>:
Bug#632449; Package openswan. (Sat, 02 Jul 2011 10:24:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
New Bug report received and forwarded. Copy sent to Rene Mayrhofer <rmayr@debian.org>. (Sat, 02 Jul 2011 10:24:18 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: openswan: obsolete build-dependency: libopensc2-dev
Date: Sat, 2 Jul 2011 12:22:03 +0200
Package: openswan
Version: 1:2.6.28+dfsg-5
Severity: serious
Tags: wheezy sid

openswan build-depends on libopensc2-dev, which is no longer built by
the opensc source package.

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Rene Mayrhofer <rmayr@debian.org>:
Bug#632449; Package openswan. (Sat, 02 Jul 2011 11:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to René Mayrhofer <rmayr@debian.org>:
Extra info received and forwarded to list. Copy sent to Rene Mayrhofer <rmayr@debian.org>. (Sat, 02 Jul 2011 11:12:04 GMT) Full text and rfc822 format available.

Message #10 received at 632449@bugs.debian.org (full text, mbox):

From: René Mayrhofer <rmayr@debian.org>
To: Julien Cristau <jcristau@debian.org>, 632449@bugs.debian.org
Subject: Re: Bug#632449: openswan: obsolete build-dependency: libopensc2-dev
Date: Sat, 02 Jul 2011 13:01:22 +0200
On 02.07.2011 12:22, Julien Cristau wrote:
> Package: openswan
> Version: 1:2.6.28+dfsg-5
> Severity: serious
> Tags: wheezy sid
>
> openswan build-depends on libopensc2-dev, which is no longer built by
> the opensc source package.
Why is this supposed to be a serious packaging issue? The 
build-dependency on libopensc2-dev eases backporting to lenny, which 
still a few people (me included) do.

Rene




Information forwarded to debian-bugs-dist@lists.debian.org, Rene Mayrhofer <rmayr@debian.org>:
Bug#632449; Package openswan. (Sat, 02 Jul 2011 11:33:21 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Rene Mayrhofer <rmayr@debian.org>. (Sat, 02 Jul 2011 11:33:24 GMT) Full text and rfc822 format available.

Message #15 received at 632449@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: René Mayrhofer <rmayr@debian.org>, 632449@bugs.debian.org
Subject: Re: Bug#632449: openswan: obsolete build-dependency: libopensc2-dev
Date: Sat, 02 Jul 2011 12:29:31 +0100
On Sat, 2011-07-02 at 13:01 +0200, René Mayrhofer wrote:
> On 02.07.2011 12:22, Julien Cristau wrote:
> > Package: openswan
> > Version: 1:2.6.28+dfsg-5
> > Severity: serious
> > Tags: wheezy sid
> >
> > openswan build-depends on libopensc2-dev, which is no longer built by
> > the opensc source package.
> Why is this supposed to be a serious packaging issue? The 
> build-dependency on libopensc2-dev eases backporting to lenny, which 
> still a few people (me included) do.

It makes the package completely unbuildable in unstable, and testing
once the new opensc migrates.  How is that *not* a serious packaging
issue?

Regards,

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Rene Mayrhofer <rmayr@debian.org>:
Bug#632449; Package openswan. (Sat, 02 Jul 2011 11:33:29 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Rene Mayrhofer <rmayr@debian.org>. (Sat, 02 Jul 2011 11:33:30 GMT) Full text and rfc822 format available.

Message #20 received at 632449@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: René Mayrhofer <rmayr@debian.org>
Cc: 632449@bugs.debian.org
Subject: Re: Bug#632449: openswan: obsolete build-dependency: libopensc2-dev
Date: Sat, 2 Jul 2011 13:30:58 +0200
On Sat, Jul  2, 2011 at 13:01:22 +0200, René Mayrhofer wrote:

> On 02.07.2011 12:22, Julien Cristau wrote:
> >Package: openswan
> >Version: 1:2.6.28+dfsg-5
> >Severity: serious
> >Tags: wheezy sid
> >
> >openswan build-depends on libopensc2-dev, which is no longer built by
> >the opensc source package.
> Why is this supposed to be a serious packaging issue? The
> build-dependency on libopensc2-dev eases backporting to lenny, which
> still a few people (me included) do.
> 
Because it means your package is not buildable in sid once
libopensc2-dev gets decrufted.

Cheers,
Julien




Bug 632449 cloned as bug 635890. Request was from Laurent Bigonville <bigon@debian.org> to control@bugs.debian.org. (Fri, 29 Jul 2011 12:36:02 GMT) Full text and rfc822 format available.

Reply sent to Harald Jenny <harald@a-little-linux-box.at>:
You have taken responsibility. (Thu, 22 Dec 2011 15:36:26 GMT) Full text and rfc822 format available.

Notification sent to Julien Cristau <jcristau@debian.org>:
Bug acknowledged by developer. (Thu, 22 Dec 2011 15:36:26 GMT) Full text and rfc822 format available.

Message #27 received at 632449-close@bugs.debian.org (full text, mbox):

From: Harald Jenny <harald@a-little-linux-box.at>
To: 632449-close@bugs.debian.org
Subject: Bug#632449: fixed in openswan 1:2.6.37-1
Date: Thu, 22 Dec 2011 15:33:37 +0000
Source: openswan
Source-Version: 1:2.6.37-1

We believe that the bug you reported is fixed in the latest version of
openswan, which is due to be installed in the Debian FTP archive:

openswan-dbg_2.6.37-1_i386.deb
  to main/o/openswan/openswan-dbg_2.6.37-1_i386.deb
openswan-doc_2.6.37-1_all.deb
  to main/o/openswan/openswan-doc_2.6.37-1_all.deb
openswan-modules-dkms_2.6.37-1_i386.deb
  to main/o/openswan/openswan-modules-dkms_2.6.37-1_i386.deb
openswan-modules-source_2.6.37-1_all.deb
  to main/o/openswan/openswan-modules-source_2.6.37-1_all.deb
openswan_2.6.37-1.debian.tar.gz
  to main/o/openswan/openswan_2.6.37-1.debian.tar.gz
openswan_2.6.37-1.dsc
  to main/o/openswan/openswan_2.6.37-1.dsc
openswan_2.6.37-1_i386.deb
  to main/o/openswan/openswan_2.6.37-1_i386.deb
openswan_2.6.37.orig.tar.gz
  to main/o/openswan/openswan_2.6.37.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 632449@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Harald Jenny <harald@a-little-linux-box.at> (supplier of updated openswan package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon,  5 Dec 2011 09:05:27 +0100
Source: openswan
Binary: openswan openswan-dbg openswan-doc openswan-modules-source openswan-modules-dkms
Architecture: source all i386
Version: 1:2.6.37-1
Distribution: unstable
Urgency: high
Maintainer: Rene Mayrhofer <rmayr@debian.org>
Changed-By: Harald Jenny <harald@a-little-linux-box.at>
Description: 
 openswan   - Internet Key Exchange daemon
 openswan-dbg - Internet Key Exchange daemon - debugging symbols
 openswan-doc - Internet Key Exchange daemon - documentation
 openswan-modules-dkms - Internet Key Exchange daemon - DKMS source
 openswan-modules-source - Internet Key Exchange daemon - kernel module source
Closes: 520671 595809 612977 623985 625277 626790 632449 633831 639299 650674
Changes: 
 openswan (1:2.6.37-1) unstable; urgency=HIGH
 .
   [Harald Jenny]
   * New upstream release.
     Fixes pluto crypto helper handler vulnerability (CVE-2011-4073).
     Closes: #650674: [CVE-2011-4073] Openswan crypto helper crasher
 .
 openswan (1:2.6.36-1) UNRELEASED; urgency=medium
 .
   [Harald Jenny]
   * New upstream release.
   * Adjusted one of the manpage patches for line break problems.
   * Removed pluto Makefile patch by Jari Aalto (fixed upstream).
   * Incorporated translation updates.
     Closes: #625277: openswan: [INTL:ja] Update po-debconf template translation
                      (ja.po)
     Closes: #633831: openswan: [INTL:nl] Dutch translation of debconf templates
   * Removed obsolete build depedency on libopensc2-dev (code already removed by
     upstream).
     Closes: #632449: openswan: obsolete build-dependency: libopensc2-dev
 .
 openswan (1:2.6.35-1) UNRELEASED; urgency=medium
 .
   [Harald Jenny]
   * New upstream release.
     Closes: #639299: openswan: IP compression doesn't work
   * Adjusted one of the manpage patches for line break problems.
   * Removed some old documentation handling code from debian/rules.
   * Modified openswan-doc to cope with changes in upstream documentation
     directory structure and file list.
   * Bumped Standards for all packages to 3.9.2 (no changes needed).
   * Added build-arch and build-indep targets to please lintian.
 .
 openswan (1:2.6.34-1) UNRELEASED; urgency=medium
 .
   [Harald Jenny]
   * New upstream release.
     Closes: #520671: openswan: Unable to specify a specific MTU on a vpn tunnel
     Closes: #626790: openswan-modules-dkms: Kernel modules doesn't compile
 .
 openswan (1:2.6.33-1) UNRELEASED; urgency=low
 .
   [Harald Jenny]
   * New upstream release.
     Closes: #595809: openswan: Manpage error ipsec_rsasigkey(8)
     Closes: #623985: 2.6.33 version Bump Request
   * Dropped +dfsg from Debian version as upstream has removed some old unfree
     documentation allowing unmodified usage of their tarball.
   * Removed previously introduced exit code patch.
 .
 openswan (1:2.6.32+dfsg-1~experimental+1) UNRELEASED; urgency=low
 .
   [Harald Jenny]
   * New upstream release.
   * Removed patch for bad NAME section and multibyte character issues by
     Jari Aalto (fixed upstream).
   * Removed patch to correct manpage section mismatch (included upstream).
   * Re-enabled, renamed and rewrote init script patch by Jari Aalto to set
     correct start runlevels for openswan.
   * Added patch from upstream git to use proper exit code in init script
     when running under Debian.
 .
 openswan (1:2.6.31+dfsg-1~experimental+1) UNRELEASED; urgency=low
 .
   [Harald Jenny]
   * New upstream release.
     Closes: #612977: Warning: ignored obsolete keyword (null)
   * Removed previously cherry-picked regression fix.
   * Removed patch to fix duplicate init script installation (upstream
     implemented a different solution).
   * Removed some manpage fixes for spelling errors and utf characters by
     Jari Aalto (included upstream).
   * Renamed and modified manpage patch for bad NAME section and multibyte
     character issues by Jari Aalto.
   * Re-enabled, renamed and modified manpage fixes for line break problems
     by Jari Aalto.
   * Removed lintian override for debug package linking to openswan docs.
   * Added patch to correct manpage section mismatch.
   * Re-added cleaning of debconf DB to postrm (Thanks to Simon Deziel for
     pointing me to his fix).
 .
 openswan (1:2.6.29+dfsg-1~experimental+1) UNRELEASED; urgency=low
 .
   [Harald Jenny]
   * New upstream release.
     Fixes XAUTH Cisco handling code (CVE-2010-3302, CVE-2010-3308).
   * Removed 2.6.35 git patches as they are included in new upstream version.
   * Added patch to fix duplicate init script installation (Reincarnation of
     #532348: openswan: installs dupliate init script /etc/init.d/setup).
   * Modified lintian override for long but unsplittable manpage line again.
   * Integrated upstream patch fixing regression introduced by security fixes.
   * Created patch to allow line break in manpage and removed corresponding
     lintian override.
   * Added ${misc:Depends} to doc package and removed override.
   * Changed Vcs-Fields as Debian project switched from svn to git.
 .
 openswan (1:2.6.28+dfsg-2~experimental+1) UNRELEASED; urgency=low
 .
   [Harald Jenny]
   * Modified lintian override for long but unsplittable manpage line.
   * Do not include 2.6.34 SAref patches from upstream anymore as this version
     already disappeared from experimental.
   * Instead added 2.6.35 git patches for SAref feature and KLIPS compatibility
     (LP: #623367).
   * Bumped Standards for binary module package to 3.9.1 (no changes needed).
   * Added lintian override for docs in debug package.
Checksums-Sha1: 
 30c161e2965f96c81bcb8e85d78710490be2936d 1650 openswan_2.6.37-1.dsc
 a0da03e113f1a54c60513f7e8f9908e198c5cd15 11238286 openswan_2.6.37.orig.tar.gz
 c5d47a7f6b839ab9f1c814c75e5419c060bbe353 103780 openswan_2.6.37-1.debian.tar.gz
 9b802da312f9d1301974262cb8b859d969c150c5 1572306 openswan-doc_2.6.37-1_all.deb
 fde50c1605aa317c5f65f6ddd680229cdec60f90 571696 openswan-modules-source_2.6.37-1_all.deb
 2e9f5d737ae0d59b93493e75b5b63a583e8b4dfe 1109028 openswan_2.6.37-1_i386.deb
 e736376e867a0dbf05912a002484cab914e84b46 1608058 openswan-dbg_2.6.37-1_i386.deb
 bc208c6fbd814009701f9311c50b3a0cc83ff619 621462 openswan-modules-dkms_2.6.37-1_i386.deb
Checksums-Sha256: 
 6bfb212d627f4f7c69f9d40cc5f843df220e2853b6bb693deb5a4841d3e0d5bb 1650 openswan_2.6.37-1.dsc
 235a8e0207db661d533368037b2d6d3e9a300cca37e0ed0e906d96fee3a8cc62 11238286 openswan_2.6.37.orig.tar.gz
 148783e7c985a80772056c50b9eea432f46c80dd87e228ed1cd6dd0b05968b13 103780 openswan_2.6.37-1.debian.tar.gz
 315b2e572c5062e64c3b48750273bf65bb24635a1068fd792fa5ae3531e6d970 1572306 openswan-doc_2.6.37-1_all.deb
 55e9b453f38dd1c968107315bce564045979d99a941df5a536f052ce4088fa21 571696 openswan-modules-source_2.6.37-1_all.deb
 f671edc0f9694bccf5bbac2774eb52875601e05694315c508dce2eb377629c18 1109028 openswan_2.6.37-1_i386.deb
 f200721f3ddb63f2b0aec7047d33cbbe55a570b22e001347bea17fc0a20b93d5 1608058 openswan-dbg_2.6.37-1_i386.deb
 ffddae82fbf6d91e18d9a6801e441517ae0f9ded1eaf7450781cc609c97666a4 621462 openswan-modules-dkms_2.6.37-1_i386.deb
Files: 
 0759e1e1ff84e9fc7631477ebcb6de8c 1650 net optional openswan_2.6.37-1.dsc
 e5c948555088df06cfadcfbe6c13adfe 11238286 net optional openswan_2.6.37.orig.tar.gz
 10d4182dbe4c120ab81c753baa19ba0f 103780 net optional openswan_2.6.37-1.debian.tar.gz
 097229dbbbe6b8652ffca4b2304626a4 1572306 doc optional openswan-doc_2.6.37-1_all.deb
 5a883cb7e22256852a850ae0ac20e2c3 571696 kernel optional openswan-modules-source_2.6.37-1_all.deb
 d08b6e9cd3a7ac89d6e314536249bc35 1109028 net optional openswan_2.6.37-1_i386.deb
 f12f9d471a2f36ce58e21f9807395dab 1608058 debug extra openswan-dbg_2.6.37-1_i386.deb
 bf563cc30be7cf645a11fdaa93f3fbd5 621462 kernel optional openswan-modules-dkms_2.6.37-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk7zSZEACgkQq7SPDcPCS96yegCdFmXuKFZqxhcKMfx8uEh/zifp
lcAAn0qeZaUbkJW3bew74rl52nQmsaVq
=jVUs
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 14 Mar 2012 08:32:21 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 21:30:07 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.