Debian Bug report logs - #630775
libgl1-nvidia-glx: Does not provide libgl1 and breaks libgl1-mesa-glx

version graph

Package: libgl1-nvidia-glx; Maintainer for libgl1-nvidia-glx is Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>; Source for libgl1-nvidia-glx is src:nvidia-graphics-drivers.

Reported by: Ben Klein <shacklein@gmail.com>

Date: Fri, 17 Jun 2011 09:27:02 UTC

Severity: important

Found in version nvidia-graphics-drivers/275.09.07-1

Fixed in version nvidia-graphics-drivers/275.09.07-2

Done: Andreas Beckmann <debian@abeckmann.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, shacklein@gmail.com, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Fri, 17 Jun 2011 09:27:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Klein <shacklein@gmail.com>:
New Bug report received and forwarded. Copy sent to shacklein@gmail.com, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 17 Jun 2011 09:27:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Ben Klein <shacklein@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libgl1-nvidia-glx: Does not provide libgl1 and breaks libgl1-mesa-glx
Date: Fri, 17 Jun 2011 19:11:47 +1000
Package: libgl1-nvidia-glx
Version: 275.09.07-1
Severity: grave
Justification: renders package unusable


libgl1-nvidia-glx = 275.09.07-1 has a "breaks" clause for libgl1-mesa-glx >= 7.10.2-4. The current version of this package in sid is 7.10.3-1, and there is no earlier version accessible in the repository. To compound this problem, libgl1-nvidia-glx does not provide libgl1, so libgl1-mesa-glx cannot be removed in favour of libgl1-nvidia-glx for non-free nvidia driver users.

This prevents the upgrade of xserver-xorg-core to 2:1.10.2-1 as the xorg-video-abi-8 virtual package is no longer available for the older nvidia-glx = 260.19.44-1.

-- Package-specific info:
uname -a:
Linux legion 2.6.37.3-roman #4 SMP PREEMPT Sun Apr 3 20:24:53 EST 2011 x86_64 GNU/Linux

/proc/version:
Linux version 2.6.37.3-roman (btk@legion) (gcc version 4.5.2 (Debian 4.5.2-6) ) #4 SMP PREEMPT Sun Apr 3 20:24:53 EST 2011

lspci 'VGA compatible controller [0300]':
02:00.0 VGA compatible controller [0300]: nVidia Corporation G94 [GeForce 9600 GT] [10de:0622] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device [1043:8275]
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f8000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at f6000000 (64-bit, non-prefetchable) [size=32M]
	Region 5: I/O ports at bc00 [size=128]
	[virtual] Expansion ROM at f9000000 [disabled] [size=512K]
	Capabilities: <access denied>

OpenGL and NVIDIA library files installed:
lrwxrwxrwx 1 root root       37 Mar  3 19:11 /etc/alternatives/ia32-libGL.so -> /usr/lib32/nvidia/diversions/libGL.so
lrwxrwxrwx 1 root root       28 Mar  3 15:27 /etc/alternatives/ia32-libGL.so.1 -> /usr/lib32/nvidia/libGL.so.1
lrwxrwxrwx 1 root root       26 Mar 21 03:42 /etc/alternatives/libGL.so.1 -> /usr/lib/nvidia/libGL.so.1
lrwxrwxrwx 1 root root       28 Mar 21 03:42 /usr/lib/libGL.so.1 -> /etc/alternatives/libGL.so.1
lrwxrwxrwx 1 root root       26 Mar 21 02:41 /usr/lib/libnvidia-cfg.so.1 -> libnvidia-cfg.so.260.19.44
-rw-r--r-- 1 root root   132664 Feb 28 17:59 /usr/lib/libnvidia-cfg.so.260.19.44
-rw-r--r-- 1 root root 27089296 Feb 28 17:56 /usr/lib/libnvidia-glcore.so.260.19.44
lrwxrwxrwx 1 root root       23 Mar 21 02:42 /usr/lib/libnvidia-tls.so.1 -> libnvidia-tls.so.180.22
-rw-r--r-- 1 root root     3360 Sep  2  2008 /usr/lib/libnvidia-tls.so.173.14.09
-rw-r--r-- 1 root root     6136 Jan 12  2009 /usr/lib/libnvidia-tls.so.180.22
-rw-r--r-- 1 root root     5936 Feb 28 17:58 /usr/lib/libnvidia-tls.so.260.19.44
lrwxrwxrwx 1 root root       31 Mar  3 19:11 /usr/lib32/libGL.so -> /etc/alternatives/ia32-libGL.so
lrwxrwxrwx 1 root root       33 Mar  3 15:27 /usr/lib32/libGL.so.1 -> /etc/alternatives/ia32-libGL.so.1
-rw-r--r-- 1 root root 23726100 Feb 28 16:46 /usr/lib32/libnvidia-glcore.so.260.19.44
-rw-r--r-- 1 root root     4436 Feb 28 16:49 /usr/lib32/libnvidia-tls.so.260.19.44

/usr/lib/nvidia:
total 6252
drwxr-xr-x   3 root root    4096 Jun 17 18:42 .
drwxr-xr-x 240 root root  118784 Jun 17 18:42 ..
-rwxr-xr-x   1 root root    1338 May 16 11:01 check-for-conflicting-opengl-libraries
drwxr-xr-x   2 root root    4096 Jun 17 18:02 diversions
lrwxrwxrwx   1 root root      18 Mar 21 02:41 libGL.so.1 -> libGL.so.260.19.44
-rw-r--r--   1 root root  980368 Feb 28 17:56 libGL.so.260.19.44
lrwxrwxrwx   1 root root      19 Mar 21 02:41 libglx.so -> libglx.so.260.19.44
-rw-r--r--   1 root root 5259592 Feb 28 17:58 libglx.so.260.19.44
-rwxr-xr-x   1 root root     441 May 16 11:01 pre-install

/usr/lib/nvidia/diversions:
total 424
drwxr-xr-x 2 root root   4096 Jun 17 18:02 .
drwxr-xr-x 3 root root   4096 Jun 17 18:42 ..
-rw-r--r-- 1 root root    189 Mar 17 16:39 dummy.txt
-rw-r--r-- 1 root root 416168 Mar  8 02:48 libglx.so

/usr/lib32/nvidia:
total 792
drwxr-xr-x  3 root root   4096 Mar 21 02:41 .
drwxr-xr-x 38 root root  36864 Jun 17 18:10 ..
drwxr-xr-x  2 root root   4096 Mar 21 02:41 diversions
lrwxrwxrwx  1 root root     18 Mar 21 02:41 libGL.so.1 -> libGL.so.260.19.44
-rw-r--r--  1 root root 758308 Feb 28 16:47 libGL.so.260.19.44

/usr/lib32/nvidia/diversions:
total 408
drwxr-xr-x 2 root root   4096 Mar 21 02:41 .
drwxr-xr-x 3 root root   4096 Mar 21 02:41 ..
lrwxrwxrwx 1 root root     10 Mar 21 02:41 libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root     12 Mar 21 02:41 libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 401528 Jul 16  2010 libGL.so.1.2

Files from nvidia-installer:



-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.37.3-roman (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgl1-nvidia-glx depends on:
ii  libc6                        2.13-7      Embedded GNU C Library: Shared lib
ii  libgl1-nvidia-alternatives   260.19.44-1 simplifies replacing MESA libGL wi
ii  libx11-6                     2:1.4.3-2   X11 client-side library
ii  libxext6                     2:1.3.0-3   X11 miscellaneous extension librar
ii  libxv1                       2:1.0.6-1   X11 Video extension library
ii  libxvmc1                     2:1.0.6-1   X11 Video extension library
ii  nvidia-installer-cleanup [nv 20110515+1  Cleanup after driver installation 

Versions of packages libgl1-nvidia-glx recommends:
ii  nvidia-kern 260.19.44-1+2.6.37.3~roman-2 NVIDIA binary kernel module for Li

Versions of packages libgl1-nvidia-glx suggests:
ii  nvidia-kernel-source         275.09.07-1 NVIDIA binary kernel module source

Versions of packages nvidia-glx depends on:
ii  dpkg        1.16.0.3                     Debian package management system
ii  libc6       2.13-7                       Embedded GNU C Library: Shared lib
ii  libglx-nvid 260.19.44-1                  simplifies replacing Xorg module l
ii  nvidia-inst 20110515+1                   Cleanup after driver installation 
ii  nvidia-kern 260.19.44-1+2.6.37.3~roman-2 NVIDIA binary kernel module for Li
ii  xserver-xor 2:1.9.4.901-1                Xorg X server - core server

Versions of packages nvidia-glx recommends:
ii  nvidia-vdpau-driver          260.19.44-1 NVIDIA vdpau driver

Versions of packages nvidia-glx suggests:
ii  nvidia-kernel-source         275.09.07-1 NVIDIA binary kernel module source
ii  nvidia-settings              195.36.24-1 Tool for configuring the NVIDIA gr

Versions of packages nvidia-kernel-source depends on:
ii  debhelper                     8.1.6      helper programs for debian/rules
ii  make                          3.81-8.1   An utility for Directing compilati
ii  quilt                         0.48-7     Tool to work with series of patche

Versions of packages nvidia-kernel-source recommends:
ii  kernel-package               12.036+nmu1 A utility for building Linux kerne
ii  module-assistant             0.11.3      tool to make module package creati
ii  nvidia-kernel-common         20110515+1  NVIDIA binary kernel module suppor

Versions of packages nvidia-kernel-source suggests:
ii  nvidia-glx [nvidia-glx]      260.19.44-1 NVIDIA binary Xorg driver

Versions of packages libgl1-nvidia-glx is related to:
ii  binutils              2.21.52.20110606-2 The GNU assembler, linker and bina
pn  binutils-gold         <none>             (no description available)
ii  linux-headers-2.6.37. 2.6.37.3~roman-1   Header files related to Linux kern
ii  nvidia-glx [nvidia-gl 260.19.44-1        NVIDIA binary Xorg driver
ii  nvidia-kernel-common  20110515+1         NVIDIA binary kernel module suppor
pn  nvidia-kernel-dkms    <none>             (no description available)
ii  nvidia-kernel-source  275.09.07-1        NVIDIA binary kernel module source
ii  xserver-xorg          1:7.6+4            the X.Org X server
ii  xserver-xorg-core     2:1.9.4.901-1      Xorg X server - core server

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Fri, 17 Jun 2011 09:33:21 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 17 Jun 2011 09:33:26 GMT) Full text and rfc822 format available.

Message #10 received at 630775@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Ben Klein <shacklein@gmail.com>, 630775@bugs.debian.org
Subject: Re: Bug#630775: libgl1-nvidia-glx: Does not provide libgl1 and breaks libgl1-mesa-glx
Date: Fri, 17 Jun 2011 11:30:17 +0200
On 2011-06-17 11:11, Ben Klein wrote:
> libgl1-nvidia-glx = 275.09.07-1 has a "breaks" clause for libgl1-mesa-glx >= 7.10.2-4. The current version of this package in sid is 7.10.3-1, and there is no earlier version accessible in the repository. To compound this problem, libgl1-nvidia-glx does not provide libgl1, so libgl1-mesa-glx cannot be removed in favour of libgl1-nvidia-glx for non-free nvidia driver users.

Please use MESA from testing. We are working on updating the diversion
handling for multiarch support.

On 2011-06-16 17:19, Mario Palomo wrote:
This is working for me:

# apt-get install libgl1-mesa-dev=7.10.2-3 libgl1-mesa-dri=7.10.2-3
libgl1-mesa-glx=7.10.2-3 libglu1-mesa=7.10.2-3 libglu1-mesa-dev=7.10.2-3
mesa-common-dev=7.10.2-3

Andreas




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Fri, 17 Jun 2011 09:54:51 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Klein <shacklein@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 17 Jun 2011 09:54:54 GMT) Full text and rfc822 format available.

Message #15 received at 630775@bugs.debian.org (full text, mbox):

From: Ben Klein <shacklein@gmail.com>
To: Andreas Beckmann <debian@abeckmann.de>
Cc: 630775@bugs.debian.org
Subject: Re: Bug#630775: libgl1-nvidia-glx: Does not provide libgl1 and breaks libgl1-mesa-glx
Date: Fri, 17 Jun 2011 09:53:37 +0000
On 17 June 2011 09:30, Andreas Beckmann <debian@abeckmann.de> wrote:
> On 2011-06-17 11:11, Ben Klein wrote:
>> libgl1-nvidia-glx = 275.09.07-1 has a "breaks" clause for libgl1-mesa-glx >= 7.10.2-4. The current version of this package in sid is 7.10.3-1, and there is no earlier version accessible in the repository. To compound this problem, libgl1-nvidia-glx does not provide libgl1, so libgl1-mesa-glx cannot be removed in favour of libgl1-nvidia-glx for non-free nvidia driver users.
>
> Please use MESA from testing. We are working on updating the diversion
> handling for multiarch support.

Thanks for the response. I've just spent the last half hour or so
trying to get xorg to load with 260.x.x nvidia driver and newer
libgl1-mesa-glx installed, and discovered the new location of the
libGL.so.1 symlink. Thanks.

Will libgl1-nvidia-glx be made to provide libgl1? I read on the
nvidia-glx bugs that there is an argument against it.

> On 2011-06-16 17:19, Mario Palomo wrote:
> This is working for me:
>
> # apt-get install libgl1-mesa-dev=7.10.2-3 libgl1-mesa-dri=7.10.2-3
> libgl1-mesa-glx=7.10.2-3 libglu1-mesa=7.10.2-3 libglu1-mesa-dev=7.10.2-3
> mesa-common-dev=7.10.2-3
>
> Andreas
>




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Fri, 17 Jun 2011 15:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 17 Jun 2011 15:54:05 GMT) Full text and rfc822 format available.

Message #20 received at 630775@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Ben Klein <shacklein@gmail.com>
Cc: 630775@bugs.debian.org
Subject: Re: Bug#630775: libgl1-nvidia-glx: Does not provide libgl1 and breaks libgl1-mesa-glx
Date: Fri, 17 Jun 2011 17:49:59 +0200
On 2011-06-17 11:53, Ben Klein wrote:
> Will libgl1-nvidia-glx be made to provide libgl1? I read on the
> nvidia-glx bugs that there is an argument against it.

No, this will cause more trouble than it solves.

Andreas




Added tag(s) pending. Request was from Anibal Monsalve Salazar <anibal@debian.org> to control@bugs.debian.org. (Mon, 20 Jun 2011 08:09:08 GMT) Full text and rfc822 format available.

Severity set to 'important' from 'grave' Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Mon, 20 Jun 2011 14:06:08 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Wed, 22 Jun 2011 01:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Nick Orlov <bugfixer@list.ru>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Wed, 22 Jun 2011 01:36:05 GMT) Full text and rfc822 format available.

Message #29 received at 630775@bugs.debian.org (full text, mbox):

From: Nick Orlov <bugfixer@list.ru>
To: 630775@bugs.debian.org
Subject: temporary workaround for unstable
Date: Tue, 21 Jun 2011 21:02:54 -0400
>> Will libgl1-nvidia-glx be made to provide libgl1? I read on the
>> nvidia-glx bugs that there is an argument against it.

> No, this will cause more trouble than it solves.

I'm not so sure about that - some people may end up wiping out half
of the system because of this conflict ...

Anyway - as a temporary workaround for unstable I ended up creating
empty metapackage 'libg1-fake' which depends on libgl1-nvidia-glx and
provides libgl1. This allowed to remove conflicting libgl1-mesa-glx and
put system back to a consistent state.

So far looks good - quake works :)

-- 
With best wishes,
	Nick Orlov.





Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630775; Package libgl1-nvidia-glx. (Thu, 23 Jun 2011 13:30:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 23 Jun 2011 13:30:09 GMT) Full text and rfc822 format available.

Message #34 received at 630775@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Nick Orlov <bugfixer@list.ru>, 630775@bugs.debian.org
Subject: Re: Bug#630775: temporary workaround for unstable
Date: Thu, 23 Jun 2011 15:28:24 +0200
On 2011-06-22 03:02, Nick Orlov wrote:
> Anyway - as a temporary workaround for unstable I ended up creating
> empty metapackage 'libg1-fake' which depends on libgl1-nvidia-glx and
> provides libgl1. This allowed to remove conflicting libgl1-mesa-glx and
> put system back to a consistent state.

Why didn't you just downgrade libgl1-mesa-glx (and other mesa packages)
to the version from testing?

Andreas




Reply sent to Andreas Beckmann <debian@abeckmann.de>:
You have taken responsibility. (Thu, 23 Jun 2011 19:57:21 GMT) Full text and rfc822 format available.

Notification sent to Ben Klein <shacklein@gmail.com>:
Bug acknowledged by developer. (Thu, 23 Jun 2011 19:57:21 GMT) Full text and rfc822 format available.

Message #39 received at 630775-close@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: 630775-close@bugs.debian.org
Subject: Bug#630775: fixed in nvidia-graphics-drivers 275.09.07-2
Date: Thu, 23 Jun 2011 19:55:48 +0000
Source: nvidia-graphics-drivers
Source-Version: 275.09.07-2

We believe that the bug you reported is fixed in the latest version of
nvidia-graphics-drivers, which is due to be installed in the Debian FTP archive:

libcuda1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libcuda1_275.09.07-2_i386.deb
libgl1-nvidia-alternatives_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libgl1-nvidia-alternatives_275.09.07-2_i386.deb
libgl1-nvidia-glx_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libgl1-nvidia-glx_275.09.07-2_i386.deb
libglx-nvidia-alternatives_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libglx-nvidia-alternatives_275.09.07-2_i386.deb
libnvcuvid1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvcuvid1_275.09.07-2_i386.deb
libnvidia-compiler_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvidia-compiler_275.09.07-2_i386.deb
libnvidia-ml1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvidia-ml1_275.09.07-2_i386.deb
nvidia-alternative_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-alternative_275.09.07-2_i386.deb
nvidia-glx_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-glx_275.09.07-2_i386.deb
nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
  to non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
nvidia-graphics-drivers_275.09.07-2.dsc
  to non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_275.09.07-2.dsc
nvidia-kernel-dkms_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-kernel-dkms_275.09.07-2_i386.deb
nvidia-kernel-source_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-kernel-source_275.09.07-2_i386.deb
nvidia-libopencl1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-libopencl1_275.09.07-2_i386.deb
nvidia-opencl-common_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-opencl-common_275.09.07-2_i386.deb
nvidia-opencl-icd_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-opencl-icd_275.09.07-2_i386.deb
nvidia-smi_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-smi_275.09.07-2_i386.deb
nvidia-vdpau-driver_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-vdpau-driver_275.09.07-2_i386.deb
xserver-xorg-video-nvidia_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/xserver-xorg-video-nvidia_275.09.07-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 630775@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andreas Beckmann <debian@abeckmann.de> (supplier of updated nvidia-graphics-drivers package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 18 Jun 2011 13:45:25 +0200
Source: nvidia-graphics-drivers
Binary: nvidia-glx xserver-xorg-video-nvidia nvidia-glx-ia32 libgl1-nvidia-glx libgl1-nvidia-glx-ia32 nvidia-alternative nvidia-kernel-dkms nvidia-kernel-source nvidia-vdpau-driver nvidia-vdpau-driver-ia32 nvidia-smi libcuda1 libcuda1-ia32 libnvidia-compiler libnvidia-compiler-ia32 libnvcuvid1 libnvidia-ml1 nvidia-opencl-common nvidia-opencl-icd nvidia-opencl-icd-ia32 nvidia-libopencl1 nvidia-libopencl1-ia32 libgl1-nvidia-alternatives libgl1-nvidia-alternatives-ia32 libglx-nvidia-alternatives
Architecture: source i386
Version: 275.09.07-2
Distribution: experimental
Urgency: low
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Changed-By: Andreas Beckmann <debian@abeckmann.de>
Description: 
 libcuda1   - NVIDIA CUDA runtime library
 libcuda1-ia32 - NVIDIA CUDA runtime library (32-bit)
 libgl1-nvidia-alternatives - transition to glx-alternative-nvidia
 libgl1-nvidia-alternatives-ia32 - simplifies replacing MESA libGL with GPU vendor libraries (32-bit
 libgl1-nvidia-glx - NVIDIA binary OpenGL libraries${nvidia:LegacyDesc}
 libgl1-nvidia-glx-ia32 - NVIDIA binary OpenGL 32-bit libraries${nvidia:LegacyDesc}
 libglx-nvidia-alternatives - transition to glx-alternative-nvidia
 libnvcuvid1 - NVIDIA CUDA nvcuvid runtime library
 libnvidia-compiler - NVIDIA runtime compiler library
 libnvidia-compiler-ia32 - NVIDIA runtime compiler library (32-bit)
 libnvidia-ml1 - NVIDIA management library (NVML) runtime library
 nvidia-alternative - allows the selection of NVIDIA as GLX provider
 nvidia-glx - NVIDIA metapackage${nvidia:LegacyDesc}
 nvidia-glx-ia32 - NVIDIA 32-bit libraries (transitional package)
 nvidia-kernel-dkms - NVIDIA binary kernel module DKMS source${nvidia:LegacyDesc}
 nvidia-kernel-source - NVIDIA binary kernel module source${nvidia:LegacyDesc}
 nvidia-libopencl1 - NVIDIA OpenCL library
 nvidia-libopencl1-ia32 - NVIDIA OpenCL 32-bit library
 nvidia-opencl-common - NVIDIA OpenCL driver
 nvidia-opencl-icd - NVIDIA OpenCL ICD
 nvidia-opencl-icd-ia32 - NVIDIA OpenCL ICD (32-bit)
 nvidia-smi - NVIDIA System Management Interface
 nvidia-vdpau-driver - NVIDIA vdpau driver
 nvidia-vdpau-driver-ia32 - NVIDIA vdpau 32-bit driver
 xserver-xorg-video-nvidia - NVIDIA binary Xorg driver${nvidia:LegacyDesc}
Closes: 630527 630565 630579 630775 630850
Changes: 
 nvidia-graphics-drivers (275.09.07-2) experimental; urgency=low
 .
   [ Andreas Beckmann ]
   * Upload to experimental.
   * Switch to multiarch-aware libGL.* diversion handling provided by the
     glx-diversions/glx-alternatives-nvidia packages, convert old packages
     libgl{1,x}-nvidia-alternatives to transitional ones.
     (Closes: #630527, #630775, #630579, #630565, #630850)
   * Drop Breaks: libgl1-mesa-glx (>= 7.10.2-4~).
   * Move handling of alternatives from nvidia-glx and libgl1-nvidia-glx to
     nvidia-alternative (new package) and glx-alternative-nvidia (from
     glx-alternatives).  libGL.so.1 and libglx.so (the Xorg module) no longer
     can be configured independently, avoiding possible mixed NVIDIA/MESA
     setups.
   * Split the Xorg driver and modules from nvidia-glx into new package
     xserver-xorg-driver-nvidia (package name agreed by Cyril Brulebois).
   * Override a spelling error in the binary-only part of the kernel module.
   * Drop override for no longer emitted experimental shlib-calls-exit.
Checksums-Sha1: 
 4c94489d9bf844ca7e5b40237f3bf4c651500dfa 2352 nvidia-graphics-drivers_275.09.07-2.dsc
 f4683724a23543d6f2fd6cd329382d23381a7645 85920 nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 36e1835d2bd01f3598005d1b055cb68fb0c94e07 323620 nvidia-glx_275.09.07-2_i386.deb
 87d62d7967a28d8b900b2e89f9129c6f750b507e 3654148 xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 9f0f0081af94f612bb25bdabc6a83b80782a71cf 7833520 libgl1-nvidia-glx_275.09.07-2_i386.deb
 c4edd92a05cc1c9abddb437ce3752328ad785fd0 64588 nvidia-alternative_275.09.07-2_i386.deb
 ecf3f6c1fee74f062ac51b7b918ebcc64fd033d7 8970238 nvidia-kernel-dkms_275.09.07-2_i386.deb
 41db97f6306d0626f9488ce9bb5af3aa40ec0dd9 8362560 nvidia-kernel-source_275.09.07-2_i386.deb
 990d162c8f4950148c24e3ab0d0f27375748aa65 1044898 nvidia-vdpau-driver_275.09.07-2_i386.deb
 5dc4968e35b684165fc7191442271438f3ea99c6 89928 nvidia-smi_275.09.07-2_i386.deb
 71d94c62480ceb5c242da512aca3b42ef72024c5 4493812 libcuda1_275.09.07-2_i386.deb
 50be55c117497a211adc13c78e6977ba687671ec 7413334 libnvidia-compiler_275.09.07-2_i386.deb
 487a1ef511f0e36dcd07607818c5017b1e50077e 1168740 libnvcuvid1_275.09.07-2_i386.deb
 d67d311ec714c20a03a576d7d5bbdf0aa502473a 100626 libnvidia-ml1_275.09.07-2_i386.deb
 bddc37a9363b87f6d188133d904ccca9c0fe238c 63956 nvidia-opencl-common_275.09.07-2_i386.deb
 7e266173fb35f488ca0320d5f35cabca4be7e839 63844 nvidia-opencl-icd_275.09.07-2_i386.deb
 2b6c4d778560a7246230bcffecd8eaeba26d0e42 71782 nvidia-libopencl1_275.09.07-2_i386.deb
 1ac20a12e527a87fccb887225a5b8aafbb5eddab 63852 libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 af4090d20d925bab91733943a57262deed2406bf 63792 libglx-nvidia-alternatives_275.09.07-2_i386.deb
Checksums-Sha256: 
 90b552a33b162f2466b931fb7fe759cfdeedd5ec6f7a0ad63a4464e98e9f8b55 2352 nvidia-graphics-drivers_275.09.07-2.dsc
 b927649a41505aa7c6db4fa04502dc149a04734c8e51e19609cbe2360293ef29 85920 nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 36a738a71c06cff485fa7ca87dc322382b09045c279b23b68645fa40cec29345 323620 nvidia-glx_275.09.07-2_i386.deb
 5b980aa427c10cef625467b7fdbee637a39bc5feb7fa4c6c1e8ac5741c68d77c 3654148 xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 a1fafe1d55e81a219c92a3600ebe0188f0ab780ffcb1e42716ee23a80c71dfe8 7833520 libgl1-nvidia-glx_275.09.07-2_i386.deb
 897d58c57a61446b0fde1c3155a182d85124cf770301d33b7e819516fbfcbed9 64588 nvidia-alternative_275.09.07-2_i386.deb
 2c1b817dab5359943f31bec2d3eab3d1e689ec1a26d5bdf6696e7c911924599c 8970238 nvidia-kernel-dkms_275.09.07-2_i386.deb
 c9ce382e8f3cb09bee436396ce461cd6598b887a6d908c7d10811dff22eb3b85 8362560 nvidia-kernel-source_275.09.07-2_i386.deb
 4dc94d6088b269a7a167a835829eb5d0ea5b13673072521c7472c7b80c5b5115 1044898 nvidia-vdpau-driver_275.09.07-2_i386.deb
 d7ad3749894ab47547072ec3dce02a1b0d1aef41e588e2621c3613ed159892e6 89928 nvidia-smi_275.09.07-2_i386.deb
 1505b05a14968050b56d04bd1a99bee2bcdae7c888258fae1d9940ce2ba8493e 4493812 libcuda1_275.09.07-2_i386.deb
 0a990b983c82ce55d6d46be16517a2a811ce15a81fb1239dc43e6cf5faff4487 7413334 libnvidia-compiler_275.09.07-2_i386.deb
 b5ceea9a56d10f5327f7f41a5818e969a1408dc52d22a6f6269d90e5bb8343a2 1168740 libnvcuvid1_275.09.07-2_i386.deb
 37549c1c6e1d0ae077bd8d599fa235d350166f4d410c0522990e19d1bf8ee738 100626 libnvidia-ml1_275.09.07-2_i386.deb
 5891bf22422a6006fb4441378dab4436e4358e6270644b817c6cb298c94d2a2d 63956 nvidia-opencl-common_275.09.07-2_i386.deb
 6c06f379c4dd6edbd90bea09a3a39ec9864a012c4d58843fb17c986f7fd7b140 63844 nvidia-opencl-icd_275.09.07-2_i386.deb
 7b58d7102f90b7e663207e73aba94f9abac13aa18e9eebaf4849d8dbcd93a897 71782 nvidia-libopencl1_275.09.07-2_i386.deb
 51c6656ef54ad1362531897d95eb9491f819fadcdce9d592d1b268498e465c24 63852 libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 7d2a34d8a5820adbe88e3b02ad24b671fb5cdcc39d29343fba7353277f0020a5 63792 libglx-nvidia-alternatives_275.09.07-2_i386.deb
Files: 
 c3ee178e4df0128075ef45585c09ece5 2352 non-free/libs optional nvidia-graphics-drivers_275.09.07-2.dsc
 59dfaf4342326e19a2ecbd1c55ec5dd9 85920 non-free/libs optional nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 f063658eb77dbe4f42e09d9803f78ed1 323620 non-free/x11 optional nvidia-glx_275.09.07-2_i386.deb
 883d3e7ac1a819ea98aa120b06ddc0a9 3654148 non-free/x11 optional xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 284d2ef6b8b5053840ca4e7a82514182 7833520 non-free/libs optional libgl1-nvidia-glx_275.09.07-2_i386.deb
 db0baad8f7d71b362eba9bca04aeb4d0 64588 non-free/libs optional nvidia-alternative_275.09.07-2_i386.deb
 3108b3a1cf44185ee9dee4581da9620d 8970238 non-free/kernel optional nvidia-kernel-dkms_275.09.07-2_i386.deb
 f5298520c0177fc17054d7d87eadac90 8362560 non-free/kernel optional nvidia-kernel-source_275.09.07-2_i386.deb
 7421cae459db96a0badac06d84e06eb9 1044898 non-free/libs optional nvidia-vdpau-driver_275.09.07-2_i386.deb
 37d33c00a4062bc4c6c898d7ef67a7df 89928 non-free/utils optional nvidia-smi_275.09.07-2_i386.deb
 bd4fce8461fc6e8e2a28371326df25e5 4493812 non-free/libs optional libcuda1_275.09.07-2_i386.deb
 f8b4bdc99d0021dbaa2a52c273473bfb 7413334 non-free/libs optional libnvidia-compiler_275.09.07-2_i386.deb
 c5ece7fecb68d6e32d690f602e86178b 1168740 non-free/libs optional libnvcuvid1_275.09.07-2_i386.deb
 656226c652b9d627bde69a4b58e2553d 100626 non-free/libs optional libnvidia-ml1_275.09.07-2_i386.deb
 e88e4aecb83044787eaedae1f1524644 63956 non-free/libs optional nvidia-opencl-common_275.09.07-2_i386.deb
 69026aceaddb21d79c1d601562c1b1ff 63844 non-free/libs optional nvidia-opencl-icd_275.09.07-2_i386.deb
 9c767eb1793536824a66dc16de6fb5d9 71782 non-free/libs optional nvidia-libopencl1_275.09.07-2_i386.deb
 6cb1617c214ca8249d14a779ddd15e45 63852 non-free/oldlibs optional libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 434dfbe39f1df2912ee98e348e531d7a 63792 non-free/oldlibs optional libglx-nvidia-alternatives_275.09.07-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAEBCAAGBQJN/ocLAAoJEH2AMVxXNt51xecIAKdG/UPIAB+Yt033AxgEfV9u
R8N0FWrXK4qflyMylD5Z+UIvkVNEFgGKr3JTrJ8r0WpEgDsXd5ob5impfG63D50a
iq6Ydd+WCEiD8hF+eEsnleLc3oE9fLlZTLfRk++Pq1vVfIVVc1MVCfzBY5jWddPm
5SP3ZtY7fSigu05qEewVpGZh5WuyZgdMHyrKXdYm/CB3tbxmpmamY+XZLRLaUcoe
jNfNOesko5Z9rXMRkNlfoPw1oqJkT7H/6dZylYLinBclMD0ozsB24ynOLtaN/819
TBM7O8qF7ryzKl2b8qlyAZOP9KP6RQc0mkaF8xOMiMUmT+39lRnDupMKASIhR2M=
=rfYg
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 26 Jul 2011 07:40:29 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 25 07:10:20 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.