Debian Bug report logs - #630579
nvidia-glx: glx cannot be utilised

version graph

Package: nvidia-glx; Maintainer for nvidia-glx is Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>; Source for nvidia-glx is src:nvidia-graphics-drivers.

Reported by: Sophoklis Goumas <olspookishmagus@gmail.com>

Date: Wed, 15 Jun 2011 11:36:04 UTC

Severity: important

Found in version nvidia-graphics-drivers/270.41.19-1

Fixed in version nvidia-graphics-drivers/275.09.07-2

Done: Andreas Beckmann <debian@abeckmann.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Wed, 15 Jun 2011 11:36:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sophoklis Goumas <olspookishmagus@gmail.com>:
New Bug report received and forwarded. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Wed, 15 Jun 2011 11:36:07 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sophoklis Goumas <olspookishmagus@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: nvidia-glx: glx cannot be utilised
Date: Wed, 15 Jun 2011 14:34:16 +0300
Package: nvidia-glx
Version: 270.41.19-1
Severity: important

Following a recent dist-upgrade glx does not get utilised.

-- glxinfo output:
glxinfo: 
name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

-- Package-specific info:
uname -a:
Linux sojourn 2.6.39-2-686-pae #1 SMP Wed Jun 8 11:33:14 UTC 2011 i686 GNU/Linux

/proc/version:
Linux version 2.6.39-2-686-pae (Debian 2.6.39-2) (ben@decadent.org.uk) (gcc version 4.4.6 (Debian 4.4.6-3) ) #1 SMP Wed Jun 8 11:33:14 UTC 2011

/proc/driver/nvidia/version:
NVRM version: NVIDIA UNIX x86 Kernel Module  270.41.19  Mon May 16 23:31:36 PDT 2011
GCC version:  gcc version 4.4.6 (Debian 4.4.6-6) 

lspci 'VGA compatible controller [0300]':
01:00.0 VGA compatible controller [0300]: nVidia Corporation GF104 [GeForce GTX 460] [10de:0e22] (rev a1) (prog-if 00 [VGA controller])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=32M]
	Region 1: Memory at e8000000 (64-bit, prefetchable) [size=128M]
	Region 3: Memory at e4000000 (64-bit, prefetchable) [size=64M]
	Region 5: I/O ports at bc00 [size=128]
	[virtual] Expansion ROM at f7b00000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia

OpenGL and NVIDIA library files installed:
lrwxrwxrwx 1 root root       24 Jun 15 11:49 /etc/alternatives/libGL.so -> /usr/lib/nvidia/libGL.so
lrwxrwxrwx 1 root root       26 Nov 28  2010 /etc/alternatives/libGL.so.1 -> /usr/lib/nvidia/libGL.so.1
lrwxrwxrwx 1 root root       26 Jun 15 11:50 /usr/lib/libGL.so -> /etc/alternatives/libGL.so
lrwxrwxrwx 1 root root       28 Nov 28  2010 /usr/lib/libGL.so.1 -> /etc/alternatives/libGL.so.1
lrwxrwxrwx 1 root root       26 May 24 23:23 /usr/lib/libnvidia-cfg.so.1 -> libnvidia-cfg.so.270.41.19
-rw-r--r-- 1 root root   131944 May 17 09:52 /usr/lib/libnvidia-cfg.so.270.41.19
-rw-r--r-- 1 root root 24182932 May 17 09:48 /usr/lib/libnvidia-glcore.so.270.41.19
-rw-r--r-- 1 root root     4504 May 17 09:51 /usr/lib/libnvidia-tls.so.270.41.19

/usr/lib/nvidia:
total 4660
drwxr-xr-x   3 root root    4096 Jun 15 12:47 .
drwxr-xr-x 317 root root  131072 Jun 15 11:51 ..
-rwxr-xr-x   1 root root    1338 May 16 04:01 check-for-conflicting-opengl-libraries
drwxr-xr-x   2 root root    4096 Jun 14 21:36 diversions
lrwxrwxrwx   1 root root      26 Jun 15 11:49 libGL.so -> /usr/lib/nvidia/libGL.so.1
lrwxrwxrwx   1 root root      18 May 24 23:23 libGL.so.1 -> libGL.so.270.41.19
-rw-r--r--   1 root root  781540 May 17 09:48 libGL.so.270.41.19
lrwxrwxrwx   1 root root      19 May 24 23:23 libglx.so -> libglx.so.270.41.19
-rw-r--r--   1 root root 3827376 May 17 09:51 libglx.so.270.41.19
-rwxr-xr-x   1 root root     441 May 16 04:01 pre-install

/usr/lib/nvidia/diversions:
total 328
drwxr-xr-x 2 root root   4096 Jun 14 21:36 .
drwxr-xr-x 3 root root   4096 Jun 15 12:47 ..
-rw-r--r-- 1 root root    189 Mar 22 08:38 dummy.txt
-rw-r--r-- 1 root root 315608 Jun 14 16:10 libglx.so

Files from nvidia-installer:


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.39-2-686-pae (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nvidia-glx depends on:
ii  dpkg                1.16.0.3             Debian package management system
ii  libc6               2.13-7               Embedded GNU C Library: Shared lib
ii  libgl1-nvidia-glx [ 270.41.19-1          NVIDIA binary OpenGL libraries
ii  libglx-nvidia-alter 270.41.19-1          simplifies replacing Xorg module l
ii  nvidia-installer-cl 20110515+1           Cleanup after driver installation 
ii  nvidia-kernel-2.6.3 270.41.19-1+2.6.39-2 NVIDIA binary kernel module for Li
ii  nvidia-kernel-dkms  270.41.19-1          NVIDIA binary kernel module DKMS s
ii  nvidia-support      20110515+1           NVIDIA binary graphics driver supp
ii  xserver-xorg-core [ 2:1.10.2-1+b1        Xorg X server - core server

Versions of packages nvidia-glx recommends:
ii  nvidia-vdpau-driver          270.41.19-1 NVIDIA vdpau driver

Versions of packages nvidia-glx suggests:
ii  nvidia-kernel-dkms [nvidia-k 270.41.19-1 NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source         270.41.19-1 NVIDIA binary kernel module source
ii  nvidia-settings              270.41.06-1 Tool for configuring the NVIDIA gr

Versions of packages nvidia-kernel-dkms depends on:
ii  dkms                          2.1.1.2-6  Dynamic Kernel Module Support Fram
ii  nvidia-kernel-common          20110515+1 NVIDIA binary kernel module suppor

nvidia-kernel-dkms recommends no packages.

Versions of packages nvidia-kernel-source depends on:
ii  debhelper                     8.1.6      helper programs for debian/rules
ii  make                          3.81-8.1   An utility for Directing compilati
ii  quilt                         0.48-7     Tool to work with series of patche

Versions of packages nvidia-kernel-source recommends:
ii  kernel-package               12.036+nmu1 A utility for building Linux kerne
ii  module-assistant             0.11.3      tool to make module package creati
ii  nvidia-kernel-common         20110515+1  NVIDIA binary kernel module suppor

nvidia-kernel-source suggests no packages.

Versions of packages nvidia-glx is related to:
ii  linux-headers-2.6-686 [lin 2.6.38+34     Header files for Linux 2.6-686 (me
ii  linux-headers-2.6.32-5-686 2.6.32-31     Header files for Linux 2.6.32-5-68
ii  linux-headers-2.6.32-5-686 2.6.32-31     Header files for Linux 2.6.32-5-68
ii  linux-headers-2.6.38-2-686 2.6.38-5      Header files for Linux 2.6.38-2-68
ii  linux-headers-2.6.38-2-686 2.6.38-5      Header files for Linux 2.6.38-2-68
ii  linux-headers-2.6.39-1-686 2.6.39-1      Header files for Linux 2.6.39-1-68
ii  linux-headers-2.6.39-2-686 2.6.39-2      Header files for Linux 2.6.39-2-68
ii  nvidia-glx [nvidia-glx]    270.41.19-1   NVIDIA binary Xorg driver
ii  nvidia-kernel-common       20110515+1    NVIDIA binary kernel module suppor
ii  nvidia-kernel-dkms [nvidia 270.41.19-1   NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source       270.41.19-1   NVIDIA binary kernel module source
ii  xserver-xorg               1:7.6+7       X.Org X server
ii  xserver-xorg-core          2:1.10.2-1+b1 Xorg X server - core server

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Wed, 15 Jun 2011 13:09:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Raza Abbas <debianuser4@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Wed, 15 Jun 2011 13:09:13 GMT) Full text and rfc822 format available.

Message #10 received at 630579@bugs.debian.org (full text, mbox):

From: Raza Abbas <debianuser4@gmail.com>
To: 630579@bugs.debian.org
Subject: nvidia-glx: glx cannot be utilised
Date: Wed, 15 Jun 2011 09:06:20 -0400
I have this same prob.

-- 
Raza Abbas <DebianUser4@gmail.com>





Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Wed, 15 Jun 2011 15:33:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Wed, 15 Jun 2011 15:33:12 GMT) Full text and rfc822 format available.

Message #15 received at 630579@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Sophoklis Goumas <olspookishmagus@gmail.com>, 630579@bugs.debian.org, Raza Abbas <debianuser4@gmail.com>
Subject: Re: Bug#630579: nvidia-glx: glx cannot be utilised
Date: Wed, 15 Jun 2011 17:30:58 +0200
On 2011-06-15 13:34, Sophoklis Goumas wrote:
> Following a recent dist-upgrade glx does not get utilised.

Please use Xorg and MESA from testing, not unstable for now. I'm working
on upgrading the diversions.


Andreas




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Thu, 16 Jun 2011 00:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Tony Houghton <h@realh.co.uk>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 16 Jun 2011 00:03:03 GMT) Full text and rfc822 format available.

Message #20 received at 630579@bugs.debian.org (full text, mbox):

From: Tony Houghton <h@realh.co.uk>
To: 630579@bugs.debian.org
Subject: Re: nvidia-glx: glx cannot be utilised
Date: Thu, 16 Jun 2011 01:00:16 +0100
Is there a workaround we can do in the meantime, eg changing symlinks?




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Thu, 16 Jun 2011 12:54:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 16 Jun 2011 12:54:10 GMT) Full text and rfc822 format available.

Message #25 received at 630579@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Tony Houghton <h@realh.co.uk>, 630579@bugs.debian.org
Subject: Re: Bug#630579: nvidia-glx: glx cannot be utilised
Date: Thu, 16 Jun 2011 14:52:14 +0200
On 2011-06-16 02:00, Tony Houghton wrote:
> Is there a workaround we can do in the meantime, eg changing symlinks?

Downgrade Xorg and MESA to the version in testing (i.e. before multiarch
MESA).

Andreas




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Thu, 16 Jun 2011 15:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mario Palomo <mariopal@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 16 Jun 2011 15:21:03 GMT) Full text and rfc822 format available.

Message #30 received at 630579@bugs.debian.org (full text, mbox):

From: Mario Palomo <mariopal@gmail.com>
To: 630579@bugs.debian.org
Subject: Re: Bug#630579: nvidia-glx: glx cannot be utilised
Date: Thu, 16 Jun 2011 17:19:22 +0200
On 2011-06-16 02:00, Tony Houghton wrote:
> Is there a workaround we can do in the meantime, eg changing symlinks?

This is working for me:

# apt-get install libgl1-mesa-dev=7.10.2-3 libgl1-mesa-dri=7.10.2-3
libgl1-mesa-glx=7.10.2-3 libglu1-mesa=7.10.2-3
libglu1-mesa-dev=7.10.2-3 mesa-common-dev=7.10.2-3




Added tag(s) pending. Request was from Anibal Monsalve Salazar <anibal@debian.org> to control@bugs.debian.org. (Mon, 20 Jun 2011 08:09:09 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Mon, 20 Jun 2011 10:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Joseph Parker <vactevo@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Mon, 20 Jun 2011 10:42:05 GMT) Full text and rfc822 format available.

Message #37 received at 630579@bugs.debian.org (full text, mbox):

From: Joseph Parker <vactevo@googlemail.com>
To: 630579@bugs.debian.org
Cc: Mario Palomo <mariopal@gmail.com>
Subject: Re: Bug#630579: nvidia-glx: glx cannot be utilised
Date: Mon, 20 Jun 2011 12:39:46 +0200
> This is working for me:
>
> # apt-get install libgl1-mesa-dev=7.10.2-3 libgl1-mesa-dri=7.10.2-3
> libgl1-mesa-glx=7.10.2-3 libglu1-mesa=7.10.2-3
> libglu1-mesa-dev=7.10.2-3 mesa-common-dev=7.10.2-3

Hi Mario,

i've got a problem using your cmdline; it would uninstall xorg etc...
I don't know how to downgrade now...
see below at *1).

At the moment the packages are at the following versions:
libgl1-mesa-dev		7.10.3-1
libgl1-mesa-dri		7.10.3-2
libgl1-mesa-glx		7.10.3-1
libglu1-mesa		7.10.3-2
libglu1-mesa-dev	7.10.3-2
mesa-common-dev		7.10.3-1

___
Thanks,
Joseph.


*1)
== output of apt-get with the suggested workaround/downgrade ==

 # apt-get -s install libgl1-mesa-dev=7.10.2-3 libgl1-mesa-dri=7.10.2-3
libgl1-mesa-glx=7.10.2-3 libglu1-mesa=7.10.2-3 libglu1-mesa-dev=7.10.2-3
mesa-common-dev=7.10.2-3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  xorg-docs-core xfonts-scalable xfonts-75dpi libgl1-nvidia-glx
xfonts-100dpi nvidia-kernel-dkms
  libgl1-nvidia-alternatives
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libgl1-nvidia-glx nvidia-kernel-dkms
Suggested packages:
  libglide3
The following packages will be REMOVED:
  nvidia-glx xorg xserver-xorg xserver-xorg-core xserver-xorg-input-all
xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-fbdev xserver-xorg-video-nouveau
  xserver-xorg-video-vesa
The following packages will be upgraded:
  libgl1-nvidia-glx nvidia-kernel-dkms
The following packages will be DOWNGRADED:
  libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa
libglu1-mesa-dev mesa-common-dev
2 upgraded, 0 newly installed, 6 downgraded, 11 to remove and 117 not
upgraded.
Remv nvidia-glx [270.41.19-1]
Remv xorg [1:7.6+7]
Remv xserver-xorg [1:7.6+7]
Remv xserver-xorg-video-vesa [1:2.3.0-7]
Remv xserver-xorg-video-nouveau [1:0.0.16+git20110411+8378443-1+b1]
Remv xserver-xorg-video-fbdev [1:0.4.2-4+b1]
Remv xserver-xorg-input-all [1:7.6+7]
Remv xserver-xorg-input-synaptics [1.4.0-1+b1]
Remv xserver-xorg-input-evdev [1:2.6.0-2+b1]
Remv xserver-xorg-input-wacom [0.10.10+20110203-1+b1]
Remv xserver-xorg-core [2:1.10.2-2]
Inst libgl1-mesa-dev [7.10.3-1] (7.10.2-3 Debian:testing [i386]) []
Inst mesa-common-dev [7.10.3-1] (7.10.2-3 Debian:testing [i386]) []
Inst libgl1-mesa-dri [7.10.3-2] (7.10.2-3 Debian:testing [i386]) []
Inst libgl1-mesa-glx [7.10.3-1] (7.10.2-3 Debian:testing [i386])
Inst libgl1-nvidia-glx [270.41.19-1] (275.09.07-1 Debian:unstable [i386])
Inst nvidia-kernel-dkms [270.41.19-1] (275.09.07-1 Debian:unstable [i386])
Inst libglu1-mesa-dev [7.10.3-2] (7.10.2-3 Debian:testing [i386]) []
Inst libglu1-mesa [7.10.3-2] (7.10.2-3 Debian:testing [i386])
Conf mesa-common-dev (7.10.2-3 Debian:testing [i386])
Conf libgl1-mesa-glx (7.10.2-3 Debian:testing [i386])
Conf libgl1-mesa-dev (7.10.2-3 Debian:testing [i386])
Conf libgl1-mesa-dri (7.10.2-3 Debian:testing [i386])
Conf libgl1-nvidia-glx (275.09.07-1 Debian:unstable [i386])
Conf nvidia-kernel-dkms (275.09.07-1 Debian:unstable [i386])
Conf libglu1-mesa (7.10.2-3 Debian:testing [i386])
Conf libglu1-mesa-dev (7.10.2-3 Debian:testing [i386])




Reply sent to Andreas Beckmann <debian@abeckmann.de>:
You have taken responsibility. (Thu, 23 Jun 2011 19:57:18 GMT) Full text and rfc822 format available.

Notification sent to Sophoklis Goumas <olspookishmagus@gmail.com>:
Bug acknowledged by developer. (Thu, 23 Jun 2011 19:57:19 GMT) Full text and rfc822 format available.

Message #42 received at 630579-close@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: 630579-close@bugs.debian.org
Subject: Bug#630579: fixed in nvidia-graphics-drivers 275.09.07-2
Date: Thu, 23 Jun 2011 19:55:48 +0000
Source: nvidia-graphics-drivers
Source-Version: 275.09.07-2

We believe that the bug you reported is fixed in the latest version of
nvidia-graphics-drivers, which is due to be installed in the Debian FTP archive:

libcuda1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libcuda1_275.09.07-2_i386.deb
libgl1-nvidia-alternatives_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libgl1-nvidia-alternatives_275.09.07-2_i386.deb
libgl1-nvidia-glx_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libgl1-nvidia-glx_275.09.07-2_i386.deb
libglx-nvidia-alternatives_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libglx-nvidia-alternatives_275.09.07-2_i386.deb
libnvcuvid1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvcuvid1_275.09.07-2_i386.deb
libnvidia-compiler_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvidia-compiler_275.09.07-2_i386.deb
libnvidia-ml1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/libnvidia-ml1_275.09.07-2_i386.deb
nvidia-alternative_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-alternative_275.09.07-2_i386.deb
nvidia-glx_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-glx_275.09.07-2_i386.deb
nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
  to non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
nvidia-graphics-drivers_275.09.07-2.dsc
  to non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_275.09.07-2.dsc
nvidia-kernel-dkms_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-kernel-dkms_275.09.07-2_i386.deb
nvidia-kernel-source_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-kernel-source_275.09.07-2_i386.deb
nvidia-libopencl1_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-libopencl1_275.09.07-2_i386.deb
nvidia-opencl-common_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-opencl-common_275.09.07-2_i386.deb
nvidia-opencl-icd_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-opencl-icd_275.09.07-2_i386.deb
nvidia-smi_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-smi_275.09.07-2_i386.deb
nvidia-vdpau-driver_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/nvidia-vdpau-driver_275.09.07-2_i386.deb
xserver-xorg-video-nvidia_275.09.07-2_i386.deb
  to non-free/n/nvidia-graphics-drivers/xserver-xorg-video-nvidia_275.09.07-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 630579@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andreas Beckmann <debian@abeckmann.de> (supplier of updated nvidia-graphics-drivers package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 18 Jun 2011 13:45:25 +0200
Source: nvidia-graphics-drivers
Binary: nvidia-glx xserver-xorg-video-nvidia nvidia-glx-ia32 libgl1-nvidia-glx libgl1-nvidia-glx-ia32 nvidia-alternative nvidia-kernel-dkms nvidia-kernel-source nvidia-vdpau-driver nvidia-vdpau-driver-ia32 nvidia-smi libcuda1 libcuda1-ia32 libnvidia-compiler libnvidia-compiler-ia32 libnvcuvid1 libnvidia-ml1 nvidia-opencl-common nvidia-opencl-icd nvidia-opencl-icd-ia32 nvidia-libopencl1 nvidia-libopencl1-ia32 libgl1-nvidia-alternatives libgl1-nvidia-alternatives-ia32 libglx-nvidia-alternatives
Architecture: source i386
Version: 275.09.07-2
Distribution: experimental
Urgency: low
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Changed-By: Andreas Beckmann <debian@abeckmann.de>
Description: 
 libcuda1   - NVIDIA CUDA runtime library
 libcuda1-ia32 - NVIDIA CUDA runtime library (32-bit)
 libgl1-nvidia-alternatives - transition to glx-alternative-nvidia
 libgl1-nvidia-alternatives-ia32 - simplifies replacing MESA libGL with GPU vendor libraries (32-bit
 libgl1-nvidia-glx - NVIDIA binary OpenGL libraries${nvidia:LegacyDesc}
 libgl1-nvidia-glx-ia32 - NVIDIA binary OpenGL 32-bit libraries${nvidia:LegacyDesc}
 libglx-nvidia-alternatives - transition to glx-alternative-nvidia
 libnvcuvid1 - NVIDIA CUDA nvcuvid runtime library
 libnvidia-compiler - NVIDIA runtime compiler library
 libnvidia-compiler-ia32 - NVIDIA runtime compiler library (32-bit)
 libnvidia-ml1 - NVIDIA management library (NVML) runtime library
 nvidia-alternative - allows the selection of NVIDIA as GLX provider
 nvidia-glx - NVIDIA metapackage${nvidia:LegacyDesc}
 nvidia-glx-ia32 - NVIDIA 32-bit libraries (transitional package)
 nvidia-kernel-dkms - NVIDIA binary kernel module DKMS source${nvidia:LegacyDesc}
 nvidia-kernel-source - NVIDIA binary kernel module source${nvidia:LegacyDesc}
 nvidia-libopencl1 - NVIDIA OpenCL library
 nvidia-libopencl1-ia32 - NVIDIA OpenCL 32-bit library
 nvidia-opencl-common - NVIDIA OpenCL driver
 nvidia-opencl-icd - NVIDIA OpenCL ICD
 nvidia-opencl-icd-ia32 - NVIDIA OpenCL ICD (32-bit)
 nvidia-smi - NVIDIA System Management Interface
 nvidia-vdpau-driver - NVIDIA vdpau driver
 nvidia-vdpau-driver-ia32 - NVIDIA vdpau 32-bit driver
 xserver-xorg-video-nvidia - NVIDIA binary Xorg driver${nvidia:LegacyDesc}
Closes: 630527 630565 630579 630775 630850
Changes: 
 nvidia-graphics-drivers (275.09.07-2) experimental; urgency=low
 .
   [ Andreas Beckmann ]
   * Upload to experimental.
   * Switch to multiarch-aware libGL.* diversion handling provided by the
     glx-diversions/glx-alternatives-nvidia packages, convert old packages
     libgl{1,x}-nvidia-alternatives to transitional ones.
     (Closes: #630527, #630775, #630579, #630565, #630850)
   * Drop Breaks: libgl1-mesa-glx (>= 7.10.2-4~).
   * Move handling of alternatives from nvidia-glx and libgl1-nvidia-glx to
     nvidia-alternative (new package) and glx-alternative-nvidia (from
     glx-alternatives).  libGL.so.1 and libglx.so (the Xorg module) no longer
     can be configured independently, avoiding possible mixed NVIDIA/MESA
     setups.
   * Split the Xorg driver and modules from nvidia-glx into new package
     xserver-xorg-driver-nvidia (package name agreed by Cyril Brulebois).
   * Override a spelling error in the binary-only part of the kernel module.
   * Drop override for no longer emitted experimental shlib-calls-exit.
Checksums-Sha1: 
 4c94489d9bf844ca7e5b40237f3bf4c651500dfa 2352 nvidia-graphics-drivers_275.09.07-2.dsc
 f4683724a23543d6f2fd6cd329382d23381a7645 85920 nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 36e1835d2bd01f3598005d1b055cb68fb0c94e07 323620 nvidia-glx_275.09.07-2_i386.deb
 87d62d7967a28d8b900b2e89f9129c6f750b507e 3654148 xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 9f0f0081af94f612bb25bdabc6a83b80782a71cf 7833520 libgl1-nvidia-glx_275.09.07-2_i386.deb
 c4edd92a05cc1c9abddb437ce3752328ad785fd0 64588 nvidia-alternative_275.09.07-2_i386.deb
 ecf3f6c1fee74f062ac51b7b918ebcc64fd033d7 8970238 nvidia-kernel-dkms_275.09.07-2_i386.deb
 41db97f6306d0626f9488ce9bb5af3aa40ec0dd9 8362560 nvidia-kernel-source_275.09.07-2_i386.deb
 990d162c8f4950148c24e3ab0d0f27375748aa65 1044898 nvidia-vdpau-driver_275.09.07-2_i386.deb
 5dc4968e35b684165fc7191442271438f3ea99c6 89928 nvidia-smi_275.09.07-2_i386.deb
 71d94c62480ceb5c242da512aca3b42ef72024c5 4493812 libcuda1_275.09.07-2_i386.deb
 50be55c117497a211adc13c78e6977ba687671ec 7413334 libnvidia-compiler_275.09.07-2_i386.deb
 487a1ef511f0e36dcd07607818c5017b1e50077e 1168740 libnvcuvid1_275.09.07-2_i386.deb
 d67d311ec714c20a03a576d7d5bbdf0aa502473a 100626 libnvidia-ml1_275.09.07-2_i386.deb
 bddc37a9363b87f6d188133d904ccca9c0fe238c 63956 nvidia-opencl-common_275.09.07-2_i386.deb
 7e266173fb35f488ca0320d5f35cabca4be7e839 63844 nvidia-opencl-icd_275.09.07-2_i386.deb
 2b6c4d778560a7246230bcffecd8eaeba26d0e42 71782 nvidia-libopencl1_275.09.07-2_i386.deb
 1ac20a12e527a87fccb887225a5b8aafbb5eddab 63852 libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 af4090d20d925bab91733943a57262deed2406bf 63792 libglx-nvidia-alternatives_275.09.07-2_i386.deb
Checksums-Sha256: 
 90b552a33b162f2466b931fb7fe759cfdeedd5ec6f7a0ad63a4464e98e9f8b55 2352 nvidia-graphics-drivers_275.09.07-2.dsc
 b927649a41505aa7c6db4fa04502dc149a04734c8e51e19609cbe2360293ef29 85920 nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 36a738a71c06cff485fa7ca87dc322382b09045c279b23b68645fa40cec29345 323620 nvidia-glx_275.09.07-2_i386.deb
 5b980aa427c10cef625467b7fdbee637a39bc5feb7fa4c6c1e8ac5741c68d77c 3654148 xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 a1fafe1d55e81a219c92a3600ebe0188f0ab780ffcb1e42716ee23a80c71dfe8 7833520 libgl1-nvidia-glx_275.09.07-2_i386.deb
 897d58c57a61446b0fde1c3155a182d85124cf770301d33b7e819516fbfcbed9 64588 nvidia-alternative_275.09.07-2_i386.deb
 2c1b817dab5359943f31bec2d3eab3d1e689ec1a26d5bdf6696e7c911924599c 8970238 nvidia-kernel-dkms_275.09.07-2_i386.deb
 c9ce382e8f3cb09bee436396ce461cd6598b887a6d908c7d10811dff22eb3b85 8362560 nvidia-kernel-source_275.09.07-2_i386.deb
 4dc94d6088b269a7a167a835829eb5d0ea5b13673072521c7472c7b80c5b5115 1044898 nvidia-vdpau-driver_275.09.07-2_i386.deb
 d7ad3749894ab47547072ec3dce02a1b0d1aef41e588e2621c3613ed159892e6 89928 nvidia-smi_275.09.07-2_i386.deb
 1505b05a14968050b56d04bd1a99bee2bcdae7c888258fae1d9940ce2ba8493e 4493812 libcuda1_275.09.07-2_i386.deb
 0a990b983c82ce55d6d46be16517a2a811ce15a81fb1239dc43e6cf5faff4487 7413334 libnvidia-compiler_275.09.07-2_i386.deb
 b5ceea9a56d10f5327f7f41a5818e969a1408dc52d22a6f6269d90e5bb8343a2 1168740 libnvcuvid1_275.09.07-2_i386.deb
 37549c1c6e1d0ae077bd8d599fa235d350166f4d410c0522990e19d1bf8ee738 100626 libnvidia-ml1_275.09.07-2_i386.deb
 5891bf22422a6006fb4441378dab4436e4358e6270644b817c6cb298c94d2a2d 63956 nvidia-opencl-common_275.09.07-2_i386.deb
 6c06f379c4dd6edbd90bea09a3a39ec9864a012c4d58843fb17c986f7fd7b140 63844 nvidia-opencl-icd_275.09.07-2_i386.deb
 7b58d7102f90b7e663207e73aba94f9abac13aa18e9eebaf4849d8dbcd93a897 71782 nvidia-libopencl1_275.09.07-2_i386.deb
 51c6656ef54ad1362531897d95eb9491f819fadcdce9d592d1b268498e465c24 63852 libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 7d2a34d8a5820adbe88e3b02ad24b671fb5cdcc39d29343fba7353277f0020a5 63792 libglx-nvidia-alternatives_275.09.07-2_i386.deb
Files: 
 c3ee178e4df0128075ef45585c09ece5 2352 non-free/libs optional nvidia-graphics-drivers_275.09.07-2.dsc
 59dfaf4342326e19a2ecbd1c55ec5dd9 85920 non-free/libs optional nvidia-graphics-drivers_275.09.07-2.debian.tar.gz
 f063658eb77dbe4f42e09d9803f78ed1 323620 non-free/x11 optional nvidia-glx_275.09.07-2_i386.deb
 883d3e7ac1a819ea98aa120b06ddc0a9 3654148 non-free/x11 optional xserver-xorg-video-nvidia_275.09.07-2_i386.deb
 284d2ef6b8b5053840ca4e7a82514182 7833520 non-free/libs optional libgl1-nvidia-glx_275.09.07-2_i386.deb
 db0baad8f7d71b362eba9bca04aeb4d0 64588 non-free/libs optional nvidia-alternative_275.09.07-2_i386.deb
 3108b3a1cf44185ee9dee4581da9620d 8970238 non-free/kernel optional nvidia-kernel-dkms_275.09.07-2_i386.deb
 f5298520c0177fc17054d7d87eadac90 8362560 non-free/kernel optional nvidia-kernel-source_275.09.07-2_i386.deb
 7421cae459db96a0badac06d84e06eb9 1044898 non-free/libs optional nvidia-vdpau-driver_275.09.07-2_i386.deb
 37d33c00a4062bc4c6c898d7ef67a7df 89928 non-free/utils optional nvidia-smi_275.09.07-2_i386.deb
 bd4fce8461fc6e8e2a28371326df25e5 4493812 non-free/libs optional libcuda1_275.09.07-2_i386.deb
 f8b4bdc99d0021dbaa2a52c273473bfb 7413334 non-free/libs optional libnvidia-compiler_275.09.07-2_i386.deb
 c5ece7fecb68d6e32d690f602e86178b 1168740 non-free/libs optional libnvcuvid1_275.09.07-2_i386.deb
 656226c652b9d627bde69a4b58e2553d 100626 non-free/libs optional libnvidia-ml1_275.09.07-2_i386.deb
 e88e4aecb83044787eaedae1f1524644 63956 non-free/libs optional nvidia-opencl-common_275.09.07-2_i386.deb
 69026aceaddb21d79c1d601562c1b1ff 63844 non-free/libs optional nvidia-opencl-icd_275.09.07-2_i386.deb
 9c767eb1793536824a66dc16de6fb5d9 71782 non-free/libs optional nvidia-libopencl1_275.09.07-2_i386.deb
 6cb1617c214ca8249d14a779ddd15e45 63852 non-free/oldlibs optional libgl1-nvidia-alternatives_275.09.07-2_i386.deb
 434dfbe39f1df2912ee98e348e531d7a 63792 non-free/oldlibs optional libglx-nvidia-alternatives_275.09.07-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAEBCAAGBQJN/ocLAAoJEH2AMVxXNt51xecIAKdG/UPIAB+Yt033AxgEfV9u
R8N0FWrXK4qflyMylD5Z+UIvkVNEFgGKr3JTrJ8r0WpEgDsXd5ob5impfG63D50a
iq6Ydd+WCEiD8hF+eEsnleLc3oE9fLlZTLfRk++Pq1vVfIVVc1MVCfzBY5jWddPm
5SP3ZtY7fSigu05qEewVpGZh5WuyZgdMHyrKXdYm/CB3tbxmpmamY+XZLRLaUcoe
jNfNOesko5Z9rXMRkNlfoPw1oqJkT7H/6dZylYLinBclMD0ozsB24ynOLtaN/819
TBM7O8qF7ryzKl2b8qlyAZOP9KP6RQc0mkaF8xOMiMUmT+39lRnDupMKASIhR2M=
=rfYg
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Fri, 24 Jun 2011 19:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Joseph Parker <vactevo@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 24 Jun 2011 19:51:03 GMT) Full text and rfc822 format available.

Message #47 received at 630579@bugs.debian.org (full text, mbox):

From: Joseph Parker <vactevo@googlemail.com>
To: 630579@bugs.debian.org
Subject: Re: Bug#630579: fixed in nvidia-graphics-drivers 275.09.07-2
Date: Fri, 24 Jun 2011 21:48:30 +0200
Hi,
updated to 275.09.07-3 from experimental.
nvidia graphics now working again.
Thanks Andreas.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#630579; Package nvidia-glx. (Sun, 03 Jul 2011 10:12:53 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sophoklis Goumas <olspookishmagus@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 03 Jul 2011 10:12:57 GMT) Full text and rfc822 format available.

Message #52 received at 630579@bugs.debian.org (full text, mbox):

From: Sophoklis Goumas <olspookishmagus@gmail.com>
To: Debian Bug Tracking System <630579@bugs.debian.org>
Subject: Re: Bug#630579: fixed in nvidia-glx 275.09.07-4
Date: Sun, 03 Jul 2011 13:09:05 +0300
Package: nvidia-glx
Followup-For: Bug #630579

As of version 275.09.07-4 GLX is utilised back again.

-- Package-specific info:
uname -a:
Linux sojourn 2.6.39-2-686-pae #1 SMP Wed Jun 8 11:33:14 UTC 2011 i686 GNU/Linux

/proc/version:
Linux version 2.6.39-2-686-pae (Debian 2.6.39-2) (ben@decadent.org.uk) (gcc version 4.4.6 (Debian 4.4.6-3) ) #1 SMP Wed Jun 8 11:33:14 UTC 2011

/proc/driver/nvidia/version:
NVRM version: NVIDIA UNIX x86 Kernel Module  275.09.07  Wed Jun  8 15:42:20 PDT 2011
GCC version:  gcc version 4.4.6 (Debian 4.4.6-6) 

lspci 'VGA compatible controller [0300]':
01:00.0 VGA compatible controller [0300]: nVidia Corporation GF104 [GeForce GTX 460] [10de:0e22] (rev a1) (prog-if 00 [VGA controller])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=32M]
	Region 1: Memory at e8000000 (64-bit, prefetchable) [size=128M]
	Region 3: Memory at e4000000 (64-bit, prefetchable) [size=64M]
	Region 5: I/O ports at bc00 [size=128]
	[virtual] Expansion ROM at f7b00000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia

OpenGL and NVIDIA library files installed:
lrwxrwxrwx 1 root root       15 Jul  2 21:25 /etc/alternatives/glx -> /usr/lib/nvidia
lrwxrwxrwx 1 root root       41 Jul  2 21:25 /etc/alternatives/glx--libGL.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/libGL.so.1
lrwxrwxrwx 1 root root       41 Jul  2 21:25 /etc/alternatives/glx--libGL.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/libGL.so.1
lrwxrwxrwx 1 root root       49 Jul  2 21:25 /etc/alternatives/glx--libXvMCNVIDIA.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/libXvMCNVIDIA.so.1
lrwxrwxrwx 1 root root       57 Jul  2 21:25 /etc/alternatives/glx--libXvMCNVIDIA_dynamic.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/libXvMCNVIDIA_dynamic.so.1
lrwxrwxrwx 1 root root       25 Jul  2 21:25 /etc/alternatives/glx--libglx.so -> /usr/lib/nvidia/libglx.so
lrwxrwxrwx 1 root root       49 Jul  2 21:25 /etc/alternatives/glx--libnvidia-cfg.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/libnvidia-cfg.so.1
lrwxrwxrwx 1 root root       36 Jul  2 21:25 /etc/alternatives/glx--nvidia-bug-report.sh -> /usr/lib/nvidia/nvidia-bug-report.sh
lrwxrwxrwx 1 root root       29 Jul  2 21:25 /etc/alternatives/glx--nvidia_drv.so -> /usr/lib/nvidia/nvidia_drv.so
lrwxrwxrwx 1 root root       24 Jun 15 11:49 /etc/alternatives/libGL.so -> /usr/lib/nvidia/libGL.so
lrwxrwxrwx 1 root root       23 Jul  2 21:25 /etc/alternatives/nvidia -> /usr/lib/nvidia/current
lrwxrwxrwx 1 root root       49 Jul  2 21:25 /etc/alternatives/nvidia--libGL.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/current/libGL.so.1
lrwxrwxrwx 1 root root       49 Jul  2 21:25 /etc/alternatives/nvidia--libGL.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/current/libGL.so.1
lrwxrwxrwx 1 root root       57 Jul  2 21:25 /etc/alternatives/nvidia--libXvMCNVIDIA.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/current/libXvMCNVIDIA.so.1
lrwxrwxrwx 1 root root       65 Jul  2 21:25 /etc/alternatives/nvidia--libXvMCNVIDIA_dynamic.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/current/libXvMCNVIDIA_dynamic.so.1
lrwxrwxrwx 1 root root       33 Jul  2 21:25 /etc/alternatives/nvidia--libglx.so -> /usr/lib/nvidia/current/libglx.so
lrwxrwxrwx 1 root root       57 Jul  2 21:25 /etc/alternatives/nvidia--libnvidia-cfg.so.1-i386-linux-gnu -> /usr/lib/i386-linux-gnu/nvidia/current/libnvidia-cfg.so.1
lrwxrwxrwx 1 root root       44 Jul  2 21:25 /etc/alternatives/nvidia--nvidia-bug-report.sh -> /usr/lib/nvidia/current/nvidia-bug-report.sh
lrwxrwxrwx 1 root root       37 Jul  2 21:25 /etc/alternatives/nvidia--nvidia_drv.so -> /usr/lib/nvidia/current/nvidia_drv.so
lrwxrwxrwx 1 root root       48 Jul  2 21:25 /usr/lib/i386-linux-gnu/libGL.so.1 -> /etc/alternatives/glx--libGL.so.1-i386-linux-gnu
lrwxrwxrwx 1 root root       56 Jul  2 21:25 /usr/lib/i386-linux-gnu/libnvidia-cfg.so.1 -> /etc/alternatives/glx--libnvidia-cfg.so.1-i386-linux-gnu
-rw-r--r-- 1 root root 25950132 Jun  9 02:00 /usr/lib/i386-linux-gnu/libnvidia-glcore.so.275.09.07
-rw-r--r-- 1 root root     7160 Jun  9 02:04 /usr/lib/i386-linux-gnu/libnvidia-tls.so.275.09.07

/usr/lib/i386-linux-gnu/nvidia/:
total 24
drwxr-xr-x  3 root root  4096 Jul  2 21:25 .
drwxr-xr-x 15 root root 12288 Jul  2 22:07 ..
drwxr-xr-x  2 root root  4096 Jul  2 21:25 current
lrwxrwxrwx  1 root root    51 Jul  2 21:25 libGL.so.1 -> /etc/alternatives/nvidia--libGL.so.1-i386-linux-gnu
lrwxrwxrwx  1 root root    59 Jul  2 21:25 libXvMCNVIDIA.so.1 -> /etc/alternatives/nvidia--libXvMCNVIDIA.so.1-i386-linux-gnu
lrwxrwxrwx  1 root root    67 Jul  2 21:25 libXvMCNVIDIA_dynamic.so.1 -> /etc/alternatives/nvidia--libXvMCNVIDIA_dynamic.so.1-i386-linux-gnu
lrwxrwxrwx  1 root root    59 Jul  2 21:25 libnvidia-cfg.so.1 -> /etc/alternatives/nvidia--libnvidia-cfg.so.1-i386-linux-gnu

/usr/lib/i386-linux-gnu/nvidia/current/:
total 1108
drwxr-xr-x 2 root root   4096 Jul  2 21:25 .
drwxr-xr-x 3 root root   4096 Jul  2 21:25 ..
lrwxrwxrwx 1 root root     18 Jun 28 00:35 libGL.so.1 -> libGL.so.275.09.07
-rw-r--r-- 1 root root 790756 Jun  9 02:01 libGL.so.275.09.07
lrwxrwxrwx 1 root root     26 Jun 28 00:35 libXvMCNVIDIA.so.1 -> libXvMCNVIDIA.so.275.09.07
-rw-r--r-- 1 root root 182964 Jun  9 01:47 libXvMCNVIDIA.so.275.09.07
lrwxrwxrwx 1 root root     26 Jun 28 00:35 libXvMCNVIDIA_dynamic.so.1 -> libXvMCNVIDIA.so.275.09.07
lrwxrwxrwx 1 root root     26 Jun 28 00:35 libnvidia-cfg.so.1 -> libnvidia-cfg.so.275.09.07
-rw-r--r-- 1 root root 131944 Jun  9 02:05 libnvidia-cfg.so.275.09.07

/usr/lib/mesa-diverted/:
total 556
drwxr-xr-x   4 root root   4096 Jul  2 22:10 .
drwxr-xr-x 319 root root 131072 Jul  3 13:04 ..
drwxr-xr-x   2 root root   4096 Jul  2 21:25 i386-linux-gnu
-rw-r--r--   1 root root 413912 Jul  2 13:56 libglx.so
drwxr-xr-x   2 root root   4096 Jun 29 20:27 x86_64-linux-gnu

/usr/lib/mesa-diverted/i386-linux-gnu/:
total 396
drwxr-xr-x 2 root root   4096 Jul  2 21:25 .
drwxr-xr-x 4 root root   4096 Jul  2 22:10 ..
lrwxrwxrwx 1 root root     12 Jun 19 20:02 libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 391184 Jun 19 20:02 libGL.so.1.2

/usr/lib/mesa-diverted/x86_64-linux-gnu/:
total 8
drwxr-xr-x 2 root root 4096 Jun 29 20:27 .
drwxr-xr-x 4 root root 4096 Jul  2 22:10 ..

/usr/lib/nvidia/:
total 148
drwxr-xr-x   3 root root   4096 Jul  2 21:25 .
drwxr-xr-x 319 root root 131072 Jul  3 13:04 ..
-rwxr-xr-x   1 root root   1338 May 16 04:01 check-for-conflicting-opengl-libraries
drwxr-xr-x   2 root root   4096 Jul  2 21:25 current
lrwxrwxrwx   1 root root     26 Jun 15 11:49 libGL.so -> /usr/lib/nvidia/libGL.so.1
lrwxrwxrwx   1 root root     35 Jul  2 21:25 libglx.so -> /etc/alternatives/nvidia--libglx.so
lrwxrwxrwx   1 root root     24 Jul  2 21:25 nvidia -> /etc/alternatives/nvidia
lrwxrwxrwx   1 root root     46 Jul  2 21:25 nvidia-bug-report.sh -> /etc/alternatives/nvidia--nvidia-bug-report.sh
lrwxrwxrwx   1 root root     39 Jul  2 21:25 nvidia_drv.so -> /etc/alternatives/nvidia--nvidia_drv.so
-rwxr-xr-x   1 root root    441 May 16 04:01 pre-install

/usr/lib/nvidia/current/:
total 10336
drwxr-xr-x 2 root root    4096 Jul  2 21:25 .
drwxr-xr-x 3 root root    4096 Jul  2 21:25 ..
lrwxrwxrwx 1 root root      19 Jun 28 00:35 libglx.so -> libglx.so.275.09.07
-rw-r--r-- 1 root root 3842128 Jun  9 02:04 libglx.so.275.09.07
-rwxr-xr-x 1 root root   13393 May 18 03:02 nvidia-bug-report.sh
-rw-r--r-- 1 root root    5895 Jun 28 00:35 nvidia.ids
-rw-r--r-- 1 root root 6687320 Jun  9 01:47 nvidia_drv.so

/usr/lib/nvidia/nvidia/:
total 10336
drwxr-xr-x 2 root root    4096 Jul  2 21:25 .
drwxr-xr-x 3 root root    4096 Jul  2 21:25 ..
lrwxrwxrwx 1 root root      19 Jun 28 00:35 libglx.so -> libglx.so.275.09.07
-rw-r--r-- 1 root root 3842128 Jun  9 02:04 libglx.so.275.09.07
-rwxr-xr-x 1 root root   13393 May 18 03:02 nvidia-bug-report.sh
-rw-r--r-- 1 root root    5895 Jun 28 00:35 nvidia.ids
-rw-r--r-- 1 root root 6687320 Jun  9 01:47 nvidia_drv.so

Files from nvidia-installer:


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.39-2-686-pae (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nvidia-glx depends on:
ii  dpkg                1.16.0.3             Debian package management system
ii  libgl1-nvidia-glx   275.09.07-4          NVIDIA binary OpenGL libraries
ii  nvidia-alternative  275.09.07-4          allows the selection of NVIDIA as 
ii  nvidia-installer-cl 20110515+1           Cleanup after driver installation 
ii  nvidia-kernel-2.6.3 275.09.07-1+2.6.39-2 NVIDIA binary kernel module for Li
ii  nvidia-kernel-dkms  275.09.07-4          NVIDIA binary kernel module DKMS s
ii  nvidia-support      20110515+1           NVIDIA binary graphics driver supp
ii  nvidia-vdpau-driver 275.09.07-4          NVIDIA vdpau driver
ii  xserver-xorg-video- 275.09.07-4          NVIDIA binary Xorg driver

nvidia-glx recommends no packages.

Versions of packages nvidia-glx suggests:
ii  nvidia-kernel-dkms [nvidia-k 275.09.07-4 NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source         275.09.07-4 NVIDIA binary kernel module source
ii  nvidia-settings              275.09.07-1 Tool for configuring the NVIDIA gr

Versions of packages libgl1-nvidia-glx depends on:
ii  libc6                        2.13-8      Embedded GNU C Library: Shared lib
ii  libx11-6                     2:1.4.3-2   X11 client-side library
ii  libxext6                     2:1.3.0-3   X11 miscellaneous extension librar
ii  libxv1                       2:1.0.6-1   X11 Video extension library
ii  libxvmc1                     2:1.0.6-1   X11 Video extension library
ii  multiarch-support            2.13-8      Transitional package to ensure mul
ii  nvidia-alternative           275.09.07-4 allows the selection of NVIDIA as 
ii  nvidia-installer-cleanup     20110515+1  Cleanup after driver installation 

Versions of packages libgl1-nvidia-glx recommends:
ii  nvidia-kernel-2.6.3 275.09.07-1+2.6.39-2 NVIDIA binary kernel module for Li
ii  nvidia-kernel-dkms  275.09.07-4          NVIDIA binary kernel module DKMS s

Versions of packages libgl1-nvidia-glx suggests:
ii  nvidia-kernel-dkms [nvidia-k 275.09.07-4 NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source         275.09.07-4 NVIDIA binary kernel module source

Versions of packages xserver-xorg-video-nvidia depends on:
ii  dpkg                      1.16.0.3       Debian package management system
ii  libc6                     2.13-8         Embedded GNU C Library: Shared lib
ii  libgl1-nvidia-glx         275.09.07-4    NVIDIA binary OpenGL libraries
ii  nvidia-alternative        275.09.07-4    allows the selection of NVIDIA as 
ii  nvidia-installer-cleanup  20110515+1     Cleanup after driver installation 
ii  xserver-xorg-core [xorg-v 2:1.10.2.902-1 Xorg X server - core server

Versions of packages xserver-xorg-video-nvidia recommends:
ii  nvidia-kernel-2.6.3 275.09.07-1+2.6.39-2 NVIDIA binary kernel module for Li
ii  nvidia-kernel-dkms  275.09.07-4          NVIDIA binary kernel module DKMS s
ii  nvidia-vdpau-driver 275.09.07-4          NVIDIA vdpau driver

Versions of packages xserver-xorg-video-nvidia suggests:
ii  nvidia-kernel-dkms [nvidia-k 275.09.07-4 NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source         275.09.07-4 NVIDIA binary kernel module source
ii  nvidia-settings              275.09.07-1 Tool for configuring the NVIDIA gr

Versions of packages nvidia-alternative depends on:
ii  glx-alternative-nvidia        0.1.3      allows the selection of NVIDIA as 

Versions of packages nvidia-kernel-dkms depends on:
ii  dkms                          2.1.1.2-6  Dynamic Kernel Module Support Fram
ii  nvidia-installer-cleanup      20110515+1 Cleanup after driver installation 
ii  nvidia-kernel-common          20110515+1 NVIDIA binary kernel module suppor

nvidia-kernel-dkms recommends no packages.

Versions of packages nvidia-kernel-source depends on:
ii  debhelper                     8.9.0      helper programs for debian/rules
ii  make                          3.81-8.1   An utility for Directing compilati
ii  quilt                         0.48-7     Tool to work with series of patche

Versions of packages nvidia-kernel-source recommends:
ii  kernel-package               12.036+nmu1 A utility for building Linux kerne
ii  module-assistant             0.11.4      tool to make module package creati
ii  nvidia-kernel-common         20110515+1  NVIDIA binary kernel module suppor

nvidia-kernel-source suggests no packages.

Versions of packages nvidia-glx is related to:
ii  linux-headers-2.6-686 [li 2.6.38+34      Header files for Linux 2.6-686 (me
ii  linux-headers-2.6.32-5-68 2.6.32-31      Header files for Linux 2.6.32-5-68
ii  linux-headers-2.6.32-5-68 2.6.32-31      Header files for Linux 2.6.32-5-68
ii  linux-headers-2.6.38-2-68 2.6.38-5       Header files for Linux 2.6.38-2-68
ii  linux-headers-2.6.38-2-68 2.6.38-5       Header files for Linux 2.6.38-2-68
ii  linux-headers-2.6.39-1-68 2.6.39-1       Header files for Linux 2.6.39-1-68
ii  linux-headers-2.6.39-2-68 2.6.39-2       Header files for Linux 2.6.39-2-68
ii  nvidia-glx                275.09.07-4    NVIDIA metapackage
ii  nvidia-kernel-common      20110515+1     NVIDIA binary kernel module suppor
ii  nvidia-kernel-dkms [nvidi 275.09.07-4    NVIDIA binary kernel module DKMS s
ii  nvidia-kernel-source      275.09.07-4    NVIDIA binary kernel module source
ii  xserver-xorg              1:7.6+7        X.Org X server
ii  xserver-xorg-core         2:1.10.2.902-1 Xorg X server - core server

-- no debconf information




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 01 Aug 2011 07:39:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 02:52:21 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.