Debian Bug report logs - #630275
gnome-packagekit: Please transition to libnotify 0.7

version graph

Package: src:gnome-packagekit; Maintainer for src:gnome-packagekit is Matthias Klumpp <mak@debian.org>;

Reported by: bigon@debian.org

Date: Sun, 12 Jun 2011 19:39:51 UTC

Severity: serious

Tags: sid, wheezy

Found in version gnome-packagekit/2.32.0-2

Fixed in versions gnome-packagekit/3.0.3-1, gnome-packagekit/3.0.3-2

Done: Matthias Klumpp <matthias@tenstral.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to Matthias Klumpp <matthias@nlinux.org>:
Bug#630275; Package src:gnome-packagekit. (Sun, 12 Jun 2011 19:39:54 GMT) Full text and rfc822 format available.

Acknowledgement sent to bigon@debian.org:
New Bug report received and forwarded. Copy sent to Matthias Klumpp <matthias@nlinux.org>. (Sun, 12 Jun 2011 19:39:54 GMT) Full text and rfc822 format available.

Message #5 received at maintonly@bugs.debian.org (full text, mbox):

From: bigon@debian.org
To: maintonly@bugs.debian.org
Subject: gnome-packagekit: Please transition to libnotify 0.7
Date: Sun, 12 Jun 2011 21:38:28 +0200
Source: gnome-packagekit
Version: 2.32.0-2
Severity: important
User: pkg-gnome-maintainers@lists.alioth.debian.org
Usertags: libnotify0.7-transition

Hi,

We are planning to transition[0] libnotify to version 0.7 which
breaks its API.

Unfortunately, after a rebuild it seems that your package FTBFS with
the newer version.

Packages of the 0.7 version can be currently found in experimental.

API changes (shamelessly taken from[1]):
notify_notification_new_with_status_icon is gone
notify_notification_attach_to_status_icon is gone
notify_notification_attach_to_widget is gone
notify_notification_set_geometry_hints is gone
notify_notification_new has lost its widget argument

All rebuild logs can be found at:
http://people.debian.org/~bigon/libnotify0.7_rebuildlog/

Cheers

Laurent Bigonville

[0] http://release.debian.org/transitions/html/libnotify.html
[1] http://lists.fedoraproject.org/pipermail/devel/2010-November/144914.html 





Information stored :
Bug#630275; Package src:gnome-packagekit. (Sun, 12 Jun 2011 19:51:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matthias Klumpp <matthias@nlinux.org>:
Extra info received and filed, but not forwarded.

You requested that the message be sent to the package maintainer(s) but either the Bug report is not associated with any package (probably because of a missing Package pseudo-header field in the original Bug report), or the package(s) specified do not have any maintainer(s).

Your message has *not* been sent to any package maintainers; it has merely been filed in the Bug tracking system. If you require assistance please contact owner@bugs.debian.org quoting the Bug number 630275.

(Sun, 12 Jun 2011 19:51:06 GMT) Full text and rfc822 format available.


Message #10 received at 630275-maintonly@bugs.debian.org (full text, mbox):

From: Matthias Klumpp <matthias@nlinux.org>
To: <bigon@debian.org>, <630275-maintonly@bugs.debian.org>
Subject: Re: Bug#630275: gnome-packagekit: Please transition to libnotify 0.7
Date: Sun, 12 Jun 2011 21:49:23 +0200
Hi!
We have a new version of GNOME-PackageKit, which is currently in
experimental, as we can't upload it to unstable: It fails to build with
libnotify <= 0.5.
So, you can push it to unstable, as soon as the package is there we can
upload GNOME-PackageKit 3.0 to unstable, which works with LibNotify 0.7.
Thanks & kind regards
   Matthias

On Sun, 12 Jun 2011 21:38:28 +0200, bigon@debian.org wrote:
> Source: gnome-packagekit
> Version: 2.32.0-2
> Severity: important
> User: pkg-gnome-maintainers@lists.alioth.debian.org
> Usertags: libnotify0.7-transition
> 
> Hi,
> 
> We are planning to transition[0] libnotify to version 0.7 which
> breaks its API.
> 
> Unfortunately, after a rebuild it seems that your package FTBFS with
> the newer version.
> 
> Packages of the 0.7 version can be currently found in experimental.
> 
> API changes (shamelessly taken from[1]):
> notify_notification_new_with_status_icon is gone
> notify_notification_attach_to_status_icon is gone
> notify_notification_attach_to_widget is gone
> notify_notification_set_geometry_hints is gone
> notify_notification_new has lost its widget argument
> 
> All rebuild logs can be found at:
> http://people.debian.org/~bigon/libnotify0.7_rebuildlog/
> 
> Cheers
> 
> Laurent Bigonville
> 
> [0] http://release.debian.org/transitions/html/libnotify.html
> [1]
> http://lists.fedoraproject.org/pipermail/devel/2010-November/144914.html




Added indication that bug 630275 blocks 622363 Request was from Laurent Bigonville <bigon@debian.org> to control@bugs.debian.org. (Sun, 12 Jun 2011 19:51:34 GMT) Full text and rfc822 format available.

Added blocking bug(s) of 630275: 622363 Request was from Matthias Klumpp <matthias@nlinux.org> to control@bugs.debian.org. (Sun, 12 Jun 2011 19:57:03 GMT) Full text and rfc822 format available.

Bug Marked as fixed in versions gnome-packagekit/3.0.3-1. Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Sun, 12 Jun 2011 22:36:14 GMT) Full text and rfc822 format available.

Removed blocking bug(s) of 630275: 622363 Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Mon, 13 Jun 2011 08:49:31 GMT) Full text and rfc822 format available.

Added tag(s) sid and wheezy. Request was from Laurent Bigonville <bigon@debian.org> to control@bugs.debian.org. (Mon, 25 Jul 2011 16:12:15 GMT) Full text and rfc822 format available.

Severity set to 'serious' from 'important' Request was from Laurent Bigonville <bigon@debian.org> to control@bugs.debian.org. (Sun, 31 Jul 2011 16:39:13 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Matthias Klumpp <matthias@nlinux.org>:
Bug#630275; Package src:gnome-packagekit. (Fri, 05 Aug 2011 12:23:43 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Matthias Klumpp <matthias@nlinux.org>. (Fri, 05 Aug 2011 12:24:09 GMT) Full text and rfc822 format available.

Message #27 received at 630275@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: 630275@bugs.debian.org
Subject: gnome-packagekit: Please transition to libnotify 0.7
Date: Fri, 05 Aug 2011 14:20:14 +0200
[Message part 1 (text/plain, inline)]
Hi Matthias,

libnotify 0.7 is in unstable now.
Could you please upload gnome-packagekit 3.0 to unstable.
If you need a sponsor, let us know.

Michael

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Matthias Klumpp <matthias@nlinux.org>:
Bug#630275; Package src:gnome-packagekit. (Mon, 08 Aug 2011 17:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matthias Klumpp <matthias@tenstral.net>:
Extra info received and forwarded to list. Copy sent to Matthias Klumpp <matthias@nlinux.org>. (Mon, 08 Aug 2011 17:51:03 GMT) Full text and rfc822 format available.

Message #32 received at 630275@bugs.debian.org (full text, mbox):

From: Matthias Klumpp <matthias@tenstral.net>
To: Michael Biebl <biebl@debian.org>, <630275@bugs.debian.org>
Subject: Re: Bug#630275: gnome-packagekit: Please transition to libnotify 0.7
Date: Mon, 08 Aug 2011 19:49:48 +0200
On Fri, 05 Aug 2011 14:20:14 +0200, Michael Biebl <biebl@debian.org>
wrote:
> Hi Matthias,
> 
> libnotify 0.7 is in unstable now.
Cool, many thanks!

> Could you please upload gnome-packagekit 3.0 to unstable.
> If you need a sponsor, let us know.
I'm at Desktop-Summit right now, so I haven't had too much time. There is
one issue left which I need to resolve before the new GPK rev is ready,
I'll do that tomorrow. :)

Cheers,
   Matthias





Reply sent to Matthias Klumpp <matthias@tenstral.net>:
You have taken responsibility. (Tue, 09 Aug 2011 14:51:10 GMT) Full text and rfc822 format available.

Notification sent to bigon@debian.org:
Bug acknowledged by developer. (Tue, 09 Aug 2011 14:51:10 GMT) Full text and rfc822 format available.

Message #37 received at 630275-close@bugs.debian.org (full text, mbox):

From: Matthias Klumpp <matthias@tenstral.net>
To: 630275-close@bugs.debian.org
Subject: Bug#630275: fixed in gnome-packagekit 3.0.3-2
Date: Tue, 09 Aug 2011 14:48:13 +0000
Source: gnome-packagekit
Source-Version: 3.0.3-2

We believe that the bug you reported is fixed in the latest version of
gnome-packagekit, which is due to be installed in the Debian FTP archive:

gnome-packagekit-data_3.0.3-2_all.deb
  to main/g/gnome-packagekit/gnome-packagekit-data_3.0.3-2_all.deb
gnome-packagekit_3.0.3-2.debian.tar.gz
  to main/g/gnome-packagekit/gnome-packagekit_3.0.3-2.debian.tar.gz
gnome-packagekit_3.0.3-2.dsc
  to main/g/gnome-packagekit/gnome-packagekit_3.0.3-2.dsc
gnome-packagekit_3.0.3-2_amd64.deb
  to main/g/gnome-packagekit/gnome-packagekit_3.0.3-2_amd64.deb
python-packagekit-gtk_3.0.3-2_all.deb
  to main/g/gnome-packagekit/python-packagekit-gtk_3.0.3-2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 630275@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Matthias Klumpp <matthias@tenstral.net> (supplier of updated gnome-packagekit package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 05 Aug 2011 16:11:10 +0200
Source: gnome-packagekit
Binary: gnome-packagekit gnome-packagekit-data python-packagekit-gtk
Architecture: source amd64 all
Version: 3.0.3-2
Distribution: unstable
Urgency: low
Maintainer: Matthias Klumpp <matthias@tenstral.net>
Changed-By: Matthias Klumpp <matthias@tenstral.net>
Description: 
 gnome-packagekit - Graphical distribution neutral software management tools
 gnome-packagekit-data - Data files for graphical distribution neutral software management
 python-packagekit-gtk - Python GTK+ widgets for PackageKit clients
Closes: 630275 636191
Changes: 
 gnome-packagekit (3.0.3-2) unstable; urgency=low
 .
   * Upload to unstable (Closes: #630275)
   * Build-depend on rarian-compat (LP: #791497)
      This _might_ close this one too: (Closes: #636191)
   * Fix (possible) FTBFS due to GTK+ compile warnings (LP: #808992)
   * Remove DISABLE_DEPRECATED CPPFLAGS (otherwise might cause FTBFS on Sid)
   * Build-depend on gtk-doc-tools
   * Updated my email-address
Checksums-Sha1: 
 61d456e476f4e258b7057580f7ffaac94081582e 1666 gnome-packagekit_3.0.3-2.dsc
 8675c36754abf9ebed5187789a20eff25f98260c 5228 gnome-packagekit_3.0.3-2.debian.tar.gz
 bcfaca0c9e10c578ef20c6c7dc9a47b68decb4df 656234 gnome-packagekit_3.0.3-2_amd64.deb
 ec9e1d6d20de2b50d28fefd8d10a17e513cd8023 4706032 gnome-packagekit-data_3.0.3-2_all.deb
 06c78ee7ad5bc83e47ff65eb6357430550a7b7d6 221628 python-packagekit-gtk_3.0.3-2_all.deb
Checksums-Sha256: 
 f1a9ef029810e52be2e14e8383afb1bb00ea7d8159be16fe7cf296475f6e7225 1666 gnome-packagekit_3.0.3-2.dsc
 ce62fd4359e50b449ec83460f65f1dd2cdae65410c6604c12639051645f46e08 5228 gnome-packagekit_3.0.3-2.debian.tar.gz
 952e049aec383bd3fbe44df366cebc4709a4d6d36409e7436b8f33314258ca41 656234 gnome-packagekit_3.0.3-2_amd64.deb
 5d9cd4d64d9b9defb1f81e3b55fdfa061379f1a09abb54cc8c298710ff1f1db1 4706032 gnome-packagekit-data_3.0.3-2_all.deb
 0bf09f222b3cbd9c0c7adc9eea2aa12173fa0799cd412b1f70ba69d714e129bc 221628 python-packagekit-gtk_3.0.3-2_all.deb
Files: 
 33b6515bbe782c2b918ad745be372901 1666 gnome optional gnome-packagekit_3.0.3-2.dsc
 297076eecf508901404afe973540449f 5228 gnome optional gnome-packagekit_3.0.3-2.debian.tar.gz
 b59ef53c12f32a6af0f39b9ec1429778 656234 gnome optional gnome-packagekit_3.0.3-2_amd64.deb
 78897f6c0a884cb144a63c0fa7fc5a7b 4706032 gnome optional gnome-packagekit-data_3.0.3-2_all.deb
 0c1fb99e227da731a3192459657aa6eb 221628 python optional python-packagekit-gtk_3.0.3-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk5BOeYACgkQrCpf/gCCPsIVOwCfaX38s2CI7y7crS6rs//EZbtR
Es8AnjGj7m6gaprr4i25JsGDK4/vHy3k
=YiH/
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 13 Sep 2011 07:39:40 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 08:59:32 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.