Debian Bug report logs - #629882
buffy: FTBFS: PrefDialog.cc:108:78: error: call of overloaded 'ComboBox(Glib::RefPtr<Gtk::ListStore>&)' is ambiguous

version graph

Package: src:buffy; Maintainer for src:buffy is Enrico Zini <enrico@debian.org>;

Reported by: Didier Raboud <odyx@debian.org>

Date: Thu, 9 Jun 2011 08:21:01 UTC

Severity: serious

Tags: patch, sid, wheezy

Found in version buffy/1.2.1-1

Fixed in version buffy/1.2.1-1.1

Done: Neil Williams <codehelp@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Enrico Zini <enrico@debian.org>:
Bug#629882; Package src:buffy. (Thu, 09 Jun 2011 08:21:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Didier Raboud <odyx@debian.org>:
New Bug report received and forwarded. Copy sent to Enrico Zini <enrico@debian.org>. (Thu, 09 Jun 2011 08:21:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Didier Raboud <odyx@debian.org>
To: submit@bugs.debian.org
Subject: buffy: FTBFS: PrefDialog.cc:108:78: error: call of overloaded 'ComboBox(Glib::RefPtr<Gtk::ListStore>&)' is ambiguous
Date: Thu, 9 Jun 2011 10:20:01 +0200
Source: buffy
Version: 1.2.1-1
Severity: serious
Tags: wheezy sid
User: debian-qa@lists.debian.org
Usertags: qa-ftbfs-20110607 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part:
> g++ -DHAVE_CONFIG_H -I. -I..  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/cairomm-1.0 -I/usr/lib/cairomm-1.0/include   -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include      -g -O2 -g -O2 -Wall -Wall -c -o buffy-PrefDialog.o `test -f 'PrefDialog.cc' || echo './'`PrefDialog.cc
> PrefDialog.cc: In constructor 'PrefDialog::PrefDialog(Gtk::Window&)':
> PrefDialog.cc:108:78: error: call of overloaded 'ComboBox(Glib::RefPtr<Gtk::ListStore>&)' is ambiguous
> PrefDialog.cc:108:78: note: candidates are:
> /usr/include/gtkmm-2.4/gtkmm/combobox.h:145:12: note: Gtk::ComboBox::ComboBox(bool)
> /usr/include/gtkmm-2.4/gtkmm/combobox.h:137:12: note: Gtk::ComboBox::ComboBox(const Glib::RefPtr<Gtk::TreeModel>&)
> PrefDialog.cc:108:79: error: 'manage' was not declared in this scope
> PrefDialog.cc:108:79: note: suggested alternative:
> /usr/include/gtkmm-2.4/gtkmm/object.h:57:4: note:   'Gtk::manage'
> make[3]: *** [buffy-PrefDialog.o] Error 1

The full build log is available from:
   http://people.debian.org/~lucas/logs/2011/06/07/buffy_1.2.1-1_lsid64.buildlog

A list of current common problems and possible solutions is available at 
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot.  Internet was not
accessible from the build systems.




Information forwarded to debian-bugs-dist@lists.debian.org, Enrico Zini <enrico@debian.org>:
Bug#629882; Package src:buffy. (Sat, 14 Jan 2012 02:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to peter green <plugwash@p10link.net>:
Extra info received and forwarded to list. Copy sent to Enrico Zini <enrico@debian.org>. (Sat, 14 Jan 2012 02:27:03 GMT) Full text and rfc822 format available.

Message #10 received at 629882@bugs.debian.org (full text, mbox):

From: peter green <plugwash@p10link.net>
To: 629882@bugs.debian.org
Cc: control@bugs.debian.org
Subject: buffy: FTBFS: PrefDialog.cc:108:78: error: call of overloaded, 'ComboBox(Glib::RefPtr<Gtk::ListStore>&)' is ambiguous
Date: Sat, 14 Jan 2012 02:24:24 +0000
[Message part 1 (text/plain, inline)]
tags 629882 +patch
thanks

>Relevant part:
>> g++ -DHAVE_CONFIG_H -I. -I..  -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/gtk-unix-print-2.0 -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/cairomm-1.0 -I/usr/lib/cairomm-1.0/include   -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include      -g -O2 -g -O2 -Wall -Wall -c -o buffy-PrefDialog.o `test -f 'PrefDialog.cc' || echo './'`PrefDialog.cc
>> PrefDialog.cc: In constructor 'PrefDialog::PrefDialog(Gtk::Window&)':
>> PrefDialog.cc:108:78: error: call of overloaded 'ComboBox(Glib::RefPtr<Gtk::ListStore>&)' is ambiguous
>> PrefDialog.cc:108:78: note: candidates are:
>> /usr/include/gtkmm-2.4/gtkmm/combobox.h:145:12: note: Gtk::ComboBox::ComboBox(bool)
>> /usr/include/gtkmm-2.4/gtkmm/combobox.h:137:12: note: Gtk::ComboBox::ComboBox(const Glib::RefPtr<Gtk::TreeModel>&)
>> PrefDialog.cc:108:79: error: 'manage' was not declared in this scope
>> PrefDialog.cc:108:79: note: suggested alternative:
>> /usr/include/gtkmm-2.4/gtkmm/object.h:57:4: note:   'Gtk::manage'
>> make[3]: *** [buffy-PrefDialog.o] Error 1
Looks like ubuntu have already fixed this. The ubuntu source builds find in sid.

I have attatched the diff between the latest sid package and the package in ubuntu.
Before uploading to debian you will probablly want to get rid of the changes to
debian/control (just ubuntu's usual messing with maintainer fields) and adjust the
changelog entry but otherwise it seems fine for debian.



[buffy.diff (text/x-diff, attachment)]

Added tag(s) patch. Request was from peter green <plugwash@p10link.net> to control@bugs.debian.org. (Sat, 14 Jan 2012 02:27:05 GMT) Full text and rfc822 format available.

Reply sent to Neil Williams <codehelp@debian.org>:
You have taken responsibility. (Sun, 04 Mar 2012 15:51:08 GMT) Full text and rfc822 format available.

Notification sent to Didier Raboud <odyx@debian.org>:
Bug acknowledged by developer. (Sun, 04 Mar 2012 15:51:08 GMT) Full text and rfc822 format available.

Message #17 received at 629882-close@bugs.debian.org (full text, mbox):

From: Neil Williams <codehelp@debian.org>
To: 629882-close@bugs.debian.org
Subject: Bug#629882: fixed in buffy 1.2.1-1.1
Date: Sun, 04 Mar 2012 15:48:48 +0000
Source: buffy
Source-Version: 1.2.1-1.1

We believe that the bug you reported is fixed in the latest version of
buffy, which is due to be installed in the Debian FTP archive:

buffy_1.2.1-1.1.diff.gz
  to main/b/buffy/buffy_1.2.1-1.1.diff.gz
buffy_1.2.1-1.1.dsc
  to main/b/buffy/buffy_1.2.1-1.1.dsc
buffy_1.2.1-1.1_amd64.deb
  to main/b/buffy/buffy_1.2.1-1.1_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 629882@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Neil Williams <codehelp@debian.org> (supplier of updated buffy package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 04 Mar 2012 15:15:14 +0000
Source: buffy
Binary: buffy
Architecture: source amd64
Version: 1.2.1-1.1
Distribution: unstable
Urgency: low
Maintainer: Enrico Zini <enrico@debian.org>
Changed-By: Neil Williams <codehelp@debian.org>
Description: 
 buffy      - Heavy duty browser for mail folders
Closes: 629882
Changes: 
 buffy (1.2.1-1.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Apply Ubuntu patch from Daniel T Chen <crimsun@ubuntu.com>
     (Closes: #629882)
Checksums-Sha1: 
 ffa83425a9fd6465f87f84178c67249b2154c988 1273 buffy_1.2.1-1.1.dsc
 b7dd094490375dd723d336bd479f8137ca2c5b49 3591 buffy_1.2.1-1.1.diff.gz
 fbed4fcc9c8c97b2b41d734170348b59ca0ea4ac 155878 buffy_1.2.1-1.1_amd64.deb
Checksums-Sha256: 
 dd8f1721043f3380e414d8b798e0acf690fde4147f07cfb943e11e27d214f891 1273 buffy_1.2.1-1.1.dsc
 7919a19ee3842f9124fa068d8bcd47b0201f021f2788c608decc1a3e4649ec7d 3591 buffy_1.2.1-1.1.diff.gz
 07cdff8cb8d7a02e79823d5a29ffd78962175bcbcecae892af065c4528391c62 155878 buffy_1.2.1-1.1_amd64.deb
Files: 
 504d5756811add5925a138097232ea6f 1273 mail optional buffy_1.2.1-1.1.dsc
 44d01977ee139108894b9a3237f7f291 3591 mail optional buffy_1.2.1-1.1.diff.gz
 ea38caf960fe953d0b359b2a49216e71 155878 mail optional buffy_1.2.1-1.1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk9TitgACgkQiAEJSii8s+NTxgCfQXp3nGuEXer9o1sjuIl/UkxM
V+YAn0jUKhBcfMZ3aNvyJkIUQAr5UC8v
=KXwJ
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 12 Apr 2012 07:41:57 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 05:38:25 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.