Debian Bug report logs - #625392
mdadm: ftbfs with gcc-4.6 -Werror

version graph

Package: mdadm; Maintainer for mdadm is Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>; Source for mdadm is src:mdadm.

Reported by: Matthias Klose <doko@debian.org>

Date: Tue, 3 May 2011 11:01:52 UTC

Severity: serious

Tags: confirmed, fixed-upstream, sid, wheezy

Found in version mdadm/3.1.4-1+8efb9d1

Fixed in version mdadm/3.2.2-1

Done: madduck@debian.org (martin f. krafft)

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>:
Bug#625392; Package mdadm. (Tue, 03 May 2011 11:01:55 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matthias Klose <doko@debian.org>:
New Bug report received and forwarded. Copy sent to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>. (Tue, 03 May 2011 11:02:00 GMT) Full text and rfc822 format available.

Message #5 received at maintonly@bugs.debian.org (full text, mbox):

From: Matthias Klose <doko@debian.org>
To: maintonly@bugs.debian.org
Subject: mdadm: ftbfs with gcc-4.6 -Werror
Date: Tue, 03 May 2011 10:33:50 +0000
Package: mdadm
Version: 3.1.4-1+8efb9d1
Severity: important
Tags: wheezy sid
User: debian-gcc@lists.debian.org
Usertags: ftbfs-gcc-4.6 ftbfs-werror

This package builds with -Werror, and GCC 4.6 triggers new warnings
which will make the package fail to build.  Currently a Debian patch
just passes
    -Wno-error=unused-but-set-variable and
    -Wno-error=unused-but-set-parameter
to avoid build failures, but this patch will be reverted with the
GCC 4.6.1 release, and the severity of the report will be raised.

The full build log can be found at:
http://people.debian.org/~doko/tmp/werror/mdadm_3.1.4-1+8efb9d1_lsid64.buildlog
The last lines of the build log are at the end of this report.





Information forwarded to debian-bugs-dist@lists.debian.org, Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>:
Bug#625392; Package mdadm. (Sun, 03 Jul 2011 01:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Maxime Chatelle <mmyc@gmx.com>:
Extra info received and forwarded to list. Copy sent to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>. (Sun, 03 Jul 2011 01:48:03 GMT) Full text and rfc822 format available.

Message #10 received at 625392@bugs.debian.org (full text, mbox):

From: Maxime Chatelle <mmyc@gmx.com>
To: 625392@bugs.debian.org
Cc: martin f krafft <madduck@debian.org>, Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>, "control@bugs.debian.org" <control@bugs.debian.org>
Subject: RE: mdadm: ftbfs with gcc-4.6 -Werror
Date: Sun, 03 Jul 2011 03:46:46 +0200
[Message part 1 (text/plain, inline)]
tags 625392 confirmed
quit

Hi,

I reviewed these unused variables. None can cause problem in mdadm. I 
propose to simply remove -Werror from upstream Makefile, failing to 
build on warning don't make code better.

But, if you think is better to comment out these variables and 
associated dead code, I'm ready to make a little patch.

Cheers,
 xakz
-- 
Maxime Chatelle, human from earth, 010001111.cm94IGxvdmVyCg==.kpr
<mchatelle ↯ linux-france ↯ org> <mmyc ↯ gmx ↯ com>
79E0 25F5 06C5 5C7F F57C BADD 13EE 911A 8A1A 9DE9
[Message part 2 (application/pgp-signature, inline)]

Added tag(s) confirmed. Request was from Maxime Chatelle <mmyc@gmx.com> to control@bugs.debian.org. (Sun, 03 Jul 2011 01:48:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>:
Bug#625392; Package mdadm. (Sun, 03 Jul 2011 07:18:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to martin f krafft <madduck@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>. (Sun, 03 Jul 2011 07:18:07 GMT) Full text and rfc822 format available.

Message #17 received at 625392@bugs.debian.org (full text, mbox):

From: martin f krafft <madduck@debian.org>
To: Maxime Chatelle <mmyc@gmx.com>
Cc: 625392@bugs.debian.org
Subject: Re: mdadm: ftbfs with gcc-4.6 -Werror
Date: Sun, 3 Jul 2011 09:15:31 +0200
[Message part 1 (text/plain, inline)]
also sprach Maxime Chatelle <mmyc@gmx.com> [2011.07.03.0346 +0200]:
> I reviewed these unused variables. None can cause problem in
> mdadm. I propose to simply remove -Werror from upstream Makefile,
> failing to build on warning don't make code better.
>
> But, if you think is better to comment out these variables and
> associated dead code, I'm ready to make a little patch.

I think we should not remove -Werror but rather fix the cause.

-- 
 .''`.   martin f. krafft <madduck@d.o>      Related projects:
: :'  :  proud Debian developer               http://debiansystem.info
`. `'`   http://people.debian.org/~madduck    http://vcs-pkg.org
  `-  Debian - when you have better things to do than fixing systems
 
this product is under strict quality contril with perfect packing and
quality when leving the factory.please keep away from damp.high
temperature or sun expose.If found any detectives when purchasing.
please return the productby airmail to our administration section and
inform the time, place.and store of this purchase for our
improvement.We shall give you a satisfactory reply.Thanks for your
patronage and welcome your comments.
                                             -- http://www.engrish.com
[digital_signature_gpg.asc (application/pgp-signature, inline)]

Severity set to 'serious' from 'important' Request was from Matthias Klose <doko@debian.org> to control@bugs.debian.org. (Sat, 09 Jul 2011 09:53:45 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>:
Bug#625392; Package mdadm. (Wed, 13 Jul 2011 13:54:38 GMT) Full text and rfc822 format available.

Acknowledgement sent to Maxime Chatelle <mmyc@gmx.com>:
Extra info received and forwarded to list. Copy sent to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>. (Wed, 13 Jul 2011 13:54:38 GMT) Full text and rfc822 format available.

Message #24 received at 625392@bugs.debian.org (full text, mbox):

From: Maxime Chatelle <mmyc@gmx.com>
To: 625392@bugs.debian.org
Subject: Re: mdadm: ftbfs with gcc-4.6 -Werror
Date: Wed, 13 Jul 2011 15:28:49 +0200
[Message part 1 (text/plain, inline)]
Hi,

Sorry, with holidays, I lack of time.
Attached, a patch that comment out all unused variables and associated 
code.

This patch is mainly for stable because the to-be-packaged version 
(3.2.2) dont appear to have this issue (just quick checked, I'm not 
sure)

It build fine with the patch and gcc 4.6.1 :)

Cheers,
 xakz
-- 
Maxime Chatelle, human from earth, 010001111.cm94IGxvdmVyCg==.kpr
<mchatelle ↯ linux-france ↯ org> <mmyc ↯ gmx ↯ com>
79E0 25F5 06C5 5C7F F57C BADD 13EE 911A 8A1A 9DE9
[fix-ftbfs-for-gcc-4.6.1-unused-var-commented.patch (text/x-patch, attachment)]
[Message part 3 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>:
Bug#625392; Package mdadm. (Fri, 15 Jul 2011 10:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Scott Schaefer <saschaefer@neurodiverse.org>:
Extra info received and forwarded to list. Copy sent to Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>. (Fri, 15 Jul 2011 10:12:16 GMT) Full text and rfc822 format available.

Message #29 received at 625392@bugs.debian.org (full text, mbox):

From: Scott Schaefer <saschaefer@neurodiverse.org>
To: 625392@bugs.debian.org
Subject: Verified fix in 3.2.2
Date: Fri, 15 Jul 2011 06:10:50 -0400
I have verified upstream release 3.2.2 build under gcc 4.6.1 without 
errors with

gcc -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter






Added tag(s) fixed-upstream. Request was from Scott Schaefer <saschaefer@neurodiverse.org> to control@bugs.debian.org. (Fri, 15 Jul 2011 10:12:57 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from Michael Tokarev <mjt@tls.msk.ru> to control@bugs.debian.org. (Sat, 10 Sep 2011 11:24:35 GMT) Full text and rfc822 format available.

Reply sent to madduck@debian.org (martin f. krafft):
You have taken responsibility. (Thu, 15 Sep 2011 07:21:36 GMT) Full text and rfc822 format available.

Notification sent to Matthias Klose <doko@debian.org>:
Bug acknowledged by developer. (Thu, 15 Sep 2011 07:21:36 GMT) Full text and rfc822 format available.

Message #38 received at 625392-close@bugs.debian.org (full text, mbox):

From: madduck@debian.org (martin f. krafft)
To: 625392-close@bugs.debian.org
Subject: Bug#625392: fixed in mdadm 3.2.2-1
Date: Thu, 15 Sep 2011 07:17:22 +0000
Source: mdadm
Source-Version: 3.2.2-1

We believe that the bug you reported is fixed in the latest version of
mdadm, which is due to be installed in the Debian FTP archive:

mdadm-udeb_3.2.2-1_amd64.udeb
  to main/m/mdadm/mdadm-udeb_3.2.2-1_amd64.udeb
mdadm_3.2.2-1.debian.tar.bz2
  to main/m/mdadm/mdadm_3.2.2-1.debian.tar.bz2
mdadm_3.2.2-1.dsc
  to main/m/mdadm/mdadm_3.2.2-1.dsc
mdadm_3.2.2-1_amd64.deb
  to main/m/mdadm/mdadm_3.2.2-1_amd64.deb
mdadm_3.2.2.orig.tar.bz2
  to main/m/mdadm/mdadm_3.2.2.orig.tar.bz2



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 625392@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
martin f. krafft <madduck@debian.org> (supplier of updated mdadm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 01 Aug 2011 10:41:41 +0200
Source: mdadm
Binary: mdadm mdadm-udeb
Architecture: source amd64
Version: 3.2.2-1
Distribution: unstable
Urgency: low
Maintainer: Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>
Changed-By: martin f. krafft <madduck@debian.org>
Description: 
 mdadm      - tool to administer Linux MD arrays (software RAID)
 mdadm-udeb - tool to administer Linux MD arrays (software RAID) (udeb)
Closes: 595516 598957 604702 605722 610421 611627 611632 615494 618463 618561 621346 625392 628371 633054
Changes: 
 mdadm (3.2.2-1) unstable; urgency=low
 .
   [ martin f. krafft ]
   * New upstream version (closes: #615494), which addresses:
     - --grow option aware of size change of underlying device (closes: #618463)
     - builds with -Werror on gcc-4.6 (closes: #625392).
     - new features/functionality:
       + Policy framework.
       + Improved management of reshaping arrays.
       + Support for Intel Matrix Storage Manager (IMSM)
     Thanks to Scott Schaefer for his help in preparing this release!
   * Do not print io rescheduling info message when run by cron
     (closes: #598957).
   * Fix checkarray script so that it does not die after scheduling the first
     device when there is no scheduling class specified; thanks to Mario
     'BitKoenig' Holbe (closes: #611627).
   * Do not include DEVICE line in generated configs but use the built-in value
     by default (closes: #604702).
   * Make mdadm-raid init script depend on hostname; thanks to Mario
    'BitKoenig' Holbe (closes: #610421).
   * Schedule start/stop of mdadm-raid before/after filesystems are
     checked&mounted/unmounted; thanks to Mario 'BitKoenig' Holbe
     (closes: #611632).
   * Work around a shell coding bug for cases when there are zero active
     devices (closes: #618561).
   * Add NEWS entry about metadata change and requirement on new Grub version
     (closes: #595516).
   * Update mdadd.sh script from Arno's webpage.
   * Update md.txt from latest kernel source.
   * Updated debconf translations:
     - Catalan by Innocent De Marchi (closes: #628371)
     - Danish by Joe Dalton (closes: #621346)
   * Small typo fix in RAID5_versus_RAID10.txt
   * Bump Standards-Version to 3.9.2; no changes required.
 .
   [ Michael Tokarev ]
   * don't print W: auto-read-only in checkarray in quiet mode,
     thanks to Bernd Hanisch for the patch (Closes: #605722)
   * move initscript metadata from /lib/init/rw/.mdadm to /run/mdadm,
     and depend on initscripts (>= 2.88dsf-13.3) for /run (Closes: #633054)
   * move runtime stuff from /dev/.mdadm to /run/mdadm
   * document defaults change in debian/NEWS (it was forgotten to be
     done for squeeze) - metadata & chunk size (Closes: #595516)
Checksums-Sha1: 
 943859c83323631f3b6342e32720b41666322b9b 2190 mdadm_3.2.2-1.dsc
 8ec366a7e7f3ae3a8765d8f43f1d62234a80c698 357234 mdadm_3.2.2.orig.tar.bz2
 5ceadc639033fa656a7292374e4a294d0f1fcf5f 123535 mdadm_3.2.2-1.debian.tar.bz2
 4844110b4da321cc9c2b325537706cf03d77d0b6 536758 mdadm_3.2.2-1_amd64.deb
 47ac5f8c3b3cece7bc5ed20ddce16a9c70ec7aba 180836 mdadm-udeb_3.2.2-1_amd64.udeb
Checksums-Sha256: 
 b3aa33e3f3938aba2cc5056663175c8daa0732091d9a8875abe1debff60b17d4 2190 mdadm_3.2.2-1.dsc
 0d1a04e688b082bc88846e3f524abd50bc782b6ffc06123140f7d358c8f9b906 357234 mdadm_3.2.2.orig.tar.bz2
 9d94d66d79cda1deaaa8e5e68cb203327a5c69b629c9773004b9fb9d618e203e 123535 mdadm_3.2.2-1.debian.tar.bz2
 c23d8f0a7140fbae3a9ffd3dd4a563c21bffe0ec408e1f4f4ae5644413ceda71 536758 mdadm_3.2.2-1_amd64.deb
 0b2a3e56dbff6f4e192b69037ba304418f2813c6ab8dc9315219b9692d2e25dd 180836 mdadm-udeb_3.2.2-1_amd64.udeb
Files: 
 196025705dae8c288d569cb53241f1b9 2190 admin optional mdadm_3.2.2-1.dsc
 12ee2fbf3beddb60601fb7a4c4905651 357234 admin optional mdadm_3.2.2.orig.tar.bz2
 e8f0a9a45f116508eda17ad171514307 123535 admin optional mdadm_3.2.2-1.debian.tar.bz2
 5e48a3f95039af09a4957cdbcdc40090 536758 admin optional mdadm_3.2.2-1_amd64.deb
 eb26e081e822e69e64dd28cf063d0ce3 180836 debian-installer optional mdadm-udeb_3.2.2-1_amd64.udeb
Package-Type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQLvBAEBCgDZBQJOcaKXwBEaaHR0cDovL21hcnRpbi1rcmFmZnQubmV0L2dwZy9z
aWctcG9saWN5LzU1Yzk4ODJkOTk5YmJjYzQvMjAxMTAxMjQxMTI1P3NoYTUxMnN1
bT0xY2FkOTZmZDI3ZDMyMzNmNTNlMjI4NDk1MzM2NDgxMDdlNWVlOGQ1YmU2NTUy
NTFkNzRjOGYxYzVjM2JjNDJmMjMwNGZhNTE1MTUwZjdiZDRkZDA1ZTk4MTk5MjRm
MDQ5NTEzZWU5OTYyY2E3MTcwOWY4MWQ5NDUxNTg1MmJkOAAKCRBVyYgtmZu8xIlD
EACjaBhiT38IYF2rKx8GadkV8hjp5cFdUNSmMV9Mhoy3BefJuTs1YkQH8yYDazA6
XLkBxo1/34vZxyJr7a9+V0JqdDAnDHpUojg10a1T3LMFf5oV/+5HX173HadeWnFT
ZXSmhocb67uDDmq502XSOZYq9JE7RXis2Maf3Ln+gBGdnnWYke3wjr1WIWhMGALW
laPI6AQbMRpd+hdPv1jKvSmgNSPFwJq7OJudOKD+iN78536tP3hLJSbl4Mun8lsH
kjvOe+RcbemfHWLCGnIXbF6xrbnUgz7yiWwAjwZ9Yv/VkGw0sVjETzuGF875sY1P
qXFaxFhSTSglNCBHU6I4XCS0sgD9GuDRmqNPRiuqOouDGbofV9nbYwMt0JVQTyL8
rYQLlsz48dj/rMwQau67x8II89obThGa1vHQvO8XemMmmJhEWJaJZ8x4cmZ+1e/O
6AvUmfT6MiuHZ1phZhRy6gMpPjy0xkrSHeuIyllzz+E9pF4/OBOlrbmRHk0VJOo1
RzTACaD5ZL4OU1LE4QgBwt0ebc0uSiLM05UaEq7NL+UBPcZRqyq5CVyN7DNpBAY7
C4wYCc0Kti6B38SDbCNhmgYQMkQFlmph/t3aOrhLrSLPsQP0pH/349zvoBhganGM
mqXn6HECgy6EysT8wRQyB4C7eNfSB2fQTdAgmExILYf0qg==
=AsIz
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 14 Mar 2012 09:43:54 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 14:29:35 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.