Debian Bug report logs - #621878
gcj-4.4-jdk misses jni_md.h on kfreebsd

version graph

Package: gcj-4.4-jdk; Maintainer for gcj-4.4-jdk is Debian GCC Maintainers <debian-gcc@lists.debian.org>;

Reported by: Cyril Brulebois <kibi@debian.org>

Date: Sun, 10 Apr 2011 01:39:15 UTC

Severity: serious

Fixed in version db/5.1.25-4

Done: Ondřej Surý <ondrej@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, kibi@debian.org, Debian Berkeley DB Group <pkg-db-devel@alioth.debian.org>:
Bug#621878; Package src:db4.6. (Sun, 10 Apr 2011 01:39:18 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
New Bug report received and forwarded. Copy sent to kibi@debian.org, Debian Berkeley DB Group <pkg-db-devel@alioth.debian.org>. (Sun, 10 Apr 2011 01:39:18 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: db4.6: FTBFS on kfreebsd-*: jni.h:52:20: fatal error: jni_md.h: No such file or directory
Date: Sun, 10 Apr 2011 00:39:30 +0200
Source: db4.6
Version: 4.6.21-18
Severity: serious
Justification: FTBFS
User: debian-bsd@lists.debian.org
Usertags: kfreebsd

Hi,

your package no longer builds on kfreebsd-*, even with up-to-date
unstable chroots. Might be some java-ish issues, and not your bug
actually, feel free to clone/reassign where it belongs:
| /bin/sh ./libtool --mode=compile gcc -c -I. -I../dist/.. -I/usr/include/tcl8.5 -D_GNU_SOURCE -D_REENTRANT -Wall -g -O2  -fno-strict-aliasing -I/usr/lib/jvm/java-gcj/include ../dist/../libdb_java/db_java_wrap.c
|  gcc -c -I. -I../dist/.. -I/usr/include/tcl8.5 -D_GNU_SOURCE -D_REENTRANT -Wall -g -O2 -fno-strict-aliasing -I/usr/lib/jvm/java-gcj/include ../dist/../libdb_java/db_java_wrap.c  -fPIC -DPIC -o .libs/db_java_wrap.o
| In file included from ../dist/../libdb_java/db_java_wrap.c:123:0:
| /usr/lib/jvm/java-gcj/include/jni.h:52:20: fatal error: jni_md.h: No such file or directory
| compilation terminated.
| make[1]: *** [db_java_wrap.lo] Error 1

Full build logs:
  https://buildd.debian.org/status/package.php?p=db4.6

KiBi.




Reply sent to Ondřej Surý <ondrej@debian.org>:
You have taken responsibility. (Tue, 19 Apr 2011 19:21:25 GMT) Full text and rfc822 format available.

Notification sent to Cyril Brulebois <kibi@debian.org>:
Bug acknowledged by developer. (Tue, 19 Apr 2011 19:21:26 GMT) Full text and rfc822 format available.

Message #10 received at 621878-close@bugs.debian.org (full text, mbox):

From: Ondřej Surý <ondrej@debian.org>
To: 621878-close@bugs.debian.org
Subject: Bug#621878: fixed in db4.6 4.6.21-19
Date: Tue, 19 Apr 2011 19:18:14 +0000
Source: db4.6
Source-Version: 4.6.21-19

We believe that the bug you reported is fixed in the latest version of
db4.6, which is due to be installed in the Debian FTP archive:

db4.6-util_4.6.21-19_amd64.deb
  to main/d/db4.6/db4.6-util_4.6.21-19_amd64.deb
db4.6_4.6.21-19.debian.tar.gz
  to main/d/db4.6/db4.6_4.6.21-19.debian.tar.gz
db4.6_4.6.21-19.dsc
  to main/d/db4.6/db4.6_4.6.21-19.dsc
libdb4.6_4.6.21-19_amd64.deb
  to main/d/db4.6/libdb4.6_4.6.21-19_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 621878@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Ondřej Surý <ondrej@debian.org> (supplier of updated db4.6 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 19 Apr 2011 20:23:02 +0200
Source: db4.6
Binary: libdb4.6 db4.6-util
Architecture: source amd64
Version: 4.6.21-19
Distribution: unstable
Urgency: low
Maintainer: Debian Berkeley DB Group <pkg-db-devel@lists.alioth.debian.org>
Changed-By: Ondřej Surý <ondrej@debian.org>
Description: 
 db4.6-util - Berkeley v4.6 Database Utilities
 libdb4.6   - Berkeley v4.6 Database Libraries [runtime]
Closes: 257203 258831 449184 515931 621253 621878
Changes: 
 db4.6 (4.6.21-19) unstable; urgency=low
 .
   * Update Debian Berkeley DB Group list email
   * Remove obsolete Conflicts, move more packages to oldlibs
   * Remove Doc, C++, Java and TCL packages
     (Closes: #621878, #515931, #621253, #449184, #258831, #257203)
Checksums-Sha1: 
 1d71d3471f6d471f2161d05906d8abf2c9c16daf 1268 db4.6_4.6.21-19.dsc
 c06901cdf0d3410502c86a79aab57a74d1b05c2c 104040 db4.6_4.6.21-19.debian.tar.gz
 929a9fb21581d6707c2c47bd2fce9ef19003645f 604940 libdb4.6_4.6.21-19_amd64.deb
 fc420e16827724f5f9dc8d5a4fdb4dd0ca2ecc4b 116866 db4.6-util_4.6.21-19_amd64.deb
Checksums-Sha256: 
 f62d284e175d9b23d63eea6fea9c678d52f57448f0efef2ffed7d783880f5320 1268 db4.6_4.6.21-19.dsc
 880e649df3b326588feacb6e64650d8b69e1b02a9add0606b13ca132904c9457 104040 db4.6_4.6.21-19.debian.tar.gz
 3ebcd1dff4a0ab55ceffff2cef7ddabe6b0140c59560ecc867c3c0669e21674b 604940 libdb4.6_4.6.21-19_amd64.deb
 c2eeafddc63703e94286d3290853fa3b374bbee1def8a506800976408651ac7e 116866 db4.6-util_4.6.21-19_amd64.deb
Files: 
 e45fe1f35b443595aae0a3b062b4ca0d 1268 libs standard db4.6_4.6.21-19.dsc
 5649471b30a845d9e3c2c365d6e69db8 104040 libs standard db4.6_4.6.21-19.debian.tar.gz
 3a7a1f2facd69436449a076ebc970259 604940 oldlibs standard libdb4.6_4.6.21-19_amd64.deb
 be42af88acd413d0dd67a8ad8801e5b6 116866 database optional db4.6-util_4.6.21-19_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk2t3VgACgkQ9OZqfMIN8nORUQCfTbe21thxQKyXaGDc1pAUEfcn
vzwAoKvyOwnyc4FiwaSI20PhgNxRGP+0
=pRCR
-----END PGP SIGNATURE-----





Bug No longer marked as fixed in versions db4.6/4.6.21-19 and reopened. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 19 Apr 2011 21:15:18 GMT) Full text and rfc822 format available.

Bug reassigned from package 'src:db4.6' to 'gcj-4.4-jdk'. Request was from Ondřej Surý <ondrej@sury.org> to control@bugs.debian.org. (Tue, 19 Apr 2011 21:15:19 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions db4.6/4.6.21-18. Request was from Ondřej Surý <ondrej@sury.org> to control@bugs.debian.org. (Tue, 19 Apr 2011 21:15:19 GMT) Full text and rfc822 format available.

Changed Bug title to 'gcj-4.4-jdk misses jni_md.h on kfreebsd' from 'db4.6: FTBFS on kfreebsd-*: jni.h:52:20: fatal error: jni_md.h: No such file or directory' Request was from Ondřej Surý <ondrej@sury.org> to control@bugs.debian.org. (Tue, 19 Apr 2011 21:15:20 GMT) Full text and rfc822 format available.

Added indication that 621878 affects db4.6, db4.7, db4.8, and db Request was from Ondřej Surý <ondrej@sury.org> to control@bugs.debian.org. (Tue, 19 Apr 2011 21:15:21 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GCC Maintainers <debian-gcc@lists.debian.org>:
Bug#621878; Package gcj-4.4-jdk. (Tue, 19 Apr 2011 23:03:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ondřej Surý <ondrej@sury.org>:
Extra info received and forwarded to list. Copy sent to Debian GCC Maintainers <debian-gcc@lists.debian.org>. (Tue, 19 Apr 2011 23:03:09 GMT) Full text and rfc822 format available.

Message #25 received at 621878@bugs.debian.org (full text, mbox):

From: Ondřej Surý <ondrej@sury.org>
To: Matthias Klose <doko@debian.org>, 621878@bugs.debian.org
Cc: Debian GCC Maintainers <debian-gcc@lists.debian.org>, debian-bsd@lists.debian.org
Subject: Re: gcj-4.4-jdk misses jni_md.h on kfreebsd platform
Date: Wed, 20 Apr 2011 00:59:57 +0200
[Message part 1 (text/plain, inline)]
On Tue, Apr 19, 2011 at 23:34, Matthias Klose <doko@debian.org> wrote:
> On 04/19/2011 11:11 PM, Ondřej Surý wrote:
>>
>> reopen 621878
>> reassign 621878 gcj-4.4-jdk
>> retitle 621878 gcj-4.4-jdk misses jni_md.h on kfreebsd
>> affects 621878 +db4.6 db4.7 db4.8 db
>> thank you
>>
>> Dear Debian GCC Team please look at http://bugs.debian.org/621878, it
>> looks like jni_md.h header is missing there which is causing FTBFSes
>> for dbX.Y packages.
>>
>> You can find failed build logs here:
>>
>>
>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-i386&ver=5.1.25-2&stamp=1302733739
>>
>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-2&stamp=1302733541
>
> is this a kfreebsd issue?

Version 5.1.25-1 built fine:
https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-1&stamp=1297388366

Version 5.1.25-2 started to fail on kfreebsd-{amd64,amd32}. The buildd
failures on ia64, mips, s390 and sparc are of different nature.

The error from 5.1.25-2 build is:
libtool: compile:  gcc -c -I. -I../src -I/usr/include/tcl8.5
-D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall
-g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing
../lang/java/libdb_java/db_java_wrap.c  -fPIC -DPIC -o
.libs/db_java_wrap.o
In file included from ../lang/java/libdb_java/db_java_wrap.c:137:0:
/usr/lib/jvm/default-java/include/jni.h:52:20: fatal error: jni_md.h:
No such file or directory

The same line compiles with lots of warnings, but compiles. So
something must have changed on gcj side between the two builds which
broke it.

> looks more like you are assuming that the default
> version of gcc matches the one for gcj. please reassign back.

Could you please elaborate? Are you trying to say that calling:

> gcc -c -I. -I../src -I/usr/include/tcl8.5 -D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall -g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing ../lang/java/libdb_java/db_java_wrap.c  -fPIC -DPIC -o .libs/db_java_wrap.o

is wrong when gcc is different version than gcj? Well the build log
say gcc-4.4 and gcj-4.4-*, so there should be nothing wrong.

O.
-- 
Ondřej Surý <ondrej@sury.org>
[db_5.1.25-1..2.diff.gz (application/x-gzip, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GCC Maintainers <debian-gcc@lists.debian.org>:
Bug#621878; Package gcj-4.4-jdk. (Wed, 20 Apr 2011 05:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ondřej Surý <ondrej@sury.org>:
Extra info received and forwarded to list. Copy sent to Debian GCC Maintainers <debian-gcc@lists.debian.org>. (Wed, 20 Apr 2011 05:24:03 GMT) Full text and rfc822 format available.

Message #30 received at 621878@bugs.debian.org (full text, mbox):

From: Ondřej Surý <ondrej@sury.org>
To: Ondřej Surý <ondrej@sury.org>
Cc: Matthias Klose <doko@debian.org>, "621878@bugs.debian.org" <621878@bugs.debian.org>, Debian GCC Maintainers <debian-gcc@lists.debian.org>, "debian-bsd@lists.debian.org" <debian-bsd@lists.debian.org>
Subject: Re: gcj-4.4-jdk misses jni_md.h on kfreebsd platform
Date: Wed, 20 Apr 2011 07:20:07 +0200
Just a quick note, the difference in gcj version between successful and unsuccessfull build is 4.4.5-9 vs 4.4.5-14

Ondřej Surý

On 20.4.2011, at 0:59, Ondřej Surý <ondrej@sury.org> wrote:

> On Tue, Apr 19, 2011 at 23:34, Matthias Klose <doko@debian.org> wrote:
>> On 04/19/2011 11:11 PM, Ondřej Surý wrote:
>>> 
>>> reopen 621878
>>> reassign 621878 gcj-4.4-jdk
>>> retitle 621878 gcj-4.4-jdk misses jni_md.h on kfreebsd
>>> affects 621878 +db4.6 db4.7 db4.8 db
>>> thank you
>>> 
>>> Dear Debian GCC Team please look at http://bugs.debian.org/621878, it
>>> looks like jni_md.h header is missing there which is causing FTBFSes
>>> for dbX.Y packages.
>>> 
>>> You can find failed build logs here:
>>> 
>>> 
>>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-i386&ver=5.1.25-2&stamp=1302733739
>>> 
>>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-2&stamp=1302733541
>> 
>> is this a kfreebsd issue?
> 
> Version 5.1.25-1 built fine:
> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-1&stamp=1297388366
> 
> Version 5.1.25-2 started to fail on kfreebsd-{amd64,amd32}. The buildd
> failures on ia64, mips, s390 and sparc are of different nature.
> 
> The error from 5.1.25-2 build is:
> libtool: compile:  gcc -c -I. -I../src -I/usr/include/tcl8.5
> -D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall
> -g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing
> ../lang/java/libdb_java/db_java_wrap.c -fPIC -DPIC -o
> .libs/db_java_wrap.o
> In file included from ../lang/java/libdb_java/db_java_wrap.c:137:0:
> /usr/lib/jvm/default-java/include/jni.h:52:20: fatal error: jni_md.h:
> No such file or directory
> 
> The same line compiles with lots of warnings, but compiles. So
> something must have changed on gcj side between the two builds which
> broke it.
> 
>> looks more like you are assuming that the default
>> version of gcc matches the one for gcj. please reassign back.
> 
> Could you please elaborate? Are you trying to say that calling:
> 
>> gcc -c -I. -I../src -I/usr/include/tcl8.5 -D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall -g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing ../lang/java/libdb_java/db_java_wrap.c  -fPIC -DPIC -o .libs/db_java_wrap.o
> 
> is wrong when gcc is different version than gcj? Well the build log
> say gcc-4.4 and gcj-4.4-*, so there should be nothing wrong.
> 
> O.
> -- 
> Ondřej Surý <ondrej@sury.org>
> <db_5.1.25-1..2.diff.gz>




Information forwarded to debian-bugs-dist@lists.debian.org, Debian GCC Maintainers <debian-gcc@lists.debian.org>:
Bug#621878; Package gcj-4.4-jdk. (Wed, 20 Apr 2011 09:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matthias Klose <doko@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GCC Maintainers <debian-gcc@lists.debian.org>. (Wed, 20 Apr 2011 09:51:10 GMT) Full text and rfc822 format available.

Message #35 received at 621878@bugs.debian.org (full text, mbox):

From: Matthias Klose <doko@debian.org>
To: Ondřej Surý <ondrej@sury.org>
Cc: "621878@bugs.debian.org" <621878@bugs.debian.org>, Debian GCC Maintainers <debian-gcc@lists.debian.org>, "debian-bsd@lists.debian.org" <debian-bsd@lists.debian.org>
Subject: Re: gcj-4.4-jdk misses jni_md.h on kfreebsd platform
Date: Wed, 20 Apr 2011 11:48:04 +0200
reassign 621878 db5.1
thanks

you have to include both <java_home>/include and <java_home>/include/linux.

On 04/20/2011 07:20 AM, Ondřej Surý wrote:
> Just a quick note, the difference in gcj version between successful and unsuccessfull build is 4.4.5-9 vs 4.4.5-14
>
> Ondřej Surý
>
> On 20.4.2011, at 0:59, Ondřej Surý<ondrej@sury.org>  wrote:
>
>> On Tue, Apr 19, 2011 at 23:34, Matthias Klose<doko@debian.org>  wrote:
>>> On 04/19/2011 11:11 PM, Ondřej Surý wrote:
>>>>
>>>> reopen 621878
>>>> reassign 621878 gcj-4.4-jdk
>>>> retitle 621878 gcj-4.4-jdk misses jni_md.h on kfreebsd
>>>> affects 621878 +db4.6 db4.7 db4.8 db
>>>> thank you
>>>>
>>>> Dear Debian GCC Team please look at http://bugs.debian.org/621878, it
>>>> looks like jni_md.h header is missing there which is causing FTBFSes
>>>> for dbX.Y packages.
>>>>
>>>> You can find failed build logs here:
>>>>
>>>>
>>>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-i386&ver=5.1.25-2&stamp=1302733739
>>>>
>>>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-2&stamp=1302733541
>>>
>>> is this a kfreebsd issue?
>>
>> Version 5.1.25-1 built fine:
>> https://buildd.debian.org/status/fetch.php?pkg=db&arch=kfreebsd-amd64&ver=5.1.25-1&stamp=1297388366
>>
>> Version 5.1.25-2 started to fail on kfreebsd-{amd64,amd32}. The buildd
>> failures on ia64, mips, s390 and sparc are of different nature.
>>
>> The error from 5.1.25-2 build is:
>> libtool: compile:  gcc -c -I. -I../src -I/usr/include/tcl8.5
>> -D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall
>> -g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing
>> ../lang/java/libdb_java/db_java_wrap.c -fPIC -DPIC -o
>> .libs/db_java_wrap.o
>> In file included from ../lang/java/libdb_java/db_java_wrap.c:137:0:
>> /usr/lib/jvm/default-java/include/jni.h:52:20: fatal error: jni_md.h:
>> No such file or directory
>>
>> The same line compiles with lots of warnings, but compiles. So
>> something must have changed on gcj side between the two builds which
>> broke it.
>>
>>> looks more like you are assuming that the default
>>> version of gcc matches the one for gcj. please reassign back.
>>
>> Could you please elaborate? Are you trying to say that calling:
>>
>>> gcc -c -I. -I../src -I/usr/include/tcl8.5 -D_GNU_SOURCE -D_REENTRANT -I/usr/lib/jvm/default-java/include -Wall -g -O2 -I/usr/lib/jvm/default-java/include -fno-strict-aliasing ../lang/java/libdb_java/db_java_wrap.c  -fPIC -DPIC -o .libs/db_java_wrap.o
>>
>> is wrong when gcc is different version than gcj? Well the build log
>> say gcc-4.4 and gcj-4.4-*, so there should be nothing wrong.
>>
>> O.
>> --
>> Ondřej Surý<ondrej@sury.org>
>> <db_5.1.25-1..2.diff.gz>





Reply sent to Ondřej Surý <ondrej@debian.org>:
You have taken responsibility. (Wed, 20 Apr 2011 13:21:14 GMT) Full text and rfc822 format available.

Notification sent to Cyril Brulebois <kibi@debian.org>:
Bug acknowledged by developer. (Wed, 20 Apr 2011 13:21:14 GMT) Full text and rfc822 format available.

Message #40 received at 621878-close@bugs.debian.org (full text, mbox):

From: Ondřej Surý <ondrej@debian.org>
To: 621878-close@bugs.debian.org
Subject: Bug#621878: fixed in db 5.1.25-4
Date: Wed, 20 Apr 2011 13:17:44 +0000
Source: db
Source-Version: 5.1.25-4

We believe that the bug you reported is fixed in the latest version of
db, which is due to be installed in the Debian FTP archive:

db5.1-doc_5.1.25-4_all.deb
  to main/d/db/db5.1-doc_5.1.25-4_all.deb
db5.1-util_5.1.25-4_amd64.deb
  to main/d/db/db5.1-util_5.1.25-4_amd64.deb
db_5.1.25-4.debian.tar.gz
  to main/d/db/db_5.1.25-4.debian.tar.gz
db_5.1.25-4.dsc
  to main/d/db/db_5.1.25-4.dsc
libdb5.1++-dev_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1++-dev_5.1.25-4_amd64.deb
libdb5.1++_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1++_5.1.25-4_amd64.deb
libdb5.1-dbg_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-dbg_5.1.25-4_amd64.deb
libdb5.1-dev_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-dev_5.1.25-4_amd64.deb
libdb5.1-java-dev_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-java-dev_5.1.25-4_amd64.deb
libdb5.1-java-gcj_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-java-gcj_5.1.25-4_amd64.deb
libdb5.1-java_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-java_5.1.25-4_amd64.deb
libdb5.1-sql-dev_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-sql-dev_5.1.25-4_amd64.deb
libdb5.1-sql_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-sql_5.1.25-4_amd64.deb
libdb5.1-stl-dev_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-stl-dev_5.1.25-4_amd64.deb
libdb5.1-stl_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-stl_5.1.25-4_amd64.deb
libdb5.1-tcl_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1-tcl_5.1.25-4_amd64.deb
libdb5.1_5.1.25-4_amd64.deb
  to main/d/db/libdb5.1_5.1.25-4_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 621878@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Ondřej Surý <ondrej@debian.org> (supplier of updated db package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 20 Apr 2011 14:07:51 +0200
Source: db
Binary: db5.1-doc libdb5.1-dev libdb5.1 db5.1-util libdb5.1++ libdb5.1++-dev libdb5.1-tcl libdb5.1-dbg libdb5.1-java libdb5.1-java-gcj libdb5.1-java-dev libdb5.1-sql-dev libdb5.1-sql libdb5.1-stl-dev libdb5.1-stl
Architecture: source all amd64
Version: 5.1.25-4
Distribution: unstable
Urgency: low
Maintainer: Debian Berkeley DB Group <pkg-db-devel@lists.alioth.debian.org>
Changed-By: Ondřej Surý <ondrej@debian.org>
Description: 
 db5.1-doc  - Berkeley v5.1 Database Documentation [html]
 db5.1-util - Berkeley v5.1 Database Utilities
 libdb5.1   - Berkeley v5.1 Database Libraries [runtime]
 libdb5.1++ - Berkeley v5.1 Database Libraries for C++ [runtime]
 libdb5.1++-dev - Berkeley v5.1 Database Libraries for C++ [development]
 libdb5.1-dbg - Berkeley v5.1 Database Libraries [debug]
 libdb5.1-dev - Berkeley v5.1 Database Libraries [development]
 libdb5.1-java - Berkeley v5.1 Database Libraries for Java
 libdb5.1-java-dev - Berkeley v5.1 Database Libraries for Java [development]
 libdb5.1-java-gcj - Berkeley v5.1 Database Libraries for Java (native code)
 libdb5.1-sql - Berkeley v5.1 Database Libraries [SQL runtime]
 libdb5.1-sql-dev - Berkeley v5.1 Database Libraries [SQL development]
 libdb5.1-stl - Berkeley v5.1 Database Libraries [STL runtime]
 libdb5.1-stl-dev - Berkeley v5.1 Database Libraries [STL development]
 libdb5.1-tcl - Berkeley v5.1 Database Libraries for Tcl [module]
Closes: 606065 621878
Changes: 
 db (5.1.25-4) unstable; urgency=low
 .
   * Add debug info for all libraries
   * Fix FTBFS on freebsd-{amd64,i386} (Thanks Matthias Klose)
     (Closes: #621878)
   * Fix lintian warnings and errors:
     + Update default java build dependencies
     + Tighten Java libraries dependencies
     + Fix errors in db5.1_load.1 manpage
   * Debian packaging:
     + Convert package build system to debhelper with overrides
     + Move debian/rules to debhelper
     + Remove some obsolete Conflicts
     + Add ${misc:Depends} since we build depend on debhelper now
     + Use tcltk-defaults command for tcl dependencies
       (Closes: #606065)
     + Use dh_nativejava debhelper command
     + Move upstream source changes to quilt patches
   * Add lintian-overrides for:
     + ancient-autotools-helper-file,ancient-libtool: odbc/jdbc is not used
     + package-name-doesnt-match-sonames: historical reasons
     + sqlite3 embedded-library: db5.1-sql provides sqlite3 ABI
Checksums-Sha1: 
 6ef49da7276a53688b92ba898ab822d3ec951d98 1561 db_5.1.25-4.dsc
 26bd9833e902406b0871d70d271a21d9778859af 27153 db_5.1.25-4.debian.tar.gz
 7a5681f8f966477e434ad64855b268d654d869fa 16515754 db5.1-doc_5.1.25-4_all.deb
 1ef98d6f799c099d9ae70be86b629d688e6a9843 881890 libdb5.1-dev_5.1.25-4_amd64.deb
 02f7e6d6687b02d9c1c59871b11681ec22f81f0c 728124 libdb5.1_5.1.25-4_amd64.deb
 40da5a5ba9d4c700dca0fb82b8a90a25c6cbb29e 105506 db5.1-util_5.1.25-4_amd64.deb
 fc0ba60fe35f7c4c2157ef3ebfc3fe0b0f0b7a0c 762256 libdb5.1++_5.1.25-4_amd64.deb
 34a17c92e74f77ca3a5e15d12317c4c9ad7b34c5 1802306 libdb5.1++-dev_5.1.25-4_amd64.deb
 c679a7906ac3db4ff056ca6b675a2935652a3aa3 2708734 libdb5.1-tcl_5.1.25-4_amd64.deb
 f604ee977d1fba99d4feaf2e64b689100a623362 30182366 libdb5.1-dbg_5.1.25-4_amd64.deb
 c6b60bb3e56bf372d9aeed28012b6edecfa53c50 1294890 libdb5.1-java_5.1.25-4_amd64.deb
 0b1343ad0de62e9ecf5a74c49c1f583ab8f1eb77 778304 libdb5.1-java-gcj_5.1.25-4_amd64.deb
 16f710ae2029c5208b402222ef2fcb85d3dd0ca1 904998 libdb5.1-java-dev_5.1.25-4_amd64.deb
 c1f0c122327ee28d9cef8dc6d215b6bb3054e191 2294030 libdb5.1-sql-dev_5.1.25-4_amd64.deb
 eaa6bc70bf1b668503d4cc9999bd6ddbdebc98a8 961206 libdb5.1-sql_5.1.25-4_amd64.deb
 c1fe03ed3f7b62c0a081fc499ab59c5b511cae74 1963092 libdb5.1-stl-dev_5.1.25-4_amd64.deb
 97907cd1f980374c3729eface9c965e436c9b5be 792138 libdb5.1-stl_5.1.25-4_amd64.deb
Checksums-Sha256: 
 e9b584d7016610d0f2acc5cdc654731f353379a4b5f39b92014df1a4b45106a1 1561 db_5.1.25-4.dsc
 3d7de94c1dd739e2986cec8cbc6ab19d4429b0a790ba8480a7f128c15fcb6058 27153 db_5.1.25-4.debian.tar.gz
 9480d4fa3716aa8694157164e7c8c85ee222dcee1317dd185a3a4b2152df3aca 16515754 db5.1-doc_5.1.25-4_all.deb
 bd8e748d7fe81e7b36ed64999d431ca5aaca217bd40a0e60ec5a5e6f763ed676 881890 libdb5.1-dev_5.1.25-4_amd64.deb
 b55217d3cfd5014073ba6577c566359d55f332899cfe746ae883849632fbca99 728124 libdb5.1_5.1.25-4_amd64.deb
 615f4209323d55242aeb3c2faa3ee636f1c1bdfcfc4e7b423f8857a3433bfde6 105506 db5.1-util_5.1.25-4_amd64.deb
 3a0210d25cb4be5257e9c61c51c41d69d0d9caf5a28a8c29bb7634d7b1e66ed5 762256 libdb5.1++_5.1.25-4_amd64.deb
 141dc9d7d36655530566f3a29834d4f1a8e1a0369ea28a9056cd5f7f328660d6 1802306 libdb5.1++-dev_5.1.25-4_amd64.deb
 bb1576befe5f535cd9e7d857d727242047e58395878b9d6784aca5b6da3a2544 2708734 libdb5.1-tcl_5.1.25-4_amd64.deb
 19bfbdf2e0ddd51394651fefb3634f184f1089b5c6a3f97b79e920455c1976ed 30182366 libdb5.1-dbg_5.1.25-4_amd64.deb
 4889d7c277f489a514aad900df0b5382c13f455d98a2871525b40310ecf2b74b 1294890 libdb5.1-java_5.1.25-4_amd64.deb
 00f59a835825ca395537c53e40190f8935573f268632cbcf1679ea637dbca0d8 778304 libdb5.1-java-gcj_5.1.25-4_amd64.deb
 12dc7ada2626f58b01fd3d1947a5abb34a75092b4f2748ef76e07317cdf78a67 904998 libdb5.1-java-dev_5.1.25-4_amd64.deb
 dd6c447985049a39a7090a4bf9eafcc5f06d467363be540f28217da85b8fae5f 2294030 libdb5.1-sql-dev_5.1.25-4_amd64.deb
 8b13728689a58a32ebe0124b23bf6559c1af54a01d215baaf2a3c331ca5ec5ef 961206 libdb5.1-sql_5.1.25-4_amd64.deb
 22e22c9c7f767566800c1cc89dddacda822280555f6e9bd682c44aabbb79056b 1963092 libdb5.1-stl-dev_5.1.25-4_amd64.deb
 a460d777d5def5e932a5dcfee29e4476bd2909fb4f30ace99b382b217a1414c9 792138 libdb5.1-stl_5.1.25-4_amd64.deb
Files: 
 8111f89f2d3ba5fd1a64d9e5664521e6 1561 libs standard db_5.1.25-4.dsc
 06fef29fc1c7d38e57f66dd06fc2ed6d 27153 libs standard db_5.1.25-4.debian.tar.gz
 9c6d2af136d7d90a50d3c71e413b5e9e 16515754 doc optional db5.1-doc_5.1.25-4_all.deb
 cc7cae33b3209bf2258806fa1d768794 881890 libdevel extra libdb5.1-dev_5.1.25-4_amd64.deb
 32c65a16e5ce8109e99c81e0b6de9cb4 728124 libs standard libdb5.1_5.1.25-4_amd64.deb
 9f7497360e52d909db3495e825b2256d 105506 database optional db5.1-util_5.1.25-4_amd64.deb
 52886d16dd693e418d071f747d1423b3 762256 libs optional libdb5.1++_5.1.25-4_amd64.deb
 4145fe0300d0bcdfc7bc06641fd6af08 1802306 libdevel extra libdb5.1++-dev_5.1.25-4_amd64.deb
 2eed793accf89d1575f26b36f867dbfe 2708734 interpreters extra libdb5.1-tcl_5.1.25-4_amd64.deb
 cf1354867b56b0b7a33ab62f587c0a83 30182366 debug extra libdb5.1-dbg_5.1.25-4_amd64.deb
 97dde2539768723a06f67936135abaf3 1294890 java optional libdb5.1-java_5.1.25-4_amd64.deb
 0ba3a8eeb83e5fa654ee01d08374b198 778304 java optional libdb5.1-java-gcj_5.1.25-4_amd64.deb
 cb0fba27bbe4de4a9feb9bf3d0a050fc 904998 libdevel optional libdb5.1-java-dev_5.1.25-4_amd64.deb
 eb414177217f57331dbf341adb49ec46 2294030 libdevel extra libdb5.1-sql-dev_5.1.25-4_amd64.deb
 bc73df19e4f515b2db5f41d1094cd6f4 961206 libs extra libdb5.1-sql_5.1.25-4_amd64.deb
 f4ae457dabfbaf9a9a098bc9e79494db 1963092 libdevel extra libdb5.1-stl-dev_5.1.25-4_amd64.deb
 34b6c241c662c5a7e32d5648388f613b 792138 libs extra libdb5.1-stl_5.1.25-4_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk2u2jgACgkQ9OZqfMIN8nPEGwCeJr+/DhEbLuemYQbqI3scrcxZ
k24An0ikQwlxfYXjAjxCpZPYVGo324Df
=TF9N
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 19 May 2011 07:37:41 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 07:23:51 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.