Debian Bug report logs - #620901
flashplugin-nonfree: Audio has horrible noisy artifacts

version graph

Package: flashplugin-nonfree; Maintainer for flashplugin-nonfree is Bart Martens <bartm@debian.org>; Source for flashplugin-nonfree is src:flashplugin-nonfree.

Reported by: Sam Morris <sam@robots.org.uk>

Date: Tue, 5 Apr 2011 00:06:01 UTC

Severity: important

Tags: upstream

Merged with 627966, 628652

Found in version flashplugin-nonfree/1:2.8.3

Done: Bart Martens <bartm@debian.org>

Bug is archived. No further changes may be made.

Forwarded to https://bugs.adobe.com/jira/browse/FP-5739

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Tue, 05 Apr 2011 00:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sam Morris <sam@robots.org.uk>:
New Bug report received and forwarded. Copy sent to Bart Martens <bartm@debian.org>. (Tue, 05 Apr 2011 00:06:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sam Morris <sam@robots.org.uk>
To: submit@bugs.debian.org
Subject: flashplugin-nonfree: Audio has horrible noisy artifacts
Date: Tue, 05 Apr 2011 00:20:04 +0100
[Message part 1 (text/plain, inline)]
Package: flashplugin-nonfree
Version: 1:2.8.3
Severity: important

Flash movies have a horrible repetitive metallic sound. I'm attaching
the recording of a movie that demonstrates the problem. The recording
was taken with the movie present at
<https://www.hsbc.co.uk/1/2/security-centre/secure-key-demo>.

This happens with chrome and iceweasel, hence I've filed it at Flash. It
may, however, be a problem with pulseaudio. I don't know which it is, so
reassign if you think it is necessary.

-- Package-specific info:
Debian version: 6.0.1
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	338e954c02ba6776b6b8a908e6f96b5f  /var/cache/flashplugin-nonfree/flashplayer_square_p1_64bit_linux_091510.tar.gz
	4a4561e456612a6751653b58342d53df  /var/cache/flashplugin-nonfree/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz
	267bfdb38d14c9d96d0d04e273c3d961  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 Mar 10 23:59 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: 6.0.1
  APT prefers stable-updates
  APT policy: (550, 'stable-updates'), (550, 'stable'), (540, 'testing'), (530, 'unstable'), (520, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf 1.5.36.1                Debian configuration management sy
di  gnupg            1.4.10-4                GNU privacy guard - a free PGP rep
ii  libatk1.0-0      1.32.0-3                The ATK accessibility toolkit
ii  libcairo2        1.10.2-6                The Cairo 2D vector graphics libra
ii  libcurl3-gnutls  7.21.0-1                Multi-protocol file transfer libra
ii  libfontconfig1   2.8.0-2.1               generic font configuration library
ii  libfreetype6     2.4.2-2.1               FreeType 2 font engine, shared lib
ii  libgcc1          1:4.6.0-2               GCC support library
ii  libglib2.0-0     2.28.2-1                The GLib library of C routines
ii  libgtk2.0-0      2.24.3-1                The GTK+ graphical user interface 
ii  libnspr4-0d      4.8.6-1                 NetScape Portable Runtime Library
ii  libnss3-1d       3.12.9.with.ckbi.1.82-1 Network Security Service libraries
ii  libpango1.0-0    1.28.3-5                Layout and rendering of internatio
ii  libstdc++6       4.6.0-2                 The GNU Standard C++ Library v3
ii  libx11-6         2:1.3.3-4               X11 client-side library
ii  libxext6         2:1.1.2-1               X11 miscellaneous extension librar
ii  libxt6           1:1.0.7-1               X11 toolkit intrinsics library
ii  wget             1.12-2.1                retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
ii  iceweasel                     4.0-3      Web browser based on Firefox
pn  konqueror-nsplugins           <none>     (no description available)
pn  msttcorefonts                 <none>     (no description available)
ii  ttf-dejavu                    2.31-1     Metapackage to pull in ttf-dejavu-
pn  ttf-xfree86-nonfree           <none>     (no description available)
ii  x-ttcidfont-conf              32         TrueType and CID fonts configurati

-- no debconf information

[foo.flac (audio/x-flac, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, kai.weber@glorybox.de, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Wed, 04 May 2011 13:15:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Kai Weber <kai.weber@glorybox.de>:
Extra info received and forwarded to list. Copy sent to kai.weber@glorybox.de, Bart Martens <bartm@debian.org>. (Wed, 04 May 2011 13:15:10 GMT) Full text and rfc822 format available.

Message #10 received at 620901@bugs.debian.org (full text, mbox):

From: Kai Weber <kai.weber@glorybox.de>
To: Debian Bug Tracking System <620901@bugs.debian.org>
Subject: Re: Audio has horrible noisy artifacts
Date: Wed, 04 May 2011 15:10:45 +0200
Package: flashplugin-nonfree
Version: 1:2.8.3
Followup-For: Bug #620901

I can confirm this bug is still valid.

Interesstingly the articats do not appear in Youtube or Vimeo videos.  I get
those artifacts on Soundcloud or Flash games for example.

Regards, Kai

-- Package-specific info:
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	267bfdb38d14c9d96d0d04e273c3d961  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 May  4 15:00 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (750, 'unstable'), (250, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf 1.5.39                  Debian configuration management sy
ii  gnupg            1.4.11-3                GNU privacy guard - a free PGP rep
ii  libatk1.0-0      2.0.0-1                 The ATK accessibility toolkit
ii  libcairo2        1.10.2-6                The Cairo 2D vector graphics libra
ii  libcurl3-gnutls  7.21.6-1                Multi-protocol file transfer libra
ii  libfontconfig1   2.8.0-2.2               generic font configuration library
ii  libfreetype6     2.4.4-1                 FreeType 2 font engine, shared lib
ii  libgcc1          1:4.6.0-6               GCC support library
ii  libglib2.0-0     2.28.6-1                The GLib library of C routines
ii  libgtk2.0-0      2.24.4-3                The GTK+ graphical user interface 
ii  libnspr4-0d      4.8.7-2                 NetScape Portable Runtime Library
ii  libnss3-1d       3.12.9.with.ckbi.1.82-1 Network Security Service libraries
ii  libpango1.0-0    1.28.3-6                Layout and rendering of internatio
ii  libstdc++6       4.6.0-6                 The GNU Standard C++ Library v3
ii  libx11-6         2:1.4.3-1               X11 client-side library
ii  libxext6         2:1.2.0-2               X11 miscellaneous extension librar
ii  libxt6           1:1.1.1-1               X11 toolkit intrinsics library
ii  wget             1.12-3.1                retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
ii  iceweasel                     3.5.19-2   Web browser based on Firefox
pn  konqueror-nsplugins           <none>     (no description available)
ii  ttf-dejavu                    2.33-1     Metapackage to pull in ttf-dejavu-
ii  ttf-mscorefonts-installer [ms 3.3        Installer for Microsoft TrueType c
pn  ttf-xfree86-nonfree           <none>     (no description available)
ii  x-ttcidfont-conf              32+nmu2    TrueType and CID fonts configurati

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Fri, 06 May 2011 19:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Markus Wagner <markus@mwagner.info>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Fri, 06 May 2011 19:57:03 GMT) Full text and rfc822 format available.

Message #15 received at 620901@bugs.debian.org (full text, mbox):

From: Markus Wagner <markus@mwagner.info>
To: 620901@bugs.debian.org
Subject: Binary patch for 10.3 d162 (64-Bit)
Date: Fri, 6 May 2011 21:50:39 +0200
[Message part 1 (text/plain, inline)]
This bug has been posted upstream. A bspatch has been attached
https://bugs.adobe.com/jira/browse/FP-5739

The patch seemst to comre from here:
http://www.linux.org.ru/forum/talks/5663681

Applying this patch fixed th 64-bit version of flashplayer for me. (Version 
identification 10.3 d162)

It is due to some changes of memcpy in glibc:
http://article.gmane.org/gmane.comp.lib.glibc.alpha/15278

See also the related discussion here:
https://bugzilla.redhat.com/show_bug.cgi?id=638477




[Message part 2 (text/html, inline)]
[memcpy-10.3.162.29.bsdiff (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Mon, 09 May 2011 07:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Kevin Mitchell <kevmitch@math.sfu.ca>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Mon, 09 May 2011 07:15:03 GMT) Full text and rfc822 format available.

Message #20 received at 620901@bugs.debian.org (full text, mbox):

From: Kevin Mitchell <kevmitch@math.sfu.ca>
To: Debian Bug Tracking System <620901@bugs.debian.org>
Subject: flashplugin-nonfree: equivalent to adobe #FP-5739[1], fedorax #638477[2]
Date: Sun, 08 May 2011 22:58:35 -0700
Package: flashplugin-nonfree
Followup-For: Bug #620901

This appears to be be consistent with the bug described at
[1,2]. Namely, recent libc optimisations of memcpy have exposed cases
where libflashplayer.so uses memcpy on overlapping memory. Suggested solutions are 

1) revert the optimisation in glibc (obviously a distasteful solution)
2) futz around with preloading alternative memcpy (I have verified that preloading an alias of memcpy to memmove fixes the problem). The downside is that this forces all of firefox (or whatever browser) to use memmove as well. 
3) dissasemble the libflashplayer.so binary and change memcpy to memmove. this would probably be difficult to maintain.
4) wait for adobe to clean up its mess. I don't need to point out the downside to this.

[1] https://bugs.adobe.com/jira/browse/FP-5739
[2] https://bugzilla.redhat.com/show_bug.cgi?id=638477

-- Package-specific info:
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	338e954c02ba6776b6b8a908e6f96b5f  /var/cache/flashplugin-nonfree/flashplayer_square_p1_64bit_linux_091510.tar.gz
	267bfdb38d14c9d96d0d04e273c3d961  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 Apr 12 16:50 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (600, 'unstable'), (500, 'testing'), (400, 'stable'), (300, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.34.8.001 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf 1.5.39                  Debian configuration management sy
ii  gnupg            1.4.11-3                GNU privacy guard - a free PGP rep
ii  libatk1.0-0      2.0.0-1                 The ATK accessibility toolkit
ii  libcairo2        1.10.2-6                The Cairo 2D vector graphics libra
ii  libcurl3-gnutls  7.21.6-1                Multi-protocol file transfer libra
ii  libfontconfig1   2.8.0-2.2               generic font configuration library
ii  libfreetype6     2.4.4-1                 FreeType 2 font engine, shared lib
ii  libgcc1          1:4.6.0-7               GCC support library
ii  libglib2.0-0     2.28.6-1                The GLib library of C routines
ii  libgtk2.0-0      2.24.4-3                The GTK+ graphical user interface 
ii  libnspr4-0d      4.8.7-2                 NetScape Portable Runtime Library
ii  libnss3-1d       3.12.9.with.ckbi.1.82-1 Network Security Service libraries
ii  libpango1.0-0    1.28.3-6                Layout and rendering of internatio
ii  libstdc++6       4.6.0-7                 The GNU Standard C++ Library v3
ii  libx11-6         2:1.4.3-1               X11 client-side library
ii  libxext6         2:1.2.0-2               X11 miscellaneous extension librar
ii  libxt6           1:1.1.1-1               X11 toolkit intrinsics library
ii  wget             1.12-3.1                retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
ii  iceweasel                     4.0.1-2    Web browser based on Firefox
pn  konqueror-nsplugins           <none>     (no description available)
ii  msttcorefonts                 2.7        transitional dummy package
ii  ttf-dejavu                    2.33-1     Metapackage to pull in ttf-dejavu-
ii  ttf-mscorefonts-installer [ms 3.3        Installer for Microsoft TrueType c
pn  ttf-xfree86-nonfree           <none>     (no description available)
ii  x-ttcidfont-conf              32+nmu2    TrueType and CID fonts configurati

-- debconf information:
  flashplugin-nonfree/httpget: false
  flashplugin-nonfree/not_exist:
  flashplugin-nonfree/local:




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Sun, 22 May 2011 21:17:23 GMT) Full text and rfc822 format available.

Acknowledgement sent to jaydee@email.cz:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Sun, 22 May 2011 21:17:24 GMT) Full text and rfc822 format available.

Message #25 received at 620901@bugs.debian.org (full text, mbox):

From: jaydee@email.cz
To: 620901@bugs.debian.org
Subject: automated patch
Date: Sun, 22 May 2011 23:11:23 +0200 (CEST)
> 3) dissasemble the libflashplayer.so binary and change memcpy to memmove. this would probably be difficult to maintain.

This can be done automatically - as part of update-flashplugin-nonfree perhaps? See https://bugzilla.redhat.com/attachment.cgi?id=460254 (attachment of https://bugzilla.redhat.com/show_bug.cgi?id=638477 ). Nasty, but works fine for me (well, after changing /bin/sh to /bin/bash).




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Sun, 22 May 2011 21:17:29 GMT) Full text and rfc822 format available.

Acknowledgement sent to jaydee@email.cz:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Sun, 22 May 2011 21:17:30 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Tue, 24 May 2011 02:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Leandro Lucarella <luca@llucax.com.ar>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Tue, 24 May 2011 02:09:03 GMT) Full text and rfc822 format available.

Message #35 received at 620901@bugs.debian.org (full text, mbox):

From: Leandro Lucarella <luca@llucax.com.ar>
To: 620901@bugs.debian.org
Subject: Can't you apply the Adobe's binary patch?
Date: Mon, 23 May 2011 23:05:31 -0300
Can't you apply the binary patch published by Adobe[1]? I know this
would make the package depends on bsdiff, but at least is a viable
solution until Adobe releases a new version with the fix...

[1] https://bugs.adobe.com/jira/browse/FP-5739

-- 
Leandro Lucarella (AKA luca)                     http://llucax.com.ar/
----------------------------------------------------------------------
GPG Key: 5F5A8D05 (F8CD F9A7 BF00 5431 4145  104C 949E BFB6 5F5A 8D05)
----------------------------------------------------------------------
No es malo que en la condición humana exista la mentira. Miente el púber
si quiere ponerla.
	-- Ricardo Vaporeso. Madrid, 1921.




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Tue, 24 May 2011 15:06:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jakub Drnec <jaydee@email.cz>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Tue, 24 May 2011 15:06:03 GMT) Full text and rfc822 format available.

Message #40 received at 620901@bugs.debian.org (full text, mbox):

From: Jakub Drnec <jaydee@email.cz>
To: 620901@bugs.debian.org
Subject: Re: Can't you apply the Adobe's binary patch?
Date: Tue, 24 May 2011 17:02:15 +0200 (CEST)
> Can't you apply the binary patch published by Adobe[1]?

I don't think RussianNeuroMancer (see the bug's Activity Stream) is from Adobe.
At least with the objdump hack you can see what it's doing.
--
Jakub Drnec




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Wed, 25 May 2011 16:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Torquil Macdonald Sørensen <torquil@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Wed, 25 May 2011 16:45:03 GMT) Full text and rfc822 format available.

Message #45 received at 620901@bugs.debian.org (full text, mbox):

From: Torquil Macdonald Sørensen <torquil@gmail.com>
To: Debian Bug Tracking System <620901@bugs.debian.org>
Subject: Re: Audio has horrible noisy artifacts
Date: Wed, 25 May 2011 18:42:58 +0200
Package: flashplugin-nonfree
Version: 1:2.8.3
Followup-For: Bug #620901

Unfortunately, running the 'memcpy-to-memmove.sh' as root on libflashplayer.so has resulted
in Iceweasel no longer detecting a Flash plugin... I have made sure my non-root user
has read permission to the modified file, but nevertheless Iceweasel does not report the presence
of a Flash plugin...

(I did have to change #!/bin/sh to #!/bin/bash as in a previous post here. Otherwise
I got an error message when running the script. Something along the lines of
"ERR bad trap".)

tmac@asus:~$ file /usr/lib/flashplugin-nonfree/libflashplayer.so 
/usr/lib/flashplugin-nonfree/libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

I wish Gnash didn't use as much CPU as it seems to do...

Best regards
Torquil Sørensen

-- Package-specific info:
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	ae86158ba0a6381f834d000826cbd226  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 May 13 10:34 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (700, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf 1.5.39                  Debian configuration management sy
pn  gnupg            <none>                  (no description available)
ii  libatk1.0-0      2.0.0-1                 The ATK accessibility toolkit
ii  libcairo2        1.10.2-6                The Cairo 2D vector graphics libra
ii  libcurl3-gnutls  7.21.6-1                Multi-protocol file transfer libra
ii  libfontconfig1   2.8.0-2.2               generic font configuration library
ii  libfreetype6     2.4.4-1                 FreeType 2 font engine, shared lib
ii  libgcc1          1:4.6.0-9               GCC support library
ii  libglib2.0-0     2.28.6-1                The GLib library of C routines
ii  libgtk2.0-0      2.24.4-3                The GTK+ graphical user interface 
ii  libnspr4-0d      4.8.8-1                 NetScape Portable Runtime Library
ii  libnss3-1d       3.12.9.with.ckbi.1.82-1 Network Security Service libraries
ii  libpango1.0-0    1.28.3-6                Layout and rendering of internatio
ii  libstdc++6       4.6.0-9                 The GNU Standard C++ Library v3
ii  libx11-6         2:1.4.3-1               X11 client-side library
ii  libxext6         2:1.3.0-1               X11 miscellaneous extension librar
ii  libxt6           1:1.1.1-1               X11 toolkit intrinsics library
ii  wget             1.12-3.1                retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
ii  iceweasel                     4.0.1-2    Web browser based on Firefox
pn  konqueror-nsplugins           <none>     (no description available)
pn  msttcorefonts                 <none>     (no description available)
ii  ttf-dejavu                    2.33-1     Metapackage to pull in ttf-dejavu-
pn  ttf-xfree86-nonfree           <none>     (no description available)
ii  x-ttcidfont-conf              32+nmu2    TrueType and CID fonts configurati

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Wed, 25 May 2011 17:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Torquil Macdonald Sørensen <torquil@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Wed, 25 May 2011 17:09:03 GMT) Full text and rfc822 format available.

Message #50 received at 620901@bugs.debian.org (full text, mbox):

From: Torquil Macdonald Sørensen <torquil@gmail.com>
To: Debian Bug Tracking System <620901@bugs.debian.org>
Subject: Re: Audio has horrible noisy artifacts
Date: Wed, 25 May 2011 19:04:45 +0200
Package: flashplugin-nonfree
Version: 1:2.8.3
Followup-For: Bug #620901

I know this isn't a discussion forum.... But in the interest of completeness, I wanted
to mention that the binary patch seems to have fixed the problem.

Ref:
https://bugs.adobe.com/jira/browse/FP-573

- Torquil

-- Package-specific info:
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	35c297ffef7a5a7ed8fb4f5526ced799  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 May 25 18:57 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (700, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf 1.5.39                  Debian configuration management sy
pn  gnupg            <none>                  (no description available)
ii  libatk1.0-0      2.0.0-1                 The ATK accessibility toolkit
ii  libcairo2        1.10.2-6                The Cairo 2D vector graphics libra
ii  libcurl3-gnutls  7.21.6-1                Multi-protocol file transfer libra
ii  libfontconfig1   2.8.0-2.2               generic font configuration library
ii  libfreetype6     2.4.4-1                 FreeType 2 font engine, shared lib
ii  libgcc1          1:4.6.0-9               GCC support library
ii  libglib2.0-0     2.28.6-1                The GLib library of C routines
ii  libgtk2.0-0      2.24.4-3                The GTK+ graphical user interface 
ii  libnspr4-0d      4.8.8-1                 NetScape Portable Runtime Library
ii  libnss3-1d       3.12.9.with.ckbi.1.82-1 Network Security Service libraries
ii  libpango1.0-0    1.28.3-6                Layout and rendering of internatio
ii  libstdc++6       4.6.0-9                 The GNU Standard C++ Library v3
ii  libx11-6         2:1.4.3-1               X11 client-side library
ii  libxext6         2:1.3.0-1               X11 miscellaneous extension librar
ii  libxt6           1:1.1.1-1               X11 toolkit intrinsics library
ii  wget             1.12-3.1                retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
ii  iceweasel                     4.0.1-2    Web browser based on Firefox
pn  konqueror-nsplugins           <none>     (no description available)
pn  msttcorefonts                 <none>     (no description available)
ii  ttf-dejavu                    2.33-1     Metapackage to pull in ttf-dejavu-
pn  ttf-xfree86-nonfree           <none>     (no description available)
ii  x-ttcidfont-conf              32+nmu2    TrueType and CID fonts configurati

-- no debconf information




Merged 620901 627966. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Fri, 27 May 2011 06:15:10 GMT) Full text and rfc822 format available.

Added tag(s) upstream. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Fri, 27 May 2011 06:15:11 GMT) Full text and rfc822 format available.

Set Bug forwarded-to-address to 'https://bugs.adobe.com/jira/browse/FP-5739'. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Fri, 27 May 2011 06:15:12 GMT) Full text and rfc822 format available.

Added tag(s) patch. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Fri, 27 May 2011 06:15:14 GMT) Full text and rfc822 format available.

Removed tag(s) patch. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Fri, 27 May 2011 07:24:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Fri, 27 May 2011 19:12:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Jones <raptorman18@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Fri, 27 May 2011 19:12:02 GMT) Full text and rfc822 format available.

Message #65 received at 620901@bugs.debian.org (full text, mbox):

From: Paul Jones <raptorman18@gmail.com>
To: 620901@bugs.debian.org
Subject: Re: flashplugin-nonfree: Audio has horrible noisy artifacts
Date: Fri, 27 May 2011 15:12:55 -0400
HI, firstly the patch posted here earlier does work. I had previously
used ldpreload to workaround this.

However, if the Red Hat thread is read, you will see that the glib
problem does affect other software. Notably some fluendo codecs. There
is little upside to the changes that were made to glib, yet the
downsides are quite evident. Linus makes the point time and again in
that thread.

Changes to glib should be considered more seriously, as it is in Fedora.

PJ




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Fri, 03 Jun 2011 01:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Christopher Meiklejohn <christopher.meiklejohn@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Fri, 03 Jun 2011 01:39:03 GMT) Full text and rfc822 format available.

Message #70 received at 620901@bugs.debian.org (full text, mbox):

From: Christopher Meiklejohn <christopher.meiklejohn@gmail.com>
To: 620901@bugs.debian.org
Subject: Possible duplicate bug?
Date: Thu, 2 Jun 2011 21:36:31 -0400
Experiencing the same issues in this bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628652




Forcibly Merged 620901 627966 628652. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Tue, 07 Jun 2011 02:45:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Tue, 07 Jun 2011 04:24:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Nieder <jrnieder@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Tue, 07 Jun 2011 04:24:02 GMT) Full text and rfc822 format available.

Message #77 received at 620901@bugs.debian.org (full text, mbox):

From: Jonathan Nieder <jrnieder@gmail.com>
To: anarcat <anarcat@anarcat.ath.cx>
Cc: 620901@bugs.debian.org
Subject: Re: flash audio distortion after glibc upgrade
Date: Mon, 6 Jun 2011 23:21:02 -0500
anarcat wrote:

> I agree this is a flash bug. What I am saying is that this can be fixed
> in glibc, and was actually fixed in:
>
> http://sources.redhat.com/bugzilla/show_bug.cgi?id=12518

Yes.  Imho upstream's fix is a good one.  Alas, it introduces new ABI,
so we can't adopt it until 2.14 is released; http://bugs.debian.org/625522
has more details about this.

> I therefore think we should either wait for Adobe or for glibc to fix
> this.

Meh.  How about something like the following, to start?
---
 debian/changelog |    6 ++++
 README           |   79 ++++++++++++++++++++++++++++++++++++++++++++++++++++-
 2 files changed, 83 insertions(+), 2 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index dd5e9f8..879ac61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+flashplugin-nonfree (1:2.8.3+jrn) local; urgency=low
+
+  * Added information from the wiki page to README.  Works around: #620901.
+
+ -- Jonathan Nieder <jrnieder@gmail.com>  Mon, 06 Jun 2011 23:13:54 -0500
+
 flashplugin-nonfree (1:2.8.3) unstable; urgency=low
 
   * Depends: libgtk2.0-0 (>= 2.14).  Closes: #598390.
diff --git a/README b/README
index c944115..ce66f0d 100644
--- a/README
+++ b/README
@@ -1,2 +1,77 @@
-Please read the information at:
-http://wiki.debian.org/FlashPlayer
+Using the Adobe Flash browser plugin on Debian
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+See http://wiki.debian.org/FlashPlayer for current information about
+this package.
+
+Updating
+--------
+
+To update the Adobe Flash Player, run "update-flashplugin-nonfree
+--install".
+
+Strange audio artifacts
+-----------------------
+
+If the Flash Player sounds like it's trapped in a flooded submarine,
+you are probably running into [1].  See [2] for a workaround.
+
+[1] https://bugs.adobe.com/jira/browse/FP-5739
+[2] /usr/share/doc/libc6/NEWS.Debian.gz
+
+Checking the version number
+---------------------------
+
+To verify the Adobe Flash Player version number installed on your
+system, for example to confirm that a security update has been
+installed, access the About Flash Player page at [3] or right-click on
+content running in Flash Player and select "About Adobe (or
+Macromedia) Flash Player" from the menu. If you use multiple browsers,
+perform the check for each browser you have installed on your system.
+
+[3] http://www.adobe.com/software/flash/about/
+
+Using Flash Player with pulseaudio
+----------------------------------
+
+If you need the Flash Player to work with pulse, you can ask libasound
+to do so in your ~/.asoundrc:
+
+	pcm.pulse {
+	    type pulse
+	}
+
+	ctl.pulse {
+	    type pulse
+	}
+
+	pcm.!default {
+	    type pulse
+	}
+
+	ctl.!default {
+	    type pulse
+	}
+
+Plugin causing high CPU usage
+-----------------------------
+
+In case the plugin causes high CPU usage, try creating a
+/etc/adobe/mms.cfg:
+
+	# Adobe player settings
+	AVHardwareDisable = 0
+	FullScreenDisable = 0
+	LocalFileReadDisable = 1
+	FileDownloadDisable = 1
+	FileUploadDisable = 1
+	LocalStorageLimit = 1
+	ThirdPartyStorage = 1
+	AssetCacheSize = 10
+	AutoUpdateDisable = 1
+	LegacyDomainMatching = 0
+	LocalFileLegacyAction = 0
+	AllowUserLocalTrust = 0
+	# DisableSockets = 1
+	OverrideGPUValidation = 1
+	EnableLinuxHWVideoDecode=1
-- 
1.7.5.3





Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Mon, 13 Jun 2011 18:30:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Carlos C Soto <csoto@sia-solutions.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Mon, 13 Jun 2011 18:30:06 GMT) Full text and rfc822 format available.

Message #82 received at 620901@bugs.debian.org (full text, mbox):

From: Carlos C Soto <csoto@sia-solutions.com>
To: 620901@bugs.debian.org
Subject: [flashplugin-nonfree] Confirmed and path from Adobe works
Date: Mon, 13 Jun 2011 13:20:18 -0500
Package: flashplugin-nonfree
Version: 1:2.8.3

--- Please enter the report below this line. ---

Confirm that bug exists and the patch supplied by Adobe[1] works for version 
10.3 d162

# file libflashplayer.so
libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), 
dynamically linked, stripped

These are the MD5 sums of files:
35c297ffef7a5a7ed8fb4f5526ced799  libflashplayer-changed.so
267bfdb38d14c9d96d0d04e273c3d961  libflashplayer-original.so

[1] https://bugs.adobe.com/jira/browse/FP-5739

--- System information. ---
Architecture: amd64
Kernel: Linux 2.6.38-2-amd64

Debian Release: wheezy/sid
990 testing security.debian.org
990 testing ftp.debian.org
990 testing debian-multimedia.org
990 squeeze-backports mozilla.debian.net
990 squeeze-backports backports.debian.org
500 testing-proposed-updates ftp.debian.org
500 stable dl.google.com
200 unstable ftp.debian.org

--- Package information. ---
Depends (Version) | Installed
==============================-+-===========
debconf | 1.5.39
OR debconf-2.0 |
wget | 1.12-3.1
gnupg | 1.4.11-3
libatk1.0-0 | 2.0.0-1
libcairo2 | 1.10.2-6
libfontconfig1 | 2.8.0-2.2
libfreetype6 | 2.4.4-1
libgcc1 | 1:4.6.0-10
libglib2.0-0 | 2.28.6-1
libgtk2.0-0 (>= 2.14) | 2.24.4-3
libnspr4-0d | 4.8.8-1
libnss3-1d | 3.12.10-1
libpango1.0-0 | 1.28.3-6
libstdc++6 | 4.6.0-10
libx11-6 | 2:1.4.3-1
libxext6 | 2:1.3.0-1
libxt6 | 1:1.1.1-1
libcurl3-gnutls | 7.21.6-1


Package's Recommends field is empty.

Suggests (Version) | Installed
=============================================-+-===========
iceweasel | 4.0.1-1~bpo60+1
konqueror-nsplugins |
x-ttcidfont-conf |
msttcorefonts |
ttf-dejavu | 2.33-1
ttf-xfree86-nonfree |
flashplugin-nonfree-extrasound |



--- Output from package bug script ---
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
49b55c7eb8044453e5f6f2e4b3cb4084 
/var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
35c297ffef7a5a7ed8fb4f5526ced799 /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
flash-mozilla.so - auto mode
link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
lrwxrwxrwx 1 root root 34 jun 3 01:30 /usr/lib/mozilla/plugins/flash-mozilla.so 
-> /etc/alternatives/flash-mozilla.so
/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to 
`/etc/alternatives/flash-mozilla.so'





Information forwarded to debian-bugs-dist@lists.debian.org, julieneula@yahoo.fr, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Fri, 01 Jul 2011 19:03:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Eula <julieneula@yahoo.fr>:
Extra info received and forwarded to list. Copy sent to julieneula@yahoo.fr, Bart Martens <bartm@debian.org>. (Fri, 01 Jul 2011 19:03:07 GMT) Full text and rfc822 format available.

Message #87 received at 620901@bugs.debian.org (full text, mbox):

From: Julien Eula <julieneula@yahoo.fr>
To: Debian Bug Tracking System <620901@bugs.debian.org>
Subject: Re: Binary patch working for 10.3.162, request for inclusion in the package
Date: Fri, 01 Jul 2011 21:00:56 +0200
Package: flashplugin-nonfree
Version: 1:2.8.3
Followup-For: Bug #620901

Hello, I can confirm the binary patch is working for Flash Player 10.3.162 (I'm
running wheezy).
Could the libflashplayer.so be automatically patched by the postinst script in
the package?
I know this would make it depend on bsdiff, is it a problem?

What i have done:
   wget -O /tmp/memcpy-10.3.162.29.bsdiff
https://bugs.adobe.com/jira/secure/attachment/70204/memcpy-10.3.162.29.bsdiff
   sudo aptitude -Ry install bsdiff
   sudo bspatch /usr/lib/flashplugin-nonfree/libflashplayer.so /usr/lib
/flashplugin-nonfree/libflashplayer.so.new /tmp/memcpy-10.3.162.29.bsdiff
   sudo mv /usr/lib/flashplugin-nonfree/libflashplayer.so.new /usr/lib
/flashplugin-nonfree/libflashplayer.so
   rm /tmp/memcpy-10.3.162.29.bsdiff

Thanks.



-- Package-specific info:
Debian version: wheezy/sid
Architecture: amd64
Package version: 1:2.8.3
Adobe Flash Player version: LNX 10,3,162,29
MD5 checksums:
	49b55c7eb8044453e5f6f2e4b3cb4084  /var/cache/flashplugin-nonfree/flashplayer10_2_p3_64bit_linux_111710.tar.gz
	35c297ffef7a5a7ed8fb4f5526ced799  /usr/lib/flashplugin-nonfree/libflashplayer.so
Alternatives:
	flash-mozilla.so - auto mode
	  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
	/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
	Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
	lrwxrwxrwx 1 root root 34 Jun 17 13:49 /usr/lib/mozilla/plugins/flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
	/usr/lib/mozilla/plugins/flash-mozilla.so: symbolic link to `/etc/alternatives/flash-mozilla.so'

-- System Information:
Debian Release: wheezy/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf-2.0]         1.5.39     Debian configuration management sy
ii  gnupg                         1.4.11-3   GNU privacy guard - a free PGP rep
ii  libatk1.0-0                   2.0.0-1    The ATK accessibility toolkit
ii  libcairo2                     1.10.2-6   The Cairo 2D vector graphics libra
ii  libcurl3-gnutls               7.21.6-2   Multi-protocol file transfer libra
ii  libfontconfig1                2.8.0-2.2  generic font configuration library
ii  libfreetype6                  2.4.4-1    FreeType 2 font engine, shared lib
ii  libgcc1                       1:4.6.0-10 GCC support library
ii  libglib2.0-0                  2.28.6-1   The GLib library of C routines
ii  libgtk2.0-0                   2.24.4-3   The GTK+ graphical user interface 
ii  libnspr4-0d                   4.8.8-2    NetScape Portable Runtime Library
ii  libnss3-1d                    3.12.10-1  Network Security Service libraries
ii  libpango1.0-0                 1.28.3-6   Layout and rendering of internatio
ii  libstdc++6                    4.6.0-10   The GNU Standard C++ Library v3
ii  libx11-6                      2:1.4.3-2  X11 client-side library
ii  libxext6                      2:1.3.0-3  X11 miscellaneous extension librar
ii  libxt6                        1:1.1.1-2  X11 toolkit intrinsics library
ii  wget                          1.12-3.1   retrieves files from the web

flashplugin-nonfree recommends no packages.

Versions of packages flashplugin-nonfree suggests:
pn  flashplugin-nonfree-extrasoun <none>     (no description available)
pn  iceweasel                     <none>     (no description available)
pn  konqueror-nsplugins           <none>     (no description available)
pn  ttf-dejavu                    <none>     (no description available)
ii  ttf-mscorefonts-installer [ms 3.3        Installer for Microsoft TrueType c
pn  ttf-xfree86-nonfree           <none>     (no description available)
pn  x-ttcidfont-conf              <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#620901; Package flashplugin-nonfree. (Fri, 12 Aug 2011 23:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jerome Charaoui <jerome@riseup.net>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. (Fri, 12 Aug 2011 23:21:03 GMT) Full text and rfc822 format available.

Message #92 received at 620901@bugs.debian.org (full text, mbox):

From: Jerome Charaoui <jerome@riseup.net>
To: 620901@bugs.debian.org
Subject: Re: Audio has horrible noisy artifacts
Date: Fri, 12 Aug 2011 19:08:04 -0400
Updating Flash today using the command "update-flashplayer-nonfree
--install" fixed the problem for me.

The Flash package downloaded is
flashplayer11_b2_install_lin_64_080811.tar.gz and the version reported
is LNX 11,0,1,98




Reply sent to Bart Martens <bartm@debian.org>:
You have taken responsibility. (Sat, 13 Aug 2011 05:36:05 GMT) Full text and rfc822 format available.

Notification sent to Sam Morris <sam@robots.org.uk>:
Bug acknowledged by developer. (Sat, 13 Aug 2011 05:36:06 GMT) Full text and rfc822 format available.

Message #97 received at 620901-done@bugs.debian.org (full text, mbox):

From: Bart Martens <bartm@debian.org>
To: 620901-done@bugs.debian.org
Subject: [jerome@riseup.net: Bug#620901: Audio has horrible noisy artifacts]
Date: Sat, 13 Aug 2011 05:33:07 +0000
----- Forwarded message from Jerome Charaoui <jerome@riseup.net> -----

Date: Fri, 12 Aug 2011 19:08:04 -0400
From: Jerome Charaoui <jerome@riseup.net>
To: 620901@bugs.debian.org
Subject: Bug#620901: Audio has horrible noisy artifacts
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110626 Iceowl/1.0b2
	Icedove/3.1.11

Updating Flash today using the command "update-flashplayer-nonfree
--install" fixed the problem for me.

The Flash package downloaded is
flashplayer11_b2_install_lin_64_080811.tar.gz and the version reported
is LNX 11,0,1,98



----- End forwarded message -----




Reply sent to Bart Martens <bartm@debian.org>:
You have taken responsibility. (Sat, 13 Aug 2011 05:36:06 GMT) Full text and rfc822 format available.

Notification sent to Paul Jones <raptorman18@gmail.com>:
Bug acknowledged by developer. (Sat, 13 Aug 2011 05:36:06 GMT) Full text and rfc822 format available.

Reply sent to Bart Martens <bartm@debian.org>:
You have taken responsibility. (Sat, 13 Aug 2011 05:36:07 GMT) Full text and rfc822 format available.

Notification sent to Christopher Meiklejohn <christopher.meiklejohn@gmail.com>:
Bug acknowledged by developer. (Sat, 13 Aug 2011 05:36:07 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 22 Sep 2011 07:32:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 10:18:28 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.