Debian Bug report logs - #620646
pgdesigner: uninstallable in sid

version graph

Package: pgdesigner; Maintainer for pgdesigner is Pierre Chifflier <pollux@debian.org>;

Reported by: Julien Cristau <jcristau@debian.org>

Date: Sun, 3 Apr 2011 09:45:02 UTC

Severity: grave

Tags: sid, wheezy

Found in version pgdesigner/1.2.17-2

Fixed in version 1.2.17-2+rm

Done: Debian FTP Masters <ftpmaster@ftp-master.debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Pierre Chifflier <pollux@debian.org>:
Bug#620646; Package pgdesigner. (Sun, 03 Apr 2011 09:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
New Bug report received and forwarded. Copy sent to Pierre Chifflier <pollux@debian.org>. (Sun, 03 Apr 2011 09:45:10 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: pgdesigner: uninstallable in sid
Date: Sun, 3 Apr 2011 11:42:20 +0200
Package: pgdesigner
Version: 1.2.17-2
Severity: grave
Tags: wheezy sid
Justification: renders package unusable

The latest gambas2 version doesn't build gambas2-gb-qt-kde anymore,
making pgdesigner uninstallable.

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Pierre Chifflier <pollux@debian.org>:
Bug#620646; Package pgdesigner. (Tue, 26 Apr 2011 21:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Pierre Chifflier <pollux@debian.org>. (Tue, 26 Apr 2011 21:36:04 GMT) Full text and rfc822 format available.

Message #10 received at 620646@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: 620646@bugs.debian.org, Julien Cristau <jcristau@debian.org>
Subject: pgdesigner: uninstallable in sid
Date: Tue, 26 Apr 2011 23:33:47 +0200
[Message part 1 (text/plain, inline)]
Hi Pierre,

I've prepared an NMU and uploaded it to DELAYED/7. The changelog reads:

pgdesigner (1.2.17-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Drop dependency on gambas2-gb-qt-kde and gambas2-gb-qt-kde-html.
    See http://wiki.debian.org/kdelibs4c2aRemoval. (Closes: #620646)

 -- Michael Biebl <biebl@debian.org>  Tue, 26 Apr 2011 23:24:24 +0200

Cheers,
Michael
-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?
[pgdesigner-nmu.diff (text/plain, attachment)]
[signature.asc (application/pgp-signature, attachment)]

Added tag(s) pending. Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Tue, 26 Apr 2011 21:39:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#620646; Package pgdesigner. (Thu, 28 Apr 2011 12:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pierre Chifflier <pollux@debian.org>:
Extra info received and forwarded to list. (Thu, 28 Apr 2011 12:48:04 GMT) Full text and rfc822 format available.

Message #17 received at 620646@bugs.debian.org (full text, mbox):

From: Pierre Chifflier <pollux@debian.org>
To: Michael Biebl <biebl@debian.org>, 620646@bugs.debian.org
Cc: Julien Cristau <jcristau@debian.org>
Subject: Re: Bug#620646: pgdesigner: uninstallable in sid
Date: Thu, 28 Apr 2011 14:07:15 +0200
On 04/26/2011 11:33 PM, Michael Biebl wrote:
> Hi Pierre,
>
> I've prepared an NMU and uploaded it to DELAYED/7. The changelog reads:
>
> pgdesigner (1.2.17-2.1) unstable; urgency=low
>
>    * Non-maintainer upload.
>    * Drop dependency on gambas2-gb-qt-kde and gambas2-gb-qt-kde-html.
>      See http://wiki.debian.org/kdelibs4c2aRemoval. (Closes: #620646)
>
>   -- Michael Biebl<biebl@debian.org>   Tue, 26 Apr 2011 23:24:24 +0200
>
> Cheers,
> Michael


Hi,

I have tested the packages here. Unfortunately, it does not solve the 
problem since these dependencies are required at runtime:
$ pgdesigner
ERROR: #27: Cannot load component 'gb.qt.kde': cannot find library file

After discussing with the Gambas maintainer and upstream, it seems that 
upstream does not want to port gambas to Qt4, meaning that 
gambas2-gb-qt-kde will probably not be available anymore in Debian.
Most probable solution is that I'll have to ask the removal of the 
package from Debian until its dependencies can be packaged.
In the meantime, I'll ask you to cancel your upload an keep the bug open.

Thanks,
Pierre




Information forwarded to debian-bugs-dist@lists.debian.org, Pierre Chifflier <pollux@debian.org>:
Bug#620646; Package pgdesigner. (Thu, 28 Apr 2011 13:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Pierre Chifflier <pollux@debian.org>. (Thu, 28 Apr 2011 13:36:03 GMT) Full text and rfc822 format available.

Message #22 received at 620646@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Pierre Chifflier <pollux@debian.org>
Cc: 620646@bugs.debian.org, Julien Cristau <jcristau@debian.org>
Subject: Re: Bug#620646: pgdesigner: uninstallable in sid
Date: Thu, 28 Apr 2011 13:13:56 +0200
[Message part 1 (text/plain, inline)]
Am 28.04.2011 14:07, schrieb Pierre Chifflier:
> On 04/26/2011 11:33 PM, Michael Biebl wrote:
>> Hi Pierre,
>>
>> I've prepared an NMU and uploaded it to DELAYED/7. The changelog reads:
>>
>> pgdesigner (1.2.17-2.1) unstable; urgency=low
>>
>>    * Non-maintainer upload.
>>    * Drop dependency on gambas2-gb-qt-kde and gambas2-gb-qt-kde-html.
>>      See http://wiki.debian.org/kdelibs4c2aRemoval. (Closes: #620646)
>>
>>   -- Michael Biebl<biebl@debian.org>   Tue, 26 Apr 2011 23:24:24 +0200
>>
>> Cheers,
>> Michael
> 
> 
> Hi,
> 
> I have tested the packages here. Unfortunately, it does not solve the 
> problem since these dependencies are required at runtime:
> $ pgdesigner
> ERROR: #27: Cannot load component 'gb.qt.kde': cannot find library file
> 
> After discussing with the Gambas maintainer and upstream, it seems that 
> upstream does not want to port gambas to Qt4, meaning that 
> gambas2-gb-qt-kde will probably not be available anymore in Debian.
> Most probable solution is that I'll have to ask the removal of the 
> package from Debian until its dependencies can be packaged.
> In the meantime, I'll ask you to cancel your upload an keep the bug open.

I've cancelled the upload.
Would you be so kind an file a RM bug for pgdesigner (or reassign this one to
ftp.debian.org) until this has been sorted out.
pgdesigner is the only remaining package which blocks the kdelibs removal from
testing which in turn blocks other packages, like avahi, from migrating to
testing. [1]

Cheers,
Michael

[1] http://release.debian.org/migration/testing.pl?package=avahi
-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Pierre Chifflier <pollux@debian.org>:
Bug#620646; Package pgdesigner. (Thu, 28 Apr 2011 13:48:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pierre Chifflier <chifflier@wzdftpd.net>:
Extra info received and forwarded to list. Copy sent to Pierre Chifflier <pollux@debian.org>. (Thu, 28 Apr 2011 13:48:09 GMT) Full text and rfc822 format available.

Message #27 received at 620646@bugs.debian.org (full text, mbox):

From: Pierre Chifflier <chifflier@wzdftpd.net>
To: debian-release@lists.debian.org
Cc: 620646@bugs.debian.org, Michael Biebl <biebl@debian.org>, Julien Cristau <jcristau@debian.org>
Subject: RM: pgdesigner -- ROM; uninstallable, blocks kdelibs removal
Date: Thu, 28 Apr 2011 15:35:42 +0200
Hi,

pgdesigner is actually uninstallable due to the removal of
gambas2-gb-qt-kde and gambas2-gb-qt-kde-html (See #620646).

After some discussions with the gambas maintainer (#620646) and
upstream, it seems there is no solution since upstream is not really
willing to port gambas to Qt4 [1]

Without any better solution, I request the removal of pgdesigner.

Cheers,
Pierre

[1] http://sourceforge.net/mailarchive/forum.php?thread_name=4D77ED70.9060804%40csolve.net&forum_name=gambas-devel




Information forwarded to debian-bugs-dist@lists.debian.org, Pierre Chifflier <pollux@debian.org>:
Bug#620646; Package pgdesigner. (Thu, 28 Apr 2011 21:24:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Pierre Chifflier <pollux@debian.org>. (Thu, 28 Apr 2011 21:24:06 GMT) Full text and rfc822 format available.

Message #32 received at 620646@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: "Pierre Chifflier" <chifflier@wzdftpd.net>
Cc: debian-release@lists.debian.org, 620646@bugs.debian.org, "Michael Biebl" <biebl@debian.org>, "Julien Cristau" <jcristau@debian.org>
Subject: Re: RM: pgdesigner -- ROM; uninstallable, blocks kdelibs removal
Date: Thu, 28 Apr 2011 22:20:16 +0100
On Thu, April 28, 2011 14:35, Pierre Chifflier wrote:
> pgdesigner is actually uninstallable due to the removal of
> gambas2-gb-qt-kde and gambas2-gb-qt-kde-html (See #620646).
>
> After some discussions with the gambas maintainer (#620646) and
> upstream, it seems there is no solution since upstream is not really
> willing to port gambas to Qt4 [1]
>
> Without any better solution, I request the removal of pgdesigner.

I added a removal hint for pgdesigner earlier this afternoon, having
spotted the comments in #620646, in order to try and get the migration of
kdelibs / avahi unjammed.  Thanks for confirming that you agree with (or
at least understand) that action.

Regards,

Adam





Removed tag(s) pending. Request was from kitterma@mailout00.controlledmail.com (Scott Kitterman) to control@bugs.debian.org. (Fri, 19 Aug 2011 03:03:02 GMT) Full text and rfc822 format available.

Reply sent to Debian FTP Masters <ftpmaster@ftp-master.debian.org>:
You have taken responsibility. (Mon, 05 Mar 2012 10:01:15 GMT) Full text and rfc822 format available.

Notification sent to Julien Cristau <jcristau@debian.org>:
Bug acknowledged by developer. (Mon, 05 Mar 2012 10:01:15 GMT) Full text and rfc822 format available.

Message #39 received at 620646-done@bugs.debian.org (full text, mbox):

From: Debian FTP Masters <ftpmaster@ftp-master.debian.org>
To: 504374-done@bugs.debian.org,512990-done@bugs.debian.org,517980-done@bugs.debian.org,543265-done@bugs.debian.org,620646-done@bugs.debian.org,
Cc: pgdesigner@packages.debian.org, pgdesigner@packages.qa.debian.org
Subject: Bug#662201: Removed package(s) from unstable
Date: Mon, 05 Mar 2012 09:58:45 +0000
Version: 1.2.17-2+rm

Dear submitter,

as the package pgdesigner has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/662201

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Alexander Reichle-Schmehl (the ftpmaster behind the curtain)




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 03 Apr 2012 07:43:36 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 15:50:45 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.