Debian Bug report logs - #617549
[zapping] segmentation fault

Package: xserver-xorg-driver-ati; Maintainer for xserver-xorg-driver-ati is (unknown);

Reported by: dpdt1 <dpdt1@riseup.net>

Date: Wed, 9 Mar 2011 18:21:15 UTC

Severity: important

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Robert Luberda <robert@debian.org>:
Bug#617549; Package zapping. (Wed, 09 Mar 2011 18:21:18 GMT) Full text and rfc822 format available.

Acknowledgement sent to dpdt1 <dpdt1@riseup.net>:
New Bug report received and forwarded. Copy sent to Robert Luberda <robert@debian.org>. (Wed, 09 Mar 2011 18:21:18 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: dpdt1 <dpdt1@riseup.net>
To: submit@bugs.debian.org
Subject: [zapping] segmentation fault
Date: Wed, 09 Mar 2011 20:20:42 +0200
Package: zapping
Version: 0.10~cvs6-4+b2
Severity: grave

--- Please enter the report below this line. ---

hello,

cannot start zapping no matter what. bash output : 

$ zapping
Segmentation fault
$

the only logged messages i see, are in Xorg.0.log :

xf86CheckModeForDriver: called with invalid scrnInfoRec

every time i try to start zapping (console or menu), i get 7 of these messages, in Xorg.0.log

thx,

dpdt1



--- System information. ---
Architecture: amd64
Kernel:       Linux 2.6.32-5-openvz-amd64

Debian Release: 6.0
  500 stable          security.debian.org 
  500 stable          ftp.gr.debian.org 
  500 squeeze-updates ftp.gr.debian.org 

--- Package information. ---
Depends                 (Version) | Installed
=================================-+-===============
libartsc0              (>= 1.5.9) | 1.5.9-3+b2
libc6                  (>= 2.3.3) | 2.11.2-10
libesd0               (>= 0.2.35) | 0.2.41-8
libgconf2-4           (>= 2.27.0) | 2.28.1-6
libglade2-0          (>= 1:2.6.1) | 1:2.6.4-1
libglib2.0-0          (>= 2.24.0) | 2.24.2-1
libgnome2-0           (>= 2.17.3) | 2.30.0-1
libgnomeui-0          (>= 2.22.0) | 2.24.3-1
libgnomevfs2-0     (>= 1:2.17.90) | 1:2.24.3-1
libgtk2.0-0           (>= 2.18.0) | 2.20.1-2
libjpeg62                (>= 6b1) | 6b1-1
liblircclient0                    | 0.8.3-5
libpango1.0-0         (>= 1.14.0) | 1.28.3-1+squeeze2
libpng12-0          (>= 1.2.13-4) | 1.2.44-1
libpython2.6             (>= 2.6) | 2.6.6-8+b1
libx11-6                          | 2:1.3.3-4
libxext6                          | 2:1.1.2-1
libxinerama1                      | 2:1.1-3
libxml2                (>= 2.7.4) | 2.7.8.dfsg-2
libxmu6                           | 2:1.0.5-2
libxv1                            | 2:1.0.5-1
libxxf86dga1                      | 2:1.1.1-2
libxxf86vm1                       | 1:1.1.0-2
libzvbi0              (>= 0.2.11) | 0.2.33-1
gconf2              (>= 2.28.1-2) | 2.28.1-6


Package's Recommends field is empty.

Package's Suggests field is empty.









Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#617549; Package zapping. (Wed, 09 Mar 2011 23:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Luberda <robert@debian.org>:
Extra info received and forwarded to list. (Wed, 09 Mar 2011 23:18:03 GMT) Full text and rfc822 format available.

Message #10 received at 617549@bugs.debian.org (full text, mbox):

From: Robert Luberda <robert@debian.org>
To: dpdt1 <dpdt1@riseup.net>, 617549@bugs.debian.org
Subject: Re: Bug#617549: [zapping] segmentation fault
Date: Wed, 09 Mar 2011 23:28:25 +0100
dpdt1 writes:

Hi,

> 
> cannot start zapping no matter what. bash output : 
> 
> $ zapping
> Segmentation fault


Could you please run the two following commands:

/usr/sbin/zapping_setup_fb -vv 2> zapping-setup-fb.out
/usr/bin/zapping --debug --console-errors 2> zapping.out

and send me the two *.out files?

It would be also useful if you could provide a stack backtrace generated
by gdb, if you know how to do this (if not I can guide you later).

What tv card do you have installed in your system? Does any other tv
programs like xawtv or tvtime work for you?

Regards,
robert




Information forwarded to debian-bugs-dist@lists.debian.org, Robert Luberda <robert@debian.org>:
Bug#617549; Package zapping. (Thu, 10 Mar 2011 00:09:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to "dpdt1" <dpdt1@riseup.net>:
Extra info received and forwarded to list. Copy sent to Robert Luberda <robert@debian.org>. (Thu, 10 Mar 2011 00:09:07 GMT) Full text and rfc822 format available.

Message #15 received at 617549@bugs.debian.org (full text, mbox):

From: "dpdt1" <dpdt1@riseup.net>
To: 617549@bugs.debian.org
Subject: Re: Bug#617549: [zapping] segmentation fault
Date: Thu, 10 Mar 2011 02:06:18 +0200 (EET)
[Message part 1 (text/plain, inline)]
hello,

i thought it was an xorg error so i removed xserver-xorg-driver-ati and
using only radeon driver now. (ati radeon X300 vga)
rebooting desktop i can now start zapping app normally.
(so maybe you can remove grave status now.)

tv card is a Lifeview Flytv Platinum FM / GO
identifies as :
# lspci
01:07.0 Multimedia controller: Philips Semiconductors
SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)

with autoloaded mod saa7134.

giving the 2 commands as suggested and attaching files.

1.
$ /usr/sbin/zapping_setup_fb -vv 2> zapping-setup-fb.out
Segmentation fault
$

2.
$ /usr/bin/zapping --debug --console-errors 2> zapping.out

for gdb i can try this guide (?) :
http://wiki.debian.org/HowToGetABacktrace
but last time i tried, i couldnt get much (xserver error..)  :-)

thanks,

dpdt1.
[zapping-setup-fb.out (application/octet-stream, attachment)]
[zapping.out (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Robert Luberda <robert@debian.org>:
Bug#617549; Package zapping. (Sat, 03 Mar 2012 15:18:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Javi Merino <vicho@debian.org>:
Extra info received and forwarded to list. Copy sent to Robert Luberda <robert@debian.org>. (Sat, 03 Mar 2012 15:18:05 GMT) Full text and rfc822 format available.

Message #20 received at 617549@bugs.debian.org (full text, mbox):

From: Javi Merino <vicho@debian.org>
To: 617549@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Zapping segfaults with xserver-xorg-driver-ati
Date: Sat, 3 Mar 2012 15:14:41 +0000
[Message part 1 (text/plain, inline)]
reassign 617549 xserver-xorg-driver-ati
severity 617549 important
thanks

dpdt1 wrote:
> i thought it was an xorg error so i removed xserver-xorg-driver-ati and
> using only radeon driver now. (ati radeon X300 vga)
> rebooting desktop i can now start zapping app normally.
> (so maybe you can remove grave status now.)

It looks like a bug in the ati driver for your card, rather than a bug
in zapping.  Zapping works on the framebuffer and it fails with
xserver-xorg-driver-ati when openning the video device:

> (C) 2000-2005 IƱaki G. Etxebarria, Michael H. Schimek.
> This program is freely redistributable under the terms
> of the GNU General Public License.
> 
> Using video device '/dev/video0', display ':0.0', screen -1.
> Querying frame buffer parameters from X server.
> Xinerama base 0, 0, version 1.1
> DGA base 65, 135, version 2.0
> Screen 0:
>   position               0, 0 - 1280, 1024
>   frame buffer address   0xffffffffe00c0000
>   frame buffer size      1280x1024 pixels, 0x500000 bytes
>   bytes per line         5120 bytes
>   pixfmt                 BGRA32_LE
> Opening device /dev/video0.
> 3 = open ("/dev/video0", RDWR
[signature.asc (application/pgp-signature, inline)]

Bug reassigned from package 'zapping' to 'xserver-xorg-driver-ati'. Request was from Javi Merino <vicho@debian.org> to control@bugs.debian.org. (Sat, 03 Mar 2012 15:18:07 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions zapping/0.10~cvs6-4. Request was from Javi Merino <vicho@debian.org> to control@bugs.debian.org. (Sat, 03 Mar 2012 15:18:07 GMT) Full text and rfc822 format available.

Severity set to 'important' from 'grave' Request was from Javi Merino <vicho@debian.org> to control@bugs.debian.org. (Sat, 03 Mar 2012 15:18:08 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 22:50:24 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.