Debian Bug report logs - #614328
live-build cannot create a live user

version graph

Package: live-build; Maintainer for live-build is Live Systems Maintainers <debian-live@lists.debian.org>; Source for live-build is src:live-build.

Reported by: Piotr <upiter77@lycos.com>

Date: Mon, 21 Feb 2011 02:15:02 UTC

Severity: important

Found in version live-build/2.0.12-2

Done: Daniel Baumann <daniel.baumann@progress-technologies.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, upiter77@lycos.com, Debian Live Project <debian-live@lists.debian.org>:
Bug#614328; Package live-build. (Mon, 21 Feb 2011 02:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Piotr <upiter77@lycos.com>:
New Bug report received and forwarded. Copy sent to upiter77@lycos.com, Debian Live Project <debian-live@lists.debian.org>. (Mon, 21 Feb 2011 02:15:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Piotr <upiter77@lycos.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: live-build cannot create a live user
Date: Mon, 21 Feb 2011 02:13:57 +0100
Package: live-build
Version: 2.0.12-2
Severity: important


I've created a live usb-hdd on squeeze, but the live user was not created.
If I boot this image I get this message:

live-config: hostname user-setupadduser: The GID 1000 is already in use.
usermod: user 'user' does not exist
 sudosudo: unknown user: user
:ERROR


-- Package-specific info:

-- System Information:
Debian Release: 6.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages live-build depends on:
ii  cdebootstrap                  0.5.7      Bootstrap a Debian system
ii  debootstrap                   1.0.26     Bootstrap a basic Debian system

Versions of packages live-build recommends:
ii  cpio                          2.11-4     GNU cpio -- a program to manage ar
ii  gnu-fdisk                     1.2.4-3    Linux fdisk replacement based on l

Versions of packages live-build suggests:
ii  dosfstools           3.0.9-1             utilities for making and checking 
ii  genisoimage          9:1.1.11-1          Creates ISO-9660 CD-ROM filesystem
ii  grub                 0.97-64             GRand Unified Bootloader (dummy pa
pn  memtest86+ | memtest <none>              (no description available)
ii  mtools               4.0.12-1            Tools for manipulating MSDOS files
pn  parted               <none>              (no description available)
pn  squashfs-tools | gen <none>              (no description available)
ii  sudo                 1.7.4p4-2.squeeze.1 Provide limited super user privile
ii  syslinux             2:4.02+dfsg-7       collection of boot loaders
ii  uuid-runtime         2.17.2-9            runtime components for the Univers
pn  win32-loader         <none>              (no description available)

-- no debconf information




Reply sent to daniel.baumann@progress-technologies.net:
You have taken responsibility. (Mon, 21 Feb 2011 05:42:04 GMT) Full text and rfc822 format available.

Notification sent to Piotr <upiter77@lycos.com>:
Bug acknowledged by developer. (Mon, 21 Feb 2011 05:42:04 GMT) Full text and rfc822 format available.

Message #10 received at 614328-done@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel.baumann@progress-technologies.net>
To: Piotr <upiter77@lycos.com>, 614328-done@bugs.debian.org
Subject: Re: Bug#614328: live-build cannot create a live user
Date: Mon, 21 Feb 2011 06:39:40 +0100
On 02/21/2011 02:13 AM, Piotr wrote:
> I've created a live usb-hdd on squeeze, but the live user was not created.

first, this is not a live-build problem, but one with live-config.

> If I boot this image I get this message:
> 
> live-config: hostname user-setupadduser: The GID 1000 is already in use.
> usermod: user 'user' does not exist
>  sudosudo: unknown user: user
> :ERROR

second, this is a local issue with your configuration. live-config
insists of making it's user with uid 1000/gid 1000. apparently you did
create a local user through the config tree (e.g. local hooks, or manual
manipulation). make sure you don't use uid 1000 and you'll be fine.

-- 
Address:        Daniel Baumann, Burgunderstrasse 3, CH-4562 Biberist
Email:          daniel.baumann@progress-technologies.net
Internet:       http://people.progress-technologies.net/~daniel.baumann/




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 21 Mar 2011 07:33:33 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 01:26:52 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.