Debian Bug report logs - #613431
ITP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit

version graph

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Emil Langrock <emil.langrock@gmx.de>

Date: Mon, 14 Feb 2011 20:33:04 UTC

Owned by: olly@survex.com

Severity: wishlist

Fixed in version wxwidgets3.0/3.0.0-1

Done: Olly Betts <olly@survex.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#613431; Package wnpp. (Mon, 14 Feb 2011 20:33:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Emil Langrock <emil.langrock@gmx.de>:
New Bug report received and forwarded. Copy sent to wnpp@debian.org. (Mon, 14 Feb 2011 20:33:07 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Emil Langrock <emil.langrock@gmx.de>
To: submit@bugs.debian.org
Cc: freewx-maint@lists.alioth.debian.org
Subject: RFP: wxWidgets Cross-platform C++ GUI toolkit
Date: Mon, 14 Feb 2011 21:32:07 +0100
Package: wnpp
Severity: wishlist

* Package name    : wxwidgets2.9
  Version         : 2.9.1
  Upstream Author : Cant find it on the website
* URL             : http://www.wxwidgets.org/
* License         : wxWindows Library License
  Programming Lang: C++
  Description     : wxWidgets Cross-platform C++ GUI toolkit

wxWidgets (formerly known as wxWindows) is a class library for C++ providing 
GUI components and other facilities on several popular platforms (and some 
unpopular ones as well). For more information see http://wxwidgets.org

New version of software or new software appears on the horizon which uses 
wxwidget 2.9 only functionality. These software could be uploaded to 
experimental, but Debian doesn't provide this version at all.




Changed Bug title to 'RFP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit' from 'RFP: wxWidgets Cross-platform C++ GUI toolkit' Request was from Emil Langrock <emil.langrock@gmx.de> to control@bugs.debian.org. (Mon, 14 Feb 2011 20:39:05 GMT) Full text and rfc822 format available.

Added indication that bug 613431 blocks 637771 Request was from Clara Gnos <clara.gnos@googlemail.com> to control@bugs.debian.org. (Sun, 14 Aug 2011 10:03:22 GMT) Full text and rfc822 format available.

Added indication that bug 613431 blocks 627263 Request was from Olly Betts <olly@survex.com> to control@bugs.debian.org. (Tue, 11 Oct 2011 01:03:09 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#613431; Package wnpp. (Wed, 12 Oct 2011 01:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Wed, 12 Oct 2011 01:21:03 GMT) Full text and rfc822 format available.

Message #16 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: 613431@bugs.debian.org
Cc: freewx-maint@lists.alioth.debian.org
Subject: Re: Bug#613431: RFP: wxWidgets Cross-platform C++ GUI toolkit
Date: Wed, 12 Oct 2011 13:50:05 +1300
On Mon, Feb 14, 2011 at 09:32:07PM +0100, Emil Langrock wrote:
> New version of software or new software appears on the horizon which uses 
> wxwidget 2.9 only functionality. These software could be uploaded to 
> experimental, but Debian doesn't provide this version at all.

Unfortunately 2.9 is a development release series and has no guarantees
of API stability, which means it's not terribly suitable for packaging.
Every point release (e.g. 2.9.2 to 2.9.3) would be like trying to
move the archive from 2.6 to 2.8, which is just unfeasible given the
number of reverse dependencies of wx.

So this will probably need to wait until it matures and becomes 3.0.x.
Latest word I've seen is "3.0 will probably happen in the beginning of
the next year rather than in this one" at:

http://wxwidgets.blogspot.com/2011/07/292-and-plans-for-future.html

However the "huge amounts of the new code that will hopefully be in
2.9.3" makes me wonder if the start of 2012 is a realistic target.

It's rather unhelpful for upstream to be encouraging new projects to
require wx 2.9, when it isn't ABI or even API stable, but that's the
situation.

Cheers,
    Olly




Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#613431; Package wnpp. (Sat, 12 Nov 2011 05:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Sat, 12 Nov 2011 05:24:03 GMT) Full text and rfc822 format available.

Message #21 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: 613431@bugs.debian.org
Cc: freewx-maint@lists.alioth.debian.org
Subject: Re: Bug#613431: RFP: wxWidgets Cross-platform C++ GUI toolkit
Date: Sat, 12 Nov 2011 18:21:55 +1300
retitle 613431 ITP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit
owner 613431 olly@survex.com
thanks

My current work pushing to eliminate wxwidgets2.6 from the archive is
progressing nicely, and I'm pretty confident we can get that done by the
end of the year, and we're nearly at the stage where all that's left is
giving maintainers a reasonable opportunity to make the needed changes,
and NMU those packages that remain unfixed.

So the next logical step seems to be to package wxwidgets2.9 to
experimental which will new packages wanting to use it to at least get
started, and will hopefully allow us to be ready when 3.0 gets released
(since the 3.0 package should be very similar to the last 2.9 ones).

Cheers,
    Olly




Changed Bug title to 'ITP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit' from 'RFP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit' Request was from Olly Betts <olly@survex.com> to control@bugs.debian.org. (Sat, 12 Nov 2011 05:24:05 GMT) Full text and rfc822 format available.

Owner recorded as olly@survex.com. Request was from Olly Betts <olly@survex.com> to control@bugs.debian.org. (Sat, 12 Nov 2011 05:24:05 GMT) Full text and rfc822 format available.

Removed indication that bug 613431 blocks 627263 Request was from Carlo Stemberger <carlo.stemberger@gmail.com> to control@bugs.debian.org. (Tue, 22 Nov 2011 21:57:06 GMT) Full text and rfc822 format available.

Added indication that bug 613431 blocks 691384 Request was from Sebastian Reichel <sre@ring0.de> to control@bugs.debian.org. (Wed, 24 Oct 2012 23:51:04 GMT) Full text and rfc822 format available.

Added indication that bug 613431 blocks 535073 Request was from Brandon <winterknight@nerdshack.com> to control@bugs.debian.org. (Wed, 29 May 2013 03:06:09 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Sat, 01 Jun 2013 05:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Brandon <winterknight@nerdshack.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Sat, 01 Jun 2013 05:27:04 GMT) Full text and rfc822 format available.

Message #36 received at 613431@bugs.debian.org (full text, mbox):

From: Brandon <winterknight@nerdshack.com>
To: Olly Betts <olly@survex.com>
Cc: 613431@bugs.debian.org, wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Subject: Packaging wxwidgets2.9
Date: Fri, 31 May 2013 22:23:24 -0700
Hi Olly. What are your intentions toward packaging wxwidgets 2.9? Is it
something you are still interested in? You are still listed as the
owner of the ITP, but the bug report hasn't had any significant
activity in the last 18 months.

If you are no longer interested, I am.

-Brandon




Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Wed, 05 Jun 2013 12:30:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Wed, 05 Jun 2013 12:30:04 GMT) Full text and rfc822 format available.

Message #41 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: Brandon <winterknight@nerdshack.com>, 613431@bugs.debian.org
Cc: wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Subject: Re: Bug#613431: Packaging wxwidgets2.9
Date: Wed, 5 Jun 2013 12:59:27 +0100
On Fri, May 31, 2013 at 10:23:24PM -0700, Brandon wrote:
> Hi Olly. What are your intentions toward packaging wxwidgets 2.9? Is it
> something you are still interested in? You are still listed as the
> owner of the ITP, but the bug report hasn't had any significant
> activity in the last 18 months.

The main issue remains that 2.9 is a development series - the API and
ABI can both change incompatibly between versions, which means that
each new 2.9.x version would be like 2.6 to 2.8 in terms of work for
Debian (and as I was the main driver for that migration, I have a good
idea of what that's like).

I do realise that 2.9.x is needed by a growing number of applications
(especially as wxwidgets.org suggests you might prefer to use it for new
applications).

I've been talking to upstream about this, and explaining the problems
that the current situation creates for distros (especially those with
binary packages, but the potential for API changes is a problem for
source-based distros too).  They seem sympathetic, and I'm hoping we
can set things on course to actually get a 3.0 release out.

Meanwhile my plan is to get 2.9 packages staged in experimental, which
will allow maintainers to test their existing packages with 2.9, and
also to work on new packages which need 2.9.

Once we have a better idea how hard 2.8 to 2.9 will be, we can make a
more informed plan for what goes in Jessie.  Ideally I'd like to have
just one wx version in Jessie, and that to be 3.0.

Cheers,
    Olly



Added indication that bug 613431 blocks 712303 Request was from Olly Betts <olly@survex.com> to control@bugs.debian.org. (Sat, 06 Jul 2013 03:36:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Sat, 06 Jul 2013 03:57:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Sat, 06 Jul 2013 03:57:05 GMT) Full text and rfc822 format available.

Message #48 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: Tobias Frost <tobi@coldtobi.de>, 713864@bugs.debian.org
Cc: Debian Bug Tracking System <control@bugs.debian.org>, 613431@bugs.debian.org
Subject: Re: Bug#713864: wxwidgets2.8: Please update to 2.9 (and enable gtkprinting)
Date: Sat, 6 Jul 2013 15:33:27 +1200
unblock 712303 with 713864
block 712303 with 613431
close 713864
thanks

On Sun, Jun 23, 2013 at 01:57:05PM +0200, Tobias Frost wrote:
> Reading #644571 I understand that only updateing to wxwidgets2.9 will
> solve this (or keeping libgnomeprintui2.2 some longer).
> 
> As the gnomeprint is supposed to be removed, the only option seems to
> upgrade to 2.9 ASAP, because this will prevent kicad from being
> packaged. (and the version in debian is *really* old, breaking e.g
> some libraries (for electrical componens) avaialable in the net)

There's already an ITP bug for wxwidgets2.9:

http://bugs.debian.org/613431

That's the appropriate place to discuss upgrading to 2.9, so I've
adjusted your block and I'm going to close 713864.  Not having packages
of wx2.9 isn't a bug in wx2.8.

The fundamental problem which still remains is that wx 2.9 isn't ABI
stable, so makes it painful to maintain packages of it.  Every 2.9.x
minor release would essentially be like transitioning the archive from
wx 2.6 to 2.8.  Debian actually had packages of 2.5.x many years ago,
but I'm told it didn't work out all that well (it was before I was
involved in wx maintenance).

I've talked to wx upstream and they are aware of the pain that the
current situation is causing distros with binary packages.  Hopefully
they'll actually finally get 3.0 out, but if that isn't looking likely
to happen in time for jessie, we'll have to make a decision on what
to do.  The best option may be to pick a 2.9.x release and stick to
it.

Meanwhile my plan is to package 2.9.5 once it is released (I'm lead to
believe it isn't far off) and upload that to experimental so we can work
on making sure all the packages which use wx are ready for a transition.
The ideal would be to have just one version of wx in jessie, be it 2.8,
2.9 or 3.0.

Cheers,
    Olly



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Sun, 11 Aug 2013 20:18:20 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastian Reichel <sre@ring0.de>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Sun, 11 Aug 2013 20:18:20 GMT) Full text and rfc822 format available.

Message #53 received at 613431@bugs.debian.org (full text, mbox):

From: Sebastian Reichel <sre@ring0.de>
To: 613431@bugs.debian.org
Cc: olly@survex.com
Subject: status update?
Date: Sun, 11 Aug 2013 22:17:48 +0200
[Message part 1 (text/plain, inline)]
Hi Olly,

What's the status of your packaging? wxWidgets 2.9.5 has been
released roughly a month ago. I would like to update aegisub to 3.x
branch, since 2.x branch is no longer maintained by upstream
maintainers.

ABI bumps in libwxWidgets would mainly be a problem for reverse
dependencies. From my perspective (maintainer of a reverse
depdendency) multiple ABI bumps in wxWidgets are the lesser evil
compared to being totally unsupported by upstream developers.

Please note, that having software with an unstable API in Debian is
not that uncommon (enlightenment [by now stable], libfso*,
libradare*, ...).  It obviously increases the maintenance work,
though.

-- Sebastian
[signature.asc (application/pgp-signature, inline)]

Added indication that bug 613431 blocks 703150 Request was from Daniel Leidert <dleidert@debian.org> to control@bugs.debian.org. (Mon, 19 Aug 2013 22:39:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Wed, 04 Sep 2013 08:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastian Reichel <sre@ring0.de>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Wed, 04 Sep 2013 08:27:04 GMT) Full text and rfc822 format available.

Message #60 received at 613431@bugs.debian.org (full text, mbox):

From: Sebastian Reichel <sre@ring0.de>
To: Olly Betts <olly@survex.com>
Cc: 613431@bugs.debian.org
Subject: Re: status update?
Date: Wed, 4 Sep 2013 10:22:51 +0200
[Message part 1 (text/plain, inline)]
On Wed, Sep 04, 2013 at 02:32:51AM +0100, Olly Betts wrote:
> > ABI bumps in libwxWidgets would mainly be a problem for reverse
> > dependencies. From my perspective (maintainer of a reverse
> > depdendency) multiple ABI bumps in wxWidgets are the lesser evil
> > compared to being totally unsupported by upstream developers.
> 
> wx 2.8 isn't totally unsupported upstream.  It's true that there haven't
> been any wx 2.8 releases for ages, but there are still commits to the
> branch - last was 18 days ago as I write this: [...]

I was talking about the reverse dependencies here. Reverse
dependencies, which have switched to wx 2.9 cannot be upgraded
in Debian and old releases are no longer supported by upstream.

-- Sebastian
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Thu, 05 Sep 2013 11:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Thu, 05 Sep 2013 11:03:04 GMT) Full text and rfc822 format available.

Message #65 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: Sebastian Reichel <sre@ring0.de>
Cc: 613431@bugs.debian.org
Subject: Re: status update?
Date: Wed, 4 Sep 2013 02:32:51 +0100
On Sun, Aug 11, 2013 at 10:17:48PM +0200, Sebastian Reichel wrote:
> What's the status of your packaging? wxWidgets 2.9.5 has been
> released roughly a month ago. I would like to update aegisub to 3.x
> branch, since 2.x branch is no longer maintained by upstream
> maintainers.

I've been on vacation, and then my wx packaging energies were taken with
sorting out wx 2.8 bugs which were reported while I was away.

Hopefully I should be on to 2.9 soon though.

> ABI bumps in libwxWidgets would mainly be a problem for reverse
> dependencies. From my perspective (maintainer of a reverse
> depdendency) multiple ABI bumps in wxWidgets are the lesser evil
> compared to being totally unsupported by upstream developers.

wx 2.8 isn't totally unsupported upstream.  It's true that there haven't
been any wx 2.8 releases for ages, but there are still commits to the
branch - last was 18 days ago as I write this:

https://github.com/wxWidgets/wxWidgets/commits/WX_2_8_BRANCH

> Please note, that having software with an unstable API in Debian is
> not that uncommon (enlightenment [by now stable], libfso*,
> libradare*, ...).  It obviously increases the maintenance work,
> though.

The increased maintenance work is a real issue.  I'm the only active
member of the wx maintenance team at the moment, with limited time to
devote to it, and wx has a lot of reverse dependencies (many without an
active maintainer judging from the number of NMUs I had to do to get rid
of wx 2.6).

Cheers,
    Olly



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Sun, 15 Sep 2013 11:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Johannes Schauer <j.schauer@email.de>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Sun, 15 Sep 2013 11:51:04 GMT) Full text and rfc822 format available.

Message #70 received at 613431@bugs.debian.org (full text, mbox):

From: Johannes Schauer <j.schauer@email.de>
To: 613431@bugs.debian.org
Cc: 613431-subscribe@bugs.debian.org
Subject: wxwidgets3.0 seems to be in sight
Date: Sun, 15 Sep 2013 13:46:44 +0200
Hi,

good news: it seems that after seven (!!) years there is finally a new stable
wxwidgets release in sight [1]. They say they release in September but even if
they that doesnt happen, the list of blocker bugs for the 3.0 release doesnt
seem to be too long [2].

Bad news: half of the bug are osx specific which we dont care about :D

cheers, josch

[1] http://trac.wxwidgets.org/wiki/Roadmap
[2] http://trac.wxwidgets.org/query?status=accepted&status=confirmed&status=new&status=reopened&order=priority&milestone=3.0



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, olly@survex.com:
Bug#613431; Package wnpp. (Sun, 15 Sep 2013 13:09:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olly Betts <olly@survex.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, olly@survex.com. (Sun, 15 Sep 2013 13:09:09 GMT) Full text and rfc822 format available.

Message #75 received at 613431@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: Johannes Schauer <j.schauer@email.de>, 613431@bugs.debian.org
Subject: Re: Bug#613431: wxwidgets3.0 seems to be in sight
Date: Sun, 15 Sep 2013 14:06:13 +0100
On Sun, Sep 15, 2013 at 01:46:44PM +0200, Johannes Schauer wrote:
> good news: it seems that after seven (!!) years there is finally a new stable
> wxwidgets release in sight [1]. They say they release in September but even if
> they that doesnt happen, the list of blocker bugs for the 3.0 release doesnt
> seem to be too long [2].

Thanks, but I'm in touch with upstream and following progress so there's
no need to ping the ITP bug with such info.

If you want to help get 3.0 into debian, the most useful thing to do
would be to test the wxwidgets2.9 packages which should be appearing in
experimental in the near future.

Cheers,
    Olly



Added tag(s) pending. Request was from Olly Betts <olly@survex.com> to control@bugs.debian.org. (Sun, 15 Sep 2013 13:30:09 GMT) Full text and rfc822 format available.

Reply sent to Olly Betts <olly@survex.com>:
You have taken responsibility. (Thu, 14 Nov 2013 04:03:08 GMT) Full text and rfc822 format available.

Notification sent to Emil Langrock <emil.langrock@gmx.de>:
Bug acknowledged by developer. (Thu, 14 Nov 2013 04:03:09 GMT) Full text and rfc822 format available.

Message #82 received at 613431-close@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: 613431-close@bugs.debian.org
Subject: Bug#613431: fixed in wxwidgets3.0 3.0.0-1
Date: Thu, 14 Nov 2013 04:00:06 +0000
Source: wxwidgets3.0
Source-Version: 3.0.0-1

We believe that the bug you reported is fixed in the latest version of
wxwidgets3.0, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 613431@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Olly Betts <olly@survex.com> (supplier of updated wxwidgets3.0 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 12 Nov 2013 11:38:12 +0000
Source: wxwidgets3.0
Binary: libwxbase3.0-0 libwxbase3.0-dev libwxbase3.0-0-dbg libwxgtk3.0-0 libwxgtk3.0-dev libwxgtk3.0-0-dbg libwxgtk-media3.0-0 libwxgtk-media3.0-0-dbg libwxgtk-media3.0-dev wx-common wx3.0-headers wx3.0-i18n wx3.0-examples libwxmsw3.0-dev wx3.0-headers-msw
Architecture: source amd64 all
Version: 3.0.0-1
Distribution: unstable
Urgency: low
Maintainer: wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Changed-By: Olly Betts <olly@survex.com>
Description: 
 libwxbase3.0-0 - wxBase library (runtime) - non-GUI support classes of wxWidgets t
 libwxbase3.0-0-dbg - debugging symbols for the wxBase library
 libwxbase3.0-dev - wxBase library (development) - non-GUI support classes of wxWidge
 libwxgtk-media3.0-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ media library runt
 libwxgtk-media3.0-0-dbg - debugging symbols for the wxGTK media library
 libwxgtk-media3.0-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ media library deve
 libwxgtk3.0-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
 libwxgtk3.0-0-dbg - debugging symbols for the wxGTK GUI toolkit library
 libwxgtk3.0-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
 libwxmsw3.0-dev - wxMSW mingw32msvc-cross
 wx-common  - wxWidgets Cross-platform C++ GUI toolkit (common support files)
 wx3.0-examples - wxWidgets Cross-platform C++ GUI toolkit (examples)
 wx3.0-headers - wxWidgets Cross-platform C++ GUI toolkit (header files)
 wx3.0-headers-msw - Extra wxWidgets headers for mingw32msvc-cross
 wx3.0-i18n - wxWidgets Cross-platform C++ GUI toolkit (i18n support)
Closes: 492896 613431 655251
Changes: 
 wxwidgets3.0 (3.0.0-1) unstable; urgency=low
 .
   * New upstream release! (Closes: #613431, #492896)
     + Incorporates all our patches.
     + __WXDEBUG__ is now on by default, so our -dbg packages now just contain
       detached debugging symbols. (Closes: #655251)
     + Upstream tarball is now DFSG-free, so we no longer repack it.
   * The wxwidgets2.8 source package was based on wxPython sources, but
     wxwidgets3.0 is based on wxWidgets.  The major motivation is we don't want
     to wait until wxPython 3.0.0 is released to package wxWidgets 3.0.0, but
     it's probably better overall anyway.  Currently the "-doc" package is gone
     (as these docs aren't in wx source code distribution), but this should
     reappear in the near future.
   * debian/control: Drop conflicts against packages (or versions of packages)
     which no longer exist in any supported Debian or Ubuntu release.
Checksums-Sha1: 
 a4cd2506149206898f8c222993d15b119858afd5 2975 wxwidgets3.0_3.0.0-1.dsc
 756a9c54d1f411e262f03bacb78ccef085a9880a 19815734 wxwidgets3.0_3.0.0.orig.tar.bz2
 fd7ea3bf97cdbae7f0d7eb99ac6c60b67c209da7 40168 wxwidgets3.0_3.0.0-1.debian.tar.gz
 25608f78ca456e44a758bee848bded52a6e70a8a 1043346 libwxbase3.0-0_3.0.0-1_amd64.deb
 1d842dac94889477ab0f49ef85a1328829ce1639 128434 libwxbase3.0-dev_3.0.0-1_amd64.deb
 ff777e2b84b885a24fbab008856af4a41bfd9333 13335606 libwxbase3.0-0-dbg_3.0.0-1_amd64.deb
 862a155f33ddbe347a67781ba5548828f298a625 3894224 libwxgtk3.0-0_3.0.0-1_amd64.deb
 c678b3bb0cfdb993088d5849d9de888df8374a22 128598 libwxgtk3.0-dev_3.0.0-1_amd64.deb
 4722e7a71ec032056e0cd32161ced47d7f8ae96b 64896322 libwxgtk3.0-0-dbg_3.0.0-1_amd64.deb
 6e7796cf8736ed889bb32b324640e875ebe0994c 139626 libwxgtk-media3.0-0_3.0.0-1_amd64.deb
 902d61d339b59e50a98e7da6648815bb0ddec4f6 472254 libwxgtk-media3.0-0-dbg_3.0.0-1_amd64.deb
 6fb81335674009ba9f92aedc4071ba035b5c78a9 107952 libwxgtk-media3.0-dev_3.0.0-1_amd64.deb
 efe23e49731b6e4585b3d066d2358d58bb4b3531 1116800 wx3.0-headers_3.0.0-1_amd64.deb
 38846a255c84597c223ff60a3f7a37bd2897aeb1 544656 wx3.0-i18n_3.0.0-1_all.deb
 f14910b1353be490baa06cd15f1f5152d854bbf6 3657280 wx3.0-examples_3.0.0-1_all.deb
Checksums-Sha256: 
 e1ff9d04ec0e41eb1262083044910d6ef4f628f3c83faf3e5e011efc0907caa9 2975 wxwidgets3.0_3.0.0-1.dsc
 ff340539bcb6e45d8dbce848d3c13ebce34da6ffb9004a0a88e9541bec45bf85 19815734 wxwidgets3.0_3.0.0.orig.tar.bz2
 75e14444860f345bed3bf69be8248d0f1bfa9043d3daf34a4e420893608071a8 40168 wxwidgets3.0_3.0.0-1.debian.tar.gz
 22e9aed45fc6dfb2910eea53fe7219380a2b8709d640146b4238edf6f4329f30 1043346 libwxbase3.0-0_3.0.0-1_amd64.deb
 5dd40208ab79ac959064edc1f5a437ef63c8f2e18ab98203313b1ca037111010 128434 libwxbase3.0-dev_3.0.0-1_amd64.deb
 26408f54dbf6e8548017094ac91c555e2e2f6b7344b1858f7384e88c984a0100 13335606 libwxbase3.0-0-dbg_3.0.0-1_amd64.deb
 bc40186435334e2239e1fbf75eb80b6f6bc139f63f555e019e965e77c11c7c82 3894224 libwxgtk3.0-0_3.0.0-1_amd64.deb
 824f791180e1ae23fb12fb8cfb487510c81d9aac99e4e78998ec5eac07d51770 128598 libwxgtk3.0-dev_3.0.0-1_amd64.deb
 4972b0b007b6f2ac760e9c666492063208bab84bbded84fd41f524be2d130543 64896322 libwxgtk3.0-0-dbg_3.0.0-1_amd64.deb
 977e1d26a2f1177973bdd8d918e7c2b78cfcf987b2e791c5e89525bfff36732b 139626 libwxgtk-media3.0-0_3.0.0-1_amd64.deb
 a612e56cd7de98f9bd21522161a148d57f4fcadf3a285213e5bf3fcc9dd40ced 472254 libwxgtk-media3.0-0-dbg_3.0.0-1_amd64.deb
 6f3707ab1d44140351ec585723488a796423f9a1168014675dc17bac16ca7d35 107952 libwxgtk-media3.0-dev_3.0.0-1_amd64.deb
 8a0349448e2487c556f5277464d356a48b2b13a6d527d36306603a02a8b81c7e 1116800 wx3.0-headers_3.0.0-1_amd64.deb
 a3a9506e1d49825e7f93f3559958d6c5d36bd4206698ec5e14d15cf270920427 544656 wx3.0-i18n_3.0.0-1_all.deb
 79a6c8877281220c7f6bd6af00659eb0575fa32c2d288b970a0b26188b37c8e3 3657280 wx3.0-examples_3.0.0-1_all.deb
Files: 
 1f0a7029f30608f264de306744c53afa 2975 libs optional wxwidgets3.0_3.0.0-1.dsc
 241998efc12205172ed24c18788ea2cd 19815734 libs optional wxwidgets3.0_3.0.0.orig.tar.bz2
 244a81c978f5a4bc374240a2633ec41e 40168 libs optional wxwidgets3.0_3.0.0-1.debian.tar.gz
 69f870c645efa7a827252fe185d11a19 1043346 libs optional libwxbase3.0-0_3.0.0-1_amd64.deb
 a404f41905b0e43482862319c1d0a10a 128434 libdevel optional libwxbase3.0-dev_3.0.0-1_amd64.deb
 23f23afdd09ef6222b28ed8cf51331b9 13335606 debug extra libwxbase3.0-0-dbg_3.0.0-1_amd64.deb
 dc0e6ee457cf557875a4b36362ff7787 3894224 libs optional libwxgtk3.0-0_3.0.0-1_amd64.deb
 e766d7baf0ee24c82e3d3e81dd2bb3ad 128598 libdevel optional libwxgtk3.0-dev_3.0.0-1_amd64.deb
 69908fb9d73c9405bf2ad5f194c6ff1c 64896322 debug extra libwxgtk3.0-0-dbg_3.0.0-1_amd64.deb
 590b0be76f4029029b33d79defd697ad 139626 libs optional libwxgtk-media3.0-0_3.0.0-1_amd64.deb
 5306579d23ca5083739e60aada4ca20c 472254 debug extra libwxgtk-media3.0-0-dbg_3.0.0-1_amd64.deb
 8fc784251eb3ada2b3a0158d2b5a078a 107952 libdevel optional libwxgtk-media3.0-dev_3.0.0-1_amd64.deb
 0899a3688bf850bd424e95bc18ef7f7b 1116800 devel optional wx3.0-headers_3.0.0-1_amd64.deb
 a1d795de09d71a73b1975e1da30f08bb 544656 localization optional wx3.0-i18n_3.0.0-1_all.deb
 cf489742b7af2e8aefcb31ed05a4f5ea 3657280 devel optional wx3.0-examples_3.0.0-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJSgjZTAAoJEBgUewc7rSsHL+AQAI5lXv6zv1JGypggxHUm3i5a
3eeSj2KtVxjjwhiZT42np5Z8sFl5nGQg2lSfBCRxQ6/+walPYI6L3RMby58HeC43
SAtk1JZDnqaonAolxZ+/KrODoSaTLVF+VwbMLtEHS+DjZ6grMFVMnuJ2YH+3lPbR
O0jTqPuJZj9wgp1gTwuwoBTnYuCMEcg7clTWhJXbtszF6Z69Dko0/snUfzHv/okg
udunEQPAxWDy8RcpUGRUG/gpuh1YgOr0MLuwRwPGtDsxZSZEMBuTPks26qYXv8EW
3Oa7Hv06U7AotVqGIugb2KCb91bJEN8lPBap4oqmNzJ8vtmmb8m67cKQiDHYOaxu
APfPgYkGWjqM1UCTiDq9zPnipWmahyAQ1c4sMaUxTuuKSKFy83vfA12jJ27SMeyQ
a33HucNrt23KbZHr8FZwZ5iQCnMnFp0Lq3jD5NjvITkI6PVcz3aHqhNkwFdlR+ZM
VNnfGxiQhsZwGsjYokmVwGtV8zHbo/Ott4mYF8VQdP8AqpP5by1gz4v+/BGSmMAy
+Dn6OucpEgDUZqdQCgJB+nkxZnULRxSJYXajvXOmOKJ6OA/DUSf7M8AudK8JGhEv
XpplBZAW2G3zBmNxlAgmkvKpkWSqr5/5OLVgDf1g9A5jSguKruGC6WRu953/SL+w
k3uoljmD/G6QaqOxUHEl
=KBs9
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 12 Dec 2013 07:27:26 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 14:27:20 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.