Debian Bug report logs - #611412
mutt: bogus regex for BTS subscription

version graph

Package: mutt; Maintainer for mutt is Antonio Radici <antonio@dyne.org>; Source for mutt is src:mutt.

Reported by: Jakub Wilk <jwilk@debian.org>

Date: Sat, 29 Jan 2011 00:27:01 UTC

Severity: minor

Tags: confirmed, upstream

Found in version mutt/1.5.21-2

Fixed in version mutt/1.5.21-5

Done: Antonio Radici <antonio@dyne.org>

Bug is archived. No further changes may be made.

Forwarded to http://bugs.mutt.org/3514

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, jwilk@debian.org, Antonio Radici <antonio@dyne.org>:
Bug#611412; Package mutt. (Sat, 29 Jan 2011 00:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jakub Wilk <jwilk@debian.org>:
New Bug report received and forwarded. Copy sent to jwilk@debian.org, Antonio Radici <antonio@dyne.org>. (Sat, 29 Jan 2011 00:27:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jakub Wilk <jwilk@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: mutt: bogus regex for BTS subscription
Date: Sat, 29 Jan 2011 01:22:58 +0100
Package: mutt
Version: 1.5.21-2
Severity: minor

From mutt's help:

| To mark all messages sent to a specific bug report's address on
| Debian's bug tracking system as list mail, for instance, you could say
| 
| subscribe [0-9]*.*@bugs.debian.org

But this regex matches, amongst others, submit@bugs.debian.org and 
control@bugs.debian.org. It should be rather "[0-9].*@bugs.debian.org" 
or "[0-9]+.*@bugs.debian.org".

-- 
Jakub Wilk




Added tag(s) confirmed and pending. Request was from Antonio Radici <antonio@dyne.org> to control@bugs.debian.org. (Sat, 16 Apr 2011 08:15:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#611412; Package mutt. (Mon, 02 May 2011 21:54:40 GMT) Full text and rfc822 format available.

Acknowledgement sent to Antonio Radici <antonio@dyne.org>:
Extra info received and forwarded to list. (Mon, 02 May 2011 21:54:41 GMT) Full text and rfc822 format available.

Message #12 received at 611412@bugs.debian.org (full text, mbox):

From: Antonio Radici <antonio@dyne.org>
To: 611412@bugs.debian.org
Subject: mutt: bogus regex for BTS subscription
Date: Mon, 2 May 2011 21:54:46 +0000
forwarded 611412 http://bugs.mutt.org/3514
tag 611412 +upstream
thanks

Fix in git, patch submitted upstream

Cheers
Antonio




Set Bug forwarded-to-address to 'http://bugs.mutt.org/3514'. Request was from Antonio Radici <antonio@dyne.org> to control@bugs.debian.org. (Mon, 02 May 2011 21:55:18 GMT) Full text and rfc822 format available.

Added tag(s) upstream. Request was from Antonio Radici <antonio@dyne.org> to control@bugs.debian.org. (Mon, 02 May 2011 21:55:18 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Antonio Radici <antonio@dyne.org>:
Bug#611412; Package mutt. (Mon, 02 May 2011 21:56:02 GMT) Full text and rfc822 format available.

Message #19 received at 611412@bugs.debian.org (full text, mbox):

From: Mutt <fleas@mutt.org>
To: antonio@dyne.org
Cc: mutt-dev@mutt.org, 611412@bugs.debian.org
Subject: [Mutt] #3514: bogus regexp for BTS subscription
Date: Mon, 02 May 2011 21:39:32 -0000
#3514: bogus regexp for BTS subscription
------------------------------+---------------------------------------------
 Reporter:  antonio@…         |       Owner:  mutt-dev
     Type:  defect            |      Status:  new     
 Priority:  trivial           |   Milestone:          
Component:  mutt              |     Version:  1.5.21  
 Keywords:  patch             |  
------------------------------+---------------------------------------------
 Forwarding from http://bugs.debian.org/611412

 {{{
 The manual reports a bad regexp for Debian bugs in BTS:

 subscribe [0-9]*.*@bugs.debian.org

 But this regex matches, amongst others, submit@bugs.debian.org and
 control@bugs.debian.org.

 The new proposed regexp is:
 subscribe [0-9]+.*@bugs.debian.org

 The attached patch fixes the problem
 }}}

-- 
Ticket URL: <http://dev.mutt.org/trac/ticket/3514>
Mutt <http://www.mutt.org/>
The Mutt mail user agent





Reply sent to Antonio Radici <antonio@dyne.org>:
You have taken responsibility. (Sun, 08 May 2011 12:45:26 GMT) Full text and rfc822 format available.

Notification sent to Jakub Wilk <jwilk@debian.org>:
Bug acknowledged by developer. (Sun, 08 May 2011 12:45:27 GMT) Full text and rfc822 format available.

Message #24 received at 611412-close@bugs.debian.org (full text, mbox):

From: Antonio Radici <antonio@dyne.org>
To: 611412-close@bugs.debian.org
Subject: Bug#611412: fixed in mutt 1.5.21-5
Date: Sun, 08 May 2011 12:40:56 +0000
Source: mutt
Source-Version: 1.5.21-5

We believe that the bug you reported is fixed in the latest version of
mutt, which is due to be installed in the Debian FTP archive:

mutt-dbg_1.5.21-5_amd64.deb
  to main/m/mutt/mutt-dbg_1.5.21-5_amd64.deb
mutt-patched_1.5.21-5_amd64.deb
  to main/m/mutt/mutt-patched_1.5.21-5_amd64.deb
mutt_1.5.21-5.diff.gz
  to main/m/mutt/mutt_1.5.21-5.diff.gz
mutt_1.5.21-5.dsc
  to main/m/mutt/mutt_1.5.21-5.dsc
mutt_1.5.21-5_amd64.deb
  to main/m/mutt/mutt_1.5.21-5_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 611412@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Antonio Radici <antonio@dyne.org> (supplier of updated mutt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 05 May 2011 15:00:56 +0000
Source: mutt
Binary: mutt mutt-patched mutt-dbg
Architecture: source amd64
Version: 1.5.21-5
Distribution: unstable
Urgency: low
Maintainer: Antonio Radici <antonio@dyne.org>
Changed-By: Antonio Radici <antonio@dyne.org>
Description: 
 mutt       - text-based mailreader supporting MIME, GPG, PGP and threading
 mutt-dbg   - debugging symbols for mutt
 mutt-patched - Mutt Mail User Agent with extra patches
Closes: 494735 578098 584138 584581 586454 589240 603186 603287 611405 611410 611412 613781 619216 619822 620945 624058 624085
Changes: 
 mutt (1.5.21-5) unstable; urgency=low
 .
   * debian/control: Standards-Version moved from 3.9.2.0 to 3.9.2 for
     cosmetic reasons
   * debian/patches/mutt-patched:
     + sidebar: patch replaced with the one written by Stuart Henderson
       (Closes: 619822)
     + sidebar: don't overwrite the status if status_on_top is enabled
       (Closes: 494735)
     + sidebar-sorted: use strcoll() to sort the sidebar using the locale
       settings of the system, patch by Arnaud Riess (Closes: 589240)
     + multiple-fccs: added a patch that allows multiple FCC separated by commas,
       written by Omen Wild (Closes: 586454)
     + sidebar-utf8: rewrites make_sidebar_entry() to allow correct padding of
       utf-8 strings and also prevents segfaults due to overflows
       (Closes: 584581, 603287)
   * debian/patches/debian-specific:
     + Muttrc: remove a hook for application/octet-stream, already upstream
       (Closes: 611405)
   * debian/patches/upstream:
     + 611412-bts-regexp.patch: fixes a regexp for BTS in the mutt manual
       (Closes: 611412)
     + 624058-gnutls-deprecated.patch: deprecate gnutls_protocol_set_priority()
       (Closes: 624058)
     + 624085-gnutls-deprecated-verify-peers.patch: deprecate
       gnutls_certificate_verify_peers() (Closes: 624085)
     + 584138-mx_update_context-segfault.patch: fix a segfault due to holes in
       IMAP headers, 537694-segv-imap-headers.patch is removed as part of this
       fix (Closes: 584138)
     + 619216-gnutls-CN-validation.patch: fix the validation of the
       commonname in the gnutls code (Closes: 619216)
     + 611410-no-implicit_autoview-for-text-html.patch: blacklist
       text/html from implicit_autoview, patch by Loïc Minier
       (Closes: 611410, 620945)
   * debian/patches/compressed-folders: remove partially uncompressed folder if
       the open fails (Closes: 578098)
   * debian/extra/samples/sidebar.muttrc: documented the options that
     the sidebar-{sorted,dotted} patches are introducing; documentation
     submitted by Julien Valroff (Closes: 603186)
   * added mutt.desktop and to debian/extra and installed through mutt.install,
     it contains a MimeType handler for mailto (Closes: 613781)
Checksums-Sha1: 
 348f7e208580ab89c1150840929286993d8cd3db 1404 mutt_1.5.21-5.dsc
 ea75302765d16d6b6dad083c6dc37773a3e38b67 165185 mutt_1.5.21-5.diff.gz
 dca121e5eeb855e7ad136f131f29d9aa014695b6 2142402 mutt_1.5.21-5_amd64.deb
 267f6e4375f4e6723ada4b144edd49818baa4aad 438888 mutt-patched_1.5.21-5_amd64.deb
 6b4cfa973b454f18927c3406104b3c3a99c4f484 1561112 mutt-dbg_1.5.21-5_amd64.deb
Checksums-Sha256: 
 0951e0ef2b3dae1b6dc24ec04fcaf2052360aa90639d6649249df7a13d91c528 1404 mutt_1.5.21-5.dsc
 0b3be194c2a6d0c5a09ef39d92a55547f94e868d15863d4492bc075618a24559 165185 mutt_1.5.21-5.diff.gz
 66e4814092cedbdc73d2b2458772d3cdd65c82729a4289f2cabdc2ba2d2bc5a3 2142402 mutt_1.5.21-5_amd64.deb
 f95c75979fa558acc4068106a1e13eac9e06a1a83440104a475b80070a97413b 438888 mutt-patched_1.5.21-5_amd64.deb
 ccab3bbf0e2eada73a04ad208cf1abfaf39727cc8b43aba1f375ab3f89b98c35 1561112 mutt-dbg_1.5.21-5_amd64.deb
Files: 
 9f696835ea852566cdbb53fceaaae8af 1404 mail standard mutt_1.5.21-5.dsc
 3c9437bc1b05ea39f1d9dd368a85a269 165185 mail standard mutt_1.5.21-5.diff.gz
 c125a28fc23cf6c59bba46b49654b42d 2142402 mail standard mutt_1.5.21-5_amd64.deb
 cda9452010718b255b6451870dc9cb2f 438888 mail extra mutt-patched_1.5.21-5_amd64.deb
 10b685001f584ce16cdbc51b513561c4 1561112 debug extra mutt-dbg_1.5.21-5_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk3GSlEACgkQ6Tq8aae+WrCLhwCfbRA6ZVyx58d0n6Zpw5XadnMD
e9kAoJSiIA+1ZPWn8ipKDg8y6q1OBr5t
=Vy84
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Antonio Radici <antonio@dyne.org>:
Bug#611412; Package mutt. (Mon, 20 Jun 2011 23:21:03 GMT) Full text and rfc822 format available.

Message #27 received at 611412@bugs.debian.org (full text, mbox):

From: Mutt <fleas@mutt.org>
To: antonio@dyne.org, me@sigpipe.org
Cc: mutt-dev@mutt.org, 611412@bugs.debian.org
Subject: Re: [Mutt] #3514: bogus regexp for BTS subscription
Date: Mon, 20 Jun 2011 23:07:46 -0000
#3514: bogus regexp for BTS subscription
-------------------------------+--------------------------------------------
  Reporter:  antonio@…         |       Owner:  mutt-dev
      Type:  defect            |      Status:  closed  
  Priority:  trivial           |   Milestone:          
 Component:  mutt              |     Version:  1.5.21  
Resolution:  fixed             |    Keywords:  patch   
-------------------------------+--------------------------------------------
Changes (by me):

  * status:  new => closed
  * resolution:  => fixed


-- 
Ticket URL: <http://dev.mutt.org/trac/ticket/3514#comment:1>
Mutt <http://www.mutt.org/>
The Mutt mail user agent





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 19 Jul 2011 07:32:18 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 01:31:34 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.