Debian Bug report logs - #607240
wordpress: Copyrighted song lyrics included in the source code

version graph

Package: wordpress; Maintainer for wordpress is Craig Small <csmall@debian.org>; Source for wordpress is src:wordpress.

Reported by: Nicolas Kuttler <debian-bugs@nicolaskuttler.de>

Date: Thu, 16 Dec 2010 03:03:01 UTC

Severity: serious

Found in version wordpress/2.5.1-11+lenny3

Fixed in version wordpress/3.0.3.dfsg-1

Done: Giuseppe Iuculano <iuculano@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Giuseppe Iuculano <iuculano@debian.org>:
Bug#607240; Package wordpress. (Thu, 16 Dec 2010 03:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Nicolas Kuttler <debian-bugs@nicolaskuttler.de>:
New Bug report received and forwarded. Copy sent to Giuseppe Iuculano <iuculano@debian.org>. (Thu, 16 Dec 2010 03:03:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Nicolas Kuttler <debian-bugs@nicolaskuttler.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: wordpress: Copyrighted song lyrics included in the source code
Date: Thu, 16 Dec 2010 03:02:42 +0100
Package: wordpress
Version: 2.5.1-11+lenny3
Severity: serious
Justification: Policy 2.1


WordPress includes a plugin in wp-content/plugins/hello.php in the
default distribution. This plugin contains in the source code the full
lyrics to a copyrighted work, a song called "Hello Dolly".

IANAL, but I believe it is impossible that these lyrics are
GPL-compatible. Relevant wordpress ticket:

http://core.trac.wordpress.org/ticket/15769

(the discussion is rather unsettling)

A quick research on http://iswcnet.cisac.org/iswcnet/logon.do seems to
show the copyright holders.

Regards,

Nicolas

-- System Information:
Debian Release: 5.0.7
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.18-028stab070.7 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages wordpress depends on:
ii  apache2            2.2.9-10+lenny8       Apache HTTP Server metapackage
ii  apache2-mpm-prefor 2.2.9-10+lenny8       Apache HTTP Server - traditional n
ii  libapache2-mod-php 5.2.6.dfsg.1-1+lenny9 server-side, HTML-embedded scripti
ii  libjs-prototype    1.6.0.2-4             JavaScript Framework for dynamic w
ii  libjs-scriptaculou 1.8.1-5               JavaScript library for dynamic web
ii  libphp-phpmailer   1.73-6                full featured email transfer class
ii  libphp-snoopy      1.2.4-1               Snoopy is a PHP class that simulat
ii  lighttpd [httpd]   1.4.19-5+lenny1       A fast webserver with minimal memo
ii  mysql-client-5.0 [ 5.0.51a-24+lenny4     MySQL database client binaries
ii  nginx [httpd]      0.7.67-3~bpo50+1      small, but very powerful and effic
ii  php5               5.2.6.dfsg.1-1+lenny9 server-side, HTML-embedded scripti
ii  php5-cgi           5.2.6.dfsg.1-1+lenny9 server-side, HTML-embedded scripti
ii  php5-gd            5.2.6.dfsg.1-1+lenny9 GD module for php5
ii  php5-mysql         5.2.6.dfsg.1-1+lenny9 MySQL module for php5
ii  tinymce            3.0.8-1               platform independent web based Jav

wordpress recommends no packages.

Versions of packages wordpress suggests:
ii  mysql-server-5.0 [virt 5.0.51a-24+lenny4 MySQL database server binaries

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#607240; Package wordpress. (Fri, 17 Dec 2010 10:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Giuseppe Iuculano <iuculano@debian.org>:
Extra info received and forwarded to list. (Fri, 17 Dec 2010 10:03:03 GMT) Full text and rfc822 format available.

Message #10 received at 607240@bugs.debian.org (full text, mbox):

From: Giuseppe Iuculano <iuculano@debian.org>
To: 607240@bugs.debian.org,control@bugs.debian.org,607240-submitter@bugs.debian.org
Subject: [f29b6ac] Fix for Bug#607240 committed to git
Date: Fri, 17 Dec 2010 09:59:41 +0000
tags 607240 + pending
thanks

Hello,

     The following change has been committed for this bug by
 Giuseppe Iuculano <iuculano@debian.org> on Fri, 17 Dec 2010 10:59:01 +0100.
 The fix will be in the next upload. 
=========================================================================
Use GPL-compliant lyrics in the hello dolly plugin.

Closes: #607240
=========================================================================

You can check the diff of the fix at:

    http://git.debian.org/?p=collab-maint/wordpress.git;a=commitdiff;h=f29b6ac






Added tag(s) pending. Request was from Giuseppe Iuculano <iuculano@debian.org> to control@bugs.debian.org. (Fri, 17 Dec 2010 10:03:05 GMT) Full text and rfc822 format available.

Message sent on to Nicolas Kuttler <debian-bugs@nicolaskuttler.de>:
Bug#607240. (Fri, 17 Dec 2010 10:03:07 GMT) Full text and rfc822 format available.

Reply sent to Giuseppe Iuculano <iuculano@debian.org>:
You have taken responsibility. (Fri, 17 Dec 2010 15:48:12 GMT) Full text and rfc822 format available.

Notification sent to Nicolas Kuttler <debian-bugs@nicolaskuttler.de>:
Bug acknowledged by developer. (Fri, 17 Dec 2010 15:48:12 GMT) Full text and rfc822 format available.

Message #20 received at 607240-close@bugs.debian.org (full text, mbox):

From: Giuseppe Iuculano <iuculano@debian.org>
To: 607240-close@bugs.debian.org
Subject: Bug#607240: fixed in wordpress 3.0.3-1
Date: Fri, 17 Dec 2010 15:32:13 +0000
Source: wordpress
Source-Version: 3.0.3-1

We believe that the bug you reported is fixed in the latest version of
wordpress, which is due to be installed in the Debian FTP archive:

wordpress-l10n_3.0.3-1_all.deb
  to main/w/wordpress/wordpress-l10n_3.0.3-1_all.deb
wordpress_3.0.3-1.debian.tar.gz
  to main/w/wordpress/wordpress_3.0.3-1.debian.tar.gz
wordpress_3.0.3-1.dsc
  to main/w/wordpress/wordpress_3.0.3-1.dsc
wordpress_3.0.3-1_all.deb
  to main/w/wordpress/wordpress_3.0.3-1_all.deb
wordpress_3.0.3.orig.tar.gz
  to main/w/wordpress/wordpress_3.0.3.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 607240@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Giuseppe Iuculano <iuculano@debian.org> (supplier of updated wordpress package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 17 Dec 2010 11:03:55 +0100
Source: wordpress
Binary: wordpress wordpress-l10n
Architecture: source all
Version: 3.0.3-1
Distribution: unstable
Urgency: high
Maintainer: Giuseppe Iuculano <iuculano@debian.org>
Changed-By: Giuseppe Iuculano <iuculano@debian.org>
Description: 
 wordpress  - weblog manager
 wordpress-l10n - weblog manager - language files
Closes: 606657 607240
Changes: 
 wordpress (3.0.3-1) unstable; urgency=high
 .
   * [014c926] Imported Upstream version 3.0.3 (Closes: #606657)
   * [f29b6ac] Use GPL-compliant lyrics in the hello dolly plugin.
     (Closes: #607240)
Checksums-Sha1: 
 b944fe4d7d75726ab829aef11e692d1527c7a64b 1259 wordpress_3.0.3-1.dsc
 888c2f32fa18dfd5f02291cd8f33c67c3c9cc367 2689163 wordpress_3.0.3.orig.tar.gz
 54994ea86e36cf3127f415eacfef2fef8e5540d9 7032584 wordpress_3.0.3-1.debian.tar.gz
 e9e659581573c55f2fb24cf4827e2d1da9b2a7fe 2513700 wordpress_3.0.3-1_all.deb
 975b61d1f0748710ef7f876a8b6f3483432081c5 5987888 wordpress-l10n_3.0.3-1_all.deb
Checksums-Sha256: 
 051fa0d898dd5494c1cf7cd09769e27d6141c53681b509418fd8b420e1243a23 1259 wordpress_3.0.3-1.dsc
 a62114d0d0d4bbc01101de1135de6dd8116f34ff35ecc77fb0601e933f789dcc 2689163 wordpress_3.0.3.orig.tar.gz
 5e276f3a1cac7c59a3122c8394647a30baacde33ce5c0d66f1b3cf45e855e6cb 7032584 wordpress_3.0.3-1.debian.tar.gz
 fcafd79a6ba769e7fdca6811adc1f267f855d11401385c05d873f685be5c1c17 2513700 wordpress_3.0.3-1_all.deb
 a814a3bc84fb09a6dc9d1b3c381286bbfb37a6ed1e62bf973150746c1c02ac9e 5987888 wordpress-l10n_3.0.3-1_all.deb
Files: 
 6a3be0f45af6a2fedb4e6d629e1fbc36 1259 web optional wordpress_3.0.3-1.dsc
 c9f2c1db36a78d62596bc97d90bf00ae 2689163 web optional wordpress_3.0.3.orig.tar.gz
 764ef4a8647caaef403f16af848345d0 7032584 web optional wordpress_3.0.3-1.debian.tar.gz
 4a1dce1527a5bdc22b6a90ff2cb24560 2513700 web optional wordpress_3.0.3-1_all.deb
 7453dd06b42fa93cca2768b983870bb7 5987888 localization optional wordpress-l10n_3.0.3-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk0LN3UACgkQNxpp46476aqnMwCeN/ToyBZblSWWJK+gYdldSq5b
W2EAnRkXlqwuEg2W/KY3ja5idvzSQvct
=Pkta
-----END PGP SIGNATURE-----





Bug No longer marked as fixed in versions wordpress/3.0.3-1 and reopened. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 28 Dec 2010 16:27:03 GMT) Full text and rfc822 format available.

Reply sent to Giuseppe Iuculano <iuculano@debian.org>:
You have taken responsibility. (Tue, 28 Dec 2010 17:21:10 GMT) Full text and rfc822 format available.

Notification sent to Nicolas Kuttler <debian-bugs@nicolaskuttler.de>:
Bug acknowledged by developer. (Tue, 28 Dec 2010 17:21:10 GMT) Full text and rfc822 format available.

Message #27 received at 607240-close@bugs.debian.org (full text, mbox):

From: Giuseppe Iuculano <iuculano@debian.org>
To: 607240-close@bugs.debian.org
Subject: Bug#607240: fixed in wordpress 3.0.3.dfsg-1
Date: Tue, 28 Dec 2010 17:18:10 +0000
Source: wordpress
Source-Version: 3.0.3.dfsg-1

We believe that the bug you reported is fixed in the latest version of
wordpress, which is due to be installed in the Debian FTP archive:

wordpress-l10n_3.0.3.dfsg-1_all.deb
  to main/w/wordpress/wordpress-l10n_3.0.3.dfsg-1_all.deb
wordpress_3.0.3.dfsg-1.debian.tar.gz
  to main/w/wordpress/wordpress_3.0.3.dfsg-1.debian.tar.gz
wordpress_3.0.3.dfsg-1.dsc
  to main/w/wordpress/wordpress_3.0.3.dfsg-1.dsc
wordpress_3.0.3.dfsg-1_all.deb
  to main/w/wordpress/wordpress_3.0.3.dfsg-1_all.deb
wordpress_3.0.3.dfsg.orig.tar.gz
  to main/w/wordpress/wordpress_3.0.3.dfsg.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 607240@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Giuseppe Iuculano <iuculano@debian.org> (supplier of updated wordpress package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 28 Dec 2010 17:22:34 +0100
Source: wordpress
Binary: wordpress wordpress-l10n
Architecture: source all
Version: 3.0.3.dfsg-1
Distribution: unstable
Urgency: high
Maintainer: Giuseppe Iuculano <iuculano@debian.org>
Changed-By: Giuseppe Iuculano <iuculano@debian.org>
Description: 
 wordpress  - weblog manager
 wordpress-l10n - weblog manager - language files
Closes: 607240
Changes: 
 wordpress (3.0.3.dfsg-1) unstable; urgency=high
 .
   * [e113893] Imported Upstream version 3.0.3.dfsg
     - Re-packaged without the hello dolly plugin (Closes: #607240)
   * [9d62cfd] Removed hello.patch
Checksums-Sha1: 
 619aba3d22a42fb4f888f46ed162c035544a3314 1294 wordpress_3.0.3.dfsg-1.dsc
 768b183ce8686eb650d5a8f7d8f92a8133a4505f 2684768 wordpress_3.0.3.dfsg.orig.tar.gz
 f592402349698bf14058589ea56dc05532e45941 7031728 wordpress_3.0.3.dfsg-1.debian.tar.gz
 5864ee98e16b140c8c30b2ca137924a088725dc7 2512654 wordpress_3.0.3.dfsg-1_all.deb
 ad8ad0afa9a2ca906d62b9ea4c5c4f781c15cbd5 5987792 wordpress-l10n_3.0.3.dfsg-1_all.deb
Checksums-Sha256: 
 3eb542c85949bb177b7f11eb752c28a0b39efe09fdce5a8e8e1734a05809ae0b 1294 wordpress_3.0.3.dfsg-1.dsc
 f31819ca3c206ad600b82842d3d24c2c655e03f8947585a0356750eb54d7423e 2684768 wordpress_3.0.3.dfsg.orig.tar.gz
 4bc61b982c142f3c373be672fcc5366dbe600c2f21be29dc21aa8da716cec319 7031728 wordpress_3.0.3.dfsg-1.debian.tar.gz
 9acd3ab53043e211fa914575438cf05b6d9783c62f5d660a60589fc409907612 2512654 wordpress_3.0.3.dfsg-1_all.deb
 97284e223a5a5afceba84b6ed8e99726cad81f111c20d02bc7ecd123259aaa9c 5987792 wordpress-l10n_3.0.3.dfsg-1_all.deb
Files: 
 3d7ec2a7aaef23d74b736937d1c18c40 1294 web optional wordpress_3.0.3.dfsg-1.dsc
 68f4da222bff7260dbf0504612441e93 2684768 web optional wordpress_3.0.3.dfsg.orig.tar.gz
 c16c36fc8afd5b3e9b6e63e3437cf2d9 7031728 web optional wordpress_3.0.3.dfsg-1.debian.tar.gz
 936795db63c1285e2ce7f8a341013448 2512654 web optional wordpress_3.0.3.dfsg-1_all.deb
 a342456fbe08b4f805401730f681d02e 5987792 localization optional wordpress-l10n_3.0.3.dfsg-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk0aEf8ACgkQNxpp46476aoJDwCfXrb7Vuv3iOfci2P7kFEC5krk
EncAn2HdCCIYf3c1C481YM8jkAN1JCO3
=MSSm
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 07 Mar 2011 08:50:45 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 07:03:21 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.