Debian Bug report logs - #607204
awstats will use " " in XHTML output

version graph

Package: awstats; Maintainer for awstats is Sergey B Kirpichev <skirpichev@gmail.com>; Source for awstats is src:awstats.

Reported by: Francis Russell <francis+dbts@unchartedbackwaters.co.uk>

Date: Wed, 15 Dec 2010 17:03:02 UTC

Severity: normal

Found in version awstats/6.9.5~dfsg-2

Done: Sergey B Kirpichev <skirpichev@gmail.com>

Bug is archived. No further changes may be made.

Forwarded to http://sourceforge.net/tracker/?func=detail&aid=3216590&group_id=13764&atid=113764

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, francis+dbts@unchartedbackwaters.co.uk, Debian AWStats Team <pkg-awstats-devel@lists.alioth.debian.org>:
Bug#607204; Package awstats. (Wed, 15 Dec 2010 17:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Francis Russell <francis+dbts@unchartedbackwaters.co.uk>:
New Bug report received and forwarded. Copy sent to francis+dbts@unchartedbackwaters.co.uk, Debian AWStats Team <pkg-awstats-devel@lists.alioth.debian.org>. (Wed, 15 Dec 2010 17:03:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Francis Russell <francis+dbts@unchartedbackwaters.co.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: awstats produces invalid XHTML
Date: Wed, 15 Dec 2010 16:58:11 +0000
Package: awstats
Version: 6.9.5~dfsg-2
Severity: normal


When configured to output XHTML, awstats will use "&nbsp;" in the resulting
output file. This isn't a valid XHTML entity and causes awstats to fail to
render under some browsers (Firefox 3.6 in Ubuntu, though apparently not
Iceweasel in Debian). Running the awstats output through the W3C XHTML validator
also seemed to show other issues.

Francis


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36.2 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash




Set Bug forwarded-to-address to 'http://sourceforge.net/tracker/?func=detail&aid=3216590&group_id=13764&atid=113764'. Request was from Sergey B Kirpichev <skirpichev@gmail.com> to control@bugs.debian.org. (Wed, 16 Mar 2011 15:45:05 GMT) Full text and rfc822 format available.

Changed Bug title to 'awstats will use "&nbsp;" in XHTML output' from 'awstats produces invalid XHTML' Request was from Sergey B Kirpichev <skirpichev@gmail.com> to control@bugs.debian.org. (Wed, 16 Mar 2011 15:45:06 GMT) Full text and rfc822 format available.

Message sent on to Francis Russell <francis+dbts@unchartedbackwaters.co.uk>:
Bug#607204. (Wed, 16 Mar 2011 15:45:10 GMT) Full text and rfc822 format available.

Message #12 received at 607204-submitter@bugs.debian.org (full text, mbox):

From: Sergey B Kirpichev <skirpichev@gmail.com>
To: 607204-submitter@bugs.debian.org
Subject: Re: awstats produces invalid XHTML
Date: Wed, 16 Mar 2011 18:41:16 +0300
forwarded 607204 http://sourceforge.net/tracker/?func=detail&aid=3216590&group_id=13764&atid=113764
retitle 607204 awstats will use "&nbsp;" in XHTML output
thanks

Hello,

I've forwarded your bug to upstream BTS and retitled it accordingly.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian AWStats Team <pkg-awstats-devel@lists.alioth.debian.org>:
Bug#607204; Package awstats. (Sun, 03 Apr 2011 23:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Francis Russell <francis+dbts@unchartedbackwaters.co.uk>:
Extra info received and forwarded to list. Copy sent to Debian AWStats Team <pkg-awstats-devel@lists.alioth.debian.org>. (Sun, 03 Apr 2011 23:09:03 GMT) Full text and rfc822 format available.

Message #17 received at 607204@bugs.debian.org (full text, mbox):

From: Francis Russell <francis+dbts@unchartedbackwaters.co.uk>
To: 607204@bugs.debian.org
Subject: Re: Bug#607204: awstats produces invalid XHTML
Date: Sun, 03 Apr 2011 23:57:39 +0100
So, I've recently been informed that &nbsp; *is* actually valid XHTML.
The  wonderful amount of misleading information about &nbsp; being
invalid XHTML, or Firefox not supporting &nbsp; is due to a bizarre
browser bug that apparently causes Firefox to reject &nbsp; in XHTML
under certain circumstances. The same browser bug hit me.

However, I did just run awstats output though W3C's XHTML validator, and
there are still large numbers of validation errors, just the &nbsp;
thing isn't one of them.

Francis




Message sent on to Francis Russell <francis+dbts@unchartedbackwaters.co.uk>:
Bug#607204. (Tue, 05 Apr 2011 17:33:03 GMT) Full text and rfc822 format available.

Message #20 received at 607204-submitter@bugs.debian.org (full text, mbox):

From: Sergey B Kirpichev <skirpichev@gmail.com>
To: 607204-submitter@bugs.debian.org
Subject: Re: [Pkg-awstats-devel] Bug#607204: awstats produces invalid XHTML
Date: Tue, 5 Apr 2011 21:28:43 +0400
On Mon, Apr 4, 2011 at 2:57 AM, Francis Russell
<francis+dbts@unchartedbackwaters.co.uk> wrote:
> So, I've recently been informed that &nbsp; *is* actually valid XHTML.
> The  wonderful amount of misleading information about &nbsp; being
> invalid XHTML, or Firefox not supporting &nbsp; is due to a bizarre
> browser bug that apparently causes Firefox to reject &nbsp; in XHTML
> under certain circumstances. The same browser bug hit me.

Are you sure that "&nbsp;" is a cause of this bug?

E.g. have you tried to replace all occurences of "&nbsp;"
with "&#160;"?  Is such a page renders ok in your browser?




Information forwarded to debian-bugs-dist@lists.debian.org, Sergey B Kirpichev <skirpichev@gmail.com>:
Bug#607204; Package awstats. (Tue, 12 Apr 2011 23:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Francis Russell <francis@unchartedbackwaters.co.uk>:
Extra info received and forwarded to list. Copy sent to Sergey B Kirpichev <skirpichev@gmail.com>. (Tue, 12 Apr 2011 23:18:03 GMT) Full text and rfc822 format available.

Message #25 received at 607204@bugs.debian.org (full text, mbox):

From: Francis Russell <francis@unchartedbackwaters.co.uk>
To: 607204@bugs.debian.org
Subject: Re: Bug#607204: [Pkg-awstats-devel] Bug#607204: awstats produces invalid XHTML
Date: Wed, 13 Apr 2011 00:15:46 +0100
So the bug I hit is apparently an issue that occurs when upgrading a
running instance of Firefox on certain platforms. Once it's been
restarted, it no longer complains. There's a more in-depth discussion of
the issue in this other bug report.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619617

Still, as I said before, the rest of the report about awstats's invalid
XHTML is still valid.

Francis




Information forwarded to debian-bugs-dist@lists.debian.org, Sergey B Kirpichev <skirpichev@gmail.com>:
Bug#607204; Package awstats. (Sun, 19 Jun 2011 01:27:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Chaskiel Grundman <cg2v@andrew.cmu.edu>:
Extra info received and forwarded to list. Copy sent to Sergey B Kirpichev <skirpichev@gmail.com>. (Sun, 19 Jun 2011 01:27:06 GMT) Full text and rfc822 format available.

Message #30 received at 607204@bugs.debian.org (full text, mbox):

From: Chaskiel Grundman <cg2v@andrew.cmu.edu>
To: 607204@bugs.debian.org
Subject: Bug#607204: awstats produces invalid XHTML
Date: Sat, 18 Jun 2011 20:53:19 -0400 (EDT)
I think this the validation failures are mostly because it's marked 
as XHTML Strict whereas it's actually transitional. If I change the 
doctype (and fix the selected="true" thing), the output validates.





Reply sent to Sergey B Kirpichev <skirpichev@gmail.com>:
You have taken responsibility. (Wed, 21 Dec 2011 18:36:40 GMT) Full text and rfc822 format available.

Notification sent to Francis Russell <francis+dbts@unchartedbackwaters.co.uk>:
Bug acknowledged by developer. (Wed, 21 Dec 2011 18:36:40 GMT) Full text and rfc822 format available.

Message #35 received at 607204-done@bugs.debian.org (full text, mbox):

From: Sergey B Kirpichev <skirpichev@gmail.com>
To: 607204-done@bugs.debian.org
Subject: Re: awstats produces invalid XHTML
Date: Wed, 21 Dec 2011 22:28:32 +0400
Since 7.0~dfsg-3 awstats output should
pass XHTML validation (see patch 1017_fix_html_output_markup.patch).

So, I will close this bugreport.






Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 19 Jan 2012 07:32:37 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 11:30:34 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.