Debian Bug report logs - #605277
chef: remove from squeeze because of solr (#602697)?

version graph

Package: chef; Maintainer for chef is Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>; Source for chef is src:chef.

Reported by: Thomas Koch <thomas@koch.ro>

Date: Sun, 7 Nov 2010 10:39:07 UTC

Severity: serious

Tags: squeeze

Found in version chef/0.8.16-4.1

Fixed in version chef/0.8.16-4.2

Done: Luca Capello <luca@pca.it>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, thomas@koch.ro, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Sun, 07 Nov 2010 10:39:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Koch <thomas@koch.ro>:
New Bug report received and forwarded. Copy sent to thomas@koch.ro, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sun, 07 Nov 2010 10:39:10 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Thomas Koch <thomas@koch.ro>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: should not be included in squeeze
Date: Sun, 07 Nov 2010 11:38:26 +0100
Package: solr
Severity: serious
Tags: squeeze

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
debian-java and the package's maintainer Jan-Pascal van Best and
proposed the removal of solr from Squeeze, mainly because:

- - it's already outdated a year by now (see bug #602696 )
- - it doesn't even include all contribs (see bug #602695 )
- - the package has accumulated too many bugs
- - there doesn't seem to be enough (wo)man power to maintain the package
  right now on a standard that would make it fit for Debian _stable_

So until nothing else happens, please don't include solr in Debian
squeeze.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJM1oGeAAoJEAf8SJEEK6ZaFiAP/jFmubZ8p3rWiMAAgwKqcttk
3tUbU+w8meAMv89k8k32BdYQMmMzg0K8ecsxJeTNIgV4CRvroUwf3vRL3qd6Tgbr
U57wcVB+J6Ionea0oYru35wqGAwBsRm6fFUFRpDWrVJjuRMrrIFz7WUJHmiCmSjO
+eUvo/I4hniXcgLEm72Hui/qT6HeYMHKQMlzPbjSVkTbsC/d8Q7TpE/YLu6Q5BeG
yKNvyMUou02QUX2wtDIPw2K/j71OuF/PPqWv1hLDdIqbm1sTmbTSKMKmTkG0spQc
ySa7djpLiWTffTH3gmKDMqSjnUuRjvJCJowLx85aicKulZuyh+Juo4Ump84V8KJN
vBmCWtbI/IzldDWX73eWtkzm29fyDK62ovt7Jqm9IQ5jnrUSeRTJ+xNXfAvRjTKg
Hs0jgbNiUMivqlm9wcA5d9vuzZRhchwUm9VtC8UMs3SWW+FAP2oQg/yYETYZ5rs9
xvGMS3tFgJJ1Pe8wuP3IzUo/j7jVOyxMWWOak6orGJApePOk6zG6cIYzSdo6RGfI
dflA5MfHEhMOsCR3Q9fd+YRgEdyIOcnGHity31yS0RPsLO78PV8yztW5VLZXQ5f2
52aU1UMFYp2ULtW0wSFayC5lLclGo/fYKzXX+TIwBrUryukiKVPaelJ11TsAYefr
PfTZdFLR1T86DewUPivM
=TqjB
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Sun, 07 Nov 2010 12:54:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sun, 07 Nov 2010 12:54:11 GMT) Full text and rfc822 format available.

Message #10 received at 602697@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Thomas Koch <thomas@koch.ro>, 602697@bugs.debian.org
Subject: Re: Bug#602697: should not be included in squeeze
Date: Sun, 07 Nov 2010 12:53:10 +0000
On Sun, 2010-11-07 at 11:38 +0100, Thomas Koch wrote:
> I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
> debian-java and the package's maintainer Jan-Pascal van Best and
> proposed the removal of solr from Squeeze, mainly because:
> 
> - - it's already outdated a year by now (see bug #602696 )
> - - it doesn't even include all contribs (see bug #602695 )
> - - the package has accumulated too many bugs
> - - there doesn't seem to be enough (wo)man power to maintain the package
>   right now on a standard that would make it fit for Debian _stable_
> 
> So until nothing else happens, please don't include solr in Debian
> squeeze.

The package has a reverse-dependency in testing already, so can't be
removed right now:

Checking reverse dependencies...
# Broken Depends:
chef: chef-solr

It's also in lenny (albeit in contrib) so if it were removed then a
migration path for those users to a replacement would be good.

Regards,

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Sun, 07 Nov 2010 18:45:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to thomas@koch.ro:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sun, 07 Nov 2010 18:45:08 GMT) Full text and rfc822 format available.

Message #15 received at 602697@bugs.debian.org (full text, mbox):

From: Thomas Koch <thomas@koch.ro>
To: "Adam D. Barratt" <adam@adam-barratt.org.uk>, 602697@bugs.debian.org, Joshua Timberman <joshua@opscode.com>, Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Subject: Re: Bug#602697: chef-solr depends on solr
Date: Sun, 7 Nov 2010 14:52:24 +0100
Adam D. Barratt:
> On Sun, 2010-11-07 at 11:38 +0100, Thomas Koch wrote:
> > I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
> > debian-java and the package's maintainer Jan-Pascal van Best and
> > proposed the removal of solr from Squeeze, mainly because:
> > 
> > - - it's already outdated a year by now (see bug #602696 )
> > - - it doesn't even include all contribs (see bug #602695 )
> > - - the package has accumulated too many bugs
> > - - there doesn't seem to be enough (wo)man power to maintain the package
> > 
> >   right now on a standard that would make it fit for Debian _stable_
> > 
> > So until nothing else happens, please don't include solr in Debian
> > squeeze.
> 
> The package has a reverse-dependency in testing already, so can't be
> removed right now:
> 
> Checking reverse dependencies...
> # Broken Depends:
> chef: chef-solr

to the maintainer of Chef in Debian,

this is just to inform you, that there is a recommendation from me to remove 
the solr package from Debian. However since chef-solr does depend on solr, 
you'd affected by this removal.

I've had a quick look over the informations about your package (bugs, 
piuparts, lintian) and would like to ask you, whether you wouldn't also be 
better to not include chef in Debian in its current state. - Please keep in 
mind that you commit yourself to maintain your package during the entire life 
of Debian Squeeze which may well be over two years!

Users of chef could still install chef via testing or backports if chef should 
not be shipped with Debian Squeeze.

If you still want to include chef in Debian Squeeze, would you like to help 
maintaining the solr package?

Best regards,

Thomas Koch, http://www.koch.ro




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Sun, 07 Nov 2010 20:45:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jan-Pascal van Best <janpascal@vanbest.org>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sun, 07 Nov 2010 20:45:06 GMT) Full text and rfc822 format available.

Message #20 received at 602697@bugs.debian.org (full text, mbox):

From: Jan-Pascal van Best <janpascal@vanbest.org>
To: Thomas Koch <thomas@koch.ro>, 602697@bugs.debian.org, pkg-java-maintainers@lists.alioth.debian.org
Subject: Re: Bug#602697: should not be included in squeeze
Date: Sun, 07 Nov 2010 21:37:34 +0100
[Message part 1 (text/plain, inline)]
On 11/07/2010 11:38 AM, Thomas Koch wrote:
> Package: solr
> Severity: serious
> Tags: squeeze
>
> I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
> debian-java and the package's maintainer Jan-Pascal van Best and
> proposed the removal of solr from Squeeze, mainly because:
>
> - it's already outdated a year by now (see bug #602696 )
> - it doesn't even include all contribs (see bug #602695 )
> - the package has accumulated too many bugs
> - there doesn't seem to be enough (wo)man power to maintain the package
>   right now on a standard that would make it fit for Debian _stable_
>
> So until nothing else happens, please don't include solr in Debian
> squeeze.
>
Agreed. Solr is moving too fast, and accumulating too many dependencies
(which have their own dependencies, and so on) to be maintained properly
right now.

Jan-Pascal

[Message part 2 (text/html, inline)]
[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Mon, 08 Nov 2010 17:39:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Victor Seva <linuxmaniac@torreviejawireless.org>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Mon, 08 Nov 2010 17:39:07 GMT) Full text and rfc822 format available.

Message #25 received at 602697@bugs.debian.org (full text, mbox):

From: Victor Seva <linuxmaniac@torreviejawireless.org>
To: Jan-Pascal van Best <janpascal@vanbest.org>
Cc: Thomas Koch <thomas@koch.ro>, 602697@bugs.debian.org, pkg-java-maintainers@lists.alioth.debian.org
Subject: Re: Bug#602697: should not be included in squeeze
Date: Mon, 8 Nov 2010 18:34:23 +0100
[Message part 1 (text/plain, inline)]
Hi Jan-Pascal and Thomas,

On 11/07/2010  21:37, Jan-Pascal van Best wrote:

> On 11/07/2010 11:38 AM, Thomas Koch wrote:
> > Package: solr
> 
> > Severity: serious
> 
> > Tags: squeeze
> 
> >
>> I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
>> debian-java and the package's maintainer Jan-Pascal van Best and
>> proposed the removal of solr from Squeeze, mainly because:
>> 
>> - it's already outdated a year by now (see bug #602696 )
>> - it doesn't even include all contribs (see bug #602695 )
>> - the package has accumulated too many bugs
>> - there doesn't seem to be enough (wo)man power to maintain the package
>>   right now on a standard that would make it fit for Debian _stable_
>> 

We[0] are currently using solr at Work. I have backported [1] the last version to lenny for our own use and it's running on our production servers. So I'm stepping forward to help packaging in anyway I can. I have some experience packaging [2] but not with java apps. 

>> So until nothing else happens, please don't include solr in Debian
>> squeeze.
>> 
> Agreed. Solr is moving too fast, and accumulating too many dependencies (which have their own dependencies, and so on) to be maintained properly right now.
> 
> Jan-Pascal

What is the priority? Upgrade the package to 1.4.1? Fix the issues on 1.4.0?


Thanks

[0] http://www.cervantesvirtual.com/
[1] https://github.com/linuxmaniac/bvmc_debian/tree/master/solr/ 
[2] http://qa.debian.org/developer.php?login=linuxmaniac%40torreviejawireless.org
[PGP.sig (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Mon, 08 Nov 2010 17:57:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to thomas@koch.ro:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Mon, 08 Nov 2010 17:57:06 GMT) Full text and rfc822 format available.

Message #30 received at 602697@bugs.debian.org (full text, mbox):

From: Thomas Koch <thomas@koch.ro>
To: Victor Seva <linuxmaniac@torreviejawireless.org>
Cc: "Jan-Pascal van Best" <janpascal@vanbest.org>, 602697@bugs.debian.org
Subject: Re: Bug#602697: should not be included in squeeze
Date: Mon, 8 Nov 2010 18:54:28 +0100
Victor Seva:
> What is the priority? Upgrade the package to 1.4.1? Fix the issues on
> 1.4.0?
Hi Victor,

thank you very much for the offer. I think having version 1.4.1 should be the 
minimum requirement for Debian Squeeze. However I'm afraid we won't be allowed 
to do any additional upload for Squeeze only for an updated version.

The GIT repository used for the Debian solr packaging was a bit of an 
experiment of me. I would be willing to throw it away and let you start from 
skretch if this would help you.

Best regards,

Thomas Koch, http://www.koch.ro




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#602697; Package solr. (Sun, 28 Nov 2010 16:48:15 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luca Capello <luca@pca.it>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 16:48:15 GMT) Full text and rfc822 format available.

Message #35 received at 602697@bugs.debian.org (full text, mbox):

From: Luca Capello <luca@pca.it>
To: 602697@bugs.debian.org
Cc: Thomas Koch <thomas@koch.ro>, Joshua Timberman <joshua@opscode.com>, Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>, "Adam D. Barratt" <adam@adam-barratt.org.uk>, Jan-Pascal van Best <janpascal@vanbest.org>, Victor Seva <linuxmaniac@torreviejawireless.org>
Subject: chef: remove from squeeze because of solr (#602697)? (was Re: Bug#602697: chef-solr depends on solr)
Date: Sun, 28 Nov 2010 17:47:41 +0100
[Message part 1 (text/plain, inline)]
clone 602697 -1
retitle -1 chef: remove from squeeze because of solr (#602697)?
found -1 0.8.16-4.1
block 602697 by -1
thanks

Hi there!

Cc:ing all the people that have interacted with this bug.

On Sun, 07 Nov 2010 14:52:24 +0100, Thomas Koch wrote:
> Adam D. Barratt:
>> On Sun, 2010-11-07 at 11:38 +0100, Thomas Koch wrote:
>> > I've written a mail ("Remove Solr from Squeeze?") on 2010/10/12 to
>> > debian-java and the package's maintainer Jan-Pascal van Best and
>> > proposed the removal of solr from Squeeze, mainly because:
>> > 
>> > - - it's already outdated a year by now (see bug #602696 )
>> > - - it doesn't even include all contribs (see bug #602695 )
>> > - - the package has accumulated too many bugs
>> > - - there doesn't seem to be enough (wo)man power to maintain the package
>> > 
>> >   right now on a standard that would make it fit for Debian _stable_
>> > 
>> > So until nothing else happens, please don't include solr in Debian
>> > squeeze.
>> 
>> The package has a reverse-dependency in testing already, so can't be
>> removed right now:
>> 
>> Checking reverse dependencies...
>> # Broken Depends:
>> chef: chef-solr
>
> to the maintainer of Chef in Debian,
>
> this is just to inform you, that there is a recommendation from me to remove 
> the solr package from Debian. However since chef-solr does depend on solr, 
> you'd affected by this removal.

Some hints about the chef package in Debian:

- Debian has (6-month-old) 0.8.16-4.1, while upstream is at 0.9.12
- popcon show 41 installation (2 recent) for the chef binary package and
  2 (0 recent) for the chef-solr binary package
- there is an RC bug for chef-solr (#604231, installation fails because
  of nodedown)

Thus, I think the best thing would be to remove chef from squeeze (new
bugs created), so then we can remove solr as well.

>> It's also in lenny (albeit in contrib) so if it were removed then a
>> migration path for those users to a replacement would be good.

Given that chef-solr was not in lenny, the above applies to solr only.
However, I should say that I do not know at all a good migration path.

Thx, bye,
Gismo / Luca
[signature.asc (application/pgp-signature, inline)]

Bug 602697 cloned as bug 605277. Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 16:48:17 GMT) Full text and rfc822 format available.

Changed Bug title to 'chef: remove from squeeze because of solr (#602697)?' from 'should not be included in squeeze' Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 16:48:20 GMT) Full text and rfc822 format available.

Bug Marked as found in versions 0.8.16-4.1. Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 16:48:20 GMT) Full text and rfc822 format available.

Added indication that bug 605277 blocks 602697 Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 16:48:22 GMT) Full text and rfc822 format available.

Bug reassigned from package 'solr' to 'chef'. Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 20:24:10 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions 0.8.16-4.1. Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 20:24:10 GMT) Full text and rfc822 format available.

Bug Marked as found in versions chef/0.8.16-4.1. Request was from Luca Capello <luca@pca.it> to control@bugs.debian.org. (Sun, 28 Nov 2010 20:24:11 GMT) Full text and rfc822 format available.

Reply sent to Luca Capello <luca@pca.it>:
You have taken responsibility. (Thu, 09 Dec 2010 23:45:04 GMT) Full text and rfc822 format available.

Notification sent to Thomas Koch <thomas@koch.ro>:
Bug acknowledged by developer. (Thu, 09 Dec 2010 23:45:04 GMT) Full text and rfc822 format available.

Message #54 received at 605277-done@bugs.debian.org (full text, mbox):

From: Luca Capello <luca@pca.it>
To: 605277-done@bugs.debian.org
Cc: Thomas Koch <thomas@koch.ro>, Joshua Timberman <joshua@opscode.com>, Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>, Jan-Pascal van Best <janpascal@vanbest.org>, Victor Seva <linuxmaniac@torreviejawireless.org>, debian-release@lists.debian.org
Subject: Re: chef: remove from squeeze because of solr (#602697)? (was Re: Bug#602697: chef-solr depends on solr)
Date: Fri, 10 Dec 2010 00:41:08 +0100
[Message part 1 (text/plain, inline)]
Package: chef
Version: 0.8.16-4.2

Hi there!

Adding debian-release@ to the cc: given that this is (no more) an RC
bug, please read the background in the BTS.

On Sun, 28 Nov 2010 17:47:41 +0100, Luca Capello wrote:
> Cc:ing all the people that have interacted with this bug.

Done again, please forgive me if you are no more interested in it.

> On Sun, 07 Nov 2010 14:52:24 +0100, Thomas Koch wrote:
>> Adam D. Barratt:
>>> On Sun, 2010-11-07 at 11:38 +0100, Thomas Koch wrote:
>>> > So until nothing else happens, please don't include solr in Debian
>>> > squeeze.
>>> 
>>> The package has a reverse-dependency in testing already, so can't be
>>> removed right now:
>>> 
>>> Checking reverse dependencies...
>>> # Broken Depends:
>>> chef: chef-solr
>>
>> to the maintainer of Chef in Debian,
>>
>> this is just to inform you, that there is a recommendation from me to remove 
>> the solr package from Debian. However since chef-solr does depend on solr, 
>> you'd affected by this removal.
>
> Some hints about the chef package in Debian:
>
> - Debian has (6-month-old) 0.8.16-4.1, while upstream is at 0.9.12
> - popcon show 41 installation (2 recent) for the chef binary package and
>   2 (0 recent) for the chef-solr binary package
> - there is an RC bug for chef-solr (#604231, installation fails because
>   of nodedown)
>
> Thus, I think the best thing would be to remove chef from squeeze (new
> bugs created), so then we can remove solr as well.

No need anymore to remove chef from squeeze, given that after its
maintainer hint I uploaded the 0.8.16-4.2 NMU which removes any -server*
and -solr package.

This is the reason why I closed this bug with the NMU version.

>>> It's also in lenny (albeit in contrib) so if it were removed then a
>>> migration path for those users to a replacement would be good.
>
> Given that chef-solr was not in lenny, the above applies to solr only.
> However, I should say that I do not know at all a good migration path.

This still stands, but I am no solr expert, sorry.

Thx, bye,
Gismo / Luca
[Message part 2 (application/pgp-signature, inline)]

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 12 Jan 2011 07:33:21 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 23:27:49 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.