Debian Bug report logs - #605218
apt-get dist-upgrade fails to install ia32-libs since version 20101117

version graph

Package: ia32-libs; Maintainer for ia32-libs is Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>; Source for ia32-libs is src:ia32-libs.

Reported by: Luc Castermans <luc@castermans.org>

Date: Sun, 28 Nov 2010 08:39:02 UTC

Severity: grave

Tags: patch

Found in version ia32-libs/20101117

Fixed in version ia32-libs/20101129

Done: Goswin von Brederlow <goswin-v-b@web.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 08:39:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luc Castermans <luc@castermans.org>:
New Bug report received and forwarded. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 08:39:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Luc Castermans <luc@castermans.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 08:56:44 +0100
Package: ia32-libs
Version: 20101117
Severity: grave
Tags: d-i
Justification: renders package unusable

apt-get install ia32-libs fails to install the package; this occurs since the latest release of this package

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=nl_NL.UTF-8, LC_CTYPE=nl_NL.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ia32-libs depends on:
ii  dpkg                    1.15.8.5         Debian package management system
ii  lib32asound2            1.0.23-2.1       shared library for ALSA applicatio
pn  lib32bz2-1.0            <none>           (no description available)
pn  lib32gcc1               <none>           (no description available)
ii  lib32ncurses5           5.7+20100313-4   shared libraries for terminal hand
pn  lib32stdc++6            <none>           (no description available)
pn  lib32v4l-0              <none>           (no description available)
ii  lib32z1                 1:1.2.3.4.dfsg-3 compression library - 32 bit runti
ii  libc6-i386              2.11.2-7         Embedded GNU C Library: 32-bit sha

ia32-libs recommends no packages.

Versions of packages ia32-libs suggests:
pn  ia32-libs-gtk                 <none>     (no description available)




Removed tag(s) d-i. Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sun, 28 Nov 2010 13:27:14 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 14:42:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Xavier Oswald <xoswald@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 14:42:08 GMT) Full text and rfc822 format available.

Message #12 received at 605218@bugs.debian.org (full text, mbox):

From: Xavier Oswald <xoswald@debian.org>
To: Debian Bug Tracking System <605218@bugs.debian.org>
Cc: Luc Castermans <luc@castermans.org>
Subject: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 15:41:19 +0100
[Message part 1 (text/plain, inline)]
tags 605218 unreproducible

Hi,

The bugreport doesn't contain a lot of informaton. But well, I tried to
reproduce it.

Some test cases:

1) clean lenny chroot
   install ia32-libs
   doing an upgrade  of the package to squeeze
   OK.

2) clean lenny chroot
   install ia32-libs
   doing a dist-upgrade to squeeze
   OK.

3) clean lenny chroot
   install ia32-libs
   doing a package upgrade to sid
   OK.

4) clean lenny chroot
   install ia32-libs
   doing a dist-upgrade to sid
   OK.

5) clean squeeze chroot
   install ia32-libs
   OK

5) clean sid chroot
   install ia32-libs
   OK


Please provide us more information.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=C (charmap=UTF-8) (ignored: LC_ALL set to fr_FR.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ia32-libs depends on:
ii  dpkg                    1.15.8.6         Debian package management system
ii  lib32asound2            1.0.23-2.1       shared library for ALSA applicatio
ii  lib32bz2-1.0            1.0.5-6          high-quality block-sorting file co
ii  lib32gcc1               1:4.4.5-8        GCC support library (32 bit Versio
ii  lib32ncurses5           5.7+20100313-4   shared libraries for terminal hand
ii  lib32stdc++6            4.4.5-8          The GNU Standard C++ Library v3 (3
ii  lib32v4l-0              0.8.1-1          Collection of video4linux support 
ii  lib32z1                 1:1.2.3.4.dfsg-3 compression library - 32 bit runti
ii  libc6-i386              2.11.2-7         Embedded GNU C Library: 32-bit sha

ia32-libs recommends no packages.

Versions of packages ia32-libs suggests:
pn  ia32-libs-gtk                 <none>     (no description available)

-- no debconf information

-- 
Xavier Oswald <xoswald@debian.org>
GNU/Linux Debian Developer - http://www.debian.org/
GPG key ID: 0x464B8DE3
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 19:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Francesco <harpomarx@alice.it>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 19:12:03 GMT) Full text and rfc822 format available.

Message #17 received at 605218@bugs.debian.org (full text, mbox):

From: Francesco <harpomarx@alice.it>
To: Debian Bug Tracking System <605218@bugs.debian.org>
Subject: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 20:08:52 +0100
Package: ia32-libs
Severity: normal

  I had the same issue using squeeze amd64 and wine; manually upgrading the
package resulted in error and a further investigation took me to uninstall 
package ia32-libs-workaround-499043 and then reinstall ia32-libs and related 
packages updated

-- System Information:
Debian Release: squeeze/sid
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash




Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 21:39:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luc Castermans <luc@castermans.org>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 21:39:06 GMT) Full text and rfc822 format available.

Message #22 received at 605218@bugs.debian.org (full text, mbox):

From: Luc Castermans <luc@castermans.org>
To: Xavier Oswald <xoswald@debian.org>
Cc: 605218@bugs.debian.org
Subject: Re: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 22:16:26 +0100
Hello,

As Francesco replied, I removed ia32-libs-workaround-499043
and now also the problem is gone.

Maybe you could fix a dependency ?

Thanks,


-- 

Luc Castermans
e-mail: luc at castermans . org
Visit my site at http://www.castermans.org
Free (as in Freedom) Office suite at http://nl.openoffice.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 21:48:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 21:48:10 GMT) Full text and rfc822 format available.

Message #27 received at 605218@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Luc Castermans <luc@castermans.org>, 605218@bugs.debian.org
Cc: Xavier Oswald <xoswald@debian.org>
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 22:45:21 +0100
[Message part 1 (text/plain, inline)]
On Sun, Nov 28, 2010 at 22:16:26 +0100, Luc Castermans wrote:

> Hello,
> 
> As Francesco replied, I removed ia32-libs-workaround-499043
> and now also the problem is gone.
> 
Where did this ia32-libs-workaround-499043 package come from?  As far as
I can tell, nowhere near the debian archive...

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 28 Nov 2010 22:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 28 Nov 2010 22:09:03 GMT) Full text and rfc822 format available.

Message #32 received at 605218@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Julien Cristau <jcristau@debian.org>, 605218@bugs.debian.org
Cc: Luc Castermans <luc@castermans.org>, Xavier Oswald <xoswald@debian.org>
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Sun, 28 Nov 2010 22:05:54 +0000
On Sun, 2010-11-28 at 22:45 +0100, Julien Cristau wrote:
> On Sun, Nov 28, 2010 at 22:16:26 +0100, Luc Castermans wrote:
> 
> > Hello,
> > 
> > As Francesco replied, I removed ia32-libs-workaround-499043
> > and now also the problem is gone.
> > 
> Where did this ia32-libs-workaround-499043 package come from?  As far as
> I can tell, nowhere near the debian archive...

It looks to be a hack for making ia32-libs and flash play nicely
together in lenny - see
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499043#92

Regards,

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Mon, 29 Nov 2010 07:03:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to snorky snorky <snorky2001@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Mon, 29 Nov 2010 07:03:07 GMT) Full text and rfc822 format available.

Message #37 received at 605218@bugs.debian.org (full text, mbox):

From: snorky snorky <snorky2001@gmail.com>
To: 605218@bugs.debian.org
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs since version 20101117
Date: Mon, 29 Nov 2010 07:58:35 +0100
[Message part 1 (text/plain, inline)]
Same problem for me.

Removing ia32-libs-workaround-499043 package solved the issue. I probably
have played with the flash player workaroud under Lenny too.

Regards
[Message part 2 (text/html, inline)]

Message sent on to Luc Castermans <luc@castermans.org>:
Bug#605218. (Mon, 29 Nov 2010 18:30:09 GMT) Full text and rfc822 format available.

Message #40 received at 605218-submitter@bugs.debian.org (full text, mbox):

From: Patrick Matthäi <pmatthaei@debian.org>
To: 605218-submitter@bugs.debian.org
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs since, version 20101117
Date: Mon, 29 Nov 2010 19:26:37 +0100
[Message part 1 (text/plain, inline)]
Looks like it would be not worth to add a conflicts to the next
ia32-libs upload, since flash is popular and some more ppl may have got
this workaround package installed...

-- 
/*
Mit freundlichem Gruß / With kind regards,
 Patrick Matthäi
 GNU/Linux Debian Developer

E-Mail: pmatthaei@debian.org
        patrick@linux-dev.org

Comment:
Always if we think we are right,
we were maybe wrong.
*/

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Wed, 01 Dec 2010 21:21:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Gilbert <michael.s.gilbert@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Wed, 01 Dec 2010 21:21:10 GMT) Full text and rfc822 format available.

Message #45 received at 605218@bugs.debian.org (full text, mbox):

From: Michael Gilbert <michael.s.gilbert@gmail.com>
To: 605218@bugs.debian.org
Subject: re: apt-get dist-upgrade fails to install ia32-libs
Date: Wed, 1 Dec 2010 16:18:54 -0500
Since ia32-libs-workaround-499043 is a third-party package, this really
isn't Debian's problem. I think that the bug can be safely closed. In
the meantime, this discussion can serve as a record for anyone else who
may have installed the rogue package and run into the problem.

Mike




Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Wed, 01 Dec 2010 21:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Wed, 01 Dec 2010 21:39:03 GMT) Full text and rfc822 format available.

Message #50 received at 605218@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Michael Gilbert <michael.s.gilbert@gmail.com>, 605218@bugs.debian.org
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs
Date: Wed, 1 Dec 2010 22:34:57 +0100
[Message part 1 (text/plain, inline)]
On Wed, Dec  1, 2010 at 16:18:54 -0500, Michael Gilbert wrote:

> Since ia32-libs-workaround-499043 is a third-party package, this really
> isn't Debian's problem. I think that the bug can be safely closed. In
> the meantime, this discussion can serve as a record for anyone else who
> may have installed the rogue package and run into the problem.
> 
NAK.  If the package was widely documented as the way to get flash on
64bit, then we need to handle the upgrade path, if only by conflicting
against it.

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Thu, 02 Dec 2010 05:15:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Gilbert <michael.s.gilbert@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Thu, 02 Dec 2010 05:15:05 GMT) Full text and rfc822 format available.

Message #55 received at 605218@bugs.debian.org (full text, mbox):

From: Michael Gilbert <michael.s.gilbert@gmail.com>
To: 605218@bugs.debian.org, control <control@bugs.debian.org>
Subject: Re: Bug#605218: apt-get dist-upgrade fails to install ia32-libs
Date: Thu, 2 Dec 2010 00:12:16 -0500
[Message part 1 (text/plain, inline)]
tag 605218 patch
thanks

On Wed, Dec 1, 2010 at 4:34 PM, Julien Cristau wrote:
> On Wed, Dec  1, 2010 at 16:18:54 -0500, Michael Gilbert wrote:
>
>> Since ia32-libs-workaround-499043 is a third-party package, this really
>> isn't Debian's problem. I think that the bug can be safely closed. In
>> the meantime, this discussion can serve as a record for anyone else who
>> may have installed the rogue package and run into the problem.
>>
> NAK.  If the package was widely documented as the way to get flash on
> 64bit, then we need to handle the upgrade path, if only by conflicting
> against it.

Please see attached patch.  I've tested that this will successfully
install the new ia32-libs and remove ia32-libs-workaround-499043 (if
its installed) in the process.

Mike
[ia32-libs.patch (text/x-patch, attachment)]

Added tag(s) patch. Request was from Michael Gilbert <michael.s.gilbert@gmail.com> to control@bugs.debian.org. (Thu, 02 Dec 2010 05:15:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Thu, 02 Dec 2010 08:34:29 GMT) Full text and rfc822 format available.

Acknowledgement sent to Goswin von Brederlow <goswin-v-b@web.de>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Thu, 02 Dec 2010 08:34:29 GMT) Full text and rfc822 format available.

Message #62 received at 605218@bugs.debian.org (full text, mbox):

From: Goswin von Brederlow <goswin-v-b@web.de>
To: Michael Gilbert <michael.s.gilbert@gmail.com>
Cc: 605218@bugs.debian.org
Subject: Re: [Pkg-ia32-libs-maintainers] Bug#605218: apt-get dist-upgrade fails to install ia32-libs
Date: Thu, 02 Dec 2010 09:17:30 +0100
Michael Gilbert <michael.s.gilbert@gmail.com> writes:

> tag 605218 patch
> thanks
>
> On Wed, Dec 1, 2010 at 4:34 PM, Julien Cristau wrote:
>> On Wed, Dec  1, 2010 at 16:18:54 -0500, Michael Gilbert wrote:
>>
>>> Since ia32-libs-workaround-499043 is a third-party package, this really
>>> isn't Debian's problem. I think that the bug can be safely closed. In
>>> the meantime, this discussion can serve as a record for anyone else who
>>> may have installed the rogue package and run into the problem.
>>>
>> NAK.  If the package was widely documented as the way to get flash on
>> 64bit, then we need to handle the upgrade path, if only by conflicting
>> against it.
>
> Please see attached patch.  I've tested that this will successfully
> install the new ia32-libs and remove ia32-libs-workaround-499043 (if
> its installed) in the process.
>
> Mike

It would have been more helpfull for someone to sponsor the already
fixed package on mentors.debian.net.

MfG
        Goswin




Added tag(s) pending. Request was from Goswin von Brederlow <goswin-v-b@web.de> to control@bugs.debian.org. (Thu, 02 Dec 2010 08:34:31 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Thu, 02 Dec 2010 17:00:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Gilbert <michael.s.gilbert@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Thu, 02 Dec 2010 17:00:08 GMT) Full text and rfc822 format available.

Message #69 received at 605218@bugs.debian.org (full text, mbox):

From: Michael Gilbert <michael.s.gilbert@gmail.com>
To: 605218@bugs.debian.org
Subject: Re: [Pkg-ia32-libs-maintainers] Bug#605218: apt-get dist-upgrade fails to install ia32-libs
Date: Thu, 2 Dec 2010 11:57:23 -0500
On Thu, 02 Dec 2010 09:17:30 +0100, Goswin von Brederlow wrote:
> Michael Gilbert <michael.s.gilbert@gmail.com> writes:
> 
> > tag 605218 patch
> > thanks
> >
> > On Wed, Dec 1, 2010 at 4:34 PM, Julien Cristau wrote:
> >> On Wed, Dec  1, 2010 at 16:18:54 -0500, Michael Gilbert wrote:
> >>
> >>> Since ia32-libs-workaround-499043 is a third-party package, this really
> >>> isn't Debian's problem. I think that the bug can be safely closed. In
> >>> the meantime, this discussion can serve as a record for anyone else who
> >>> may have installed the rogue package and run into the problem.
> >>>
> >> NAK.  If the package was widely documented as the way to get flash on
> >> 64bit, then we need to handle the upgrade path, if only by conflicting
> >> against it.
> >
> > Please see attached patch.  I've tested that this will successfully
> > install the new ia32-libs and remove ia32-libs-workaround-499043 (if
> > its installed) in the process.
> >
> > Mike
> 
> It would have been more helpfull for someone to sponsor the already
> fixed package on mentors.debian.net.

OK, I'll send an RFS message.

Mike




Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Thu, 02 Dec 2010 17:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alexander Reichle-Schmehl <tolimar@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Thu, 02 Dec 2010 17:21:05 GMT) Full text and rfc822 format available.

Message #74 received at 605218@bugs.debian.org (full text, mbox):

From: Alexander Reichle-Schmehl <tolimar@debian.org>
To: Goswin von Brederlow <goswin-v-b@web.de>, 605218@bugs.debian.org
Cc: Michael Gilbert <michael.s.gilbert@gmail.com>
Subject: Re: Bug#605218: [Pkg-ia32-libs-maintainers] Bug#605218: apt-get dist-upgrade fails to install ia32-libs
Date: Thu, 02 Dec 2010 18:17:26 +0100
Hi!

Am 02.12.2010 09:17, schrieb Goswin von Brederlow:

> It would have been more helpfull for someone to sponsor the already
> fixed package on mentors.debian.net.

Ping me tomorrow.  I'll try to have a look at it.


Best regards,
  Alexander




Reply sent to Goswin von Brederlow <goswin-v-b@web.de>:
You have taken responsibility. (Fri, 03 Dec 2010 12:21:07 GMT) Full text and rfc822 format available.

Notification sent to Luc Castermans <luc@castermans.org>:
Bug acknowledged by developer. (Fri, 03 Dec 2010 12:21:07 GMT) Full text and rfc822 format available.

Message #79 received at 605218-close@bugs.debian.org (full text, mbox):

From: Goswin von Brederlow <goswin-v-b@web.de>
To: 605218-close@bugs.debian.org
Subject: Bug#605218: fixed in ia32-libs 20101129
Date: Fri, 03 Dec 2010 12:17:47 +0000
Source: ia32-libs
Source-Version: 20101129

We believe that the bug you reported is fixed in the latest version of
ia32-libs, which is due to be installed in the Debian FTP archive:

ia32-libs-dev_20101129_amd64.deb
  to main/i/ia32-libs/ia32-libs-dev_20101129_amd64.deb
ia32-libs_20101129.dsc
  to main/i/ia32-libs/ia32-libs_20101129.dsc
ia32-libs_20101129.tar.gz
  to main/i/ia32-libs/ia32-libs_20101129.tar.gz
ia32-libs_20101129_amd64.deb
  to main/i/ia32-libs/ia32-libs_20101129_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 605218@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Goswin von Brederlow <goswin-v-b@web.de> (supplier of updated ia32-libs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 29 Nov 2010 22:43:35 +0100
Source: ia32-libs
Binary: ia32-libs ia32-libs-dev
Architecture: source amd64
Version: 20101129
Distribution: unstable
Urgency: high
Maintainer: Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>
Changed-By: Goswin von Brederlow <goswin-v-b@web.de>
Description: 
 ia32-libs  - ia32 shared libraries for use on amd64 and ia64 systems
 ia32-libs-dev - ia32 development files for use on amd64 and ia64 systems
Closes: 605218
Changes: 
 ia32-libs (20101129) unstable; urgency=high
 .
   [ Goswin von Brederlow ]
   * Add Conflicts: ia32-libs-workaround-499043 to avoid file overwrite
     errors. (Closes: #605218)
 .
   * Packages updated
 .
   [ libxi (2:1.3-5) unstable; urgency=low ]
 .
   * Cherry-picked fixes from upstream:
     - man: fix types for XGetSelectedExtensionEvents
     - Initialize extension with the right number of events (obsoletes our
       quilt patch)
     - Don't unlock the Display twice
     - Fix usage of uninitialized value
     - Fix memory leak in XIGetSelectedEvents
     - Always unlock display correctly
     - man: improve readability of XAllowDeviceEvents
     - man: fix typo in XIQueryDevice doc (#598964)
     - Fix typo when converting raw events from the wire
     - man: XGetDeviceProperty(3) has no parameter 'pending'
 .
   [ sane-backends (1.0.21-7) unstable; urgency=low ]
 .
   * debian/patches/genesys_disable_raw_data_log.patch:
     + Added; disable raw data logging. Raw data logging was enabled
       upstream at some point before 1.0.21 most probably as an oversight
       when committing new code. When enabled, a raw.pnm file is left
       behind in the cwd when using the genesys backend (602995).
 .
   * debconf translations:
     + Properly install vi.po, mistakenly put in po/ instead of
       debian/po in 1.0.21-6.
 .
   [ sane-backends (1.0.21-6) unstable; urgency=low ]
 .
   * debian/patches/saned_exit_avahi_process.patch:
     + Added; exit Avahi process on error/loop termination.
   * debian/patches/xerox_mfp_new_ids.patch:
     + Added; add USB IDs for supported machines in xerox_mfp (#601748).
   * debian/patches/scsi_perfection_2450.patch:
     + Added; add SCSI IDs for the Perfection 2450 via FireWire
       (#601810).
   * debian/patches/scsi_scanjet_4c.patch:
     + Added; add SCSI IDs for the ScanJet 4c (#601656).
 .
   * debconf translations:
     + vi.po: courtesy of Clytie Siddall (#601530).
Checksums-Sha1: 
 8e5bbc132d3a2113c9eff94e8bbc9642ccbb4048 1875 ia32-libs_20101129.dsc
 3549549ef76d847d3f53d7e80bb9116ee64b4239 334017456 ia32-libs_20101129.tar.gz
 9349a353194819d519200d405e8f28de61c22f46 34217030 ia32-libs_20101129_amd64.deb
 39322e9e8fc480c08be8c90b1fb9c9fa6574176b 13076504 ia32-libs-dev_20101129_amd64.deb
Checksums-Sha256: 
 4fa14aaac5e749256a90f3045e225b64141216720dd495f1cbff57ec27037797 1875 ia32-libs_20101129.dsc
 dee9c1ef7db1382e665706f1df79f9718c6e343716a55d05e825978d25e87556 334017456 ia32-libs_20101129.tar.gz
 b5351d33dafb6361f211fd2f02c6b8948fa1fc78f13babe8d874f9a4e1a9fcfd 34217030 ia32-libs_20101129_amd64.deb
 d5a0f29c819654c859d3842e0d6ccc4483d87e69f5fe5e3943e20fea4ecd028b 13076504 ia32-libs-dev_20101129_amd64.deb
Files: 
 3f9ab83ae3e42be3b42829d998e26dde 1875 libs optional ia32-libs_20101129.dsc
 58f880994847b9e60dee4f3cf3403260 334017456 libs optional ia32-libs_20101129.tar.gz
 6b64d1d0fe4d71b8a9d56dcd82715a48 34217030 libs optional ia32-libs_20101129_amd64.deb
 c6fb327944a0eb74996192989390a65f 13076504 libdevel extra ia32-libs-dev_20101129_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJM+N0YAAoJEMJLZaJnLIsSgSgP/0xLo8FiljPDAvkPBP1WI0BM
KZmd6VoFY36rADtUsfH8jbjHegc62iu8GFHFJ+/Tz0rGume2wlQ8+CSFVlxGOOuU
gVeAqFM0RpN/RMEemvagml7YSoMuxTaUWswf27Xwb9/fJCC1tWU2d3vP1rlhvQ4u
owP8t3VI9DRmZobe6CgktU6xBWNZIvOW5boPAoPgHqgOHMtB/GKReW86L0hxsiMs
iSd8m5BtrFSD56N08gN50qaV2Yvf8cdADCisaBcPQXkCcomt+nd3z9Zxmnew0ngj
hqTD2TCPWMDMRaSubcOgLSrNxGpwAdTgv1RnM7aD9tOWLpLnldk/ZXWOMu6zncaG
EZC8qh4kJxMxCyYh42sXnwTVh3n6h12x0SpNfhOzLgIQucKLa4IkE4E6ClzUztgi
qtgrG9WRFePQUs30mQvHK91jzc4jDmJ8UB0InXlRKjm0ihsC9bvvLYtnSFJf+tHU
QSzd2u8a29HDsnsNDwZb7UwSoGzuvl4xPXk3QP0e5fCAijTU8itf75QmgehSYhM1
on7Uc1maL5xpGSpV2sBNiPbNUQjQrU0YxUFOKJKP7tTvVs1uk25SMJgAWrvRSMGA
TcT77fcPPP+pW65RS21Y/rFCmeuAHeuZaKs1Iz8rSLlLSB3QGxS6TwoRt4+cLBTg
QSEsXURLJaxt0D4IVqpN
=PkES
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Sun, 05 Dec 2010 14:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to David Martin <davidcmartin2000@yahoo.co.uk>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Sun, 05 Dec 2010 14:15:03 GMT) Full text and rfc822 format available.

Message #84 received at 605218@bugs.debian.org (full text, mbox):

From: David Martin <davidcmartin2000@yahoo.co.uk>
To: 605218@bugs.debian.org
Subject: Same problem: fresh installation
Date: Sun, 5 Dec 2010 14:11:16 +0000
[Message part 1 (text/plain, inline)]
I've just reinstalled Ubuntu 10.04 using the Wubi download and my first
action is to try to get the Epson SX215 scanner working. It never worked
in the previous installation because of an 'Error: Wrong architecture
'i386'' message.
I've now worked out I needed the ia32-libs_20101117_amd64.deb (I'm still an
Ubuntu novice) but that fails to install as reported here.  However, the
flash patch ia32-libs-workaround-499043 has not been installed (I've
checked by trying to purge it). I installed the ia32-libs but still no
joy.

David
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>:
Bug#605218; Package ia32-libs. (Tue, 07 Dec 2010 15:09:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Goswin von Brederlow <goswin-v-b@web.de>:
Extra info received and forwarded to list. Copy sent to Debian ia32-libs Team <pkg-ia32-libs-maintainers@lists.alioth.debian.org>. (Tue, 07 Dec 2010 15:09:13 GMT) Full text and rfc822 format available.

Message #89 received at 605218@bugs.debian.org (full text, mbox):

From: Goswin von Brederlow <goswin-v-b@web.de>
To: David Martin <davidcmartin2000@yahoo.co.uk>
Cc: 605218@bugs.debian.org
Subject: Re: [Pkg-ia32-libs-maintainers] Bug#605218: Same problem: fresh installation
Date: Tue, 07 Dec 2010 16:03:25 +0100
David Martin <davidcmartin2000@yahoo.co.uk> writes:

> I've just reinstalled Ubuntu 10.04 using the Wubi download and my first
> action is to try to get the Epson SX215 scanner working. It never worked
> in the previous installation because of an 'Error: Wrong architecture 'i386'' message.
> I've now worked out I needed the ia32-libs_20101117_amd64.deb (I'm still an
> Ubuntu novice) but that fails to install as reported here.  However, the
> flash patch ia32-libs-workaround-499043 has not been installed (I've
> checked by trying to purge it). I installed the ia32-libs but still no
> joy.
>
> David

Without showing the error I certainly can't help you. You should file
Ubuntu errors under Ubuntu first too.

MfG
        Goswin




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 15 Jan 2011 07:31:22 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 16:07:52 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.