Debian Bug report logs - #604798
missing dependency on python-gnome2

version graph

Package: python-gnomeapplet; Maintainer for python-gnomeapplet is Loic Minier <lool@dooz.org>;

Reported by: Stefano Zacchiroli <zack@debian.org>

Date: Wed, 24 Nov 2010 12:00:01 UTC

Severity: serious

Found in version gnome-python-desktop/2.30.0-3

Fixed in version gnome-python-desktop/2.30.0-4

Done: Josselin Mouette <joss@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#604798; Package python-gnomeapplet. (Wed, 24 Nov 2010 12:00:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Stefano Zacchiroli <zack@debian.org>:
New Bug report received and forwarded. Copy sent to Loic Minier <lool@dooz.org>. (Wed, 24 Nov 2010 12:00:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Stefano Zacchiroli <zack@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: missing dependency on python-gnome2
Date: Wed, 24 Nov 2010 12:56:25 +0100
Package: python-gnomeapplet
Version: 2.30.0-3
Severity: serious

python-gnomeapplet seems to be missing a dependecy on the package providing
Python module bonobo.ui. In a sid chroot updated today, installing
python-gnomeapplet (via apt-get) I get the following:

  >>> import gnomeapplet
  Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
  ImportError: No module named bonobo.ui
  >>> 

Installing python-gnome2 fixes the problem.

Cheers.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=it_IT.utf8, LC_CTYPE=it_IT.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages python-gnomeapplet depends on:
ii  libart-2.0-2            2.3.21-1         Library of functions for 2D graphi
ii  libatk1.0-0             1.30.0-1         The ATK accessibility toolkit
ii  libbonobo2-0            2.24.3-1         Bonobo CORBA interfaces library
ii  libbonoboui2-0          2.24.3-1         The Bonobo UI library
ii  libc6                   2.11.2-7         Embedded GNU C Library: Shared lib
ii  libcairo2               1.8.10-6         The Cairo 2D vector graphics libra
ii  libfontconfig1          2.8.0-2.1        generic font configuration library
ii  libfreetype6            2.4.2-2.1        FreeType 2 font engine, shared lib
ii  libgconf2-4             2.28.1-6         GNOME configuration database syste
ii  libglib2.0-0            2.24.2-1         The GLib library of C routines
ii  libgnome2-0             2.30.0-1         The GNOME library - runtime files
ii  libgnomecanvas2-0       2.30.1-1         A powerful object-oriented display
ii  libgnomeui-0            2.24.3-1         The GNOME libraries (User Interfac
ii  libgnomevfs2-0          1:2.24.3-1       GNOME Virtual File System (runtime
ii  libgtk2.0-0             2.20.1-2         The GTK+ graphical user interface 
ii  libice6                 2:1.0.7-1        X11 Inter-Client Exchange library
ii  liborbit2               1:2.14.18-0.1    libraries for ORBit2 - a CORBA ORB
ii  libpanel-applet2-0      2.30.2-2         library for GNOME Panel applets
ii  libpango1.0-0           1.28.3-1         Layout and rendering of internatio
ii  libpopt0                1.16-1           lib for parsing cmdline parameters
ii  libsm6                  2:1.2.0-1        X11 Session Management library
ii  python                  2.6.6-3+squeeze1 interactive high-level object-orie
ii  python-gtk2             2.17.0-4         Python bindings for the GTK+ widge
ii  python-pyorbit          2.24.0-6         A Python language binding for the 
ii  python-support          1.0.11           automated rebuilding support for P

python-gnomeapplet recommends no packages.

Versions of packages python-gnomeapplet suggests:
ii  gnome-panel                   2.30.2-2   launcher and docking facility for 

-- no debconf information




Added tag(s) pending. Request was from Gaudenz Steinlin <gaudenz@debian.org> to control@bugs.debian.org. (Sun, 28 Nov 2010 01:15:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Minier <lool@dooz.org>:
Bug#604798; Package python-gnomeapplet. (Sun, 28 Nov 2010 01:18:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gaudenz Steinlin <gaudenz@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Minier <lool@dooz.org>. (Sun, 28 Nov 2010 01:18:06 GMT) Full text and rfc822 format available.

Message #12 received at 604798@bugs.debian.org (full text, mbox):

From: Gaudenz Steinlin <gaudenz@debian.org>
To: 604798 <604798@bugs.debian.org>
Cc: control@bugs.debian.org
Subject: status update
Date: Sun, 28 Nov 2010 02:10:52 +0100
[Message part 1 (text/plain, inline)]
tags 604798 +pending
Thanks

I looked into this bug during the BSP in Bern and found out that a fix
is already in SVN. According to the following IRC discussion the gnome
team is taking care to do an upload soon:

13:39 <   gaudenz> Is there a reason why the fix for #604798 is only committed to SVN but not uploaded or the bug tagged pending?
13:39 <   gaudenz> Anyone against me doing an NMU?
13:40 <    mbiebl> Np237: did you want to squeeze in another fix for python-gnomeapplet?
[...]
17:51 <    mbiebl> pochu: wanna make the gnome-python-desktop upload?
17:51 <    mbiebl> seems you've been caring for that package in the past
17:52 <     pochu> I'm pretty sure Np237 will do it
17:52 <     pochu> Np237: if I'm wrong speak up :)
17:52 <     pochu> gaudenz: no need for an NMU, we'll upload it soon

Gaudenz
-- 
Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~
[signature.asc (application/pgp-signature, attachment)]

Reply sent to Josselin Mouette <joss@debian.org>:
You have taken responsibility. (Wed, 01 Dec 2010 17:51:05 GMT) Full text and rfc822 format available.

Notification sent to Stefano Zacchiroli <zack@debian.org>:
Bug acknowledged by developer. (Wed, 01 Dec 2010 17:51:05 GMT) Full text and rfc822 format available.

Message #17 received at 604798-close@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: 604798-close@bugs.debian.org
Subject: Bug#604798: fixed in gnome-python-desktop 2.30.0-4
Date: Wed, 01 Dec 2010 17:47:58 +0000
Source: gnome-python-desktop
Source-Version: 2.30.0-4

We believe that the bug you reported is fixed in the latest version of
gnome-python-desktop, which is due to be installed in the Debian FTP archive:

gnome-python-desktop_2.30.0-4.debian.tar.gz
  to main/g/gnome-python-desktop/gnome-python-desktop_2.30.0-4.debian.tar.gz
gnome-python-desktop_2.30.0-4.dsc
  to main/g/gnome-python-desktop/gnome-python-desktop_2.30.0-4.dsc
python-brasero_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-brasero_2.30.0-4_amd64.deb
python-bugbuddy_2.30.0-4_all.deb
  to main/g/gnome-python-desktop/python-bugbuddy_2.30.0-4_all.deb
python-evince_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-evince_2.30.0-4_amd64.deb
python-evolution_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-evolution_2.30.0-4_amd64.deb
python-gnome2-desktop-dev_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-gnome2-desktop-dev_2.30.0-4_amd64.deb
python-gnomeapplet_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-gnomeapplet_2.30.0-4_amd64.deb
python-gnomedesktop_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-gnomedesktop_2.30.0-4_amd64.deb
python-gnomekeyring_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-gnomekeyring_2.30.0-4_amd64.deb
python-gtop_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-gtop_2.30.0-4_amd64.deb
python-mediaprofiles_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-mediaprofiles_2.30.0-4_amd64.deb
python-metacity_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-metacity_2.30.0-4_amd64.deb
python-rsvg_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-rsvg_2.30.0-4_amd64.deb
python-totem-plparser_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-totem-plparser_2.30.0-4_amd64.deb
python-wnck_2.30.0-4_amd64.deb
  to main/g/gnome-python-desktop/python-wnck_2.30.0-4_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 604798@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Josselin Mouette <joss@debian.org> (supplier of updated gnome-python-desktop package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 01 Dec 2010 18:34:27 +0100
Source: gnome-python-desktop
Binary: python-gnome2-desktop-dev python-brasero python-bugbuddy python-evince python-evolution python-gnomeapplet python-gnomedesktop python-gnomekeyring python-gtop python-mediaprofiles python-metacity python-rsvg python-totem-plparser python-wnck
Architecture: source all amd64
Version: 2.30.0-4
Distribution: unstable
Urgency: low
Maintainer: Loic Minier <lool@dooz.org>
Changed-By: Josselin Mouette <joss@debian.org>
Description: 
 python-brasero - Python module for brasero
 python-bugbuddy - Python module for bug-buddy
 python-evince - Python bindings for the evince libraries
 python-evolution - Python bindings for the evolution libraries
 python-gnome2-desktop-dev - Python bindings for the GNOME desktop environment
 python-gnomeapplet - Python bindings for the GNOME panel applet library
 python-gnomedesktop - Python bindings for the GNOME desktop library
 python-gnomekeyring - Python bindings for the GNOME keyring library
 python-gtop - Python bindings for the Gtop library
 python-mediaprofiles - Python bindings for the GNOME media profiles library
 python-metacity - Python bindings for metacity
 python-rsvg - Python bindings for the RSVG library
 python-totem-plparser - Python bindings for the Totem playlist parser library
 python-wnck - Python bindings for the WNCK library
Closes: 604798
Changes: 
 gnome-python-desktop (2.30.0-4) unstable; urgency=low
 .
   * python-gnomeapplet: depend on python-gnome2. Closes: #604798.
Checksums-Sha1: 
 faae84f6acf044509e2250e3e6ff91820f6283ed 2240 gnome-python-desktop_2.30.0-4.dsc
 769b372c11ce1a34baa373aa5633fb8ab83c9be3 199221 gnome-python-desktop_2.30.0-4.debian.tar.gz
 85b51551ebb28600bf2611e2f022f0beb79b4013 36098 python-bugbuddy_2.30.0-4_all.deb
 2a7fb9fda1e1d7681aa81cbcd3265c4177918b56 69538 python-gnome2-desktop-dev_2.30.0-4_amd64.deb
 bbee300829cf455bb0862066b0045c0e30718ca0 113358 python-brasero_2.30.0-4_amd64.deb
 567daca0f9377cc7f16a5ec14a2f4259cdd63653 101646 python-evince_2.30.0-4_amd64.deb
 be69e94a6ede9f558b026e6499fb8b3fcc03739d 101946 python-evolution_2.30.0-4_amd64.deb
 049cd5e62d889c20022262d673279a9fe19acc5a 46148 python-gnomeapplet_2.30.0-4_amd64.deb
 d2cd66f76d8d1bda5bd82e9e4bf30d3b7bc9bfae 56824 python-gnomedesktop_2.30.0-4_amd64.deb
 9c49238c1c8559cab49455f7e84e006bdc175aef 69370 python-gnomekeyring_2.30.0-4_amd64.deb
 e9b54c7078f30d18050320e0b78a9a3e8eed4943 47930 python-gtop_2.30.0-4_amd64.deb
 a55ce49ff4e8919ca8a715c2b3107fa4ae21fc30 42354 python-mediaprofiles_2.30.0-4_amd64.deb
 1232ae22f39e174f999ada55c03eb471b211bb77 59008 python-metacity_2.30.0-4_amd64.deb
 df59e5be9e5d8960302dbd210660157fa6f4989d 41888 python-rsvg_2.30.0-4_amd64.deb
 0fc07aa847494f41d2ceceebf2d61702cf9ba657 44270 python-totem-plparser_2.30.0-4_amd64.deb
 1541c5f90d6d94791cb54ac91035b822531a1e44 75518 python-wnck_2.30.0-4_amd64.deb
Checksums-Sha256: 
 5eb46ea290074b07835f0b3471ef8e1a6e508a052c8ea1e5862a51e72499a1d3 2240 gnome-python-desktop_2.30.0-4.dsc
 a9beaa40bb5252560ea9cf5bcb95422be2867c9f2a856f15fe4a42c8068db8e3 199221 gnome-python-desktop_2.30.0-4.debian.tar.gz
 d78eb1687b3434df92b2abde09293bd4f9d39def407c5e8deb31d65e4d0f6ff7 36098 python-bugbuddy_2.30.0-4_all.deb
 115ec8ad146d45e4c985294d54925a6d7d7339ec85c6caa7d628a3a0c006555f 69538 python-gnome2-desktop-dev_2.30.0-4_amd64.deb
 319d5f4eea4dc1eda4f6af73eeddcfe46e3d2286b5a8c40c8c2dde31dff4f1ea 113358 python-brasero_2.30.0-4_amd64.deb
 932854116179ee9407ea137ac39ae750b1b6246b0f394d6f2b75c5169c196308 101646 python-evince_2.30.0-4_amd64.deb
 5a3ec214de28d19529c2ab6bd8c60bb7aa9e1cc8d572fdf04cf9225fa68ae78f 101946 python-evolution_2.30.0-4_amd64.deb
 c4263acc8c77d6900ba8f1b8ae23b7a39976516f2297964c4d1037963a1bbd71 46148 python-gnomeapplet_2.30.0-4_amd64.deb
 dc6ffc7e7612718b0f5fc374debef0a7b55f73af1b05f883c468660621f0cae3 56824 python-gnomedesktop_2.30.0-4_amd64.deb
 5c287831d2be2f3e741936216db6b6d3ba01f908ed1bd2555bbeef45015114c3 69370 python-gnomekeyring_2.30.0-4_amd64.deb
 2804ebb9d55d8b46ee762f72b1d884ebe2fe6d15aa1ad0ebc6ce87806c24d8d2 47930 python-gtop_2.30.0-4_amd64.deb
 58ca21fc511f6356c68103f963768c466074eabd9730c3fc590ccc10ca8a4f30 42354 python-mediaprofiles_2.30.0-4_amd64.deb
 9e44d1a19e0f5879e03a98a48262331ea0d64b9a10487c92ce22ac3d885e633e 59008 python-metacity_2.30.0-4_amd64.deb
 2b5b1a21ae0b112cb0ca8e412cab6dd6603c591113961948ac66bf8c410b5b45 41888 python-rsvg_2.30.0-4_amd64.deb
 6768196e4d425cd57c3db671ffcbada073077843a911a280ddeb449a6a83b152 44270 python-totem-plparser_2.30.0-4_amd64.deb
 513b92c25794dfa2ae0b2b5d95dc30b297068cc79e1c5c9e08d910e5e09ad6c5 75518 python-wnck_2.30.0-4_amd64.deb
Files: 
 7e2f539b2a8660ee53bf55d1b8b3d58e 2240 python optional gnome-python-desktop_2.30.0-4.dsc
 8421845af353eed35d8b7c642517357b 199221 python optional gnome-python-desktop_2.30.0-4.debian.tar.gz
 dbba7738bfe44d1acc4a38b019461fbc 36098 python optional python-bugbuddy_2.30.0-4_all.deb
 4302d35378eda3616e20fa75e5bd2a4b 69538 python optional python-gnome2-desktop-dev_2.30.0-4_amd64.deb
 7ab49f0be5d20ea147acd56f93575b1c 113358 python optional python-brasero_2.30.0-4_amd64.deb
 d40cd87154e06a653e1b65798d05f7d5 101646 python optional python-evince_2.30.0-4_amd64.deb
 fd4d550ff6c63544c9d36b9a8d56910e 101946 python optional python-evolution_2.30.0-4_amd64.deb
 89e0d46b638fb173fe72a1f67c89774f 46148 python optional python-gnomeapplet_2.30.0-4_amd64.deb
 e112f235c0f97218b6934618f7736db6 56824 python optional python-gnomedesktop_2.30.0-4_amd64.deb
 962d6a2bbe66776b884b0f872d9b9891 69370 python optional python-gnomekeyring_2.30.0-4_amd64.deb
 15aaa0cd326b16f42976fde6d6509ffe 47930 python optional python-gtop_2.30.0-4_amd64.deb
 1a96109c76b523da0203377a6004d98e 42354 python optional python-mediaprofiles_2.30.0-4_amd64.deb
 a4f7741ca7025edf4fb6b2a3fb5a6d57 59008 python optional python-metacity_2.30.0-4_amd64.deb
 05dd64d3962010b440349c628d8b69ad 41888 python optional python-rsvg_2.30.0-4_amd64.deb
 31021f19c003b04dcb696fcd9f5274b7 44270 python optional python-totem-plparser_2.30.0-4_amd64.deb
 36d5efb9b39bbf57c278c3e5598d9b43 75518 python optional python-wnck_2.30.0-4_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iD8DBQFM9ogwrSla4ddfhTMRAtTHAJsE0qaWeJ2LQIR6vOjpkw6wxNjltwCfdhW9
jhN6NsGcBqI8eXCZYE0MhDo=
=M7pX
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 09 Jan 2011 07:35:06 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 12:38:57 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.