Debian Bug report logs - #601901
gnome-applets: On kfreebsd, cpufreq-applet not included but still listed in "Add to Panel".

version graph

Package: gnome-applets; Maintainer for gnome-applets is Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>; Source for gnome-applets is src:gnome-applets.

Reported by: Michael Dorrington <michael.dorrington@gmail.com>

Date: Sat, 30 Oct 2010 21:03:02 UTC

Severity: normal

Found in version gnome-applets/2.30.0-3

Fixed in versions gnome-applets/2.91.4~20110321-1, gnome-applets/2.30.0-4

Done: Michael Biebl <biebl@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, debian-bsd@lists.debian.org, gpastore@debian.org (Guilherme de S. Pastore):
Bug#601901; Package gnome-applets. (Sat, 30 Oct 2010 21:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Dorrington <michael.dorrington@gmail.com>:
New Bug report received and forwarded. Copy sent to debian-bsd@lists.debian.org, gpastore@debian.org (Guilherme de S. Pastore). (Sat, 30 Oct 2010 21:03:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michael Dorrington <michael.dorrington@gmail.com>
To: submit@bugs.debian.org
Subject: gnome-applets: On kfreebsd, cpufreq-applet not included but still listed in "Add to Panel".
Date: Sat, 30 Oct 2010 21:59:10 +0100
[Message part 1 (text/plain, inline)]
Package: gnome-applets
Version: 2.30.0-3
Severity: normal
User: debian-bsd@lists.debian.org
Usertags: kfreebsd
X-Debbugs-CC: debian-bsd@lists.debian.org

On kfreebsd, in "Add to Panel" window the following applet is listed:

CPU Frequency Scaling Monitor
Monitor the CPU Frequency Scaling

On an attempt to add this applet a pop up is displayed saying:

   / \   The panel encountered a problem while 
  / ! \  loading "OAFIID:GNOME_CPUFreqApplet".

         Do you want to delete the applet from your configuration?

                                         [Don't Delete]   [Delete]

$ head /usr/lib/bonobo/servers/GNOME_CPUFreqApplet.server
<?xml version="1.0"?>
<oaf_info>

<oaf_server iid="OAFIID:GNOME_CPUFreqApplet_Factory"
	    type="exe"
	    location="/usr/lib/gnome-applets/cpufreq-applet">

	<oaf_attribute name="repo_ids" type="stringv">
		<item value="IDL:Bonobo/GenericFactory:1.0"/>
		<item value="IDL:Bonobo/Unknown:1.0"/>

$ ls /usr/lib/gnome-applets/cpufreq-applet
ls: cannot access /usr/lib/gnome-applets/cpufreq-applet: No such file or directory
$ ls /usr/lib/gnome-applets/
accessx-status-applet  geyes_applet2      modem_applet        trashapplet
battstat-applet-2      gweather-applet-2  multiload-applet-2
charpick_applet2       invest-applet      null_applet
drivemount_applet2     mixer_applet2      stickynotes_applet

http://packages.debian.org/squeeze/kfreebsd-i386/gnome-applets/filelist
http://packages.debian.org/squeeze/i386/gnome-applets/filelist

Regards,
Mike.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: kfreebsd-i386 (i686)

Kernel: kFreeBSD 8.1-1-686
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-applets depends on:
ii  gconf2                  2.28.1-5         GNOME configuration database syste
ii  gnome-applets-data      2.30.0-3         Various applets for the GNOME pane
ii  gnome-icon-theme        2.30.3-1         GNOME Desktop icon theme
ii  gnome-panel             2.30.2-2         launcher and docking facility for 
ii  gstreamer0.10-plugins-g 0.10.24-1        GStreamer plugins from the "good" 
ii  gvfs                    1.6.4-2          userspace virtual filesystem - ser
ii  libatk1.0-0             1.30.0-1         The ATK accessibility toolkit
ii  libbonobo2-0            2.24.3-1         Bonobo CORBA interfaces library
ii  libbonoboui2-0          2.24.3-1         The Bonobo UI library
ii  libc0.1                 2.11.2-6         Embedded GNU C Library: Shared lib
ii  libgconf2-4             2.28.1-5         GNOME configuration database syste
ii  libglib2.0-0            2.24.2-1         The GLib library of C routines
ii  libgnome-desktop-2-17   2.30.2-1         Utility library for loading .deskt
ii  libgnome2-0             2.30.0-1         The GNOME library - runtime files
ii  libgstreamer-plugins-ba 0.10.30-1        GStreamer libraries from the "base
ii  libgstreamer0.10-0      0.10.30-1        Core GStreamer libraries and eleme
ii  libgtk2.0-0             2.20.1-2         The GTK+ graphical user interface 
ii  libgtop2-7              2.28.1-1         gtop system monitoring library (sh
ii  libgucharmap7           1:2.30.3-1       Unicode browser widget library (sh
ii  libgweather1            2.30.2-1         GWeather shared library
ii  libnotify1 [libnotify1- 0.5.0-2          sends desktop notifications to a n
ii  liboobs-1-4             2.30.1-1         GObject based interface to system-
ii  libpanel-applet2-0      2.30.2-2         library for GNOME Panel applets
ii  libpango1.0-0           1.28.3-1         Layout and rendering of internatio
ii  libupower-glib1         0.9.5-3          abstraction for power management -
ii  libwnck22               2.30.4-2         Window Navigator Construction Kit 
ii  libx11-6                2:1.3.3-3        X11 client-side library
ii  libxml2                 2.7.7.dfsg-4     GNOME XML library
ii  python                  2.6.6-3+squeeze1 interactive high-level object-orie

Versions of packages gnome-applets recommends:
ii  cpufrequtils          007-1              utilities to deal with the cpufreq
ii  deskbar-applet        2.32.0-1           universal search and navigation ba
ii  gnome-media           2.30.0-1           GNOME media utilities
ii  gnome-netstatus-apple 2.28.1-1           Network status applet for GNOME
ii  gnome-system-monitor  2.28.1-1           Process viewer and system resource
ii  policykit-1-gnome     0.96-2             GNOME authentication agent for Pol
ii  python-gconf          2.28.1-1           Python bindings for the GConf conf
ii  python-gnome2         2.28.1-1           Python bindings for the GNOME desk
ii  python-gnomeapplet    2.30.0-3           Python bindings for the GNOME pane
ii  python-gobject        2.21.4+is.2.21.3-1 Python bindings for the GObject li
ii  python-gtk2           2.17.0-4           Python bindings for the GTK+ widge

Versions of packages gnome-applets suggests:
ii  tomboy                        1.2.1-1    desktop note taking program using 

-- no debconf information


[signature.asc (application/pgp-signature, attachment)]

Reply sent to Josselin Mouette <joss@debian.org>:
You have taken responsibility. (Tue, 22 Mar 2011 12:21:05 GMT) Full text and rfc822 format available.

Notification sent to Michael Dorrington <michael.dorrington@gmail.com>:
Bug acknowledged by developer. (Tue, 22 Mar 2011 12:21:06 GMT) Full text and rfc822 format available.

Message #10 received at 601901-close@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: 601901-close@bugs.debian.org
Subject: Bug#601901: fixed in gnome-applets 2.91.4~20110321-1
Date: Tue, 22 Mar 2011 12:17:10 +0000
Source: gnome-applets
Source-Version: 2.91.4~20110321-1

We believe that the bug you reported is fixed in the latest version of
gnome-applets, which is due to be installed in the Debian FTP archive:

gnome-applets-data_2.91.4~20110321-1_all.deb
  to main/g/gnome-applets/gnome-applets-data_2.91.4~20110321-1_all.deb
gnome-applets-dbg_2.91.4~20110321-1_amd64.deb
  to main/g/gnome-applets/gnome-applets-dbg_2.91.4~20110321-1_amd64.deb
gnome-applets_2.91.4~20110321-1.debian.tar.gz
  to main/g/gnome-applets/gnome-applets_2.91.4~20110321-1.debian.tar.gz
gnome-applets_2.91.4~20110321-1.dsc
  to main/g/gnome-applets/gnome-applets_2.91.4~20110321-1.dsc
gnome-applets_2.91.4~20110321-1_amd64.deb
  to main/g/gnome-applets/gnome-applets_2.91.4~20110321-1_amd64.deb
gnome-applets_2.91.4~20110321.orig.tar.gz
  to main/g/gnome-applets/gnome-applets_2.91.4~20110321.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 601901@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Josselin Mouette <joss@debian.org> (supplier of updated gnome-applets package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 21 Mar 2011 22:32:13 +0100
Source: gnome-applets
Binary: gnome-applets-data gnome-applets gnome-applets-dbg
Architecture: source all amd64
Version: 2.91.4~20110321-1
Distribution: experimental
Urgency: low
Maintainer: Guilherme de S. Pastore <gpastore@debian.org>
Changed-By: Josselin Mouette <joss@debian.org>
Description: 
 gnome-applets - Various applets for the GNOME panel - binary files
 gnome-applets-data - Various applets for the GNOME panel - data files
 gnome-applets-dbg - Various applets for the GNOME panel - binary files with debugging
Closes: 601901
Changes: 
 gnome-applets (2.91.4~20110321-1) experimental; urgency=low
 .
   * Move .server files in the binary package, since the list is
     architecture-dependent. Closes: #601901.
   * Add appropriate Replaces.
   * New upstream git snapshot compatible with gnome-panel 2.91.
   * Require more recent panel.
   * Drop all Python stuff, disable Invest applet.
   * 01_battstat_upower.patch:
     + Small fixes for GTK+ 3.
     + Fix a very important bug in error handling.
   * 09_modemlights_use_new_gst.patch, 10_network-manager.patch: dropped.
     They needs porting and modemlights is disabled anyway.
   * Disable 98_autoreconf.patch and 99_ltmain_as-needed.patch. Use
     dh-autoreconf instead.
   * 02_link_X11.patch: new patch. Correctly link applets to libX11.
   * 03_mixer_gtk3.patch: new patch. Port the mixer applet to GTK+ 3.
Checksums-Sha1: 
 8d22366663a7ef6bd17fc9006ccebe2cea5d3372 2299 gnome-applets_2.91.4~20110321-1.dsc
 3ed5cb69587d9d413119cbdfaf2200b55f23cea1 12717714 gnome-applets_2.91.4~20110321.orig.tar.gz
 44a481220b509855bdf54794250e3c1a9d62e470 31925 gnome-applets_2.91.4~20110321-1.debian.tar.gz
 acee42fee4962a66c219796d36c893be282f6c4b 9927578 gnome-applets-data_2.91.4~20110321-1_all.deb
 fead3970008229036ff3a451db22a310aa28145c 308404 gnome-applets_2.91.4~20110321-1_amd64.deb
 9578614f995fbe4254588c3096d99aaf42e4692c 610498 gnome-applets-dbg_2.91.4~20110321-1_amd64.deb
Checksums-Sha256: 
 445aca7c1e4e738d0524f52f3be0dfacc93cd1ad021ed36ebbe8b280258e4f91 2299 gnome-applets_2.91.4~20110321-1.dsc
 3790123228af7e2b51d5dea1fb8e8bdd73615cdc9428d00b931302dfdabd3903 12717714 gnome-applets_2.91.4~20110321.orig.tar.gz
 f5da0ac829067ee75ee0ad2bac401191c35ce95b66b8eaf82d13fcadaabbbc32 31925 gnome-applets_2.91.4~20110321-1.debian.tar.gz
 ab7a1d2848c65d9d973f9a007babe6ba6eb339374a46cf9f110b9c7d87658d34 9927578 gnome-applets-data_2.91.4~20110321-1_all.deb
 d43a34de5daded19229148d231d87f9a63091b56f8e20108fe207479b00bf3f4 308404 gnome-applets_2.91.4~20110321-1_amd64.deb
 630ceb1ffcb548c018886e0944c2a9d2d727c6b6fd2c9e8a30cdacef8bab2d7c 610498 gnome-applets-dbg_2.91.4~20110321-1_amd64.deb
Files: 
 aec36dc011d39ad09bf471b8c77dab68 2299 gnome optional gnome-applets_2.91.4~20110321-1.dsc
 f40a46916a01a485b00dad9b6323eea2 12717714 gnome optional gnome-applets_2.91.4~20110321.orig.tar.gz
 8104bb87617fabfbe879679fdf03db95 31925 gnome optional gnome-applets_2.91.4~20110321-1.debian.tar.gz
 a70dc67cc064450885d7ad5b0f7703c0 9927578 gnome optional gnome-applets-data_2.91.4~20110321-1_all.deb
 e9dc7f4bb02b27230fba4decb7ffa406 308404 gnome optional gnome-applets_2.91.4~20110321-1_amd64.deb
 662523ac8e35afeefdddf4624a869ca8 610498 debug extra gnome-applets-dbg_2.91.4~20110321-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFNh8fvrSla4ddfhTMRAofYAKCcI27JDBZU8sYABFIaQraND1rJbgCcD9M4
vJSHiQezvnp2nSmLUXvJ5RE=
=7uIz
-----END PGP SIGNATURE-----





Reply sent to Michael Biebl <biebl@debian.org>:
You have taken responsibility. (Mon, 01 Aug 2011 14:51:10 GMT) Full text and rfc822 format available.

Notification sent to Michael Dorrington <michael.dorrington@gmail.com>:
Bug acknowledged by developer. (Mon, 01 Aug 2011 14:51:10 GMT) Full text and rfc822 format available.

Message #15 received at 601901-close@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: 601901-close@bugs.debian.org
Subject: Bug#601901: fixed in gnome-applets 2.30.0-4
Date: Mon, 01 Aug 2011 14:48:06 +0000
Source: gnome-applets
Source-Version: 2.30.0-4

We believe that the bug you reported is fixed in the latest version of
gnome-applets, which is due to be installed in the Debian FTP archive:

gnome-applets-data_2.30.0-4_all.deb
  to main/g/gnome-applets/gnome-applets-data_2.30.0-4_all.deb
gnome-applets-dbg_2.30.0-4_i386.deb
  to main/g/gnome-applets/gnome-applets-dbg_2.30.0-4_i386.deb
gnome-applets_2.30.0-4.debian.tar.gz
  to main/g/gnome-applets/gnome-applets_2.30.0-4.debian.tar.gz
gnome-applets_2.30.0-4.dsc
  to main/g/gnome-applets/gnome-applets_2.30.0-4.dsc
gnome-applets_2.30.0-4_i386.deb
  to main/g/gnome-applets/gnome-applets_2.30.0-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 601901@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Biebl <biebl@debian.org> (supplier of updated gnome-applets package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 01 Aug 2011 00:57:19 +0200
Source: gnome-applets
Binary: gnome-applets-data gnome-applets gnome-applets-dbg
Architecture: source all i386
Version: 2.30.0-4
Distribution: unstable
Urgency: low
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Changed-By: Michael Biebl <biebl@debian.org>
Description: 
 gnome-applets - Various applets for the GNOME panel - binary files
 gnome-applets-data - Various applets for the GNOME panel - data files
 gnome-applets-dbg - Various applets for the GNOME panel - binary files with debugging
Closes: 554646 601901
Changes: 
 gnome-applets (2.30.0-4) unstable; urgency=low
 .
   [ Josselin Mouette ]
   * Move .server files in the binary package, since the list is
     architecture-dependent. Closes: #601901.
   * Add appropriate Replaces.
 .
   [ Michael Biebl ]
   * debian/watch: Track .bz2 tarballs.
   * debian/control.in:
     - Remove old Conflicts/Replaces for trashapplet.
     - Add Breaks in addition to Replaces for the moved .server files.
     - Bump Standards-Version to 3.9.2. No further changes.
     - Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
   * Bump debhelper compatibility level to 8.
     - Update Build-Depends on debhelper.
     - Strip debian/tmp/ from .install files.
   * Switch to dh_python2:
     - Drop Build-Depends on python-support.
     - Bump Build-Depends on python-dev to (>= 2.6.6-3~) and cdbs to
       (>= 0.4.90~)
     - Replace dh_pysupport with dh_python2 in debian/rules.
     - Remove debian/pyversions.
   * Use dh-autoreconf to update the build-system:
     - Add Build-Depends on dh-autoreconf.
     - Add autoreconf.mk include to debian/rules.
     - Remove debian/patches/98_autoreconf.patch.
   * debian/patches/16_link_dbus-glib.patch
     - Link gweather and cpufreq applet against dbus-glib. Closes: #554646
   * debian/patches/17_libnotify_0.7.patch
     - Update gweather and battstat applet for the API changes in libnotify
       0.7. Bump the Build-Depends on libnotify-dev accordingly.
Checksums-Sha1: 
 42a879004c8aeed0fea6cf9765e07ea81fc02f0a 3040 gnome-applets_2.30.0-4.dsc
 390da95887d8a982fef8e46fa1cffa5e3afe20cd 38351 gnome-applets_2.30.0-4.debian.tar.gz
 ad14fc3836a0158ff7e621857b1ce2dd0bd3d09d 9838940 gnome-applets-data_2.30.0-4_all.deb
 1c6cf7cb039714f7bef747dd2a259436379bb328 413982 gnome-applets_2.30.0-4_i386.deb
 fc67a03ec7b6512ef0becb5c21b164aa4135ee24 722778 gnome-applets-dbg_2.30.0-4_i386.deb
Checksums-Sha256: 
 14ea49b0f99a9c02331a012e1d816669c406266a7ccc6c30e0bcfd0fb4d5182f 3040 gnome-applets_2.30.0-4.dsc
 2505e40ee723e60508501a1e8eb78fab12a8d1f0c8c68de4890319e7f6298071 38351 gnome-applets_2.30.0-4.debian.tar.gz
 de4d6bc23aebe4431f011a51c9a4058665f750ce8c302dc484eaaf885063ab9d 9838940 gnome-applets-data_2.30.0-4_all.deb
 927dcd60dd4e9edea3426d6ac860a12b7cc2f1f2851bbf0bb698da87e054939e 413982 gnome-applets_2.30.0-4_i386.deb
 5e6f5b2f2a55f65da1f42c2e6520607820d66bcc7a1fbc268943e1efed1d5888 722778 gnome-applets-dbg_2.30.0-4_i386.deb
Files: 
 8ccf161f82a93d6ada0b2e4f493b4041 3040 gnome optional gnome-applets_2.30.0-4.dsc
 b8842e4bf0e9cde01bce034182139e3a 38351 gnome optional gnome-applets_2.30.0-4.debian.tar.gz
 f4a6d0d8de09a8da3c4ea6503ca6cb3a 9838940 gnome optional gnome-applets-data_2.30.0-4_all.deb
 d5bac47eca7b03b667eb144897fa1e1c 413982 gnome optional gnome-applets_2.30.0-4_i386.deb
 d162eed3a8d6fa8a3b5169fda6943080 722778 debug extra gnome-applets-dbg_2.30.0-4_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCAAGBQJONeqSAAoJEGrh3w1gjyLc8EkP/iHg9bD4zDYCL+8I9k0xz5FP
4tDo9Xp1X+cWUWeChWsXzCxzSdMQXO26UQGs9hn0hUXyUIymb7vneJyWsQxQjzsd
r9seLvnPIt3JI7w/p2E4BflsZBlVf5HMNbbcYxVBbMdT1Li8e8IBQCDYj5k5j1hS
km4xI0TEoYC0BqgpphVsaEQNoTAoQEUbeFjnqY0PZu3DdlRU0Oc1v0+55DXQfSv/
XOqchHstVBxyFsYBaZLWBioL8nDbMR/Q7jA9Q4WRDqvv8wRE59Q25LlFX4N/mJnH
PlUtot9pP41QyosR0K4XZ1jwOWd5Ss0RNRHjPaXOKOkfQz7MTbY20Vo/h7C3oZi9
n3UJybNpjRe6C4FXYnTKBioaEA/6IMnIkXMKAJ/DIkNMdyQZsbEMj5hepuuVTfbA
yJdzlVXNfQ/ezLVXQS13iwG8shhoR1T69/FBypiM31f6sb8Rke7gVIaWNTia80f2
ZmnhkUHe1nFj7D1LfW2YIP11BFNV1SKGVarDWbHQy3c/i2dxNA4P7f/fEvxSBxgw
euDN8iDipVeGk4DNhYTGT/gKUxd9GJHMp2NSO0z7MWSx956AdfiFchHdwenVxVRw
jr1pwK31YMw/QaSJC2zVqO5RuQhGsbJUYviTF2+1gW65xzu8uCEp97Cdp8G3hjYA
LxDCMHd+PLNWA9PIoISz
=3O4y
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 13 Sep 2011 07:31:01 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 23:01:57 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.