Debian Bug report logs - #600206
libcompass-ruby: compass apparently completely broken

version graph

Package: libcompass-ruby; Maintainer for libcompass-ruby is (unknown);

Reported by: Jonas Smedegaard <dr@jones.dk>

Date: Thu, 14 Oct 2010 16:48:01 UTC

Severity: grave

Found in version libcompass-ruby/0.10.2debian-2

Fixed in version libcompass-ruby/0.10.6~dfsg-1

Done: Jonas Smedegaard <dr@jones.dk>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Thu, 14 Oct 2010 16:48:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonas Smedegaard <dr@jones.dk>:
New Bug report received and forwarded. Copy sent to Micah Anderson <micah@debian.org>. (Thu, 14 Oct 2010 16:48:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jonas Smedegaard <dr@jones.dk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libcompass-ruby: compass apparently completely broken
Date: Thu, 14 Oct 2010 18:46:38 +0200
Package: libcompass-ruby
Version: 0.10.2debian-2
Severity: grave
Justification: renders package unusable

Hi,

Trying out compass today, I realized that it aparently is completely unusable
out-of-the-box :-(

It cannot even list its own provided frameworks:

jonas@auryn:sass (master)$ compass --list-frameworks
/usr/lib/ruby/1.8/compass/frameworks.rb:53:in `initialize': No such file or directory - /usr/share/compass/frameworks/frameworks (Errno::ENOENT)
	from /usr/lib/ruby/1.8/compass/frameworks.rb:53:in `new'
	from /usr/lib/ruby/1.8/compass/frameworks.rb:53:in `discover'
	from /usr/lib/ruby/1.8/compass/frameworks.rb:124
	from /usr/lib/ruby/1.8/compass.rb:19:in `require'
	from /usr/lib/ruby/1.8/compass.rb:19
	from /usr/lib/ruby/1.8/compass.rb:18:in `each'
	from /usr/lib/ruby/1.8/compass.rb:18
	from /usr/bin/compass:20:in `require'
	from /usr/bin/compass:20
	from /usr/bin/compass:8:in `fallback_load_path'
	from /usr/bin/compass:19


Adding a symlink from /usr/share/compass/frameworks/frameworks to
/usr/share/compass/frameworks makes above command work - and others too.

I suspect the build routines sets the install path wrongly.


Kind regards,

 - Jonas

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36-rc6-amd64 (SMP w/2 CPU cores)
Locale: LANG=da_DK.UTF-8, LC_CTYPE=da_DK.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libcompass-ruby depends on:
ii  libcompass-ruby1.8        0.10.2debian-2 Compass is a SASS-based stylesheet
ii  libfssm-ruby              0.1.4-2        keeps track via inotify the state 
ii  libhaml-ruby              3.0.15-1       Elegant, easy and powerful templat

libcompass-ruby recommends no packages.

libcompass-ruby suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Fri, 15 Oct 2010 07:06:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to deepak@debian.org:
Extra info received and forwarded to list. Copy sent to Micah Anderson <micah@debian.org>. (Fri, 15 Oct 2010 07:06:05 GMT) Full text and rfc822 format available.

Message #10 received at 600206@bugs.debian.org (full text, mbox):

From: Deepak Tripathi <deepak@debian.org>
To: 600206@bugs.debian.org
Subject: libcompass-ruby: compass apparently completely broken
Date: Fri, 15 Oct 2010 12:33:28 +0530
[Message part 1 (text/plain, inline)]
Hi,

I will have a look and let you know.



Thanks
Deepak Tripathi
Debian Developer.
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Sat, 13 Nov 2010 19:39:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Steve McIntyre <steve@einval.com>:
Extra info received and forwarded to list. Copy sent to Micah Anderson <micah@debian.org>. (Sat, 13 Nov 2010 19:39:06 GMT) Full text and rfc822 format available.

Message #15 received at 600206@bugs.debian.org (full text, mbox):

From: Steve McIntyre <steve@einval.com>
To: deepak@debian.org, 600206@bugs.debian.org
Subject: Re: Bug#600206: libcompass-ruby: compass apparently completely broken
Date: Sat, 13 Nov 2010 19:37:24 +0000
On Fri, Oct 15, 2010 at 12:33:28PM +0530, Deepak Tripathi wrote:
>Hi,
>
>I will have a look and let you know.

Hi Deepak,

Anything to report?

Cheers,
-- 
Steve McIntyre, Cambridge, UK.                                steve@einval.com
"This dress doesn't reverse." -- Alden Spiess





Information forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Sat, 13 Nov 2010 19:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Enrico Zini <enrico@enricozini.org>:
Extra info received and forwarded to list. Copy sent to Micah Anderson <micah@debian.org>. (Sat, 13 Nov 2010 19:57:02 GMT) Full text and rfc822 format available.

Message #20 received at 600206@bugs.debian.org (full text, mbox):

From: Enrico Zini <enrico@enricozini.org>
To: Steve McIntyre <steve@einval.com>, 600206@bugs.debian.org
Cc: deepak@debian.org
Subject: Re: Bug#600206: libcompass-ruby: compass apparently completely broken
Date: Sat, 13 Nov 2010 19:55:13 +0000
[Message part 1 (text/plain, inline)]
On Sat, Nov 13, 2010 at 07:37:24PM +0000, Steve McIntyre wrote:

> >I will have a look and let you know.
> Hi Deepak,
> Anything to report?

Or actually, popcon of libcompass-ruby is very low and it seems to have
no reverse dependencies: would it be worth removing it from testing and
then looking at this in comfort in unstable?


Ciao,

Enrico

-- 
GPG key: 4096R/E7AD5568 2009-05-08 Enrico Zini <enrico@enricozini.org>
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Tue, 16 Nov 2010 09:51:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to deepak@debian.org:
Extra info received and forwarded to list. Copy sent to Micah Anderson <micah@debian.org>. (Tue, 16 Nov 2010 09:51:10 GMT) Full text and rfc822 format available.

Message #25 received at 600206@bugs.debian.org (full text, mbox):

From: Deepak Tripathi <deepak@debian.org>
To: Enrico Zini <enrico@enricozini.org>
Cc: Steve McIntyre <steve@einval.com>, 600206@bugs.debian.org, micah@debian.org
Subject: Re: Bug#600206: libcompass-ruby: compass apparently completely broken
Date: Tue, 16 Nov 2010 15:18:56 +0530
[Message part 1 (text/plain, inline)]
Hi Steve,

Sorry for delay; i was on vacation to India (Raj).

Yes actually popcon is very low for libcompass-ruby but i will still discuss
with Micah Anderson <micah@debian.org> who is the primary maintainer for
this module and will update about his thought to the bug reports asap.

Sorry for delay.


--
dk




On Sun, Nov 14, 2010 at 1:25 AM, Enrico Zini <enrico@enricozini.org> wrote:

> On Sat, Nov 13, 2010 at 07:37:24PM +0000, Steve McIntyre wrote:
>
> > >I will have a look and let you know.
> > Hi Deepak,
> > Anything to report?
>
> Or actually, popcon of libcompass-ruby is very low and it seems to have
> no reverse dependencies: would it be worth removing it from testing and
> then looking at this in comfort in unstable?
>
>
> Ciao,
>
> Enrico
>
> --
> GPG key: 4096R/E7AD5568 2009-05-08 Enrico Zini <enrico@enricozini.org>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iQEcBAEBCAAGBQJM3u0hAAoJEON4Oc9CHQta35sH/1HtzFw05JjNcpBEkks+jeHQ
> 9lDDNNlMMr6Pgx0wYfG+Gp8anChjXCzxwmSPVzgFV7eAiZiMqNgZ4zA6rylEGrbo
> H8/U6I2WFFh+tT0EscyuT/Z0t5VdyBlUTopVX6KvPYY0jCI38R62geOyxqO5v9y9
> 9snpxNn9qskS1MsDL7UPiwX+B0M1rHUpYUeYqNwQWNAey17l+y4oQoR5wphTr4M3
> Pu1FLIU4c933kFVpzwN/tmwKJD504w0Mom/YppL5z07Pm3TGwFE6Fdft+fMVTw8t
> 7LTRp0KPVVSTwVFLqaLJDVNsWy2lnyYvhhrr01ryp8wCuxD94iGb0vYjlNKoigI=
> =NxMi
> -----END PGP SIGNATURE-----
>
>
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Micah Anderson <micah@debian.org>:
Bug#600206; Package libcompass-ruby. (Tue, 16 Nov 2010 20:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to micah anderson <micah@debian.org>:
Extra info received and forwarded to list. Copy sent to Micah Anderson <micah@debian.org>. (Tue, 16 Nov 2010 20:27:03 GMT) Full text and rfc822 format available.

Message #30 received at 600206@bugs.debian.org (full text, mbox):

From: micah anderson <micah@debian.org>
To: deepak@debian.org, Enrico Zini <enrico@enricozini.org>
Cc: Steve McIntyre <steve@einval.com>, 600206@bugs.debian.org
Subject: Re: Bug#600206: libcompass-ruby: compass apparently completely broken
Date: Tue, 16 Nov 2010 15:25:07 -0500
[Message part 1 (text/plain, inline)]
On Tue, 16 Nov 2010 15:18:56 +0530, Deepak Tripathi <deepak@debian.org> wrote:
> Hi Steve,
> 
> Sorry for delay; i was on vacation to India (Raj).
> 
> Yes actually popcon is very low for libcompass-ruby but i will still discuss
> with Micah Anderson <micah@debian.org> who is the primary maintainer for
> this module and will update about his thought to the bug reports asap.

I dont mind it being removed from testing.

micah
[Message part 2 (application/pgp-signature, inline)]

Reply sent to Jonas Smedegaard <dr@jones.dk>:
You have taken responsibility. (Wed, 02 Feb 2011 04:51:04 GMT) Full text and rfc822 format available.

Notification sent to Jonas Smedegaard <dr@jones.dk>:
Bug acknowledged by developer. (Wed, 02 Feb 2011 04:51:04 GMT) Full text and rfc822 format available.

Message #35 received at 600206-close@bugs.debian.org (full text, mbox):

From: Jonas Smedegaard <dr@jones.dk>
To: 600206-close@bugs.debian.org
Subject: Bug#600206: fixed in libcompass-ruby 0.10.6~dfsg-1
Date: Wed, 02 Feb 2011 04:47:14 +0000
Source: libcompass-ruby
Source-Version: 0.10.6~dfsg-1

We believe that the bug you reported is fixed in the latest version of
libcompass-ruby, which is due to be installed in the Debian FTP archive:

libcompass-ruby1.8_0.10.6~dfsg-1_all.deb
  to main/libc/libcompass-ruby/libcompass-ruby1.8_0.10.6~dfsg-1_all.deb
libcompass-ruby_0.10.6~dfsg-1.debian.tar.gz
  to main/libc/libcompass-ruby/libcompass-ruby_0.10.6~dfsg-1.debian.tar.gz
libcompass-ruby_0.10.6~dfsg-1.dsc
  to main/libc/libcompass-ruby/libcompass-ruby_0.10.6~dfsg-1.dsc
libcompass-ruby_0.10.6~dfsg-1_all.deb
  to main/libc/libcompass-ruby/libcompass-ruby_0.10.6~dfsg-1_all.deb
libcompass-ruby_0.10.6~dfsg.orig.tar.gz
  to main/libc/libcompass-ruby/libcompass-ruby_0.10.6~dfsg.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 600206@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jonas Smedegaard <dr@jones.dk> (supplier of updated libcompass-ruby package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 02 Feb 2011 05:35:23 +0100
Source: libcompass-ruby
Binary: libcompass-ruby libcompass-ruby1.8
Architecture: source all
Version: 0.10.6~dfsg-1
Distribution: unstable
Urgency: low
Maintainer: Micah Anderson <micah@debian.org>
Changed-By: Jonas Smedegaard <dr@jones.dk>
Description: 
 libcompass-ruby - Compass is a SASS-based stylesheet authoring tool
 libcompass-ruby1.8 - Compass is a SASS-based stylesheet authoring tool (Ruby 1.8)
Closes: 600206
Changes: 
 libcompass-ruby (0.10.6~dfsg-1) unstable; urgency=low
 .
   * New upstream release.
   * Add get-orig-tar target.
   * Friendly invasion: Add myself as uploader.
   * Fix patch 003 to use /usr/share/compass/frameworks (not
     /usr/share/compass/frameworks/frameworks) by default.
     Closes: bug#600206.
   * Refresh patches w/ compacting options --no-timestamps --no-index
     -pab.
   * Update watch file to use ~dfsg repackaging suffix.
Checksums-Sha1: 
 061c91a70c272ddc4e776ff0bf7e6c7bb6842bbb 2172 libcompass-ruby_0.10.6~dfsg-1.dsc
 d241bede2031324db2b090e172ba96925e583494 975910 libcompass-ruby_0.10.6~dfsg.orig.tar.gz
 77724faff9b660cb8a78d822053fef5c5826918a 6855 libcompass-ruby_0.10.6~dfsg-1.debian.tar.gz
 35eb4dfccd35973eec6b34b83e413c5ef8ed7b13 513078 libcompass-ruby_0.10.6~dfsg-1_all.deb
 5c87ebf4590ea7027179dbc9ea9c8d1be6d9fcb2 168002 libcompass-ruby1.8_0.10.6~dfsg-1_all.deb
Checksums-Sha256: 
 bc0adb0f0e6e3bf7f5c7c5e0d6cd19c0123a67df0229f3047283e08d4a5fec4d 2172 libcompass-ruby_0.10.6~dfsg-1.dsc
 8311fc255f0b458d96473a9df686c4b0b34d02dbc0d547594dbdf94a4c185a6b 975910 libcompass-ruby_0.10.6~dfsg.orig.tar.gz
 8b7457f4b2b27ba74372caddee4bb441f4dd0dbfe2466b86922b18fa489ca343 6855 libcompass-ruby_0.10.6~dfsg-1.debian.tar.gz
 0abc9861bedf36a88536f0837369b93265cd0038f53a0f95707eb772905eaf2e 513078 libcompass-ruby_0.10.6~dfsg-1_all.deb
 25592fed4fe64d6357259841d92c0ec0f5e593f777867970cad1bc03cdd13440 168002 libcompass-ruby1.8_0.10.6~dfsg-1_all.deb
Files: 
 b70630da24610a2bb0148661198affdb 2172 ruby optional libcompass-ruby_0.10.6~dfsg-1.dsc
 482e060c64e345973ef38af91fc796cb 975910 ruby optional libcompass-ruby_0.10.6~dfsg.orig.tar.gz
 350135fc7ace30a0531dc0f3b20c869c 6855 ruby optional libcompass-ruby_0.10.6~dfsg-1.debian.tar.gz
 df99269a1d4be4935ac54a2edd06b4fe 513078 ruby optional libcompass-ruby_0.10.6~dfsg-1_all.deb
 b5c198bc9e071b0dcd33ddffc1075c18 168002 ruby optional libcompass-ruby1.8_0.10.6~dfsg-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCgAGBQJNSN9oAAoJECx8MUbBoAEh0w0P/09x71a6mcAphbpjge3MnnUH
/RqZzmUPj1Mi/ztvy7MaIGTkARGNmZkuBP8yxDNOk47Kta78hXrWVphN6wItEiK0
2RKaVYClkYcc55OPXA9XqwznZ4H2hNXycOQNQbrUmdB2fIIYuop0QZBSp/xnBsfj
mm5UMxfyEsHh9zM221n8qClmul8Dp6zdYwrhXUhv0NYGd0xWW/zGUWjKe0YY7/Pz
MCpyBIak0x3ipDe8EOg1VBarvRAp9p2ToxX4sudIn+aj14/euLUhw3Y4beboTYQO
9xG+XZJRgTSjCguozPOE2zc55jqTLe+umPFyvX8EmPJLNDvhSK4KngS58C9eQiAt
ENnH7twTUKOSI+mVlNxjMYmz7zTEfBp3EXSN+Sum532EukN3eW6ywT0UqBX7ve3f
R0Krrf6DQNEBC5pME/Eb3UEA1cgTZhC/RWW5XVJKDeU9UkfW+JhcWScR7AVAuZkg
VFdLGX6Y0DnqZBhfAcqQ81ryXLs4sTohSKw73csblDVeXocB6zD/9CqjyArPAiJk
E0bEWMvio0fsxqaWwgowVlygIuZFe9BeENZgBtZXMKoe+zCHbW3FWdMs2cbpYWxB
HMINGK3AgdqQBeVhz9ZN6GvAyI/ErKOWS/CIY87oiENFENgORLMMkLjjDzy4bB95
6ln+j3p7+4CI+64I4Las
=VWVD
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 16 Mar 2011 07:32:47 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 01:29:03 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.