Debian Bug report logs - #599933
perl: fails to build with GCC 4.5

version graph

Package: perl; Maintainer for perl is Niko Tyni <ntyni@debian.org>; Source for perl is src:perl.

Reported by: Colin Watson <cjwatson@ubuntu.com>

Date: Tue, 12 Oct 2010 15:00:01 UTC

Severity: important

Tags: fixed-upstream, patch, sid, upstream

Found in version perl/5.10.1-15

Fixed in versions perl/5.12.2-2, perl/5.10.1-18

Done: Dominic Hargreaves <dom@earth.li>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#599933; Package perl. (Tue, 12 Oct 2010 15:00:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Colin Watson <cjwatson@ubuntu.com>:
New Bug report received and forwarded. Copy sent to Niko Tyni <ntyni@debian.org>. (Tue, 12 Oct 2010 15:00:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Colin Watson <cjwatson@ubuntu.com>
To: submit@bugs.debian.org
Subject: perl: fails to build with GCC 4.5
Date: Tue, 12 Oct 2010 15:56:11 +0100
[Message part 1 (text/plain, inline)]
Package: perl
Version: 5.10.1-15
Severity: important
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch natty

Ubuntu recently switched to GCC 4.5, and we quickly found that Perl
failed to build with it.  Here's the build log:

  http://launchpadlibrarian.net/57494704/buildlog_ubuntu-natty-i386.perl_5.10.1-15ubuntu1_FAILEDTOBUILD.txt.gz

It ends as follows:

  # Verify that the headers are usable
  for ph in `< /build/buildd/perl-5.10.1/debian/headers sed -e 's/\.h$/.ph/'`; do \
                  if [ ! -f /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/$ph ]; then \
                          echo "$ph: missing"; else \
                  /build/buildd/perl-5.10.1/perl.static -I /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10 -I /build/buildd/perl-5.10.1/debian/tmp/usr/share/perl/5.10 -e \
                          "print '"$ph": '; require '"$ph"'; print \"ok\n\";" \
                                  || exit 1; \
                  fi; \
          done
  Illegal declaration of subroutine main::__INT16_C at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/_h2ph_pre.ph line 162.
  Compilation failed in require at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/asm/termios.ph line 1.
  Compilation failed in require at -e line 1.
  asm/termios.ph: make: *** [install-stamp] Error 1

I hunted around a bit and tracked down
http://perl5.git.perl.org/perl.git/commit/8d66b3f930dc6d88b524d103e304308ae73a46e7,
which fixes this problem (although the commit message is uninformative).
Attached please find a patch to incorporate this.

Thanks,

-- 
Colin Watson                                       [cjwatson@ubuntu.com]
[perl-gcc-4.5.patch (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#599933; Package perl. (Tue, 12 Oct 2010 20:57:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. (Tue, 12 Oct 2010 20:57:06 GMT) Full text and rfc822 format available.

Message #10 received at 599933@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Colin Watson <cjwatson@ubuntu.com>, 599933@bugs.debian.org
Subject: Re: Bug#599933: perl: fails to build with GCC 4.5
Date: Tue, 12 Oct 2010 23:54:29 +0300
On Tue, Oct 12, 2010 at 03:56:11PM +0100, Colin Watson wrote:
> Package: perl
> Version: 5.10.1-15
> Severity: important
> Tags: patch
> User: ubuntu-devel@lists.ubuntu.com
> Usertags: origin-ubuntu ubuntu-patch natty
> 
> Ubuntu recently switched to GCC 4.5, and we quickly found that Perl
> failed to build with it.

>   Illegal declaration of subroutine main::__INT16_C at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/_h2ph_pre.ph line 162.
>   Compilation failed in require at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/asm/termios.ph line 1.

> I hunted around a bit and tracked down
> http://perl5.git.perl.org/perl.git/commit/8d66b3f930dc6d88b524d103e304308ae73a46e7,
> which fixes this problem (although the commit message is uninformative).
> Attached please find a patch to incorporate this.

Thanks! I don't see a reason for pushing this into squeeze (seems like an
unnecessary risk to me), but I'll certainly add it to the 5.12 packages
in experimental.

If you (or anybody else) think it should go in squeeze too, please let
me know.
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#599933; Package perl. (Tue, 12 Oct 2010 21:31:38 GMT) Full text and rfc822 format available.

Acknowledgement sent to Colin Watson <cjwatson@debian.org>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Tue, 12 Oct 2010 21:31:38 GMT) Full text and rfc822 format available.

Message #15 received at 599933@bugs.debian.org (full text, mbox):

From: Colin Watson <cjwatson@debian.org>
To: Niko Tyni <ntyni@debian.org>
Cc: 599933@bugs.debian.org
Subject: Re: Bug#599933: perl: fails to build with GCC 4.5
Date: Tue, 12 Oct 2010 22:24:30 +0100
On Tue, Oct 12, 2010 at 11:54:29PM +0300, Niko Tyni wrote:
> On Tue, Oct 12, 2010 at 03:56:11PM +0100, Colin Watson wrote:
> > Ubuntu recently switched to GCC 4.5, and we quickly found that Perl
> > failed to build with it.
> 
> >   Illegal declaration of subroutine main::__INT16_C at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/_h2ph_pre.ph line 162.
> >   Compilation failed in require at /build/buildd/perl-5.10.1/debian/tmp/usr/lib/perl/5.10/asm/termios.ph line 1.
> 
> > I hunted around a bit and tracked down
> > http://perl5.git.perl.org/perl.git/commit/8d66b3f930dc6d88b524d103e304308ae73a46e7,
> > which fixes this problem (although the commit message is uninformative).
> > Attached please find a patch to incorporate this.
> 
> Thanks! I don't see a reason for pushing this into squeeze (seems like an
> unnecessary risk to me), but I'll certainly add it to the 5.12 packages
> in experimental.
> 
> If you (or anybody else) think it should go in squeeze too, please let
> me know.

As far as I'm concerned, just 5.12 would be fine (indeed, it's not in
the upstream maint-5.12 branch, only in blead).  I mostly just wanted to
ensure that folks working on GCC 4.5 in Debian didn't have to replicate
my search for a fix.

Thanks,

-- 
Colin Watson                                       [cjwatson@debian.org]




Reply sent to Niko Tyni <ntyni@debian.org>:
You have taken responsibility. (Tue, 02 Nov 2010 11:36:19 GMT) Full text and rfc822 format available.

Notification sent to Colin Watson <cjwatson@ubuntu.com>:
Bug acknowledged by developer. (Tue, 02 Nov 2010 11:36:19 GMT) Full text and rfc822 format available.

Message #20 received at 599933-close@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 599933-close@bugs.debian.org
Subject: Bug#599933: fixed in perl 5.12.2-2
Date: Tue, 02 Nov 2010 11:32:34 +0000
Source: perl
Source-Version: 5.12.2-2

We believe that the bug you reported is fixed in the latest version of
perl, which is due to be installed in the Debian FTP archive:

libcgi-fast-perl_5.12.2-2_all.deb
  to main/p/perl/libcgi-fast-perl_5.12.2-2_all.deb
libperl-dev_5.12.2-2_amd64.deb
  to main/p/perl/libperl-dev_5.12.2-2_amd64.deb
libperl5.12_5.12.2-2_amd64.deb
  to main/p/perl/libperl5.12_5.12.2-2_amd64.deb
perl-base_5.12.2-2_amd64.deb
  to main/p/perl/perl-base_5.12.2-2_amd64.deb
perl-debug_5.12.2-2_amd64.deb
  to main/p/perl/perl-debug_5.12.2-2_amd64.deb
perl-doc_5.12.2-2_all.deb
  to main/p/perl/perl-doc_5.12.2-2_all.deb
perl-modules_5.12.2-2_all.deb
  to main/p/perl/perl-modules_5.12.2-2_all.deb
perl_5.12.2-2.debian.tar.gz
  to main/p/perl/perl_5.12.2-2.debian.tar.gz
perl_5.12.2-2.dsc
  to main/p/perl/perl_5.12.2-2.dsc
perl_5.12.2-2_amd64.deb
  to main/p/perl/perl_5.12.2-2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 599933@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Niko Tyni <ntyni@debian.org> (supplier of updated perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 02 Nov 2010 11:34:32 +0200
Source: perl
Binary: perl-base libcgi-fast-perl perl-doc perl-modules perl-debug libperl5.12 libperl-dev perl
Architecture: source all amd64
Version: 5.12.2-2
Distribution: experimental
Urgency: low
Maintainer: Niko Tyni <ntyni@debian.org>
Changed-By: Niko Tyni <ntyni@debian.org>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.12 - shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - minimal Perl system
 perl-debug - debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
Closes: 379329 508764 596105 596734 596844 599933 601549
Changes: 
 perl (5.12.2-2) experimental; urgency=low
 .
   * Merge 5.10.1-15 and -16 from unstable:
     + Include the Text::Tabs license in debian/copyright. Thanks to "v.nix.is".
       (Closes: #596844)
     + Downgrade the 'make' recommendation to a suggestion to avoid pulling
       it in by default after all. (Closes: #596734) (Reopens: #293908)
     + Squelch useless locale warnings during package maintainer scripts.
       (Closes: #508764)
     + Improve LC_NUMERIC documentation. (Closes: #379329)
     + Fix sprintf not to ignore LC_NUMERIC with constants. (Closes: #601549)
     + Fix stack pointer corruption in pp_concat() with "use encoding".
       (Closes: #596105)
   * Unapply the debian/use_gdbm patch, obsolete since 5.8.4.
   * Fix h2ph header generation with GCC 4.5. Upstream patch by Robin Barker.
     (Closes: #599933)
Checksums-Sha1: 
 be804c5a49e9b63f76857fedce3c922df9957700 1423 perl_5.12.2-2.dsc
 19a022f64138edf6adcf2d50db1c1e3ee0f31d90 87572 perl_5.12.2-2.debian.tar.gz
 e06525a6fdc0635b84cc8c3bfd89fdcb85f7bccf 54260 libcgi-fast-perl_5.12.2-2_all.deb
 ee1c3e2859cf46b2f9bdbcee44266569edefb6bd 7506772 perl-doc_5.12.2-2_all.deb
 6439ebf9319ff7ae46333d63c9d78b51c3919cd0 4754640 perl-modules_5.12.2-2_all.deb
 f298e4dcbe6d70d624b0ee0c47aace19e388e1fa 1483584 perl-base_5.12.2-2_amd64.deb
 637245f29dac6dc071a7c1e0a8d385021f35c1e9 5895258 perl-debug_5.12.2-2_amd64.deb
 a6861a26609a771fdc85d4213f39dfca59f7d7d6 1150 libperl5.12_5.12.2-2_amd64.deb
 f1cea8b566f42816c85f784120d36a95ecffed4f 2573502 libperl-dev_5.12.2-2_amd64.deb
 5cfd5fe5dd6b30555d3905ff39ecdce64cbe07e3 4221210 perl_5.12.2-2_amd64.deb
Checksums-Sha256: 
 0e15780cd0b91b9e3f94c0131dadd86d8f54fbac67fe6f6d71110a520b568af9 1423 perl_5.12.2-2.dsc
 c6aee7bf9b70caa662a5bdc3cc4d4a4d2c2f1a833f04d75b0347835f9b544232 87572 perl_5.12.2-2.debian.tar.gz
 a6499b7f391f94142a30396ba1c9231e8c81cc552b4868f3f6de01194ae1f0c6 54260 libcgi-fast-perl_5.12.2-2_all.deb
 dbf876032f70ee45271e66e8aaec97fd55374bbbf65bbddf722467b8bdf3e987 7506772 perl-doc_5.12.2-2_all.deb
 c2c914a2be2fd07c31d209bab92e04bb582e29ae3cd95d32104e0c519509af64 4754640 perl-modules_5.12.2-2_all.deb
 e7ee0aa1fe64a964b66ec6ddb77ed40a44822ced78cd11b7a1bcd8fe1d4cace5 1483584 perl-base_5.12.2-2_amd64.deb
 61a2bda261b4d25e44a49fa1e57fa8cd438faf8ade378d6b8b1fd3cf82cdf60e 5895258 perl-debug_5.12.2-2_amd64.deb
 cba09404b8e60078953868740398a07dcff8d3d0f8eae0bdb539b1e4109cb730 1150 libperl5.12_5.12.2-2_amd64.deb
 4472cdf3ea8d003873c965aaada267b192d273cb0697f618272e5615d4a065e7 2573502 libperl-dev_5.12.2-2_amd64.deb
 7af1ad3685eeec13ed2750b92ff190ac272e65fb44b94da7cfc8ab17a928762a 4221210 perl_5.12.2-2_amd64.deb
Files: 
 be3df9a17d91f2f9fd3690f35513024f 1423 perl standard perl_5.12.2-2.dsc
 2c5ef80f180743ee342c15486a29c66d 87572 perl standard perl_5.12.2-2.debian.tar.gz
 8bfa31025e78fea891a33c0a19033740 54260 perl optional libcgi-fast-perl_5.12.2-2_all.deb
 c944d25183a3a99128d74b26852e650c 7506772 doc optional perl-doc_5.12.2-2_all.deb
 89af65e54e3af5cb8b40c161216f6142 4754640 perl standard perl-modules_5.12.2-2_all.deb
 09b99bbc17cf6277adffdafb47021710 1483584 perl required perl-base_5.12.2-2_amd64.deb
 f614a4e2b20da365f698cf3a77f927fe 5895258 debug extra perl-debug_5.12.2-2_amd64.deb
 25c16c05cf1972ee1d28e2b2fa779cab 1150 libs optional libperl5.12_5.12.2-2_amd64.deb
 4fb5cd7e834cb555e2286d81ad3a7eeb 2573502 libdevel optional libperl-dev_5.12.2-2_amd64.deb
 d547be35d28a4220474371d74e892913 4221210 perl standard perl_5.12.2-2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkzP8twACgkQiyizGWoHLTmeNgCglhd8FKXF89s+IwEEqBgARQIR
8DQAn3Axo5TuVu8xy72Wv06pzZmpcLQr
=Tn2n
-----END PGP SIGNATURE-----





Added tag(s) upstream and fixed-upstream. Request was from Dominic Hargreaves <dom@earth.li> to control@bugs.debian.org. (Fri, 11 Feb 2011 21:21:08 GMT) Full text and rfc822 format available.

Added tag(s) sid. Request was from Dominic Hargreaves <dom@earth.li> to control@bugs.debian.org. (Sat, 12 Mar 2011 15:27:13 GMT) Full text and rfc822 format available.

Reply sent to Dominic Hargreaves <dom@earth.li>:
You have taken responsibility. (Tue, 15 Mar 2011 23:03:10 GMT) Full text and rfc822 format available.

Notification sent to Colin Watson <cjwatson@ubuntu.com>:
Bug acknowledged by developer. (Tue, 15 Mar 2011 23:03:10 GMT) Full text and rfc822 format available.

Message #29 received at 599933-close@bugs.debian.org (full text, mbox):

From: Dominic Hargreaves <dom@earth.li>
To: 599933-close@bugs.debian.org
Subject: Bug#599933: fixed in perl 5.10.1-18
Date: Tue, 15 Mar 2011 23:02:41 +0000
Source: perl
Source-Version: 5.10.1-18

We believe that the bug you reported is fixed in the latest version of
perl, which is due to be installed in the Debian FTP archive:

libcgi-fast-perl_5.10.1-18_all.deb
  to main/p/perl/libcgi-fast-perl_5.10.1-18_all.deb
libperl-dev_5.10.1-18_i386.deb
  to main/p/perl/libperl-dev_5.10.1-18_i386.deb
libperl5.10_5.10.1-18_i386.deb
  to main/p/perl/libperl5.10_5.10.1-18_i386.deb
perl-base_5.10.1-18_i386.deb
  to main/p/perl/perl-base_5.10.1-18_i386.deb
perl-debug_5.10.1-18_i386.deb
  to main/p/perl/perl-debug_5.10.1-18_i386.deb
perl-doc_5.10.1-18_all.deb
  to main/p/perl/perl-doc_5.10.1-18_all.deb
perl-modules_5.10.1-18_all.deb
  to main/p/perl/perl-modules_5.10.1-18_all.deb
perl-suid_5.10.1-18_i386.deb
  to main/p/perl/perl-suid_5.10.1-18_i386.deb
perl_5.10.1-18.debian.tar.gz
  to main/p/perl/perl_5.10.1-18.debian.tar.gz
perl_5.10.1-18.dsc
  to main/p/perl/perl_5.10.1-18.dsc
perl_5.10.1-18_i386.deb
  to main/p/perl/perl_5.10.1-18_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 599933@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Dominic Hargreaves <dom@earth.li> (supplier of updated perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 15 Mar 2011 20:59:04 +0000
Source: perl
Binary: perl-base libcgi-fast-perl perl-doc perl-modules perl-debug perl-suid libperl5.10 libperl-dev perl
Architecture: source all i386
Version: 5.10.1-18
Distribution: unstable
Urgency: low
Maintainer: Niko Tyni <ntyni@debian.org>
Changed-By: Dominic Hargreaves <dom@earth.li>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.10 - shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - minimal Perl system
 perl-debug - debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
 perl-suid  - runs setuid Perl scripts
Closes: 599933 608385 617985
Changes: 
 perl (5.10.1-18) unstable; urgency=low
 .
   * Add Conflicts, Replaces, Provides for libencode-perl which is
     being packaged separately. (Closes: #608385)
   * Include information about preparing the repository for use with
     topgit in debian/README.source
   * Fix h2ph header generation with GCC 4.5. Upstream patch by Robin Barker.
     (Closes: #599933)
   * Override Lintian error wrong-path-for-interpreter for
     ./usr/share/perl/5.10.1/Class/ISA.pm which is not expected to be
     executed
   * Add Conflicts, Replaces, Provides for libfile-path-perl which is
     packaged separately (Closes: #617985)
   * Include the full text of the license statements for BSD-style
     licenses in debian/copyright, rather than the deprecated practice of
     referring to an external copy
Checksums-Sha1: 
 289d6caffc8e928c4dec1adaa53fb40aafb0f2ac 1415 perl_5.10.1-18.dsc
 1d95b560055e16a412bf5e0cd2f5acda0b0a4701 116560 perl_5.10.1-18.debian.tar.gz
 c7c865f7a9070644690bbb2d2bbf31422d0ad1a0 53294 libcgi-fast-perl_5.10.1-18_all.deb
 82ffd1bda821d4af7fa3ff494bf4100196e836a3 7189138 perl-doc_5.10.1-18_all.deb
 8100a470c3ebab97d6b2c4ec49f385a82419a8ea 3491106 perl-modules_5.10.1-18_all.deb
 49e4cdfe039375d0e2109928d403320077e96039 979546 perl-base_5.10.1-18_i386.deb
 6723e3d40689f223f2f2c94691cab64204516eee 7446838 perl-debug_5.10.1-18_i386.deb
 b2ae23df7db2f007606dbef61caa9ee65860f10a 33056 perl-suid_5.10.1-18_i386.deb
 48f4c37740784811c800185a6f8b8a4955598ee4 631444 libperl5.10_5.10.1-18_i386.deb
 daa7b36ee2ba7f42f6e7e51f98415b840e034b26 2503094 libperl-dev_5.10.1-18_i386.deb
 3a2b558f10876dc793b69ea3b04f6a6987903766 3780260 perl_5.10.1-18_i386.deb
Checksums-Sha256: 
 184ee7006f0e0dc424b87b469280abbf35386c9d578c4d32c5d9dae455924f62 1415 perl_5.10.1-18.dsc
 7bafc550d21f19bb8a6af4fbc6f0cd40ebf31e2a2cd4955c3c47ca5eebc90e79 116560 perl_5.10.1-18.debian.tar.gz
 23d6dc7c2627d73b70ff981fb1b70ef41f4a3e53e7d8555f3a2f4de8b2611182 53294 libcgi-fast-perl_5.10.1-18_all.deb
 3b7687186c554ad1fb79d9ba8ab65dc8ffeb8751af651175b3b0d3a8c63e488a 7189138 perl-doc_5.10.1-18_all.deb
 0c2a94dfe42635c6f77b0eb68a449ec9789ec6b7d2a8357414b5784d1121dd4f 3491106 perl-modules_5.10.1-18_all.deb
 9adeffbf75b9078e729114376d148d2781b60ccb6041cc39ecac0c14946d923b 979546 perl-base_5.10.1-18_i386.deb
 32b09e09b0675d1c46d009870212abc07e79077dca1c17b93ec8c1e94936a30d 7446838 perl-debug_5.10.1-18_i386.deb
 a904607df1edf3d0c51a8c7f0e966174f588ec9b3a6aa4cec0c35788e444da94 33056 perl-suid_5.10.1-18_i386.deb
 d3130ad3485a6634ea5db5c7fcf41bbadbd8d9e2bed25bddb1a4b36671dc59ac 631444 libperl5.10_5.10.1-18_i386.deb
 dd14ba266a70b3b3eded5cf0cfe3cca0a65d15908fd09f7c5646b5f66a1bcdf3 2503094 libperl-dev_5.10.1-18_i386.deb
 7c35c3704938dda626e53cb13631116d6e442c0da41f326f89affdc5c891a491 3780260 perl_5.10.1-18_i386.deb
Files: 
 c98ed13923fa1b98a9d439cc076c2f33 1415 perl standard perl_5.10.1-18.dsc
 22b9286d5f28ef678a10ef56f193ab68 116560 perl standard perl_5.10.1-18.debian.tar.gz
 9f4e8c2341fab62a350e7e17775a3d1e 53294 perl optional libcgi-fast-perl_5.10.1-18_all.deb
 92711af93faf224d4371d9f30b61e546 7189138 doc optional perl-doc_5.10.1-18_all.deb
 a7496f87d79765e281618187119c1686 3491106 perl standard perl-modules_5.10.1-18_all.deb
 67965af70959908a994189c00fd165b9 979546 perl required perl-base_5.10.1-18_i386.deb
 cacdcf5f8d8f131ac86df5dd62ddee81 7446838 debug extra perl-debug_5.10.1-18_i386.deb
 6836e552a5ded06586d74c4cdc25034d 33056 perl optional perl-suid_5.10.1-18_i386.deb
 2ae0855c62a7940b2ad442c7b3eff26e 631444 libs optional libperl5.10_5.10.1-18_i386.deb
 6b9f47d2b45ec19442db91a1b6fd6d2e 2503094 libdevel optional libperl-dev_5.10.1-18_i386.deb
 a8202d1a2377709a276c9bf8b7c4392e 3780260 perl standard perl_5.10.1-18_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFNf9/SYzuFKFF44qURAjcEAKCmnwfhNBPTCI8p5MB7uwhj1KaaRQCgrQ+L
1vUFzQOB1zUy/D225mvfm8Y=
=YyjG
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 30 Apr 2011 08:02:19 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 17:12:31 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.