Debian Bug report logs - #598989
libextractor-java: FTBFS on armel: error: libextractor-java requires libextractor

version graph

Package: src:libextractor-java; Maintainer for src:libextractor-java is Debian QA Group <packages@qa.debian.org>;

Reported by: Cyril Brulebois <kibi@debian.org>

Date: Sun, 3 Oct 2010 17:06:01 UTC

Severity: serious

Tags: experimental

Found in version libextractor-java/0.6.0-1

Fixed in version libextractor-java/0.6.0-2

Done: Daniel Baumann <daniel@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, kibi@debian.org, Debian GNUnet Maintainers <gnunet@lists.debian-maintainers.org>:
Bug#598989; Package src:libextractor-java. (Sun, 03 Oct 2010 17:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
New Bug report received and forwarded. Copy sent to kibi@debian.org, Debian GNUnet Maintainers <gnunet@lists.debian-maintainers.org>. (Sun, 03 Oct 2010 17:06:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libextractor-java: FTBFS on armel: error: libextractor-java requires libextractor
Date: Sun, 03 Oct 2010 19:02:13 +0200
Source: libextractor-java
Version: 0.6.0-1
Severity: serious
Justification: FTBFS
User: debian-arm@lists.debian.org
Usertags: eabi

Hi,

your package no longer builds on armel:
| checking for extractor.h... yes
| configure: error: libextractor-java requires libextractor
| checking for EXTRACTOR_plugin_add_defaults in -lextractor... no

Full build logs:
  https://buildd.debian.org/status/package.php?p=libextractor-java&suite=experimental

Mraw,
KiBi.




Added tag(s) experimental. Request was from Hector Oron <zumbi@debian.org> to control@bugs.debian.org. (Sat, 13 Nov 2010 15:09:05 GMT) Full text and rfc822 format available.

Reply sent to daniel@debian.org:
You have taken responsibility. (Sat, 20 Nov 2010 16:48:04 GMT) Full text and rfc822 format available.

Notification sent to Cyril Brulebois <kibi@debian.org>:
Bug acknowledged by developer. (Sat, 20 Nov 2010 16:48:04 GMT) Full text and rfc822 format available.

Message #12 received at 598989-done@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel@debian.org>
To: 598989-done@bugs.debian.org, 598989-submitter@bugs.debian.org
Subject: Re: libextractor-java: FTBFS on armel: error: libextractor-java requires libextractor
Date: Sat, 20 Nov 2010 17:44:52 +0100
libe-java 0.6 needs libe 0.6, which is why there's a versioned
build-depends on it.

in the build log, it can be seen, that the autobuilder is installing
libe 0.5 from unstable, rather than 0.6 from experimental.

this is a problem in your autobuilder, not in the package, closing.

-- 
Address:        Daniel Baumann, Burgunderstrasse 3, CH-4562 Biberist
Email:          daniel.baumann@panthera-systems.net
Internet:       http://people.panthera-systems.net/~daniel-baumann/




Message sent on to Cyril Brulebois <kibi@debian.org>:
Bug#598989. (Sat, 20 Nov 2010 16:48:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNUnet Maintainers <gnunet@lists.debian-maintainers.org>:
Bug#598989; Package src:libextractor-java. (Sat, 20 Nov 2010 17:03:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNUnet Maintainers <gnunet@lists.debian-maintainers.org>. (Sat, 20 Nov 2010 17:03:08 GMT) Full text and rfc822 format available.

Message #20 received at 598989@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: daniel@debian.org, 598989@bugs.debian.org, 598989-submitter@bugs.debian.org
Subject: Re: Bug#598989: libextractor-java: FTBFS on armel: error: libextractor-java requires libextractor
Date: Sat, 20 Nov 2010 18:00:14 +0100
[Message part 1 (text/plain, inline)]
reopen 598989
kthxbye

On Sat, Nov 20, 2010 at 17:44:52 +0100, Daniel Baumann wrote:

> libe-java 0.6 needs libe 0.6, which is why there's a versioned
> build-depends on it.
> 
> in the build log, it can be seen, that the autobuilder is installing
> libe 0.5 from unstable, rather than 0.6 from experimental.
> 
> this is a problem in your autobuilder, not in the package, closing.
> 
No.  0.6.0 <= 1:0.5.23 so the package from unstable satisfies the build
dependency.

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Did not alter fixed versions and reopened. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 20 Nov 2010 17:03:13 GMT) Full text and rfc822 format available.

Message sent on to Cyril Brulebois <kibi@debian.org>:
Bug#598989. (Sat, 20 Nov 2010 17:03:18 GMT) Full text and rfc822 format available.

Reply sent to Daniel Baumann <daniel@debian.org>:
You have taken responsibility. (Sun, 21 Nov 2010 11:03:06 GMT) Full text and rfc822 format available.

Notification sent to Cyril Brulebois <kibi@debian.org>:
Bug acknowledged by developer. (Sun, 21 Nov 2010 11:03:06 GMT) Full text and rfc822 format available.

Message #30 received at 598989-close@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel@debian.org>
To: 598989-close@bugs.debian.org
Subject: Bug#598989: fixed in libextractor-java 0.6.0-2
Date: Sun, 21 Nov 2010 11:02:07 +0000
Source: libextractor-java
Source-Version: 0.6.0-2

We believe that the bug you reported is fixed in the latest version of
libextractor-java, which is due to be installed in the Debian FTP archive:

libextractor-java-dbg_0.6.0-2_i386.deb
  to main/libe/libextractor-java/libextractor-java-dbg_0.6.0-2_i386.deb
libextractor-java-dev_0.6.0-2_i386.deb
  to main/libe/libextractor-java/libextractor-java-dev_0.6.0-2_i386.deb
libextractor-java0_0.6.0-2_i386.deb
  to main/libe/libextractor-java/libextractor-java0_0.6.0-2_i386.deb
libextractor-java_0.6.0-2.debian.tar.gz
  to main/libe/libextractor-java/libextractor-java_0.6.0-2.debian.tar.gz
libextractor-java_0.6.0-2.dsc
  to main/libe/libextractor-java/libextractor-java_0.6.0-2.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 598989@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Baumann <daniel@debian.org> (supplier of updated libextractor-java package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 21 Nov 2010 11:53:33 +0100
Source: libextractor-java
Binary: libextractor-java0 libextractor-java-dbg libextractor-java-dev
Architecture: source i386
Version: 0.6.0-2
Distribution: experimental
Urgency: low
Maintainer: Debian GNUnet Maintainers <gnunet@lists.debian-maintainers.org>
Changed-By: Daniel Baumann <daniel@debian.org>
Description: 
 libextractor-java-dbg - Java bindings for GNU libextractor (debug)
 libextractor-java-dev - Java bindings for GNU libextractor (development)
 libextractor-java0 - Java bindings for GNU libextractor
Closes: 598989
Changes: 
 libextractor-java (0.6.0-2) experimental; urgency=low
 .
   * Bumping versioned build-depends on debhelper.
   * Correcting versioned build-depends on libextractor (Closes:
     #598989).
   * Updating to debhelper version 8.
   * Updating to standards version 3.9.1.
   * Using simplified autotools handling in rules.
   * Switching to source format 3.0 (quilt).
   * Not using simplified dh_auto_install call since that doesn't work.
Checksums-Sha1: 
 4f39e4108f08cb912834b9693eeedc934d6f05d5 1508 libextractor-java_0.6.0-2.dsc
 80f62f0082f85d546c9f04bd07788daa3e1a4caf 3964 libextractor-java_0.6.0-2.debian.tar.gz
 46391395276da73d0012db463b5b348ab8bf5cb3 10186 libextractor-java0_0.6.0-2_i386.deb
 71c7cd8517d7a3ff070e1c86058d2e0653ac89b4 16908 libextractor-java-dbg_0.6.0-2_i386.deb
 b97ba6ad268c08cde13154b9e35377ab418042e7 4478 libextractor-java-dev_0.6.0-2_i386.deb
Checksums-Sha256: 
 10da1d3780763f7eab6709370e4586a780af3d47735e889dce8eb007e994335f 1508 libextractor-java_0.6.0-2.dsc
 d5e8f6bd9162c3a1f966a32befe9f6bff001b9c01afbbfeda4eb1882e0359f89 3964 libextractor-java_0.6.0-2.debian.tar.gz
 9703ddac8213d61fb9674a6c54079de7cd130a8f3b8342a5123202a2a1e59b4a 10186 libextractor-java0_0.6.0-2_i386.deb
 473b8adfd985c20762bb0232d6b7c63c18bd761f590b67cf70f6c101102db20c 16908 libextractor-java-dbg_0.6.0-2_i386.deb
 4776455c9457a31f4321524a8027ee9d10056083a373ecf9dfde8c57ff3b186b 4478 libextractor-java-dev_0.6.0-2_i386.deb
Files: 
 e73a2ce5c68517859f80b68be1d08cca 1508 libs optional libextractor-java_0.6.0-2.dsc
 3762cc2738e0c46dfeb1dd38a48be331 3964 libs optional libextractor-java_0.6.0-2.debian.tar.gz
 968406d0ff5894a16887a1612f044d0e 10186 libs optional libextractor-java0_0.6.0-2_i386.deb
 dc9ba2d3c6f47607ce497130b141a4c7 16908 debug extra libextractor-java-dbg_0.6.0-2_i386.deb
 30ef80e652612d1794febfef879465f8 4478 libdevel optional libextractor-java-dev_0.6.0-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkzo+ogACgkQ+C5cwEsrK54b3wCffvwAesjzt/tC31XxPfuMJQ7x
Zp4AoJFiClnzbdxj5hJJgOQsj42CqFV+
=2n+v
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 20 Dec 2010 07:37:10 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 05:32:53 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.