Debian Bug report logs - #598562
nmu: evolution-mapi_0.30.3-2

Package: release.debian.org; Maintainer for release.debian.org is Debian Release Team <debian-release@lists.debian.org>;

Reported by: Iñigo Martínez <inigo.martinez@ikusi.com>

Date: Thu, 30 Sep 2010 06:51:02 UTC

Severity: normal

Done: Julien Cristau <jcristau@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>:
Bug#598562; Package evolution-mapi. (Thu, 30 Sep 2010 06:51:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Iñigo Martínez <inigo.martinez@ikusi.com>:
New Bug report received and forwarded. Copy sent to Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>. (Thu, 30 Sep 2010 06:51:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Iñigo Martínez <inigo.martinez@ikusi.com>
To: submit@bugs.debian.org
Subject: evolution-mapi can't be installed
Date: Thu, 30 Sep 2010 08:37:35 +0200
Package: evolution-mapi
Version: 0.30.3-2

When I try to install evolution-mapi I can't. It says that some packages
have unmet dependencies, but it's not true:

aptitude install evolution-mapi -t experimental
The following NEW packages will be installed:
  evolution-mapi{b} libdcerpc0{a} libexchangemapi-1.0-0{a} libgensec0{a} libldb0{a} libmapi0{a} libndr-standard0{a} libndr0{a} libregistry0{a} libsamba-hostconfig0{a} 
  libsamba-util0{a} libtevent0{a} samba-common{a} samba-common-bin{a} 
0 packages upgraded, 14 newly installed, 0 to remove and 128 not upgraded.
Need to get 11.5MB of archives. After unpacking 38.3MB will be used.
The following packages have unmet dependencies:
  evolution-mapi: Depends: libgtkhtml-editor0 (>= 1:3.30.2) but 3.30.3-1 is installed.
                  Depends: libgtkhtml3.14-19 (>= 1:3.30.2) but 3.30.3-1 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     evolution-mapi [Not Installed]

Dependencies against libgtkhtml-editor0 and libgtkhtml3.14-19 don't look correct.

Regards,




Reply sent to Jelmer Vernooij <jelmer@vernstok.nl>:
You have taken responsibility. (Thu, 30 Sep 2010 07:15:06 GMT) Full text and rfc822 format available.

Notification sent to Iñigo Martínez <inigo.martinez@ikusi.com>:
Bug acknowledged by developer. (Thu, 30 Sep 2010 07:15:06 GMT) Full text and rfc822 format available.

Message #10 received at 598562-done@bugs.debian.org (full text, mbox):

From: Jelmer Vernooij <jelmer@vernstok.nl>
To: 598562-done@bugs.debian.org
Subject: Fixed
Date: Thu, 30 Sep 2010 09:14:11 +0200
Version: 0.30.3-2

-- 




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>:
Bug#598562; Package evolution-mapi. (Sun, 03 Oct 2010 03:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Javier Vasquez <j.e.vasquez.v@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>. (Sun, 03 Oct 2010 03:45:03 GMT) Full text and rfc822 format available.

Message #15 received at 598562@bugs.debian.org (full text, mbox):

From: Javier Vasquez <j.e.vasquez.v@gmail.com>
To: 598562@bugs.debian.org
Subject: evolution-mapi can't be installed
Date: Sat, 2 Oct 2010 21:43:16 -0600
Well, there are several dependencies upon experimental, but they can
be overcome, :-)

The problem about libgtkhtml-editor0 and libgtkhtml3.14-19 are to be
fixed though.  I had to edit 3 files:

/var/lib/apt/lists/<mirror>_debian_dists_unstable_main_binary-amd64_Packages
/var/lib/dpkg/status
/var/lib/dpkg/available

Look in those for the dependencies for evolution-mapi, and in all of
them where it said ">= 1:3.30.2" for those 2 packages, I just used
instead ">= 3.30.2", since the latest version for those 2 packages is
"3.30.3-1" even higher than the one required, this solves the issue...

It might be that "1:" was just a typo...  Once you modify those files,
you can install it without problems, except by the fact you'll have to
solve dependencies coming from experimental, which is not a big deal
any ways...

I have it installed, but haven't tested it yet...

-- 
Javier.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>:
Bug#598562; Package evolution-mapi. (Sun, 03 Oct 2010 08:57:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>. (Sun, 03 Oct 2010 08:57:06 GMT) Full text and rfc822 format available.

Message #20 received at 598562@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Javier Vasquez <j.e.vasquez.v@gmail.com>, 598562@bugs.debian.org
Subject: Re: [Evolution] Bug#598562: evolution-mapi can't be installed
Date: Sun, 03 Oct 2010 10:55:16 +0200
[Message part 1 (text/plain, inline)]
On sam., 2010-10-02 at 21:43 -0600, Javier Vasquez wrote:
> Well, there are several dependencies upon experimental, but they can
> be overcome, :-)

Well, now it's in unstable...
> 
> The problem about libgtkhtml-editor0 and libgtkhtml3.14-19 are to be
> fixed though.  I had to edit 3 files:
> 
> /var/lib/apt/lists/<mirror>_debian_dists_unstable_main_binary-amd64_Packages
> /var/lib/dpkg/status
> /var/lib/dpkg/available
> 
> Look in those for the dependencies for evolution-mapi, and in all of
> them where it said ">= 1:3.30.2" for those 2 packages, I just used
> instead ">= 3.30.2", since the latest version for those 2 packages is
> "3.30.3-1" even higher than the one required, this solves the issue...

I'm not sure “solve” is the right term when you mess up with your dpkg
database like this.
> 
> It might be that "1:" was just a typo...

Actually it's an epoch, and I have *no* idea where it comes from, since
nothing (nor in gtkhtml nor evolution-mapi sources have it).

Cheers,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>:
Bug#598562; Package evolution-mapi. (Sun, 03 Oct 2010 09:15:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Evolution Maintainers <pkg-evolution-maintainers@lists.alioth.debian.org>. (Sun, 03 Oct 2010 09:15:13 GMT) Full text and rfc822 format available.

Message #25 received at 598562@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Javier Vasquez <j.e.vasquez.v@gmail.com>, 598562@bugs.debian.org
Cc: jelmer@debian.org, control@bugs.debian.org
Subject: Re: [Evolution] Bug#598562: evolution-mapi can't be installed
Date: Sun, 03 Oct 2010 11:14:34 +0200
[Message part 1 (text/plain, inline)]
reassign 598562 release.debian.org
retitle 598562 nmu: evolution-mapi_0.30.3-2
thanks

On sam., 2010-10-02 at 21:43 -0600, Javier Vasquez wrote:
> Look in those for the dependencies for evolution-mapi, and in all of
> them where it said ">= 1:3.30.2" for those 2 packages, I just used
> instead ">= 3.30.2", since the latest version for those 2 packages is
> "3.30.3-1" even higher than the one required, this solves the issue... 

Ok, it seems the build was done in a dirty chroot or something, with
wrong gtkhtml installed, since it's the case only on amd64. A binNMU
should fix it.

For RT:

nmu evolution-mapi_0.30.3-2 . amd64 . -m "rebuild with correct gtkhtml3.14 version"

Thanks!
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Bug reassigned from package 'evolution-mapi' to 'release.debian.org'. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Sun, 03 Oct 2010 09:15:14 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions evolution-mapi/0.30.3-2. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Sun, 03 Oct 2010 09:15:15 GMT) Full text and rfc822 format available.

Bug No longer marked as fixed in versions 0.30.3-2. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Sun, 03 Oct 2010 09:15:16 GMT) Full text and rfc822 format available.

Changed Bug title to 'nmu: evolution-mapi_0.30.3-2' from 'evolution-mapi can't be installed' Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Sun, 03 Oct 2010 09:15:17 GMT) Full text and rfc822 format available.

Did not alter fixed versions and reopened. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 03 Oct 2010 09:21:14 GMT) Full text and rfc822 format available.

Bug closed, send any further explanations to Iñigo Martínez <inigo.martinez@ikusi.com> Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sun, 03 Oct 2010 09:27:04 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 01 Nov 2010 07:33:37 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 12:57:39 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.