Debian Bug report logs - #594898
gnome-system-tools: In kfreebsd Network Administration Tool says the platform is not supported.

version graph

Package: system-tools-backends; Maintainer for system-tools-backends is Jose Carlos Garcia Sogo <jsogo@debian.org>; Source for system-tools-backends is src:system-tools-backends.

Reported by: Michael Dorrington <michael.dorrington@gmail.com>

Date: Mon, 30 Aug 2010 14:12:01 UTC

Severity: normal

Tags: patch

Fixed in version system-tools-backends/2.10.1-1

Done: Josselin Mouette <joss@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, debian-bsd@lists.debian.org, Jose Carlos Garcia Sogo <jsogo@debian.org>:
Bug#594898; Package gnome-system-tools. (Mon, 30 Aug 2010 14:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Dorrington <michael.dorrington@gmail.com>:
New Bug report received and forwarded. Copy sent to debian-bsd@lists.debian.org, Jose Carlos Garcia Sogo <jsogo@debian.org>. (Mon, 30 Aug 2010 14:12:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michael Dorrington <michael.dorrington@gmail.com>
To: submit@bugs.debian.org
Subject: gnome-system-tools: In kfreebsd Network Administration Tool says the platform is not supported.
Date: Mon, 30 Aug 2010 15:09:53 +0100
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256


Package: gnome-system-tools
Version: 2.30.2-1
Severity: normal
User: debian-bsd@lists.debian.org
Usertags: kfreebsd
X-Debbugs-CC: debian-bsd@lists.debian.org


In kfreebsd, launching the Gnome Network Administration Tool by going to
System->Administration->Network pops up a message saying:

 Unsupported platform

 The platform you are running
 is not supported by this tool

 If you know for sure that it works like one of the platforms
 listed below, you can select that and continue. Note,
 however, that this might damage the system configuration
 or downright cripple your computer.

 Arch Linux
 Ark Linux
 ...
 Debian GNU/Linux
 ...
 FreeBSD
  ...
  8
 Gentoo Linux
 ...

Not sure which, if any, is the 'correct' answer.

Once answered this is question isn't asked again.

- -- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: kfreebsd-i386 (i686)

Kernel: kFreeBSD 8.1-1-686
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-system-tools depends on:
ii  gconf2                        2.28.1-3   GNOME configuration
database syste
ii  libatk1.0-0                   1.30.0-1   The ATK accessibility toolkit
ii  libc0.1                       2.11.2-2   Embedded GNU C Library:
Shared lib
ii  libcairo2                     1.8.10-4   The Cairo 2D vector
graphics libra
ii  libdbus-1-3                   1.2.24-3   simple interprocess
messaging syst
ii  libfontconfig1                2.8.0-2.1  generic font configuration
library
ii  libfreetype6                  2.4.2-1    FreeType 2 font engine,
shared lib
ii  libgconf2-4                   2.28.1-3   GNOME configuration
database syste
ii  libglib2.0-0                  2.24.1-1   The GLib library of C routines
ii  libgtk2.0-0                   2.20.1-1   The GTK+ graphical user
interface
ii  liboobs-1-4                   2.30.1-1   GObject based interface to
system-
ii  libpango1.0-0                 1.28.1-1   Layout and rendering of
internatio
ii  libpolkit-gobject-1-0         0.96-2     PolicyKit Authorization API
ii  libpolkit-gtk-1-0             0.96-2     PolicyKit GTK+ API
ii  perl                          5.10.1-14  Larry Wall's Practical
Extraction
ii  policykit-1-gnome             0.96-2     GNOME authentication agent
for Pol
ii  system-tools-backends         2.10.0-2   System Tools to manage
computer co

Versions of packages gnome-system-tools recommends:
ii  gnome-control-center          1:2.30.1-2 utilities to configure the
GNOME d

Versions of packages gnome-system-tools suggests:
pn  ntp                           <none>     (no description available)

- -- no debconf information
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBCAAGBQJMe7uxAAoJENdybD6q+OPv+DsP/iKdfYQOU7Vzngjk0iK3o3r1
iLADLxv7HZ6NFcDTFDFtFsVkPR/ALllU6vDBhMlEafo0yzNVJ1DACxBtBrYlCrcR
5TaSPyEmXstzNxiK+uFjnRwMid8NTrG7Qjg9vNJIeXPXpbXjj9NDHhlI0l9kObeZ
YCveyHspetH07ivGC3+xikCJPMUhENoCREZkqN59fq2UBihrMNIQU0vHkx2OSZQx
1U9kMvpsw2tymBFIlaElzCJTtJt96UmYHe+ZtoeTNGK4p9zPq8tlByrtNeIZmita
5TcugslKF7NTDcjocFPqUh4C08s2Aum8zFpCCnJHXJSM6vpLJVzSbsJG2a28iGKD
HAIglaAQUr6Is4743cEOoxb5Uuzoju0GO+dKJnyn8PgdKNztlby3mCpXH2ARXlEV
nTGwG9YiMgQYOmxLp7/HYCFMd7lMJLl5iMV0jeG/HuCJyMuIpJmf3IInexQ5FSQB
khhM4gMAtdCeb4o1cclq/PzsY04MkI7Sechu8+UJ7SqToniHYKEO3fiGW38EqFiY
USwammMmNx6DqZ1iDk1nVbp6kjDFTOmM7T9JVT42mnZwGRd4S//BRUlErFXm5gR9
R2Gq1lRcjy0drtKQCyY1bHpI1DoDAA0Pr0rvQ6hDdIsR+lNJVp6kSbumD7nMIJWu
mofTXb5UfnezaArzXG2B
=7bIO
-----END PGP SIGNATURE-----




Bug reassigned from package 'gnome-system-tools' to 'system-tools-backends'. Request was from Gonéri Le Bouder <goneri@rulezlan.org> to control@bugs.debian.org. (Thu, 02 Sep 2010 14:54:02 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions gnome-system-tools/2.30.2-1. Request was from Gonéri Le Bouder <goneri@rulezlan.org> to control@bugs.debian.org. (Thu, 02 Sep 2010 14:54:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Jose Carlos Garcia Sogo <jsogo@debian.org>:
Bug#594898; Package system-tools-backends. (Thu, 02 Sep 2010 14:57:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gonéri Le Bouder <goneri@rulezlan.org>:
Extra info received and forwarded to list. Copy sent to Jose Carlos Garcia Sogo <jsogo@debian.org>. (Thu, 02 Sep 2010 14:57:08 GMT) Full text and rfc822 format available.

Message #14 received at 594898@bugs.debian.org (full text, mbox):

From: Gonéri Le Bouder <goneri@rulezlan.org>
To: 594898@bugs.debian.org
Cc: Michael Dorrington <michael.dorrington@gmail.com>
Subject: Re: Bug#594898: gnome-system-tools: In kfreebsd Network Administration Tool says the platform is not supported.
Date: Thu, 2 Sep 2010 16:49:19 +0200
[Message part 1 (text/plain, inline)]
On Mon, Aug 30, 2010 at 03:09:53PM +0100, Michael Dorrington wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> 
> Package: gnome-system-tools
> Version: 2.30.2-1
> Severity: normal
> User: debian-bsd@lists.debian.org
> Usertags: kfreebsd
> X-Debbugs-CC: debian-bsd@lists.debian.org
> 
> 
> In kfreebsd, launching the Gnome Network Administration Tool by going to
> System->Administration->Network pops up a message saying:
> 
>  Unsupported platform

Hi,

I reasigned the bug to system-tools-backends.
I attached the patch.

Best regards,

     Gonéri
[kfreebsd.diff (text/x-diff, attachment)]
[signature.asc (application/pgp-signature, inline)]

Added tag(s) patch. Request was from Gonéri Le Bouder <goneri@rulezlan.org> to control@bugs.debian.org. (Thu, 02 Sep 2010 14:57:10 GMT) Full text and rfc822 format available.

Reply sent to Josselin Mouette <joss@debian.org>:
You have taken responsibility. (Tue, 19 Oct 2010 23:18:08 GMT) Full text and rfc822 format available.

Notification sent to Michael Dorrington <michael.dorrington@gmail.com>:
Bug acknowledged by developer. (Tue, 19 Oct 2010 23:18:08 GMT) Full text and rfc822 format available.

Message #21 received at 594898-close@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: 594898-close@bugs.debian.org
Subject: Bug#594898: fixed in system-tools-backends 2.10.1-1
Date: Tue, 19 Oct 2010 23:15:09 +0000
Source: system-tools-backends
Source-Version: 2.10.1-1

We believe that the bug you reported is fixed in the latest version of
system-tools-backends, which is due to be installed in the Debian FTP archive:

system-tools-backends-dev_2.10.1-1_all.deb
  to main/s/system-tools-backends/system-tools-backends-dev_2.10.1-1_all.deb
system-tools-backends_2.10.1-1.debian.tar.gz
  to main/s/system-tools-backends/system-tools-backends_2.10.1-1.debian.tar.gz
system-tools-backends_2.10.1-1.dsc
  to main/s/system-tools-backends/system-tools-backends_2.10.1-1.dsc
system-tools-backends_2.10.1-1_amd64.deb
  to main/s/system-tools-backends/system-tools-backends_2.10.1-1_amd64.deb
system-tools-backends_2.10.1.orig.tar.gz
  to main/s/system-tools-backends/system-tools-backends_2.10.1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 594898@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Josselin Mouette <joss@debian.org> (supplier of updated system-tools-backends package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 20 Oct 2010 00:36:37 +0200
Source: system-tools-backends
Binary: system-tools-backends system-tools-backends-dev
Architecture: source all amd64
Version: 2.10.1-1
Distribution: unstable
Urgency: low
Maintainer: Jose Carlos Garcia Sogo <jsogo@debian.org>
Changed-By: Josselin Mouette <joss@debian.org>
Description: 
 system-tools-backends - System Tools to manage computer configuration -- scripts
 system-tools-backends-dev - System Tools to manage computer configuration -- development file
Closes: 594898
Changes: 
 system-tools-backends (2.10.1-1) unstable; urgency=low
 .
   * New upstream bugfix release.
   * 01_kfreebsd.diff: add kfreebsd support. Closes: #594898.
Checksums-Sha1: 
 e3669188aeff737c928638cee1cc040954325f2e 1729 system-tools-backends_2.10.1-1.dsc
 b5108ee37cf2b10f1917c9302bee9437b0c5169c 580528 system-tools-backends_2.10.1.orig.tar.gz
 79cec08e9a4fc2afcc6dd7a02450c8d07f350940 8501 system-tools-backends_2.10.1-1.debian.tar.gz
 cb1408e45a5bd4693233972378334c756da53bf2 81790 system-tools-backends-dev_2.10.1-1_all.deb
 7f2717c22cc3248fbaf0508af1e5801c2fcee747 199818 system-tools-backends_2.10.1-1_amd64.deb
Checksums-Sha256: 
 670bdc71fb54298c8a3c8dc9203a5a43544481d7c481a868bcd411767f0f3fde 1729 system-tools-backends_2.10.1-1.dsc
 2f740c99c8cb99226e20cf11ecfcb7f07b74f84d3c07408b72b2f97fc587fee7 580528 system-tools-backends_2.10.1.orig.tar.gz
 0d01bf9f918c46c4cbefdae178902e0df74e5ab5b171050fdd45385b053f4703 8501 system-tools-backends_2.10.1-1.debian.tar.gz
 f04a22df3cc4b3ea8d2d76671347b1d038c4cf4909603a90b9984044e707b281 81790 system-tools-backends-dev_2.10.1-1_all.deb
 4f5cf2870f2a4a6445d7e85654bd87a1711590917e4da8875438581c654a9f37 199818 system-tools-backends_2.10.1-1_amd64.deb
Files: 
 976888ff2d7be9f3eb8d9e3a28fce355 1729 admin optional system-tools-backends_2.10.1-1.dsc
 cf633d333c4a3dc67414056517e58941 580528 admin optional system-tools-backends_2.10.1.orig.tar.gz
 6ec4fa448a382fff26c31ae81491454d 8501 admin optional system-tools-backends_2.10.1-1.debian.tar.gz
 0017e241baaccf8b76c8b353a927c7f2 81790 devel optional system-tools-backends-dev_2.10.1-1_all.deb
 737cf4da8e5691334151b4e97588d069 199818 admin optional system-tools-backends_2.10.1-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iD8DBQFMvh7qrSla4ddfhTMRAv02AJ9Q711bzuHs/KS1inDko2ANEe3pOgCgg4Nm
S3qg3noy+3UGmR7ffjPVTYc=
=+6bs
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 27 Nov 2010 07:36:58 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 07:13:25 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.