Debian Bug report logs - #594490
Dodument new apt-get is compatible with aptitude autoinstall etc.

version graph

Package: debian-reference; Maintainer for debian-reference is Osamu Aoki <osamu@debian.org>; Source for debian-reference is src:debian-reference.

Reported by: Sergiy Kolesnikov <skstudio@gmx.de>

Date: Thu, 26 Aug 2010 11:48:01 UTC

Severity: important

Found in version debian-reference/2.43

Fixed in version debian-reference/2.44

Done: Osamu Aoki <osamu@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Osamu Aoki <osamu@debian.org>:
Bug#594490; Package debian-reference. (Thu, 26 Aug 2010 11:48:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sergiy Kolesnikov <skstudio@gmx.de>:
New Bug report received and forwarded. Copy sent to Osamu Aoki <osamu@debian.org>. (Thu, 26 Aug 2010 11:48:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sergiy Kolesnikov <skstudio@gmx.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: debian-reference: aptitude is recommended but apt-get is used throughout the document
Date: Thu, 26 Aug 2010 13:45:19 +0200
Package: debian-reference
Version: 2.43
Severity: important

Hi,

the reference in lenny (v 2.24) states: "Although it is now safe to mix different 
package tools on the Debian system, it is best to continue using aptitude as 
much as possible."  Many examples in the lenny's version use aptitude.  
aptaitude was also said to be the preferred package management tool since etch.

In the current version (2.43) most of the examples use apt-get.  It is confusing 
because:
1. Since etch users were told to use aptitude instead of apt-get;
2. It is not mentioned, what is the preferred package management tool for now;
3. It is not mentioned, if it is still safe to mix both tools.

I don't know. what was the reason for switching back to apt-get. If it is 
because of the three bugs mentioned in section 2.2.1, then bugs #411123 and 
#514930 has been fixed already and the bug #570377 is tagged Severity: normal.  
Besides, the last bug appeared in a mixed testing/unstable system and has to do 
with dependencies, so it is not clear, if it is aptitude's fault at all.

Regards,
Sergiy

-- System Information:
Debian Release: 5.0.5
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-bpo.2-686 (SMP w/2 CPU cores)
Locale: LANG=uk_UA.UTF-8, LC_CTYPE=uk_UA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash




Reply sent to Osamu Aoki <osamu@debian.org>:
You have taken responsibility. (Thu, 26 Aug 2010 12:45:07 GMT) Full text and rfc822 format available.

Notification sent to Sergiy Kolesnikov <skstudio@gmx.de>:
Bug acknowledged by developer. (Thu, 26 Aug 2010 12:45:07 GMT) Full text and rfc822 format available.

Message #10 received at 594490-done@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: Sergiy Kolesnikov <skstudio@gmx.de>, 594490-done@bugs.debian.org
Subject: Re: Bug#594490: debian-reference: aptitude is recommended but apt-get is used throughout the document
Date: Thu, 26 Aug 2010 21:43:02 +0900
Hi,

On Thu, Aug 26, 2010 at 01:45:19PM +0200, Sergiy Kolesnikov wrote:
> Package: debian-reference
> Version: 2.43
> Severity: important
> 
> Hi,
> 
> the reference in lenny (v 2.24) states: "Although it is now safe to mix different 
> package tools on the Debian system, it is best to continue using aptitude as 
> much as possible."  Many examples in the lenny's version use aptitude.  
> aptaitude was also said to be the preferred package management tool since etch.

Please note Release note is going through similar changes.

I use apt-get for installation related and global upgrade related
situation for ROBUSTNESS.

I use aptitude daily.

I really mean "as much as possible."  When it is required, use apt-get!
 
> In the current version (2.43) most of the examples use apt-get.  It is confusing 
> because:
> 1. Since etch users were told to use aptitude instead of apt-get;
> 2. It is not mentioned, what is the preferred package management tool for now;

Any tool you like.  This reference is not about picking "best" package.

> 3. It is not mentioned, if it is still safe to mix both tools.

There are minor complication.  This is tutorial document.  I am not
going to describe corner case bugs.  At the end, it is you to decide
based on the "current" situation which I can not guess while wrting.

> I don't know. what was the reason for switching back to apt-get. 

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=411280

> If it is 
> because of the three bugs mentioned in section 2.2.1, then bugs #411123 and 
> #514930 has been fixed already and the bug #570377 is tagged Severity: normal.  

These are just illustrating examples.  This has been plaguing Debian a
while and I do not expect things change much since aptitude is much more
complicated tool.

> Besides, the last bug appeared in a mixed testing/unstable system and has to do 
> with dependencies, so it is not clear, if it is aptitude's fault at all.

I am not arguing on this point.  Several prominent DD were cought with
this bug.  That is enough to judge that this program is sometimes
flakey.

Osamu





Information forwarded to debian-bugs-dist@lists.debian.org, Osamu Aoki <osamu@debian.org>:
Bug#594490; Package debian-reference. (Thu, 26 Aug 2010 17:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sergiy Kolesnikov <skstudio@gmx.de>:
Extra info received and forwarded to list. Copy sent to Osamu Aoki <osamu@debian.org>. (Thu, 26 Aug 2010 17:39:05 GMT) Full text and rfc822 format available.

Message #15 received at 594490@bugs.debian.org (full text, mbox):

From: Sergiy Kolesnikov <skstudio@gmx.de>
To: Osamu Aoki <osamu@debian.org>
Cc: 594490@bugs.debian.org
Subject: Re: Bug#594490: debian-reference: aptitude is recommended but apt-get is used throughout the document
Date: Thu, 26 Aug 2010 19:36:56 +0200
Hi Osamu,

Osamu Aoki написав(ла):
>> the reference in lenny (v 2.24) states: "Although it is now safe to mix different 
>> package tools on the Debian system, it is best to continue using aptitude as 
>> much as possible."
> 
> Please note Release note is going through similar changes.
> 
> I use apt-get for installation related and global upgrade related
> situation for ROBUSTNESS.
> 
> I use aptitude daily.
> 
> I really mean "as much as possible."  When it is required, use apt-get!

I use aptitude daily, just like you.  As long as the Reference used 
aptitude in the most examples I had no questions.  But the sentence I 
cited above is missing in the current version of the Reference and the 
most examples are now using apt-get.  Besides, I remember that one was 
told not to mix aptitude and apt-get.  These are the things which 
confused me.  I believe that just putting the cited sentence back to the 
Reference could prevent such a confusion.

The questions about mixing aptitude and apt-get and about aptitude vs. 
apt-get come up over and over again: 
http://lists.debian.org/debian-user/2010/08/msg01387.html
Mentioning in the Debian Reference (in the Chapter 2.2.1 for example) 
that apt-get has improved a lot, that aptitude is not the recommended 
package management tool any more, that one can mix both tools (most of 
the time) safely and referencing the discussion
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=411280
would be really helpful.

Thank you!

-- 
Regards,
Sergiy





Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#594490; Package debian-reference. (Fri, 27 Aug 2010 14:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. (Fri, 27 Aug 2010 14:45:05 GMT) Full text and rfc822 format available.

Message #20 received at 594490@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: Sergiy Kolesnikov <skstudio@gmx.de>
Cc: 594490@bugs.debian.org
Subject: Re: Bug#594490: debian-reference: aptitude is recommended but apt-get is used throughout the document
Date: Fri, 27 Aug 2010 23:39:40 +0900
reopen 594490
retitle 594490 Dodument new apt-get is compatible with aptitude autoinstall etc.
tags 594490 wishlist
thanks

I have been thinking how to improve these text and reduce confusion.
Just stating and closing bug with "I am right" may not be the best
solution.  I also do not want to break too many translation.  I just got
100% Italian and Japanese :-)

On Thu, Aug 26, 2010 at 07:36:56PM +0200, Sergiy Kolesnikov wrote:
> >I really mean "as much as possible."  When it is required, use apt-get!
> 
> I use aptitude daily, just like you.  As long as the Reference used
> aptitude in the most examples I had no questions.  But the sentence
> I cited above is missing in the current version of the Reference and
> the most examples are now using apt-get.  Besides, I remember that
> one was told not to mix aptitude and apt-get.  

I was one of those who advocated not to mix apt-get with aptitude
casually unless absolutely needed.  That is before apt to understand
autoinstall.  Essentially, when apt-get start understanding autoinstall,
the major conflicts between apt-get and aptitude has disapeared.

I just checked if autoinstall by apt will mark them autoinstall in
aptitude.  YES!

> These are the things
> which confused me.  I believe that just putting the cited sentence
> back to the Reference could prevent such a confusion.
> 
> The questions about mixing aptitude and apt-get and about aptitude
> vs. apt-get come up over and over again:
> http://lists.debian.org/debian-user/2010/08/msg01387.html

  echo $package hold | dpkg --set-selection 

This is worth documented in DR.

> Mentioning in the Debian Reference (in the Chapter 2.2.1 for
> example) that apt-get has improved a lot, that aptitude is not the
> recommended package management tool any more, 

I am recommending any tool: apt-get aptitude, update-manager, ... at the
top of chapter 2.

> that one can mix both
> tools (most of the time) safely and referencing the discussion
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=411280
> would be really helpful.

I get some point here.  You can see my post there.

This is certainly quite debatable topic which many people worry the
basis of my assertion.

Let's summarize my TODO:

1. Since I change mind on "Although it is now safe..." (Now removed in
   2.43), I should have some stance statement with pointer to reference
   is good idea.

2. Since hold feature is in dpkg level, it is nice to have example added
   so people know apt-get and aptitude are the same on handling them.
   aptitude only have easy user interface to manupilate these data.

3. autoinstall state data of aptitude was the conflicting point between
   apt-get and aptitude.  The removal of such issues in squeeze may be 
   best documented.

So I reopen and change this to wishlist bug.





Did not alter fixed versions and reopened. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 27 Aug 2010 14:45:07 GMT) Full text and rfc822 format available.

Changed Bug title to 'Dodument new apt-get is compatible with aptitude autoinstall etc.' from 'debian-reference: aptitude is recommended but apt-get is used throughout the document' Request was from Osamu Aoki <osamu@debian.org> to control@bugs.debian.org. (Fri, 27 Aug 2010 14:45:07 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from Osamu Aoki <osamu@debian.org> to control@bugs.debian.org. (Sat, 28 Aug 2010 12:33:07 GMT) Full text and rfc822 format available.

Reply sent to Osamu Aoki <osamu@debian.org>:
You have taken responsibility. (Wed, 22 Sep 2010 17:21:14 GMT) Full text and rfc822 format available.

Notification sent to Sergiy Kolesnikov <skstudio@gmx.de>:
Bug acknowledged by developer. (Wed, 22 Sep 2010 17:21:14 GMT) Full text and rfc822 format available.

Message #31 received at 594490-close@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: 594490-close@bugs.debian.org
Subject: Bug#594490: fixed in debian-reference 2.44
Date: Wed, 22 Sep 2010 17:17:17 +0000
Source: debian-reference
Source-Version: 2.44

We believe that the bug you reported is fixed in the latest version of
debian-reference, which is due to be installed in the Debian FTP archive:

debian-reference-common_2.44_all.deb
  to main/d/debian-reference/debian-reference-common_2.44_all.deb
debian-reference-de_2.44_all.deb
  to main/d/debian-reference/debian-reference-de_2.44_all.deb
debian-reference-en_2.44_all.deb
  to main/d/debian-reference/debian-reference-en_2.44_all.deb
debian-reference-es_2.44_all.deb
  to main/d/debian-reference/debian-reference-es_2.44_all.deb
debian-reference-fr_2.44_all.deb
  to main/d/debian-reference/debian-reference-fr_2.44_all.deb
debian-reference-it_2.44_all.deb
  to main/d/debian-reference/debian-reference-it_2.44_all.deb
debian-reference-ja_2.44_all.deb
  to main/d/debian-reference/debian-reference-ja_2.44_all.deb
debian-reference-pl_2.44_all.deb
  to main/d/debian-reference/debian-reference-pl_2.44_all.deb
debian-reference-pt-br_2.44_all.deb
  to main/d/debian-reference/debian-reference-pt-br_2.44_all.deb
debian-reference-zh-cn_2.44_all.deb
  to main/d/debian-reference/debian-reference-zh-cn_2.44_all.deb
debian-reference-zh-tw_2.44_all.deb
  to main/d/debian-reference/debian-reference-zh-tw_2.44_all.deb
debian-reference_2.44.dsc
  to main/d/debian-reference/debian-reference_2.44.dsc
debian-reference_2.44.tar.gz
  to main/d/debian-reference/debian-reference_2.44.tar.gz
debian-reference_2.44_all.deb
  to main/d/debian-reference/debian-reference_2.44_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 594490@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Osamu Aoki <osamu@debian.org> (supplier of updated debian-reference package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 23 Sep 2010 01:29:18 +0900
Source: debian-reference
Binary: debian-reference-common debian-reference debian-reference-en debian-reference-fr debian-reference-it debian-reference-ja debian-reference-es debian-reference-de debian-reference-pt-br debian-reference-pl debian-reference-zh-tw debian-reference-zh-cn
Architecture: source all
Version: 2.44
Distribution: unstable
Urgency: low
Maintainer: Osamu Aoki <osamu@debian.org>
Changed-By: Osamu Aoki <osamu@debian.org>
Description: 
 debian-reference - metapackage to install (all) translations of Debian Reference
 debian-reference-common - Debian system administration guide, common files
 debian-reference-de - Debian system administration guide, German translation
 debian-reference-en - Debian system administration guide, English original
 debian-reference-es - Debian system administration guide, Spanish translation
 debian-reference-fr - Debian system administration guide, French translation
 debian-reference-it - Debian system administration guide, Italian translation
 debian-reference-ja - Debian system administration guide, Japanese translation
 debian-reference-pl - Debian system administration guide, Polish translation
 debian-reference-pt-br - Debian system administration guide, Portuguese translation
 debian-reference-zh-cn - Debian system administration guide, Chinese(CN) translation
 debian-reference-zh-tw - Debian system administration guide, Chinese(TW) translation
Closes: 593960 594490
Changes: 
 debian-reference (2.44) unstable; urgency=low
 .
   * Fixed wrong markup <package>git-svn</package> etc.
   * Fixed broken table for font types.
   * Added Italian translation with po4a by beatrice.
   * Addressed hold trick with dpkg and mixed use of apt-get/aptitude.
     Closes: #594490
   * Added .htaccess file per Simon Paillard for UTF-8 .txt .
   * Set wheezy as the new testing name. Closes: #593960
   * Updated for the launch of official backports.debian.org.
   * Changed Japanese translation style to use space between CJK and ASCII.
   * Included asciidoc VERSION = '8.2.7' patched for newer Python
     for easy conversion from ascoodoc to XML.
   * Removed listing of removed packages.
   * Updated copyright to 2007-2010.
   * DEP-5 debian/copyright file.
Checksums-Sha1: 
 1005774a07f1bdb1e74757dd182e5385c08ba040 1332 debian-reference_2.44.dsc
 4d6228eba39b744e1eb8e67d44d71bd89f162546 4109310 debian-reference_2.44.tar.gz
 02d27c0e4e43d4b7949a5d37652b526cc23444fb 31102 debian-reference-common_2.44_all.deb
 3192c6d75be798b5b90eb9e10f5a0b1e51f3e2ec 16992 debian-reference_2.44_all.deb
 b5883eb4e2483f0666ba4225d90b27f475e4855d 869648 debian-reference-en_2.44_all.deb
 de8d2c4f241a3f2358ed5dd48adbad7042d33152 1016920 debian-reference-fr_2.44_all.deb
 b1a99a56b3b41321bd34becf6c9a8c0cc34a5b6f 969662 debian-reference-it_2.44_all.deb
 76f7aade70d889a2f6d0b5fd0fa00cfeb3a06b88 1009410 debian-reference-ja_2.44_all.deb
 240b40255466610560296a01073c0c132c4981ad 792270 debian-reference-es_2.44_all.deb
 492f930dfa60ae9d48f88bcc48ce4f3e7fefccf8 745760 debian-reference-de_2.44_all.deb
 2c11fe03ef010ee3c91d998ace37218e77e8d46f 810760 debian-reference-pt-br_2.44_all.deb
 bf86e78f89cc2b5e88e16b8e93de5723e92313cf 856250 debian-reference-pl_2.44_all.deb
 1962595db2eab9dd901cd9aeece3defb9b474c8d 820242 debian-reference-zh-tw_2.44_all.deb
 d6e7bb22f10ae9c3bcbcbeff3fea8602a731b92a 815152 debian-reference-zh-cn_2.44_all.deb
Checksums-Sha256: 
 fefafd3dc6d967fe0f49ee44f9527dcd89f255042e5e732671bc92a66b99e982 1332 debian-reference_2.44.dsc
 8f85d74316b0c9402f8f5b1220c66276dc4d88493e1b34f30e8f16e0a625428a 4109310 debian-reference_2.44.tar.gz
 abe13abe6f44a358a4dab6b3f07c1c988849bc8728d6b685a232e56271f87bb8 31102 debian-reference-common_2.44_all.deb
 0288ea88f2029aad841749e56b4d75dfed50faae57ac426c1b3f4e1f2ab632ca 16992 debian-reference_2.44_all.deb
 56b5e94f5b5f0c266a97e00be1f63039077a957c09cb2e36787993eed7580f0c 869648 debian-reference-en_2.44_all.deb
 df0d83567cc0ce48539eb3cd8038fe8dd16eb030701523bbcf6f6eaaaa483c77 1016920 debian-reference-fr_2.44_all.deb
 700c9e7a0656ec99251f7986dae5041cf3c8316d136af0f741f01f28fede87cc 969662 debian-reference-it_2.44_all.deb
 5ec5ea08ca8a829af3022c1c501dabf107d0a421f5c7405d5f0ca5e0bf37595c 1009410 debian-reference-ja_2.44_all.deb
 b1809e8687034331e1d2e4853c6ccd05d89825a03aac458cae3e4f0880767b29 792270 debian-reference-es_2.44_all.deb
 4911d6c2b62962ece088c33005fc3986f42058c8de4d8fe2d1de72ebec4e53db 745760 debian-reference-de_2.44_all.deb
 b2777c3afa747b4e1fbaaef5143103840eabc96fefa92a651f7460368dd5d221 810760 debian-reference-pt-br_2.44_all.deb
 298e49e5507776e3598059e5794b33221b611e2048a67dd823cf3da63830f89e 856250 debian-reference-pl_2.44_all.deb
 07d8fd15702767881f7b6edbeb2fd4659ce7e706c6060ac972d216f8dd3a55be 820242 debian-reference-zh-tw_2.44_all.deb
 7b499dcde68ee9d3db6ed2ac17c4606c0e623a34ab8b66ba7571c774ac6529fd 815152 debian-reference-zh-cn_2.44_all.deb
Files: 
 c34f1900352861213af4ea4652de851e 1332 doc optional debian-reference_2.44.dsc
 4c1c593cc5a7ed62d327bcf6fb47fe7d 4109310 doc optional debian-reference_2.44.tar.gz
 4150040a511f2366f72f56e16e56a801 31102 doc optional debian-reference-common_2.44_all.deb
 2e94a59a97b58add888d73082b5b7171 16992 doc optional debian-reference_2.44_all.deb
 96dd56658bc2e5dddf783cf0d555023a 869648 doc optional debian-reference-en_2.44_all.deb
 dbf2c1e48cb8c5ac7087e3a3ad5c9e53 1016920 doc optional debian-reference-fr_2.44_all.deb
 4b82f7d093671d008a4da9b4d4259d19 969662 doc optional debian-reference-it_2.44_all.deb
 c9bbef0f6c4538e13159844928513c8d 1009410 doc optional debian-reference-ja_2.44_all.deb
 f5f6033f69fd807f584187fe010d1c7d 792270 doc optional debian-reference-es_2.44_all.deb
 fdd199f7e17dc9f4c9862e6f8e6673ca 745760 doc optional debian-reference-de_2.44_all.deb
 d35f6ae4fadeb2287da9e265d8cc5332 810760 doc optional debian-reference-pt-br_2.44_all.deb
 74ee221c4e6312e7843414b5fe6c12fa 856250 doc optional debian-reference-pl_2.44_all.deb
 59e462cb47d641ff2c6d052a9d7f8753 820242 doc optional debian-reference-zh-tw_2.44_all.deb
 c7a396e149413a5a8499a598c54e8fc1 815152 doc optional debian-reference-zh-cn_2.44_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkyaN/cACgkQ6A/EwagGHzKlFwCfeVYQe2HB9nLEXYc4CC4F3ZYx
6GEAnRbXRev7u64vVF04h9nT6MI6qyuM
=oLbO
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 31 Oct 2010 07:34:59 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 06:45:22 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.