Debian Bug report logs - #593739
partman can't find mtab

version graph

Package: rootskel; Maintainer for rootskel is Debian Install System Team <debian-boot@lists.debian.org>; Source for rootskel is src:rootskel.

Reported by: <ironmark@hispeed.ch>

Date: Fri, 20 Aug 2010 16:45:01 UTC

Severity: normal

Fixed in version rootskel/1.88

Done: Colin Watson <cjwatson@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#593739; Package live-build. (Fri, 20 Aug 2010 16:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to <ironmark@hispeed.ch>:
New Bug report received and forwarded. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Fri, 20 Aug 2010 16:45:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: <ironmark@hispeed.ch>
To: submit@bugs.debian.org
Subject: live-build: GUI-installer fails (partman can't find mtab) s. syslog entiers below
Date: Fri, 20 Aug 2010 18:41:58 +0200
Subject: live-build: GUI-installer fails (partman can't find mtab) s. syslog entiers below
Package: live-build
Version: 2.0~a23-1
Severity: normal

*** Please type your report below this line ***
Hi,

As I am not 100% sure if it is a live-build or maybe a debian-installer-launcher issue please reassign in case I am wrong - thank you for your support and understanding.

I have repeated the install try for GUI-installer (debian-installer-launcher in vbox/live mode) to HDD and have saved install logs.

The following entries say that partman is missing the "mtab" file and finished with status "unconfigured" .. see below (the line like: main-menu[2289]: INFO: Menu item 'partman-base' succeeded but requested to be left unconfigured.)
# ---
Aug 20 13:51:53 partman: No volume groups found
Aug 20 13:51:53 partman:
Aug 20 13:51:53 partman:   Reading all physical volumes.  This may take a while...
Aug 20 13:51:53 partman-lvm:
Aug 20 13:51:53 partman-lvm: No volume groups found
Aug 20 13:51:53 partman-lvm:
Aug 20 13:52:20 partman: mke2fs 1.41.12 (17-May-2010)
Aug 20 13:52:20 partman: ext2fs_check_if_mount
Aug 20 13:52:20 partman: :
Aug 20 13:52:20 partman: Can't check if filesystem is mounted due to missing mtab file
Aug 20 13:52:20 partman:
Aug 20 13:52:20 partman: while determining whether /dev/sda1 is mounted.
Aug 20 13:52:20 partman:
Aug 20 13:52:21 partman: mkfs.ext3
Aug 20 13:52:21 partman: :
Aug 20 13:52:21 partman: Can't check if filesystem is mounted due to missing mtab file
Aug 20 13:52:21 partman:
Aug 20 13:52:21 partman:
Aug 20 13:52:21 partman:        while trying to create journal
Aug 20 13:52:21 partman:
Aug 20 13:52:39 kernel: [  286.259899] btrfs: Unknown symbol zlib_deflateEnd
Aug 20 13:52:39 kernel: [  286.260043] btrfs: Unknown symbol zlib_deflate
Aug 20 13:52:39 kernel: [  286.260043] btrfs: Unknown symbol zlib_deflate_workspacesize
Aug 20 13:52:39 kernel: [  286.261458] btrfs: Unknown symbol zlib_deflateInit2
Aug 20 13:53:14 main-menu[2289]: INFO: Menu item 'partman-base' succeeded but requested to be left unconfigured.
Aug 20 13:53:23 main-menu[2289]: INFO: Menu item 'save-logs' selected
# ---

It is a clear reason however I don't know why "mtab" doesn't exist at this time.

It looks like I didn't include some .udeb packages like "cdebconf-udeb" manually into the live image (or they were not included automatically from live-build):
# ---
# grep " anna.*ignored" syslog 
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (fat-modules): package doesn't exist (ignored)
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (zlib-modules-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (ufsutils-udeb): package doesn't exist (ignored)
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (fat-modules): package doesn't exist (ignored)
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (zlib-modules-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:50:08 anna[3582]: DEBUG: resolver (ufsutils-udeb): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (cdebconf-udeb): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (di-utils): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (kernel-image-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (core-modules-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (fat-modules): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (libdebian-installer4-udeb): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (archdetect): package doesn't exist (ignored)
Aug 20 13:51:47 anna[6395]: DEBUG: resolver (hw-detect): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (cdebconf-udeb): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (di-utils): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (kernel-image-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (core-modules-2.6.32-5-amd64-di): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (fat-modules): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (libdebian-installer4-udeb): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (archdetect): package doesn't exist (ignored)
Aug 20 13:51:49 anna[6489]: DEBUG: resolver (hw-detect): package doesn't exist (ignored)
# --

There were NO suspicious entries in "hardware-summary" or "partman" logs.

regards
Mark


-- Package-specific info:

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages live-build depends on:
ii  debootstrap                   1.0.23     Bootstrap a basic Debian system

Versions of packages live-build recommends:
ii  cpio                          2.11-4     GNU cpio -- a program to manage ar
ii  gettext-base                  0.18.1.1-1 GNU Internationalization utilities
ii  gnu-fdisk                     1.2.4-3+b1 Linux fdisk replacement based on l

Versions of packages live-build suggests:
ii  dosfstools                    3.0.9-1    utilities for making and checking 
ii  fakeroot                      1.14.4-1   Gives a fake root environment
ii  genisoimage                   9:1.1.10-1 Creates ISO-9660 CD-ROM filesystem
pn  memtest86+ | memtest86        <none>     (no description available)
ii  mtools                        4.0.12-1   Tools for manipulating MSDOS files
pn  parted                        <none>     (no description available)
pn  squashfs-tools | genext2fs |  <none>     (no description available)
ii  sudo                          1.7.2p7-1  Provide limited super user privile
pn  syslinux | grub               <none>     (no description available)
pn  uuid-runtime                  <none>     (no description available)
pn  win32-loader                  <none>     (no description available)

-- no debconf information





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#593739; Package live-build. (Sat, 21 Aug 2010 21:51:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to daniel@debian.org:
Extra info received and forwarded to list. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Sat, 21 Aug 2010 21:51:07 GMT) Full text and rfc822 format available.

Message #10 received at 593739@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel@debian.org>
To: ironmark@hispeed.ch
Cc: 593739@bugs.debian.org
Subject: Re: Bug#593739: live-build: GUI-installer fails (partman can't find mtab) s. syslog entiers below
Date: Sat, 21 Aug 2010 23:48:26 +0200
reassign 593739 partman
retitle 593739 partman can't find mtab
thanks

On 08/20/2010 06:41 PM, ironmark@hispeed.ch wrote:
> As I am not 100% sure if it is a live-build or maybe a debian-installer-launcher issue please reassign in case I am wrong

has nothing to do with live or d-i-launcher; reassigning to partman.

-- 
Address:        Daniel Baumann, Burgunderstrasse 3, CH-4562 Biberist
Email:          daniel.baumann@panthera-systems.net
Internet:       http://people.panthera-systems.net/~daniel-baumann/




Bug reassigned from package 'live-build' to 'partman'. Request was from Daniel Baumann <daniel@debian.org> to control@bugs.debian.org. (Sat, 21 Aug 2010 21:51:08 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions live-build/2.0~a23-1. Request was from Daniel Baumann <daniel@debian.org> to control@bugs.debian.org. (Sat, 21 Aug 2010 21:51:09 GMT) Full text and rfc822 format available.

Changed Bug title to 'partman can't find mtab' from 'live-build: GUI-installer fails (partman can't find mtab) s. syslog entiers below' Request was from Daniel Baumann <daniel@debian.org> to control@bugs.debian.org. (Sat, 21 Aug 2010 21:51:10 GMT) Full text and rfc822 format available.

Bug reassigned from package 'partman' to 'rootskel'. Request was from Colin Watson <cjwatson@debian.org> to control@bugs.debian.org. (Sat, 21 Aug 2010 22:42:11 GMT) Full text and rfc822 format available.

Reply sent to Colin Watson <cjwatson@debian.org>:
You have taken responsibility. (Sat, 21 Aug 2010 22:45:03 GMT) Full text and rfc822 format available.

Notification sent to <ironmark@hispeed.ch>:
Bug acknowledged by developer. (Sat, 21 Aug 2010 22:45:03 GMT) Full text and rfc822 format available.

Message #23 received at 593739-done@bugs.debian.org (full text, mbox):

From: Colin Watson <cjwatson@debian.org>
To: 593739-done@bugs.debian.org
Cc: ironmark@hispeed.ch, Daniel Baumann <daniel@debian.org>
Subject: Re: Bug#593739: live-build: GUI-installer fails (partman can't find mtab) s. syslog entiers below
Date: Sat, 21 Aug 2010 23:43:14 +0100
Source: rootskel
Source-Version: 1.88

On Sat, Aug 21, 2010 at 11:48:26PM +0200, Daniel Baumann wrote:
> On 08/20/2010 06:41 PM, ironmark@hispeed.ch wrote:
> > As I am not 100% sure if it is a live-build or maybe a
> > debian-installer-launcher issue please reassign in case I am wrong
> 
> has nothing to do with live or d-i-launcher; reassigning to partman.

I fixed this yesterday in rootskel.

rootskel (1.88) unstable; urgency=low

  * Skip the creation of /etc/mtab on Hurd, rather than on everything but
    Hurd.  Thanks to Trent W. Buck for the report.

 -- Colin Watson <cjwatson@debian.org>  Fri, 20 Aug 2010 13:05:47 +0100

Cheers,

-- 
Colin Watson                                       [cjwatson@debian.org]




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 19 Sep 2010 07:33:13 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 25 08:55:08 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.