Debian Bug report logs - #593085
libdataobjects-ruby1.9.1: load error with ruby 1.9.2

version graph

Package: libdataobjects-ruby1.9.1; Maintainer for libdataobjects-ruby1.9.1 is Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>; Source for libdataobjects-ruby1.9.1 is src:ruby-dataobjects.

Reported by: Lucas Nussbaum <lucas@lucas-nussbaum.net>

Date: Sun, 15 Aug 2010 11:45:01 UTC

Severity: serious

Found in version libdataobjects-ruby/0.10.2-1

Fixed in version libdataobjects-ruby/0.10.2-2

Done: Deepak Tripathi <deepak@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Deepak Tripathi <apenguinlinux@gmail.com>:
Bug#593085; Package libdataobjects-ruby1.9.1. (Sun, 15 Aug 2010 11:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lucas Nussbaum <lucas@lucas-nussbaum.net>:
New Bug report received and forwarded. Copy sent to Deepak Tripathi <apenguinlinux@gmail.com>. (Sun, 15 Aug 2010 11:45:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Lucas Nussbaum <lucas@lucas-nussbaum.net>
To: submit@bugs.debian.org
Subject: libdataobjects-ruby1.9.1: load error with ruby 1.9.2
Date: Sun, 15 Aug 2010 13:43:56 +0200
Package: libdataobjects-ruby1.9.1
Version: 0.10.2-1
Severity: serious

Hi,

Loading the library fails with ruby1.9.2:
<internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- addressable/uri (LoadError)
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /usr/lib/ruby/1.9.1/data_objects/uri.rb:1:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from /usr/lib/ruby/1.9.1/data_objects.rb:7:in `<top (required)>'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from <internal:lib/rubygems/custom_require>:29:in `require'
	from -e:1:in `<main>'
-- 
| Lucas Nussbaum
| lucas@lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas@nussbaum.fr             GPG: 1024D/023B3F4F |




Message sent on to Lucas Nussbaum <lucas@lucas-nussbaum.net>:
Bug#593085. (Sat, 21 Aug 2010 07:57:05 GMT) Full text and rfc822 format available.

Message #8 received at 593085-submitter@bugs.debian.org (full text, mbox):

From: Deepak Tripathi <apenguinlinux@gmail.com>
To: 593085-submitter@bugs.debian.org
Subject: libdataobjects-ruby1.9.1: load error with ruby 1.9.2
Date: Sat, 21 Aug 2010 13:25:02 +0530
[Message part 1 (text/plain, inline)]
Hi,

Thanks for reporting bug, I am really sorry for delay, I was on vacation.

By this weekend i will fix this and upload it to pkg-ruby-extras svn.



-- 
Deepak Tripathi
E3 71V3 8Y C063 (We Live By Code)
http://www.gnumonk.com
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#593085; Package libdataobjects-ruby1.9.1. (Fri, 27 Aug 2010 10:39:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Deepak Tripathi <apenguinlinux@gmail.com>:
Extra info received and forwarded to list. (Fri, 27 Aug 2010 10:39:06 GMT) Full text and rfc822 format available.

Message #13 received at 593085@bugs.debian.org (full text, mbox):

From: Deepak Tripathi <apenguinlinux@gmail.com>
To: 593085@bugs.debian.org
Subject: libdataobjects-ruby1.9.1: load error with ruby 1.9.2
Date: Fri, 27 Aug 2010 16:07:31 +0530
Hi,

I have fix this issue and its available in pkg-ruby-extra's svn. once
libaddressable-ruby (dependencies) will get uploaded,I will upload this to archive.



Thanks
-- 
|-----------------------------|
| Deepak Tripathi             |
| irc: irc.debian.org         |
| nick: deepak, gnumonk       |
| web: http://www.gnumonk.com |
|-----------------------------|




Information forwarded to debian-bugs-dist@lists.debian.org, Deepak Tripathi <apenguinlinux@gmail.com>:
Bug#593085; Package libdataobjects-ruby1.9.1. (Sat, 18 Sep 2010 08:54:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lucas Nussbaum <lucas@lucas-nussbaum.net>:
Extra info received and forwarded to list. Copy sent to Deepak Tripathi <apenguinlinux@gmail.com>. (Sat, 18 Sep 2010 08:54:15 GMT) Full text and rfc822 format available.

Message #18 received at 593085@bugs.debian.org (full text, mbox):

From: Lucas Nussbaum <lucas@lucas-nussbaum.net>
To: Deepak Tripathi <apenguinlinux@gmail.com>, 593085@bugs.debian.org
Subject: Re: Bug#593085: libdataobjects-ruby1.9.1: load error with ruby 1.9.2
Date: Sat, 18 Sep 2010 10:06:49 +0200
On 27/08/10 at 16:07 +0530, Deepak Tripathi wrote:
> 
> Hi,
> 
> I have fix this issue and its available in pkg-ruby-extra's svn. once
> libaddressable-ruby (dependencies) will get uploaded,I will upload this to archive.

libaddressable-ruby is currently waiting in NEW. It needs to be accepted
before we can move forward.

- Lucas




Reply sent to Deepak Tripathi <deepak@debian.org>:
You have taken responsibility. (Mon, 18 Oct 2010 17:36:09 GMT) Full text and rfc822 format available.

Notification sent to Lucas Nussbaum <lucas@lucas-nussbaum.net>:
Bug acknowledged by developer. (Mon, 18 Oct 2010 17:36:09 GMT) Full text and rfc822 format available.

Message #23 received at 593085-close@bugs.debian.org (full text, mbox):

From: Deepak Tripathi <deepak@debian.org>
To: 593085-close@bugs.debian.org
Subject: Bug#593085: fixed in libdataobjects-ruby 0.10.2-2
Date: Mon, 18 Oct 2010 17:32:07 +0000
Source: libdataobjects-ruby
Source-Version: 0.10.2-2

We believe that the bug you reported is fixed in the latest version of
libdataobjects-ruby, which is due to be installed in the Debian FTP archive:

libdataobjects-ruby1.8_0.10.2-2_all.deb
  to main/libd/libdataobjects-ruby/libdataobjects-ruby1.8_0.10.2-2_all.deb
libdataobjects-ruby1.9.1_0.10.2-2_all.deb
  to main/libd/libdataobjects-ruby/libdataobjects-ruby1.9.1_0.10.2-2_all.deb
libdataobjects-ruby_0.10.2-2.diff.gz
  to main/libd/libdataobjects-ruby/libdataobjects-ruby_0.10.2-2.diff.gz
libdataobjects-ruby_0.10.2-2.dsc
  to main/libd/libdataobjects-ruby/libdataobjects-ruby_0.10.2-2.dsc
libdataobjects-ruby_0.10.2-2_all.deb
  to main/libd/libdataobjects-ruby/libdataobjects-ruby_0.10.2-2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 593085@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Deepak Tripathi <deepak@debian.org> (supplier of updated libdataobjects-ruby package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 18 Oct 2010 21:45:26 +0530
Source: libdataobjects-ruby
Binary: libdataobjects-ruby1.8 libdataobjects-ruby1.9.1 libdataobjects-ruby
Architecture: source all
Version: 0.10.2-2
Distribution: unstable
Urgency: low
Maintainer: Deepak Tripathi <deepak@debian.org>
Changed-By: Deepak Tripathi <deepak@debian.org>
Description: 
 libdataobjects-ruby - Rewrite Ruby database drivers to conform to a single interface (r
 libdataobjects-ruby1.8 - Rewrite Ruby database drivers to conform to a single interface
 libdataobjects-ruby1.9.1 - Rewrite Ruby database drivers to conform to a single interface
Closes: 593085
Changes: 
 libdataobjects-ruby (0.10.2-2) unstable; urgency=low
 .
   * debian/control
      + added libaddressable-ruby as Depends (Closes: #593085).
      + bumped standard version to 3.9.1 (no changes).
      + removed DM Upload tag.
Checksums-Sha1: 
 51d19c2c28b1c5ab8f1e35fff42063d8d7f1c084 2128 libdataobjects-ruby_0.10.2-2.dsc
 d02e148ec3958c1724da832f0b32542aeeead315 25008 libdataobjects-ruby_0.10.2.orig.tar.gz
 a4fff2b301725929305731c60c3ee3e1efe9c59a 2531 libdataobjects-ruby_0.10.2-2.diff.gz
 c5ebbc2038727b4a24899009c0f7938ad0edc569 22678 libdataobjects-ruby1.8_0.10.2-2_all.deb
 34ae272a601ee77a8c677907e6c52cd324f2a3fb 22692 libdataobjects-ruby1.9.1_0.10.2-2_all.deb
 646c9701567b289a63e36d3ba2884fabb6a16d4e 3012 libdataobjects-ruby_0.10.2-2_all.deb
Checksums-Sha256: 
 ade847cabf052009d2eb93f689aaff875324a5e03ed102235574de1181437825 2128 libdataobjects-ruby_0.10.2-2.dsc
 61416d840fcd395d64ac958e06edd43e1356da52b635a7f5ba4fe8d96806fc70 25008 libdataobjects-ruby_0.10.2.orig.tar.gz
 1bfce9013dd3413465b776f97245bcc6c7374c3fba225331d6a049122efb002c 2531 libdataobjects-ruby_0.10.2-2.diff.gz
 97fb38a0f9bfd8120b066c9ca432e8a0cff4df69244aa5ce55e4f5700662aaa2 22678 libdataobjects-ruby1.8_0.10.2-2_all.deb
 860e00b224da470410b706a9f5838992d51c7c0af24cc41be436e8e589be9ca1 22692 libdataobjects-ruby1.9.1_0.10.2-2_all.deb
 657cb226c103d94130baeab35e6de071cea6ee0141ea1a4058a4127ee82f4db7 3012 libdataobjects-ruby_0.10.2-2_all.deb
Files: 
 9660e30a593c2b92f01d6a8049e5b82e 2128 ruby optional libdataobjects-ruby_0.10.2-2.dsc
 806efcce3e85bf23915da826a6d16311 25008 ruby optional libdataobjects-ruby_0.10.2.orig.tar.gz
 cab8d412283ff49c7b72a5324ab495e5 2531 ruby optional libdataobjects-ruby_0.10.2-2.diff.gz
 47644a80fef806dce443c0a2f83705b3 22678 ruby optional libdataobjects-ruby1.8_0.10.2-2_all.deb
 fa92501d93a24c98b6036b1beac1444c 22692 ruby optional libdataobjects-ruby1.9.1_0.10.2-2_all.deb
 c8a34e65fcc6183f7c2ddc40225ee14d 3012 ruby optional libdataobjects-ruby_0.10.2-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMvIGTAAoJEMTRaBp/IXsBd6sQAI+Pag7hUHw/l5CMOjnffl4s
uHrWGN8F35YwNgmapghhdKjpHMva38j7hyUiR4z66atm8sms94xHI7YEluVdv9Gy
G0haxNN/pcXJTId4P8BGRErclX6wFO0emAT2nFaZMJeriNRgDeaXrhwVKMV4BiAS
QC+KnxkQvNsL09SKEjVrukZkEFdm8lYpuGruvI+sW0K1MimuD+FtnFmQ83LU98nQ
JmFZdgN3Ez1gUIPdbIo6ddN4A2gu305vKaLsxfqVx+/XQr10k7LbeE9cSdoZ2oUI
UvVtcd2PJESyfMsAFImjiW7p4hrFm1NX3q5aX6OPScXOKftnmtcZSF93FLagkDzI
hfgPMoFS27oFj0Ap6+jxUthgHvL9RoaVRrA3VaoZO3Ret84TxRkdMuieCeMXZe+f
/kZJZdLjyvukmhfKn9Lrv/uS/GYe3anrIj+UprfRM32/lNvN0JjFwaeKKGkgsj5z
nh9cmT1r6TJWMdMvjMrxOfjsVU9PCjJFYAZsS4omSyYmW9IBRAw7lc1oz6bum4kV
e96srhy6O4B7+SiLacIRF/bPqGxsYinKwqKLjfr342PFsRijLsRB3r612g2Y0ruB
Az7XmfN7i9P0QKOv3c/ZQMYxGaAeq9xKuiiJjXj6wUidfE0trou72sKF0SaQfioF
qAgpYbqjyBcSKGE5NZXz
=MzIR
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 27 Nov 2010 07:36:06 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 13:38:18 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.