Debian Bug report logs - #592770
Daily build d-i + lenny + GRUB2: "Unable to install GRUB in /dev/sda"

Package: grub-installer; Maintainer for grub-installer is Debian Install System Team <debian-boot@lists.debian.org>; Source for grub-installer is src:grub-installer.

Reported by: "Daniel Richard G." <skunk@iSKUNK.ORG>

Date: Thu, 12 Aug 2010 17:39:01 UTC

Severity: important

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Install System Team <debian-boot@lists.debian.org>:
Bug#592770; Package debian-installer. (Thu, 12 Aug 2010 17:39:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Daniel Richard G." <skunk@iSKUNK.ORG>:
New Bug report received and forwarded. Copy sent to Debian Install System Team <debian-boot@lists.debian.org>. (Thu, 12 Aug 2010 17:39:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Daniel Richard G." <skunk@iSKUNK.ORG>
To: "Debian BTS" <submit@bugs.debian.org>
Subject: Daily build d-i + lenny + GRUB2: "Unable to install GRUB in /dev/sda"
Date: Thu, 12 Aug 2010 13:37:32 -0400
Package: debian-installer
Version: 20100805-15:58
Severity: important

I am attempting to install lenny with GRUB2 using a daily build of d-i.
After being prompted whether or not to install to the MBR, I get a red-
screen error as follows:

    [!!] Configuring grub-pc

    Unable to install GRUB in /dev/sda
    Executing 'grub-install /dev/sda' failed.

    This is a fatal error.

Looking at the log on tty4, I see what appears to be the output of "grub-
install --help", and then

    error: Running 'grub-install --no-floppy --force "/dev/sda"' failed.

The only instance of "grub-install" that I can find is under /target,
and if I invoke that as shown in the log, I get

    Unrecognized option `--force'

If I drop the --force option, I get

    /target/usr/sbin/grub-install: .: line 121: can't open '/usr/lib/grub/update-grub_lib'




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install System Team <debian-boot@lists.debian.org>:
Bug#592770; Package debian-installer. (Mon, 24 Jan 2011 10:48:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to tajuzpoczta <tajuzpoczta@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Install System Team <debian-boot@lists.debian.org>.

Your message did not contain a Subject field. They are recommended and useful because the title of a $gBug is determined using this field. Please remember to include a Subject field in your messages in future.

(Mon, 24 Jan 2011 10:48:07 GMT) Full text and rfc822 format available.


Message #10 received at 592770@bugs.debian.org (full text, mbox):

From: tajuzpoczta <tajuzpoczta@gmail.com>
To: 592770@bugs.debian.org
Date: Mon, 24 Jan 2011 11:44:47 +0100
I had have this same problem, when I used kernel from testing, not from
Lenny to netboot.




Bug reassigned from package 'debian-installer' to 'grub-installer'. Request was from Miguel Figueiredo <elmig@debianpt.org> to control@bugs.debian.org. (Tue, 25 Jan 2011 22:18:51 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions 20100805-15:58. Request was from Miguel Figueiredo <elmig@debianpt.org> to control@bugs.debian.org. (Tue, 25 Jan 2011 22:18:52 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 18:40:02 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.