Debian Bug report logs - #587380
debconf-set-selections: --checkonly issues warning about password db

version graph

Package: debconf; Maintainer for debconf is Debconf Developers <debconf-devel@lists.alioth.debian.org>; Source for debconf is src:debconf.

Reported by: Vagrant Cascadian <vagrant+debianbugs@freegeek.org>

Date: Mon, 28 Jun 2010 02:27:02 UTC

Severity: wishlist

Found in version debconf/1.5.24

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debconf Developers <debconf-devel@lists.alioth.debian.org>:
Bug#587380; Package debconf. (Mon, 28 Jun 2010 02:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Vagrant Cascadian <vagrant+debianbugs@freegeek.org>:
New Bug report received and forwarded. Copy sent to Debconf Developers <debconf-devel@lists.alioth.debian.org>. (Mon, 28 Jun 2010 02:27:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Vagrant Cascadian <vagrant+debianbugs@freegeek.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: debconf-set-selections: --checkonly issues warning about password db
Date: Sun, 27 Jun 2010 19:23:06 -0700
Package: debconf
Version: 1.5.24
Severity: wishlist
File: /usr/bin/debconf-set-selections

when running debconf-set-selections --checkonly as a non-root user, it issues
the following warning:

  debconf-set-selections --checkonly /usr/share/simple-cdd/profiles/default.preseed
  debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

is it possible to check the format of a preseeding file without actually
accessing the debconf password database and issuing a warning?

that would be nice. thanks!

live well,
  vagrant

-- System Information:
Debian Release: 5.0.5
  APT prefers stable
  APT policy: (500, 'stable'), (103, 'testing'), (102, 'unstable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages debconf depends on:
ii  debconf-i18n             1.5.24          full internationalization support 
ii  perl-base                5.10.0-19lenny2 minimal Perl system

Versions of packages debconf recommends:
ii  apt-utils                0.7.20.2+lenny2 APT utility programs

Versions of packages debconf suggests:
ii  debconf-doc           1.5.24             debconf documentation
pn  debconf-utils         <none>             (no description available)
pn  libgnome2-perl        <none>             (no description available)
pn  libnet-ldap-perl      <none>             (no description available)
pn  libqt-perl            <none>             (no description available)
ii  libterm-readline-gnu- 1.17a-2+b1         Perl extension for the GNU Readlin
ii  perl                  5.10.0-19lenny2    Larry Wall's Practical Extraction 
ii  whiptail              0.52.2-11.3+lenny1 Displays user-friendly dialog boxe

-- debconf information excluded




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 25 08:17:44 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.