Debian Bug report logs - #587087
aptitude: Internal error: found 2 (choice -> promotion) mappings for a single choice.

version graph

Package: aptitude; Maintainer for aptitude is Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>; Source for aptitude is src:aptitude.

Reported by: Josh Triplett <josh@joshtriplett.org>

Date: Fri, 25 Jun 2010 06:39:05 UTC

Severity: normal

Found in versions aptitude/0.6.5-1, aptitude/0.6.4-1, aptitude/0.6.3-3.2, aptitude/0.6.3-2, aptitude/0.6.3-3.1, aptitude/0.6.3-3, aptitude/0.6.3-3.2+squeeze1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, josh@joshtriplett.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Fri, 25 Jun 2010 06:39:08 GMT) Full text and rfc822 format available.

Message #3 received at submit@bugs.debian.org (full text, mbox):

From: Josh Triplett <josh@joshtriplett.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: aptitude: Internal error: found 2 (choice -> promotion) mappings for a single choice.
Date: Thu, 24 Jun 2010 23:35:15 -0700
Package: aptitude
Version: 0.6.3-2
Severity: normal

I ran aptitude, and saw a handful of packages to upgrade, including
glibc packages.  I hit + on libc-bin, and several copies of the message
"Internal error: found 2 (choice -> promotion) mappings for a single
choice." appeared near the cursor (ignoring the curses display).  More
appeared if I marked/unmarked libc packages for upgrade.

I've saved a state bundle (46MB bzipped).  Let me know if part or all of
that would help.

- Josh Triplett

-- Package-specific info:
aptitude 0.6.3 compiled at Jun 20 2010 22:12:02
Compiler: g++ 4.4.4
Compiled against:
  apt version 4.8.0
  NCurses version 5.7
  libsigc++ version: 2.2.4.2
  Ept support enabled.
  Gtk+ support disabled.

Current library versions:
  NCurses version: ncurses 5.7.20100313
  cwidget version: 0.5.16
  Apt version: 4.8.0
	linux-vdso.so.1 =>  (0x00007fff931ff000)
	libapt-pkg-libc6.9-6.so.4.8 => /usr/lib/libapt-pkg-libc6.9-6.so.4.8 (0x00007fb8b5309000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0x00007fb8b50b6000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0x00007fb8b4eb0000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0x00007fb8b4be4000)
	libept.so.0 => /usr/lib/libept.so.0 (0x00007fb8b496d000)
	libxapian.so.15 => /usr/lib/libxapian.so.15 (0x00007fb8b4618000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007fb8b4401000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007fb8b4171000)
	libboost_iostreams.so.1.42.0 => /usr/lib/libboost_iostreams.so.1.42.0 (0x00007fb8b3f55000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00007fb8b3d39000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fb8b3a25000)
	libm.so.6 => /lib/libm.so.6 (0x00007fb8b37a2000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007fb8b358c000)
	libc.so.6 => /lib/libc.so.6 (0x00007fb8b322b000)
	libutil.so.1 => /lib/libutil.so.1 (0x00007fb8b3027000)
	libdl.so.2 => /lib/libdl.so.2 (0x00007fb8b2e23000)
	libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x00007fb8b2c12000)
	librt.so.1 => /lib/librt.so.1 (0x00007fb8b2a0a000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fb8b55e7000)
Terminal: xterm
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.34-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6.9 0.7.25.3         Advanced front-end for dpkg
ii  libboost-iostreams1.42. 1.42.0-3         Boost.Iostreams Library
ii  libc6                   2.11.2-1         Embedded GNU C Library: Shared lib
ii  libcwidget3             0.5.16-3         high-level terminal interface libr
ii  libept0                 0.5.30           High-level library for managing De
ii  libgcc1                 1:4.4.4-5        GCC support library
ii  libncursesw5            5.7+20100313-2   shared libraries for terminal hand
ii  libsigc++-2.0-0c2a      2.2.4.2-1        type-safe Signal Framework for C++
ii  libsqlite3-0            3.6.23.1-4       SQLite 3 shared library
ii  libstdc++6              4.4.4-5          The GNU Standard C++ Library v3
ii  libxapian15             1.0.20-2         Search engine library
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages aptitude recommends:
pn  apt-xapian-index              <none>     (no description available)
pn  aptitude-doc-en | aptitude-do <none>     (no description available)
ii  libparse-debianchangelog-perl 1.1.1-2    parse Debian changelogs and output
ii  sensible-utils                0.0.4      Utilities for sensible alternative

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
pn  tasksel                       <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#587087; Package aptitude. (Sun, 27 Jun 2010 17:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. (Sun, 27 Jun 2010 17:33:05 GMT) Full text and rfc822 format available.

Message #8 received at 587087@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Josh Triplett <josh@joshtriplett.org>, 587087@bugs.debian.org
Subject: Re: Bug#587087: aptitude: Internal error: found 2 (choice -> promotion) mappings for a single choice.
Date: Sun, 27 Jun 2010 10:06:51 -0700
On Thu, Jun 24, 2010 at 11:35:15PM -0700, Josh Triplett <josh@joshtriplett.org> was heard to say:
> I ran aptitude, and saw a handful of packages to upgrade, including
> glibc packages.  I hit + on libc-bin, and several copies of the message
> "Internal error: found 2 (choice -> promotion) mappings for a single
> choice." appeared near the cursor (ignoring the curses display).  More
> appeared if I marked/unmarked libc packages for upgrade.
> 
> I've saved a state bundle (46MB bzipped).  Let me know if part or all of
> that would help.

  Yeah, send it along and I'll see what I can do.

  Daniel




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Mon, 26 Jul 2010 13:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Vincent Lefevre <vincent@vinc17.net>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Mon, 26 Jul 2010 13:39:06 GMT) Full text and rfc822 format available.

Message #13 received at 587087@bugs.debian.org (full text, mbox):

From: Vincent Lefevre <vincent@vinc17.net>
To: Debian Bug Tracking System <587087@bugs.debian.org>
Subject: aptitude: Internal error: found 2 (choice -> promotion) mappings for a single choice.
Date: Mon, 26 Jul 2010 15:37:10 +0200
Package: aptitude
Version: 0.6.3-3
Severity: normal

Same problem. It occurred for the libpurple0 upgrade while there
were currently broken packages.

-- Package-specific info:
aptitude 0.6.3 compiled at Jul 10 2010 21:00:20
Compiler: g++ 4.4.4
Compiled against:
  apt version 4.8.0
  NCurses version 5.7
  libsigc++ version: 2.2.4.2
  Ept support enabled.
  Gtk+ support disabled.

Current library versions:
  NCurses version: ncurses 5.7.20100313
  cwidget version: 0.5.16
  Apt version: 4.8.0
	linux-vdso.so.1 =>  (0x00007fff4f9ff000)
	libapt-pkg-libc6.9-6.so.4.8 => /usr/lib/libapt-pkg-libc6.9-6.so.4.8 (0x00007f52a94d0000)
	libncursesw.so.5 => /lib64/libncursesw.so.5 (0x00007f52a927d000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0x00007f52a9077000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0x00007f52a8dab000)
	libept.so.1 => /usr/lib/libept.so.1 (0x00007f52a8b59000)
	libxapian.so.15 => /usr/lib/libxapian.so.15 (0x00007f52a8804000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f52a85ed000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007f52a835d000)
	libboost_iostreams.so.1.42.0 => /usr/lib/libboost_iostreams.so.1.42.0 (0x00007f52a8141000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f52a7f25000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f52a7c11000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f52a798e000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f52a7778000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f52a7417000)
	libutil.so.1 => /lib64/libutil.so.1 (0x00007f52a7213000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f52a700f000)
	libbz2.so.1.0 => /lib64/libbz2.so.1.0 (0x00007f52a6dfe000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f52a6bf6000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f52a97b3000)
Terminal: xterm-debian
$DISPLAY not set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.31-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=POSIX, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6.9 0.7.25.3         Advanced front-end for dpkg
ii  libboost-iostreams1.42. 1.42.0-3+b1      Boost.Iostreams Library
ii  libc6                   2.11.2-2         Embedded GNU C Library: Shared lib
ii  libcwidget3             0.5.16-3         high-level terminal interface libr
ii  libept1                 1.0.3            High-level library for managing De
ii  libgcc1                 1:4.4.4-7        GCC support library
ii  libncursesw5            5.7+20100313-2   shared libraries for terminal hand
ii  libsigc++-2.0-0c2a      2.2.4.2-1        type-safe Signal Framework for C++
ii  libsqlite3-0            3.6.23.1-4       SQLite 3 shared library
ii  libstdc++6              4.4.4-7          The GNU Standard C++ Library v3
ii  libxapian15             1.0.20-2         Search engine library
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages aptitude recommends:
ii  apt-xapian-index              0.38       maintenance tools for a Xapian ind
ii  aptitude-doc-en [aptitude-doc 0.6.3-3    English manual for aptitude, a ter
ii  libparse-debianchangelog-perl 1.1.1-2    parse Debian changelogs and output
ii  sensible-utils                0.0.4      Utilities for sensible alternative

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
ii  tasksel                       2.81       Tool for selecting tasks for insta

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Thu, 05 Aug 2010 08:51:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Javier Barroso <Javier.Barroso@isotrol.com>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Thu, 05 Aug 2010 08:51:05 GMT) Full text and rfc822 format available.

Message #18 received at 587087@bugs.debian.org (full text, mbox):

From: Javier Barroso <Javier.Barroso@isotrol.com>
To: 587087@bugs.debian.org
Subject: Some more info for this bug
Date: Thu, 05 Aug 2010 10:47:32 +0200
While I'm upgrading from lenny to squeeze (libc6 from squeeze and 
aptitude from squeeze but many packages from lenny), I found udev - grub 
- linux-image problem, and trying to solve these problems with 
aptitude-curse I'm reading this message (Internal error: found 2...) 
many times when I press "=" command, for example

Thanks!
PD: (Sorry if this info is irrelevant)




Information forwarded to debian-bugs-dist@lists.debian.org, josh@joshtriplett.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Mon, 06 Sep 2010 17:45:13 GMT) Full text and rfc822 format available.

Message #21 received at 587087@bugs.debian.org (full text, mbox):

From: Josh Triplett <josh@joshtriplett.org>
To: Debian Bug Tracking System <587087@bugs.debian.org>
Subject: Re: Internal error: found 2 (choice -> promotion) mappings for a single choice.
Date: Mon, 06 Sep 2010 10:41:08 -0700
[Message part 1 (text/plain, inline)]
Package: aptitude
Version: 0.6.3-3.1
Severity: normal

Managed to run into this again, this time just by pressing + on
libwebkit-1.0-2 to upgrade it (which won't work right now due to wanting
libgtk2.0-0 (>= 2.21.6) from experimental).

I've attached the state bundle as aptitude-state-bundle.internal-error.2
; if you also want the one from when I originally encountered this bug,
let me know and I can send it as well.

- Josh Triplett

-- Package-specific info:
aptitude 0.6.3 compiled at Aug 26 2010 19:06:44
Compiler: g++ 4.4.5 20100816 (prerelease)
Compiled against:
  apt version 4.10.0
  NCurses version 5.7
  libsigc++ version: 2.2.4.2
  Ept support enabled.
  Gtk+ support disabled.

Current library versions:
  NCurses version: ncurses 5.7.20100313
  cwidget version: 0.5.16
  Apt version: 4.10.0
	linux-vdso.so.1 =>  (0x00007fff493ff000)
	libapt-pkg.so.4.10 => /usr/lib/libapt-pkg.so.4.10 (0x00007f0963ba8000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0x00007f0963955000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0x00007f096374f000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0x00007f0963483000)
	libept.so.1 => /usr/lib/libept.so.1 (0x00007f096322f000)
	libxapian.so.22 => /usr/lib/libxapian.so.22 (0x00007f0962e4e000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f0962c37000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007f09629a1000)
	libboost_iostreams.so.1.42.0 => /usr/lib/libboost_iostreams.so.1.42.0 (0x00007f0962785000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00007f0962569000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f0962255000)
	libm.so.6 => /lib/libm.so.6 (0x00007f0961fd2000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f0961dbc000)
	libc.so.6 => /lib/libc.so.6 (0x00007f0961a5b000)
	libutil.so.1 => /lib/libutil.so.1 (0x00007f0961857000)
	libdl.so.2 => /lib/libdl.so.2 (0x00007f0961653000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x00007f096144e000)
	libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x00007f096123e000)
	librt.so.1 => /lib/librt.so.1 (0x00007f0961036000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f0963ec4000)
Terminal: xterm
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg4.10]    0.8.1            Advanced front-end for dpkg
ii  libboost-iostreams1.42. 1.42.0-4         Boost.Iostreams Library
ii  libc6                   2.11.2-5         Embedded GNU C Library: Shared lib
ii  libcwidget3             0.5.16-3         high-level terminal interface libr
ii  libept1                 1.0.3+b1         High-level library for managing De
ii  libgcc1                 1:4.4.4-13       GCC support library
ii  libncursesw5            5.7+20100313-2   shared libraries for terminal hand
ii  libsigc++-2.0-0c2a      2.2.4.2-1        type-safe Signal Framework for C++
ii  libsqlite3-0            3.7.2-1          SQLite 3 shared library
ii  libstdc++6              4.4.4-13         The GNU Standard C++ Library v3
ii  libxapian22             1.2.3-2          Search engine library
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages aptitude recommends:
pn  apt-xapian-index              <none>     (no description available)
pn  aptitude-doc-en | aptitude-do <none>     (no description available)
ii  libparse-debianchangelog-perl 1.1.1-2.1  parse Debian changelogs and output
ii  sensible-utils                0.0.4      Utilities for sensible alternative

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
pn  tasksel                       <none>     (no description available)

-- no debconf information
[aptitude-state-bundle.internal-error.2 (application/x-bzip2, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Wed, 22 Sep 2010 09:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to grin <grin@grin.hu>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Wed, 22 Sep 2010 09:00:03 GMT) Full text and rfc822 format available.

Message #26 received at 587087@bugs.debian.org (full text, mbox):

From: grin <grin@grin.hu>
To: 587087@bugs.debian.org
Subject: pretty reproduceable, still present
Date: Wed, 22 Sep 2010 10:23:36 +0200
Package: aptitude
Version: 0.6.3-3.1
Severity: normal

This bug is around for a while, and pretty easy to trigger here just by
walking around the conflict resolver trying next ones. Some trigger it,
some doesn't.

I would appreciate, if possible, if the error message would contain a bit
more information abou what conflicts witch what, how, so at least we could
look around in status files or repositories, checking for abnormal dependencies
for example.




Bug Marked as found in versions aptitude/0.6.3-3.2. Request was from Vincent Lefevre <vincent@vinc17.net> to control@bugs.debian.org. (Tue, 26 Oct 2010 20:06:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#587087; Package aptitude. (Tue, 15 Mar 2011 09:31:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Diggory Hardy <diggory.hardy@unibas.ch>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Tue, 15 Mar 2011 09:31:08 GMT) Full text and rfc822 format available.

Message #33 received at 587087@bugs.debian.org (full text, mbox):

From: Diggory Hardy <diggory.hardy@unibas.ch>
To: 587087@bugs.debian.org
Subject: pinning?
Date: Mon, 14 Mar 2011 18:30:29 +0100
(aptitude  0.6.3-3.2)

I ran into this after adding wheezy and sid repositories and configuring pinning with the following preferences file, though not immediately (when trying to upgrade xserver-xorg-input-synaptics):

Package: *
Pin: release n=squeeze
Pin-Priority: 900

Package: *
Pin: release n=wheezy
Pin-Priority: 500

Package: *
Pin: release n=sid
Pin-Priority: 10




Bug Marked as found in versions aptitude/0.6.4-1. Request was from Vincent Lefevre <vincent@vinc17.net> to control@bugs.debian.org. (Sun, 22 May 2011 00:15:03 GMT) Full text and rfc822 format available.

Bug Marked as found in versions aptitude/0.6.5-1. Request was from Vincent Lefevre <vincent@vinc17.net> to control@bugs.debian.org. (Sat, 18 Feb 2012 10:42:01 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>:
Bug#587087; Package aptitude. (Tue, 25 Sep 2012 19:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Miś Uszatek <adres.email@ymail.com>:
Extra info received and forwarded to list. Copy sent to Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>. (Tue, 25 Sep 2012 19:39:03 GMT) Full text and rfc822 format available.

Message #42 received at 587087@bugs.debian.org (full text, mbox):

From: Miś Uszatek <adres.email@ymail.com>
To: 587087@bugs.debian.org
Subject: Re: Internal error: found 2 (choice -> promotion) mappings for a single choice
Date: Tue, 25 Sep 2012 21:33:59 +0200
[Message part 1 (text/plain, inline)]
Package: aptitude
Version: 0.6.3-3.2+squeeze1



The same problem with me, see annex




-- Package-specific info:
aptitude 0.6.3 compiled at Aug 12 2011 21:08:09
Compiler: g++ 4.4.5
Compiled against:
  apt version 4.10.1
  NCurses version 5.7
  libsigc++ version: 2.2.4.2
  Ept support enabled.
  Gtk+ support disabled.

Current library versions:
  NCurses version: ncurses 5.7.20100313
  cwidget version: 0.5.16
  Apt version: 4.10.1
	linux-gate.so.1 =>  (0xb77bd000)
	libapt-pkg.so.4.10 => /usr/lib/libapt-pkg.so.4.10 (0xb76ae000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0xb7668000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb7661000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0xb75a1000)
	libept.so.1 => /usr/lib/libept.so.1 (0xb7550000)
	libxapian.so.22 => /usr/lib/sse2/libxapian.so.22 (0xb7375000)
	libz.so.1 => /usr/lib/libz.so.1 (0xb7361000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb72d4000)
	libboost_iostreams.so.1.42.0 => /usr/lib/libboost_iostreams.so.1.42.0 (0xb72bb000)
	libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb72a2000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb71ad000)
	libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7187000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7169000)
	libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7021000)
	libutil.so.1 => /lib/i686/cmov/libutil.so.1 (0xb701d000)
	libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb7019000)
	libuuid.so.1 => /lib/libuuid.so.1 (0xb7015000)
	libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb7004000)
	librt.so.1 => /lib/i686/cmov/librt.so.1 (0xb6ffa000)
	/lib/ld-linux.so.2 (0xb77be000)
Terminal: xterm
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: 6.0.5
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg4.10]   0.8.10.3+squeeze1 Advanced front-end for dpkg
ii  libboost-iostreams1.42 1.42.0-4          Boost.Iostreams Library
ii  libc6                  2.11.3-3          Embedded GNU C Library: Shared lib
ii  libcwidget3            0.5.16-3          high-level terminal interface libr
ii  libept1                1.0.4             High-level library for managing De
ii  libgcc1                1:4.4.5-8         GCC support library
ii  libncursesw5           5.7+20100313-5    shared libraries for terminal hand
ii  libsigc++-2.0-0c2a     2.2.4.2-1         type-safe Signal Framework for C++
ii  libsqlite3-0           3.7.3-1           SQLite 3 shared library
ii  libstdc++6             4.4.5-8           The GNU Standard C++ Library v3
ii  libxapian22            1.2.3-2           Search engine library
ii  zlib1g                 1:1.2.3.4.dfsg-3  compression library - runtime

Versions of packages aptitude recommends:
pn  apt-xapian-index              <none>     (no description available)
pn  aptitude-doc-en | aptitude-do <none>     (no description available)
pn  libparse-debianchangelog-perl <none>     (no description available)
ii  sensible-utils                0.0.4      Utilities for sensible alternative

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
ii  tasksel                       2.88       Tool for selecting tasks for insta

-- Configuration Files:
/etc/cron.daily/aptitude [Errno 2] Nie ma takiego pliku ani katalogu: u'/etc/cron.daily/aptitude'

-- no debconf information
[aptitude.png (image/png, attachment)]

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 07:04:36 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.