Debian Bug report logs - #585986
wx-common: wx-config tool is missing!

version graph

Package: wx-common; Maintainer for wx-common is wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>; Source for wx-common is src:wxwidgets3.0.

Reported by: Saulo Soares de Toledo <saulotoledo@gmail.com>

Date: Tue, 15 Jun 2010 13:00:01 UTC

Severity: important

Tags: lenny, sid, squeeze, wheezy

Found in version wxwidgets2.8/2.8.10.1-3

Fixed in version wxwidgets2.8/2.8.12.1-4

Done: Olly Betts <olly@survex.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, saulotoledo@gmail.com, wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>:
Bug#585986; Package wx-common. (Tue, 15 Jun 2010 13:00:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Saulo Soares de Toledo <saulotoledo@gmail.com>:
New Bug report received and forwarded. Copy sent to saulotoledo@gmail.com, wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>. (Tue, 15 Jun 2010 13:00:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Saulo Soares de Toledo <saulotoledo@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: wx-common: wx-config tool is missing!
Date: Tue, 15 Jun 2010 09:56:55 -0300
Package: wx-common
Version: 2.8.10.1-3
Severity: important
Tags: squeeze sid lenny

Package wx-common has /usr/share/man/man1/wx-config.1.gz man file, but there
are no wx-config package!

It's needed to compile some applications, like poedit.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=pt_BR.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages wx-common depends on:
ii  libc6                   2.11.1-1         Embedded GNU C Library: Shared lib
ii  libexpat1               2.0.1-7          XML parsing C library - runtime li
ii  libgcc1                 1:4.4.4-3        GCC support library
ii  libstdc++6              4.4.4-3          The GNU Standard C++ Library v3
ii  libwxbase2.8-0          2.8.10.1-3       wxBase library (runtime) - non-GUI
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

wx-common recommends no packages.

wx-common suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>:
Bug#585986; Package wx-common. (Tue, 15 Jun 2010 13:51:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ryan Niebur <ryan@debian.org>:
Extra info received and forwarded to list. Copy sent to wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>. (Tue, 15 Jun 2010 13:51:09 GMT) Full text and rfc822 format available.

Message #10 received at 585986@bugs.debian.org (full text, mbox):

From: Ryan Niebur <ryan@debian.org>
To: Saulo Soares de Toledo <saulotoledo@gmail.com>
Cc: 585986@bugs.debian.org
Subject: Re: [Freewx-maint] Bug#585986: wx-common: wx-config tool is missing!
Date: Tue, 15 Jun 2010 06:48:06 -0700
[Message part 1 (text/plain, inline)]
On Tue, Jun 15, 2010 at 09:56:55AM -0300, Saulo Soares de Toledo wrote:
> Package: wx-common
> Version: 2.8.10.1-3
> Severity: important
> Tags: squeeze sid lenny
> 
> Package wx-common has /usr/share/man/man1/wx-config.1.gz man file, but there
> are no wx-config package!
> 
> It's needed to compile some applications, like poedit.
> 

install libwxgtk2.8-dev.

Cheers,
Ryan

-- 
_________________________
Ryan Niebur
ryanryan52@gmail.com
[signature.asc (application/pgp-signature, inline)]

Added tag(s) wheezy. Request was from Kurt Roeckx <kurt@roeckx.be> to control@bugs.debian.org. (Wed, 16 Feb 2011 19:04:16 GMT) Full text and rfc822 format available.

Reply sent to Olly Betts <olly@survex.com>:
You have taken responsibility. (Tue, 06 Dec 2011 05:39:03 GMT) Full text and rfc822 format available.

Notification sent to Saulo Soares de Toledo <saulotoledo@gmail.com>:
Bug acknowledged by developer. (Tue, 06 Dec 2011 05:39:03 GMT) Full text and rfc822 format available.

Message #17 received at 585986-close@bugs.debian.org (full text, mbox):

From: Olly Betts <olly@survex.com>
To: 585986-close@bugs.debian.org
Subject: Bug#585986: fixed in wxwidgets2.8 2.8.12.1-4
Date: Tue, 06 Dec 2011 05:34:22 +0000
Source: wxwidgets2.8
Source-Version: 2.8.12.1-4

We believe that the bug you reported is fixed in the latest version of
wxwidgets2.8, which is due to be installed in the Debian FTP archive:

python-wxtools_2.8.12.1-4_all.deb
  to main/w/wxwidgets2.8/python-wxtools_2.8.12.1-4_all.deb
python-wxversion_2.8.12.1-4_all.deb
  to main/w/wxwidgets2.8/python-wxversion_2.8.12.1-4_all.deb
wx2.8-doc_2.8.12.1-4_all.deb
  to main/w/wxwidgets2.8/wx2.8-doc_2.8.12.1-4_all.deb
wx2.8-examples_2.8.12.1-4_all.deb
  to main/w/wxwidgets2.8/wx2.8-examples_2.8.12.1-4_all.deb
wx2.8-i18n_2.8.12.1-4_all.deb
  to main/w/wxwidgets2.8/wx2.8-i18n_2.8.12.1-4_all.deb
wxwidgets2.8_2.8.12.1-4.diff.gz
  to main/w/wxwidgets2.8/wxwidgets2.8_2.8.12.1-4.diff.gz
wxwidgets2.8_2.8.12.1-4.dsc
  to main/w/wxwidgets2.8/wxwidgets2.8_2.8.12.1-4.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 585986@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Olly Betts <olly@survex.com> (supplier of updated wxwidgets2.8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 06 Dec 2011 04:08:48 +0000
Source: wxwidgets2.8
Binary: libwxbase2.8-0 libwxbase2.8-dev libwxbase2.8-dbg libwxgtk2.8-0 libwxgtk2.8-dev libwxgtk2.8-dbg python-wxgtk2.8 python-wxgtk2.8-dbg python-wxversion python-wxtools wx-common wx2.8-headers wx2.8-i18n wx2.8-doc wx2.8-examples libwxmsw2.8-dev libwxmsw2.8-dbg wx2.8-headers-msw
Architecture: source amd64 all
Version: 2.8.12.1-4
Distribution: sid
Urgency: low
Maintainer: wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Changed-By: Olly Betts <olly@survex.com>
Description: 
 libwxbase2.8-0 - wxBase library (runtime) - non-GUI support classes of wxWidgets t
 libwxbase2.8-dbg - wxBase library (debug) - non-GUI support classes of wxWidgets too
 libwxbase2.8-dev - wxBase library (development) - non-GUI support classes of wxWidge
 libwxgtk2.8-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
 libwxgtk2.8-dbg - wxWidgets Cross-platform C++ GUI toolkit (GTK+ debug)
 libwxgtk2.8-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
 libwxmsw2.8-dbg - wxMSW mingw32msvc-cross (debug)
 libwxmsw2.8-dev - wxMSW mingw32msvc-cross
 python-wxgtk2.8 - wxWidgets Cross-platform C++ GUI toolkit (wxPython binding)
 python-wxgtk2.8-dbg - wxWidgets Cross-platform C++ GUI toolkit (wxPython binding, debug
 python-wxtools - wxWidgets Cross-platform C++ GUI toolkit (wxPython common files)
 python-wxversion - wxWidgets Cross-platform C++ GUI toolkit (wxPython version select
 wx-common  - wxWidgets Cross-platform C++ GUI toolkit (common support files)
 wx2.8-doc  - wxWidgets Cross-platform C++ GUI toolkit (documentation)
 wx2.8-examples - wxWidgets Cross-platform C++ GUI toolkit (examples)
 wx2.8-headers - wxWidgets Cross-platform C++ GUI toolkit (header files)
 wx2.8-headers-msw - Extra wxWidgets headers for mingw32msvc-cross
 wx2.8-i18n - wxWidgets Cross-platform C++ GUI toolkit (i18n support)
Closes: 585986 645411
Changes: 
 wxwidgets2.8 (2.8.12.1-4) unstable; urgency=low
 .
   * Add support for multiarch same by applying patch from Gregory Hainaut.
     (Closes: #645411)
   * Tighten dependency from wxgtk2.8-dev to wx-common from "Suggests" to
     "Depends" to ensure that the wx-config man page will be installed if
     wx-config is. (Closes: #585986)
   * debian/wxrc-tools.1: "2.6" -> "2.8"; "wxWindows -> wxWidgets".
   * debian/wx-config.1: Fix typos.
Checksums-Sha1: 
 6d9f0627ed397711d64eff01d3bcbda6873684cf 3237 wxwidgets2.8_2.8.12.1-4.dsc
 3a5a1d90676fdb5191a3dd6f4f02111cd96c5308 68011 wxwidgets2.8_2.8.12.1-4.diff.gz
 b6bdd251b68b0614ede3e77ae017e76783bd0b29 90912 python-wxversion_2.8.12.1-4_all.deb
 83c48e25c72d5b66be4c3263d2e267250dab62ab 91892 python-wxtools_2.8.12.1-4_all.deb
 3e74eeca55aed9ae3f60a866e7dc7ff08173d6e0 861262 wx2.8-i18n_2.8.12.1-4_all.deb
 a63e17b078f8df7714a82e714cb204cc0974fcb0 1991150 wx2.8-doc_2.8.12.1-4_all.deb
 798a2ae19437295c770ece6c3b3d791105d5e492 8044696 wx2.8-examples_2.8.12.1-4_all.deb
Checksums-Sha256: 
 ccc4369f8c4d33d53f05333c742444cbeee0f9e7839110928de518c9b9d83dd5 3237 wxwidgets2.8_2.8.12.1-4.dsc
 3ec9d9ab6335f27bca1a5b1faca29047475c55e1d7e7256117ac7e855bbd85c6 68011 wxwidgets2.8_2.8.12.1-4.diff.gz
 6816fe2b938fcc84d08d28c56555e7f397e19a6027145e519c8beb6a2e058e29 90912 python-wxversion_2.8.12.1-4_all.deb
 c1381d7ca69b6b5c3ab40825c483b07579df4d25799ef95679eeb7f76955d8c2 91892 python-wxtools_2.8.12.1-4_all.deb
 f2cd99b8a61b5277b55a572b89c9c124c2c211d17c44aa5a32bcfaeb76cd5f4c 861262 wx2.8-i18n_2.8.12.1-4_all.deb
 ff28341047720666a5cfcaa710696746f1c0de5b78131ae58a56190d94d11a59 1991150 wx2.8-doc_2.8.12.1-4_all.deb
 f8b295331c11ddfba3085b962094f62928c0abca7fcaf26907dd8ef8729d69da 8044696 wx2.8-examples_2.8.12.1-4_all.deb
Files: 
 b20b0c37196fad9b92050ebfa94a63bb 3237 libs optional wxwidgets2.8_2.8.12.1-4.dsc
 f2f58b978a732d942c6a286f67be4e5f 68011 libs optional wxwidgets2.8_2.8.12.1-4.diff.gz
 a2dd6b3816e032d1eddfcd0285c51b6d 90912 python optional python-wxversion_2.8.12.1-4_all.deb
 6078d479b82acee2bed1bdbc7e5c35e0 91892 python optional python-wxtools_2.8.12.1-4_all.deb
 f271c8de87a3b0245dc4bbbbe79da54b 861262 localization optional wx2.8-i18n_2.8.12.1-4_all.deb
 fd5e7cf219ada235d645e204bab71305 1991150 doc optional wx2.8-doc_2.8.12.1-4_all.deb
 0037cfc58c120d3a7b7738c10c5f989f 8044696 devel optional wx2.8-examples_2.8.12.1-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJO3aQoAAoJEBgUewc7rSsHA5EP/Ro+dwVTyxmeI30FBWRcg6o6
Mu0aM2kF+VNatx8eExzosremQSrYrdQb/xBT1ZqEoeZjxPHxZoHMSCeGKqKXPJFl
YgEjbqkGOgez319BUYpzv6LqYXAKkZD2luaCbd18kna1WDVe1S71dQbx+BxxUGwy
p48OYZJYNmaauSH+aKsprYwfjXT1NxT7WtCYxpz1q9ffjbmxmtN70z04ekwq0tw4
mIqwLL3IwuWjIGDD5jV+fcLrGM5sZPbJbSW0HPLoUZaqfBTjSHGWjgdXEsrsCPrC
EmUah8279jbwlCgx7ZatMY1M2N4zvP3HXxePtTK4vfRaWuAbHaIq3SfFg3nPsu0r
LhTqfKwfQ6fyXupV5DMbcnhOaPjSoWgiArby0pjE9XIMsDBwCeGjtwm9gLmprMG6
wK9XwTos3YOToP/B7aDCDsIwnEHXr8FiHMgmwsYG4BmDIgbyznJfQyN5LkG6jS9M
kRSBQF4WT6aeFx9M2pBzDVZteWcV3GDyTV/SrBX9I2Enq3S3p46mJ4Qwqkxud1E4
PlY9xZQKUN/e/qBdMFRSNjVLBUdfkPdJiJMQSsrIWYjBuSdW0O++5PHItoJoXErb
EagjVhiHipY5F+ejAu7iScbEF4IkYfWXPlgH8FJPRZXgbFRBQwc+XxSQGT783/D8
r4pRCy+WpEjApxls1TYH
=q57k
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 04 Jan 2012 07:35:38 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 00:37:33 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.