Debian Bug report logs - #584243
libsaxon-java: should depend on headless JRE

version graph

Package: libsaxon-java; Maintainer for libsaxon-java is Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>; Source for libsaxon-java is src:libsaxon-java.

Reported by: "brian m. carlson" <sandals@crustytoothpaste.net>

Date: Wed, 2 Jun 2010 16:03:01 UTC

Severity: important

Tags: patch

Found in version libsaxon-java/1:6.5.5-6

Fixed in version libsaxon-java/1:6.5.5-7

Done: Niels Thykier <niels@thykier.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#584243; Package libsaxon-java. (Wed, 02 Jun 2010 16:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "brian m. carlson" <sandals@crustytoothpaste.ath.cx>:
New Bug report received and forwarded. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Wed, 02 Jun 2010 16:03:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "brian m. carlson" <sandals@crustytoothpaste.ath.cx>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libsaxon-java: should depend on headless JRE
Date: Wed, 2 Jun 2010 16:01:46 +0000
[Message part 1 (text/plain, inline)]
Package: libsaxon-java
Version: 1:6.5.5-6
Severity: important

libsaxon-java depends on a full JRE.  With OpenJDK, this forces the
installation of libgtk2.0-0, which is not appropriate for a server.
Please instead depend on java2-runtime-headless, since there's no need
for graphical support.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.34-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libsaxon-java depends on:
ii  default-jre [java2-runtime]   1.6-36     Standard Java or Java compatible R
ii  openjdk-6-jre [java2-runtime] 6b18-1.8-2 OpenJDK Java runtime, using Hotspo

libsaxon-java recommends no packages.

Versions of packages libsaxon-java suggests:
ii  libjdom1-java               1.1.1+dfsg-1 lightweight and fast library using
pn  libsaxon-java-doc           <none>       (no description available)

-- no debconf information

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
[signature.asc (application/pgp-signature, inline)]

Changed Bug submitter to '"brian m. carlson" <sandals@crustytoothpaste.net>' from '"brian m. carlson" <sandals@crustytoothpaste.ath.cx>' Request was from "brian m. carlson" <sandals@crustytoothpaste.net> to control@bugs.debian.org. (Thu, 03 Feb 2011 20:52:14 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#584243; Package libsaxon-java. (Fri, 11 Mar 2011 20:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "brian m. carlson" <sandals@crustytoothpaste.net>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Fri, 11 Mar 2011 20:24:03 GMT) Full text and rfc822 format available.

Message #12 received at 584243@bugs.debian.org (full text, mbox):

From: "brian m. carlson" <sandals@crustytoothpaste.net>
To: 584243@bugs.debian.org
Subject: Any progress on Saxon updates?
Date: Fri, 11 Mar 2011 20:20:13 +0000
[Message part 1 (text/plain, inline)]
Bug 584243, which deals with incorrect dependencies, has been open for
nine months with no response.  While it's fine for my laptop to have a
full JRE, it's not fine for my server.  This makes it difficult to use
Jing due to dependency problems.  I've built a custom version of the
package to fix this, but I'd prefer not to have to carry a patched
version of the package if I don't have to.

Is there any progress on fixing the dependencies?  It seems like a
trivial fix, but if necessary, I can supply a patch.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>:
Bug#584243; Package libsaxon-java. (Sat, 12 Mar 2011 00:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "brian m. carlson" <sandals@crustytoothpaste.net>:
Extra info received and forwarded to list. Copy sent to Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>. (Sat, 12 Mar 2011 00:03:03 GMT) Full text and rfc822 format available.

Message #17 received at 584243@bugs.debian.org (full text, mbox):

From: "brian m. carlson" <sandals@crustytoothpaste.net>
To: 584243@bugs.debian.org
Subject: Patch for 584243
Date: Fri, 11 Mar 2011 23:59:23 +0000
[Message part 1 (text/plain, inline)]
tags 584243 + patch
kthxbye

Attached is a (honestly rather trivial) patch to fix 584243.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
[saxon.patch (text/x-diff, attachment)]
[signature.asc (application/pgp-signature, inline)]

Added tag(s) patch. Request was from "brian m. carlson" <sandals@crustytoothpaste.net> to control@bugs.debian.org. (Sat, 12 Mar 2011 00:03:05 GMT) Full text and rfc822 format available.

Reply sent to Niels Thykier <niels@thykier.net>:
You have taken responsibility. (Sat, 12 Mar 2011 09:51:10 GMT) Full text and rfc822 format available.

Notification sent to "brian m. carlson" <sandals@crustytoothpaste.net>:
Bug acknowledged by developer. (Sat, 12 Mar 2011 09:51:10 GMT) Full text and rfc822 format available.

Message #24 received at 584243-close@bugs.debian.org (full text, mbox):

From: Niels Thykier <niels@thykier.net>
To: 584243-close@bugs.debian.org
Subject: Bug#584243: fixed in libsaxon-java 1:6.5.5-7
Date: Sat, 12 Mar 2011 09:47:35 +0000
Source: libsaxon-java
Source-Version: 1:6.5.5-7

We believe that the bug you reported is fixed in the latest version of
libsaxon-java, which is due to be installed in the Debian FTP archive:

libsaxon-java-doc_6.5.5-7_all.deb
  to main/libs/libsaxon-java/libsaxon-java-doc_6.5.5-7_all.deb
libsaxon-java-gcj_6.5.5-7_i386.deb
  to main/libs/libsaxon-java/libsaxon-java-gcj_6.5.5-7_i386.deb
libsaxon-java_6.5.5-7.debian.tar.gz
  to main/libs/libsaxon-java/libsaxon-java_6.5.5-7.debian.tar.gz
libsaxon-java_6.5.5-7.dsc
  to main/libs/libsaxon-java/libsaxon-java_6.5.5-7.dsc
libsaxon-java_6.5.5-7_all.deb
  to main/libs/libsaxon-java/libsaxon-java_6.5.5-7_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 584243@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Niels Thykier <niels@thykier.net> (supplier of updated libsaxon-java package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 12 Mar 2011 09:07:41 +0100
Source: libsaxon-java
Binary: libsaxon-java libsaxon-java-gcj libsaxon-java-doc
Architecture: source all i386
Version: 1:6.5.5-7
Distribution: unstable
Urgency: low
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Niels Thykier <niels@thykier.net>
Description: 
 libsaxon-java - Saxon XSLT Processor
 libsaxon-java-doc - Saxon XSLT Processor's documentation and javadoc
 libsaxon-java-gcj - Saxon XSLT Processor (native code)
Closes: 568347 584243
Changes: 
 libsaxon-java (1:6.5.5-7) unstable; urgency=low
 .
   * Team upload.
   * Removed unneeded JREs from lib package.  Thanks to Brian M.
     Carlson for the report.  (Closes: #584243)
   * Removed Arnaud Vandyck from uploaders.  Thanks for your work
     on this package.
   * Bumped Standards-Versions to 3.9.1
     - Moved the packages to the java section
   * Use javadoc from default-java instead of openjdk-6.
   * Use javahelper to install jar files.
   * Rewrote d/rules as dh7 with overrides.
   * Replaced default-jdk-builddep with default-jdk and
     gcj-native-helper.
   * Added missing ${misc:Depends}.
   * Linked the javadoc against system javadoc.
   * Accepted patch from Brian M. Carlson to make saxon use
     uppercase encoding names.  (Closes: #568347)
   * Converted source package to 3.0 (quilt).
   * Updated the descriptions a bit.
   * Moved javadoc compilation to binary/binary-indep to avoid it
     being build when doing binary-only builds.
Checksums-Sha1: 
 388ce9e7e81a8490e31bd182e1b4c0b43bbcaf21 2083 libsaxon-java_6.5.5-7.dsc
 d4d080dd26107c9b3306fcb5f2e1b858704f2567 8842 libsaxon-java_6.5.5-7.debian.tar.gz
 bd02b531fd5df5734321c8c980ad27b6ddc76436 577106 libsaxon-java_6.5.5-7_all.deb
 f8d3c7a735ab22f2a650caaa7f149d035850b651 608544 libsaxon-java-gcj_6.5.5-7_i386.deb
 94f1ee9cde16655fe9f8b3e5467ebfef8831249c 1297818 libsaxon-java-doc_6.5.5-7_all.deb
Checksums-Sha256: 
 7f9bc8bb6e1fc5610ae56efabc1e2bc068d99dcadfde6313277c1fdb97994a0a 2083 libsaxon-java_6.5.5-7.dsc
 0062ea174b4a6ec6933bcf9b6ccfdab80cb8465d900112fc0af37a1104451f16 8842 libsaxon-java_6.5.5-7.debian.tar.gz
 78ef0440f9183f39a30105f704557d86d72eb82809afa33a6860d4aac67c5ab2 577106 libsaxon-java_6.5.5-7_all.deb
 2ca0cebc3c8261de4d9dead6668a2df532c78e9c26bf8c979c33eb79c14be452 608544 libsaxon-java-gcj_6.5.5-7_i386.deb
 e0718c2ca5a1c98d5461c4f07093289803cb0736366579318456247b6f0b546e 1297818 libsaxon-java-doc_6.5.5-7_all.deb
Files: 
 44a96282af1709dfbfe0adde85f53abe 2083 java optional libsaxon-java_6.5.5-7.dsc
 7273330cc1e9fac2c629ddc5c12592f8 8842 java optional libsaxon-java_6.5.5-7.debian.tar.gz
 b311a25760ddd93afb55f26a521ca419 577106 java optional libsaxon-java_6.5.5-7_all.deb
 95f85a96ca73963bc6f0b59a11761a24 608544 java optional libsaxon-java-gcj_6.5.5-7_i386.deb
 cdaee1685989d79bb8e0d19cce159ebd 1297818 doc optional libsaxon-java-doc_6.5.5-7_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCAAGBQJNez4BAAoJEAVLu599gGRCf+QP/2AWO51sPrklcqNr6ICeYLBh
eW6HNc0XBrMcvKJ/SfjOH/7kEiOUfVXvP49q4QqEtnoYphfT/1qZmtRirLRaNog3
VoH3I4paHUnpRzy+WRCTFNU5+ZRU53QmnzkzSK8Rs84HOxC70M2YUzrlxHgrLek8
VtcOXUnOovau8+3xCyGGCOFyHEms3Xi3ga2JqAbJK+aJkCdk7I8yCFDlH5LpWD+I
A29g0kqF1NE/bx1EytuaGsqslZVwKKY5EjylVu/iyXZ+Mq/L9Osrzt5gDtQdMPO6
o22jjgdt2W+XOTkoD5RIxC9VHcbljbLCJALuY+Mrptj86MlBDDY7hKe0qVjPh7+H
3y3HJxNogkqPf3JNJNB31/1F6ADzH2uNR3i05kxcO135USYAjcf3NCPVKjIaH5fh
vDALmNxYOIURYOknW4Gl/BfaBwaKzoKxWpzP3HbWDj+foLCnQaT4Zqiw/BPd5RzH
i0wU5vN9m0NLHLvezvAXSN7uhn8xO1POSbgHK7DMTZD+TY/oVpCbGUU7xpyWlGkz
nmNcRc1CBa4mA9ynHKivJrKdosFYWQV+jyH+S1Sy+cgP+HDAy6AD5MMJhLhNUu4T
3kpBqJP5foMAxuFvO9WH5RkBVP41JUqjW+ZycXZ+mjcR936VozGENRAkFOsELDG1
UdHjLRTlQaerAoQ3sYAJ
=jWDs
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 30 Apr 2011 08:11:32 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 12:36:30 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.