Debian Bug report logs - #581194
libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution

version graph

Package: libpoe-component-irc-perl; Maintainer for libpoe-component-irc-perl is Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>; Source for libpoe-component-irc-perl is src:libpoe-component-irc-perl.

Reported by: "Debian bug at v.nix.is" <debian-bug@v.nix.is>

Date: Tue, 11 May 2010 14:15:05 UTC

Severity: grave

Tags: fixed-upstream, patch, security, upstream

Fixed in versions libpoe-component-irc-perl/6.32+dfsg-1, libpoe-component-irc-perl/5.84+dfsg-1+lenny1

Done: Ansgar Burchardt <ansgar@43-1.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Tue, 11 May 2010 14:15:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Debian bug at v.nix.is" <debian-bug@v.nix.is>:
New Bug report received and forwarded. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Tue, 11 May 2010 14:15:08 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Debian bug at v.nix.is" <debian-bug@v.nix.is>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution
Date: Tue, 11 May 2010 14:12:05 +0000
Package: libpoe-component-irc-perl
Severity: important
Tags: patch


IRC bots which do not take care of removing carriage returns and line 
feeds from parameters they send to the IRC component are vulnerable to 
this security hole. For example, passing an argument of "foo bar\rQUIT"
to the 'privmsg' handler will cause the client to disconnect from the 
server.

All versions of POE::Component::IRC are affected.

This has been patched upstream (relevent commits: 
http://github.com/bingos/poe-component-irc/compare/d2ead04...675f55cd) 
and included in the latest release (version 6.32).

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'unstable'), (700, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32.12-x86_64-linode12 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash




Added tag(s) upstream, security, and fixed-upstream. Request was from Ansgar Burchardt <ansgar@43-1.org> to control@bugs.debian.org. (Tue, 11 May 2010 14:33:03 GMT) Full text and rfc822 format available.

Severity set to 'grave' from 'important' Request was from Ansgar Burchardt <ansgar@43-1.org> to control@bugs.debian.org. (Tue, 11 May 2010 14:33:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Tue, 11 May 2010 20:06:03 GMT) Full text and rfc822 format available.

Message #12 received at 581194@bugs.debian.org (full text, mbox):

From: pkg-perl-maintainers@lists.alioth.debian.org
To: 581194@bugs.debian.org, 581194-submitter@bugs.debian.org
Subject: Bug in libpoe-component-irc-perl fixed in revision 57822
Date: Tue, 11 May 2010 20:04:15 +0000
tag 581194 + pending
thanks

Some bugs are closed in revision 57822
by Gregor Herrmann (gregoa)

Commit message:

* New upstream release: doesn't allow arbitrary IRC command 
  execution anymore:
  - IRC.pm: Split long messages on \r as well as \n. Plugs a security hole.
  - IRC.pm: Filter out \r in arguments to non-PRIVMSG commands too
  Closes: #581194
* Set urgency to high.




Added tag(s) pending. Request was from pkg-perl-maintainers@lists.alioth.debian.org to control@bugs.debian.org. (Tue, 11 May 2010 20:06:09 GMT) Full text and rfc822 format available.

Message sent on to "Debian bug at v.nix.is" <debian-bug@v.nix.is>:
Bug#581194. (Tue, 11 May 2010 20:06:11 GMT) Full text and rfc822 format available.

Reply sent to gregor herrmann <gregoa@debian.org>:
You have taken responsibility. (Tue, 11 May 2010 21:45:14 GMT) Full text and rfc822 format available.

Notification sent to "Debian bug at v.nix.is" <debian-bug@v.nix.is>:
Bug acknowledged by developer. (Tue, 11 May 2010 21:45:14 GMT) Full text and rfc822 format available.

Message #22 received at 581194-close@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: 581194-close@bugs.debian.org
Subject: Bug#581194: fixed in libpoe-component-irc-perl 6.32+dfsg-1
Date: Tue, 11 May 2010 21:43:33 +0000
Source: libpoe-component-irc-perl
Source-Version: 6.32+dfsg-1

We believe that the bug you reported is fixed in the latest version of
libpoe-component-irc-perl, which is due to be installed in the Debian FTP archive:

libpoe-component-irc-perl_6.32+dfsg-1.debian.tar.gz
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_6.32+dfsg-1.debian.tar.gz
libpoe-component-irc-perl_6.32+dfsg-1.dsc
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_6.32+dfsg-1.dsc
libpoe-component-irc-perl_6.32+dfsg-1_all.deb
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_6.32+dfsg-1_all.deb
libpoe-component-irc-perl_6.32+dfsg.orig.tar.gz
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_6.32+dfsg.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 581194@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
gregor herrmann <gregoa@debian.org> (supplier of updated libpoe-component-irc-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 11 May 2010 22:10:30 +0200
Source: libpoe-component-irc-perl
Binary: libpoe-component-irc-perl
Architecture: source all
Version: 6.32+dfsg-1
Distribution: unstable
Urgency: high
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: gregor herrmann <gregoa@debian.org>
Description: 
 libpoe-component-irc-perl - POE Component for manipulating IRC sessions
Closes: 581194
Changes: 
 libpoe-component-irc-perl (6.32+dfsg-1) unstable; urgency=high
 .
   * New upstream release: doesn't allow arbitrary IRC command
     execution anymore:
     - IRC.pm: Split long messages on \r as well as \n. Plugs a security hole.
     - IRC.pm: Filter out \r in arguments to non-PRIVMSG commands too
     Closes: #581194
   * Set urgency to high.
Checksums-Sha1: 
 875b2e933c6c9d73620e16926f6f2b729033a12e 2480 libpoe-component-irc-perl_6.32+dfsg-1.dsc
 51ed429dfa2a60cb5565957497676ebf4fbbdb3b 225332 libpoe-component-irc-perl_6.32+dfsg.orig.tar.gz
 312fb9f692fc9a088b126b18fbec44da8a1085fe 7035 libpoe-component-irc-perl_6.32+dfsg-1.debian.tar.gz
 ab151970348bdbbfc2dc1dd87838ce86dd0add7c 265498 libpoe-component-irc-perl_6.32+dfsg-1_all.deb
Checksums-Sha256: 
 10f85cc8a68c51f536fbc5838a90ca208f0a1bc0af1815fb1d0ddd1660c18b07 2480 libpoe-component-irc-perl_6.32+dfsg-1.dsc
 855a7bfdba5fbf67901975804bd7d0219c3b47f699b6ea2b29901c175fd71d22 225332 libpoe-component-irc-perl_6.32+dfsg.orig.tar.gz
 1af80aeb26195839960e864c9579470da11a1049436059651518c439c7a462ba 7035 libpoe-component-irc-perl_6.32+dfsg-1.debian.tar.gz
 4b27fe814c0771da26c2cee1b2be8361a5718c52c9cd23278920dea4abd8309b 265498 libpoe-component-irc-perl_6.32+dfsg-1_all.deb
Files: 
 ec1f8f9f6020016405e4a1c078aad4b1 2480 perl optional libpoe-component-irc-perl_6.32+dfsg-1.dsc
 16de5839e84b4d2f9da503398c6e5ffa 225332 perl optional libpoe-component-irc-perl_6.32+dfsg.orig.tar.gz
 1e3869b967b6bf46e90d9d4961667b0a 7035 perl optional libpoe-component-irc-perl_6.32+dfsg-1.debian.tar.gz
 aa185f0a6ae719544bb8d13332dd4f5a 265498 perl optional libpoe-component-irc-perl_6.32+dfsg-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJL6bojAAoJELs6aAGGSaoGH7cP/0zW/NISyqog++vVyRPXEE2c
3dz4evpFWHnpqWgmHsjWoK1RTWcksAlUZ2duf+6Q4n40PGnKq59qx60avA+dAMYM
8S+vEIojmAS1C5gZPX5Wq3KoBXnhwX0JCnneYhcmOoQ4uw8qU+LCnJRCKxmL8Uky
9svRYYoJJxo74ysCj3e7HyCyXyy5iyXQmKn9H7GK5YxlVvSLJxu/KQ4Ii3QQf4OZ
7pjC8XEmSgl20j3O9Hbf+KY+GZc0RI74EJehxVoOwF2PfxbvEyPTJ4zSnjTGiwlj
2kQtQdxLQAslwGxAaiI8W04ezpR0tTL5YLwXMl11lOZid8IPtYjY1XV3eZ+2fONV
MjvQ1p2nkLBsIphXwIXMGbO4MUJTqwrMa6Gaca3wk7Uuxug5Thv/ujjvEbQlD4Ef
R+A2MJJ3CXREKtXdqSSLGCBeT6gjcPTHUGfEM0cEraKnDYm/YRsk1wTX+tb/+9EP
L5y4jqXeKfMHPBY/nmUix7TPlkKM8z2wz+wxqa76v3mpcrhgMHuXtgn9ynjRyMah
zW4ph4DuKabN/xXVlhIYRDOnFTr0zt7dqe6HsOUmZzSEOoUnesuMVb9agQISnJwe
OItzc5n7UFEp9omYnoxvxhvA26tQoouB7Ek25p5CjhQr5z3+CuhUakHS0htQcJc8
e9Qr4xsMQAYr262U/mqD
=gHIb
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Fri, 23 Jul 2010 17:03:09 GMT) Full text and rfc822 format available.

Message #25 received at 581194@bugs.debian.org (full text, mbox):

From: pkg-perl-maintainers@lists.alioth.debian.org
To: 581194@bugs.debian.org, 581194-submitter@bugs.debian.org
Subject: Bug in fixed in revision 60507
Date: Fri, 23 Jul 2010 16:59:39 +0000
tag 581194 + pending
thanks

Some bugs are closed in revision 60507
by Ansgar Burchardt (ansgar-guest)

Commit message:

Filter out \r and \n in commands to prevent command injection.
(Closes: #581194)




Added tag(s) pending. Request was from pkg-perl-maintainers@lists.alioth.debian.org to control@bugs.debian.org. (Fri, 23 Jul 2010 17:03:11 GMT) Full text and rfc822 format available.

Message sent on to "Debian bug at v.nix.is" <debian-bug@v.nix.is>:
Bug#581194. (Fri, 23 Jul 2010 17:03:13 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, team@security.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Fri, 23 Jul 2010 17:21:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ansgar Burchardt <ansgar@43-1.org>:
Extra info received and forwarded to list. Copy sent to team@security.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Fri, 23 Jul 2010 17:21:06 GMT) Full text and rfc822 format available.

Message #35 received at 581194@bugs.debian.org (full text, mbox):

From: Ansgar Burchardt <ansgar@43-1.org>
To: 581194@bugs.debian.org
Subject: Re: libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution
Date: Sat, 24 Jul 2010 02:17:54 +0900
[Message part 1 (text/plain, inline)]
Hi,

POE::Component::IRC did not validate the arguments of commands to send
to the IRC server.  If a user could trick a bot into sending a string
containing \r or \n, this would allow injection or arbitrary IRC
commands.  This was fixed upstream in versions 6.14, 6.30 and finally
solved in 6.32.

Lenny is also affected from this problem.  It can be reproduced using
the attached minimalistic IRC bot in 581194.pl: using
libpoe-component-perl from Lenny the bot will exit from IRC after
seeing a message in #test-1234 and replying to it.

I prepared a patch using the same fix as upstream introduced in 6.32:
stripping \r and \n and any following characters from commands being
send.  Upstream confirmed in IRC that this should be enough to fix the
bug.

Security Team: Should we upload the proposed fix to stable-security or
should this rather be fixed in the next point release of Lenny?

Regards,
Ansgar
[581194.diff (text/x-diff, attachment)]
[581194.pl (text/x-perl, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Tue, 03 Aug 2010 07:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ansgar Burchardt <ansgar@43-1.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Tue, 03 Aug 2010 07:48:03 GMT) Full text and rfc822 format available.

Message #40 received at 581194@bugs.debian.org (full text, mbox):

From: Ansgar Burchardt <ansgar@43-1.org>
To: team@security.debian.org
Cc: 581194@bugs.debian.org
Subject: Re: Bug#581194: libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution
Date: Tue, 03 Aug 2010 16:47:05 +0900
Hi,

I did not get an answer from the security team for longer than a week
now.  Maybe the mail did get lost somewhere?

Regards,
Ansgar

Ansgar Burchardt <ansgar@43-1.org> writes:

> POE::Component::IRC did not validate the arguments of commands to send
> to the IRC server.  If a user could trick a bot into sending a string
> containing \r or \n, this would allow injection or arbitrary IRC
> commands.  This was fixed upstream in versions 6.14, 6.30 and finally
> solved in 6.32.
>
> Lenny is also affected from this problem.  It can be reproduced using
> the attached minimalistic IRC bot in 581194.pl: using
> libpoe-component-perl from Lenny the bot will exit from IRC after
> seeing a message in #test-1234 and replying to it.
>
> I prepared a patch using the same fix as upstream introduced in 6.32:
> stripping \r and \n and any following characters from commands being
> send.  Upstream confirmed in IRC that this should be enough to fix the
> bug.
>
> Security Team: Should we upload the proposed fix to stable-security or
> should this rather be fixed in the next point release of Lenny?




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Tue, 03 Aug 2010 17:09:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luciano Bello <luciano@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Tue, 03 Aug 2010 17:09:08 GMT) Full text and rfc822 format available.

Message #45 received at 581194@bugs.debian.org (full text, mbox):

From: Luciano Bello <luciano@debian.org>
To: Ansgar Burchardt <ansgar@43-1.org>
Cc: team@security.debian.org, 581194@bugs.debian.org
Subject: Re: Bug#581194: libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution
Date: Tue, 3 Aug 2010 13:59:06 -0300
Hi Ansgar,
	Thanks for getting in touch with us and sorry for the delay in the answer.

El Mar 03 Ago 2010, Ansgar Burchardt escribió:
> > Security Team: Should we upload the proposed fix to stable-security or
> > should this rather be fixed in the next point release of Lenny?

Since the problem affects only IRC commands in script that doesn't remove CR/LF 
from parameters they send to the IRC component, the problem should be fixed via 
an stable-proposed-update. Can you (or somebody else in the perl group) please 
make this upload? Remember to contact debian-release@lists.d.o attaching the 
debdiff.

Thanks you for all your contributions

Luciano




Information forwarded to debian-bugs-dist@lists.debian.org, debian-release@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#581194; Package libpoe-component-irc-perl. (Tue, 03 Aug 2010 17:36:06 GMT) Full text and rfc822 format available.

Message #48 received at 581194@bugs.debian.org (full text, mbox):

From: Ansgar Burchardt <ansgar@43-1.org>
To: 581194@bugs.debian.org
Subject: Re: Bug#581194: libpoe-component-irc-perl: Insufficient stripping of CR/LF allows arbitrary IRC command execution
Date: Wed, 04 Aug 2010 02:33:22 +0900
[Message part 1 (text/plain, inline)]
clone 581194 -1
reassign -1 release.debian.org
retitle  -1 pu: libpoe-component-irc-perl/5.84+dfsg-1+lenny1
severity -1 normal
tags     -1 =
user     release.debian.org@packages.debian.org
usertags -1 + pu
thanks

Hi,

libpoe-component-irc-perl has a bug allowing injection of IRC commands
in scripts not stripping \r and \n [1].  I prepared the attached patch to
fix this problem for Lenny.

The security team says this issue should be fixed in the next point
release and not via an upload to stable-security (see below).  Should we
go ahead and upload the proposed patch to stable?

Regards,
Ansgar

[1] <http://bugs.debian.org/581194>

Luciano Bello <luciano@debian.org> writes:
> Since the problem affects only IRC commands in script that doesn't remove CR/LF 
> from parameters they send to the IRC component, the problem should be fixed via 
> an stable-proposed-update. Can you (or somebody else in the perl group) please 
> make this upload? Remember to contact debian-release@lists.d.o attaching the 
> debdiff.
[581194.diff (text/x-diff, attachment)]

Bug 581194 cloned as bug 591511. Request was from Ansgar Burchardt <ansgar@43-1.org> to control@bugs.debian.org. (Tue, 03 Aug 2010 17:36:08 GMT) Full text and rfc822 format available.

Reply sent to Ansgar Burchardt <ansgar@43-1.org>:
You have taken responsibility. (Thu, 05 Aug 2010 08:12:03 GMT) Full text and rfc822 format available.

Notification sent to "Debian bug at v.nix.is" <debian-bug@v.nix.is>:
Bug acknowledged by developer. (Thu, 05 Aug 2010 08:12:03 GMT) Full text and rfc822 format available.

Message #55 received at 581194-close@bugs.debian.org (full text, mbox):

From: Ansgar Burchardt <ansgar@43-1.org>
To: 581194-close@bugs.debian.org
Subject: Bug#581194: fixed in libpoe-component-irc-perl 5.84+dfsg-1+lenny1
Date: Thu, 05 Aug 2010 08:09:43 +0000
Source: libpoe-component-irc-perl
Source-Version: 5.84+dfsg-1+lenny1

We believe that the bug you reported is fixed in the latest version of
libpoe-component-irc-perl, which is due to be installed in the Debian FTP archive:

libpoe-component-irc-perl_5.84+dfsg-1+lenny1.diff.gz
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_5.84+dfsg-1+lenny1.diff.gz
libpoe-component-irc-perl_5.84+dfsg-1+lenny1.dsc
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_5.84+dfsg-1+lenny1.dsc
libpoe-component-irc-perl_5.84+dfsg-1+lenny1_all.deb
  to main/libp/libpoe-component-irc-perl/libpoe-component-irc-perl_5.84+dfsg-1+lenny1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 581194@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Ansgar Burchardt <ansgar@43-1.org> (supplier of updated libpoe-component-irc-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 04 Aug 2010 04:47:59 +0900
Source: libpoe-component-irc-perl
Binary: libpoe-component-irc-perl
Architecture: source all
Version: 5.84+dfsg-1+lenny1
Distribution: stable
Urgency: high
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: Ansgar Burchardt <ansgar@43-1.org>
Description: 
 libpoe-component-irc-perl - a fully event-driven IRC client module
Closes: 581194
Changes: 
 libpoe-component-irc-perl (5.84+dfsg-1+lenny1) stable; urgency=high
 .
   * Filter out \r and \n in commands to prevent command injection.
     (Closes: #581194)
Checksums-Sha1: 
 8fa17df9a0ca9a9cf46fba7f9aad5c4864975f40 2326 libpoe-component-irc-perl_5.84+dfsg-1+lenny1.dsc
 2261bbeda616c5018ec918990f7d03515ad8b752 5994 libpoe-component-irc-perl_5.84+dfsg-1+lenny1.diff.gz
 a1c851aeafc459b55b77dd755765712977ae95c9 274150 libpoe-component-irc-perl_5.84+dfsg-1+lenny1_all.deb
Checksums-Sha256: 
 03067ffb41f95df1a1b6c3797b3597b7c1eb270cc1827ff58b8c1b227461d840 2326 libpoe-component-irc-perl_5.84+dfsg-1+lenny1.dsc
 279b105dffbf7ce2de350d4398850c5311e5860c3295af44ca8c59665cfa6b73 5994 libpoe-component-irc-perl_5.84+dfsg-1+lenny1.diff.gz
 3bf1ab03716dd7cc9262381d8fe7805745c9671f5f2dc2a13e0aab0b4325121f 274150 libpoe-component-irc-perl_5.84+dfsg-1+lenny1_all.deb
Files: 
 25a220de0cf1c55cc6d3846f473a8501 2326 perl optional libpoe-component-irc-perl_5.84+dfsg-1+lenny1.dsc
 836df41d16d5ca0ce8694e042afd24ac 5994 perl optional libpoe-component-irc-perl_5.84+dfsg-1+lenny1.diff.gz
 d0f832553c46ae245eb154980dd70b7e 274150 perl optional libpoe-component-irc-perl_5.84+dfsg-1+lenny1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMWHyZAAoJELs6aAGGSaoGh6cP/Rj4CzsYfmIPTztXD+6apjDv
c1RDRGIyWFhBW14v/gAthCfjIaLdovuqWPmf2LtpdkqCAP+xM7poMkHv1PM9SiVm
UZh5NLyqzrCOr4H20YATrXcl6wG3npH3HMcTDgqCVbhfs68GdjMVOGt4anuy0N10
h2qv1Kzk5qh2gBzm0QCCq+LN+XiOZs5ox0rRd8kXpFNtzML2wD8g239HspPaR/N/
BN7CTj6LRVFfNUbzexY1R3oMCHg0Z5VZvFcl0LiXDBFs9UMatp5iw8d0tzuKvyvk
ydood+unByA2p1OVLxLAhB4L5LNzrOtPFcDGryaaD4B5o9qVRBrlBHn8SjzataD+
0k5LPLh2egv3r1TQWzaKqnmb9CGxYyx3U+8EaOv47L2lqzSKKEvkzGvKDZbFXr64
1J5AkaaYvBT84bS9VRcBaaEppOXkMQ6cH2wirlP8leK+AS5ZLcurkkg9tVdp/HeC
Fv9MLPJa/J7d4HMSsnQv2StCwmaRAFl08uOszedzk1sjD1LJhETI6zzHtcVJqUs8
g1mVuySKyiBj7Vj4uZjIa7czaMwJNVJ6jkm/RlTWYW55x+hSxvW7QmBtGsc0I42O
Otn4g7T+BP6a0TdFj4X7pVx5XfU5w7g9GB6u4unWIRHdP//9rqe1rM+KmG/CmBPb
Lq53CT4DqzMJKMkPLu1e
=Ix0a
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 05 Sep 2010 07:42:08 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 19:59:13 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.