Debian Bug report logs - #580716
rabbitvcs: description leads user to believe that multiple VCSes are supported

version graph

Package: rabbitvcs; Maintainer for rabbitvcs is Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>;

Reported by: "brian m. carlson" <sandals@crustytoothpaste.net>

Date: Fri, 7 May 2010 23:36:02 UTC

Severity: normal

Found in version 0.13.1-1

Fixed in version rabbitvcs/0.15.0.5-1

Done: Arthur de Jong <adejong@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>:
Bug#580716; Package rabbitvcs. (Fri, 07 May 2010 23:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to "brian m. carlson" <sandals@crustytoothpaste.ath.cx>:
New Bug report received and forwarded. Copy sent to Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>. (Fri, 07 May 2010 23:36:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "brian m. carlson" <sandals@crustytoothpaste.ath.cx>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: rabbitvcs: description leads user to believe that multiple VCSes are supported
Date: Fri, 7 May 2010 23:32:24 +0000
[Message part 1 (text/plain, inline)]
Package: rabbitvcs
Version: 0.13.1-1
Severity: normal

According to Policy §3.4:

  The description should describe the package (the program) to a user
  (system administrator) who has never met it before so that they have
  enough information to decide whether they want to install it.  This
  description should not just be copied verbatim from the program's
  documentation.

Each of the four rabbitcvs-* packages that are new today contain the
following as the first paragraph of their descriptions:

  RabbitVCS is a set of graphical tools written to provide simple and
  straightforward access to the version control systems you use. There
  are extensions for Nautilus, Thunar and GEdit, and a simple
  command-line interface.

Notice that the phrase is "the version control systems you use".  Only
on the -core package is it stated that it only supports Subversion.
Instead of using hyperbole, perhaps you could specify in each package
description that "RabbitVCS is a set of graphical tools writtten to
provide simple and straightforward access to Subversion." Currently, the
description is not very useful because it does not help me as an
administrator to know whether RabbitVCS is something I want to install
at the moment.  What it may do in the future is unknowable and not
useful to imply in the package description.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>:
Bug#580716; Package rabbitvcs. (Sat, 08 May 2010 07:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jason Heeris <jason.heeris@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>. (Sat, 08 May 2010 07:45:04 GMT) Full text and rfc822 format available.

Message #10 received at 580716@bugs.debian.org (full text, mbox):

From: Jason Heeris <jason.heeris@gmail.com>
To: "brian m. carlson" <sandals@crustytoothpaste.ath.cx>, 580716@bugs.debian.org
Cc: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Re: [Python-modules-team] Bug#580716: rabbitvcs: description leads user to believe that multiple VCSes are supported
Date: Sat, 8 May 2010 15:44:20 +0800
Good point, I've committed a change for the package description to the
Alioth repo.

— Jason




Changed Bug submitter to '"brian m. carlson" <sandals@crustytoothpaste.net>' from '"brian m. carlson" <sandals@crustytoothpaste.ath.cx>' Request was from "brian m. carlson" <sandals@crustytoothpaste.net> to control@bugs.debian.org. (Thu, 03 Feb 2011 20:52:07 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from Anibal Monsalve Salazar <anibal@debian.org> to control@bugs.debian.org. (Sun, 04 Dec 2011 07:06:04 GMT) Full text and rfc822 format available.

Reply sent to Arthur de Jong <adejong@debian.org>:
You have taken responsibility. (Wed, 21 Mar 2012 22:27:04 GMT) Full text and rfc822 format available.

Notification sent to "brian m. carlson" <sandals@crustytoothpaste.net>:
Bug acknowledged by developer. (Wed, 21 Mar 2012 22:27:04 GMT) Full text and rfc822 format available.

Message #19 received at 580716-close@bugs.debian.org (full text, mbox):

From: Arthur de Jong <adejong@debian.org>
To: 580716-close@bugs.debian.org
Subject: Bug#580716: fixed in rabbitvcs 0.15.0.5-1
Date: Wed, 21 Mar 2012 22:22:25 +0000
Source: rabbitvcs
Source-Version: 0.15.0.5-1

We believe that the bug you reported is fixed in the latest version of
rabbitvcs, which is due to be installed in the Debian FTP archive:

rabbitvcs-cli_0.15.0.5-1_all.deb
  to main/r/rabbitvcs/rabbitvcs-cli_0.15.0.5-1_all.deb
rabbitvcs-core_0.15.0.5-1_all.deb
  to main/r/rabbitvcs/rabbitvcs-core_0.15.0.5-1_all.deb
rabbitvcs-gedit_0.15.0.5-1_all.deb
  to main/r/rabbitvcs/rabbitvcs-gedit_0.15.0.5-1_all.deb
rabbitvcs-nautilus_0.15.0.5-1_all.deb
  to main/r/rabbitvcs/rabbitvcs-nautilus_0.15.0.5-1_all.deb
rabbitvcs_0.15.0.5-1.debian.tar.gz
  to main/r/rabbitvcs/rabbitvcs_0.15.0.5-1.debian.tar.gz
rabbitvcs_0.15.0.5-1.dsc
  to main/r/rabbitvcs/rabbitvcs_0.15.0.5-1.dsc
rabbitvcs_0.15.0.5.orig.tar.bz2
  to main/r/rabbitvcs/rabbitvcs_0.15.0.5.orig.tar.bz2



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 580716@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Arthur de Jong <adejong@debian.org> (supplier of updated rabbitvcs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 21 Mar 2012 23:09:27 +0100
Source: rabbitvcs
Binary: rabbitvcs-core rabbitvcs-cli rabbitvcs-gedit rabbitvcs-nautilus
Architecture: source all
Version: 0.15.0.5-1
Distribution: unstable
Urgency: low
Maintainer: Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>
Changed-By: Arthur de Jong <adejong@debian.org>
Description: 
 rabbitvcs-cli - Command line interface for RabbitVCS
 rabbitvcs-core - Easy version control
 rabbitvcs-gedit - Gedit extension for RabbitVCS
 rabbitvcs-nautilus - Nautilus extension for RabbitVCS
Closes: 580716 585859 618934 619644 626809 633113 635123 644690 647999
Changes: 
 rabbitvcs (0.15.0.5-1) unstable; urgency=low
 .
   * Team upload.
 .
   [ Arthur de Jong ]
   * New upstream release (Closes: #618934) (LP: #741562, #952719):
     - Includes new client for Nautilus 3 (Closes: #633113, #644690, #647999)
       (LP: #876514).
     - Fix a problem with rename a file (Closes: #585859).
     - Allows entering repository URL when starting the browser
       (Closes: #619644).
   * Cherry-pick upstream change that implements a gedit 3 plugin and update
     packaging according to new directory layout (closes: #635123).
   * Update package descriptions to match upstream's (Closes: #580716)
     (LP: #748304).
   * Drop dependency on glade (not used in 0.15).
   * Add missing dependency on python-simplejson (LP: #769742)
   * Have rabbitvcs-nautilus Conflicts/Replaces rabbitvcs-nautilus3 to
     ensure smooth upgrades for people running upstream provided packages.
   * Update debian/copyright and switch to latest machine-readable format.
   * Move packaging to Python Applications Packaging Team repository,
     updating maintainer and Vcs-* fields.
   * Switch to using dh_python2.
   * Change package section to vcs (Closes: #626809).
   * Bump Standards-Version to 3.9.3.
 .
   [ Jakub Wilk ]
   * Add Vcs-* fields.
 .
   [ Sameer Rahmani ]
   * watch file fixed.
Checksums-Sha1: 
 9aa93088a52417bebbf0aa1d17f6b99e60026786 1565 rabbitvcs_0.15.0.5-1.dsc
 a9e1e741a3e665e3ce2769b2730fafde26955b53 536235 rabbitvcs_0.15.0.5.orig.tar.bz2
 b3a44acb65bc5362051a92951b0f485567e30abc 7745 rabbitvcs_0.15.0.5-1.debian.tar.gz
 c76029eadbfb935c687bc3cc76105f5344b23687 524086 rabbitvcs-core_0.15.0.5-1_all.deb
 acf742e11c0467dfe8e82485fa3b9802a2f2c515 6014 rabbitvcs-cli_0.15.0.5-1_all.deb
 da12f9c7774f57f3960cdc1e3b8c5eef474bf061 10860 rabbitvcs-gedit_0.15.0.5-1_all.deb
 9c50879727a53bef59fe21e0908ce03ae1669a1e 10902 rabbitvcs-nautilus_0.15.0.5-1_all.deb
Checksums-Sha256: 
 f9de2e44edb6065a6d9c98f40b9355b09c0512487ac0272b555bd16528a55434 1565 rabbitvcs_0.15.0.5-1.dsc
 cdda568e4206490e97c287743b632802c729ad44f70743bc7ab9ddc84ada66b3 536235 rabbitvcs_0.15.0.5.orig.tar.bz2
 36ee80d85be4fc145c41f5cf84f414e8efe1f6fc95252ea3dd64250ac2fc8574 7745 rabbitvcs_0.15.0.5-1.debian.tar.gz
 a981427262c0c31f8f605b8658ca0d9c837dc024ddc6c8f0dbf1897418af4061 524086 rabbitvcs-core_0.15.0.5-1_all.deb
 511d991aa4d1cc9f89298029b8b98122dbab96a1028edcec9e62d644320c3079 6014 rabbitvcs-cli_0.15.0.5-1_all.deb
 d52520ee283525661817ea0fd32dc17952c6079d47b54fd380737b6cef94cb16 10860 rabbitvcs-gedit_0.15.0.5-1_all.deb
 648d6ac8b9d414d2ad231d632e3028f45250f67ee3c71f5fa51bab2a6b4bf614 10902 rabbitvcs-nautilus_0.15.0.5-1_all.deb
Files: 
 846fbb5d2861eca4df6349364d7251e0 1565 vcs optional rabbitvcs_0.15.0.5-1.dsc
 9bf0548557cc803ad2d88f747da1af8a 536235 vcs optional rabbitvcs_0.15.0.5.orig.tar.bz2
 b050bce180282d7282118d57c36c1ff1 7745 vcs optional rabbitvcs_0.15.0.5-1.debian.tar.gz
 3813dfd90cd642030a9c913c7456dc7e 524086 vcs optional rabbitvcs-core_0.15.0.5-1_all.deb
 ed86acfb110700d6bafc139f06a520a0 6014 vcs optional rabbitvcs-cli_0.15.0.5-1_all.deb
 68c520484030785785792820b0563c5e 10860 vcs optional rabbitvcs-gedit_0.15.0.5-1_all.deb
 5bd46340bb30bb1e484a70e6ef48e6b9 10902 vcs optional rabbitvcs-nautilus_0.15.0.5-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk9qUg8ACgkQVYan35+NCKfJRwCdFZcRvdeNKLZnT02L9wDaFTZl
STAAniTDpxOBp6Yg0SYYhrDwcfHSD7+g
=oGT1
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 29 Apr 2012 07:34:01 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 03:46:41 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.