Debian Bug report logs - #577650
cupt: should use selections instead of --force-* options

Package: cupt; Maintainer for cupt is Cupt developers <cupt-devel@lists.alioth.debian.org>; Source for cupt is src:cupt.

Reported by: James Vega <jamessan@debian.org>

Date: Tue, 13 Apr 2010 12:24:12 UTC

Severity: wishlist

Merged with 575786

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, jackyf@debian.org (Eugene V. Lyubimkin):
Bug#577650; Package libcupt-perl. (Tue, 13 Apr 2010 12:24:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to James Vega <jamessan@debian.org>:
New Bug report received and forwarded. Copy sent to jackyf@debian.org (Eugene V. Lyubimkin). (Tue, 13 Apr 2010 12:24:14 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: James Vega <jamessan@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libcupt-perl: Does not handle automatic upgrade of git packages
Date: Tue, 13 Apr 2010 08:14:28 -0400
Package: libcupt-perl
Version: 1.5.9
Severity: normal

Incoming versions:
Package: git
Version: 1:1.7.0.4-2
Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.16.2-1), libexpat1 (>= 1.95.8), zlib1g (>= 1:1.2.0), perl-modules, liberror-perl, libdigest-sha1-perl
Conflicts: git (<< 4.3.20-11), git-completion, git-core (<= 1:1.7.0.4-1), qgit (<< 1.5.5)
Provides: git-completion, git-core
Package: git-core
Version: 1:1.7.0.4-2
Depends: git (>> 1:1.7.0.2)
Package: git-svn
Version: 1:1.7.0.4-2
Depends: git (>> 1:1.7.0.4), git (<< 1:1.7.0.4-.), libsvn-perl | libsvn-core-perl, libwww-perl, libterm-readkey-perl

Current versions:
Package: git-core
Version: 1:1.7.0.4-1
Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.16.2-1), libexpat1 (>= 1.95.8), zlib1g (>= 1:1.2.0), perl-modules, liberror-perl, libdigest-sha1-perl
Conflicts: git (<< 4.3.20-11), git-completion, qgit (<< 1.5.5)
Provides: git-completion
Package: git-svn
Version: 1:1.7.0.4-1
Depends: git-core (>> 1:1.7.0.4), git-core (<< 1:1.7.0.4-.), libsvn-perl | libsvn-core-perl, libwww-perl, libterm-readkey-perl

% sudo cupt safe-upgrade -o debug::resolver=1 -o debug::worker=1
Building the package cache... [done]
Initializing package resolver and worker... D: obtaining lock '/var/lib/cupt/lock'
[done]
Scheduling requested actions... D: install package 'git-core', version '1:1.7.0.4-2'
D: install package 'git-email', version '1:1.7.0.4-2'
D: install package 'git-cvs', version '1:1.7.0.4-2'
D: install package 'gitk', version '1:1.7.0.4-2'
D: install package 'libruby1.8', version '1.8.7.249-3'
D: install package 'unixodbc', version '2.2.14p2-1'
D: install package 'git-svn', version '1:1.7.0.4-2'
D: install package 'ruby1.8', version '1.8.7.249-3'
D: install package 'ri1.8', version '1.8.7.249-3'
D: install package 'odbcinst', version '2.2.14p2-1'
[done]
Resolving possible unmet dependencies... D: started resolving
D: (0:0.0) problem: package 'git-core': unsatisfied depends 'git (>> 1:1.7.0.2)'
D: (0:0.0) -> (1,Δ:+22.6,qΔ:+50.0) trying: package 'git': '<not installed>' -> '1:1.7.0.4-2'
D: (0:0.0) -> (2,Δ:-8.4,qΔ:+50.0) trying: package 'git': '<not installed>' -> '1:1.7.1~rc1-1'
D: (0:0.0) -> (3,Δ:-362.9,qΔ:+50.0) trying: package 'git-core': '1:1.7.0.4-2' -> '1:1.7.0.4-1'
D: (0:0.0) -> (4,Δ:-2006.6,qΔ:+50.0) trying: package 'git-core': '1:1.7.0.4-2' -> '<not installed>'
D:  (1:72.6) problem: package 'odbcinst': unsatisfied depends 'odbcinst1debian2 (>= 2.2.14p2)'
D:  (1:72.6) -> (5,Δ:-10.5,qΔ:+46.7) trying: package 'odbcinst1debian2': '<not installed>' -> '2.2.14p2-1'
D:  (1:72.6) -> (6,Δ:-31.1,qΔ:+46.7) trying: package 'odbcinst': '2.2.14p2-1' -> '2.2.11-21'
D:  (1:72.6) -> (7,Δ:-352.3,qΔ:+46.7) trying: package 'odbcinst': '2.2.14p2-1' -> '<not installed>'
D:   (5:108.7) problem: package 'libruby1.8': satisfied conflicts 'libreadline-ruby1.8'
D:   (5:108.7) -> (8,Δ:-31.1,qΔ:+44.8) trying: package 'libruby1.8': '1.8.7.249-3' -> '1.8.7.249-2'
D:   (5:108.7) -> (9,Δ:-230.0,qΔ:+44.8) trying: package 'libreadline-ruby1.8': '1.8.7.249-2' -> '<not installed>'
D:   (5:108.7) -> (10,Δ:-352.3,qΔ:+44.8) trying: package 'libruby1.8': '1.8.7.249-3' -> '<not installed>'
D:    (8:122.5) problem: package 'odbcinst1debian2': satisfied conflicts 'odbcinst1debian1'
D:    (8:122.5) -> (11,Δ:-350.3,qΔ:+43.5) trying: package 'odbcinst1debian1': '2.2.11-21' -> '<not installed>'
D:   (6:88.2) problem: package 'unixodbc': unsatisfied depends 'odbcinst1debian2 (>= 2.2.11-3)'
D:   (6:88.2) -> (12,Δ:-30.1,qΔ:+44.8) trying: package 'unixodbc': '2.2.14p2-1' -> '2.2.11-21'
D:   (6:88.2) -> (13,Δ:-351.3,qΔ:+44.8) trying: package 'unixodbc': '2.2.14p2-1' -> '<not installed>'
D:    (12:102.9) problem: package 'libruby1.8': satisfied conflicts 'libreadline-ruby1.8'
D:    (12:102.9) -> (14,Δ:-31.1,qΔ:+43.5) trying: package 'libruby1.8': '1.8.7.249-3' -> '1.8.7.249-2'
D:    (12:102.9) -> (15,Δ:-230.0,qΔ:+43.5) trying: package 'libreadline-ruby1.8': '1.8.7.249-2' -> '<not installed>'
D:    (12:102.9) -> (16,Δ:-352.3,qΔ:+43.5) trying: package 'libruby1.8': '1.8.7.249-3' -> '<not installed>'
D:     (14:115.3) problem: package 'ruby1.8': satisfied conflicts 'irb1.8'
D:     (14:115.3) -> (17,Δ:-31.1,qΔ:+42.6) trying: package 'ruby1.8': '1.8.7.249-3' -> '1.8.7.249-2'
D:     (14:115.3) -> (18,Δ:-230.0,qΔ:+42.6) trying: package 'irb1.8': '1.8.7.249-2' -> '<not installed>'
D:     (14:115.3) -> (19,Δ:-352.3,qΔ:+42.6) trying: package 'ruby1.8': '1.8.7.249-3' -> '<not installed>'
D:      (17:126.8) problem: package 'ri1.8': unsatisfied depends 'ruby1.8 (>= 1.8.7.249-3)'
D:      (17:126.8) -> (20,Δ:-30.1,qΔ:+41.8) trying: package 'ri1.8': '1.8.7.249-3' -> '1.8.7.249-2'
D:      (17:126.8) -> (21,Δ:-351.3,qΔ:+41.8) trying: package 'ri1.8': '1.8.7.249-3' -> '<not installed>'
D:       (20:138.5) finished
D:       (20:138.5) proposing this solution

The following 1 packages will be INSTALLED:

git

The following 5 packages will be UPGRADED:

git-core git-cvs git-email git-svn gitk

Need to get 0B/6978KiB of archives. After unpacking 32.0KiB will be freed.
Do you want to continue? [y/N/q] y
D:       (20:138.5) accepted

Performing requested actions:
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-core 1:1.7.0.4-2', reason: 'depends: git (>> 1:1.7.0.2)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-svn 1:1.7.0.4-2', reason: 'depends: git (>> 1:1.7.0.4)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-svn 1:1.7.0.4-2', reason: 'depends: git (<< 1:1.7.0.4-.)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure gitk 1:1.7.0.4-2', reason: 'depends: git (>> 1:1.7.0.4)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure gitk 1:1.7.0.4-2', reason: 'depends: git (<< 1:1.7.0.4-.)'
D: new action dependency: 'configure git-core 1:1.7.0.4-2' -> '(fake) configure git-buildpackage [git-core (>= 1:1.5.0.1-1)] 0.4.65', reason: 'depends: git-core (>= 1:1.5.0.1-1)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-cvs 1:1.7.0.4-2', reason: 'depends: git (>> 1:1.7.0.4)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-cvs 1:1.7.0.4-2', reason: 'depends: git (<< 1:1.7.0.4-.)'
D: new action dependency: 'configure git-core 1:1.7.0.4-2' -> '(fake) configure topgit [git-core] 0.8-1', reason: 'depends: git-core'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> '(fake) configure topgit [git-core] 0.8-1', reason: 'depends: git-core'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-email 1:1.7.0.4-2', reason: 'depends: git (>> 1:1.7.0.4)'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-email 1:1.7.0.4-2', reason: 'depends: git (<< 1:1.7.0.4-.)'
D: new action dependency: 'configure git-core 1:1.7.0.4-2' -> '(fake) configure gitstats [git-core (>= 1:1.5.2.4)] 2010.02.06-1', reason: 'depends: git-core (>= 1:1.5.2.4)'
D: new action dependency: 'configure git-core 1:1.7.0.4-2' -> '(fake) configure gitpkg [git-core] 0.14', reason: 'depends: git-core'
D: new action dependency: 'configure git 1:1.7.0.4-2' -> '(fake) configure gitpkg [git-core] 0.14', reason: 'depends: git-core'
D: the present action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-core 1:1.7.0.4-2'
D: the present action dependency: 'unpack git-core 1:1.7.0.4-2' -> 'configure git-core 1:1.7.0.4-2'
D: the present action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-svn 1:1.7.0.4-2'
D: the present action dependency: 'unpack git-svn 1:1.7.0.4-2' -> 'configure git-svn 1:1.7.0.4-2'
D: the present action dependency: 'configure git 1:1.7.0.4-2' -> 'configure gitk 1:1.7.0.4-2'
D: the present action dependency: 'unpack gitk 1:1.7.0.4-2' -> 'configure gitk 1:1.7.0.4-2'
D: the present action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-cvs 1:1.7.0.4-2'
D: the present action dependency: 'unpack git-cvs 1:1.7.0.4-2' -> 'configure git-cvs 1:1.7.0.4-2'
D: the present action dependency: 'unpack git 1:1.7.0.4-2' -> 'configure git 1:1.7.0.4-2'
D: the present action dependency: 'configure git 1:1.7.0.4-2' -> 'configure git-email 1:1.7.0.4-2'
D: the present action dependency: 'unpack git-email 1:1.7.0.4-2' -> 'configure git-email 1:1.7.0.4-2'
D: started changeset
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
D: unpack  git_1:1.7.0.4-2
dpkg: considering removing git-core in favour of git ...
dpkg: no, cannot proceed with removal of git-core (--auto-deconfigure will help):
 git-buildpackage depends on git-core (>= 1:1.5.0.1-1)
  git-core is to be removed.
dpkg: regarding .../git_1:1.7.0.4-2_i386.deb containing git:
 git conflicts with git-completion
  git-core provides git-completion and is present and installed.
dpkg: error processing /var/cache/apt/archives/git_1:1.7.0.4-2_i386.deb (--unpack):
 conflicting packages - not installing git
Errors were encountered while processing:
 /var/cache/apt/archives/git_1:1.7.0.4-2_i386.deb
E: /usr/bin/dpkg --unpack --force-bad-path /var/cache/apt/archives/git_1:1.7.0.4-2_i386.deb returned non-zero status: 256
D: releasing lock '/var/lib/cupt/lock'
E: error performing command 'safe-upgrade'

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (100, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-3-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libcupt-perl depends on:
ii  liblist-moreutils-perl      0.25~02-1    Perl module with additional list f
ii  libparse-recdescent-perl    1.964+dfsg-1 Perl module to create and use recu
ii  libterm-size-perl           0.2-4+b1     Perl extension for retrieving term
ii  liburi-perl                 1.54-1       module to manipulate and access UR
ii  libwww-curl-perl            4.11-1       Perl bindings to libcurl
ii  perl [libdigest-sha-perl]   5.10.1-12    Larry Wall's Practical Extraction 

Versions of packages libcupt-perl recommends:
ii  bzip2                         1.0.5-4    high-quality block-sorting file co
ii  gpgv                          1.4.10-3   GNU privacy guard - signature veri
ii  liblocale-gettext-perl        1.05-6     Using libc functions for internati

Versions of packages libcupt-perl suggests:
ii  cupt                          1.5.9      alternative front-end for dpkg -- 
pn  debdelta                      <none>     (no description available)
ii  dpkg-dev                      1.15.5.6   Debian package development tools
pn  dpkg-repack                   <none>     (no description available)
ii  lzma                          4.43-14    Compression method of 7z format in

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, jackyf@debian.org (Eugene V. Lyubimkin):
Bug#577650; Package libcupt-perl. (Tue, 13 Apr 2010 17:09:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Eugene V. Lyubimkin" <jackyf@debian.org>:
Extra info received and forwarded to list. Copy sent to jackyf@debian.org (Eugene V. Lyubimkin). (Tue, 13 Apr 2010 17:09:10 GMT) Full text and rfc822 format available.

Message #10 received at 577650@bugs.debian.org (full text, mbox):

From: "Eugene V. Lyubimkin" <jackyf@debian.org>
To: James Vega <jamessan@debian.org>, 577650@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: Bug#577650: libcupt-perl: Does not handle automatic upgrade of git packages
Date: Tue, 13 Apr 2010 20:03:58 +0300
[Message part 1 (text/plain, inline)]
package cupt libcupt-perl dpkg
reassign 577650 dpkg
merge 575786 577650
thanks

Hi James, thanks for reporting this case.

The error is on dpkg side, because

git 1:1.7.0.4-2 also Replaces 'git-core (<= 1:1.7.0.4-1)' and
'git-completion', so the following unpack command

James Vega wrote:
[...]
> D: unpack  git_1:1.7.0.4-2
> dpkg: considering removing git-core in favour of git ...
> dpkg: no, cannot proceed with removal of git-core (--auto-deconfigure will help):
>  git-buildpackage depends on git-core (>= 1:1.5.0.1-1)
>   git-core is to be removed.
> dpkg: regarding .../git_1:1.7.0.4-2_i386.deb containing git:
>  git conflicts with git-completion
>   git-core provides git-completion and is present and installed.
[...]

... should behave smoothly. The bug the of the same nature was reported
slightly earlier against dpkg, so I merged the reports.

P.S. I consider this bug as of severity 'serious', but in the thread of merged
bug one of dpkg maintainers set it to 'normal', so I'm not changing it now,
but feel free to express your opinion about it.

-- 
Eugene V. Lyubimkin aka JackYF, JID: jackyf.devel(maildog)gmail.com
C++/Perl developer, Debian Developer

[signature.asc (application/pgp-signature, attachment)]

Bug reassigned from package 'libcupt-perl' to 'dpkg'. Request was from "Eugene V. Lyubimkin" <jackyf@debian.org> to control@bugs.debian.org. (Tue, 13 Apr 2010 17:09:11 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions cupt/1.5.9. Request was from "Eugene V. Lyubimkin" <jackyf@debian.org> to control@bugs.debian.org. (Tue, 13 Apr 2010 17:09:12 GMT) Full text and rfc822 format available.

Merged 575786 577650. Request was from "Eugene V. Lyubimkin" <jackyf@debian.org> to control@bugs.debian.org. (Tue, 13 Apr 2010 17:09:13 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Dpkg Developers <debian-dpkg@lists.debian.org>:
Bug#577650; Package dpkg. (Tue, 13 Apr 2010 22:45:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Nieder <jrnieder@gmail.com>:
Extra info received and forwarded to list. Copy sent to Dpkg Developers <debian-dpkg@lists.debian.org>. (Tue, 13 Apr 2010 22:45:06 GMT) Full text and rfc822 format available.

Message #21 received at 577650@bugs.debian.org (full text, mbox):

From: Jonathan Nieder <jrnieder@gmail.com>
To: "Eugene V. Lyubimkin" <jackyf@debian.org>, control@bugs.debian.org
Cc: James Vega <jamessan@debian.org>, 577650@bugs.debian.org, git@packages.debian.org
Subject: Re: Bug#577650: libcupt-perl: Does not handle automatic upgrade of git packages
Date: Tue, 13 Apr 2010 17:41:30 -0500
clone 577650 -1
retitle -1 conflict on git-completion should be versioned to avoid dpkg bug
# justification: makes upgrade without --force-depends ugly
severity -1 serious
reassign -1 git git/1.7.0.4-2
thanks

Eugene V. Lyubimkin wrote:
> merge 575786 577650
[...]
> Hi James, thanks for reporting this case.
> 
> The error is on dpkg side, because

Hi, thanks for the report and explanation.  I think we should work
around this by dropping the Replaces/Conflicts on git-completion.
That has not been a separate package since etch.

To make it easier on backporters, we can do something like this:

 Conflicts: git-completion (<< 0+20060817+)
 Replaces: git-completion (<< 0+20060817+)

> P.S. I consider this bug as of severity 'serious', but in the thread of merged
> bug one of dpkg maintainers set it to 'normal', so I'm not changing it now,
> but feel free to express your opinion about it.

I could play bug ping-pong, but I’d rather just fix the bug.  Thanks
for pointing me to it.

Cheers,
Jonathan




Disconnected #577650 from all other report(s). Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Tue, 13 Apr 2010 23:45:03 GMT) Full text and rfc822 format available.

Bug 577650 cloned as bug 577730. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Tue, 13 Apr 2010 23:45:04 GMT) Full text and rfc822 format available.

Merged 575786 577650. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Tue, 13 Apr 2010 23:45:10 GMT) Full text and rfc822 format available.

Severity set to 'serious' from 'normal' Request was from "Eugene V. Lyubimkin" <jackyf@debian.org> to control@bugs.debian.org. (Sun, 09 May 2010 10:06:06 GMT) Full text and rfc822 format available.

Severity set to 'important' from 'serious' Request was from Raphael Hertzog <hertzog@debian.org> to control@bugs.debian.org. (Mon, 17 May 2010 20:15:10 GMT) Full text and rfc822 format available.

Message #32 received at 575786-done@bugs.debian.org (full text, mbox):

From: Guillem Jover <guillem@debian.org>
To: "Eugene V. Lyubimkin" <jackyf@debian.org>, 575786-done@bugs.debian.org
Subject: Re: Bug#575786: dpkg: refuses to unpack package having conflicts+replaces of virtual package
Date: Sun, 15 Dec 2013 05:05:15 +0100
Hi!

On Mon, 2010-03-29 at 12:02:33 +0300, Eugene V. Lyubimkin wrote:
> Package: dpkg
> Version: 1.15.5.6
> Severity: important
> 
> >From dpkg log:
> -8<-
> Selecting previously deselected package libboost1.42-dev.
>  libboost1.42-dev conflicts with bcp
>   libboost1.40-dev provides bcp and is present and installed.
> dpkg: error processing /var/cache/apt/archives/libboost1.42-dev_1.42.0-3_i386.deb (--unpack):
>  conflicting packages - not installing libboost1.42-dev
> ->8-
> 
> Sure, libboost1.42-dev conflicts with bcp, but it also replaces it:
> -8<-
> $ cupt show libboost1.42-dev | grep Replaces
> Replaces: bcp
> ->8-

That's because the request to dpkg was not explicit enough. The way to
do that is to create a “dpkg transaction”, by setting the apropriate
selections so that dpkg knows what it can do. This is how the “venerable”
dselect has worked all this time w/o ever requiring any kind of --force
option.

The rationale is that dpkg does not really like to remove packages if not
asked explicitly, and in a case like this, just removing the interface
providing package might not be enough, and other packages might suddenly
have unsatisfiable dependencies, and dpkg should not start removing stuff
until the situation is ok. That's why either the user or the frontent
should exactly specify what it can do.

Please see the test case on CPR interfaces in the dpkg test suite, as
an example usage:

  <http://anonscm.debian.org/gitweb/?p=dpkg/pkg-tests.git;a=tree;f=t-conflict-provide-replace-interface;hb=HEAD>

I'm thus closing this report.

Thanks,
Guillem



Bug reopened Request was from Guillem Jover <guillem@debian.org> to 575786-submit@bugs.debian.org. (Tue, 17 Dec 2013 16:03:05 GMT) Full text and rfc822 format available.

Bug reassigned from package 'dpkg' to 'cupt'. Request was from Guillem Jover <guillem@debian.org> to 575786-submit@bugs.debian.org. (Tue, 17 Dec 2013 16:03:06 GMT) Full text and rfc822 format available.

No longer marked as found in versions dpkg/1.15.5.6. Request was from Guillem Jover <guillem@debian.org> to 575786-submit@bugs.debian.org. (Tue, 17 Dec 2013 16:03:07 GMT) Full text and rfc822 format available.

Changed Bug title to 'cupt: should use selections instead of --force-* options' from 'libcupt-perl: Does not handle automatic upgrade of git packages' Request was from Guillem Jover <guillem@debian.org> to 575786-submit@bugs.debian.org. (Tue, 17 Dec 2013 16:03:08 GMT) Full text and rfc822 format available.

Severity set to 'wishlist' from 'important' Request was from "Eugene V. Lyubimkin" <jackyf@debian.org> to 575786-submit@bugs.debian.org. (Tue, 17 Dec 2013 19:54:16 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 16:12:37 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.