Debian Bug report logs - #575645
RFP: flashplugin-nonfree-pulse -- Non free Flash plugin for Pulse Audio

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Safir Secerovic <sapphire@linux.org.ba>

Date: Sat, 27 Mar 2010 21:36:02 UTC

Severity: wishlist

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, sapphire@linux.org.ba, unknown-package@qa.debian.org:
Bug#575645; Package flashplugin-nonfree-pulse. (Sat, 27 Mar 2010 21:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Safir Secerovic <sapphire@linux.org.ba>:
New Bug report received and forwarded. Copy sent to sapphire@linux.org.ba, unknown-package@qa.debian.org. (Sat, 27 Mar 2010 21:36:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Safir Secerovic <sapphire@linux.org.ba>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: We need this package in order to make flash 10 plugin to work properly with pulseaudio
Date: Sat, 27 Mar 2010 22:33:44 +0100
Package: flashplugin-nonfree-pulse
Version: 0.1~000+nmu1
Severity: important

This bug report is related to bug #477266 where this package was previously deprecated with the argument that newer version of Flash plugin, version 10 already interfaces with ALSA and PulseAudio seamlessly. As it turn out, it is not the case. Flashplugin only works if it is used first and no other applications is using sound through pulseaudio. With this support library, flash plugin works natively under pulseaudio without any problems thus, iceweasel is running stable without crashes at all. 
Please reintroduce this package into Debian archive. 
Debianized source is available at: 
 http://pulseaudio.vdbonline.net
It compiles and works on both the i386 and amd64 architectures.



-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages flashplugin-nonfree-pulse depends on:
ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
ii  libpulse0                     0.9.21-1   PulseAudio client libraries

Versions of packages flashplugin-nonfree-pulse recommends:
ii  flashplugin-nonfree           1:2.8      Adobe Flash Player - browser plugi

Versions of packages flashplugin-nonfree-pulse suggests:
ii  pulseaudio                    0.9.21-1   PulseAudio sound server

-- no debconf information




Bug reassigned from package 'flashplugin-nonfree-pulse' to 'wnpp'. Request was from Martin Michlmayr <tbm@cyrius.com> to control@bugs.debian.org. (Sun, 28 Mar 2010 22:30:18 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions 0.1~000+nmu1. Request was from Martin Michlmayr <tbm@cyrius.com> to control@bugs.debian.org. (Sun, 28 Mar 2010 22:30:19 GMT) Full text and rfc822 format available.

Changed Bug title to 'RFP: flashplugin-nonfree-pulse' from 'We need this package in order to make flash 10 plugin to work properly with pulseaudio' Request was from Martin Michlmayr <tbm@cyrius.com> to control@bugs.debian.org. (Sun, 28 Mar 2010 22:30:20 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#575645; Package wnpp. (Sun, 28 Mar 2010 22:39:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Sun, 28 Mar 2010 22:39:08 GMT) Full text and rfc822 format available.

Message #16 received at 575645@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: Safir Secerovic <sapphire@linux.org.ba>, 575645@bugs.debian.org
Cc: CJ van den Berg <cj@vdbonline.com>
Subject: Re: Bug#575645: We need this package in order to make flash 10 plugin to work properly with pulseaudio
Date: Sun, 28 Mar 2010 23:30:48 +0100
Copying CJ from #477266:

* Safir Secerovic <sapphire@linux.org.ba> [2010-03-27 22:33]:
> Package: flashplugin-nonfree-pulse
> Version: 0.1~000+nmu1
> Severity: important
> 
> This bug report is related to bug #477266 where this package was previously deprecated with the argument that newer version of Flash plugin, version 10 already interfaces with ALSA and PulseAudio seamlessly. As it turn out, it is not the case. Flashplugin only works if it is used first and no other applications is using sound through pulseaudio. With this support library, flash plugin works natively under pulseaudio without any problems thus, iceweasel is running stable without crashes at all. 
> Please reintroduce this package into Debian archive. 
> Debianized source is available at: 
>  http://pulseaudio.vdbonline.net
> It compiles and works on both the i386 and amd64 architectures.
> 
> 
> 
> -- System Information:
> Debian Release: squeeze/sid
>   APT prefers unstable
>   APT policy: (500, 'unstable'), (1, 'experimental')
> Architecture: amd64 (x86_64)
> 
> Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
> Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> 
> Versions of packages flashplugin-nonfree-pulse depends on:
> ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
> ii  libpulse0                     0.9.21-1   PulseAudio client libraries
> 
> Versions of packages flashplugin-nonfree-pulse recommends:
> ii  flashplugin-nonfree           1:2.8      Adobe Flash Player - browser plugi
> 
> Versions of packages flashplugin-nonfree-pulse suggests:
> ii  pulseaudio                    0.9.21-1   PulseAudio sound server
> 
> -- no debconf information
> 

-- 
Martin Michlmayr
http://www.cyrius.com/




Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#575645; Package wnpp. (Sat, 22 May 2010 05:42:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bryan Cebuliak <bryan.cebuliak@gmail.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Sat, 22 May 2010 05:42:03 GMT) Full text and rfc822 format available.

Message #21 received at 575645@bugs.debian.org (full text, mbox):

From: Bryan Cebuliak <bryan.cebuliak@gmail.com>
To: 575645@bugs.debian.org
Subject: flashplayer 10 with pulseaudio works ok for me with proper /etc/sound.conf configuration
Date: Sat, 22 May 2010 15:39:23 +1000
Setting the /etc/sound.conf to use pulseaudio as default fixed the
problem of no sound on Flashplayer 10 for me. My sound.conf is below.
The last two stanzas are the relevant ones to set the default to
pulseaudio:

pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

See:
http://forums.debian.net/viewtopic.php?t=12497




Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#575645; Package wnpp. (Sun, 23 May 2010 11:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bryan Cebuliak <bryan.cebuliak@gmail.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Sun, 23 May 2010 11:03:03 GMT) Full text and rfc822 format available.

Message #26 received at 575645@bugs.debian.org (full text, mbox):

From: Bryan Cebuliak <bryan.cebuliak@gmail.com>
To: 575645@bugs.debian.org
Subject: flashplayer 10 with pulseaudio works ok for me with proper /etc/asound.conf configuration
Date: Sun, 23 May 2010 20:58:59 +1000
Sorry, that should read /etc/asound.conf




Changed Bug title to 'RFP: flashplugin-nonfree-pulse -- Non free Flash plugin for Pulseaudio' from 'RFP: flashplugin-nonfree-pulse' Request was from Dario Minnucci <midget@debian.org> to control@bugs.debian.org. (Thu, 10 Feb 2011 21:45:08 GMT) Full text and rfc822 format available.

Changed Bug title to 'RFP: flashplugin-nonfree-pulse -- Non free Flash plugin for Pulse Audio' from 'RFP: flashplugin-nonfree-pulse -- Non free Flash plugin for Pulseaudio' Request was from Dario Minnucci <midget@debian.org> to control@bugs.debian.org. (Thu, 10 Feb 2011 22:03:09 GMT) Full text and rfc822 format available.

Severity set to 'wishlist' from 'important' Request was from Dario Minnucci <midget@debian.org> to control@bugs.debian.org. (Thu, 10 Feb 2011 22:27:16 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#575645; Package wnpp. (Thu, 21 Apr 2011 10:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Harald Thingelstad <harald@thingelstad.org>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Thu, 21 Apr 2011 10:03:07 GMT) Full text and rfc822 format available.

Message #37 received at 575645@bugs.debian.org (full text, mbox):

From: Harald Thingelstad <harald@thingelstad.org>
To: 575645@bugs.debian.org
Subject: Flashplayer 10 still has trouble with asound.conf workaround.
Date: Thu, 21 Apr 2011 11:06:33 +0200
It may work for some, but there are strange (and to me unknown)
troubles with setting /etc/asound.conf (as above). Other programs,
relying on the same workaround, not functioning. Dubious
issues making the workaround to work (last time, it finally helped
to reboot for some unknown reason). This is the third time (at least)
this has just stopped working after system updates (to Debian testing,
that is) and I'm just simply tired of this.

So could you folks please stop the disagreement, accept the asound.conf
workaround as the dubious, unstable abomination it is and allow
flashplugin-nonfree-pulse into the Debian archives as a fix?

I'd gladly use gnash if it allowed me play my video streams (YouTube
etc.) but currently it doesn't work and I have to use flashplugin
instead. More than half of the time, with my experience of it, without
sound. (And yes I'm sure I can fix it if I really want, but I have
other things to do and most of the time, I'm not such a media hog that I
bother.)

Regards,
Harald Thingelstad




Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#575645; Package wnpp. (Thu, 21 Apr 2011 20:27:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Harald Thingelstad <harald@thingelstad.org>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. (Thu, 21 Apr 2011 20:27:06 GMT) Full text and rfc822 format available.

Message #42 received at 575645@bugs.debian.org (full text, mbox):

From: Harald Thingelstad <harald@thingelstad.org>
To: 575645@bugs.debian.org
Subject: Okay...
Date: Thu, 21 Apr 2011 22:26:15 +0200
Okay.... After some searching...

Installing the libasound2-plugins package helped me. This time. As
described in Bug report #477266.

It actually works.

(Wonder what happens next time. Or if the problem may actually be
fixed now?)

Harald Thingelstad




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 13:38:06 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.