Debian Bug report logs - #573517
aptitude u crashes after editing /etc/apt/sources.list in kfreebsd-amd64

version graph

Package: aptitude; Maintainer for aptitude is Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>; Source for aptitude is src:aptitude.

Reported by: Marco Tulio Gontijo e Silva <marcot@debian.org>

Date: Fri, 12 Mar 2010 01:48:05 UTC

Severity: normal

Found in version aptitude/0.6.1.5-2

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, debian-bsd@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#573517; Package aptitude. (Fri, 12 Mar 2010 01:48:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Marco Tulio Gontijo e Silva <marcot@debian.org>:
New Bug report received and forwarded. Copy sent to debian-bsd@lists.debian.org, Daniel Burrows <dburrows@debian.org>. (Fri, 12 Mar 2010 01:48:08 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Marco Tulio Gontijo e Silva <marcot@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: aptitude u crashes after editing /etc/apt/sources.list in kfreebsd-amd64
Date: Thu, 11 Mar 2010 22:38:51 -0300
Package: aptitude
Version: 0.6.1.5-2
Severity: normal

I just installed Debian/KFreeBSD with the daily-image of debian-installer from
2010-01-21.  I edited /etc/apt/sources.list, runned aptitude, and pressed u.
I got:
Ouch!  Got SIGSEV, dying..
Ouch!  Got SIGSEV, dying..
Segmentation fault

So I runned aptitude update, and it worked.  After that I entered the GUI
again and selected some packages to install.  When I pressed g g I got the
same problem, segfault.  So I runned aptitude install and it worked.

I could reproduce these bugs deterministicly.  I`ll install aptitude-dbg and
see what I can get.

Greetings.

-- Package-specific info:
aptitude 0.6.1.5 compiled at Feb  3 2010 06:48:49
Compiler: g++ 4.4.3
Compiled against:
  apt version 4.8.0
  NCurses version 5.7
  libsigc++ version: 2.2.4.2
  Ept support enabled.
  Gtk+ support disabled.

Current library versions:
  NCurses version: ncurses 5.7.20090803
  cwidget version: 0.5.16
  Apt version: 4.8.0
	libapt-pkg-libc6.9-6.so.4.8 => /usr/lib/libapt-pkg-libc6.9-6.so.4.8 (0x0000000820225000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0x00000008204ec000)
	liblog4cxx.so.10 => /usr/lib/liblog4cxx.so.10 (0x000000082073d000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0x0000000820b2b000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0x0000000820d30000)
	libept.so.0 => /usr/lib/libept.so.0 (0x0000000820ffc000)
	libxapian.so.15 => /usr/lib/libxapian.so.15 (0x0000000821273000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00000008215c5000)
	libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00000008217dc000)
	libboost_iostreams.so.1.40.0 => /usr/lib/libboost_iostreams.so.1.40.0 (0x0000000821a69000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x0000000821c75000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0000000821e93000)
	libm.so.1 => /lib/libm.so.1 (0x00000008221a4000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0000000822427000)
	libc.so.0.1 => /lib/libc.so.0.1 (0x000000082263d000)
	libutil.so.1 => /lib/libutil.so.1 (0x000000082297d000)
	libdl.so.2 => /lib/libdl.so.2 (0x0000000822b81000)
	libaprutil-1.so.0 => /usr/lib/libaprutil-1.so.0 (0x0000000822d85000)
	libdb-4.8.so => /usr/lib/libdb-4.8.so (0x0000000822fa8000)
	libapr-1.so.0 => /usr/lib/libapr-1.so.0 (0x0000000823323000)
	libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x000000082355a000)
	/lib/ld-kfreebsd-x86-64.so.1 => /lib64/ld-kfreebsd-x86-64.so.1 (0x0000000020000000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x000000082376b000)
	librt.so.1 => /lib/librt.so.1 (0x000000082396f000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x0000000823b84000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0x0000000823dbc000)
Terminal: cons25
$DISPLAY not set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: kfreebsd-amd64 (x86_64)

Kernel: kFreeBSD 7.2-1-amd64
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6.9 0.7.25.3         Advanced front-end for dpkg
ii  libboost-iostreams1.40. 1.40.0-6+b1      Boost.Iostreams Library
ii  libc0.1                 2.10.2-6         Embedded GNU C Library: Shared lib
ii  libcwidget3             0.5.16-3         high-level terminal interface libr
ii  libept0                 0.5.30           High-level library for managing De
ii  libgcc1                 1:4.4.3-2        GCC support library
ii  liblog4cxx10            0.10.0-1.1       A logging library for C++
ii  libncursesw5            5.7+20090803-2   shared libraries for terminal hand
ii  libsigc++-2.0-0c2a      2.2.4.2-1        type-safe Signal Framework for C++
ii  libsqlite3-0            3.6.22-1         SQLite 3 shared library
ii  libstdc++6              4.4.3-2          The GNU Standard C++ Library v3
ii  libxapian15             1.0.18-1         Search engine library
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages aptitude recommends:
pn  apt-xapian-index              <none>     (no description available)
pn  aptitude-doc-en | aptitude-do <none>     (no description available)
pn  libparse-debianchangelog-perl <none>     (no description available)
ii  sensible-utils                0.0.2      Utilities for sensible alternative

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
ii  tasksel                       2.81       Tool for selecting tasks for insta

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#573517; Package aptitude. (Fri, 12 Mar 2010 08:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petr Salinger <Petr.Salinger@seznam.cz>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Fri, 12 Mar 2010 08:12:05 GMT) Full text and rfc822 format available.

Message #10 received at 573517@bugs.debian.org (full text, mbox):

From: Petr Salinger <Petr.Salinger@seznam.cz>
To: Marco Tulio Gontijo e Silva <marcot@debian.org>, 573517@bugs.debian.org
Subject: Re: Bug#573517: aptitude u crashes after editing /etc/apt/sources.list in kfreebsd-amd64
Date: Fri, 12 Mar 2010 11:13:02 +0100 (CET)
Hi.

> I just installed Debian/KFreeBSD with the daily-image of debian-installer from
> 2010-01-21.  I edited /etc/apt/sources.list, runned aptitude, and pressed u.
> I got:
> Ouch!  Got SIGSEV, dying..
> Ouch!  Got SIGSEV, dying..
> Segmentation fault
>
> So I runned aptitude update, and it worked.  After that I entered the GUI
> again and selected some packages to install.  When I pressed g g I got the
> same problem, segfault.  So I runned aptitude install and it worked.
>
> I could reproduce these bugs deterministicly.  I`ll install aptitude-dbg and
> see what I can get.

I cannot reproduce it here, neither under kfreebsd-amd64 neither under 
kfreebsd-i386.

It is not the fresh install, but up-to-date install.
The kernel is from 7.2 series, the coreutils is 7.5-6.
It seems coreutils 8.4-2 might have some problem with 7.2 kernels.
Tested on both console and from ssh-in shell.

Please could you verify your coreutils version,
mounted filesystesm - it should looks like:

/dev/ad0s1a on / (ufs, local)
devfs on /dev (devfs, local)
tmpfs on /lib/init/rw (tmpfs, local, nosuid)
linprocfs on /proc (linprocfs, local, noexec, nosuid)
linsysfs on /sys (linsysfs, local)
fdescfs on /dev/fd (fdescfs)

Please could you save your current package list,
do "apt-get update ; apt-get dist-upgrade" and retest ?

Does it change when you switch to 8.0 kernel ?

Petr




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#573517; Package aptitude. (Sat, 13 Mar 2010 14:30:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to marcot@debian.org:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Sat, 13 Mar 2010 14:30:04 GMT) Full text and rfc822 format available.

Message #15 received at 573517@bugs.debian.org (full text, mbox):

From: marcot@debian.org
To: 573517@bugs.debian.org
Subject: Result of some commands in the system
Date: Sat, 13 Mar 2010 06:26:40 -0800 (PST)
$ cat /etc/mtab
/dev/ad4s7 / ufs rw 0 0
devfs /dev devfs rw 0 0
linprocfs /proc linprocfs rw 0 0
/sys /sys sysfs rw 0 0
fdescfs /dev/fd fdescfs rw 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid 0 0

$ uname -a
GNU/kFreeBSD zezinho 7.2-1-amd64 #0 Fri Jan 15 17:02:08 UTC 2010 x86_64 amd64 Intel(R) Core(TM)2 Duo CPU     T5750  @ 2.00GHz GNU/kFreeBSD

$ dpkg -l coreutils
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                            Version                Description
+++-===============================================-======================-============================================
ii  coreutils                                       8.4-2                  GNU core utilities

After I installed kernel 8.0, the problem disappeared, but I got these crashes: 

As root

terminate called after throwing an instance of `cwidget::threads::ThreadJoinException'
Ouch!  Got SIGABORT, dying..
Aborted

As a user:

Uncaught exception: Unable to read from stdin: Operation not permitted




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 16:48:22 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.