Debian Bug report logs - #573336
xserver-xorg-video-intel: intel_drv xorg driver failure

version graph

Package: xserver-xorg-video-intel; Maintainer for xserver-xorg-video-intel is Debian X Strike Force <debian-x@lists.debian.org>; Source for xserver-xorg-video-intel is src:xserver-xorg-video-intel.

Reported by: vyrus <vyrus001@gmail.com>

Date: Wed, 10 Mar 2010 17:33:02 UTC

Severity: grave

Found in version xserver-xorg-video-intel/2:2.9.1-2

Done: Paul Wise <pabs@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, vyrus001@gmail.com, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#573336; Package xserver-xorg-video-intel. (Wed, 10 Mar 2010 17:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to vyrus <vyrus001@gmail.com>:
New Bug report received and forwarded. Copy sent to vyrus001@gmail.com, Debian X Strike Force <debian-x@lists.debian.org>. (Wed, 10 Mar 2010 17:33:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: vyrus <vyrus001@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: xserver-xorg-video-intel: intel_drv xorg driver failure
Date: Wed, 10 Mar 2010 09:32:44 -0800
Package: xserver-xorg-video-intel
Version: 2:2.9.1-2
Severity: grave
Justification: renders package unusable


When attempting to use the "intel" driver in xorg, gdm produces the following error.

X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.8-dsa-amd64 x86_64 Debian
Current Operating System: Linux l020050 2.6.32-trunk-amd64 #1 SMP Sun Jan 10 22:40:40 UTC 2010 x86_64
Kernel command line: root=/dev/sda1 ro single
Build Date: 16 February 2010  10:23:38AM
xorg-server 2:1.7.5-1 (buildd@brahms.debian.org) 
Current version of pixman: 0.16.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar  9 12:41:26 2010
(==) Using config file: "/etc/X11/xorg.conf"
xf86TokenToOptinfo: table is NULL
xf86TokenToOptinfo: table is NULL
/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: drm_intel_bo_disable_reuse

I believe the symbol in question is supposed to reside within the libdrm_intel1 library due to the fact that symbols of similar names seem to reside there.

-------
# objdump -T /usr/lib/libdrm_intel.so.1 | grep drm_intel_bo
0000000000005c20 g    DF .text	00000000000001ab  Base        drm_intel_bo_gem_create_from_name
0000000000001ad0 g    DF .text	0000000000000012  Base        drm_intel_bo_unreference
0000000000002670 g    DF .text	00000000000000b3  Base        drm_intel_bo_fake_disable_backing_store
0000000000001b00 g    DF .text	000000000000000a  Base        drm_intel_bo_unmap
0000000000001c80 g    DF .text	000000000000000d  Base        drm_intel_bo_references
....

# objdump -T /usr/lib/libdrm_intel.so.1 | grep drm_intel_bol_disable_reuse
-------

*note, i am posting this from a terminal being run inside xorg by using the "vesa" driver.  As such, i have modified the xorg.conf dump below to reflect the "accurate" config rather than the "current" config, as well as removed the xorg log dump since the only one produced is of xorg starting with vesa and there for does not apply to this issue.

-- Package-specific info:
/var/lib/x11/X.roster does not exist.

/var/lib/x11/X.md5sum does not exist.

X server symlink status:
lrwxrwxrwx 1 root root 13 Jan 23  2009 /etc/X11/X -> /usr/bin/Xorg
-rwxr-xr-x 1 root root 1866912 Feb 16 02:25 /usr/bin/Xorg

/var/lib/x11/xorg.conf.roster does not exist.

VGA-compatible devices on PCI bus:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

/var/lib/x11/xorg.conf.md5sum does not exist.

Xorg X server configuration file status:
-rw-r--r-- 1 root root 1237 Mar  9 12:44 /etc/X11/xorg.conf

Contents of /etc/X11/xorg.conf:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Extensions"
	Option		"Composite"	"enable"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"intel"
#	Driver		"vesa"
	Option		"RenderAccel"			"true"
	Option		"AccelMethod"			"XAA"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection


udev information:
DRM Information from dmesg:
[    1.160913] Linux agpgart interface v0.103
[    1.385015] agpgart: Detected an Intel Mobile Intel? GM45 Express Chipset.
[    1.385015] agpgart: Detected 32764K stolen memory.
[    1.393268] agpgart: AGP aperture is 256M @ 0xe0000000


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xserver-xorg-video-intel depends on:
ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
ii  libdrm-intel1                 2.4.18-2   Userspace interface to intel-speci
ii  libdrm2                       2.4.18-2   Userspace interface to kernel DRM 
ii  libpciaccess0                 0.11.0-1   Generic PCI access library for X
ii  libxext6                      2:1.1.1-2  X11 miscellaneous extension librar
ii  libxfixes3                    1:4.0.4-1  X11 miscellaneous 'fixes' extensio
ii  libxv1                        2:1.0.5-1  X11 Video extension library
ii  libxvmc1                      2:1.0.5-1  X11 Video extension library
ii  xserver-xorg-core             2:1.7.5-1  Xorg X server - core server

xserver-xorg-video-intel recommends no packages.

xserver-xorg-video-intel suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#573336; Package xserver-xorg-video-intel. (Wed, 10 Mar 2010 18:45:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to vyrus 001 <vyrus.001@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Wed, 10 Mar 2010 18:45:07 GMT) Full text and rfc822 format available.

Message #10 received at 573336@bugs.debian.org (full text, mbox):

From: vyrus 001 <vyrus.001@gmail.com>
To: 573336@bugs.debian.org
Subject: FIXED
Date: Wed, 10 Mar 2010 10:39:01 -0800
ive managed to fix this issuue  myself by removing the old copy of
libdrm_intel1 at /usr/local/lib/ so that the default link refers to
the copy in /usr/lib instead.




Reply sent to Paul Wise <pabs@debian.org>:
You have taken responsibility. (Sun, 14 Mar 2010 06:18:03 GMT) Full text and rfc822 format available.

Notification sent to vyrus <vyrus001@gmail.com>:
Bug acknowledged by developer. (Sun, 14 Mar 2010 06:18:03 GMT) Full text and rfc822 format available.

Message #15 received at 573336-done@bugs.debian.org (full text, mbox):

From: Paul Wise <pabs@debian.org>
To: 573336-done@bugs.debian.org
Subject: xserver-xorg-video-intel: 573336: closing, user error
Date: Sun, 14 Mar 2010 13:14:46 +0700
[Message part 1 (text/plain, inline)]
Hi all,

This bug looks to be due to user error: manually installed drm library
conflicting with packaged Intel driver.

Hello from the 2010 Thai BSP:

http://wiki.debian.org/DebianThailand/MiniDebCamp2010/BSP

-- 
bye,
pabs

http://wiki.debian.org/PaulWise
[signature.asc (application/pgp-signature, inline)]

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 11 Apr 2010 07:33:33 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 10:47:58 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.