Debian Bug report logs - #569090
Uses obsolete V4L1 API

version graph

Package: camstream; Maintainer for camstream is Martín Ferrari <tincho@debian.org>;

Reported by: Ben Hutchings <ben@decadent.org.uk>

Date: Wed, 10 Feb 2010 00:27:01 UTC

Severity: serious

Tags: patch, sid, squeeze

Found in version camstream/0.27+dfsg-3

Fixed in version camstream/0.27+dfsg-4

Done: Martín Ferrari <tincho@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Martín Ferrari <tincho@debian.org>:
Bug#569090; Package camstream. (Wed, 10 Feb 2010 00:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Hutchings <ben@decadent.org.uk>:
New Bug report received and forwarded. Copy sent to Martín Ferrari <tincho@debian.org>. (Wed, 10 Feb 2010 00:27:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Ben Hutchings <ben@decadent.org.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Uses obsolete V4L1 API
Date: Wed, 10 Feb 2010 00:25:53 +0000
[Message part 1 (text/plain, inline)]
Package: camstream
Version: 0.27+dfsg-3
Severity: serious
Tags: patch

The V4L1 API is obsolete and does not work with most new V4L drivers.
You can use libv4l as an emulation layer; see the attached patch by
Hans de Goede.

Ben.

-- System Information:
Debian Release: squeeze/sid
  APT prefers proposed-updates
  APT policy: (500, 'proposed-updates'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 2.6.32-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
[camstream-0.26.3-libv4l.patch (text/x-diff, attachment)]

Added tag(s) sid and squeeze. Request was from Ben Hutchings <ben@decadent.org.uk> to control@bugs.debian.org. (Wed, 10 Feb 2010 01:03:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Martín Ferrari <tincho@debian.org>:
Bug#569090; Package camstream. (Wed, 17 Feb 2010 15:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martín Ferrari <martin.ferrari@gmail.com>:
Extra info received and forwarded to list. Copy sent to Martín Ferrari <tincho@debian.org>. (Wed, 17 Feb 2010 15:48:03 GMT) Full text and rfc822 format available.

Message #12 received at 569090@bugs.debian.org (full text, mbox):

From: Martín Ferrari <martin.ferrari@gmail.com>
To: Ben Hutchings <ben@decadent.org.uk>, 569090@bugs.debian.org
Subject: Re: Bug#569090: Uses obsolete V4L1 API
Date: Wed, 17 Feb 2010 16:43:57 +0100
Thanks for reporting! :)

On Wed, Feb 17, 2010 at 16:42, Martín Ferrari <martin.ferrari@gmail.com> wrote:
> On Wed, Feb 10, 2010 at 01:25, Ben Hutchings <ben@decadent.org.uk> wrote:
>
>> The V4L1 API is obsolete and does not work with most new V4L drivers.
>> You can use libv4l as an emulation layer; see the attached patch by
>> Hans de Goede.
>
> Although the patch couldn't be applied as it's for an old version, I
> used it as base for a new patch. I'm uploading this today.
>
> --
> Martín Ferrari
>



-- 
Martín Ferrari




Information forwarded to debian-bugs-dist@lists.debian.org, Martín Ferrari <tincho@debian.org>:
Bug#569090; Package camstream. (Wed, 17 Feb 2010 15:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martín Ferrari <martin.ferrari@gmail.com>:
Extra info received and forwarded to list. Copy sent to Martín Ferrari <tincho@debian.org>. (Wed, 17 Feb 2010 15:51:03 GMT) Full text and rfc822 format available.

Message #17 received at 569090@bugs.debian.org (full text, mbox):

From: Martín Ferrari <martin.ferrari@gmail.com>
To: Ben Hutchings <ben@decadent.org.uk>, 569090@bugs.debian.org
Subject: Re: Bug#569090: Uses obsolete V4L1 API
Date: Wed, 17 Feb 2010 16:42:41 +0100
On Wed, Feb 10, 2010 at 01:25, Ben Hutchings <ben@decadent.org.uk> wrote:

> The V4L1 API is obsolete and does not work with most new V4L drivers.
> You can use libv4l as an emulation layer; see the attached patch by
> Hans de Goede.

Although the patch couldn't be applied as it's for an old version, I
used it as base for a new patch. I'm uploading this today.

-- 
Martín Ferrari




Reply sent to Martín Ferrari <tincho@debian.org>:
You have taken responsibility. (Wed, 17 Feb 2010 17:03:13 GMT) Full text and rfc822 format available.

Notification sent to Ben Hutchings <ben@decadent.org.uk>:
Bug acknowledged by developer. (Wed, 17 Feb 2010 17:03:13 GMT) Full text and rfc822 format available.

Message #22 received at 569090-close@bugs.debian.org (full text, mbox):

From: Martín Ferrari <tincho@debian.org>
To: 569090-close@bugs.debian.org
Subject: Bug#569090: fixed in camstream 0.27+dfsg-4
Date: Wed, 17 Feb 2010 17:02:31 +0000
Source: camstream
Source-Version: 0.27+dfsg-4

We believe that the bug you reported is fixed in the latest version of
camstream, which is due to be installed in the Debian FTP archive:

camstream-doc_0.27+dfsg-4_all.deb
  to main/c/camstream/camstream-doc_0.27+dfsg-4_all.deb
camstream_0.27+dfsg-4.diff.gz
  to main/c/camstream/camstream_0.27+dfsg-4.diff.gz
camstream_0.27+dfsg-4.dsc
  to main/c/camstream/camstream_0.27+dfsg-4.dsc
camstream_0.27+dfsg-4_i386.deb
  to main/c/camstream/camstream_0.27+dfsg-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 569090@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Martín Ferrari <tincho@debian.org> (supplier of updated camstream package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 17 Feb 2010 16:14:06 +0100
Source: camstream
Binary: camstream camstream-doc
Architecture: source i386 all
Version: 0.27+dfsg-4
Distribution: unstable
Urgency: low
Maintainer: Martín Ferrari <tincho@debian.org>
Changed-By: Martín Ferrari <tincho@debian.org>
Description: 
 camstream  - collection of tools for webcams and other video-devices
 camstream-doc - documentation for CamStream
Closes: 569090
Changes: 
 camstream (0.27+dfsg-4) unstable; urgency=low
 .
   * debian/patches/use_libv4l1.patch: Use the libv4l1 compatibility library.
     Closes: #569090.
   * debian/control: Add libv4l dependency. Remove duplicate Section.
   * debian/control: Bumped Standards-Version to 3.8.4; changes required:
     - debian/README.source: quilt boilerplate README.
     - debian/patches: add descriptions.
Checksums-Sha1: 
 9a011098b95d16db12347b13b1be68a2e04c29de 1202 camstream_0.27+dfsg-4.dsc
 fbaef327f0da5d71b039254e93cd60688cdcd744 23809 camstream_0.27+dfsg-4.diff.gz
 bdc172f63f400a50fcf3c544b9224d2daa349030 366480 camstream_0.27+dfsg-4_i386.deb
 2cc2a455d201a141a483237a8b1146f39e02f450 2982580 camstream-doc_0.27+dfsg-4_all.deb
Checksums-Sha256: 
 8a6740c790c4949c5a2a5a438c60bba75c7e5ba8244b6c0c5487c527da2c5af2 1202 camstream_0.27+dfsg-4.dsc
 0c4e18c4d907db8305220911a4ec0d3cdf898847c0a953cf92ef59b5ed9030b5 23809 camstream_0.27+dfsg-4.diff.gz
 4659d890542dd8245af1e3a6df58cf397f3b8c5eff60ee2c29a015856651528e 366480 camstream_0.27+dfsg-4_i386.deb
 5a4e1c645b7c5a84df3b3368846320dd2dcf5b312a1d3907f445de41ab390fe9 2982580 camstream-doc_0.27+dfsg-4_all.deb
Files: 
 4265e9a310e74cee26e4ba31545d65d4 1202 misc optional camstream_0.27+dfsg-4.dsc
 6911f36ab5054cf7b8cbb66b10780027 23809 misc optional camstream_0.27+dfsg-4.diff.gz
 eee3ddbd63ecda1fef575ab1d403592b 366480 misc optional camstream_0.27+dfsg-4_i386.deb
 54ea92702ff9f8807d3333277c0feb82 2982580 doc optional camstream-doc_0.27+dfsg-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkt8CLQACgkQaWQ2v1ddCnYjrgCeNXHrtPG+Snrs7j5g//inHf4A
deEAnigCxYjkDpV0VkJIK4h4fttGrBap
=1oHO
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 07 Mar 2011 10:18:27 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 01:40:14 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.