Debian Bug report logs - #562214
libdevel-cover-perl: Warnings about having been built against different Perl version

version graph

Package: libdevel-cover-perl; Maintainer for libdevel-cover-perl is Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>; Source for libdevel-cover-perl is src:libdevel-cover-perl.

Reported by: Tim Retout <diocles@debian.org>

Date: Wed, 23 Dec 2009 20:51:02 UTC

Severity: important

Found in version libdevel-cover-perl/0.65-1

Fixed in version libdevel-cover-perl/0.66-1

Done: gregor herrmann <gregoa@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 20:51:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Tim Retout <tim@retout.co.uk>:
New Bug report received and forwarded. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 20:51:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Tim Retout <tim@retout.co.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 20:50:20 +0000
Package: libdevel-cover-perl
Version: 0.65-1
Severity: important

When running Devel::Cover, I get some unsightly warnings:

 t/pod-coverage.t .. ok   
 t/pod.t ........... 
 This version of Devel::Cover was built with Perl version 5.010000.
 It is now being run with Perl version 5.010001.
 Attempting to make adjustments, but you may find that some of your modules do
 not have coverage data collected.  You may need to alter the +-inc, +-ignore
 and +-select options.

 t/pod.t ........... ok

So we need to tighten up the Depends to match the version of Perl that
libdevel-cover-perl was compiled against.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libdevel-cover-perl depends on:
ii  libc6                         2.10.2-2   GNU C Library: Shared libraries
ii  perl                          5.10.1-8   Larry Wall's Practical Extraction 
ii  perl-base [perlapi-5.10.0]    5.10.1-8   minimal Perl system

libdevel-cover-perl recommends no packages.

Versions of packages libdevel-cover-perl suggests:
ii  libpod-coverage-perl          0.20-1     checker for comprehensiveness of p
pn  libppi-html-perl | perltidy   <none>     (no description available)
ii  libtemplate-perl              2.20-1     template processing system written
pn  libtest-differences-perl      <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 21:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Yu <jonathan.i.yu@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 21:12:04 GMT) Full text and rfc822 format available.

Message #10 received at 562214@bugs.debian.org (full text, mbox):

From: Jonathan Yu <jonathan.i.yu@gmail.com>
To: Tim Retout <tim@retout.co.uk>, 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 16:09:43 -0500
On Wed, Dec 23, 2009 at 3:50 PM, Tim Retout <tim@retout.co.uk> wrote:
> So we need to tighten up the Depends to match the version of Perl that
> libdevel-cover-perl was compiled against.
I get these warnings too, and have always considered them more of an
annoyance than a bug. I have been thinking about how to deal with this
issue, but I have not come up with an elegant solution that would suit
our purpose. I'd love to hear about this from the rest of the group.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 21:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ryan Niebur <ryan@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 21:21:05 GMT) Full text and rfc822 format available.

Message #15 received at 562214@bugs.debian.org (full text, mbox):

From: Ryan Niebur <ryan@debian.org>
To: Jonathan Yu <jonathan.i.yu@gmail.com>
Cc: Tim Retout <tim@retout.co.uk>, 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 13:19:29 -0800
[Message part 1 (text/plain, inline)]
On Wed, Dec 23, 2009 at 04:09:43PM -0500, Jonathan Yu wrote:
> On Wed, Dec 23, 2009 at 3:50 PM, Tim Retout <tim@retout.co.uk> wrote:
> > So we need to tighten up the Depends to match the version of Perl that
> > libdevel-cover-perl was compiled against.
> I get these warnings too, and have always considered them more of an
> annoyance than a bug. I have been thinking about how to deal with this
> issue, but I have not come up with an elegant solution that would suit
> our purpose. I'd love to hear about this from the rest of the group.
> 

lets just binnmu them as we find them?

-- 
_________________________
Ryan Niebur
ryanryan52@gmail.com
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 23:09:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Tim Retout <tim@retout.co.uk>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 23:09:03 GMT) Full text and rfc822 format available.

Message #20 received at 562214@bugs.debian.org (full text, mbox):

From: Tim Retout <tim@retout.co.uk>
To: Ryan Niebur <ryan@debian.org>
Cc: Jonathan Yu <jonathan.i.yu@gmail.com>, 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 23:07:33 +0000
On Wed, 2009-12-23 at 13:19 -0800, Ryan Niebur wrote:
> On Wed, Dec 23, 2009 at 04:09:43PM -0500, Jonathan Yu wrote:
> > On Wed, Dec 23, 2009 at 3:50 PM, Tim Retout <tim@retout.co.uk> wrote:
> > > So we need to tighten up the Depends to match the version of Perl that
> > > libdevel-cover-perl was compiled against.
> > I get these warnings too, and have always considered them more of an
> > annoyance than a bug. I have been thinking about how to deal with this
> > issue, but I have not come up with an elegant solution that would suit
> > our purpose. I'd love to hear about this from the rest of the group.
> > 
> 
> lets just binnmu them as we find them?

Yes to this.

But to spot these more easily in the future, we can add some magic to
debian/rules and debian/control to force the dependency.  They'll still
need a binNMU, but I suspect that some automated/manual mechanisms will
pick this up sooner if it causes an installability problem (hopefully
without having to involve pkg-perl at all).

It's only a trivial annoyance with 5.10.0 and 5.10.1, but with future
jumps it could break stuff, in the worst case.

-- 
Tim Retout <tim@retout.co.uk>




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 23:18:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ryan Niebur <ryanryan52@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 23:18:07 GMT) Full text and rfc822 format available.

Message #25 received at 562214@bugs.debian.org (full text, mbox):

From: Ryan Niebur <ryanryan52@gmail.com>
To: Tim Retout <tim@retout.co.uk>
Cc: Jonathan Yu <jonathan.i.yu@gmail.com>, 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 15:16:34 -0800
[Message part 1 (text/plain, inline)]
On Wed, Dec 23, 2009 at 11:07:33PM +0000, Tim Retout wrote:
> On Wed, 2009-12-23 at 13:19 -0800, Ryan Niebur wrote:
> > On Wed, Dec 23, 2009 at 04:09:43PM -0500, Jonathan Yu wrote:
> > > On Wed, Dec 23, 2009 at 3:50 PM, Tim Retout <tim@retout.co.uk> wrote:
> > > > So we need to tighten up the Depends to match the version of Perl that
> > > > libdevel-cover-perl was compiled against.
> > > I get these warnings too, and have always considered them more of an
> > > annoyance than a bug. I have been thinking about how to deal with this
> > > issue, but I have not come up with an elegant solution that would suit
> > > our purpose. I'd love to hear about this from the rest of the group.
> > > 
> > 
> > lets just binnmu them as we find them?
> 
> Yes to this.
> 
> But to spot these more easily in the future, we can add some magic to
> debian/rules and debian/control to force the dependency.  They'll still
> need a binNMU, but I suspect that some automated/manual mechanisms will
> pick this up sooner if it causes an installability problem (hopefully
> without having to involve pkg-perl at all).
> 
> It's only a trivial annoyance with 5.10.0 and 5.10.1, but with future
> jumps it could break stuff, in the worst case.
> 

we already have dh_perl which sets perl:Depends for us. perhaps it
could be extended for cases like this to make the dependency break
with new upstream perl versions. I wonder, is there any way we can
tell (from code) that it needs to have the stricter dependencies?

-- 
_________________________
Ryan Niebur
ryanryan52@gmail.com
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Wed, 23 Dec 2009 23:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ryan Niebur <ryanryan52@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Wed, 23 Dec 2009 23:36:03 GMT) Full text and rfc822 format available.

Message #30 received at 562214@bugs.debian.org (full text, mbox):

From: Ryan Niebur <ryanryan52@gmail.com>
To: Tim Retout <tim@retout.co.uk>
Cc: Jonathan Yu <jonathan.i.yu@gmail.com>, 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Wed, 23 Dec 2009 15:34:29 -0800
[Message part 1 (text/plain, inline)]
On Wed, Dec 23, 2009 at 03:16:34PM -0800, Ryan Niebur wrote:
> On Wed, Dec 23, 2009 at 11:07:33PM +0000, Tim Retout wrote:
> > On Wed, 2009-12-23 at 13:19 -0800, Ryan Niebur wrote:
> > > On Wed, Dec 23, 2009 at 04:09:43PM -0500, Jonathan Yu wrote:
> > > > On Wed, Dec 23, 2009 at 3:50 PM, Tim Retout <tim@retout.co.uk> wrote:
> > > > > So we need to tighten up the Depends to match the version of Perl that
> > > > > libdevel-cover-perl was compiled against.
> > > > I get these warnings too, and have always considered them more of an
> > > > annoyance than a bug. I have been thinking about how to deal with this
> > > > issue, but I have not come up with an elegant solution that would suit
> > > > our purpose. I'd love to hear about this from the rest of the group.
> > > > 
> > > 
> > > lets just binnmu them as we find them?
> > 
> > Yes to this.
> > 
> > But to spot these more easily in the future, we can add some magic to
> > debian/rules and debian/control to force the dependency.  They'll still
> > need a binNMU, but I suspect that some automated/manual mechanisms will
> > pick this up sooner if it causes an installability problem (hopefully
> > without having to involve pkg-perl at all).
> > 
> > It's only a trivial annoyance with 5.10.0 and 5.10.1, but with future
> > jumps it could break stuff, in the worst case.
> > 
> 
> we already have dh_perl which sets perl:Depends for us. perhaps it
> could be extended for cases like this to make the dependency break
> with new upstream perl versions. I wonder, is there any way we can
> tell (from code) that it needs to have the stricter dependencies?
> 

actually, this already happens. for example, libdevel-cover-perl
depends on perlapi-5.10.0. the problem with this is that the new
version of perl-base provides both perlapi-5.10.0 and perlapi-5.10.1.
so we do have a way to deal with this when it really would matter, the
perl maintainers just didn't use it this time (becuase it doesn't
really matter). perhaps it really should have been used this time,
and we should just binnmu everything that still depends on perlapi-5.10.0?
I'm guessing a discussion with the perl maintainer who left it
providing perlapi-5.10.0 would be insightful for us.

-- 
_________________________
Ryan Niebur
ryanryan52@gmail.com
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Fri, 25 Dec 2009 13:03:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Fri, 25 Dec 2009 13:03:06 GMT) Full text and rfc822 format available.

Message #35 received at 562214@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 562214@bugs.debian.org
Cc: perl@packages.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Fri, 25 Dec 2009 15:00:04 +0200
(cc'ing perl@packages.d.o)

On Wed, Dec 23, 2009 at 03:34:29PM -0800, Ryan Niebur wrote:

> actually, this already happens. for example, libdevel-cover-perl
> depends on perlapi-5.10.0. the problem with this is that the new
> version of perl-base provides both perlapi-5.10.0 and perlapi-5.10.1.
> so we do have a way to deal with this when it really would matter, the
> perl maintainers just didn't use it this time (becuase it doesn't
> really matter). perhaps it really should have been used this time,
> and we should just binnmu everything that still depends on perlapi-5.10.0?
> I'm guessing a discussion with the perl maintainer who left it
> providing perlapi-5.10.0 would be insightful for us.

As 5.10.0 and 5.10.1 are supposed to be ABI compatible, perl-base
currently provides both perlapi-5.10.0 and perlapi-5.10.1. Cf. perl-base
in Etch, which provides everything from perlapi-5.8.0 through to
perlapi-5.8.8.

I think the perlapi-* scheme was devised before upstream settled on a
policy of binary compatibility across minor updates. We could possibly do
with just perlapi-5.10 nowadays (or maybe it should be named perlabi-5.10 ?).

Anyway, I'm not thrilled about dropping perlapi-5.10.0 and requiring 270
or so binNMUs just because Devel::Cover thinks it might have a problem
with a newer Perl upstream version.

I suppose extending dh_perl a bit could give a scalable way to require
binNMUs for selected packages when the Perl upstream version changes.
Just a new flag to substitute ${perl:Depends} with something like
 perl (>= 5.10.1-8), perl (<< 5.10.2~)
would do AFAICS.
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Fri, 25 Dec 2009 14:00:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Fri, 25 Dec 2009 14:00:06 GMT) Full text and rfc822 format available.

Message #40 received at 562214@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: Niko Tyni <ntyni@debian.org>, 562214@bugs.debian.org
Cc: perl@packages.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Fri, 25 Dec 2009 14:56:52 +0100
[Message part 1 (text/plain, inline)]
On Fri, 25 Dec 2009 15:00:04 +0200, Niko Tyni wrote:

> Anyway, I'm not thrilled about dropping perlapi-5.10.0 and requiring 270
> or so binNMUs just because Devel::Cover thinks it might have a problem
> with a newer Perl upstream version.

It's not the only package, I remember playing with substvars in one
or two other packages before.
But I'm also a bit hesitant about _this_ drastic solution.
 
> I suppose extending dh_perl a bit could give a scalable way to require
> binNMUs for selected packages when the Perl upstream version changes.
> Just a new flag to substitute ${perl:Depends} with something like
>  perl (>= 5.10.1-8), perl (<< 5.10.2~)
> would do AFAICS.

That would indeed be nice, and IIRC this idea already came up in the
discussion about the last issue (probably on IRC).

I guess someone[tm] should try to hack up something :)

Cheers,
gregor 
-- 
 .''`.   http://info.comodo.priv.at/ -- GPG Key IDs: 0x00F3CFE4, 0x8649AA06
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Queen: Ride The Wild Wind
[signature.asc (application/pgp-signature, inline)]

Changed Bug submitter to 'Tim Retout <diocles@debian.org>' from 'Tim Retout <tim@retout.co.uk>' Request was from Tim Retout <diocles@debian.org> to control@bugs.debian.org. (Sat, 16 Jan 2010 00:18:17 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Sun, 18 Apr 2010 13:21:15 GMT) Full text and rfc822 format available.

Message #45 received at 562214@bugs.debian.org (full text, mbox):

From: Damyan Ivanov <dmn@debian.org>
To: 562214@bugs.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Sun, 18 Apr 2010 16:18:10 +0300
[Message part 1 (text/plain, inline)]
-=| gregor herrmann, Fri, Dec 25, 2009 at 02:56:52PM +0100 |=-
> On Fri, 25 Dec 2009 15:00:04 +0200, Niko Tyni wrote:
> > I suppose extending dh_perl a bit could give a scalable way to 
> > require
> > binNMUs for selected packages when the Perl upstream version changes.
> > Just a new flag to substitute ${perl:Depends} with something like
> >  perl (>= 5.10.1-8), perl (<< 5.10.2~)
> > would do AFAICS.
> 
> That would indeed be nice, and IIRC this idea already came up in the
> discussion about the last issue (probably on IRC).
> 
> I guess someone[tm] should try to hack up something :)

How about providing a new substvar? Something like ${perl:Same}  or 
${perl:Built} that would expand to a proper >=, << dependency like the 
one above.

A new substvar would avoid adding command-line switches to dh_perl, 
which may be hidden in a 'dh' call.
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Sun, 25 Apr 2010 12:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Sun, 25 Apr 2010 12:36:03 GMT) Full text and rfc822 format available.

Message #50 received at 562214@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 562214@bugs.debian.org
Cc: debhelper@packages.debian.org
Subject: Re: Bug#562214: libdevel-cover-perl: Warnings about having been built against different Perl version
Date: Sun, 25 Apr 2010 15:33:57 +0300
clone 562214 -1
retitle -1 debhelper: dh_perl: substitute a dependency on the current perl upstream version
severity -1 wishlist
submitter -1 !
reassign -1 debhelper 7.4.17
thanks

On Sun, Apr 18, 2010 at 04:18:10PM +0300, Damyan Ivanov wrote:
> -=| gregor herrmann, Fri, Dec 25, 2009 at 02:56:52PM +0100 |=-
> > On Fri, 25 Dec 2009 15:00:04 +0200, Niko Tyni wrote:
> > > I suppose extending dh_perl a bit could give a scalable way to 
> > > require
> > > binNMUs for selected packages when the Perl upstream version changes.
> > > Just a new flag to substitute ${perl:Depends} with something like
> > >  perl (>= 5.10.1-8), perl (<< 5.10.2~)
> > > would do AFAICS.
> > 
> > That would indeed be nice, and IIRC this idea already came up in the
> > discussion about the last issue (probably on IRC).
> > 
> > I guess someone[tm] should try to hack up something :)
> 
> How about providing a new substvar? Something like ${perl:Same}  or 
> ${perl:Built} that would expand to a proper >=, << dependency like the 
> one above.
> 
> A new substvar would avoid adding command-line switches to dh_perl, 
> which may be hidden in a 'dh' call.

I like the separate switch approach flag better. The case is rare enough that
having an override_dh_perl target is not much of a burden IMO.

But that's Joey's call, assuming he's OK with having this in debhelper.
I'm cloning a wishlist bug.
-- 
Niko Tyni   ntyni@debian.org




Bug 562214 cloned as bug 579112. Request was from Niko Tyni <ntyni@debian.org> to control@bugs.debian.org. (Sun, 25 Apr 2010 12:36:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#562214; Package libdevel-cover-perl. (Tue, 27 Apr 2010 07:15:03 GMT) Full text and rfc822 format available.

Message #55 received at 562214@bugs.debian.org (full text, mbox):

From: pkg-perl-maintainers@lists.alioth.debian.org
To: 562214@bugs.debian.org, 562214-submitter@bugs.debian.org
Subject: Bug in libdevel-cover-perl fixed in revision 57004
Date: Tue, 27 Apr 2010 07:11:34 +0000
tag 562214 + pending
thanks

Some bugs are closed in revision 57004
by Niko Tyni (ntyni)

Commit message:

add a dependency on the current Perl upstream version. (Closes: #562214)




Added tag(s) pending. Request was from pkg-perl-maintainers@lists.alioth.debian.org to control@bugs.debian.org. (Tue, 27 Apr 2010 07:15:08 GMT) Full text and rfc822 format available.

Message sent on to Tim Retout <diocles@debian.org>:
Bug#562214. (Tue, 27 Apr 2010 07:15:11 GMT) Full text and rfc822 format available.

Reply sent to gregor herrmann <gregoa@debian.org>:
You have taken responsibility. (Wed, 28 Apr 2010 17:21:11 GMT) Full text and rfc822 format available.

Notification sent to Tim Retout <diocles@debian.org>:
Bug acknowledged by developer. (Wed, 28 Apr 2010 17:21:11 GMT) Full text and rfc822 format available.

Message #65 received at 562214-close@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: 562214-close@bugs.debian.org
Subject: Bug#562214: fixed in libdevel-cover-perl 0.66-1
Date: Wed, 28 Apr 2010 17:18:09 +0000
Source: libdevel-cover-perl
Source-Version: 0.66-1

We believe that the bug you reported is fixed in the latest version of
libdevel-cover-perl, which is due to be installed in the Debian FTP archive:

libdevel-cover-perl_0.66-1.debian.tar.gz
  to main/libd/libdevel-cover-perl/libdevel-cover-perl_0.66-1.debian.tar.gz
libdevel-cover-perl_0.66-1.dsc
  to main/libd/libdevel-cover-perl/libdevel-cover-perl_0.66-1.dsc
libdevel-cover-perl_0.66-1_i386.deb
  to main/libd/libdevel-cover-perl/libdevel-cover-perl_0.66-1_i386.deb
libdevel-cover-perl_0.66.orig.tar.gz
  to main/libd/libdevel-cover-perl/libdevel-cover-perl_0.66.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 562214@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
gregor herrmann <gregoa@debian.org> (supplier of updated libdevel-cover-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 28 Apr 2010 18:47:51 +0200
Source: libdevel-cover-perl
Binary: libdevel-cover-perl
Architecture: source i386
Version: 0.66-1
Distribution: unstable
Urgency: low
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: gregor herrmann <gregoa@debian.org>
Description: 
 libdevel-cover-perl - Perl tool for determining code coverage metrics
Closes: 562214 578809
Changes: 
 libdevel-cover-perl (0.66-1) unstable; urgency=low
 .
   [ Ryan Niebur ]
   * Update jawnsy's email address
 .
   [ gregor herrmann ]
   * New upstream release (Closes: #578809).
   * Convert to source format 3.0 (quilt). Remove quilt framework.
   * debian/copyright: update years of upstream copyright and formatting
     according to current version of DEP5.
   * Add /me to Uploaders.
   * Set Standards-Version to 3.8.4 (no changes).
   * Add new patch to fix a spelling mistake.
 .
   [ Niko Tyni ]
   * add a dependency on the current Perl upstream version. (Closes: #562214)
Checksums-Sha1: 
 98e421c2d7b0a211e3e42dd874b23c5bb2d8eb62 2097 libdevel-cover-perl_0.66-1.dsc
 6a5432354bb72f63177531da740fb906866aad27 149858 libdevel-cover-perl_0.66.orig.tar.gz
 6a9bd697c8c94ff02e1c0c81fdb027d1ee8c7d74 4557 libdevel-cover-perl_0.66-1.debian.tar.gz
 9f4930d11dce0c8a6588ba0ef431deaba89c0a11 173986 libdevel-cover-perl_0.66-1_i386.deb
Checksums-Sha256: 
 2297131df996f15155f77844549d250aad6ce7fc03850e8945b8dd50873680bf 2097 libdevel-cover-perl_0.66-1.dsc
 063ad2ee43ae96aeba406004389d8e029729b7662aacae2e3663a9a9940a2b53 149858 libdevel-cover-perl_0.66.orig.tar.gz
 a5daebb2094d401a23174bc18d1d3f4fd2a205d8c21a37921308a8bca48c3645 4557 libdevel-cover-perl_0.66-1.debian.tar.gz
 5f5678d706bf34805431c958fc8e5ae40d8f672f0f5017fee6988dcedd8d87e7 173986 libdevel-cover-perl_0.66-1_i386.deb
Files: 
 fc120c8cb8a5a742b28a8639b194e9be 2097 perl optional libdevel-cover-perl_0.66-1.dsc
 db1a982fc82454c4f5a2d8edcc857cf3 149858 perl optional libdevel-cover-perl_0.66.orig.tar.gz
 ba98f59fca3f43417f03583434d88586 4557 perl optional libdevel-cover-perl_0.66-1.debian.tar.gz
 788db1a4a884063b5736af3fe174b307 173986 perl optional libdevel-cover-perl_0.66-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJL2Gg5AAoJELs6aAGGSaoGWoYP/1v6MEHNSdJDlu+XdvLk2ma9
TBCLlOU4LcfsQ911R1enkcZfLnc3N02LXo3XqJ1NRuABvOnKdePM4dxBMSwP9irG
LrimnrbP0PpmoNLncRxLdpjS4jPt1IJFmG3F6db71jUTLvzhNi+qbLKtUEhmBTvj
5zn4TOIeivOoZwnBxcw+NgQoWzOpR87hHaITUZD9UdREU2d77GIquBDSeaXEKrDe
8Vmt4GzwbMKF8sWuSgjLPgUihuSboElKjVc3YZBDzdUu5E8WRp5NmD4E42BEdz5I
3wRw6JPwZrejIis3giSyMeH9YFrpCNGuqdtAYF31mK3MSgN3FxhAiy2sh85FWdm+
xjTN49vjlWpsMyZCscHnpL7EaGqXWUgIceMugffb5udKuruZUFFTbGgG1M/WmT5+
ZkzDMl0kYMqwMhqjpegY5LN+SVDq0Ayi2JYgKf770/ocTrojcqv94nlfnsKSqWT8
VEZBJfZQ/rhUjELPvt3WXnmUMoKLlhR8iqR42NvSs94PIFg4SFPWQlEX7ndzH25v
o/h6B4ebIxDmpsLeX0+VJ5AaqgKW+r9ZzuFetVha7nyq3QvTpoiPSghIjmqDF836
iE5LBjtLIvGW4b2QlPJc7V+PPd7EBSI2BNZw9q0PQgMARVV9HFYd4RKLdS9SOWHH
QYh9xpFp5097iO0GMAq6
=IZnw
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 27 May 2010 07:30:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 16:07:07 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.