Debian Bug report logs - #561737
udisks, gvfs, nautilus: mounting floppies not working (no media in drive)

version graph

Package: udisks; Maintainer for udisks is Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>; Source for udisks is src:udisks.

Reported by: Wendy Elmer <webe3vt@aim.com>

Date: Sun, 20 Dec 2009 00:00:02 UTC

Severity: normal

Tags: fixed-upstream, help

Merged with 561746, 592719, 596890, 622618

Found in versions udisks/1.0.1+git20100614-3, udisks/1.0.1+git20100614-1

Blocking fix for 669973: gvfs: mounting floppies fails: `No volume for device file /dev/fd0`

Forwarded to https://bugs.freedesktop.org/show_bug.cgi?id=30283

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Josselin Mouette <joss@debian.org>:
Bug#561737; Package nautilus. (Sun, 20 Dec 2009 00:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Wendy Elmer <webe3vt@aim.com>:
New Bug report received and forwarded. Copy sent to Josselin Mouette <joss@debian.org>. (Sun, 20 Dec 2009 00:00:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Wendy Elmer <webe3vt@aim.com>
To: submit@bugs.debian.org
Subject: [nautilus] can't mount floppy(no media in drive)
Date: Sat, 19 Dec 2009 18:58:25 -0500
[Message part 1 (text/plain, inline)]
Package: nautilus
Version: 2.28.1-1
Severity: important

--- Please enter the report below this line. ---
When I go to the computer desktop icon and click on Floppy Drive with a floppy in the drive,
A popup window says "Unable to mount location No medium in the drive".  
I hear the floppy click when this happens.  If I try to mount manually from 
an exterm using mount /dev/fd0 /media/floppy
it tells me
mount: only root can do that

I used to be able to mount the floppy.  This is happening on 2 Squeeze 
computers.  Both were able to read the floppy a week or so ago.

--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.30.091103

Debian Release: squeeze/sid
  500 testing         security.debian.org 
  500 testing         debian.yorku.ca 
  500 testing         debian-multimedia.org 
  500 squeeze         www.lamaresh.net 
  500 jaunty          ppa.launchpad.net 

--- Package information. ---
Depends                       (Version) | Installed
=======================================-+-=============
libatk1.0-0                 (>= 1.20.0) | 1.28.0-1
libbeagle1                   (>= 0.3.9) | 0.3.9-1
libc6                          (>= 2.7) | 2.10.2-2
libcairo2                    (>= 1.2.4) | 1.8.8-2
libdbus-glib-1-2              (>= 0.78) | 0.82-2
libexempi3                   (>= 2.1.0) | 2.1.1-1
libexif12                               | 0.6.19-1
libgail18                   (>= 1.18.0) | 2.18.3-1
libgconf2-4                 (>= 2.27.0) | 2.28.0-1
libglib2.0-0                (>= 2.22.0) | 2.22.3-1
libgnome-desktop-2-11                   | 2.28.1-3
libgtk2.0-0                 (>= 2.18.0) | 2.18.3-1
libice6                    (>= 1:1.0.0) | 2:1.0.6-1
libnautilus-extension1      (>= 2.26.2) | 2.28.1-1
libpango1.0-0               (>= 1.20.0) | 1.26.1-1
libselinux1                   (>= 1.32) | 2.0.89-4
libsm6                                  | 2:1.1.1-1
libtrackerclient0            (>= 0.6.2) | 0.6.95-3
libunique-1.0-0              (>= 1.0.0) | 1.1.6-1
libx11-6                                | 2:1.3.2-1
libxml2                      (>= 2.7.4) | 2.7.6.dfsg-1
libxrender1                             | 1:0.9.5-1
nautilus-data                 (>= 2.28) | 2.28.1-1
nautilus-data                 (<< 2.29) | 2.28.1-1
shared-mime-info              (>= 0.50) | 0.70-1
desktop-file-utils             (>= 0.7) | 0.15-2
gvfs                         (>= 1.3.2) | 1.4.1-6
libglib2.0-data                         | 2.22.3-1


Recommends              (Version) | Installed
=================================-+-===========
desktop-base             (>= 0.2) | 5.0.5
eject                             | 2.1.5+deb1+cvs20081104-7
nautilus-cd-burner                | 
 OR brasero             (>= 2.26) | 2.28.2-1
librsvg2-common                   | 2.26.0-1
synaptic                          | 0.63
app-install-data                  | 2009.06.06
gvfs-backends                     | 1.4.1-6
consolekit                        | 0.4.1-2


Suggests           (Version) | Installed
============================-+-===========
eog                          | 2.28.1-1
evince                       | 2.28.1-1
 OR pdf-viewer               | 
totem                        | 2.28.4-1
 OR mp3-decoder              | 
xdg-user-dirs                | 
tracker                      | 






[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Josselin Mouette <joss@debian.org>:
Bug#561737; Package nautilus. (Sun, 20 Dec 2009 08:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to 561737@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Josselin Mouette <joss@debian.org>. (Sun, 20 Dec 2009 08:15:04 GMT) Full text and rfc822 format available.

Message #10 received at 561737@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: Wendy Elmer <webe3vt@aim.com>, 561737@bugs.debian.org
Cc: pkg-utopia-maintainers@lists.alioth.debian.org
Subject: Re: Bug#561737: [nautilus] can't mount floppy(no media in drive)
Date: Sun, 20 Dec 2009 09:13:30 +0100
[Message part 1 (text/plain, inline)]
reassign 561737 devicekit-disks
thanks

Le samedi 19 décembre 2009 à 18:58 -0500, Wendy Elmer a écrit : 
> --- Please enter the report below this line. ---
> When I go to the computer desktop icon and click on Floppy Drive with a floppy in the drive,
> A popup window says "Unable to mount location No medium in the drive".  
> I hear the floppy click when this happens.  If I try to mount manually from 
> an exterm using mount /dev/fd0 /media/floppy
> it tells me
> mount: only root can do that
> 
> I used to be able to mount the floppy.  This is happening on 2 Squeeze 
> computers.  Both were able to read the floppy a week or so ago.

This is probably caused by the switch to devicekit-disks. I don’t think
any of us had a floppy drive to test, so you’ll be our guinea pig.

Could you please send the output of “devkit-disks --dump”?

Thanks,
-- 
 .''`.      Josselin Mouette
: :' :
`. `'   “I recommend you to learn English in hope that you in
  `-     future understand things”  -- Jörg Schilling
[signature.asc (application/pgp-signature, inline)]

Bug reassigned from package 'nautilus' to 'devicekit-disks'. Request was from Josselin Mouette <joss@debian.org> to control@bugs.debian.org. (Sun, 20 Dec 2009 08:15:06 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions nautilus/2.28.1-1. Request was from Josselin Mouette <joss@debian.org> to control@bugs.debian.org. (Sun, 20 Dec 2009 08:15:06 GMT) Full text and rfc822 format available.

Forcibly Merged 561737 561746. Request was from Josselin Mouette <joss@debian.org> to control@bugs.debian.org. (Sun, 20 Dec 2009 08:18:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package devicekit-disks. (Sun, 20 Dec 2009 09:51:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sun, 20 Dec 2009 09:51:08 GMT) Full text and rfc822 format available.

Message #21 received at 561737@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: 561737@bugs.debian.org, 561737-submitter@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: [Pkg-utopia-maintainers] Bug#561737: [nautilus] can't mount floppy(no media in drive)
Date: Sun, 20 Dec 2009 10:47:35 +0100
[Message part 1 (text/plain, inline)]
tags 561737 help
thanks

Josselin Mouette wrote:
> reassign 561737 devicekit-disks
> thanks
> 
> Le samedi 19 décembre 2009 à 18:58 -0500, Wendy Elmer a écrit : 
>> --- Please enter the report below this line. ---
>> When I go to the computer desktop icon and click on Floppy Drive with a floppy in the drive,
>> A popup window says "Unable to mount location No medium in the drive".  
>> I hear the floppy click when this happens.  If I try to mount manually from 
>> an exterm using mount /dev/fd0 /media/floppy
>> it tells me
>> mount: only root can do that
>>
>> I used to be able to mount the floppy.  This is happening on 2 Squeeze 
>> computers.  Both were able to read the floppy a week or so ago.
> 
> This is probably caused by the switch to devicekit-disks. I don’t think
> any of us had a floppy drive to test, so you’ll be our guinea pig.

Yeah, I no longer own a computer with a floppy drive, so I can't reasonably
develop and test a patch for that (or even investigate this issue).
This is a call for help to anyone still caring for floppy drives to investigate
this and if necessary provide a patch.

Thanks,
Michael

-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Added tag(s) help. Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Sun, 20 Dec 2009 09:51:09 GMT) Full text and rfc822 format available.

Message sent on to Wendy Elmer <webe3vt@aim.com>:
Bug#561737. (Sun, 20 Dec 2009 09:51:12 GMT) Full text and rfc822 format available.

Severity set to 'normal' from 'important' Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Sun, 20 Dec 2009 09:54:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package devicekit-disks. (Mon, 21 Dec 2009 23:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Wendy Elmer <webe3vt@aim.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Mon, 21 Dec 2009 23:42:04 GMT) Full text and rfc822 format available.

Message #33 received at 561737@bugs.debian.org (full text, mbox):

From: Wendy Elmer <webe3vt@aim.com>
To: 561737@bugs.debian.org
Cc: pkg-utopia-maintainers@lists.alioth.debian.org
Subject: Re: Bug#561737: [nautilus] can't mount floppy(no media in drive)
Date: Mon, 21 Dec 2009 18:40:40 -0500
[Message part 1 (text/plain, inline)]

> 
> Could you please send the output of “devkit-disks --dump”?
> 
> Thanks,


Here is the dump.
[Message part 2 (text/html, inline)]
[devkit.dump (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package devicekit-disks. (Tue, 22 Dec 2009 10:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sergio Llorente <sllorente@gmail.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Tue, 22 Dec 2009 10:00:03 GMT) Full text and rfc822 format available.

Message #38 received at 561737@bugs.debian.org (full text, mbox):

From: Sergio Llorente <sllorente@gmail.com>
To: 561737@bugs.debian.org
Subject: Same problem
Date: Tue, 22 Dec 2009 10:57:46 +0100
I get the same problem that describes Wendy Elmer.

The output of the command

$ devkit-disks --show-info /dev/fd0

is identical to the floppy part of his attachment.

However I can mount the floppy with the next command:

$ devkit-disks --mount /dev/fd0
Mounted /org/freedesktop/DeviceKit/Disks/devices/fd0 at /media/floppy0

or this other one:

$ gnome-mount --device /dev/fd0

and a new floppy icon appears in Nautilus under "computer", labeled
"floppy0" and with the expected behaviour.  The previous floppy drive
icon is also there without any change (same pop-up with the message
"Unable to mount location No medium in the drive" when is clicked).

The "Palimpsest" utility cannot detect the medium in the drive either
(with the floppy mounted or not mounted).

Thanks,
Sergio Llorente.




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package devicekit-disks. (Tue, 09 Mar 2010 14:33:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Brent S. Elmer Ph.D." <webe3vt@aim.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Tue, 09 Mar 2010 14:33:06 GMT) Full text and rfc822 format available.

Message #43 received at 561737@bugs.debian.org (full text, mbox):

From: "Brent S. Elmer Ph.D." <webe3vt@aim.com>
To: 561737@bugs.debian.org
Subject: Ubuntu bug says fix released
Date: Tue, 09 Mar 2010 09:29:48 -0500
The same bug on Ubuntu is #441835 here
https://bugs.launchpad.net/ubuntu/karmic/+source/devicekit-disks/+bug/441835

On March 1 the status is Fix Released.  It says the change is in udisks.
Is there really a fix and will it get into Debian?

I think this bug affects many people that still have old computers with
floppies.  I know I have three computers running Debian that have
floppies.






Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package devicekit-disks. (Thu, 11 Mar 2010 15:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Brent S. Elmer Ph.D." <webe3vt@aim.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Thu, 11 Mar 2010 15:48:03 GMT) Full text and rfc822 format available.

Message #48 received at 561737@bugs.debian.org (full text, mbox):

From: "Brent S. Elmer Ph.D." <webe3vt@aim.com>
To: 561737@bugs.debian.org
Subject: RE:[Bug 561737]
Date: Thu, 11 Mar 2010 10:46:28 -0500
The same bug on Ubuntu is #441835 here
https://bugs.launchpad.net/ubuntu/karmic/+source/devicekit-disks/+bug/441835

On March 1 the status is Fix Released.  It says the change is in udisks.
Is there really a fix and will it get into Debian?

I think this bug affects many people that still have old computers with
floppies.  I know I have three computers running Debian that have
floppies.







Bug reassigned from package 'devicekit-disks' to 'udisks'. Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Thu, 18 Mar 2010 04:00:13 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Wed, 26 May 2010 11:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sergio Llorente <sllorente@gmail.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Wed, 26 May 2010 11:21:03 GMT) Full text and rfc822 format available.

Message #55 received at 561737@bugs.debian.org (full text, mbox):

From: Sergio Llorente <sllorente@gmail.com>
To: 561737@bugs.debian.org
Subject: Bug fixed in udisks 1.0.1-1
Date: Wed, 26 May 2010 13:16:43 +0200
After upgrading (testing), the floppy is mounted properly by nautilus
again.

Thanks,
Sergio.





Information forwarded to debian-bugs-dist@lists.debian.org, acimmarusti@gmail.com, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Fri, 16 Jul 2010 21:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andres Cimmarusti <acimmarusti@gmail.com>:
Extra info received and forwarded to list. Copy sent to acimmarusti@gmail.com, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 16 Jul 2010 21:03:04 GMT) Full text and rfc822 format available.

Message #60 received at 561737@bugs.debian.org (full text, mbox):

From: Andres Cimmarusti <acimmarusti@gmail.com>
To: Debian Bug Tracking System <561737@bugs.debian.org>
Subject: Re: Bug# 561737: it still doesn't work
Date: Fri, 16 Jul 2010 16:54:55 -0400
Package: udisks
Version: 1.0.1+git20100614-1
Severity: normal

I still have the problem. Nautilus can't really access the disk. Mounting it 
with root works and gnome-mount throws no errors and icons are present in the 
Places menu and on the lefthand side of nautilus but when I click on them 
nothing happens..

Maybe the git version broke this again...

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udisks depends on:
ii  dbus                  1.2.24-1           simple interprocess messaging syst
ii  libatasmart4          0.17+git20100219-2 ATA S.M.A.R.T. reading and parsing
ii  libc6                 2.11.2-2           Embedded GNU C Library: Shared lib
ii  libdbus-1-3           1.2.24-1           simple interprocess messaging syst
ii  libdbus-glib-1-2      0.86-1             simple interprocess messaging syst
ii  libdevmapper1.02.1    2:1.02.48-2        The Linux Kernel Device Mapper use
ii  libglib2.0-0          2.24.1-1           The GLib library of C routines
ii  libgudev-1.0-0        158-1              GObject-based wrapper library for 
ii  libparted0debian1     2.2-7              The GNU Parted disk partitioning s
ii  libpolkit-backend-1-0 0.96-2             PolicyKit backend API
ii  libpolkit-gobject-1-0 0.96-2             PolicyKit Authorization API
ii  libsgutils2-2         1.29-1             utilities for devices using the SC
ii  libudev0              158-1              libudev shared library
ii  udev                  158-1              /dev/ and hotplug management daemo

Versions of packages udisks recommends:
ii  dosfstools                  3.0.9-1      utilities for making and checking 
ii  hdparm                      9.27-2       tune hard disk parameters for high
ii  mtools                      4.0.12-1     Tools for manipulating MSDOS files
ii  ntfs-3g                     1:2010.3.6-1 read-write NTFS driver for FUSE
ii  ntfsprogs                   2.0.0-1+b1   tools for doing neat things in NTF
ii  policykit-1                 0.96-2       framework for managing administrat

Versions of packages udisks suggests:
pn  cryptsetup                    <none>     (no description available)
pn  mdadm                         <none>     (no description available)
pn  reiserfsprogs                 <none>     (no description available)
pn  xfsprogs                      <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, acimmarusti@gmail.com, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Fri, 16 Jul 2010 22:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andres Cimmarusti <acimmarusti@gmail.com>:
Extra info received and forwarded to list. Copy sent to acimmarusti@gmail.com, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 16 Jul 2010 22:15:03 GMT) Full text and rfc822 format available.

Message #65 received at 561737@bugs.debian.org (full text, mbox):

From: Andres Cimmarusti <acimmarusti@gmail.com>
To: Debian Bug Tracking System <561737@bugs.debian.org>
Subject: Re: more info
Date: Fri, 16 Jul 2010 18:05:39 -0400
Package: udisks
Version: 1.0.1+git20100614-1
Severity: normal

I take it back, mount as root doesn't work either!

# mount -t vfat /dev/fd0 /media/floppy0

It appears to mount correctly, but when I list the files in 
/media/floppy0 there is nothing!.

I tried using

cat /dev/fd0 

and this produced tons of output, some of which I quickly recognized 
as the data I stored in there!.

I booted an old computer into windows to get this information out...I felt quite 
embarassed in front of my windows-loving colleagues... 

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udisks depends on:
ii  dbus                  1.2.24-1           simple interprocess messaging syst
ii  libatasmart4          0.17+git20100219-2 ATA S.M.A.R.T. reading and parsing
ii  libc6                 2.11.2-2           Embedded GNU C Library: Shared lib
ii  libdbus-1-3           1.2.24-1           simple interprocess messaging syst
ii  libdbus-glib-1-2      0.86-1             simple interprocess messaging syst
ii  libdevmapper1.02.1    2:1.02.48-2        The Linux Kernel Device Mapper use
ii  libglib2.0-0          2.24.1-1           The GLib library of C routines
ii  libgudev-1.0-0        158-1              GObject-based wrapper library for 
ii  libparted0debian1     2.2-7              The GNU Parted disk partitioning s
ii  libpolkit-backend-1-0 0.96-2             PolicyKit backend API
ii  libpolkit-gobject-1-0 0.96-2             PolicyKit Authorization API
ii  libsgutils2-2         1.29-1             utilities for devices using the SC
ii  libudev0              158-1              libudev shared library
ii  udev                  158-1              /dev/ and hotplug management daemo

Versions of packages udisks recommends:
ii  dosfstools                  3.0.9-1      utilities for making and checking 
ii  hdparm                      9.27-2       tune hard disk parameters for high
ii  mtools                      4.0.12-1     Tools for manipulating MSDOS files
ii  ntfs-3g                     1:2010.3.6-1 read-write NTFS driver for FUSE
ii  ntfsprogs                   2.0.0-1+b1   tools for doing neat things in NTF
ii  policykit-1                 0.96-2       framework for managing administrat

Versions of packages udisks suggests:
pn  cryptsetup                    <none>     (no description available)
pn  mdadm                         <none>     (no description available)
pn  reiserfsprogs                 <none>     (no description available)
pn  xfsprogs                      <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Sat, 18 Sep 2010 12:51:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petra Ruebe-Pugliese <prp@prp.in-berlin.de>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sat, 18 Sep 2010 12:51:06 GMT) Full text and rfc822 format available.

Message #70 received at 561737@bugs.debian.org (full text, mbox):

From: Petra Ruebe-Pugliese <prp@prp.in-berlin.de>
To: Debian Bug Tracking System <561737@bugs.debian.org>
Subject: udisks: Udisks-daemon prevents mounting of floppy disks
Date: Sat, 18 Sep 2010 14:45:17 +0200
Package: udisks
Version: 1.0.1+git20100614-1+b1
Severity: normal


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udisks depends on:
ii  dbus                  1.2.24-3           simple interprocess messaging syst
ii  libatasmart4          0.17+git20100219-2 ATA S.M.A.R.T. reading and parsing
ii  libc6                 2.11.2-5           Embedded GNU C Library: Shared lib
ii  libdbus-1-3           1.2.24-3           simple interprocess messaging syst
ii  libdbus-glib-1-2      0.88-2             simple interprocess messaging syst
ii  libdevmapper1.02.1    2:1.02.48-3        The Linux Kernel Device Mapper use
ii  libglib2.0-0          2.24.1-1           The GLib library of C routines
ii  libgudev-1.0-0        160-1              GObject-based wrapper library for 
ii  libparted0debian1     2.3-2              The GNU Parted disk partitioning s
ii  libpolkit-backend-1-0 0.96-2             PolicyKit backend API
ii  libpolkit-gobject-1-0 0.96-2             PolicyKit Authorization API
ii  libsgutils2-2         1.29-1             utilities for devices using the SC
ii  libudev0              160-1              libudev shared library
ii  udev                  160-1              /dev/ and hotplug management daemo

Versions of packages udisks recommends:
ii  dosfstools                    3.0.9-1    utilities for making and checking 
pn  hdparm                        <none>     (no description available)
ii  mtools                        4.0.12-1   Tools for manipulating MSDOS files
pn  ntfs-3g                       <none>     (no description available)
pn  ntfsprogs                     <none>     (no description available)
pn  policykit-1                   <none>     (no description available)

Versions of packages udisks suggests:
pn  cryptsetup                    <none>     (no description available)
pn  mdadm                         <none>     (no description available)
pn  reiserfsprogs                 <none>     (no description available)
pn  xfsprogs                      <none>     (no description available)

-- no debconf information


Hello,

I wanted to file this as a separate bug report, as it has
nothing to do with nautilus or any other surface, but I gather
you do not want to open various threads on essentially the same
problem.

In fact I described the "symptoms" floppy users have been
suffering from lately in a detailed bug report, #59271,
directed to the developers of the "mount" package.

Now this problem has come to be discussed in a recent thread in
debian-user-german@lists.debian.org under the Subject "Mounten
von Disketten".  Explanations given in this thread by other
users made me realise that the fault is apparently not with the
mount program, but with udisks-daemon.

In fact mount works properly as long as udisks-daemon is not
running and vice versa:

,-----[ /bin/bash ]------------------------------------------------------------
| ~ > ps ax | grep udisks
|  2247 ?        Sl     0:00 /usr/lib/udisks/udisks-daemon
|  2248 ?        D      0:00 udisks-daemon: polling /dev/sdb /dev/sdc /dev/sr0
|  2278 pts/3    S+     0:00 grep udisks
| ~ > df -h
| Filesystem            Size  Used Avail Use% Mounted on
| /dev/sda1              27G   19G  6.8G  74% /
| tmpfs                 252M     0  252M   0% /lib/init/rw
| udev                  247M  252K  247M   1% /dev
| tmpfs                 252M     0  252M   0% /dev/shm
| ~ > mount /floppy     #  floppy drive "makes noises"
| ~ > echo $?
| 0
| > # But nothing has happened:
| ~ > df -h
| Filesystem            Size  Used Avail Use% Mounted on
| /dev/sda1              27G   19G  6.8G  74% /
| tmpfs                 252M     0  252M   0% /lib/init/rw
| udev                  247M  252K  247M   1% /dev
| tmpfs                 252M     0  252M   0% /dev/shm
| ~ > umount /floppy
| umount: /floppy is not mounted (according to mtab)
| ~ >
| -------- Other terminal, as root:  ---------
| netty:~# kill 2247
| netty:~# ps ax | grep udisks
|  2306 pts/0    S+     0:00 grep udisks
| netty:~#
| -------- Back to first terminal:  ----------
| ~ > mount /floppy
| ~ > df -h
| Filesystem            Size  Used Avail Use% Mounted on
| /dev/sda1              27G   19G  6.8G  74% /
| tmpfs                 252M     0  252M   0% /lib/init/rw
| udev                  247M  252K  247M   1% /dev
| tmpfs                 252M     0  252M   0% /dev/shm
| /dev/sdc              1.4M  865K  559K  61% /floppy
| ~ >
`------------------------------------------------------------------------------

One participant in the discussion mentioned above proposed that
the problem might be due to the way floppy drives "answer" when
"asked" by udisks whether a medium is inserted or not.  As far
as I understand he said floppy drives cannot detect if a floppy
is inserted or not; however another participant did not share
this view.

Anyway, we now know that there is some sort of misunderstanding
between mount and udisks and the way floppy drives are being
constructed.

BTW: I am talking about any sort of floppy drives: /dev/df0 as
well as USB floppy drives; there is no difference in the
behaviour as to this particular problem.  So the excuse that
developers do not own floppy drives these days is IMHO not
really a valid excuse.

I'd be very pleased if I could be of any help in clearing up
this problem, so I'd willingly act as a "guinea pig"
if there is any particular testing job to be done.

Could you please kindly contact the "mount" crew and see to
Bug #59271 being merged with this one?

  Thanks in advance,
     Petra








Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Fri, 28 Oct 2011 14:45:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Henri <henrimenke4@aim.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 28 Oct 2011 14:45:07 GMT) Full text and rfc822 format available.

Message #75 received at 561737@bugs.debian.org (full text, mbox):

From: Henri <henrimenke4@aim.com>
To: 561737@bugs.debian.org
Subject: udisks: Udisks-daemon prevents mounting of floppy disks
Date: Fri, 28 Oct 2011 16:42:17 +0200
### Possible solution ###

Hi there,

I experienced the same bug in Debian squeeze (stable) a while ago with
my floppy drive. The solution was quite simple:
Edit "/lib/udev/rules.d/80-udisks.rules" and search for the lines
---------------------------------------------------------
# PC floppy drives
#
KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}="1"

# USB floppy drives
#
SUBSYSTEMS=="usb", ATTRS{bInterfaceClass}=="08",
ATTRS{bInterfaceSubClass}=="04", ENV{ID_DRIVE_FLOPPY}="1"
---------------------------------------------------------
Replace those "1" (ones) with "0" (zeros). That's all the magic.
Now restart the udev daemon by typing "invoke-rc.d udev restart"

You're done. It should work now.

Best Regards,

Henri
-- 
Please avoid sending me Microsoft Office attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Fri, 28 Oct 2011 19:21:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 28 Oct 2011 19:21:10 GMT) Full text and rfc822 format available.

Message #80 received at 561737@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Henri <henrimenke4@aim.com>, 561737@bugs.debian.org
Subject: Re: [Pkg-utopia-maintainers] Bug#561737: udisks: Udisks-daemon prevents mounting of floppy disks
Date: Fri, 28 Oct 2011 21:20:08 +0200
[Message part 1 (text/plain, inline)]
Am 28.10.2011 16:42, schrieb Henri:
> ### Possible solution ###
> 
> Hi there,
> 
> I experienced the same bug in Debian squeeze (stable) a while ago with
> my floppy drive. The solution was quite simple:

That's not a solution, but a workaround.

Regards,
Michael


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Sun, 01 Apr 2012 21:30:15 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arnold <ca.kunze@web.de>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sun, 01 Apr 2012 21:30:15 GMT) Full text and rfc822 format available.

Message #85 received at 561737@bugs.debian.org (full text, mbox):

From: Arnold <ca.kunze@web.de>
To: 561737@bugs.debian.org
Subject: Mounting of floppy drives not successfull again
Date: Sun, 1 Apr 2012 23:25:37 +0200
Hi there,

after the last updates in Debian Sqeeze the workaround given by Henri works no 
longer. It is again impossible to mount a floppy. The floppy drive sounds like 
formatting the disk. After minutes of drive action kdiskfree  announces that 
the floppy should be mounted. But the access to the floppy is not possible. The 
same floppy used with Debian 5.0.x and with windows works without any problem.
A solution is urgently needed.

Regards
Arnold




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Fri, 20 Apr 2012 09:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Brogle <brogle@wel.de>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 20 Apr 2012 09:54:04 GMT) Full text and rfc822 format available.

Message #90 received at 561737@bugs.debian.org (full text, mbox):

From: Andreas Brogle <brogle@wel.de>
To: 561737@bugs.debian.org
Subject: udisks inhibits me to mount an USB floppy drive
Date: Fri, 20 Apr 2012 11:37:32 +0200
[Message part 1 (text/plain, inline)]
Packet: udisks Version 1.0.4-5

Hi,

Yet as root I can't manually mount a floppy in an USB drive, as long as udisks 
is installed.

A 'mount /dev/sda /mount/local/usbfloppy' fails.
There is some noise at the drive, but nothing happens.

As a workaround I can do 'udisks --mount /dev/sda'

Entries in 'etc/fstab' are ignored.

Is this a proper solution ?

Regards,
Andreas
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Mon, 23 Apr 2012 15:54:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Mon, 23 Apr 2012 15:54:02 GMT) Full text and rfc822 format available.

Message #95 received at 561737@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: 561737@bugs.debian.org
Cc: Wendy Elmer <webe3vt@aim.com>, Sergio Llorente <sllorente@gmail.com>, "Brent S. Elmer Ph.D." <webe3vt@aim.com>, Andres Cimmarusti <acimmarusti@gmail.com>, Petra Ruebe-Pugliese <prp@prp.in-berlin.de>, Henri <henrimenke4@aim.com>, Arnold <ca.kunze@web.de>, AndreasBrogle <brogle@wel.de>, BH <shoalcreek5@gmail.com>, Seshadri <seshadri_c@yahoo.com>, Nathanael Nerode <neroden@fastmail.fm>, François Revol <revol@free.fr>, rpnpif <rpnpif@free.fr>, Dirk Salva <dsalva@nutrimatic.ping.de>
Subject: udisks, gvfs, nautilus: mounting floppies not working and prevents `mount` from working too
Date: Mon, 23 Apr 2012 17:52:08 +0200
[Message part 1 (text/plain, inline)]
retitle 561737 udisks, gvfs, nautilus: mounting floppies not working (no media in drive)
forcemerge 561737 561746 592719 596890 622618
forwarded 561737 https://bugs.freedesktop.org/show_bug.cgi?id=30283
block 669973 by 561737
quit

Dear suffering floppy users,


in the future when replying to reports please import the message thread
into your mail program beforehand so the threading keeps intact.

   $ bts show --mbox 561737 # from devscripts package

Please also add all people involved in the thread to the CC list.
Otherwise they will not know that someone replied.


I was also bitten by this bug and it took quite a while to figure out
that udisks is the culprit.

Now I will try to summarize everything and hope altogether we will be
able to solve this issue.

### Problem ###

Mounting file system on floppy disks with Nautilus is not possible since
Debian Squeeze.

The problem lies within udisks. Commit ca93d4e2 [1]

        commit ca93d4e2d9e7f483b2fde1725da086e2cca44164
        Author: Martin Pitt <martin.pitt@ubuntu.com>
        Date:   Wed Jun 2 15:56:07 2010 +0200
        
            Fix long hangs on probing nonexistant floppy drives
            
            A lot of modern machines do not have a floppy drive any more, but still have a
            floppy controller somewhere (or at least the BIOS pretends to). Trying to
            open(/dev/fd0) on these machines causes long hangs, which lead to long desktop
            startup times.
            
            To fix this, avoid probing floppies for media in update_info().
            
            https://launchpad.net/bugs/539515
        
        diff --git a/src/device.c b/src/device.c
        index 763385c..0e87f1d 100644
        --- a/src/device.c
        +++ b/src/device.c
        @@ -4471,7 +4471,8 @@ update_info (Device *device)
             {
               media_available = FALSE;
         
        -      if (!g_udev_device_get_property_as_boolean (device->priv->d, "ID_CDROM"))
        +      if (!g_udev_device_get_property_as_boolean (device->priv->d, "ID_CDROM") &&
        +          !g_udev_device_get_property_as_boolean (device->priv->d, "ID_DRIVE_FLOPPY"))
                 {
                   int fd;
                   fd = open (device->priv->device_file, O_RDONLY);

always reports false that a floppy is inserted. This problem is reported
in upstream’s freedesktop.org BTS as #30283 [1]. Unfortunately the
developer David Zeuthen will not focus on getting a fix in for this
issue since he focuses on udisks2 where everything seems to work.

### Workarounds ###

1. Edit `/lib/udev/rules.d/80-udisks.rules` as mentioned in [5] to not
label the floppy drive as a floppy drive.

2. Apply the patch attached to the upstream report [6] and build the
package yourself.

3. Mounting the disk running the following from a terminal.

    `udisks --mount /dev/fd0`.

### Roadmap ###

1. Get all bug reports merged together (hopefully accomplished now) and
get the necessary dependencies sorted out. I am in favor of filing a bug
against Nautilus and gvfs and let them be blocked by 561737 (this bug
here). I am doing this for gvfs with this message.

Users experiencing this will look at the reports assigned to Nautilus
and at best against gvfs. Finding this bug will give them the necessary
information about the problem and workarounds faster.

2. Revert the commit ca93d4e2 [1] in udisks introducing this regression
[1]. It would be great if some test packages in some private repository
could be provided.

That would reopen Launchpad report #539515 [3] but closes report #441835
[4]. Also an ticket should be submitted upstream.

3. Update some Squeeze errata and README files to document that issue.
Someone cares to send a patch also upstream [7]?

4. Fix this issue properly. People hit by longer boot times as in
Launchpad #539515 should get their BIOS fixed or should have a
configuration option to disable floppy probing completely.

5. Increase the severity of this report to at least important (even
grave) as udev-daemon also prevents `mount` from working and therefore
breaks unrelated packages. Michael, could you please explain why you
disagree.

Does that sound feasible? Possibly number 4 should be discussed and done
in upstream’s report.


Thanks a lot and let us be constructive to solve this quickly,

Paul


[1] http://cgit.freedesktop.org/udisks/commit/?id=ca93d4e2d9e7f483b2fde1725da086e2cca44164
[2] https://bugs.freedesktop.org/show_bug.cgi?id=30283
[3] https://launchpad.net/bugs/539515
[4] https://bugs.launchpad.net/ubuntu/karmic/+source/devicekit-disks/+bug/441835
[5] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561737#75
[6] https://bugs.freedesktop.org/attachment.cgi?id=39751
[7] http://www.freedesktop.org/wiki/Software/udisks
[signature.asc (application/pgp-signature, inline)]

Changed Bug title to 'udisks, gvfs, nautilus: mounting floppies not working (no media in drive)' from '[nautilus] can't mount floppy(no media in drive)' Request was from Paul Menzel <pm.debian@googlemail.com> to control@bugs.debian.org. (Mon, 23 Apr 2012 15:54:08 GMT) Full text and rfc822 format available.

Marked as found in versions udisks/1.0.1+git20100614-3. Request was from Paul Menzel <pm.debian@googlemail.com> to control@bugs.debian.org. (Mon, 23 Apr 2012 15:54:11 GMT) Full text and rfc822 format available.

Merged 561737 561746 592719 596890 622618 Request was from Paul Menzel <pm.debian@googlemail.com> to control@bugs.debian.org. (Mon, 23 Apr 2012 15:54:14 GMT) Full text and rfc822 format available.

Set Bug forwarded-to-address to 'https://bugs.freedesktop.org/show_bug.cgi?id=30283'. Request was from Paul Menzel <pm.debian@googlemail.com> to control@bugs.debian.org. (Mon, 23 Apr 2012 15:54:15 GMT) Full text and rfc822 format available.

Added indication that bug 561737 blocks 669973 Request was from Paul Menzel <pm.debian@googlemail.com> to control@bugs.debian.org. (Mon, 23 Apr 2012 15:54:25 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Mon, 23 Apr 2012 16:57:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to rpnpif <rpnpif@free.fr>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Mon, 23 Apr 2012 16:57:06 GMT) Full text and rfc822 format available.

Message #110 received at 561737@bugs.debian.org (full text, mbox):

From: rpnpif <rpnpif@free.fr>
To: Debian Bug Tracking System <561737@bugs.debian.org>
Subject: Re: can't mount floppy(no media in drive)
Date: Mon, 23 Apr 2012 18:56:07 +0200
Package: udisks
Version: 1.0.1+git20100614-3
Severity: normal

For your investigations, here my experience.

I put a floppy disk in my drive.
I click on the floppy icon.
A backport kernel error is issued (see after). This error is reproductible.
$ udisks --mount /dev/fd0
Mounted /org/freedesktop/UDisks/devices/fd0 at /media/disk

Then, great !, an icon appears in Nautilus an all works fine.

So for me, udisks works fine, but Nautilus and the 3.2 kernel do not.

Regards.

Kernel failure message 1:
------------[ cut here ]------------
WARNING: at /build/buildd-linux-2.6_3.2.12-1~bpo60+1-i386-EZ37JT/linux-2.6-3.2.12/debian/build/source_i386_none/drivers/block/floppy.c:1041 setup_rw_floppy+0x1e8/0x2a1 [floppy]()
Hardware name: MS-6380                         
floppy_disable_hlt() scheduled for removal in 2012
Modules linked in: usb_storage uas vboxnetadp(O) vboxnetflt(O) vboxdrv(O) pktcdvd mperf cpufreq_stats cpufreq_powersave cpufreq_conservative cpufreq_userspace ppdev lp snd_hrtimer binfmt_misc ipt_REJECT xt_comment ipt_LOG xt_limit xt_tcpudp xt_addrtype xt_state ip6table_filter ip6_tables nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ftp nf_conntrack iptable_filter ip_tables x_tables nls_utf8 nls_cp437 vfat fat ext4 jbd2 crc16 hwmon_vid loop firewire_sbp2 usbhid hid snd_via82xx snd_ac97_codec ac97_bus ohci_hcd saa7134_alsa snd_pcm_oss snd_mixer_oss snd_pcm mt20xx snd_page_alloc snd_mpu401_uart ir_lirc_codec lirc_dev ir_mce_kbd_decoder tea5767 ir_sony_decoder snd_seq_midi ir_jvc_decoder snd_rawmidi tda9887 snd_seq_midi_event tda8290 ir_rc6_decoder ir_rc5_decoder snd_seq tuner uhci_hcd ehci_hcd usbcore ir_nec_decoder radeon saa7134 ttm rc_core videobuf_dma_sg videobuf_core v4l2_common drm_kms_helper videodev drm media tveeprom tpm_tis i2c_vi
 apro i2c_algo_bit tpm 8139too 8139cp parport_pc tpm_bios power_supply parport sg snd_timer snd_seq_device firewire_ohci usb_common i2c_core via_rhine firewire_core sr_mod floppy cdrom via_ircc mii evdev processor shpchp button crc_itu_t irda crc_ccitt snd soundcore ns558 gameport pcspkr thermal_sys ext3 jbd mbcache sd_mod crc_t10dif ata_generic pata_via libata scsi_mod
Pid: 0, comm: swapper/0 Tainted: G           O 3.2.0-0.bpo.2-686-pae #1
Call Trace:
 [<c103b945>] ? warn_slowpath_common+0x6a/0x7b
 [<f84e53ae>] ? setup_rw_floppy+0x1e8/0x2a1 [floppy]
 [<c103b9bc>] ? warn_slowpath_fmt+0x28/0x2c
 [<f84e53ae>] ? setup_rw_floppy+0x1e8/0x2a1 [floppy]
 [<c104080d>] ? irq_enter+0x49/0x49
 [<c10465d5>] ? run_timer_softirq+0x167/0x20b
 [<f84e51c6>] ? fd_watchdog+0x84/0x84 [floppy]
 [<c104080d>] ? irq_enter+0x49/0x49
 [<c10408a8>] ? __do_softirq+0x9b/0x14e
 [<c104080d>] ? irq_enter+0x49/0x49 <IRQ>  
 [<c10406f0>] ? irq_exit+0x2f/0x91
 [<c10203eb>] ? smp_apic_timer_interrupt+0x69/0x73
 [<c12d62e9>] ? apic_timer_interrupt+0x31/0x38
 [<c1026554>] ? native_safe_halt+0x2/0x3
 [<c1011ee2>] ? default_idle+0x50/0x87
 [<c100bf09>] ? cpu_idle+0xa3/0xbe
 [<c142c7d5>] ? start_kernel+0x33d/0x342
---[ end trace 444904880192fad5 ]---


-- System Information:
Debian Release: 6.0.4
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-0.bpo.2-686-pae (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udisks depends on:
ii  dbus                  1.2.24-4+squeeze1  simple interprocess messaging syst
ii  libatasmart4          0.17+git20100219-2 ATA S.M.A.R.T. reading and parsing
ii  libc6                 2.13-27            Embedded GNU C Library: Shared lib
ii  libdbus-1-3           1.2.24-4+squeeze1  simple interprocess messaging syst
ii  libdbus-glib-1-2      0.88-2.1           simple interprocess messaging syst
ii  libdevmapper1.02.1    2:1.02.48-5        The Linux Kernel Device Mapper use
ii  libglib2.0-0          2.28.2-1           The GLib library of C routines
ii  libgudev-1.0-0        164-3              GObject-based wrapper library for 
ii  libparted0debian1     2.3-5              The GNU Parted disk partitioning s
ii  libpolkit-backend-1-0 0.96-4+squeeze1    PolicyKit backend API
ii  libpolkit-gobject-1-0 0.96-4+squeeze1    PolicyKit Authorization API
ii  libsgutils2-2         1.29-1             utilities for devices using the SC
ii  libudev0              164-3              libudev shared library
ii  udev                  164-3              /dev/ and hotplug management daemo

Versions of packages udisks recommends:
ii  dosfstools               3.0.9-1         utilities for making and checking 
ii  hdparm                   9.32-1          tune hard disk parameters for high
ii  mtools                   4.0.12-1        Tools for manipulating MSDOS files
pn  ntfs-3g                  <none>          (no description available)
ii  ntfsprogs                2.0.0-1+b1      tools for doing neat things in NTF
ii  policykit-1              0.96-4+squeeze1 framework for managing administrat

Versions of packages udisks suggests:
pn  cryptsetup                    <none>     (no description available)
pn  mdadm                         <none>     (no description available)
pn  reiserfsprogs                 <none>     (no description available)
pn  xfsprogs                      <none>     (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#561737; Package udisks. (Wed, 25 Apr 2012 14:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Wed, 25 Apr 2012 14:09:03 GMT) Full text and rfc822 format available.

Message #115 received at 561737@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: 561737@bugs.debian.org
Cc: Andres Cimmarusti <acimmarusti@gmail.com>, Petra Ruebe-Pugliese <prp@prp.in-berlin.de>, Henri <henrimenke4@aim.com>, Arnold <ca.kunze@web.de>, AndreasBrogle <brogle@wel.de>, BH <shoalcreek5@gmail.com>, Seshadri <seshadri_c@yahoo.com>, Nathanael Nerode <neroden@fastmail.fm>, François Revol <revol@free.fr>, rpnpif <rpnpif@free.fr>, Dirk Salva <dsalva@nutrimatic.ping.de>, Sergio Llorente <sllorente@gmail.com>, Wendy Elmer <webe3vt@aim.com>
Subject: Re: can't mount floppy(no media in drive)
Date: Wed, 25 Apr 2012 16:07:44 +0200
[Message part 1 (text/plain, inline)]
Dear rpnpif,


thank you for your response.

Please always reply to all to the message you receive to keep everyone
informed and the threading working. Using `reportbug` not all people
will get notified. So I just found out by chance that you had replied.

It is also strange that reportbug did not pick up the changed bug title.

Am Montag, den 23.04.2012, 18:56 +0200 schrieb rpnpif:

[…]

> For your investigations, here my experience.
> 
> I put a floppy disk in my drive.
> I click on the floppy icon.
> A backport kernel error is issued (see after). This error is reproducible.

> Kernel failure message 1:
> ------------[ cut here ]------------
> WARNING: at /build/buildd-linux-2.6_3.2.12-1~bpo60+1-i386-EZ37JT/linux-2.6-3.2.12/debian/build/source_i386_none/drivers/block/floppy.c:1041 setup_rw_floppy+0x1e8/0x2a1 [floppy]()
> Hardware name: MS-6380                         
> floppy_disable_hlt() scheduled for removal in 2012
> Modules linked in: usb_storage uas vboxnetadp(O) vboxnetflt(O) vboxdrv(O) pktcdvd mperf cpufreq_stats cpufreq_powersave cpufreq_conservative cpufreq_userspace ppdev lp snd_hrtimer binfmt_misc ipt_REJECT xt_comment ipt_LOG xt_limit xt_tcpudp xt_addrtype xt_state ip6table_filter ip6_tables nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ftp nf_conntrack iptable_filter ip_tables x_tables nls_utf8 nls_cp437 vfat fat ext4 jbd2 crc16 hwmon_vid loop firewire_sbp2 usbhid hid snd_via82xx snd_ac97_codec ac97_bus ohci_hcd saa7134_alsa snd_pcm_oss snd_mixer_oss snd_pcm mt20xx snd_page_alloc snd_mpu401_uart ir_lirc_codec lirc_dev ir_mce_kbd_decoder tea5767 ir_sony_decoder snd_seq_midi ir_jvc_decoder snd_rawmidi tda9887 snd_seq_midi_event tda8290 ir_rc6_decoder ir_rc5_decoder snd_seq tuner uhci_hcd ehci_hcd usbcore ir_nec_decoder radeon saa7134 ttm rc_core videobuf_dma_sg videobuf_core v4l2_common drm_kms_helper videodev drm media tveeprom tpm_tis i2c_vi
>  apro i2c_algo_bit tpm 8139too 8139cp parport_pc tpm_bios power_supply parport sg snd_timer snd_seq_device firewire_ohci usb_common i2c_core via_rhine firewire_core sr_mod floppy cdrom via_ircc mii evdev processor shpchp button crc_itu_t irda crc_ccitt snd soundcore ns558 gameport pcspkr thermal_sys ext3 jbd mbcache sd_mod crc_t10dif ata_generic pata_via libata scsi_mod
> Pid: 0, comm: swapper/0 Tainted: G           O 3.2.0-0.bpo.2-686-pae #1
> Call Trace:

This is definitely not related to this problem and you should file a
separate report for this.

Additionally that looks like just a warning you can safely ignore. But
follow up with the Linux kernel folks regarding this problem [2].

> $ udisks --mount /dev/fd0
> Mounted /org/freedesktop/UDisks/devices/fd0 at /media/disk

This works for me too.

> Then, great !, an icon appears in Nautilus an all works fine.
> 
> So for me, udisks works fine, but Nautilus and the 3.2 kernel do not.

Take a look at the workaround list. Editing the udev rules will give you
a way where you do not need to use the command line at all.

Also you should all subscribe to the upstream report [1] too! ;-)


Thanks,

Paul


[1] https://bugs.freedesktop.org/show_bug.cgi?id=30283
[2] http://www.mentby.com/Group/linux-kernel/patch-floppy-revert-floppy-disable-halt-warning.html
[signature.asc (application/pgp-signature, inline)]

Added tag(s) fixed-upstream. Request was from bts-link-upstream@lists.alioth.debian.org to control@bugs.debian.org. (Mon, 01 Oct 2012 17:06:30 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 08:47:29 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.