Debian Bug report logs - #558488
net-snmp-config is not architecture-independent

version graph

Package: src:net-snmp; Maintainer for src:net-snmp is Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>;

Reported by: lamont@debian.org

Date: Sun, 29 Nov 2009 11:51:01 UTC

Severity: serious

Fixed in version net-snmp/5.4.2.1~dfsg-4

Done: Jochen Friedrich <jochen@scram.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Sebastian Harl <tokkee@debian.org>:
Bug#558488; Package collectd. (Sun, 29 Nov 2009 11:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to lamont@debian.org:
New Bug report received and forwarded. Copy sent to Sebastian Harl <tokkee@debian.org>. (Sun, 29 Nov 2009 11:51:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: lamont@debian.org
To: submit@bugs.debian.org
Subject: collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported
Date: Sun, 29 Nov 2009 04:48:39 -0700
Package: collectd
Version: 4.8.1-2
Severity: serious

There was an error while trying to autobuild your package:

> Automatic build of collectd_4.8.1-2 on caballero by sbuild/ia64 98
> Build started at 20091126-1607

[...]

> ** Using build dependencies supplied by package:
> Build-Depends: debhelper (>= 5), dpkg-dev (>= 1.14.10), po-debconf, dpatch, bison, flex, autotools-dev, pkg-config, linux-libc-dev (>= 2.6.25-4) | linux-libc-dev (<< 2.6.25-1), libcurl4-gnutls-dev (>= 7.18.2-5) | libcurl4-gnutls-dev (<= 7.18.2-1) | libcurl3-gnutls-dev, libmysqlclient-dev, librrd-dev | librrd2-dev, libsensors-dev, liboping-dev (>= 0.3.3), libpcap0.8-dev | libpcap-dev, iptables-dev (>= 1.4.3.2-2), libupsclient1-dev, libperl-dev, iproute-dev [!alpha !amd64 !hppa !ia64 !ppc64 !mips !mipsel], libsnmp-dev | libsnmp9-dev, libvirt-dev (>= 0.4.0-6), libxml2-dev, libhal-dev, libopenipmi-dev, libglib2.0-dev, libnotify-dev, libesmtp-dev, libpq-dev, libdbi0-dev, libmemcached-dev, openjdk-6-jdk [!hppa], libganglia1-dev (>= 3), libgcrypt11-dev, libyajl-dev

[...]

> /bin/sh ../libtool  --tag=CC   --mode=compile ia64-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -DPREFIX='"/usr"' -DCONFIGFILE='"/etc/collectd.conf"' -DLOCALSTATEDIR='"/var"' -DPKGLOCALSTATEDIR='"/var/lib/collectd"' -DPIDFILE='"/var/run/collectd.pid"' -DPLUGINDIR='"/usr/lib/collectd"' -DPKGDATADIR='"/usr/share/collectd"' -I/build/buildd/collectd-4.8.1/debian/include -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL' -UCONFIGFILE -DCONFIGFILE='"/etc/collectd/collectd.conf"' -Wall -Werror -DNETSNMP_ENABLE_IPV6 -g -O2 -DNETSNMP_USE_INLINE -Ulinux -Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl/5.10/CORE -I. -I/usr/include -Wall -g -O2 -MT snmp_la-snmp.lo -MD -MP -MF .deps/snmp_la-snmp.Tpo -c -o snmp_la-snmp.lo `test -f 'snmp.c' || echo './'`snmp.c
> rm: invalid argument: `'
>  ia64-linux-gnu-gcc -DHAVE_CONFIG_H -I. -DPREFIX=\"/usr\" -DCONFIGFILE=\"/etc/collectd.conf\" -DLOCALSTATEDIR=\"/var\" -DPKGLOCALSTATEDIR=\"/var/lib/collectd\" -DPIDFILE=\"/var/run/collectd.pid\" -DPLUGINDIR=\"/usr/lib/collectd\" -DPKGDATADIR=\"/usr/share/collectd\" -I/build/buildd/collectd-4.8.1/debian/include "-DLT_LAZY_OR_NOW=RTLD_LAZY|RTLD_GLOBAL" -UCONFIGFILE -DCONFIGFILE=\"/etc/collectd/collectd.conf\" -Wall -Werror -DNETSNMP_ENABLE_IPV6 -g -O2 -DNETSNMP_USE_INLINE -Ulinux -Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl/5.10/CORE -I. -I/usr/include -Wall -g -O2 -MT snmp_la-snmp.lo -MD -MP -MF .deps/snmp_la-snmp.Tpo -c snmp.c  -fPIC -DPIC -o .libs/snmp_la-snmp.o
> cc1: warnings being treated as errors
> snmp.c:1: error: -fstack-protector not supported for this target
> make[4]: *** [snmp_la-snmp.lo] Error 1
> make[4]: Leaving directory `/build/buildd/collectd-4.8.1/src'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory `/build/buildd/collectd-4.8.1/src'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/build/buildd/collectd-4.8.1/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/build/buildd/collectd-4.8.1'
> make: *** [build-stamp] Error 2
> dpkg-buildpackage: error: debian/rules build gave error exit status 2

A full build log can be found at:
http://buildd.debian.org/build.php?arch=ia64&pkg=collectd&ver=4.8.1-2





Bug reassigned from package 'collectd' to 'src:net-snmp'. Request was from Sebastian Harl <tokkee@debian.org> to control@bugs.debian.org. (Sun, 29 Nov 2009 14:36:06 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions collectd/4.8.1-2. Request was from Sebastian Harl <tokkee@debian.org> to control@bugs.debian.org. (Sun, 29 Nov 2009 14:36:06 GMT) Full text and rfc822 format available.

Changed Bug title to 'net-snmp-config is not architecture-independent' from 'collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported' Request was from Sebastian Harl <tokkee@debian.org> to control@bugs.debian.org. (Sun, 29 Nov 2009 14:36:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>:
Bug#558488; Package src:net-snmp. (Sun, 29 Nov 2009 14:42:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastian Harl <tokkee@debian.org>:
Extra info received and forwarded to list. Copy sent to Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>. (Sun, 29 Nov 2009 14:42:06 GMT) Full text and rfc822 format available.

Message #16 received at 558488@bugs.debian.org (full text, mbox):

From: Sebastian Harl <tokkee@debian.org>
To: lamont@debian.org, 558488@bugs.debian.org
Cc: pkg-net-snmp-devel@lists.alioth.debian.org
Subject: Re: Bug#558488: collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported
Date: Sun, 29 Nov 2009 15:32:00 +0100
[Message part 1 (text/plain, inline)]
reassign 558488 src:net-snmp
retitle 558488 net-snmp-config is not architecture-independent
thanks

Hi,

Thanks for reporting this! This bug also affects alpha, hppa, mips and
mipsel.

On Sun, Nov 29, 2009 at 04:48:39AM -0700, lamont@debian.org wrote:
> Package: collectd
> Version: 4.8.1-2
> Severity: serious
> 
> There was an error while trying to autobuild your package:
> 
> > Automatic build of collectd_4.8.1-2 on caballero by sbuild/ia64 98
> > Build started at 20091126-1607
> 
> [...]
> 
> > ** Using build dependencies supplied by package:
> > Build-Depends: debhelper (>= 5), dpkg-dev (>= 1.14.10), po-debconf, dpatch, bison, flex, autotools-dev, pkg-config, linux-libc-dev (>= 2.6.25-4) | linux-libc-dev (<< 2.6.25-1), libcurl4-gnutls-dev (>= 7.18.2-5) | libcurl4-gnutls-dev (<= 7.18.2-1) | libcurl3-gnutls-dev, libmysqlclient-dev, librrd-dev | librrd2-dev, libsensors-dev, liboping-dev (>= 0.3.3), libpcap0.8-dev | libpcap-dev, iptables-dev (>= 1.4.3.2-2), libupsclient1-dev, libperl-dev, iproute-dev [!alpha !amd64 !hppa !ia64 !ppc64 !mips !mipsel], libsnmp-dev | libsnmp9-dev, libvirt-dev (>= 0.4.0-6), libxml2-dev, libhal-dev, libopenipmi-dev, libglib2.0-dev, libnotify-dev, libesmtp-dev, libpq-dev, libdbi0-dev, libmemcached-dev, openjdk-6-jdk [!hppa], libganglia1-dev (>= 3), libgcrypt11-dev, libyajl-dev
> 
> [...]
> 
> > /bin/sh ../libtool  --tag=CC   --mode=compile ia64-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -DPREFIX='"/usr"' -DCONFIGFILE='"/etc/collectd.conf"' -DLOCALSTATEDIR='"/var"' -DPKGLOCALSTATEDIR='"/var/lib/collectd"' -DPIDFILE='"/var/run/collectd.pid"' -DPLUGINDIR='"/usr/lib/collectd"' -DPKGDATADIR='"/usr/share/collectd"' -I/build/buildd/collectd-4.8.1/debian/include -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL' -UCONFIGFILE -DCONFIGFILE='"/etc/collectd/collectd.conf"' -Wall -Werror -DNETSNMP_ENABLE_IPV6 -g -O2 -DNETSNMP_USE_INLINE -Ulinux -Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl/5.10/CORE -I. -I/usr/include -Wall -g -O2 -MT snmp_la-snmp.lo -MD -MP -MF .deps/snmp_la-snmp.Tpo -c -o snmp_la-snmp.lo `test -f 'snmp.c' || echo './'`snmp.c
> > rm: invalid argument: `'
> >  ia64-linux-gnu-gcc -DHAVE_CONFIG_H -I. -DPREFIX=\"/usr\" -DCONFIGFILE=\"/etc/collectd.conf\" -DLOCALSTATEDIR=\"/var\" -DPKGLOCALSTATEDIR=\"/var/lib/collectd\" -DPIDFILE=\"/var/run/collectd.pid\" -DPLUGINDIR=\"/usr/lib/collectd\" -DPKGDATADIR=\"/usr/share/collectd\" -I/build/buildd/collectd-4.8.1/debian/include "-DLT_LAZY_OR_NOW=RTLD_LAZY|RTLD_GLOBAL" -UCONFIGFILE -DCONFIGFILE=\"/etc/collectd/collectd.conf\" -Wall -Werror -DNETSNMP_ENABLE_IPV6 -g -O2 -DNETSNMP_USE_INLINE -Ulinux -Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl/5.10/CORE -I. -I/usr/include -Wall -g -O2 -MT snmp_la-snmp.lo -MD -MP -MF .deps/snmp_la-snmp.Tpo -c snmp.c  -fPIC -DPIC -o .libs/snmp_la-snmp.o
> > cc1: warnings being treated as errors
> > snmp.c:1: error: -fstack-protector not supported for this target
[…]
> A full build log can be found at:
> http://buildd.debian.org/build.php?arch=ia64&pkg=collectd&ver=4.8.1-2

collectd uses net-snmp-config(1)'s --cflags option to determine the
flags used to build the snmp plugin. net-snmp-config(1) is a shell
script included in the Arch: all package libsnmp-base. That script is
created at net-snmp build time and includes the CFLAGS that are used to
build net-snmp itself (and which are then returned by 'net-snmp-config
--cflags'). Now, net-snmp's CFLAGS include the output of 'perl
-MExtUtils::Embed -e ccopts' (which is required for the embedded perl
stuff), which, in turn, includes '-fstack-protector' on *some*
architectures (presumably, on those that support that flag).

So, in order to fix that, net-snmp-config should be included in some
Arch: any package, so it's going to be built on all architectures and,
hence, returns the appropriate CFLAGS for each architecture. Thus,
reassigning this bug to net-snmp. I suppose, that libsnmp-dev would be
the appropriate package for that. There are no packages in unstable that
build-depend (according to build-rdeps) on libsnmp-base (or libsnmp15),
so moving net-snmp-config to libsnmp-dev should not affect any Debian
packages. Still, imho, a NEWS.Debian entry should be added to notify any
other users.

Cheers,
Sebastian

-- 
Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>:
Bug#558488; Package src:net-snmp. (Sun, 29 Nov 2009 15:03:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>. (Sun, 29 Nov 2009 15:03:08 GMT) Full text and rfc822 format available.

Message #21 received at 558488@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Sebastian Harl <tokkee@debian.org>, 558488@bugs.debian.org
Cc: lamont@debian.org, pkg-net-snmp-devel@lists.alioth.debian.org
Subject: Re: Bug#558488: collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported
Date: Sun, 29 Nov 2009 15:59:37 +0100
On Sun, Nov 29, 2009 at 15:32:00 +0100, Sebastian Harl wrote:

> collectd uses net-snmp-config(1)'s --cflags option to determine the
> flags used to build the snmp plugin. net-snmp-config(1) is a shell
> script included in the Arch: all package libsnmp-base. That script is
> created at net-snmp build time and includes the CFLAGS that are used to
> build net-snmp itself (and which are then returned by 'net-snmp-config
> --cflags'). Now, net-snmp's CFLAGS include the output of 'perl
> -MExtUtils::Embed -e ccopts' (which is required for the embedded perl
> stuff), which, in turn, includes '-fstack-protector' on *some*
> architectures (presumably, on those that support that flag).
> 
I'm pretty sure exporting random cflags used to build net-snmp to other
packages is wrong.  So moving the script to an arch:any package would
work, but so would fixing it to only include the needed flags, not
whatever net-snmp was built with.

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>:
Bug#558488; Package src:net-snmp. (Sun, 29 Nov 2009 20:48:21 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastian Harl <tokkee@debian.org>:
Extra info received and forwarded to list. Copy sent to Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>. (Sun, 29 Nov 2009 20:48:21 GMT) Full text and rfc822 format available.

Message #26 received at 558488@bugs.debian.org (full text, mbox):

From: Sebastian Harl <tokkee@debian.org>
To: Julien Cristau <jcristau@debian.org>
Cc: 558488@bugs.debian.org, lamont@debian.org, pkg-net-snmp-devel@lists.alioth.debian.org
Subject: Re: Bug#558488: collectd_4.8.1-2(ia64/unstable): FTBFS: -fstack-protector not supported
Date: Sun, 29 Nov 2009 21:43:18 +0100
[Message part 1 (text/plain, inline)]
Hi,

On Sun, Nov 29, 2009 at 03:59:37PM +0100, Julien Cristau wrote:
> On Sun, Nov 29, 2009 at 15:32:00 +0100, Sebastian Harl wrote:
> > collectd uses net-snmp-config(1)'s --cflags option to determine the
> > flags used to build the snmp plugin. net-snmp-config(1) is a shell
> > script included in the Arch: all package libsnmp-base. That script is
> > created at net-snmp build time and includes the CFLAGS that are used to
> > build net-snmp itself (and which are then returned by 'net-snmp-config
> > --cflags'). Now, net-snmp's CFLAGS include the output of 'perl
> > -MExtUtils::Embed -e ccopts' (which is required for the embedded perl
> > stuff), which, in turn, includes '-fstack-protector' on *some*
> > architectures (presumably, on those that support that flag).
> > 
> I'm pretty sure exporting random cflags used to build net-snmp to other
> packages is wrong.

Right. However, those CFLAGS are not entirely random. The perl CFLAGS
are required when using libnetsnmpagent according to #502806. I don't
think it's reasonable to "filter" (e.g. remove -fstack-protector) those
flags before adding them to the net-snmp CFLAGS. However, it would be
nice to let net-snmp-config return different flags for e.g. libnetsnmp
and libnetsnmpagent (see my follow-up to #502806).

Also, it could be argued that perl should not include flags like
-fstack-protector in the output of ccopts. I don't have a strong opinion
on that, though.

Cheers,
Sebastian

-- 
Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>:
Bug#558488; Package src:net-snmp. (Wed, 02 Dec 2009 08:27:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sebastian Harl <tokkee@debian.org>:
Extra info received and forwarded to list. Copy sent to Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>. (Wed, 02 Dec 2009 08:27:07 GMT) Full text and rfc822 format available.

Message #31 received at 558488@bugs.debian.org (full text, mbox):

From: Sebastian Harl <tokkee@debian.org>
To: dann frazier <dannf@debian.org>, 559087@bugs.debian.org
Cc: 558488@bugs.debian.org
Subject: Re: Bug#559087: FTBFS [hppa]: -fstack-protector not supported for this target
Date: Wed, 2 Dec 2009 09:21:49 +0100
[Message part 1 (text/plain, inline)]
block 559087 by 558488
thanks

Hi,

On Tue, Dec 01, 2009 at 02:21:56PM -0700, dann frazier wrote:
> collectd_4.8.1-2 reliably fails to build on hppa:
>   https://buildd.debian.org/build.php?&pkg=collectd&ver=4.8.1-2&arch=hppa&file=log
> 
> From the most recent build attempt:
> [...]
> snmp.c:1: error: -fstack-protector not supported for this target

Thanks for reporting this! Please note, that this had already been
reported as #558488 (on ia64), which was then reassigned to net-snmp.
Since other architectures are affected as well, I'm keeping this bug
open in collectd for future reference.

I'm thinking about letting the collectd configure script filter out that
option, but that'd be a rather bad hack imho, so a fixed net-snmp would
be preferred.

Cheers,
Sebastian

-- 
Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

[signature.asc (application/pgp-signature, inline)]

Added indication that bug 558488 blocks 559087 Request was from Sebastian Harl <tokkee@debian.org> to control@bugs.debian.org. (Wed, 02 Dec 2009 08:27:11 GMT) Full text and rfc822 format available.

Reply sent to Jochen Friedrich <jochen@scram.de>:
You have taken responsibility. (Wed, 02 Dec 2009 16:21:23 GMT) Full text and rfc822 format available.

Notification sent to lamont@debian.org:
Bug acknowledged by developer. (Wed, 02 Dec 2009 16:21:23 GMT) Full text and rfc822 format available.

Message #38 received at 558488-close@bugs.debian.org (full text, mbox):

From: Jochen Friedrich <jochen@scram.de>
To: 558488-close@bugs.debian.org
Subject: Bug#558488: fixed in net-snmp 5.4.2.1~dfsg-4
Date: Wed, 02 Dec 2009 16:18:00 +0000
Source: net-snmp
Source-Version: 5.4.2.1~dfsg-4

We believe that the bug you reported is fixed in the latest version of
net-snmp, which is due to be installed in the Debian FTP archive:

libsnmp-base_5.4.2.1~dfsg-4_all.deb
  to main/n/net-snmp/libsnmp-base_5.4.2.1~dfsg-4_all.deb
libsnmp-dev_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/libsnmp-dev_5.4.2.1~dfsg-4_sparc.deb
libsnmp-perl_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/libsnmp-perl_5.4.2.1~dfsg-4_sparc.deb
libsnmp-python_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/libsnmp-python_5.4.2.1~dfsg-4_sparc.deb
libsnmp15-dbg_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/libsnmp15-dbg_5.4.2.1~dfsg-4_sparc.deb
libsnmp15_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/libsnmp15_5.4.2.1~dfsg-4_sparc.deb
net-snmp_5.4.2.1~dfsg-4.diff.gz
  to main/n/net-snmp/net-snmp_5.4.2.1~dfsg-4.diff.gz
net-snmp_5.4.2.1~dfsg-4.dsc
  to main/n/net-snmp/net-snmp_5.4.2.1~dfsg-4.dsc
snmp_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/snmp_5.4.2.1~dfsg-4_sparc.deb
snmpd_5.4.2.1~dfsg-4_sparc.deb
  to main/n/net-snmp/snmpd_5.4.2.1~dfsg-4_sparc.deb
tkmib_5.4.2.1~dfsg-4_all.deb
  to main/n/net-snmp/tkmib_5.4.2.1~dfsg-4_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 558488@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jochen Friedrich <jochen@scram.de> (supplier of updated net-snmp package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 01 Dec 2009 18:40:38 +0100
Source: net-snmp
Binary: snmpd snmp libsnmp-base libsnmp15 libsnmp15-dbg libsnmp-dev libsnmp-perl libsnmp-python tkmib
Architecture: source sparc all
Version: 5.4.2.1~dfsg-4
Distribution: unstable
Urgency: low
Maintainer: Net-SNMP Packaging Team <pkg-net-snmp-devel@lists.alioth.debian.org>
Changed-By: Jochen Friedrich <jochen@scram.de>
Description: 
 libsnmp-base - SNMP (Simple Network Management Protocol) MIBs and documentation
 libsnmp-dev - SNMP (Simple Network Management Protocol) development files
 libsnmp-perl - SNMP (Simple Network Management Protocol) Perl5 support
 libsnmp-python - SNMP (Simple Network Management Protocol) Python support
 libsnmp15  - SNMP (Simple Network Management Protocol) library
 libsnmp15-dbg - SNMP (Simple Network Management Protocol) library debug
 snmp       - SNMP (Simple Network Management Protocol) applications
 snmpd      - SNMP (Simple Network Management Protocol) agents
 tkmib      - SNMP (Simple Network Management Protocol) MIB browser
Closes: 502806 530289 557244 557434 557540 557682 558488
Changes: 
 net-snmp (5.4.2.1~dfsg-4) unstable; urgency=low
 .
   * Update 26_kfreebsd.patch with patch from Petr Salinger
     <Petr.Salinger@seznam.cz> (Closes: #557244).
   * Applied patch from Jakub Wilk <ubanus@users.sf.net> to make the
     python module compile with python2.6 (Closes: #557540).
   * Suggests snmp-mibs-downloader from contrib to download MIBs.
     Remove the download scripts from this package (Closes: #557434, #557682)
   * Move net-snmp-config to libsnmp15 as it contains platform dependent
     code (Closes: #558488). Also clean up old Replaces / Conflicts.
   * Add patch from Pino Toscano <pino@kde.org> for hurd-i386 support.
     Closes: #530289.
   * Provide a new option --base-lib-cflags for CFLAGS without perl dependent
     stuff. (Closes: #502806)
Checksums-Sha1: 
 46027b199529eaac9d62f162a83e75e5fe0b7561 1823 net-snmp_5.4.2.1~dfsg-4.dsc
 25d6a26ec71c4d62141d25c3b4d8d70895b40eae 48774 net-snmp_5.4.2.1~dfsg-4.diff.gz
 d7fc5a19ccfdcfc4715bdd83e8e16860098b0ed9 947302 snmpd_5.4.2.1~dfsg-4_sparc.deb
 119f5cfe8697761c78d0fe8718afde6c45c62c0f 1031172 snmp_5.4.2.1~dfsg-4_sparc.deb
 5244067e64a5af44ba1a6dc300d17c15edd793af 1071102 libsnmp-base_5.4.2.1~dfsg-4_all.deb
 a568be2f932dfbc129f0d357f0f500837f3af8fd 2051178 libsnmp15_5.4.2.1~dfsg-4_sparc.deb
 f1e17ec1cde0f580ed5150e6d8f8e7d47a48cf9d 1317900 libsnmp15-dbg_5.4.2.1~dfsg-4_sparc.deb
 74d214c291d78145d51b13770c590ee0c15dc7f2 1761922 libsnmp-dev_5.4.2.1~dfsg-4_sparc.deb
 e6024c126f7f60345a4980b6fb5d1c7fd7ebdbff 142178 libsnmp-perl_5.4.2.1~dfsg-4_sparc.deb
 70c624690eb2bcbbfb829f7fb595ad8257cc3ed0 906590 libsnmp-python_5.4.2.1~dfsg-4_sparc.deb
 4db663a1e59bda86d0ee75f22a123076349427c6 959348 tkmib_5.4.2.1~dfsg-4_all.deb
Checksums-Sha256: 
 77ff8038d56ee8d8f9739d189459e62306411bf0fc786e486d5c3410e044463d 1823 net-snmp_5.4.2.1~dfsg-4.dsc
 4d4b77b2f5af6bf8c113e90efb43d0ec9d2681e0d8db783686c8f5fd95e0f3bf 48774 net-snmp_5.4.2.1~dfsg-4.diff.gz
 bb06f45446992c7a820ed60c1121ddd213d5a8382f8e4c7b65a379722ace27b0 947302 snmpd_5.4.2.1~dfsg-4_sparc.deb
 2c07127ed68b880fa5f1ce7dca23cc21617273a1302c20519cc9c6257a1034eb 1031172 snmp_5.4.2.1~dfsg-4_sparc.deb
 dace12abbfb2d3173bdd4df58ef9f5eb8b63713cedcfbe3609094d1e7108f3de 1071102 libsnmp-base_5.4.2.1~dfsg-4_all.deb
 39d0eb4aabea60fb0a5284b8353d7a4bb3a611e75b1b5e2b00e2ff7c029e449c 2051178 libsnmp15_5.4.2.1~dfsg-4_sparc.deb
 7983743bde9ebb78d16cd48cff77e5cd124c25d01322222f438339e3724924a1 1317900 libsnmp15-dbg_5.4.2.1~dfsg-4_sparc.deb
 e01708201563a3549dfb3678ec04b7ce0404d39fe4ce000649f0772b77c739b3 1761922 libsnmp-dev_5.4.2.1~dfsg-4_sparc.deb
 aec6cab1157b66e55cef9e641641da7651909f77f3ff896e225b889354068fbb 142178 libsnmp-perl_5.4.2.1~dfsg-4_sparc.deb
 9ef9f1deebdc3c8fa091b1e112d8f761ce008baf988856eb8e3afa9e5932b2e0 906590 libsnmp-python_5.4.2.1~dfsg-4_sparc.deb
 f791b2b0c1be24fab6d81c0b29303bb6d12fc8d1808652caf655b7873a1191f7 959348 tkmib_5.4.2.1~dfsg-4_all.deb
Files: 
 0504e8f0c65945a2f71ab3e4a2966a0b 1823 net optional net-snmp_5.4.2.1~dfsg-4.dsc
 28013e86f304a42807446094b55fac57 48774 net optional net-snmp_5.4.2.1~dfsg-4.diff.gz
 17fb2eda3a246d38ee2847f23e05f77e 947302 net optional snmpd_5.4.2.1~dfsg-4_sparc.deb
 52249bcecc9ff34b2db1e062ab718899 1031172 net optional snmp_5.4.2.1~dfsg-4_sparc.deb
 b461df41136a9190fa7219b285d22f78 1071102 libs optional libsnmp-base_5.4.2.1~dfsg-4_all.deb
 26889b4c6e8ab15ef646c26d2e0a1dbf 2051178 libs optional libsnmp15_5.4.2.1~dfsg-4_sparc.deb
 ffe962a36a5fb7b9af41ae95c3bc31b4 1317900 debug extra libsnmp15-dbg_5.4.2.1~dfsg-4_sparc.deb
 ec4ff8ec26c41a7e556bfaed08b16c67 1761922 libdevel optional libsnmp-dev_5.4.2.1~dfsg-4_sparc.deb
 c740dfb8ca95ffd1a20d998d51f4f013 142178 perl optional libsnmp-perl_5.4.2.1~dfsg-4_sparc.deb
 56c58d2ac15b30ce147de2afad6e64cd 906590 python optional libsnmp-python_5.4.2.1~dfsg-4_sparc.deb
 e9c9953621db61eaa8e9f02193b2a1e3 959348 net optional tkmib_5.4.2.1~dfsg-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iD8DBQFLFpD30fhX0Y/ocz0RAgqpAJ9f+dReQI9luCjErzFLgGf99W6QjgCgpPZS
W2y2ppxefrjfWf8C0+OshYY=
=3N5s
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 31 Dec 2009 07:44:57 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 06:40:10 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.