Debian Bug report logs - #551356
libpar-packer-perl: fails to extract Parl with Perl 5.10.1

version graph

Package: libpar-packer-perl; Maintainer for libpar-packer-perl is Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>; Source for libpar-packer-perl is src:libpar-packer-perl.

Reported by: "Eugene V. Lyubimkin" <jackyf@debian.org>

Date: Sat, 17 Oct 2009 16:27:01 UTC

Severity: grave

Found in version libpar-packer-perl/0.991-2

Fixed in version libpar-packer-perl/0.991-3

Done: gregor herrmann <gregoa@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Sat, 17 Oct 2009 16:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Eugene V. Lyubimkin" <jackyf@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Sat, 17 Oct 2009 16:27:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Eugene V. Lyubimkin" <jackyf@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Sat, 17 Oct 2009 19:16:23 +0300
Package: libpar-packer-perl
Version: 0.991-2
Severity: grave
Justification: renders package unusable

The /usr/bin/pp cannot bundle even tiny "printer":

$ pp -o haha -e "print 'hello'"
Perl lib version (5.10.1) doesn't match executable version (v5.10.0) at
/usr/lib/perl/5.10/Config.pm line 50.
Compilation failed in require at /usr/share/perl/5.10/File/Find.pm line
1336.
Compilation failed in require at /usr/share/perl5/Archive/Zip/Archive.pm
line 7.
BEGIN failed--compilation aborted at
/usr/share/perl5/Archive/Zip/Archive.pm line 7.
Compilation failed in require at /usr/share/perl5/Archive/Zip.pm line
254.
Compilation failed in require at -e line 449.
/usr/bin/pp: Failed to extract a parl from 'PAR::StrippedPARL::Static'
to file 'parlGqZisDq' at /usr/share/perl5/PAR/Packer.pm line 1155,
<DATA> line 1.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libpar-packer-perl depends on:
ii  libarchive-zip-perl           1.30-1     Perl module for manipulation of ZI
ii  libc6                         2.9-27     GNU C Library: Shared libraries
ii  libgetopt-argvfile-perl       1.11-1     Perl module for reading script opt
ii  libio-compress-perl [libcompr 2.020-2    IO::Compress modules
ii  libmodule-scandeps-perl       0.95-1     Perl module to recursively scan Pe
ii  libpar-dist-perl              0.45-1     perl module to create and manipula
ii  libpar-perl                   0.994-1    Perl redistributable module packag
ii  libperl5.10                   5.10.1-5   Shared Perl library
ii  perl [libcompress-zlib-perl]  5.10.1-5   Larry Wall's Practical Extraction 

Versions of packages libpar-packer-perl recommends:
pn  libtk-perl                    <none>     (no description available)

libpar-packer-perl suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Sat, 17 Oct 2009 20:12:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Sat, 17 Oct 2009 20:12:06 GMT) Full text and rfc822 format available.

Message #10 received at 551356@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: "Eugene V. Lyubimkin" <jackyf@debian.org>, 551356@bugs.debian.org
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Sat, 17 Oct 2009 22:07:38 +0200
[Message part 1 (text/plain, inline)]
tag 551356 + confirmed
thanks

On Sat, 17 Oct 2009 19:16:23 +0300, Eugene V. Lyubimkin wrote:

> $ pp -o haha -e "print 'hello'"
> Perl lib version (5.10.1) doesn't match executable version (v5.10.0) at
> /usr/lib/perl/5.10/Config.pm line 50.

Hm, nasty.

I thought about adding perlapi-$Config{version} to Depends manually [0],
but that wouldn't buy us anything in this case: The current version
of libpar-packer-perl would have perlapi-5.10.0 -- and perl-base
5.10.1 provides perlapi-5.10.1 and perlapi-5.10.0, and we would be
back at square one.

Do we need to add libperl5.10 (<< $current+1~) or something like
that? Or is there a better way to ensure that the runtime
dependencies match the perl version at build time?


Cheers,
gregor

[0] dh_perl doesn't do it in this case because there are no .so files
-- 
 .''`.   http://info.comodo.priv.at/ -- GPG Key IDs: 0x00F3CFE4, 0x8649AA06
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Kurt Ostbahn & Die Kombo: Damit wos weidageht
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Sat, 17 Oct 2009 20:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Eugene V. Lyubimkin" <jackyf@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Sat, 17 Oct 2009 20:27:04 GMT) Full text and rfc822 format available.

Message #15 received at 551356@bugs.debian.org (full text, mbox):

From: "Eugene V. Lyubimkin" <jackyf@debian.org>
To: gregor herrmann <gregoa@debian.org>
Cc: 551356@bugs.debian.org
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Sat, 17 Oct 2009 23:18:05 +0300
[Message part 1 (text/plain, inline)]
gregor herrmann wrote:
> tag 551356 + confirmed
> thanks
> 
> On Sat, 17 Oct 2009 19:16:23 +0300, Eugene V. Lyubimkin wrote:
> 
>> $ pp -o haha -e "print 'hello'"
>> Perl lib version (5.10.1) doesn't match executable version (v5.10.0) at
>> /usr/lib/perl/5.10/Config.pm line 50.
> 
> Hm, nasty.
> 
> I thought about adding perlapi-$Config{version} to Depends manually [0],
> but that wouldn't buy us anything in this case: The current version
> of libpar-packer-perl would have perlapi-5.10.0 -- and perl-base
> 5.10.1 provides perlapi-5.10.1 and perlapi-5.10.0, and we would be
> back at square one.
Honestly I am not acquainted with PAR, just tried to run it first time. Do you
mean PAR requires perl version exact that was used for building?..

> Do we need to add libperl5.10 (<< $current+1~) or something like
> that? Or is there a better way to ensure that the runtime
> dependencies match the perl version at build time?
..seems so.

I don't know better solutions so far. Fortunately even patch Perl updates are
quite rare AFAIK, so this should work, and if set up automatically in rules,
should require only binNMU at the every next Perl update.

-- 
Eugene V. Lyubimkin aka JackYF, JID: jackyf.devel(maildog)gmail.com
C++/Perl developer, Debian Developer

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Sat, 17 Oct 2009 21:03:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Sat, 17 Oct 2009 21:03:10 GMT) Full text and rfc822 format available.

Message #20 received at 551356@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: "Eugene V. Lyubimkin" <jackyf@debian.org>
Cc: 551356@bugs.debian.org
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Sat, 17 Oct 2009 22:53:48 +0200
[Message part 1 (text/plain, inline)]
On Sat, 17 Oct 2009 23:18:05 +0300, Eugene V. Lyubimkin wrote:

> >> $ pp -o haha -e "print 'hello'"
> >> Perl lib version (5.10.1) doesn't match executable version (v5.10.0) at
> >> /usr/lib/perl/5.10/Config.pm line 50.
> > I thought about adding perlapi-$Config{version} to Depends manually [0],
> > but that wouldn't buy us anything in this case: The current version
> > of libpar-packer-perl would have perlapi-5.10.0 -- and perl-base
> > 5.10.1 provides perlapi-5.10.1 and perlapi-5.10.0, and we would be
> > back at square one.
> Honestly I am not acquainted with PAR, just tried to run it first time. Do you
> mean PAR requires perl version exact that was used for building?..

That was my interpretation of the error above, which might be wrong
...
 
> > Do we need to add libperl5.10 (<< $current+1~) or something like
> > that? Or is there a better way to ensure that the runtime
> > dependencies match the perl version at build time?
> ..seems so.
> I don't know better solutions so far. Fortunately even patch Perl updates are
> quite rare AFAIK, so this should work, and if set up automatically in rules,
> should require only binNMU at the every next Perl update.

Ok, let's wait a bit if someone else comes up with a better idea
before I "steal" the versioning magic from libalien-wxwidgets-perl :) 

Cheers,
gregor 
-- 
 .''`.   http://info.comodo.priv.at/ -- GPG Key IDs: 0x00F3CFE4, 0x8649AA06
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Eagles
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Thu, 22 Oct 2009 07:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Thu, 22 Oct 2009 07:57:03 GMT) Full text and rfc822 format available.

Message #25 received at 551356@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 551356@bugs.debian.org
Cc: "Eugene V. Lyubimkin" <jackyf@debian.org>
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Thu, 22 Oct 2009 10:37:51 +0300
On Sat, Oct 17, 2009 at 10:53:48PM +0200, gregor herrmann wrote:
> On Sat, 17 Oct 2009 23:18:05 +0300, Eugene V. Lyubimkin wrote:
> 
> > >> $ pp -o haha -e "print 'hello'"
> > >> Perl lib version (5.10.1) doesn't match executable version (v5.10.0) at
> > >> /usr/lib/perl/5.10/Config.pm line 50.

> > Honestly I am not acquainted with PAR, just tried to run it first time. Do you
> > mean PAR requires perl version exact that was used for building?..
> 
> That was my interpretation of the error above, which might be wrong

There's a static perl 5.10.0 inside both /usr/bin/parl and
/usr/share/perl5/PAR/StrippedPARL/Static.pm, and it won't work
with Config.pm from 5.10.1.

> > > Do we need to add libperl5.10 (<< $current+1~) or something like
> > > that? 

It's clearly necessary ATM but I'm not quite sure if that's intentional
or a bug.  myldr/Makefile.PL builds parl with -B, which is supposed
to embed core modules.

I think it's an OK solution at least for the moment as long as it's
made binNMU safe.

> > > Or is there a better way to ensure that the runtime
> > > dependencies match the perl version at build time?

Not to my knowledge.

There seems to be other possibly related trouble around PAR - see

 http://rt.cpan.org/Ticket/Display.html?id=42986
 http://rt.cpan.org/Ticket/Display.html?id=48240

It looks like at least the lenny par.pl won't use shared objects inside
the PAR archive if there's one on the system already, which is very much
Not Good.

RL is leaving me very little time for Debian currently, so it would be
great if Somebody Else could dig into this.
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Thu, 29 Oct 2009 15:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Thu, 29 Oct 2009 15:54:03 GMT) Full text and rfc822 format available.

Message #30 received at 551356@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: Niko Tyni <ntyni@debian.org>, 551356@bugs.debian.org
Cc: "Eugene V. Lyubimkin" <jackyf@debian.org>
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Thu, 29 Oct 2009 16:06:05 +0100
[Message part 1 (text/plain, inline)]
On Thu, 22 Oct 2009 10:37:51 +0300, Niko Tyni wrote:

> > > Honestly I am not acquainted with PAR, just tried to run it first time. Do you
> > > mean PAR requires perl version exact that was used for building?..
> > That was my interpretation of the error above, which might be wrong
> There's a static perl 5.10.0 inside both /usr/bin/parl and
> /usr/share/perl5/PAR/StrippedPARL/Static.pm, and it won't work
> with Config.pm from 5.10.1.

Thanks for the confirmation.
 
> > > > Do we need to add libperl5.10 (<< $current+1~) or something like
> > > > that? 
> 
> It's clearly necessary ATM but I'm not quite sure if that's intentional
> or a bug.  myldr/Makefile.PL builds parl with -B, which is supposed
> to embed core modules.
> 
> I think it's an OK solution at least for the moment as long as it's
> made binNMU safe.

Ok, I've now come up with the change below, which leads to:
Depends: perl (>= 5.10.1), [..] libperl5.10 (>= 5.10.1), perl (<< 5.10.2~), [..]

#v+

Index: debian/control
===================================================================
--- debian/control      (revision 46498)
+++ debian/control      (working copy)
@@ -22,6 +22,7 @@
 Package: libpar-packer-perl
 Architecture: any
 Depends: ${misc:Depends}, ${perl:Depends}, ${shlibs:Depends},
+ perl (>= ${perl:current}), perl (<< ${perl:next}),
  libarchive-zip-perl (>= 1),
  libgetopt-argvfile-perl (>= 1.07),
  libmodule-scandeps-perl (>= 0.81),
Index: debian/rules
===================================================================
--- debian/rules        (revision 46498)
+++ debian/rules        (working copy)
@@ -1,5 +1,11 @@
 #!/usr/bin/make -f
 
+PERLVER   := $(shell perl -e 'printf "%vd\n", $$^V')
+VMAJOR    := $(shell echo $(PERLVER) | cut -f 1 -d .)
+VMINOR    := $(shell echo $(PERLVER) | cut -f 2 -d .)
+VPATCH    := $(shell echo $(PERLVER) | cut -f 3 -d .)
+NEXTPATCH := $(shell expr $(VPATCH) + 1 2>/dev/null)
+
 %:
        dh --with quilt $@
 
@@ -20,3 +26,8 @@
        dh_auto_install
        prename s/\.pl/-archive/ \
                $(TMP)/usr/bin/par.pl $(TMP)/usr/share/man/man1/par.pl.1p
+
+override_dh_gencontrol:
+       dh_gencontrol -- \
+               -Vperl:current="$(VMAJOR).$(VMINOR).$(VPATCH)" \
+               -Vperl:next="$(VMAJOR).$(VMINOR).$(NEXTPATCH)~"

#v-
 
Does this look sane?


Cheers,
gregor
-- 
 .''`.   http://info.comodo.priv.at/ -- GPG Key IDs: 0x00F3CFE4, 0x8649AA06
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    NP: Elton John: Sad Songs
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Thu, 29 Oct 2009 16:06:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Eugene V. Lyubimkin" <jackyf@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Thu, 29 Oct 2009 16:06:13 GMT) Full text and rfc822 format available.

Message #35 received at 551356@bugs.debian.org (full text, mbox):

From: "Eugene V. Lyubimkin" <jackyf@debian.org>
To: gregor herrmann <gregoa@debian.org>
Cc: Niko Tyni <ntyni@debian.org>, 551356@bugs.debian.org
Subject: Re: Bug#551356: libpar-packer-perl: fails to extract Parl with Perl 5.10.1
Date: Thu, 29 Oct 2009 17:36:33 +0200
[Message part 1 (text/plain, inline)]
gregor herrmann wrote:
>> I think it's an OK solution at least for the moment as long as it's
>> made binNMU safe.
> 
> Ok, I've now come up with the change below, which leads to:
> Depends: perl (>= 5.10.1), [..] libperl5.10 (>= 5.10.1), perl (<< 5.10.2~), [..]
> 
>[...]

Looks good for me.

-- 
Eugene V. Lyubimkin aka JackYF, JID: jackyf.devel(maildog)gmail.com
C++/Perl developer, Debian Developer

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#551356; Package libpar-packer-perl. (Thu, 29 Oct 2009 16:06:25 GMT) Full text and rfc822 format available.

Message #38 received at 551356@bugs.debian.org (full text, mbox):

From: pkg-perl-maintainers@lists.alioth.debian.org
To: 551356@bugs.debian.org, 551356-submitter@bugs.debian.org
Subject: Bug in libpar-packer-perl fixed in revision 46503
Date: Thu, 29 Oct 2009 15:47:28 +0000
tag 551356 + pending
thanks

Some bugs are closed in revision 46503
by Gregor Herrmann (gregoa)

Commit message:

We need the same perl version at runtime as at build time; add some
substvar handling to debian/control and debian/rules to enforce an "upper
bound". Thanks to Eugene V. Lyubimkin for the bug report and to Niko Tyni
for his help in the analysis (closes: #551356).




Added tag(s) pending. Request was from pkg-perl-maintainers@lists.alioth.debian.org to control@bugs.debian.org. (Thu, 29 Oct 2009 16:06:26 GMT) Full text and rfc822 format available.

Message sent on to "Eugene V. Lyubimkin" <jackyf@debian.org>:
Bug#551356. (Thu, 29 Oct 2009 16:06:29 GMT) Full text and rfc822 format available.

Reply sent to gregor herrmann <gregoa@debian.org>:
You have taken responsibility. (Thu, 29 Oct 2009 22:00:19 GMT) Full text and rfc822 format available.

Notification sent to "Eugene V. Lyubimkin" <jackyf@debian.org>:
Bug acknowledged by developer. (Thu, 29 Oct 2009 22:00:19 GMT) Full text and rfc822 format available.

Message #48 received at 551356-close@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: 551356-close@bugs.debian.org
Subject: Bug#551356: fixed in libpar-packer-perl 0.991-3
Date: Thu, 29 Oct 2009 20:47:12 +0000
Source: libpar-packer-perl
Source-Version: 0.991-3

We believe that the bug you reported is fixed in the latest version of
libpar-packer-perl, which is due to be installed in the Debian FTP archive:

libpar-packer-perl_0.991-3.diff.gz
  to main/libp/libpar-packer-perl/libpar-packer-perl_0.991-3.diff.gz
libpar-packer-perl_0.991-3.dsc
  to main/libp/libpar-packer-perl/libpar-packer-perl_0.991-3.dsc
libpar-packer-perl_0.991-3_i386.deb
  to main/libp/libpar-packer-perl/libpar-packer-perl_0.991-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 551356@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
gregor herrmann <gregoa@debian.org> (supplier of updated libpar-packer-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 29 Oct 2009 17:58:20 +0100
Source: libpar-packer-perl
Binary: libpar-packer-perl
Architecture: source i386
Version: 0.991-3
Distribution: unstable
Urgency: low
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: gregor herrmann <gregoa@debian.org>
Description: 
 libpar-packer-perl - utility for creating PAR archives and stand-alone executables
Closes: 551356
Changes: 
 libpar-packer-perl (0.991-3) unstable; urgency=low
 .
   [ Ryan Niebur ]
   * Update ryan52's email address
 .
   [ gregor herrmann ]
   * We need the same perl version at runtime as at build time; add some
     substvar handling to debian/control and debian/rules to enforce an "upper
     bound". Thanks to Eugene V. Lyubimkin for the bug report and to Niko Tyni
     for his help in the analysis (closes: #551356).
Checksums-Sha1: 
 c903313e872668a2884bd0f7aa1e70e27cd51c10 1623 libpar-packer-perl_0.991-3.dsc
 95f94b78bc63daf7128c2518fe21951b6ff4be5e 5714 libpar-packer-perl_0.991-3.diff.gz
 4c3858c909cd35eaa1af523f222b0a4b52f3ad3b 1717700 libpar-packer-perl_0.991-3_i386.deb
Checksums-Sha256: 
 78533c2d328294f8b5c0d7d019009817e24c1a9da4810e02135c0fe409722964 1623 libpar-packer-perl_0.991-3.dsc
 2b27ef902bb68fb0267fbada6dfeb87055746ac7f8b2644dd2e95071651dc2a6 5714 libpar-packer-perl_0.991-3.diff.gz
 e5c81e83111a71b091958a0324f86fda58b00292c7cf3a5e1e4131e20ad84b58 1717700 libpar-packer-perl_0.991-3_i386.deb
Files: 
 5095560aa160b940261e0b5f11298105 1623 perl optional libpar-packer-perl_0.991-3.dsc
 df93ec83b26fe443b111e511426b79cb 5714 perl optional libpar-packer-perl_0.991-3.diff.gz
 7c96710ab131bd8eb58ed6cc9bbf1769 1717700 perl optional libpar-packer-perl_0.991-3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkrpzEMACgkQOzKYnQDzz+TFiwCgo28QxhCM/pjvAD3ZxsxUnoRp
Jo0AoOt7y5NQ+O5YVhHHGavcI6JrFK8H
=gse3
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 07 Dec 2009 07:34:28 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 00:28:10 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.