Debian Bug report logs - #549309
konqueror-nsplugins: nsplugin SEGVs on all flash sites

version graph

Package: konqueror-nsplugins; Maintainer for konqueror-nsplugins is Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>; Source for konqueror-nsplugins is src:kde-baseapps.

Reported by: Russell Coker <russell@coker.com.au>

Date: Fri, 2 Oct 2009 11:00:01 UTC

Severity: normal

Found in versions kdebase/4:3.5.9.dfsg.1-6, kdebase/4:4.4.5-1

Blocking fix for 596895: konqueror-plugin-gnash doesn't play youtube videos

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Fri, 02 Oct 2009 11:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Russell Coker <russell@coker.com.au>:
New Bug report received and forwarded. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Fri, 02 Oct 2009 11:00:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Russell Coker <russell@coker.com.au>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: konqueror-nsplugins: nsplugin SEGVs on all flash sites
Date: Fri, 02 Oct 2009 20:54:57 +1000
Package: konqueror-nsplugins
Version: 4:3.5.9.dfsg.1-6
Severity: normal

Sites such as http://www.nsa.gov/ cause nsplugin to crash on my system.  I have
gnash, gnash-common, gnash-tools, and mozilla-plugin-gnash installed.

Iceweasel displays http://www.nsa.gov/ in a way that appears to be correct.


-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=ANSI_X3.4-1968) (ignored: LC_ALL set to C)
Shell: /bin/sh linked to /bin/bash

Versions of packages konqueror-nsplugins depends on:
ii  kdelibs4c2a      4:3.5.10.dfsg.1-0lenny2 core libraries and binaries for al
ii  konqueror        4:3.5.9.dfsg.1-6        KDE's advanced file manager, web b
ii  libc6            2.7-18                  GNU C Library: Shared libraries
ii  libgcc1          1:4.3.2-1.1             GCC support library
ii  libglib2.0-0     2.16.6-2                The GLib library of C routines
ii  libqt3-mt        3:3.3.8b-5+b1           Qt GUI Library (Threaded runtime v
ii  libstdc++6       4.3.2-1.1               The GNU Standard C++ Library v3
ii  libx11-6         2:1.1.5-2               X11 client-side library
ii  libxt6           1:1.0.5-3               X11 toolkit intrinsics library

konqueror-nsplugins recommends no packages.

konqueror-nsplugins suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Tue, 21 Sep 2010 22:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gabriele Giacone <1o5g4r8o@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Tue, 21 Sep 2010 22:57:03 GMT) Full text and rfc822 format available.

Message #10 received at 549309@bugs.debian.org (full text, mbox):

From: Gabriele Giacone <1o5g4r8o@gmail.com>
To: 549309@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: konqueror-nsplugins: nsplugin SEGVs on all flash sites
Date: Wed, 22 Sep 2010 00:48:38 +0200
block 596895 by 549309
found 549309 4:4.4.5-1
thanks

Same behaviour in 4:4.4.5-1 version with gnash 0.8.8-5.

ii  browser-plugin-gnash                 0.8.8-5
ii  gnash                                0.8.8-5
ii  gnash-common                         0.8.8-5

It crashes if webpage contains any flash animations.

----
Application: nspluginviewer (nspluginviewer), signal: Aborted
The current source language is "auto; currently asm".
[Current thread is 1 (Thread 0x7f1821e83760 (LWP 6826))]

Thread 2 (Thread 0x7f180eefa710 (LWP 6828)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007f181f99fdd2 in QWaitConditionPrivate::wait (this=<value optimized
out>, mutex=0x1d4be90, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1d4be90,
time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f181f994e01 in QThreadPoolThread::run (this=0x1d42620) at
concurrent/qthreadpool.cpp:140
#4  0x00007f181f99ee15 in QThreadPrivate::start (arg=0x1d42620) at
thread/qthread_unix.cpp:248
#5  0x00007f181b5458ba in start_thread (arg=<value optimized out>) at
pthread_create.c:300
#6  0x00007f181e69002d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1821e83760 (LWP 6826)):
[KCrash Handler]
#5  0x00007f181e5f3165 in *__GI_raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f181e5f5f70 in *__GI_abort () at abort.c:92
#7  0x00007f181e9eedc5 in __gnu_cxx::__verbose_terminate_handler() () from
/usr/lib/libstdc++.so.6
#8  0x00007f181e9ed166 in ?? () from /usr/lib/libstdc++.so.6
#9  0x00007f181e9ed193 in std::terminate() () from /usr/lib/libstdc++.so.6
#10 0x00007f181e9ed216 in __cxa_rethrow () from /usr/lib/libstdc++.so.6
#11 0x00007f181fa8cf0d in QEventLoop::exec (this=<value optimized out>,
flags=<value optimized out>) at kernel/qeventloop.cpp:214
#12 0x00007f181fa91a4b in QCoreApplication::exec () at
kernel/qcoreapplication.cpp:1003
#13 0x0000000000416404 in main (argc=<value optimized out>, argv=<value
optimized out>) at ../../../../apps/nsplugins/viewer/viewer.cpp:144





Added indication that bug 549309 blocks 596895 Request was from Gabriele Giacone <1o5g4r8o@gmail.com> to control@bugs.debian.org. (Tue, 21 Sep 2010 22:57:05 GMT) Full text and rfc822 format available.

Bug Marked as found in versions kdebase/4:4.4.5-1. Request was from Gabriele Giacone <1o5g4r8o@gmail.com> to control@bugs.debian.org. (Tue, 21 Sep 2010 22:57:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sat, 14 Jan 2012 07:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alexey Eromenko <al4321@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sat, 14 Jan 2012 07:57:03 GMT) Full text and rfc822 format available.

Message #19 received at 549309@bugs.debian.org (full text, mbox):

From: Alexey Eromenko <al4321@gmail.com>
To: 549309@bugs.debian.org
Subject: This bug is critical
Date: Sat, 14 Jan 2012 09:53:39 +0200
This bug is critical, mostly because it is installed with default KDE,
and many new users experience KDE crash in Debian-stable.
Very ugly end user experience.

If possible, please fix it or remove this package from the default
Debian KDE install.

-- 
-Alexey Eromenko "Technologov"




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sat, 14 Jan 2012 11:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sat, 14 Jan 2012 11:21:07 GMT) Full text and rfc822 format available.

Message #24 received at 549309@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Alexey Eromenko <al4321@gmail.com>
Cc: debian-user <debian-user@lists.debian.org>, debian-release@lists.debian.org, 549309@bugs.debian.org
Subject: Re: Upcoming stable point release
Date: Sat, 14 Jan 2012 11:18:19 +0000
[added the KDE bug and -release to Cc]

Hi,

On Sat, 2012-01-14 at 09:18 +0200, Alexey Eromenko wrote:
> Please, if possible, exclude "konqueror-nsplugins" from the default
> KDE install in 6.0.4.
> 
> It crashes as soon as user enters any flash-enabled website. (www.amd.com)
> Very ugly user experience. Especially for Debian-stable.
> 
> (tried Debian 6.0.3 on AMD64 and i386)
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=549309

The Release Team don't make changes ourselves to the contents of
packages in stable, it's more of a collating and reviewing role for
changes that maintainers wish to make.

In this situation, either the maintainer would need to make the required
changes or another developer would need to make a non-maintainer upload
to do so.  In either case, we'd generally require that such changes are
made in unstable first, so that any regressions or new issues caused by
the change can be found before the change lands in stable.

Regards,

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sat, 14 Jan 2012 19:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gabriele Giacone <1o5g4r8o@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sat, 14 Jan 2012 19:00:03 GMT) Full text and rfc822 format available.

Message #29 received at 549309@bugs.debian.org (full text, mbox):

From: Gabriele Giacone <1o5g4r8o@gmail.com>
To: Alexey Eromenko <al4321@gmail.com>, 655841@bugs.debian.org
Cc: Christian PERRIER <bubulle@debian.org>, Michael Gilbert <michael.s.gilbert@gmail.com>, 549309@bugs.debian.org
Subject: Re: Bug#655841: Please remove Gnash from default Debian install, as it crashes
Date: Sat, 14 Jan 2012 19:56:55 +0100
browser-plugin-gnash from backports doesn't make konqueror crash anymore so
someone could identify what changes fix that and include them in 6.0.4. I'm
not sure to be able to do that and upstream is pretty dead especially about
KDE things. Patches welcome.

By the way on KDE I guess it should be more appropriate using
konqueror-plugin-gnash (KPARTS plugin) which is unmaintained upstream, missing
implementations, more failures. If it worked enough, it could be added to KDE
install. Feedbacks from KDE users welcome. Patches as well.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sat, 14 Jan 2012 23:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sune Vuorela <Sune@vuorela.dk>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sat, 14 Jan 2012 23:45:03 GMT) Full text and rfc822 format available.

Message #34 received at 549309@bugs.debian.org (full text, mbox):

From: Sune Vuorela <Sune@vuorela.dk>
To: debian-qt-kde@lists.debian.org, 549309@bugs.debian.org, debian-release@lists.debian.org
Cc: Alexey Eromenko <al4321@gmail.com>
Subject: Re: Bug#549309: Upcoming stable point release
Date: Sun, 15 Jan 2012 00:21:26 +0100
On Saturday 14 January 2012 12:18:19 Adam D. Barratt wrote:
> [added the KDE bug and -release to Cc]
> 
> Hi,
> 
> On Sat, 2012-01-14 at 09:18 +0200, Alexey Eromenko wrote:
> > Please, if possible, exclude "konqueror-nsplugins" from the default
> > KDE install in 6.0.4.

Afaik, there is no bugs in konqueror-nsplugins, so excluding it from the 
default install would be wrong.

Removing gnash from the default set of installed packages could be a option 
though until someone has isolated the fix in gnsah that Gabriele Giacone 
claims exists, given thaht gnash from backpotrs doesn't make konqueror-
nsplugins crash.

For those outside kde packaging following along:
konqueror-nsplugins contains the nspluginviewer application that khtml among 
others use to use nsplugins in a nice out-of-process fashion, a way of doing 
it that has been present since like forever and other browser vendors slowly 
are picking up.

/Sune
-- 
Man, do you know how can I do for installing on the RW LCD forward from 
Netscape 96?

You should turn off a controller for connecting a menu over the case over a 
SIMM.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sun, 15 Jan 2012 12:30:30 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sun, 15 Jan 2012 12:31:25 GMT) Full text and rfc822 format available.

Message #39 received at 549309@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Sune Vuorela <Sune@vuorela.dk>
Cc: debian-qt-kde@lists.debian.org, 549309@bugs.debian.org, debian-release@lists.debian.org, Alexey Eromenko <al4321@gmail.com>
Subject: Re: Bug#549309: Upcoming stable point release
Date: Sun, 15 Jan 2012 12:26:40 +0000
On Sun, 2012-01-15 at 00:21 +0100, Sune Vuorela wrote:
> Afaik, there is no bugs in konqueror-nsplugins, so excluding it from the 
> default install would be wrong.
> 
> Removing gnash from the default set of installed packages could be a option 
> though until someone has isolated the fix in gnsah that Gabriele Giacone 
> claims exists, given thaht gnash from backpotrs doesn't make konqueror-
> nsplugins crash.

We generally don't make task changes in stable, as they tend to affect
other things such as the composition of the installation media.  I'd be
quite loath to make such a change only to then have to revert it.

Regards,

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#549309; Package konqueror-nsplugins. (Sun, 15 Jan 2012 23:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alexey Eromenko <al4321@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Sun, 15 Jan 2012 23:15:03 GMT) Full text and rfc822 format available.

Message #44 received at 549309@bugs.debian.org (full text, mbox):

From: Alexey Eromenko <al4321@gmail.com>
To: "Adam D. Barratt" <adam@adam-barratt.org.uk>
Cc: Sune Vuorela <Sune@vuorela.dk>, debian-qt-kde@lists.debian.org, 549309@bugs.debian.org, debian-release@lists.debian.org
Subject: Re: Bug#549309: Upcoming stable point release
Date: Mon, 16 Jan 2012 01:10:57 +0200
Related Bugs:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655841
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655839

Most of the discussion is now ongoing here:
655841

>such as the composition of the installation media.

What problems can modified media cause ?

-- 
-Alexey Eromenko "Technologov"




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 23 14:31:28 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.