Debian Bug report logs - #545525
lenny: libpils{0, -dev} and libstonith{0, -dev} became uninstallable around September 3, 2009

Package: release.debian.org; Maintainer for release.debian.org is Debian Release Team <debian-release@lists.debian.org>;

Reported by: Ralf Treinen <treinen@debian.org>

Date: Mon, 7 Sep 2009 19:18:01 UTC

Severity: normal

Tags: lenny

Done: "Adam D. Barratt" <adam@adam-barratt.org.uk>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#545525; Package release.debian.org. (Mon, 07 Sep 2009 19:18:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ralf Treinen <treinen@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Mon, 07 Sep 2009 19:18:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Ralf Treinen <treinen@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: lenny: libpils{0, -dev} and libstonith{0, -dev} became uninstallable around September 3, 2009
Date: Mon, 07 Sep 2009 21:10:09 +0200
Package: release.debian.org
Severity: normal

Hello,

The following packages have become uninstallable in lenny on each 
release architecture. This was detected by edos.debian.net, the
packages were installable on Thu Sep 3 23:40:02 2009, and were
found uninstallable on the following run on Sat Sep 5 23:40:01 2009:

libpils-dev
2.1.3-6lenny4
Explanation: heartbeat-dev (= 2.1.3-6lenny4) conflicts with libpils-dev (= 2.1.3-6lenny4) libpils-dev (= 2.1.3-6lenny4) depends on heartbeat-dev (>= 2.1.3-6lenny4) {heartbeat-dev (= 2.1.3-6lenny4)}

libpils0
2.1.3-6lenny4
Explanation: libpils0 (= 2.1.3-6lenny4) depends on heartbeat (= 2.1.3-6lenny4) {heartbeat (= 2.1.3-6lenny4)} heartbeat (= 2.1.3-6lenny4) conflicts with libpils0 (= 2.1.3-6lenny4)

libstonith-dev
2.1.3-6lenny4
Explanation: heartbeat-dev (= 2.1.3-6lenny4) conflicts with libstonith-dev (= 2.1.3-6lenny4) libstonith-dev (= 2.1.3-6lenny4) depends on heartbeat-dev (>= 2.1.3-6lenny4) {heartbeat-dev (= 2.1.3-6lenny4)}

libstonith0
2.1.3-6lenny4
Explanation: heartbeat (= 2.1.3-6lenny4) conflicts with libstonith0 (= 2.1.3-6lenny4) libstonith0 (= 2.1.3-6lenny4) depends on heartbeat (= 2.1.3-6lenny4) {heartbeat (= 2.1.3-6lenny4)} 

See http://edos.debian.net/edos-debcheck/stable.php, for instance in
the column for i386 (the list of uninstallable packages was empty for
i386 before that incident).

-Ralf.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.utf8)
Shell: /bin/sh linked to /bin/bash




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#545525; Package release.debian.org. (Mon, 07 Sep 2009 19:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ralf Treinen <treinen@free.fr>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Mon, 07 Sep 2009 19:36:03 GMT) Full text and rfc822 format available.

Message #10 received at 545525@bugs.debian.org (full text, mbox):

From: Ralf Treinen <treinen@free.fr>
To: 545525@bugs.debian.org
Subject: newly uninstallable packages in lenny
Date: Mon, 7 Sep 2009 21:28:22 +0200
This bug also concerns proposed-updates. -Ralf.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#545525; Package release.debian.org. (Mon, 07 Sep 2009 20:12:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Mon, 07 Sep 2009 20:12:08 GMT) Full text and rfc822 format available.

Message #15 received at 545525@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Ralf Treinen <treinen@debian.org>, 545525@bugs.debian.org
Subject: Re: Bug#545525: lenny: libpils{0, -dev} and libstonith{0, -dev} became uninstallable around September 3, 2009
Date: Mon, 07 Sep 2009 21:10:27 +0100
On Mon, 2009-09-07 at 21:10 +0200, Ralf Treinen wrote:
> The following packages have become uninstallable in lenny on each 
> release architecture. This was detected by edos.debian.net, the
> packages were installable on Thu Sep 3 23:40:02 2009, and were
> found uninstallable on the following run on Sat Sep 5 23:40:01 2009:
> 
> libpils-dev
> 2.1.3-6lenny4
> Explanation: heartbeat-dev (= 2.1.3-6lenny4) conflicts with libpils-dev (= 2.1.3-6lenny4) libpils-dev (= 2.1.3-6lenny4) depends on heartbeat-dev (>= 2.1.3-6lenny4) {heartbeat-dev (= 2.1.3-6lenny4)}

[and others from the same source]

This was a side-effect of the fact that the -6lenny4 packages made the
packages in question virtual packages provided by heartbeat and
heartbeat-dev but also continued to ship them as binary packages.

See http://lists.debian.org/debian-release/2009/08/msg00087.html for the
discussion surrounding the upload (including a potential way of removing
the uninstallability).

Regards,

Adam




Added tag(s) lenny. Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Tue, 02 Nov 2010 14:06:11 GMT) Full text and rfc822 format available.

Reply sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
You have taken responsibility. (Tue, 13 Mar 2012 21:36:04 GMT) Full text and rfc822 format available.

Notification sent to Ralf Treinen <treinen@debian.org>:
Bug acknowledged by developer. (Tue, 13 Mar 2012 21:36:06 GMT) Full text and rfc822 format available.

Message #22 received at 545525-done@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: 545525-done@bugs.debian.org
Cc: 603569-done@bugs.debian.org
Subject: Closing outstanding lenny-related bugs
Date: Tue, 13 Mar 2012 21:32:44 +0000
Hi,

The EOL point release for lenny occurred recently, so these issues will
not be resolved.

Regards,

Adam





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 11 Apr 2012 07:38:04 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 14:27:37 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.