Debian Bug report logs - #545228
nvidia-kernel-legacy-96xx-source: does not build with 2.6.30-1-686

version graph

Package: nvidia-kernel-legacy-96xx-source; Maintainer for nvidia-kernel-legacy-96xx-source is Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>; Source for nvidia-kernel-legacy-96xx-source is src:nvidia-graphics-drivers-legacy-96xx.

Reported by: A Mennucc <mennucc1@debian.org>

Date: Sat, 5 Sep 2009 21:15:02 UTC

Severity: grave

Found in version nvidia-graphics-drivers-legacy-96xx/96.43.13-0.1

Fixed in version nvidia-graphics-drivers-legacy-96xx/96.43.16-1

Done: Randall Donald <rdonald@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sat, 05 Sep 2009 21:15:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to A Mennucc <mennucc1@debian.org>:
New Bug report received and forwarded. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sat, 05 Sep 2009 21:15:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: A Mennucc <mennucc1@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: nvidia-kernel-legacy-96xx-source: does not build with 2.6.30-1-686
Date: Sat, 5 Sep 2009 23:05:45 +0200
[Message part 1 (text/plain, inline)]
Package: nvidia-kernel-legacy-96xx-source
Version: 96.43.13-0.1
Severity: grave
Justification: renders package unusable

hi,

the source does not build with kernel 2.6.30-1-686 

I attach a typescript of the command 
#  m-a -t b-i nvidia-kernel-legacy-96xx

the most relevant errors are:
/usr/src/modules/nvidia-kernel-legacy-96xx/nv/nv-linux.h:534:2: error: #error "N
/usr/src/modules/nvidia-kernel-legacy-96xx/nv/nv-linux.h:607:2: error: #error "N
/usr/src/modules/nvidia-kernel-legacy-96xx/nv/nv-linux.h:627:2: error: #error "N
I

a.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-1-686 (SMP w/2 CPU cores)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

-- 
Andrea Mennucc
 "E' un mondo difficile. Che vita intensa!" (Tonino Carotone)
[typescript (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Fri, 02 Oct 2009 12:05:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Guilhem Bonnefille <guilhem.bonnefille@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Fri, 02 Oct 2009 12:05:10 GMT) Full text and rfc822 format available.

Message #10 received at 545228@bugs.debian.org (full text, mbox):

From: Guilhem Bonnefille <guilhem.bonnefille@gmail.com>
To: 545228@bugs.debian.org
Subject: Any news?
Date: Fri, 2 Oct 2009 13:54:44 +0200
Hi,

I encounter the same bug. Any news, workaround?
Someone needs help to solve this bug?

-- 
Guilhem BONNEFILLE
-=- JID: guyou@im.apinc.org MSN: guilhem_bonnefille@hotmail.com
-=- mailto:guilhem.bonnefille@gmail.com
-=- http://nathguil.free.fr/




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sun, 04 Oct 2009 09:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to A Mennucc <mennucc1@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 04 Oct 2009 09:15:03 GMT) Full text and rfc822 format available.

Message #15 received at 545228@bugs.debian.org (full text, mbox):

From: A Mennucc <mennucc1@debian.org>
To: 545228@bugs.debian.org
Subject: Re: Bug#545228: Acknowledgement (nvidia-kernel-legacy-96xx-source: does not build with 2.6.30-1-686 )
Date: Sun, 04 Oct 2009 10:47:07 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hi,

the upstream code (that is,
ftp://download.nvidia.com/XFree86/Linux-x86/96.43.13/
) compiles fine

the difference is AFAICT that the upstream code also runs a file
'conftest.sh' that sets some macros ; while debian/rules doesn't

the bad news is that the resulting code crashes :-(

a.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrIYQoACgkQ9B/tjjP8QKQ6qgCfRbCZqVDWiPl4QvCTWO7PRPsy
AkcAn3kW9I/gK7ODpdidk0mwiSYcRfsg
=BfFK
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sun, 04 Oct 2009 09:21:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to A Mennucc <mennucc1@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 04 Oct 2009 09:21:08 GMT) Full text and rfc822 format available.

Message #20 received at 545228@bugs.debian.org (full text, mbox):

From: A Mennucc <mennucc1@debian.org>
To: 545228@bugs.debian.org
Subject: log
Date: Sun, 04 Oct 2009 11:14:56 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I attach the X log , just in case

I also reported this bug into
http://www.nvnews.net/vbulletin/showthread.php?t=136680

a.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrIZ5AACgkQ9B/tjjP8QKQmSQCeK2teSdvPNUgIxgVrXjTXoLgM
tVkAoItBY3L6TdyF/2JapFg+r9Dp7q5U
=LQEL
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sun, 04 Oct 2009 09:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to A Mennucc <mennucc1@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 04 Oct 2009 09:24:03 GMT) Full text and rfc822 format available.

Message #25 received at 545228@bugs.debian.org (full text, mbox):

From: A Mennucc <mennucc1@debian.org>
To: 545228@bugs.debian.org
Subject: log
Date: Sun, 04 Oct 2009 11:16:03 +0200
[Message part 1 (text/plain, inline)]

[Xorg.0.log (text/x-log, inline)]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.3.901 (1.6.4 RC 1)
Release Date: 2009-8-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30.6-dsa-ia32 i686 Debian
Current Operating System: Linux frivolo 2.6.30-1-686 #1 SMP Sat Aug 15 19:11:58 UTC 2009 i686
Build Date: 14 September 2009  05:23:17PM
xorg-server 2:1.6.3.901-1 (buildd@murphy.debian.org) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct  4 10:34:12 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section.  Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Configured Monitor"
(==) No device specified for screen "Default Screen".
	Using the first device section listed.
(**) |   |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
	Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
	Entry deleted from font path.
(==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/75dpi,
	built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
	If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0xa40
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 5.0
	X.Org XInput driver : 4.0
	X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0171:0000:0000 nVidia Corporation NV17 [GeForce4 MX 440] rev 163, Mem @ 0xdf000000/16777216, 0xe8000000/134217728, 0xe7800000/524288, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) System resource ranges:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Server Extension
(II) NVIDIA GLX Module  96.43.13  Thu Jun 25 18:56:56 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.1.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  96.43.13  Thu Jun 25 18:45:26 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.6.3.901, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen" for depth/fbbpp 24/32
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.00.69.00
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 at PCI:1:0:0:
(--) NVIDIA(0):     SAMSUNG (CRT-0)
(--) NVIDIA(0): SAMSUNG (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): 
(WW) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(WW) NVIDIA(0):     will be used as the requested mode.
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(--) NVIDIA(0): DPI set to (55, 54); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GART.

Backtrace:
0: /usr/bin/X11/X(xorg_backtrace+0x3b) [0x81316cb]
1: /usr/bin/X11/X(xf86SigHandler+0x51) [0x80c1e01]
2: [0xb7fa6400]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sun, 04 Oct 2009 11:12:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to A Mennucc <mennucc1@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 04 Oct 2009 11:12:08 GMT) Full text and rfc822 format available.

Message #30 received at 545228@bugs.debian.org (full text, mbox):

From: A Mennucc <mennucc1@debian.org>
To: 545228@bugs.debian.org
Subject: reason, workaround
Date: Sun, 04 Oct 2009 12:52:51 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hi,

the problem is that module-assistant sets
  KSRC=/lib/modules/2.6.30-1-686/build
and then debian/rules calls the nvidia makefile nv/Makefile.kbuild by
  $(MAKE) SYSSRC=$(KSRC) ....
but instead if you call the upstream makefile directly,
it internally uses
  /lib/modules/2.6.30-1-686/source
in some variables; and currently those are different,
# ls -l /lib/modules/2.6.30-1-686
lrwxrwxrwx 1 root root     35 30 ago 19:39 build ->
/usr/src/linux-headers-2.6.30-1-686
lrwxrwxrwx 1 root root     38 25 ago 19:13 source ->
/usr/src/linux-headers-2.6.30-1-common

The workaround is
# cd /usr/src
# tar xzf nvidia-kernel-legacy-96xx-source.tar.gz
then edit debian/rules and delete all occurrences of SYSSRC=...
eventually
#  m-a -t  -O b-i  nvidia-kernel-legacy-96xx

this way, the NVidia nv/Makefile.kbuild will autodetect the kernel that
is currently installed, and set the variables as it likes, and it will
compile.

(This also means that "m-a -l another-kernel" will not work)

a.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrIfoMACgkQ9B/tjjP8QKRE0ACfTPDYnsPW+uLmnm1rMFAOKenJ
1yUAoIeC7OJvByeUhznzqEBh7cj/Ax02
=dOaG
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sun, 04 Oct 2009 20:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Guilhem BONNEFILLE <guilhem.bonnefille@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sun, 04 Oct 2009 20:12:03 GMT) Full text and rfc822 format available.

Message #35 received at 545228@bugs.debian.org (full text, mbox):

From: Guilhem BONNEFILLE <guilhem.bonnefille@gmail.com>
To: 545228@bugs.debian.org
Subject: Works but... missing libGL.so symbolic link
Date: Sun, 04 Oct 2009 22:01:46 +0200
[Message part 1 (text/plain, inline)]
Many thanks A Mennucc,

I applied succesfully your tips.

I just noticed that libGL.so is missing, while libGL.so.1 and
libGL.so.96.43.13 are installed.
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Sat, 10 Oct 2009 07:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to alex bodnaru <alexbodn@012.net.il>:
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Sat, 10 Oct 2009 07:42:04 GMT) Full text and rfc822 format available.

Message #40 received at 545228@bugs.debian.org (full text, mbox):

From: alex bodnaru <alexbodn@012.net.il>
To: Debian Bug Tracking System <545228@bugs.debian.org>
Subject: nvidia-kernel-legacy-96xx-source: fails with 2.6.30-2-686 either.
Date: Sat, 10 Oct 2009 09:26:01 +0200
Package: nvidia-kernel-legacy-96xx-source
Version: 96.43.13-0.1
Severity: normal

hello,

thanks a lot for bringing nvidia support into debian.
sorry we first communicate when things go wrong. no news is great news 
in bug reporting ;)
it seems, that some kernel changes occured since 
nvidia-kernel-legacy-96xx-source was packaged.

all the best,
alex

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (300, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages nvidia-kernel-legacy-96xx-source depends on:
ii  debhelper                     7.4.2      helper programs for debian/rules
ii  dpatch                        2.0.31     patch maintenance system for Debia
ii  make                          3.81-6     An utility for Directing compilati
ii  sed                           4.2.1-3    The GNU sed stream editor

Versions of packages nvidia-kernel-legacy-96xx-source recommends:
ii  devscripts                    2.10.55    scripts to make the life of a Debi
ii  kernel-package                12.021     A utility for building Linux kerne
pn  nvidia-glx-legacy-96xx        <none>     (no description available)

nvidia-kernel-legacy-96xx-source suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Thu, 29 Oct 2009 01:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to lsorense@csclub.uwaterloo.ca (Lennart Sorensen):
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 29 Oct 2009 01:18:03 GMT) Full text and rfc822 format available.

Message #45 received at 545228@bugs.debian.org (full text, mbox):

From: lsorense@csclub.uwaterloo.ca (Lennart Sorensen)
To: A Mennucc <mennucc1@debian.org>, 545228@bugs.debian.org
Subject: Re: [pkg-nvidia-devel] Bug#545228: reason, workaround
Date: Wed, 28 Oct 2009 12:05:49 -0400
On Sun, Oct 04, 2009 at 12:52:51PM +0200, A Mennucc wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> hi,
> 
> the problem is that module-assistant sets
>   KSRC=/lib/modules/2.6.30-1-686/build
> and then debian/rules calls the nvidia makefile nv/Makefile.kbuild by
>   $(MAKE) SYSSRC=$(KSRC) ....
> but instead if you call the upstream makefile directly,
> it internally uses
>   /lib/modules/2.6.30-1-686/source
> in some variables; and currently those are different,
> # ls -l /lib/modules/2.6.30-1-686
> lrwxrwxrwx 1 root root     35 30 ago 19:39 build ->
> /usr/src/linux-headers-2.6.30-1-686
> lrwxrwxrwx 1 root root     38 25 ago 19:13 source ->
> /usr/src/linux-headers-2.6.30-1-common
> 
> The workaround is
> # cd /usr/src
> # tar xzf nvidia-kernel-legacy-96xx-source.tar.gz
> then edit debian/rules and delete all occurrences of SYSSRC=...
> eventually
> #  m-a -t  -O b-i  nvidia-kernel-legacy-96xx
> 
> this way, the NVidia nv/Makefile.kbuild will autodetect the kernel that
> is currently installed, and set the variables as it likes, and it will
> compile.
> 
> (This also means that "m-a -l another-kernel" will not work)

Current version of 96xx should work now I believe.

-- 
Len Sorensen




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Thu, 29 Oct 2009 01:21:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to lsorense@csclub.uwaterloo.ca (Lennart Sorensen):
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 29 Oct 2009 01:21:04 GMT) Full text and rfc822 format available.

Message #50 received at 545228@bugs.debian.org (full text, mbox):

From: lsorense@csclub.uwaterloo.ca (Lennart Sorensen)
To: A Mennucc <mennucc1@debian.org>, 545228@bugs.debian.org
Subject: Re: [pkg-nvidia-devel] Bug#545228: Acknowledgement (nvidia-kernel-legacy-96xx-source: does not build with 2.6.30-1-686 )
Date: Wed, 28 Oct 2009 12:07:05 -0400
On Sun, Oct 04, 2009 at 10:47:07AM +0200, A Mennucc wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> hi,
> 
> the upstream code (that is,
> ftp://download.nvidia.com/XFree86/Linux-x86/96.43.13/
> ) compiles fine
> 
> the difference is AFAICT that the upstream code also runs a file
> 'conftest.sh' that sets some macros ; while debian/rules doesn't
> 
> the bad news is that the resulting code crashes :-(

Upstream conftest.sh doesn't work with debian kernel headers as of 2.6.29.
The debian package does (although only in the latest 96xx).

conftest.sh is a horrible idea, which is why we don't use it anymore.

-- 
Len Sorensen




Information forwarded to debian-bugs-dist@lists.debian.org, Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>:
Bug#545228; Package nvidia-kernel-legacy-96xx-source. (Thu, 29 Oct 2009 07:15:19 GMT) Full text and rfc822 format available.

Acknowledgement sent to lsorense@csclub.uwaterloo.ca (Lennart Sorensen):
Extra info received and forwarded to list. Copy sent to Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>. (Thu, 29 Oct 2009 07:15:20 GMT) Full text and rfc822 format available.

Message #55 received at 545228@bugs.debian.org (full text, mbox):

From: lsorense@csclub.uwaterloo.ca (Lennart Sorensen)
To: alex bodnaru <alexbodn@012.net.il>, 545228@bugs.debian.org
Subject: Re: [pkg-nvidia-devel] Bug#545228: nvidia-kernel-legacy-96xx-source: fails with 2.6.30-2-686 either.
Date: Wed, 28 Oct 2009 11:56:36 -0400
On Sat, Oct 10, 2009 at 09:26:01AM +0200, alex bodnaru wrote:
> Package: nvidia-kernel-legacy-96xx-source
> Version: 96.43.13-0.1
> Severity: normal
> 
> hello,
> 
> thanks a lot for bringing nvidia support into debian.
> sorry we first communicate when things go wrong. no news is great news 
> in bug reporting ;)
> it seems, that some kernel changes occured since 
> nvidia-kernel-legacy-96xx-source was packaged.

I suspect the current version of 96xx works now.  The NMU didn't deal
with the 2.6.29+ issues properly.  The current version should I believe.

-- 
Len Sorensen




Reply sent to Randall Donald <rdonald@debian.org>:
You have taken responsibility. (Wed, 17 Mar 2010 04:51:05 GMT) Full text and rfc822 format available.

Notification sent to A Mennucc <mennucc1@debian.org>:
Bug acknowledged by developer. (Wed, 17 Mar 2010 04:51:06 GMT) Full text and rfc822 format available.

Message #60 received at 545228-close@bugs.debian.org (full text, mbox):

From: Randall Donald <rdonald@debian.org>
To: 545228-close@bugs.debian.org
Subject: Bug#545228: fixed in nvidia-graphics-drivers-legacy-96xx 96.43.16-1
Date: Wed, 17 Mar 2010 04:47:51 +0000
Source: nvidia-graphics-drivers-legacy-96xx
Source-Version: 96.43.16-1

We believe that the bug you reported is fixed in the latest version of
nvidia-graphics-drivers-legacy-96xx, which is due to be installed in the Debian FTP archive:

nvidia-glx-legacy-96xx-dev_96.43.16-1_amd64.deb
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-glx-legacy-96xx-dev_96.43.16-1_amd64.deb
nvidia-glx-legacy-96xx-ia32_96.43.16-1_amd64.deb
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-glx-legacy-96xx-ia32_96.43.16-1_amd64.deb
nvidia-glx-legacy-96xx_96.43.16-1_amd64.deb
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-glx-legacy-96xx_96.43.16-1_amd64.deb
nvidia-graphics-drivers-legacy-96xx_96.43.16-1.diff.gz
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-graphics-drivers-legacy-96xx_96.43.16-1.diff.gz
nvidia-graphics-drivers-legacy-96xx_96.43.16-1.dsc
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-graphics-drivers-legacy-96xx_96.43.16-1.dsc
nvidia-graphics-drivers-legacy-96xx_96.43.16.orig.tar.gz
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-graphics-drivers-legacy-96xx_96.43.16.orig.tar.gz
nvidia-kernel-legacy-96xx-source_96.43.16-1_amd64.deb
  to non-free/n/nvidia-graphics-drivers-legacy-96xx/nvidia-kernel-legacy-96xx-source_96.43.16-1_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 545228@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Randall Donald <rdonald@debian.org> (supplier of updated nvidia-graphics-drivers-legacy-96xx package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 16 Mar 2010 20:21:46 -0700
Source: nvidia-graphics-drivers-legacy-96xx
Binary: nvidia-glx-legacy-96xx-ia32 nvidia-glx-legacy-96xx nvidia-glx-legacy-96xx-dev nvidia-kernel-legacy-96xx-source
Architecture: source amd64
Version: 96.43.16-1
Distribution: unstable
Urgency: low
Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Changed-By: Randall Donald <rdonald@debian.org>
Description: 
 nvidia-glx-legacy-96xx - NVIDIA binary Xorg driver (96xx legacy version)
 nvidia-glx-legacy-96xx-dev - NVIDIA Xorg driver development files (96xx legacy version)
 nvidia-glx-legacy-96xx-ia32 - NVIDIA binary Xorg driver (96xx legacy version)
 nvidia-kernel-legacy-96xx-source - NVIDIA binary kernel module source (96xx legacy version)
Closes: 534131 545228
Changes: 
 nvidia-graphics-drivers-legacy-96xx (96.43.16-1) unstable; urgency=low
 .
   * new upstream (closes:  #534131, #545228)
Checksums-Sha1: 
 d95dc5f455c1af3f3373a6e6d671780c4c427539 1373 nvidia-graphics-drivers-legacy-96xx_96.43.16-1.dsc
 a1bdfd4962c349cfaaf091b62166c9db69383dfc 20231093 nvidia-graphics-drivers-legacy-96xx_96.43.16.orig.tar.gz
 f004e8e8caf624ed74bc3179e97d5732db80b2c4 91260 nvidia-graphics-drivers-legacy-96xx_96.43.16-1.diff.gz
 0d6e5128482640d76a58900706615fa379ec7e0c 2811116 nvidia-glx-legacy-96xx-ia32_96.43.16-1_amd64.deb
 773552d9a4a209298190cad88a3c5ccb0e053804 6519776 nvidia-glx-legacy-96xx_96.43.16-1_amd64.deb
 60722ea7916f6ef80c203e693065a945cb6215a1 169532 nvidia-glx-legacy-96xx-dev_96.43.16-1_amd64.deb
 1662587bb62ef304c44ae36f8026f21b2404ecf2 4926484 nvidia-kernel-legacy-96xx-source_96.43.16-1_amd64.deb
Checksums-Sha256: 
 e7a2ba1af763e52bd25d217b7d58099c923babff3b89b30463c3103885aaee75 1373 nvidia-graphics-drivers-legacy-96xx_96.43.16-1.dsc
 c6b2f5ab2cf6eb8f87341c10f0e1b90be6f9b9b72cb5938e40b138ef031b1527 20231093 nvidia-graphics-drivers-legacy-96xx_96.43.16.orig.tar.gz
 f090592a13c8ad0811d8ce2252261c019490cbb57fdacfbf663d08baa945b3a8 91260 nvidia-graphics-drivers-legacy-96xx_96.43.16-1.diff.gz
 5528a13d344e4c9b39953303be8dc9328aa4217fd22cc00c6aa38d3683dec09b 2811116 nvidia-glx-legacy-96xx-ia32_96.43.16-1_amd64.deb
 ea1ff4da3582a8eceb05a74e970315f29a391048e12e66bf4025f53dc9ffaaf6 6519776 nvidia-glx-legacy-96xx_96.43.16-1_amd64.deb
 9461ef1d2cdf6c904da416945b53cc9fd2dfdbd5d8c308ab36e285864847bc93 169532 nvidia-glx-legacy-96xx-dev_96.43.16-1_amd64.deb
 5234e5c03925fc3db73dc144583441f6c2d95f42d54932bbe20e2f46d191aa18 4926484 nvidia-kernel-legacy-96xx-source_96.43.16-1_amd64.deb
Files: 
 78a188089c901012094265445fc5ba0c 1373 non-free/x11 optional nvidia-graphics-drivers-legacy-96xx_96.43.16-1.dsc
 fe7e3e13f46a9bee94800216e1009156 20231093 non-free/x11 optional nvidia-graphics-drivers-legacy-96xx_96.43.16.orig.tar.gz
 59e05448ba817a1a556876987a78e1a0 91260 non-free/x11 optional nvidia-graphics-drivers-legacy-96xx_96.43.16-1.diff.gz
 64f7985e3695a8b420a63298e99178a0 2811116 non-free/x11 optional nvidia-glx-legacy-96xx-ia32_96.43.16-1_amd64.deb
 f45f7221181df0a553eb90289dcdc1dc 6519776 non-free/x11 optional nvidia-glx-legacy-96xx_96.43.16-1_amd64.deb
 3464f7ac8ac8a8bb877c51cf036b6140 169532 non-free/x11 optional nvidia-glx-legacy-96xx-dev_96.43.16-1_amd64.deb
 551efce8d242a81680efe1a04de1e14a 4926484 non-free/x11 optional nvidia-kernel-legacy-96xx-source_96.43.16-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iD8DBQFLoFPYU+6HYGwn3qsRAoOUAJ9l8M2utYuA757m9d4m6+dAMoEeXQCfaFvm
zCObRdtQ4nmiLlEYQiGoJ8Q=
=MEh5
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 14 Apr 2010 07:34:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 00:19:40 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.