Debian Bug report logs - #543360
fails to install, trying to overwrite other packages files

version graph

Package: libg15render-dev; Maintainer for libg15render-dev is Giacomo Catenazzi <cate@debian.org>; Source for libg15render-dev is src:libg15render.

Reported by: Holger Levsen <holger@layer-acht.org>

Date: Mon, 24 Aug 2009 14:06:07 UTC

Severity: serious

Found in version libg15render/1.3.0~svn316-2

Fixed in version libg15render/1.3.0~svn316-2.1

Done: gregor herrmann <gregoa@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Giacomo Catenazzi <cate@debian.org>:
Bug#543360; Package libg15render-dev. (Mon, 24 Aug 2009 14:06:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Holger Levsen <holger@layer-acht.org>:
New Bug report received and forwarded. Copy sent to Giacomo Catenazzi <cate@debian.org>. (Mon, 24 Aug 2009 14:06:11 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Holger Levsen <holger@layer-acht.org>
To: submit@bugs.debian.org
Subject: fails to install, trying to overwrite other packages files
Date: Mon, 24 Aug 2009 15:43:06 +0200
[Message part 1 (text/plain, inline)]
Package: libg15render-dev
Version: 1.3.0~svn316-2
Severity: serious
User: debian-qa@lists.debian.org
Usertags: piuparts piuparts.d.o

Hi, 

during a test with piuparts I noticed your package failed to install because 
it tries to overwrite other packages files without declaring a replaces 
relation.

See policy 7.6 at 
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

From the attached log (scroll to the bottom...):

  Unpacking replacement libg15render-dev ...
  dpkg: error 
processing /var/cache/apt/archives/libg15render-dev_1.3.0~svn316-2_amd64.deb 
(--unpack):
   trying to overwrite `/usr/share/man/man3/libg15render.3.gz', which is also 
in package libg15render1
  Preparing to replace libg15render1 1.2.0.svn250-2 
(using .../libg15render1_1.3.0~svn316-2_amd64.deb) ...
  Unpacking replacement libg15render1 ...
  Errors were encountered while processing:
   /var/cache/apt/archives/libg15render-dev_1.3.0~svn316-2_amd64.deb
  E: Sub-process /usr/bin/dpkg returned an error code (1)


regards,
	Holger
[libg15render-dev_1.3.0~svn316-2.log (text/x-log, attachment)]
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Giacomo Catenazzi <cate@debian.org>:
Bug#543360; Package libg15render-dev. (Sat, 28 Nov 2009 19:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Giacomo Catenazzi <cate@debian.org>. (Sat, 28 Nov 2009 19:48:03 GMT) Full text and rfc822 format available.

Message #10 received at 543360@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: 543360@bugs.debian.org
Subject: libg15render: diff for NMU version 1.3.0~svn316-2.1
Date: Sat, 28 Nov 2009 20:39:55 +0100
[Message part 1 (text/plain, inline)]
Dear maintainer,

I've uploaded an NMU for libg15render (versioned as 1.3.0~svn316-2.1). The diff
is attached to this message.

Cheers,
gregor, from th Munich BSP
-- 
 .''`.   http://info.comodo.priv.at/ -- GPG Key IDs: 0x00F3CFE4, 0x8649AA06
 : :' :  Debian GNU/Linux user, admin, & developer - http://www.debian.org/
 `. `'   Member of VIBE!AT, SPI Inc., fellow of FSFE | http://got.to/quote/
   `-    BOFH excuse #351:  PEBKAC (Problem Exists Between Keyboard And Chair) 
[libg15render-1.3.0~svn316-2.1-nmu.diff (text/x-diff, attachment)]
[signature.asc (application/pgp-signature, inline)]

Reply sent to gregor herrmann <gregoa@debian.org>:
You have taken responsibility. (Sat, 28 Nov 2009 19:51:03 GMT) Full text and rfc822 format available.

Notification sent to Holger Levsen <holger@layer-acht.org>:
Bug acknowledged by developer. (Sat, 28 Nov 2009 19:51:04 GMT) Full text and rfc822 format available.

Message #15 received at 543360-close@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: 543360-close@bugs.debian.org
Subject: Bug#543360: fixed in libg15render 1.3.0~svn316-2.1
Date: Sat, 28 Nov 2009 19:47:12 +0000
Source: libg15render
Source-Version: 1.3.0~svn316-2.1

We believe that the bug you reported is fixed in the latest version of
libg15render, which is due to be installed in the Debian FTP archive:

libg15render-dev_1.3.0~svn316-2.1_i386.deb
  to main/libg/libg15render/libg15render-dev_1.3.0~svn316-2.1_i386.deb
libg15render1_1.3.0~svn316-2.1_i386.deb
  to main/libg/libg15render/libg15render1_1.3.0~svn316-2.1_i386.deb
libg15render_1.3.0~svn316-2.1.diff.gz
  to main/libg/libg15render/libg15render_1.3.0~svn316-2.1.diff.gz
libg15render_1.3.0~svn316-2.1.dsc
  to main/libg/libg15render/libg15render_1.3.0~svn316-2.1.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 543360@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
gregor herrmann <gregoa@debian.org> (supplier of updated libg15render package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 28 Nov 2009 20:34:18 +0100
Source: libg15render
Binary: libg15render1 libg15render-dev
Architecture: source i386
Version: 1.3.0~svn316-2.1
Distribution: unstable
Urgency: low
Maintainer: Giacomo Catenazzi <cate@debian.org>
Changed-By: gregor herrmann <gregoa@debian.org>
Description: 
 libg15render-dev - Library for interfacing with the Logitech G15 keyboards
 libg15render1 - Library for interfacing with the Logitech G15 keyboards
Closes: 543360
Changes: 
 libg15render (1.3.0~svn316-2.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Fix "fails to install, trying to overwrite other packages files"
     by adding a Replaces (closes: #543360).
   * debian/rules: s/rf/rm/.
Checksums-Sha1: 
 5abedf2726becc65ee47c3d642ff2483bc57e201 1819 libg15render_1.3.0~svn316-2.1.dsc
 282b0cc59b33949c022637b080eaa27c0116e99c 2147 libg15render_1.3.0~svn316-2.1.diff.gz
 7c4acde87ee2f1fdbd25b02b92a0c6203ee24e9c 132998 libg15render1_1.3.0~svn316-2.1_i386.deb
 7c7e5d08f9b91729f3c22a1ed434ce9a13ec57ae 20862 libg15render-dev_1.3.0~svn316-2.1_i386.deb
Checksums-Sha256: 
 1975e79fb4444024909329c51d585c06712fb0f421dfaf5f46ca582c01eac5ef 1819 libg15render_1.3.0~svn316-2.1.dsc
 1e8a3fee911dd602f98108da6939d4811349e2e5035104d2669f2bd36f1e8105 2147 libg15render_1.3.0~svn316-2.1.diff.gz
 a863d72d8f50de849cc5d466697cf1cf07403c3cdd87316dd8e4f3fd839f7657 132998 libg15render1_1.3.0~svn316-2.1_i386.deb
 06bd829264c15a5a92523c12a3f80f82fcf788926d2aa7ef967f74acedce9a86 20862 libg15render-dev_1.3.0~svn316-2.1_i386.deb
Files: 
 b8603109a3c7747b8dbd8ca6c2ba83eb 1819 libs optional libg15render_1.3.0~svn316-2.1.dsc
 b5fc1c52431f27c26ed217c683698edc 2147 libs optional libg15render_1.3.0~svn316-2.1.diff.gz
 9b60a9841737350558384360827194b0 132998 libs optional libg15render1_1.3.0~svn316-2.1_i386.deb
 8d46c394ab9a939117aa684753fbf821 20862 libdevel optional libg15render-dev_1.3.0~svn316-2.1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJLEXwuAAoJELs6aAGGSaoG/7kP/1x2ZYRfaiKWFPtXM0h1QTXp
Pax6z9myZ8JsDhdNyjbqxjN+TJBI41oTeRdsP8U1k4lRC5a4g1+OrzdODZF2erAr
2xO5r/9ix/Zdp2gjupVGn5f1ZOPiQYsSa9lE2KTL/ygx0/ZIGFbuF1+UvugW9yEh
S8BQloaONH87K21YrxPcoGi1Eum253zrLSZkg+1hWmFa94zGlY9KTIaOVm/wgC7D
/TLeIPcCY8Dz7rAO0I4VI0/+Ej5C5K6kdWVwD2dC2/AwdEhMJo9e5iLmwHwvnWQu
29Kv8OdTRtqlKcIiyMueE+i7d5GfX0O6Xn8F9dt2xo1oEz6iLnd1QgW1FDJw7R+/
3nyzGqydwutzqBw0eQ2jMPiuLTfRzlTPWVl6jIBaCIQl/A/O+MZdA8wLiFNEYBUn
m+zERzYmCBcE5HrMxPtqN29wpCwJyaKdopXnwWxhGjmJiauynI/EuOTePo3kf43B
mLGWFKUGa//615rQfku7oHpuMIweTn3DMzG0hnzwgZgaGaqPWTVMWtUsPSONRgMl
bIiVF4HHWDR7PiUeqFNCwCKIUnXGgphyRdSt4qi+0H7ixchZchah6QA24SKOuqBJ
AJiluvY+FajKgpoPvZ9zmTd5TRNGK9hWQ9AmEl1HPByLnQsG5qcTeCEJWsLe+DEt
wkxfP+DGBWtE5mb6Y7lQ
=SyTO
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 04 Jan 2010 07:45:40 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 10:39:31 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.