Debian Bug report logs - #539141
earcandy: Please depend on python-wnck

version graph

Package: earcandy; Maintainer for earcandy is Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>;

Reported by: Libor Klepáč <libor.klepac@bcom.cz>

Date: Wed, 29 Jul 2009 11:24:01 UTC

Severity: grave

Tags: patch

Found in version earcandy/0.5-1

Fixed in version earcandy/0.5-1.1

Done: Martijn van Brummelen <martijn@brumit.nl>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Andrea Colangelo <warp10@ubuntu.com>:
Bug#539141; Package earcandy. (Wed, 29 Jul 2009 11:24:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Libor Klepáč <libor.klepac@bcom.cz>:
New Bug report received and forwarded. Copy sent to Andrea Colangelo <warp10@ubuntu.com>. (Wed, 29 Jul 2009 11:24:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Libor Klepáč <libor.klepac@bcom.cz>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: earcandy: Please depend on python-wnck
Date: Wed, 29 Jul 2009 13:10:45 +0200
Package: earcandy
Version: 0.5-1
Severity: grave
Justification: renders package unusable

Hi,
i have installed this package, but it doesn't run until I installed package python-wnck.

----
~:earcandy                                                        
Traceback (most recent call last):                                                         
  File "/usr/bin/earcandy", line 17, in <module>                                           
    import ear_candy                                                                       
  File "/usr/share/earcandy/ear_candy/ear_candy.py", line 20, in <module>                  
    import wnck                                                                            
ImportError: No module named wnck
----

Please depend on it

With regards
Libor


-- System Information:
Debian Release: squeeze/sid
  APT prefers experimental
  APT policy: (700, 'experimental'), (700, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=cs_CZ.UTF-8, LC_CTYPE=cs_CZ.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages earcandy depends on:
ii  puls 0.9.16~test2~20090726git59659e1db-1 PulseAudio sound server
ii  pyth 2.5.4-3                             An interactive high-level object-o
ii  pyth 0.83.0-1                            simple interprocess messaging syst
ii  pyth 2.14.1-3                            GTK+ bindings: Glade support
ii  pyth 0.1.1-2+b1                          Python bindings for libnotify
ii  pyth 1.0.3                               automated rebuilding support for P

earcandy recommends no packages.

earcandy suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Andrea Colangelo <warp10@ubuntu.com>:
Bug#539141; Package earcandy. (Sun, 18 Oct 2009 19:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "M. van Brummelen" <martijn@brumit.nl>:
Extra info received and forwarded to list. Copy sent to Andrea Colangelo <warp10@ubuntu.com>. (Sun, 18 Oct 2009 19:54:03 GMT) Full text and rfc822 format available.

Message #10 received at 539141@bugs.debian.org (full text, mbox):

From: "M. van Brummelen" <martijn@brumit.nl>
To: 539141@bugs.debian.org
Subject: earcandy: Please depend on python-wnck
Date: Sun, 18 Oct 2009 21:47:52 +0200
[Message part 1 (text/plain, inline)]
Hi,

I added python-wnck to the control file so now the package depends on
this. After that I build the package with pbuilder environment with
pdebuild. I have added the diff like suggested
(debdiff earcandy_0.5-1.dsc earcandy_0.5-1.1.dsc >
earcandy_0.5-1.1.dsc.diff)
I also fixed a small lintian warning "out-of-date-standard-edition"


Regards,
Martijn van Brummelen


[earcandy_0.5-1.1.dsc.diff (text/x-patch, inline)]
diff -u earcandy-0.5/debian/changelog earcandy-0.5/debian/changelog
--- earcandy-0.5/debian/changelog
+++ earcandy-0.5/debian/changelog
@@ -1,3 +1,11 @@
+earcandy (0.5-1.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * fixed lintian issue "out-of-date-standards-version"
+  * Changed control-file, added python-wnck to Depend option (Closes: #539141)
+
+ -- Martijn van Brummelen <martijn@brumit.nl>  Sun, 18 Oct 2009 20:14:22 +0200
+
 earcandy (0.5-1) unstable; urgency=low
 
   * Initial release (Closes: #530330)
diff -u earcandy-0.5/debian/control earcandy-0.5/debian/control
--- earcandy-0.5/debian/control
+++ earcandy-0.5/debian/control
@@ -5,12 +5,12 @@
 Build-Depends: debhelper (>= 7.0.50)
 Build-Depends-Indep: python (>= 2.5), python-support (>= 0.5.3)
 XS-Python-Version: all
-Standards-Version: 3.8.1
+Standards-Version: 3.8.3
 Homepage: https://launchpad.net/earcandy
 
 Package: earcandy
 Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-glade2, python-dbus, python-notify, pulseaudio
+Depends: ${python:Depends}, ${misc:Depends}, python-glade2, python-dbus, python-notify, pulseaudio, python-wnck
 Description: Sound level manager for PulseAudio
  A sound level manager that nicely fades applications in and out based on their
  profile and window focus. It controls PulseAudio in order to create a seamless


[signature.asc (application/pgp-signature, attachment)]

Added tag(s) patch. Request was from Martijn van Brummelen <martijn@brumit.nl> to control@bugs.debian.org. (Sun, 18 Oct 2009 19:54:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Andrea Colangelo <warp10@ubuntu.com>:
Bug#539141; Package earcandy. (Fri, 06 Nov 2009 09:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "M. van Brummelen" <martijn@brumit.nl>:
Extra info received and forwarded to list. Copy sent to Andrea Colangelo <warp10@ubuntu.com>. (Fri, 06 Nov 2009 09:15:03 GMT) Full text and rfc822 format available.

Message #17 received at 539141@bugs.debian.org (full text, mbox):

From: "M. van Brummelen" <martijn@brumit.nl>
To: debian-mentors@lists.debian.org
Cc: 539141@bugs.debian.org
Subject: RFS: earcandy (updated package)
Date: Fri, 6 Nov 2009 10:05:08 +0100 (CET)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dear mentors,

I am looking for a sponsor for the new version 0.5-1.1
of my package "earcandy".

It builds these binary packages:
earcandy   - Sound level manager for PulseAudio

The package appears to be lintian clean.

The upload would fix the grave bug: 539141

The package can be found on mentors.debian.net:
- - - - URL: http://mentors.debian.net/debian/pool/main/e/earcandy
- - - - Source repository: deb-src http://mentors.debian.net/debian
unstable
main contrib non-free
- - - - dget
http://mentors.debian.net/debian/pool/main/e/earcandy/earcandy_0.5-1.1.dsc

I would be glad if someone uploaded this package for me.

Kind regards
Martijn van Brummelen

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Use GnuPG with Firefox : http://getfiregpg.org (Version: 0.7.9)

iEYEARECAAYFAkrz5n0ACgkQ4yGTtsQpvi/QFQCeP9QNUysT1VekpgVM4W4wr2ej
pNYAn0wVf7Ajw/MOgzm8drk7Rjd9LHo5
=OcFy
-----END PGP SIGNATURE-----






Information forwarded to debian-bugs-dist@lists.debian.org, Andrea Colangelo <warp10@ubuntu.com>:
Bug#539141; Package earcandy. (Mon, 09 Nov 2009 10:39:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to "M. van Brummelen" <martijn@brumit.nl>:
Extra info received and forwarded to list. Copy sent to Andrea Colangelo <warp10@ubuntu.com>. (Mon, 09 Nov 2009 10:39:02 GMT) Full text and rfc822 format available.

Message #22 received at 539141@bugs.debian.org (full text, mbox):

From: "M. van Brummelen" <martijn@brumit.nl>
To: 539141@bugs.debian.org
Subject: MInor change (new patch)
Date: Mon, 09 Nov 2009 11:26:00 +0100
[Message part 1 (text/plain, inline)]
Hi,

Made a minor change to the changelog like suggested on the mailinglist.

Regards,
Martijn van Brummelen
[earcandy_0.5-1.1.dsc.diff (text/x-patch, inline)]
diff -u earcandy-0.5/debian/changelog earcandy-0.5/debian/changelog
--- earcandy-0.5/debian/changelog
+++ earcandy-0.5/debian/changelog
@@ -1,3 +1,10 @@
+earcandy (0.5-1.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Added python-wnck as a dependency. (Closes: #539141)
+
+ -- Martijn van Brummelen <martijn@brumit.nl>  Mon, 09 Nov 2009 11:18:32 +0100
+
 earcandy (0.5-1) unstable; urgency=low
 
   * Initial release (Closes: #530330)
diff -u earcandy-0.5/debian/control earcandy-0.5/debian/control
--- earcandy-0.5/debian/control
+++ earcandy-0.5/debian/control
@@ -5,12 +5,12 @@
 Build-Depends: debhelper (>= 7.0.50)
 Build-Depends-Indep: python (>= 2.5), python-support (>= 0.5.3)
 XS-Python-Version: all
-Standards-Version: 3.8.1
+Standards-Version: 3.8.3
 Homepage: https://launchpad.net/earcandy
 
 Package: earcandy
 Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-glade2, python-dbus, python-notify, pulseaudio
+Depends: ${python:Depends}, ${misc:Depends}, python-glade2, python-dbus, python-notify, pulseaudio, python-wnck
 Description: Sound level manager for PulseAudio
  A sound level manager that nicely fades applications in and out based on their
  profile and window focus. It controls PulseAudio in order to create a seamless
[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Andrea Colangelo <warp10@ubuntu.com>:
Bug#539141; Package earcandy. (Tue, 10 Nov 2009 13:33:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to "M. van Brummelen" <martijn@brumit.nl>:
Extra info received and forwarded to list. Copy sent to Andrea Colangelo <warp10@ubuntu.com>. (Tue, 10 Nov 2009 13:33:09 GMT) Full text and rfc822 format available.

Message #27 received at 539141@bugs.debian.org (full text, mbox):

From: "M. van Brummelen" <martijn@brumit.nl>
To: 539141@bugs.debian.org
Subject: Small change
Date: Tue, 10 Nov 2009 14:27:26 +0100 (CET)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I forgot to change the Standards-Version from 3.8.3 to 3.8.1.
It was my fault. It should be ok now.

Regards,
Martijn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Use GnuPG with Firefox : http://getfiregpg.org (Version: 0.7.9)

iEYEARECAAYFAkr5ajQACgkQ4yGTtsQpvi8T5ACbBEtSTW/Xa3caa82N+wmVqqd5
2PUAoIh6QeEC7rqgD0e8tHjQ4rGLMw0C
=XJAZ
-----END PGP SIGNATURE-----






Reply sent to Martijn van Brummelen <martijn@brumit.nl>:
You have taken responsibility. (Tue, 10 Nov 2009 15:18:31 GMT) Full text and rfc822 format available.

Notification sent to Libor Klepáč <libor.klepac@bcom.cz>:
Bug acknowledged by developer. (Tue, 10 Nov 2009 15:18:31 GMT) Full text and rfc822 format available.

Message #32 received at 539141-close@bugs.debian.org (full text, mbox):

From: Martijn van Brummelen <martijn@brumit.nl>
To: 539141-close@bugs.debian.org
Subject: Bug#539141: fixed in earcandy 0.5-1.1
Date: Tue, 10 Nov 2009 15:17:55 +0000
Source: earcandy
Source-Version: 0.5-1.1

We believe that the bug you reported is fixed in the latest version of
earcandy, which is due to be installed in the Debian FTP archive:

earcandy_0.5-1.1.diff.gz
  to main/e/earcandy/earcandy_0.5-1.1.diff.gz
earcandy_0.5-1.1.dsc
  to main/e/earcandy/earcandy_0.5-1.1.dsc
earcandy_0.5-1.1_all.deb
  to main/e/earcandy/earcandy_0.5-1.1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 539141@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Martijn van Brummelen <martijn@brumit.nl> (supplier of updated earcandy package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 09 Nov 2009 11:18:32 +0100
Source: earcandy
Binary: earcandy
Architecture: source all
Version: 0.5-1.1
Distribution: unstable
Urgency: low
Maintainer: Andrea Colangelo <warp10@ubuntu.com>
Changed-By: Martijn van Brummelen <martijn@brumit.nl>
Description: 
 earcandy   - Sound level manager for PulseAudio
Closes: 539141
Changes: 
 earcandy (0.5-1.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Added python-wnck as a dependency. (Closes: #539141)
Checksums-Sha1: 
 74824255de78d90ce04afdfc1c83a7b9289beac4 1074 earcandy_0.5-1.1.dsc
 0eaca6bff2088802350682e8e0554a60d6acac5c 3964 earcandy_0.5-1.1.diff.gz
 cce60447aaa6761856b643d859729e3cf59da58e 46486 earcandy_0.5-1.1_all.deb
Checksums-Sha256: 
 3992fc4014b3e78a437c0f95f964180ceebd99ae2ef27881afc92b1ae6709ef7 1074 earcandy_0.5-1.1.dsc
 6342fdf96864bed2b72322f4d7cf526c0928231c144184a69dbc015b18c0f2f8 3964 earcandy_0.5-1.1.diff.gz
 8fb9557f1af0e46165a24ce06e82ab9dc0523f6db9157f8fefb350eed66f41b4 46486 earcandy_0.5-1.1_all.deb
Files: 
 4dc9825e67abdac3f4164f4910dd8d25 1074 sound optional earcandy_0.5-1.1.dsc
 bea2b26f7505889b192af48987021e37 3964 sound optional earcandy_0.5-1.1.diff.gz
 e8511c0143590b7133e8cc8858768a17 46486 sound optional earcandy_0.5-1.1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkr5c2kACgkQ2XA5inpabMdr/gCcDg1CaJJtvs9gTCeQngUMuVux
j1EAnjf83ozUetZqjoYj84D4XxLdRISa
=06X2
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 21 Dec 2009 07:40:40 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 12:32:17 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.