Debian Bug report logs - #529573
moodle: Moodle should depend on libnusoap-php instead of shipping it

version graph

Package: moodle; Maintainer for moodle is Moodle Packaging Team <pkg-moodle-maintainers@lists.alioth.debian.org>; Source for moodle is src:moodle.

Reported by: Olivier Berger <olivier.berger@it-sudparis.eu>

Date: Wed, 20 May 2009 08:30:02 UTC

Severity: normal

Found in version 1.8.2

Fixed in version moodle/1.9.8-1

Done: Xavier Oswald <xoswald@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Moodle Packaging Team <moodle-packaging@catalyst.net.nz>:
Bug#529573; Package moodle. (Wed, 20 May 2009 08:30:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Olivier Berger <olivier.berger@it-sudparis.eu>:
New Bug report received and forwarded. Copy sent to Moodle Packaging Team <moodle-packaging@catalyst.net.nz>. (Wed, 20 May 2009 08:30:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Olivier Berger <olivier.berger@it-sudparis.eu>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: moodle: Moodle should depend on libnusoap-php instead of shipping it
Date: Wed, 20 May 2009 10:21:48 +0200
Package: moodle
Version: 1.8.2
Severity: normal

FYI, libnusoap-php entered Debian (http://packages.qa.debian.org/n/nusoap.html).

A copy of nusoap is shipped in the moodle package.

The Moodle packaging should then be updated to depend on libnusoap-php instead of shipping it.

Please check if there's no version discrepency when makeing such change, which could cause problems, though.

Best regards,

P.S.: I wasn't sure this bug should be with high severity or not, as it seems to me a policy conformance problem, although I'm not sure which precise rule would apply.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'testing-proposed-updates')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-2-686 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages moodle depends on:
ii  apache2-mpm-prefork [http 2.2.11-3       Apache HTTP Server - traditional n
ii  debconf [debconf-2.0]     1.5.26         Debian configuration management sy
ii  libapache2-mod-php5       5.2.9.dfsg.1-2 server-side, HTML-embedded scripti
pn  mimetex                   <none>         (no description available)
ii  php5-cli                  5.2.9.dfsg.1-2 command-line interpreter for the p
pn  php5-curl                 <none>         (no description available)
ii  php5-gd                   5.2.9.dfsg.1-2 GD module for php5
ii  php5-mysql                5.2.9.dfsg.1-2 MySQL module for php5
ii  php5-pgsql                5.2.9.dfsg.1-2 PostgreSQL module for php5
ii  ucf                       3.0018         Update Configuration File: preserv
ii  wwwconfig-common          0.2.1          Debian web auto configuration

Versions of packages moodle recommends:
ii  mysql-server                  5.0.51a-24 MySQL database server (metapackage
ii  mysql-server-5.0 [mysql-serve 5.0.51a-24 MySQL database server binaries
ii  postgresql                    8.3.7-1    object-relational SQL database (su

moodle suggests no packages.




Information forwarded to debian-bugs-dist@lists.debian.org, Moodle Packaging Team <moodle-packaging@catalyst.net.nz>:
Bug#529573; Package moodle. (Sun, 11 Apr 2010 17:12:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Tomasz Muras <tomasz@muras.eu>:
Extra info received and forwarded to list. Copy sent to Moodle Packaging Team <moodle-packaging@catalyst.net.nz>. (Sun, 11 Apr 2010 17:12:03 GMT) Full text and rfc822 format available.

Message #10 received at 529573@bugs.debian.org (full text, mbox):

From: Tomasz Muras <tomasz@muras.eu>
To: 529573@bugs.debian.org
Subject: moodle: Moodle should depend on libnusoap-php instead of shipping it
Date: Sun, 11 Apr 2010 18:09:36 +0100
Moodle uses nusoap only if PHP version is smaller than 4 or PHP is
compiled without SOAP.
There is no need for nusoap for neither Debian squeeze or unstable -
so the library can be simply removed in the new version of the package
(it should be OK to remove it even in lenny as PHP4 is no longer
supported).


cheers,
Tomek




Reply sent to Xavier Oswald <xoswald@debian.org>:
You have taken responsibility. (Sun, 20 Jun 2010 17:21:20 GMT) Full text and rfc822 format available.

Notification sent to Olivier Berger <olivier.berger@it-sudparis.eu>:
Bug acknowledged by developer. (Sun, 20 Jun 2010 17:21:20 GMT) Full text and rfc822 format available.

Message #15 received at 529573-close@bugs.debian.org (full text, mbox):

From: Xavier Oswald <xoswald@debian.org>
To: 529573-close@bugs.debian.org
Subject: Bug#529573: fixed in moodle 1.9.8-1
Date: Sun, 20 Jun 2010 17:18:45 +0000
Source: moodle
Source-Version: 1.9.8-1

We believe that the bug you reported is fixed in the latest version of
moodle, which is due to be installed in the Debian FTP archive:

moodle_1.9.8-1.debian.tar.gz
  to main/m/moodle/moodle_1.9.8-1.debian.tar.gz
moodle_1.9.8-1.dsc
  to main/m/moodle/moodle_1.9.8-1.dsc
moodle_1.9.8-1_all.deb
  to main/m/moodle/moodle_1.9.8-1_all.deb
moodle_1.9.8.orig.tar.gz
  to main/m/moodle/moodle_1.9.8.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 529573@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Xavier Oswald <xoswald@debian.org> (supplier of updated moodle package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 20 Jun 2010 16:02:14 +0200
Source: moodle
Binary: moodle
Architecture: source all
Version: 1.9.8-1
Distribution: unstable
Urgency: low
Maintainer: Moodle Packaging Team <pkg-moodle-maintainers@lists.alioth.debian.org>
Changed-By: Xavier Oswald <xoswald@debian.org>
Description: 
 moodle     - Course Management System for Online Learning
Closes: 302205 302207 389502 475535 526543 529573 551399 551402 555672 574757 574969 576189 581229
Changes: 
 moodle (1.9.8-1) unstable; urgency=low
 .
   [Tomasz Muras]
   * New Maintainer (closes: #581229, #574969).
   * New Upstream Version (closes: #475535).
   * Added information about flvplayer to copyright (closes: #526543).
   * phpCAS XSS vulnerability fixed in mainstream Moodle 1.9.8 (closes: #574757).
   * Several security issues fixed in upstream (closes: #576189).
   * Moodle depends on postgresql or MySQL (closes: #551399).
   * Re-written to use dbconfig-common (closes: #302205).
   * Updated copyright with two new entires (closes: #526543).
   * Drop use of wwwconfig (closes: #389502).
   * Package is now not creating Apache config automatically (closes: #555672).
     It's up to the user to configure the webserver but package provides the
     templates.
   * Added "allow from localhost" (closes: #551402).
   * Asking for wwwroot during the installation (closes: #302207).
   * Removing nusoap as it's not necessary for PHP 5 (closes: #529573).
 .
   [Xavier Oswald]
   * Add myself as uploader.
   * Bump Stadards-Version to 3.8.4.
   * debian/copyright: update with DEP-5 format proposal.
   * Switch to dpkg-source 3.0 (quilt) format
 .
   [Francois Marier]
   * Bump debhelper compatibility to 7
   * Add a watch file
   * debian/control (dependencies)
     - Depend on libjs-yui instead of yui (renamed after lenny)
     - Add dependency on unzip
     - Recommend php5-xmlrpc and aspell
     - Suggest clamav
     - Demoted mimetex to recommended
   * Turn 'dbpersist' on by default in the generated config.php
   * Include whitespace warning at the end of generated config.php
   * Set the path to du, unzip and zip
   * Fix a warning with E_STRICT is turned on
Checksums-Sha1: 
 b2d23f94232b89ebb4e4764bd3f1a4eb27d6d146 1337 moodle_1.9.8-1.dsc
 a9aa0abda327ad72ee97dda6c947b313a4b8b2cb 13677111 moodle_1.9.8.orig.tar.gz
 0cb0a49deea6cc2d5eff42993237e93f7349b1bc 16083 moodle_1.9.8-1.debian.tar.gz
 68a27922946e4f9098acfd027c3e8c980d74ae71 10019954 moodle_1.9.8-1_all.deb
Checksums-Sha256: 
 73d738e21711aa47caee57a6aaf88f868d8cb1142f48a4d623501777360c3d32 1337 moodle_1.9.8-1.dsc
 702f07a060c19893a544b6310680fdbc646ec0074a5d027a1c167aa13ac36e7c 13677111 moodle_1.9.8.orig.tar.gz
 4f9663e2146438bf6776b79b3337d705e4eb874bb19f454ab466bc649f0cff61 16083 moodle_1.9.8-1.debian.tar.gz
 7fbd53da63fa089695e52e769681ce68e3b232b6551776d3c3acd8369e7ec1aa 10019954 moodle_1.9.8-1_all.deb
Files: 
 6fb46d8039407f7ed3770568f6ef452d 1337 web optional moodle_1.9.8-1.dsc
 d0fa094b29ce5bf2693e0195bdfc72f4 13677111 web optional moodle_1.9.8.orig.tar.gz
 a01eccb8fd811bed7fecd80c32fe6089 16083 web optional moodle_1.9.8-1.debian.tar.gz
 5396b88b5f4dd5e475542823f32af1d6 10019954 web optional moodle_1.9.8-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkweS1cACgkQpDDGqoi7tR4m2QCgx9+gyYR9Ps6/Ikapuf5ZQKRJ
SGsAoJWH5yK9Trt4fhl9YiXfv0HWNz0r
=4RyJ
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 19 Jul 2010 07:34:49 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 18:56:34 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.